TGLFreeType

[Properties (by Name)] [Methods (by Name)] [Events (by Name)]

Declaration

Source position: glfreetype.pas line 21

type TGLFreeType = object

  textures: pGLuint;

  list_base: GLuint;

  Height: Cardinal;

  procedure Init();

  procedure Clean;

  procedure Print();

  function TextWidth();

end;

Inheritance

TGLFreeType


TGLFreeTypeFont

[Properties (by Name)] [Methods (by Name)] [Events (by Name)]

Declaration

Source position: glfreetypefont.pas line 23

type TGLFreeTypeFont = class(TNVBaseFont)

protected

  procedure SetFlags(); override;

public

  constructor Create(); override;

  destructor Destroy; override;

  procedure Add(); override;

  function TextHeight(); override;

  function TextWidth(); override;

  procedure TextOut(); override;

end;

Inheritance

TGLFreeTypeFont
|

TNVBaseFont
|

TObject


TGLUTBitmapFont

[Properties (by Name)] [Methods (by Name)] [Events (by Name)]

Declaration

Source position: glutbitmapfont.pas line 23

type TGLUTBitmapFont = class(TNVBaseFont)

protected

  procedure SetFlags(); override;

public

  constructor Create(); override;

  destructor Destroy; override;

  procedure Add(); override;

  function TextHeight(); override;

  function TextWidth(); override;

  procedure TextOut(); override;

end;

Inheritance

TGLUTBitmapFont
|

TNVBaseFont
|

TObject


TNVBaseFont

[Properties (by Name)] [Methods (by Name)] [Events (by Name)]

Declaration

Source position: nvbasefont.pas line 14

type TNVBaseFont = class
protected
FSize: Integer;
procedure SetAngle(); virtual;
procedure SetFlags(); virtual;
public
constructor Create(); virtual; | Contructor for the base font class
procedure Add(); virtual; abstract; | Method that allows to add multiple stylized fonts
property Name: ; [r] | Font name
property Size: Integer; [r] | Font size
function TextHeight(); virtual; abstract; | Text height
function TextWidth(); virtual; abstract; | Text width
procedure TextSize(); virtual; | Text size
property Angle: Double; [rw]
property Bold: Boolean; [rw]
property Italic: Boolean; [rw]
property StrikeTrough: Boolean; [rw]
property Underline: Boolean; [rw]
procedure TextOut(); virtual; abstract;
end;

Inheritance

TNVBaseFont
|

TObject


UIContext

[Properties (by Name)] [Methods (by Name)] [Events (by Name)]

Basic UI context

Declaration

Source position: nvcontext.pas line 23

type UIContext = class(TObject)
public
constructor Create;
destructor Destroy; override;
procedure reshape(); | UI method for processing window size events
function isOnFocus; | Check if the UI is currently on Focus
public
procedure mouse(); | UI method for processing mouse events
public
procedure mouseMotion(); | UI method for processing mouse motion events
procedure keyboard(); | UI method for processing key events
procedure _begin; | UI method for entering UI processing mode
procedure _end; virtual; | UI method for leaving UI processing mode
procedure doLabel(); | UI method for drawing a static text label
public
function doButton(); | UI method for rendering and processing a push button
public
function doCheckButton(); | UI method for rendering and processing a check button
function doRadioButton(); | UI method for rendering and processing a radio button
function doHorizontalSlider(); | UI method for rendering and processing a horizontal slider
function doListItem(); | List item widget
function doListBox(); | Listbox widget
function doComboBox(); | Combobox widget
function doLineEdit(); | Line edit widget
public
procedure beginGroup(); | Begin grouping section of UI objects
public
procedure endGroup;
procedure beginFrame(); | Frame positioning section
procedure endFrame; | Frame positioning widget
function beginPanel(); | Panel positioning widget
procedure endPanel; | Panel positioning widget
function getGroupWidth;
function getGroupHeight;
function getCursorX;
function getCursorY;
function getMouseState();
procedure doTextureView(); | UI method for drawing a texture view
protected
function window;
protected
function placeRect();
published
property Painter: UIPainter; [rw]
protected
m_groupIndex: Integer;
m_groupStack: ;
m_window: Rect;
m_currentCursor: Point;
m_mouseButton: ;
m_keyBuffer: ;
m_nbKeys: Integer;
m_focusCaretPos: Integer;
m_focusPoint: Point;
m_twoStepFocus: Boolean;
m_uiOnFocus: Boolean;
end;

Inheritance

UIContext

Basic UI context
|

TObject


GLUIPainter

[Properties (by Name)] [Methods (by Name)] [Events (by Name)]

OpenGL painter class

Declaration

Source position: nvglpainter.pas line 125

type GLUIPainter = class(UIPainter)
public
constructor Create;
destructor Destroy; override;
procedure _begin(); override;
procedure _end; override;
public
procedure drawFrame(); | Draw frame primitive
public
function getLabelRect(); override;
procedure drawLabel(); override;
function getButtonRect(); override;
procedure drawButton(); override;
function getCheckRect(); override;
procedure drawCheckButton(); override;
function getRadioRect(); override;
procedure drawRadioButton(); override;
function getHorizontalSliderRect(); override;
procedure drawHorizontalSlider(); override;
function getItemRect(); override;
procedure drawListItem(); override;
function getListRect(); override;
procedure drawListBox(); override;
function getComboRect(); override;
function getComboOptionsRect(); override;
procedure drawComboBox(); override;
procedure drawComboOptions(); override;
function getLineEditRect(); override;
procedure drawLineEdit(); override;
function getPanelRect(); override;
procedure drawPanel(); override;
function getTextureViewRect(); override;
procedure drawTextureView(); override;
function getCanvasMargin; override; | Evaluate canvas margin
function getCanvasSpace; override; | Evaluate canvas space
function getFontHeight; override; | Evaluate font height
function getTextLineWidth(); override; | Evaluate text width
function getTextSize(); override; | Evaluate text size
function getTextLineWidthAt();
function getPickedCharNb(); override;
procedure drawDebugRect(); override; | Draw a rectangle for debugging purposes
procedure drawText(); | Draw text with rectangle primitive
procedure drawBoolFrame(); | Draw bool frame primitive
procedure drawString(); | Draw multi-line text primitive
procedure drawRect(); | Draw rectangle primitive
procedure drawRoundedRect(); | Draw rouded rectangle primitive
procedure drawRoundedRectOutline(); | Draw rouded rectangle outline primitive
procedure drawCircle(); | Draw circle primitive
procedure drawMinus(); | Draw minus primitive
procedure drawPlus(); | Draw plus primitive
procedure drawDownArrow(); | Draw down arrow primitive
procedure drawUpArrow(); | Draw up arrow primitive
procedure init; override; | Initialization method of the painter class
end;

Inheritance

GLUIPainter | OpenGL painter class
|
UIPainter | Basic painter class
|
TObject


GlutUIContext

[Properties (by Name)] [Methods (by Name)] [Events (by Name)]

GLut specific UI context

Declaration

Source position: nvglutcontext.pas line 27

type GlutUIContext = class(UIContext)
public
function init(); | One time initialization
public
procedure mouse(); | UI method for processing GLUT mouse button events
public
procedure specialKeyboard(); | UI method for processing key events
end;

Inheritance

GlutUIContext | GLut specific UI context
|
UIContext | Basic UI context
|
TObject


UIPainter

[Properties (by Name)] [Methods (by Name)] [Events (by Name)]

Basic painter class

Declaration

Source position: nvpainter.pas line 21

type UIPainter = class(TObject)

public

  constructor Create;

  procedure _begin(); virtual;

  procedure _end; virtual;

  procedure drawFrame(); virtual; abstract;

  function getLabelRect(); virtual; abstract;

  procedure drawLabel(); virtual; abstract;

  function getButtonRect(); virtual; abstract;

  procedure drawButton(); virtual; abstract;

  function getCheckRect(); virtual; abstract;

  procedure drawCheckButton(); virtual; abstract;

  function getRadioRect(); virtual; abstract;

  procedure drawRadioButton(); virtual; abstract;

  function getHorizontalSliderRect(); virtual; abstract;

  procedure drawHorizontalSlider(); virtual; abstract;

  function getItemRect(); virtual; abstract;

  procedure drawListItem(); virtual; abstract;

  function getListRect(); virtual; abstract;

  procedure drawListBox(); virtual; abstract;

  function getComboRect(); virtual; abstract;

  function getComboOptionsRect(); virtual; abstract;

  procedure drawComboBox(); virtual; abstract;

  procedure drawComboOptions(); virtual; abstract;

  function getLineEditRect(); virtual; abstract;

  procedure drawLineEdit(); virtual; abstract;

  function getPanelRect(); virtual; abstract;

  procedure drawPanel(); virtual; abstract;

  function getTextureViewRect(); virtual; abstract;

  procedure drawTextureView(); virtual; abstract;

  function getCanvasMargin; virtual;

  function getCanvasSpace; virtual;

  function getFontHeight; virtual;

  function getTextLineWidth(); virtual;

  function getTextSize(); virtual;

  function getPickedCharNb(); virtual;

  procedure drawDebugRect(); virtual; abstract;

  procedure init; virtual; abstract;

published

  property Font: TnvBaseFont; [rw]

end;

Inheritance

UIPainter

Basic painter class
|

TObject


Point

[Properties (by Name)] [Methods (by Name)] [Events (by Name)]

2D point object

Declaration

Source position: nvtypes.pas line 14

type Point = object
x: Integer; | X location
y: Integer; | Y location
procedure Point(); | Constructor for the Point object
end;

Inheritance

Point

2D point object


Rect

[Properties (by Name)] [Methods (by Name)] [Events (by Name)]

Rectangle object

Declaration

Source position: nvtypes.pas line 27

type Rect = object
x: Integer; | X position of top left point
y: Integer; | Y position of top left point
w: Integer; | Width of rectangle
h: Integer; | Height of rectangle
procedure Rect(); | Constructor for the Rect object
end;

Inheritance

Rect

Rectangle object


EvalBool

Boolean evaluation function

Declaration

Source position: nvpainter.pas line 85

function EvalBool(

  b: Boolean

):Byte;

Description

This function evaluates a boolean to a numerical value.

True equals 1 False equals 0


CompileASMShader

Declaration

Source position: nvshaderutils.pas line 22

function CompileASMShader(

  program_type: GLenum;

  code:

):GLuint;


CompileASMShaderFromFile

Declaration

Source position: nvshaderutils.pas line 23

function CompileASMShaderFromFile(

  target: GLenum;

  filename:

):GLuint;


CompileGLSLShader

Declaration

Source position: nvshaderutils.pas line 18

function CompileGLSLShader(

  target: GLenum;

  shader:

):GLuint;


CompileGLSLShaderFromFile

Declaration

Source position: nvshaderutils.pas line 19

function CompileGLSLShaderFromFile(

  target: GLenum;

  filename:

):GLuint;


LinkGLSLProgram

Create a program composed of vertex, geometry and fragment shaders.

Declaration

Source position: line 0

function LinkGLSLProgram(

  vertexShader: GLuint;

  fragmentShader: GLuint

):GLuint;

function LinkGLSLProgram(

  vertexShader: GLuint;

  geometryShader: GLuint;

  inputType: GLint;

  vertexOut: GLint;

  outputType: GLint;

  fragmentShader: GLuint

):GLuint;


SetPoint

Helper function to initialize the point object

Declaration

Source position: nvtypes.pas line 22

function SetPoint(

  x: Integer;

  y: Integer

):Point;

Function result

Initialize the point object


SetRect

Helper function to initialize the Rect object

Declaration

Source position: line 0

function SetRect(

  x: Integer;

  y: Integer

):Rect;

function SetRect(

  x: Integer;

  y: Integer;

  w: Integer;

  h: Integer

):Rect;


Reference for package 'nvidia-widgets'

NVIDIA widget library

Units

GLFreeType | Free Type support for OpenGL
GLFreeTypeFont
GLUTBitmapFont | GLUT bitmap font
nvBaseFont | Generic font support class
nvContext | User Interface library
nvGLPainter | User Interface library specialized for OpenGL
nvGlutContext | GLut adaptor class
nvPainter | Basic painter class
nvShaderUtils | Utility functions for compiling shaders and programs
nvTypes | Base types and constants

Description

This library is originally based on the NVIDIA widget library. NVIDIA Widgets is the immediate mode graphical user interface toolkit used by the NVIDIA SDK samples.

Originally ported to FPC by Darius Blaszyk in June 2011.

This library is distributed under the MIT license, as the original library was.

The original code can be found here: http://code.google.com/p/nvidia-widgets/

nvidia-widgets class chart
nvidia-widgets class chart

For more information see the Lazarus wiki.


Index of all identifiers in package 'nvidia-widgets'

B C E G K L M N P R S T U

B

ButtonFlags_Alt | ButtonFlags_End | ButtonFlags_Shift
ButtonFlags_Begin | ButtonFlags_Off | ButtonState
ButtonFlags_Ctrl | ButtonFlags_On |

C

cBase | CompileASMShader | cTexViewWidgetFSSource
cBool | CompileASMShaderFromFile | cTranslucent
cFont | CompileGLSLShader | cWidgetFSSource
cFontBack | CompileGLSLShaderFromFile | cWidgetVSSource
cNbColors | cOutline |

E

EvalBool

G

GLFreeType | GroupFlags_GrowDownFromLeft | GroupFlags_LayoutMask
GLFreeTypeFont | GroupFlags_GrowDownFromRight | GroupFlags_LayoutNoMargin
GLUIPainter | GroupFlags_GrowLeftFromBottom | GroupFlags_LayoutNone
GLUTBitmapFont | GroupFlags_GrowLeftFromTop | GroupFlags_LayoutNoSpace
GlutUIContext | GroupFlags_GrowRightFromBottom | GroupFlags_LayoutVertical
Group | GroupFlags_GrowRightFromTop | GroupFlags_LayoutXMask
GroupFlags_AlignBottom | GroupFlags_GrowUpFromLeft | GroupFlags_StartBottom
GroupFlags_AlignLeft | GroupFlags_GrowUpFromRight | GroupFlags_StartLeft
GroupFlags_AlignMask | GroupFlags_LayoutDefault | GroupFlags_StartMask
GroupFlags_AlignRight | GroupFlags_LayoutDefaultFallback | GroupFlags_StartRight
GroupFlags_AlignTop | GroupFlags_LayoutForce | GroupFlags_StartTop
GroupFlags_AlignXMask | GroupFlags_LayoutHorizontal | GroupFlags_StartXMask

K

Key_Down | Key_F3 | Key_Home
Key_End | Key_F4 | Key_Insert
Key_F1 | Key_F5 | Key_Left
Key_F10 | Key_F6 | Key_PageDown
Key_F11 | Key_F7 | Key_PageUp
Key_F12 | Key_F8 | Key_Right
Key_F2 | Key_F9 | Key_Up

L

LinkGLSLProgram

M

MouseButton_Left MouseButton_Middle MouseButton_Right

N

nvBaseFont | nvGlutContext | nvTypes
nvContext | nvPainter |
nvGLPainter | nvShaderUtils |

P

PGroup Point

R

Rect

S

s_colors SetPoint SetRect

T

TFontStyles | TGLFreeType | TGLUTBitmapFont
TFontStyles | TGLFreeTypeFont | TNVBaseFont

U

UIContext UIPainter


Reference for unit 'GLFreeType'

Free Type support for OpenGL

uses

  System,

  SysUtils,

  freetypeh,

  GL,

  GLu;


[Overview][Classes][Index] Reference for unit 'GLFreeType' (#nvidia-widgets)

Reference for unit 'GLFreeType': Classes

TGLFreeType


[Overview][Classes][Index] Reference for unit 'GLFreeType' (#nvidia-widgets)

Index of all identifiers in unit 'GLFreeType'

T

T

TGLFreeType


TGLFreeType


TGLFreeType
 | Init
 | Clean
 | Print
 | TextWidth


Clean (TGLFreeType)

Init (TGLFreeType)

Print (TGLFreeType)

TextWidth (TGLFreeType)


TGLFreeType.Clean

Declaration

Source position: glfreetype.pas line 31

procedure TGLFreeType.Clean;


TGLFreeType.Height

Declaration

Source position: glfreetype.pas line 24

TGLFreeType.Height: Cardinal;


TGLFreeType.Init

Declaration

Source position: glfreetype.pas line 28

procedure TGLFreeType.Init(

  const fname: ;

  AHeight: Cardinal

);


TGLFreeType.list_base

Declaration

Source position: glfreetype.pas line 23

TGLFreeType.list_base: GLuint;


TGLFreeType.Print

Declaration

Source position: glfreetype.pas line 36

procedure TGLFreeType.Print(

  x: Double;

  y: Double;

  Text:

);


TGLFreeType.textures

Declaration

Source position: glfreetype.pas line 22

TGLFreeType.textures: pGLuint;


TGLFreeType.TextWidth

Declaration

Source position: glfreetype.pas line 38

function TGLFreeType.TextWidth(

  const Text:

):Integer;


Reference for unit 'GLFreeTypeFont'

uses
System,
SysUtils,
GLFreeType, | Free Type support for OpenGL
nvBaseFont; | Generic font support class


[Overview][Types][Classes][Index] Reference for unit 'GLFreeTypeFont' (#nvidia-widgets)

Reference for unit 'GLFreeTypeFont': Types

TFontStyles


[Overview][Types][Classes][Index] Reference for unit 'GLFreeTypeFont' (#nvidia-widgets)

Reference for unit 'GLFreeTypeFont': Classes

TGLFreeTypeFont


[Overview][Types][Classes][Index] Reference for unit 'GLFreeTypeFont' (#nvidia-widgets)

Index of all identifiers in unit 'GLFreeTypeFont'

T

T

TFontStyles TGLFreeTypeFont


TFontStyles

Declaration

Source position: glfreetypefont.pas line 12

type TFontStyles = record

  Name: ;

  Bold: Boolean;

  Italic: Boolean;

  StrikeTrough: Boolean;

  Underline: Boolean;

  Font: TGLFreeType;

end;


TGLFreeTypeFont
TNVBaseFont
 | ro | Name
 | ro | Size
 |  | Angle
 |  | Bold
 |  | Italic
 |  | StrikeTrough
 |  | Underline


ro | Name (TNVBaseFont)
ro |


TGLFreeTypeFont
pt | SetFlags
 | Create
 | Destroy
 | Add
 | TextHeight
 | TextWidth
 | TextOut
TNVBaseFont
pt | SetAngle
pt | SetFlags
 | Create
 | Add
 | TextHeight
 | TextWidth
 | TextSize
 | TextOut


 | Add (TNVBaseFont)
 | Add (TGLFreeTypeFont)
 | Create (TNVBaseFont)
 | Create (TGLFreeTypeFont)
 | Destroy (TGLFreeTypeFont)
pt | SetAngle (TNVBaseFont)
pt | SetFlags (TNVBaseFont)
pt | SetFlags (TGLFreeTypeFont)
 | TextHeight (TNVBaseFont)
 | TextHeight (TGLFreeTypeFont)
 | TextOut (TNVBaseFont)
 | TextOut (TGLFreeTypeFont)
 | TextSize (TNVBaseFont)
 | TextWidth (TNVBaseFont)
 | TextWidth (TGLFreeTypeFont)


TGLFreeTypeFont

TNVBaseFont


TGLFreeTypeFont.Destroy

Declaration

Source position: glfreetypefont.pas line 33

public destructor TGLFreeTypeFont.Destroy; override;


TGLFreeTypeFont.SetFlags

Declaration

Source position: glfreetypefont.pas line 30

protected procedure TGLFreeTypeFont.SetFlags(

  AIndex: Integer;

  AValue: Boolean

); override;


TGLFreeTypeFont.TextOut

Declaration

Source position: glfreetypefont.pas line 43

public procedure TGLFreeTypeFont.TextOut(

  x: Double;

  y: Double;

  Text:

); override;


Reference for unit 'GLUTBitmapFont'

GLUT bitmap font

uses

  System,

  Classes,

  SysUtils,

  GL,

  GLut,

  nvBaseFont;

Generic font support class


[Overview][Types][Classes][Index] Reference for unit 'GLUTBitmapFont' (#nvidia-widgets)

Reference for unit 'GLUTBitmapFont': Types

TFontStyles


[Overview][Types][Classes][Index] Reference for unit 'GLUTBitmapFont' (#nvidia-widgets)

Reference for unit 'GLUTBitmapFont': Classes

TGLUTBitmapFont


[Overview][Types][Classes][Index] Reference for unit 'GLUTBitmapFont' (#nvidia-widgets)

Index of all identifiers in unit 'GLUTBitmapFont'

T

T

TFontStyles TGLUTBitmapFont


TFontStyles

Declaration

Source position: glutbitmapfont.pas line 11

type TFontStyles = record

  Name: ;

  Bold: Boolean;

  Italic: Boolean;

  StrikeTrough: Boolean;

  Underline: Boolean;

  Font: pointer;

  TextListBase: Integer;

end;


TGLUTBitmapFont
TNVBaseFont
 | ro | Name
 | ro | Size
 |  | Angle
 |  | Bold
 |  | Italic
 |  | StrikeTrough
 |  | Underline


TGLUTBitmapFont
pt | SetFlags
 | Create
 | Destroy
 | Add
 | TextHeight
 | TextWidth
 | TextOut
TNVBaseFont
pt | SetAngle
pt | SetFlags
 | Create
 | Add
 | TextHeight
 | TextWidth
 | TextSize
 | TextOut


 | Add (TNVBaseFont)
 | Add (TGLUTBitmapFont)
 | Create (TNVBaseFont)
 | Create (TGLUTBitmapFont)
 | Destroy (TGLUTBitmapFont)
pt | SetAngle (TNVBaseFont)
pt | SetFlags (TNVBaseFont)
pt | SetFlags (TGLUTBitmapFont)
 | TextHeight (TNVBaseFont)
 | TextHeight (TGLUTBitmapFont)
 | TextOut (TNVBaseFont)
 | TextOut (TGLUTBitmapFont)
 | TextSize (TNVBaseFont)
 | TextWidth (TNVBaseFont)
 | TextWidth (TGLUTBitmapFont)


TGLUTBitmapFont

TNVBaseFont


TGLUTBitmapFont.Destroy

Declaration

Source position: glutbitmapfont.pas line 34

public destructor TGLUTBitmapFont.Destroy; override;


TGLUTBitmapFont.SetFlags

Declaration

Source position: glutbitmapfont.pas line 31

protected procedure TGLUTBitmapFont.SetFlags(

  AIndex: Integer;

  AValue: Boolean

); override;


TGLUTBitmapFont.TextOut

Declaration

Source position: glutbitmapfont.pas line 44

public procedure TGLUTBitmapFont.TextOut(

  x: Double;

  y: Double;

  Text:

); override;


Reference for unit 'nvBaseFont'

Generic font support class

uses

  System,

  fpimage;


[Overview][Classes][Index] Reference for unit 'nvBaseFont' (#nvidia-widgets)

Reference for unit 'nvBaseFont': Classes

TNVBaseFont


[Overview][Classes][Index] Reference for unit 'nvBaseFont' (#nvidia-widgets)

Index of all identifiers in unit 'nvBaseFont'

T

T

TNVBaseFont


TNVBaseFont
 | ro | Name
 | ro | Size
 |  | Angle
 |  | Bold
 |  | Italic
 |  | StrikeTrough
 |  | Underline


TNVBaseFont
pt | SetAngle
pt | SetFlags
 | Create
 | Add
 | TextHeight
 | TextWidth
 | TextSize
 | TextOut


pt | SetAngle (TNVBaseFont)
pt | SetFlags (TNVBaseFont)
 | TextHeight (TNVBaseFont)
 | TextOut (TNVBaseFont)
 | TextSize (TNVBaseFont)
 | TextWidth (TNVBaseFont)


TNVBaseFont


TNVBaseFont.Add

Method that allows to add multiple stylized fonts

Declaration

Source position: nvbasefont.pas line 30

public procedure TNVBaseFont.Add(

  AName: ;

  ABold: Boolean;

  AItalic: Boolean;

  AStrikeTrough: Boolean;

  AUnderline: Boolean

); virtual; abstract;

Description

To define font styles, you will need to add the fonts first. This method allows to add a named font style and set the styles of it.


TNVBaseFont.Angle

Declaration

Source position: nvbasefont.pas line 42

public property TNVBaseFont.Angle: Double
  read FAngle
  write SetAngle;


TNVBaseFont.Bold

Declaration

Source position: nvbasefont.pas line 43

public property TNVBaseFont.Bold: Boolean
  index 1
  read GetFlags
  write SetFlags;


TNVBaseFont.Create

Contructor for the base font class

Declaration

Source position: nvbasefont.pas line 27

public constructor TNVBaseFont.Create(

  AName: ;

  ASize: Integer

); virtual;


TNVBaseFont.FSize

Declaration

Source position: nvbasefont.pas line 22

protected TNVBaseFont.FSize: Integer;


TNVBaseFont.Italic

Declaration

Source position: nvbasefont.pas line 44

public property TNVBaseFont.Italic: Boolean
  index 2
  read GetFlags
  write SetFlags;


TNVBaseFont.Name

Font name

Declaration

Source position: nvbasefont.pas line 33

public property TNVBaseFont.Name:
  read FName;


TNVBaseFont.SetAngle

Declaration

Source position: nvbasefont.pas line 24

protected procedure TNVBaseFont.SetAngle(

  AValue: Double

); virtual;


TNVBaseFont.SetFlags

Declaration

Source position: nvbasefont.pas line 25

protected procedure TNVBaseFont.SetFlags(

  AIndex: Integer;

  AValue: Boolean

); virtual;


TNVBaseFont.Size

Font size

Declaration

Source position: nvbasefont.pas line 34

public property TNVBaseFont.Size: Integer
  read FSize;


TNVBaseFont.StrikeTrough

Declaration

Source position: nvbasefont.pas line 45

public property TNVBaseFont.StrikeTrough: Boolean
  index 3
  read GetFlags
  write SetFlags;


TNVBaseFont.TextHeight

Text height

Declaration

Source position: nvbasefont.pas line 37

public function TNVBaseFont.TextHeight(

  Text:

):Integer; virtual; abstract;

Description

Some fonts will only return the font size and not the actual text height


TNVBaseFont.TextOut

Declaration

Source position: nvbasefont.pas line 49

public procedure TNVBaseFont.TextOut(

  x: Double;

  y: Double;

  Text:

); virtual; abstract;


TNVBaseFont.TextSize

Text size

Declaration

Source position: nvbasefont.pas line 39

public procedure TNVBaseFont.TextSize(

  Text: ;

  var w: Integer;

  var h: Integer

); virtual;


TNVBaseFont.TextWidth

Text width

Declaration

Source position: nvbasefont.pas line 38

public function TNVBaseFont.TextWidth(

  Text:

):Integer; virtual; abstract;


TNVBaseFont.Underline

Declaration

Source position: nvbasefont.pas line 46

public property TNVBaseFont.Underline: Boolean
  index 4
  read GetFlags
  write SetFlags;


Reference for unit 'nvContext'

User Interface library

uses
System,
Classes,
SysUtils,
nvTypes, | Base types and constants
nvPainter; | Basic painter class


[Overview][Classes][Index] Reference for unit 'nvContext' (#nvidia-widgets)

Reference for unit 'nvContext': Classes

UIContext

Basic UI context


[Overview][Classes][Index] Reference for unit 'nvContext' (#nvidia-widgets)

Index of all identifiers in unit 'nvContext'

U

U

UIContext


UIContext

pl

Painter


pl


UIContext
 | Create
 | Destroy
 | reshape
 | isOnFocus
 | mouse
 | mouseMotion
 | keyboard
 | _begin
 | _end
 | doLabel
 | doButton
 | doCheckButton
 | doRadioButton
 | doHorizontalSlider
 | doListItem
 | doListBox
 | doComboBox
 | doLineEdit
 | beginGroup
 | endGroup
 | beginFrame
 | endFrame
 | beginPanel
 | endPanel
 | getGroupWidth
 | getGroupHeight
 | getCursorX
 | getCursorY
 | getMouseState
 | doTextureView
pt | window
pt | placeRect


 | beginFrame (UIContext)
 | beginGroup (UIContext)
 | beginPanel (UIContext)
 | Create (UIContext)
 | Destroy (UIContext)
 | doButton (UIContext)
 | doCheckButton (UIContext)
 | doComboBox (UIContext)
 | doHorizontalSlider (UIContext)
 | doLabel (UIContext)
 | doLineEdit (UIContext)
 | doListBox (UIContext)
 | doListItem (UIContext)
 | doRadioButton (UIContext)
 | doTextureView (UIContext)
 | endFrame (UIContext)
 | endGroup (UIContext)
 | endPanel (UIContext)
 | getCursorX (UIContext)
 | getCursorY (UIContext)
 | getGroupHeight (UIContext)
 | getGroupWidth (UIContext)
 | getMouseState (UIContext)
 | isOnFocus (UIContext)
 | keyboard (UIContext)
 | mouse (UIContext)
 | mouseMotion (UIContext)
pt | placeRect (UIContext)
 | reshape (UIContext)
pt |


UIContext


UIContext._begin

UI method for entering UI processing mode

Declaration

Source position: nvcontext.pas line 58

public procedure UIContext._begin;

Description

This function must be used to begin the UI processing


UIContext._end

UI method for leaving UI processing mode

Declaration

Source position: nvcontext.pas line 64

public procedure UIContext._end; virtual;

Description

This function must be used to end the UI processing


UIContext.beginFrame

Frame positioning section

Declaration

Source position: nvcontext.pas line 157

public procedure UIContext.beginFrame(

  groupFlags: Integer = GroupFlags_LayoutDefault;

  const rect: Rect = 0;

  style: Integer = 0

);

Description


UIContext.beginGroup

Begin grouping section of UI objects

Declaration

Source position: line 0

procedure UIContext.beginGroup(

  groupFlags: Integer;

  const r: Rect

); overload;

procedure UIContext.beginGroup(

  groupFlags: Integer = GroupFlags_LayoutDefault

); overload;


UIContext.beginPanel

Panel positioning widget

Declaration

Source position: nvcontext.pas line 160

public function UIContext.beginPanel(

  var r: Rect;

  const Text: ;

  var isUnfold: Boolean;

  groupFlags: Integer = GroupFlags_LayoutDefault;

  style: Integer = 0

):Boolean;

Description


UIContext.Create

Declaration

Source position: nvcontext.pas line 25

public constructor UIContext.Create;


UIContext.Destroy

Declaration

Source position: nvcontext.pas line 26

public destructor UIContext.Destroy; override;


UIContext.doButton

UI method for rendering and processing a push button

Declaration

Source position: line 0

function UIContext.doButton(

  const r: Rect;

  const Text: ;

  var state: Boolean;

  style: Integer = 0

):Boolean;

function UIContext.doButton(

  const r: Rect;

  const Text:

):Boolean;

Arguments

r | optionally provides a location and size for the button
Text | text to display on the button
state | whether the button is depressed
style | optional style flag to modify the look

Arguments

r | optionally provides a location and size for the button
Text | text to display on the button

Description

The button method does only take a text and state variable. This variable is modified if the button is pressed or depressed. When a state change occurs the method function returns True.

Example code how to implement a button

none.Rect(0, 0);
ui.beginGroup(GroupFlags_GrowDownFromRight);
  if ui.doButton(none, 'Apply') then
  begin
    //code to apply your changes
  end;
ui.endGroup;


UIContext.doCheckButton

UI method for rendering and processing a check button

Declaration

Source position: nvcontext.pas line 111

public function UIContext.doCheckButton(

  const r: Rect;

  const Text: ;

  var state: Boolean;

  style: Integer = 0

):Boolean;

Arguments

r | optionally provides a location and size for the button
Text | text to display on the button
state | whether the check button is checked or not
style | optional style flag to modify the look

Function result

True if the check button state changed

Description

Check button behaves similarly as a toggle button used to display and edit a boolean property.


UIContext.doComboBox

Combobox widget

Declaration

Source position: nvcontext.pas line 149

public function UIContext.doComboBox(

  const aRect: Rect;

  numOptions: Integer;

  const options: array of ;

  var selected: Integer;

  style: Integer = 0

):Boolean;

Description


UIContext.doHorizontalSlider

UI method for rendering and processing a horizontal slider

Declaration

Source position: nvcontext.pas line 145

public function UIContext.doHorizontalSlider(

  const aRect: Rect;

  min: Double;

  max: Double;

  var Value: Double;

  style: Integer = 0

):Boolean;

Arguments

aRect | optionally provides a location and size for the widget
min | min bound of the varying range of the value
max | max bound of the varying range of the value
Value | the value edited by the widget
style | optional style flag to modify the look

Function result

True if the slider value changed

Description

Horizontal slider is used to edit and display a scalar value in the specified range [min; max].


UIContext.doLabel

UI method for drawing a static text label

Declaration

Source position: nvcontext.pas line 82

public procedure UIContext.doLabel(

  const r: Rect;

  const Text: ;

  style: Integer = 0

);

Arguments

r | optionally provides a location and size for the label
Text | Text to display for the label (can have several lines)
style | optional style flag to modify the look

Description

The label displays a non interactive text.

The style flag enables to draw the label in two distinct styles. The first one is default (style = 0) and displays the label simply as text. The alternative (style = 1) displays the label with a frame around it. An example is shown in the following figure.

The Text variable can have multiple lines.

Example code how to implement a label

none.Rect(0, 0);
ui.beginGroup(GroupFlags_GrowDownFromRight);
  ui.doLabel(none, Text);
ui.endGroup;


UIContext.doLineEdit

Line edit widget

Declaration

Source position: nvcontext.pas line 151

public function UIContext.doLineEdit(

  const aRect: Rect;

  var Text: ;

  maxTextLength: Integer;

  out nbCharsReturned: Integer;

  style: Integer = 0

):Boolean;

Description


UIContext.doListBox

Listbox widget

Declaration

Source position: nvcontext.pas line 148

public function UIContext.doListBox(

  const aRect: Rect;

  numOptions: Integer;

  const options: array of ;

  var selected: Integer;

  style: Integer = 0

):Boolean;

Description


UIContext.doListItem

List item widget

Declaration

Source position: nvcontext.pas line 147

public function UIContext.doListItem(

  index: Integer;

  const aRect: Rect;

  const Text: ;

  selected: Integer;

  style: Integer = 0

):Boolean;

Description


UIContext.doRadioButton

UI method for rendering and processing a radio button

Declaration

Source position: nvcontext.pas line 130

public function UIContext.doRadioButton(

  reference: Integer;

  const r: Rect;

  const Text: ;

  var Value: Integer;

  style: Integer = 0

):Boolean;

Arguments

reference | The reference int value represented by this radio button.
r | optionally provides a location and size for the button
Text | text to display on the button
Value | The value parameter compared to the reference value parameter.
style | optional style flag to modify the look

Function result

True if the radio button value changed

Description

Radio buttons are typically used in groups to display and edit the possible reference values taken by an integer value.

One radio button is representing a possible reference value taken by the current value. It is displaying a boolean state true if the current value is equal to the reference value.


UIContext.doTextureView

UI method for drawing a texture view

Declaration

Source position: nvcontext.pas line 186

public procedure UIContext.doTextureView(

  const aRect: Rect;

  const texID: Integer;

  zoomRect: Rect;

  mipLevel: Integer = -1;

  texelScale: Double = 1;

  texelOffset: Double = 0;

  red: Integer = 0;

  green: Integer = 1;

  blue: Integer = 2;

  alpha: Integer = 3;

  style: Integer = 0

);

Arguments

aRect | provides a location and size for the texture view
texID | texture identifier (Graphics API specific)
zoomRect | rectangle area of the texture displayed
mipLevel | mip Level of the texture displayed
texelScale | scale applied to the texel fetch
texelOffset | offset applied to the texel after scale
style | optional style flag to modify the look

Description

Several parameters control the equation used to display the texel

texel = texture2DFetch(...);
pixel = texelSwizzling( texel * texelScale + texelOffset );


UIContext.endFrame

Frame positioning widget

Declaration

Source position: nvcontext.pas line 158

public procedure UIContext.endFrame;

Description


UIContext.endGroup

Declaration

Source position: nvcontext.pas line 155

public procedure UIContext.endGroup;


UIContext.endPanel

Panel positioning widget

Declaration

Source position: nvcontext.pas line 161

public procedure UIContext.endPanel;

Description


UIContext.getCursorX

Declaration

Source position: nvcontext.pas line 166

public function UIContext.getCursorX: Integer;


UIContext.getCursorY

Declaration

Source position: nvcontext.pas line 167

public function UIContext.getCursorY: Integer;


UIContext.getGroupHeight

Declaration

Source position: nvcontext.pas line 164

public function UIContext.getGroupHeight: Integer;


UIContext.getGroupWidth

Declaration

Source position: nvcontext.pas line 163

public function UIContext.getGroupWidth: Integer;


UIContext.getMouseState

Declaration

Source position: nvcontext.pas line 169

public function UIContext.getMouseState(

  button: Integer

):ButtonState;


UIContext.isOnFocus

Check if the UI is currently on Focus

Declaration

Source position: nvcontext.pas line 35

public function UIContext.isOnFocus: Boolean;


UIContext.keyboard

UI method for processing key events

Declaration

Source position: nvcontext.pas line 51

public procedure UIContext.keyboard(

  k: Byte;

  x: Integer;

  y: Integer

);


UIContext.m_currentCursor

Declaration

Source position: nvcontext.pas line 212

protected UIContext.m_currentCursor: Point;


UIContext.m_focusCaretPos

Declaration

Source position: nvcontext.pas line 217

protected UIContext.m_focusCaretPos: Integer;


UIContext.m_focusPoint

Declaration

Source position: nvcontext.pas line 218

protected UIContext.m_focusPoint: Point;


UIContext.m_groupIndex

Declaration

Source position: nvcontext.pas line 207

protected UIContext.m_groupIndex: Integer;


UIContext.m_groupStack

Declaration

Source position: nvcontext.pas line 208

protected UIContext.m_groupStack: array [0..63] of Group;


UIContext.m_keyBuffer

Declaration

Source position: nvcontext.pas line 214

protected UIContext.m_keyBuffer: array [0..31] of Byte;


UIContext.m_mouseButton

Declaration

Source position: nvcontext.pas line 213

protected UIContext.m_mouseButton: array [0..2] of ButtonState;


UIContext.m_nbKeys

Declaration

Source position: nvcontext.pas line 215

protected UIContext.m_nbKeys: Integer;


UIContext.m_twoStepFocus

Declaration

Source position: nvcontext.pas line 219

protected UIContext.m_twoStepFocus: Boolean;


UIContext.m_uiOnFocus

Declaration

Source position: nvcontext.pas line 220

protected UIContext.m_uiOnFocus: Boolean;


UIContext.m_window

Declaration

Source position: nvcontext.pas line 210

protected UIContext.m_window: Rect;


UIContext.mouse

UI method for processing mouse events

Declaration

Source position: line 0

procedure UIContext.mouse(

  button: Integer;

  state: Integer;

  modifier: Integer;

  x: Integer;

  y: Integer

);

procedure UIContext.mouse(

  button: Integer;

  state: Integer;

  x: Integer;

  y: Integer

);


UIContext.mouseMotion

UI method for processing mouse motion events

Declaration

Source position: nvcontext.pas line 46

public procedure UIContext.mouseMotion(

  x: Integer;

  y: Integer

);


UIContext.Painter

Declaration

Source position: nvcontext.pas line 204

published property UIContext.Painter: UIPainter
  read FPainter
  write SetPainter;


UIContext.placeRect

Declaration

Source position: nvcontext.pas line 201

protected function UIContext.placeRect(

  const r: Rect

):Rect;


UIContext.reshape

UI method for processing window size events

Declaration

Source position: nvcontext.pas line 30

public procedure UIContext.reshape(

  w: Integer;

  h: Integer

);


UIContext.window

Declaration

Source position: nvcontext.pas line 189

protected function UIContext.window: Rect;


[Overview][Constants][Classes][Index] Reference for unit 'nvGLPainter' (#nvidia-widgets)

cBase

Declaration

Source position: nvglpainter.pas line 21

const cBase = 0;


[Overview][Constants][Classes][Index] Reference for unit 'nvGLPainter' (#nvidia-widgets)

cBool

Declaration

Source position: nvglpainter.pas line 22

const cBool = 4;


[Overview][Constants][Classes][Index] Reference for unit 'nvGLPainter' (#nvidia-widgets)

cFont

Declaration

Source position: nvglpainter.pas line 24

const cFont = 12;


[Overview][Constants][Classes][Index] Reference for unit 'nvGLPainter' (#nvidia-widgets)

cFontBack

Declaration

Source position: nvglpainter.pas line 25

const cFontBack = 16;


[Overview][Constants][Classes][Index] Reference for unit 'nvGLPainter' (#nvidia-widgets)

cNbColors

Declaration

Source position: nvglpainter.pas line 27

const cNbColors = 24;


[Overview][Constants][Classes][Index] Reference for unit 'nvGLPainter' (#nvidia-widgets)

cOutline

Declaration

Source position: nvglpainter.pas line 23

const cOutline = 8;


cTexViewWidgetFSSource

Declaration

Source position: nvglpainter.pas line 98

const cTexViewWidgetFSSource = '#version 120' + LineEnding + 'uniform float mipLevel /*= 0*/;' + LineEnding + 'uniform float texelScale /*= 1.0*/;' + LineEnding + 'uniform float texelOffset /*= 0.0*/;' + LineEnding + 'uniform ivec4 texelSwizzling /*= ivec4( 0, 1, 2, 3)*/;' + LineEnding + 'uniform sampler2D samp;' + LineEnding + LineEnding + 'void main()' + LineEnding + '{' + LineEnding + ' vec4 texel;' + LineEnding + ' if (mipLevel > 0)' + LineEnding + ' texel = texture2DLod( samp, gl_TexCoord[0].xy, mipLevel);' + LineEnding + ' else' + LineEnding + ' texel = texture2D( samp, gl_TexCoord[0].xy);' + LineEnding + ' texel = texel * texelScale + texelOffset;' + LineEnding + ' gl_FragColor = texel.x * vec4( texelSwizzling.x == 0, texelSwizzling.y == 0, texelSwizzling.z == 0, texelSwizzling.w == 0 );' + LineEnding + ' gl_FragColor += texel.y * vec4( texelSwizzling.x == 1, texelSwizzling.y == 1, texelSwizzling.z == 1, texelSwizzling.w == 1 );' + LineEnding + ' gl_FragColor += texel.z * vec4( texelSwizzling.x == 2, texelSwizzling.y == 2, texelSwizzling.z == 2, texelSwizzling.w == 2 );' + LineEnding + ' gl_FragColor += texel.w * vec4( texelSwizzling.x == 3, texelSwizzling.y == 3, texelSwizzling.z == 3, texelSwizzling.w == 3 );' + LineEnding + '}';


[Overview][Constants][Classes][Index] Reference for unit 'nvGLPainter' (#nvidia-widgets)

cTranslucent

Declaration

Source position: nvglpainter.pas line 26

const cTranslucent = 20;


cWidgetFSSource

Declaration

Source position: nvglpainter.pas line 78

const cWidgetFSSource = '#version 120' + LineEnding + 'uniform vec4 fillColor /*= vec4( 1.0, 0.0,0.0,1.0)*/;' + LineEnding + 'uniform vec4 borderColor /*= vec4( 1.0, 1.0,1.0,1.0)*/;' + LineEnding + 'uniform vec2 zones;' + LineEnding + LineEnding + 'void main()' + LineEnding + '{' + LineEnding + ' float doTurn = float(gl_TexCoord[0].y > 0);' + LineEnding + ' float radiusOffset = doTurn * abs( gl_TexCoord[0].z );' + LineEnding + ' float turnDir = sign( gl_TexCoord[0].z );' + LineEnding + ' vec2 uv = vec2(gl_TexCoord[0].x + turnDir*radiusOffset, gl_TexCoord[0].y);' + LineEnding + ' float l = abs( length(uv) - radiusOffset );' + LineEnding + ' float a = clamp( l - zones.x, 0.0, 2.0);' + LineEnding + ' float b = clamp( l - zones.y, 0.0, 2.0);' + LineEnding + ' b = exp2(-2.0*b*b);' + LineEnding + ' gl_FragColor = ( fillColor * b + (1.0-b)*borderColor );' + LineEnding + ' gl_FragColor.a *= exp2(-2.0*a*a);' + LineEnding + '}';


cWidgetVSSource

Declaration

Source position: nvglpainter.pas line 68

const cWidgetVSSource = '#version 120' + LineEnding + LineEnding + 'void main()' + LineEnding + '{' + LineEnding + ' gl_Position = gl_ModelViewProjectionMatrix * gl_Vertex;' + LineEnding + ' gl_TexCoord[0] = gl_MultiTexCoord0;' + LineEnding + '}';


GLUIPainter

UIPainter

pl

Font


GLUIPainter
 | Create
 | Destroy
 | _begin
 | _end
 | drawFrame
 | getLabelRect
 | drawLabel
 | getButtonRect
 | drawButton
 | getCheckRect
 | drawCheckButton
 | getRadioRect
 | drawRadioButton
 | getHorizontalSliderRect
 | drawHorizontalSlider
 | getItemRect
 | drawListItem
 | getListRect
 | drawListBox
 | getComboRect
 | getComboOptionsRect
 | drawComboBox
 | drawComboOptions
 | getLineEditRect
 | drawLineEdit
 | getPanelRect
 | drawPanel
 | getTextureViewRect
 | drawTextureView
 | getCanvasMargin
 | getCanvasSpace
 | getFontHeight
 | getTextLineWidth
 | getTextSize
 | getTextLineWidthAt
 | getPickedCharNb
 | drawDebugRect
 | drawText
 | drawBoolFrame
 | drawString
 | drawRect
 | drawRoundedRect
 | drawRoundedRectOutline
 | drawCircle
 | drawMinus
 | drawPlus
 | drawDownArrow
 | drawUpArrow
 | init
UIPainter
 | Create
 | _begin
 | _end
 | drawFrame
 | getLabelRect
 | drawLabel
 | getButtonRect
 | drawButton
 | getCheckRect
 | drawCheckButton
 | getRadioRect
 | drawRadioButton
 | getHorizontalSliderRect
 | drawHorizontalSlider
 | getItemRect
 | drawListItem
 | getListRect
 | drawListBox
 | getComboRect
 | getComboOptionsRect
 | drawComboBox
 | drawComboOptions
 | getLineEditRect
 | drawLineEdit
 | getPanelRect
 | drawPanel
 | getTextureViewRect
 | drawTextureView
 | getCanvasMargin
 | getCanvasSpace
 | getFontHeight
 | getTextLineWidth
 | getTextSize
 | getPickedCharNb
 | drawDebugRect
 | init


Create (UIPainter)

Create (GLUIPainter)

Destroy (GLUIPainter)

drawBoolFrame (GLUIPainter)

drawButton (UIPainter)

drawButton (GLUIPainter)

drawCheckButton (UIPainter)

drawCheckButton (GLUIPainter)

drawCircle (GLUIPainter)

drawComboBox (UIPainter)

drawComboBox (GLUIPainter)

drawComboOptions (UIPainter)

drawComboOptions (GLUIPainter)

drawDebugRect (UIPainter)

drawDebugRect (GLUIPainter)

drawDownArrow (GLUIPainter)

drawFrame (UIPainter)

drawFrame (GLUIPainter)

drawHorizontalSlider (UIPainter)

drawHorizontalSlider (GLUIPainter)

drawLabel (UIPainter)

drawLabel (GLUIPainter)

drawLineEdit (UIPainter)

drawLineEdit (GLUIPainter)

drawListBox (UIPainter)

drawListBox (GLUIPainter)

drawListItem (UIPainter)

drawListItem (GLUIPainter)

drawMinus (GLUIPainter)

drawPanel (UIPainter)

drawPanel (GLUIPainter)

drawPlus (GLUIPainter)

drawRadioButton (UIPainter)

drawRadioButton (GLUIPainter)

drawRect (GLUIPainter)

drawRoundedRect (GLUIPainter)

drawRoundedRectOutline (GLUIPainter)

drawString (GLUIPainter)

drawText (GLUIPainter)

drawTextureView (UIPainter)

drawTextureView (GLUIPainter)

drawUpArrow (GLUIPainter)

getButtonRect (UIPainter)

getButtonRect (GLUIPainter)

getCanvasMargin (UIPainter)

getCanvasMargin (GLUIPainter)

getCanvasSpace (UIPainter)

getCanvasSpace (GLUIPainter)

getCheckRect (UIPainter)

getCheckRect (GLUIPainter)

getComboOptionsRect (UIPainter)

getComboOptionsRect (GLUIPainter)

getComboRect (UIPainter)

getComboRect (GLUIPainter)

getFontHeight (UIPainter)

getFontHeight (GLUIPainter)

getHorizontalSliderRect (UIPainter)

getHorizontalSliderRect (GLUIPainter)

getItemRect (UIPainter)

getItemRect (GLUIPainter)

getLabelRect (UIPainter)

getLabelRect (GLUIPainter)

getLineEditRect (UIPainter)

getLineEditRect (GLUIPainter)

getListRect (UIPainter)

getListRect (GLUIPainter)

getPanelRect (UIPainter)

getPanelRect (GLUIPainter)

getPickedCharNb (UIPainter)

getPickedCharNb (GLUIPainter)

getRadioRect (UIPainter)

getRadioRect (GLUIPainter)

getTextLineWidth (UIPainter)

getTextLineWidth (GLUIPainter)

getTextLineWidthAt (GLUIPainter)

getTextSize (UIPainter)

getTextSize (GLUIPainter)

getTextureViewRect (UIPainter)

getTextureViewRect (GLUIPainter)

init (UIPainter)

init (GLUIPainter)

_begin (UIPainter)

_begin (GLUIPainter)

_end (UIPainter)

_end (GLUIPainter)


GLUIPainter

UIPainter


GLUIPainter._begin

Declaration

Source position: nvglpainter.pas line 131

public procedure GLUIPainter._begin(

  const window: Rect

); override;


GLUIPainter._end

Declaration

Source position: nvglpainter.pas line 132

public procedure GLUIPainter._end; override;


GLUIPainter.Create

Declaration

Source position: nvglpainter.pas line 128

public constructor GLUIPainter.Create;


GLUIPainter.Destroy

Declaration

Source position: nvglpainter.pas line 129

public destructor GLUIPainter.Destroy; override;


GLUIPainter.drawBoolFrame

Draw bool frame primitive

Declaration

Source position: nvglpainter.pas line 186

public procedure GLUIPainter.drawBoolFrame(

  aRect: Rect;

  corner: Point;

  isHover: Boolean = false;

  isOn: Boolean = false;

  isFocus: Boolean = false

);

Arguments

aRect | Rectangle to draw in
corner | Radius of the corner
isHover | Boolean indicating if the mouse is hovering over it
isOn | Boolean indicating if the widget is on
isFocus | Boolean indicating if the widget has focus


GLUIPainter.drawButton

Declaration

Source position: nvglpainter.pas line 141

public procedure GLUIPainter.drawButton(

  const r: Rect;

  const Text: ;

  const rt: Rect;

  isDown: Boolean;

  isHover: Boolean;

  isFocus: Boolean;

  style: Integer

); override;


GLUIPainter.drawCheckButton

Declaration

Source position: nvglpainter.pas line 144

public procedure GLUIPainter.drawCheckButton(

  const r: Rect;

  const Text: ;

  const rt: Rect;

  const rr: Rect;

  isChecked: Boolean;

  isHover: Boolean;

  isFocus: Boolean;

  style: Integer

); override;


GLUIPainter.drawCircle

Draw circle primitive

Declaration

Source position: nvglpainter.pas line 191

public procedure GLUIPainter.drawCircle(

  aRect: Rect;

  fillColorId: Integer;

  borderColorId: Integer

);

Arguments

aRect | Rectangle to draw in
fillColorId | Fill color
borderColorId | Border color


GLUIPainter.drawComboBox

Declaration

Source position: nvglpainter.pas line 160

public procedure GLUIPainter.drawComboBox(

  const aRect: Rect;

  numOptions: Integer;

  const options: array of ;

  const rt: Rect;

  const ra: Rect;

  selected: Integer;

  isHover: Boolean;

  isFocus: Boolean;

  style: Integer

); override;


GLUIPainter.drawComboOptions

Declaration

Source position: nvglpainter.pas line 161

public procedure GLUIPainter.drawComboOptions(

  const aRect: Rect;

  numOptions: Integer;

  const options: array of ;

  const ri: Rect;

  const rit: Rect;

  selected: Integer;

  hovered: Integer;

  isHover: Boolean;

  isFocus: Boolean;

  style: Integer

); override;


GLUIPainter.drawDebugRect

Draw a rectangle for debugging purposes

Declaration

Source position: nvglpainter.pas line 181

public procedure GLUIPainter.drawDebugRect(

  const r: Rect

); override;

Arguments

r

Rectangle size to draw

Description

drawDebugRect draws a simple rectangle usefull for debugging purposes.


GLUIPainter.drawDownArrow

Draw down arrow primitive

Declaration

Source position: nvglpainter.pas line 194

public procedure GLUIPainter.drawDownArrow(

  aRect: Rect;

  Width: Integer;

  fillColorId: Integer;

  borderColorId: Integer

);

Arguments

aRect | Rectangle to draw in
Width | Width of the arrow
fillColorId | Fill color
borderColorId | Border color


GLUIPainter.drawFrame

Draw frame primitive

Declaration

Source position: line 0

procedure GLUIPainter.drawFrame(

  const r: Rect;

  margin: Integer;

  style: Integer

); override;

procedure GLUIPainter.drawFrame(

  aRect: Rect;

  corner: Point;

  isHover: Boolean = false;

  isOn: Boolean = false;

  isFocus: Boolean = false

);

Arguments

aRect | Rectangle to draw in
corner | Radius of the corner
isHover | Boolean indicating if the mouse is hovering over it
isOn | Boolean indicating if the widget is on
isFocus | Boolean indicating if the widget has focus


GLUIPainter.drawHorizontalSlider

Declaration

Source position: nvglpainter.pas line 150

public procedure GLUIPainter.drawHorizontalSlider(

  const r: Rect;

  rs: Rect;

  v: Double;

  rc: Rect;

  isHover: Boolean;

  style: Integer

); override;


GLUIPainter.drawLabel

Declaration

Source position: nvglpainter.pas line 138

public procedure GLUIPainter.drawLabel(

  const r: Rect;

  const Text: ;

  const rt: Rect;

  const nbLines: Integer;

  isHover: Boolean;

  style: Integer

); override;


GLUIPainter.drawLineEdit

Declaration

Source position: nvglpainter.pas line 164

public procedure GLUIPainter.drawLineEdit(

  const r: Rect;

  const Text: ;

  const rt: Rect;

  caretPos: Integer;

  isSelected: Boolean;

  isHover: Boolean;

  style: Integer

); override;


GLUIPainter.drawListBox

Declaration

Source position: nvglpainter.pas line 156

public procedure GLUIPainter.drawListBox(

  const r: Rect;

  numOptions: Integer;

  const options: array of ;

  const ri: Rect;

  const rt: Rect;

  selected: Integer;

  hovered: Integer;

  style: Integer

); override;


GLUIPainter.drawListItem

Declaration

Source position: nvglpainter.pas line 153

public procedure GLUIPainter.drawListItem(

  const r: Rect;

  const Text: ;

  const rt: Rect;

  isSelected: Boolean;

  isHover: Boolean;

  style: Integer

); override;


GLUIPainter.drawMinus

Draw minus primitive

Declaration

Source position: nvglpainter.pas line 192

public procedure GLUIPainter.drawMinus(

  aRect: Rect;

  Width: Integer;

  fillColorId: Integer;

  borderColorId: Integer

);

Arguments

aRect | Rectangle to draw in
Width | Width of the minus
fillColorId | Fill color
borderColorId | Border color


GLUIPainter.drawPanel

Declaration

Source position: nvglpainter.pas line 167

public procedure GLUIPainter.drawPanel(

  const r: Rect;

  const Text: ;

  const rt: Rect;

  const ra: Rect;

  isUnfold: Boolean;

  isHover: Boolean;

  isFocus: Boolean;

  style: Integer

); override;


GLUIPainter.drawPlus

Draw plus primitive

Declaration

Source position: nvglpainter.pas line 193

public procedure GLUIPainter.drawPlus(

  aRect: Rect;

  Width: Integer;

  fillColorId: Integer;

  borderColorId: Integer

);

Arguments

aRect | Rectangle to draw in
Width | Width of the plus
fillColorId | Fill color
borderColorId | Border color


GLUIPainter.drawRadioButton

Declaration

Source position: nvglpainter.pas line 147

public procedure GLUIPainter.drawRadioButton(

  const r: Rect;

  const Text: ;

  const rt: Rect;

  const rr: Rect;

  isOn: Boolean;

  isHover: Boolean;

  isFocus: Boolean;

  style: Integer

); override;


GLUIPainter.drawRect

Draw rectangle primitive

Declaration

Source position: nvglpainter.pas line 188

public procedure GLUIPainter.drawRect(

  aRect: Rect;

  fillColorId: Integer;

  borderColorId: Integer

);

Arguments

aRect | Rectangle to draw in
fillColorId | Fill color
borderColorId | Border color


GLUIPainter.drawRoundedRect

Draw rouded rectangle primitive

Declaration

Source position: nvglpainter.pas line 189

public procedure GLUIPainter.drawRoundedRect(

  aRect: Rect;

  const corner: Point;

  fillColorId: Integer;

  borderColorId: Integer

);

Arguments

aRect | Rectangle to draw in
corner | Radius of the corner
fillColorId | Fill color
borderColorId | Border color


GLUIPainter.drawRoundedRectOutline

Draw rouded rectangle outline primitive

Declaration

Source position: nvglpainter.pas line 190

public procedure GLUIPainter.drawRoundedRectOutline(

  aRect: Rect;

  corner: Point;

  borderColorId: Integer

);

Arguments

aRect | Rectangle to draw in
corner | Radius of the corner
borderColorId | Border color


GLUIPainter.drawString

Draw multi-line text primitive

Declaration

Source position: nvglpainter.pas line 187

public procedure GLUIPainter.drawString(

  x: Integer;

  y: Integer;

  Text: ;

  nbLines: Integer

);

Arguments

nbLines

Number of lines in text


GLUIPainter.drawText

Draw text with rectangle primitive

Declaration

Source position: nvglpainter.pas line 184

public procedure GLUIPainter.drawText(

  r: Rect;

  Text: ;

  nbLines: Integer = 1;

  caretPos: Integer = -1;

  isHover: Boolean = false;

  isOn: Boolean = false;

  isFocus: Boolean = false

);

Arguments

r | Rectangle to draw in
nbLines | Number of lines in text
caretPos | Caret position
isHover | Boolean indicating if the mouse is hovering over it
isOn | Boolean indicating if the widget is on
isFocus | Boolean indicating if the widget has focus


GLUIPainter.drawTextureView

Declaration

Source position: nvglpainter.pas line 170

public procedure GLUIPainter.drawTextureView(

  const aRect: Rect;

  const texID: Integer;

  const rt: Rect;

  const rz: Rect;

  mipLevel: Integer;

  texelScale: Double;

  texelOffset: Double;

  r: Integer;

  g: Integer;

  b: Integer;

  a: Integer;

  style: Integer

); override;


GLUIPainter.drawUpArrow

Draw up arrow primitive

Declaration

Source position: nvglpainter.pas line 195

public procedure GLUIPainter.drawUpArrow(

  aRect: Rect;

  Width: Integer;

  fillColorId: Integer;

  borderColorId: Integer

);

Arguments

aRect | Rectangle to draw in
Width | Width of the arrow
fillColorId | Fill color
borderColorId | Border color


GLUIPainter.getButtonRect

Declaration

Source position: nvglpainter.pas line 140

public function GLUIPainter.getButtonRect(

  const r: Rect;

  const Text: ;

  out rt: Rect

):Rect; override;


GLUIPainter.getCanvasMargin

Evaluate canvas margin

Declaration

Source position: nvglpainter.pas line 173

public function GLUIPainter.getCanvasMargin: Integer; override;

Function result

Exterior margin


GLUIPainter.getCanvasSpace

Evaluate canvas space

Declaration

Source position: nvglpainter.pas line 174

public function GLUIPainter.getCanvasSpace: Integer; override;

Function result

Interior margin


GLUIPainter.getCheckRect

Declaration

Source position: nvglpainter.pas line 143

public function GLUIPainter.getCheckRect(

  const r: Rect;

  const Text: ;

  out rt: Rect;

  out rc: Rect

):Rect; override;


GLUIPainter.getComboOptionsRect

Declaration

Source position: nvglpainter.pas line 159

public function GLUIPainter.getComboOptionsRect(

  const rCombo: Rect;

  numOptions: Integer;

  const options: array of ;

  out ri: Rect;

  out rit: Rect

):Rect; override;


GLUIPainter.getComboRect

Declaration

Source position: nvglpainter.pas line 158

public function GLUIPainter.getComboRect(

  const r: Rect;

  numOptions: Integer;

  const options: array of ;

  selected: Integer;

  out rt: Rect;

  out ra: Rect

):Rect; override;


GLUIPainter.getFontHeight

Evaluate font height

Declaration

Source position: nvglpainter.pas line 175

public function GLUIPainter.getFontHeight: Integer; override;

Function result

Font height in pixels


GLUIPainter.getHorizontalSliderRect

Declaration

Source position: nvglpainter.pas line 149

public function GLUIPainter.getHorizontalSliderRect(

  const r: Rect;

  out rs: Rect;

  v: Double;

  out rc: Rect

):Rect; override;


GLUIPainter.getItemRect

Declaration

Source position: nvglpainter.pas line 152

public function GLUIPainter.getItemRect(

  const r: Rect;

  const Text: ;

  out rt: Rect

):Rect; override;


GLUIPainter.getLabelRect

Declaration

Source position: nvglpainter.pas line 137

public function GLUIPainter.getLabelRect(

  const r: Rect;

  const Text: ;

  out rt: Rect;

  out nbLines: Integer

):Rect; override;


GLUIPainter.getLineEditRect

Declaration

Source position: nvglpainter.pas line 163

public function GLUIPainter.getLineEditRect(

  const r: Rect;

  const Text: ;

  out rt: Rect

):Rect; override;


GLUIPainter.getListRect

Declaration

Source position: nvglpainter.pas line 155

public function GLUIPainter.getListRect(

  const r: Rect;

  numOptions: Integer;

  const options: array of ;

  out ri: Rect;

  out rt: Rect

):Rect; override;


GLUIPainter.getPanelRect

Declaration

Source position: nvglpainter.pas line 166

public function GLUIPainter.getPanelRect(

  const r: Rect;

  const Text: ;

  out rt: Rect;

  out ra: Rect

):Rect; override;


GLUIPainter.getPickedCharNb

Declaration

Source position: nvglpainter.pas line 179

public function GLUIPainter.getPickedCharNb(

  const Text: ;

  const at: Point

):Integer; override;


GLUIPainter.getRadioRect

Declaration

Source position: nvglpainter.pas line 146

public function GLUIPainter.getRadioRect(

  const r: Rect;

  const Text: ;

  out rt: Rect;

  out rr: Rect

):Rect; override;


GLUIPainter.getTextLineWidth

Evaluate text width

Declaration

Source position: nvglpainter.pas line 176

public function GLUIPainter.getTextLineWidth(

  const Text:

):Integer; override;

Function result

Text width


GLUIPainter.getTextLineWidthAt

Declaration

Source position: nvglpainter.pas line 178

public function GLUIPainter.getTextLineWidthAt(

  const Text: ;

  charNb: Integer

):Integer;


GLUIPainter.getTextSize

Evaluate text size

Declaration

Source position: nvglpainter.pas line 177

public function GLUIPainter.getTextSize(

  const Text: ;

  out nbLines: Integer

):Integer; override;

Function result

Text width of widest line

Description

getTextSize evaluates a string, it will calculate the number of lines it consists of and will return the length in pixels of the longest line.


GLUIPainter.getTextureViewRect

Declaration

Source position: nvglpainter.pas line 169

public function GLUIPainter.getTextureViewRect(

  const r: Rect;

  out rt: Rect

):Rect; override;


GLUIPainter.init

Initialization method of the painter class

Declaration

Source position: nvglpainter.pas line 197

public procedure GLUIPainter.init; override;


Reference for unit 'nvGLPainter'

User Interface library specialized for OpenGL

uses
System,
Classes,
nvPainter, | Basic painter class
nvTypes, | Base types and constants
GL,
ftFont,
FPCanvas;


Reference for unit 'nvGLPainter': Constants

cBase

cBool

cFont

cFontBack

cNbColors

cOutline

cTexViewWidgetFSSource

cTranslucent

cWidgetFSSource

cWidgetVSSource

s_colors


[Overview][Constants][Classes][Index] Reference for unit 'nvGLPainter' (#nvidia-widgets)

Reference for unit 'nvGLPainter': Classes

GLUIPainter

OpenGL painter class


Index of all identifiers in unit 'nvGLPainter'

C G S

C

cBase | cNbColors | cWidgetFSSource
cBool | cOutline | cWidgetVSSource
cFont | cTexViewWidgetFSSource |
cFontBack | cTranslucent |

G

GLUIPainter

S

s_colors


s_colors

Declaration

Source position: nvglpainter.pas line 29

const s_colors: array [0..23,0..3] of GLfloat = ((89 / 255, 89 / 255, 89 / 255, 0.7), (166 / 255, 166 / 255, 166 / 255, 0.8), (212 / 255, 228 / 255, 60 / 255, 0.5), (227 / 255, 237 / 255, 127 / 255, 0.5), (99 / 255, 37 / 255, 35 / 255, 1.0), (149 / 255, 55 / 255, 53 / 255, 1.0), (212 / 255, 228 / 255, 60 / 255, 1.0), (227 / 255, 237 / 255, 127 / 255, 1.0), (255 / 255, 255 / 255, 255 / 255, 1.0), (255 / 255, 255 / 255, 255 / 255, 1.0), (255 / 255, 255 / 255, 255 / 255, 1.0), (255 / 255, 255 / 255, 255 / 255, 1.0), (255 / 255, 255 / 255, 255 / 255, 1.0), (255 / 255, 255 / 255, 255 / 255, 1.0), (255 / 255, 255 / 255, 255 / 255, 1.0), (255 / 255, 255 / 255, 255 / 255, 1.0), (79 / 255, 129 / 255, 189 / 255, 1.0), (79 / 255, 129 / 255, 189 / 255, 1.0), (128 / 255, 100 / 255, 162 / 255, 1.0), (128 / 255, 100 / 255, 162 / 255, 1.0), (0 / 255, 0 / 255, 0 / 255, 0.0), (0 / 255, 0 / 255, 0 / 255, 0.0), (0 / 255, 0 / 255, 0 / 255, 0.0), (0 / 255, 0 / 255, 0 / 255, 0.0));


GlutUIContext

UIContext

pl

Painter


GlutUIContext
 | init
 | mouse
 | specialKeyboard
UIContext
 | Create
 | Destroy
 | reshape
 | isOnFocus
 | mouse
 | mouseMotion
 | keyboard
 | _begin
 | _end
 | doLabel
 | doButton
 | doCheckButton
 | doRadioButton
 | doHorizontalSlider
 | doListItem
 | doListBox
 | doComboBox
 | doLineEdit
 | beginGroup
 | endGroup
 | beginFrame
 | endFrame
 | beginPanel
 | endPanel
 | getGroupWidth
 | getGroupHeight
 | getCursorX
 | getCursorY
 | getMouseState
 | doTextureView
pt | window
pt | placeRect


 | beginFrame (UIContext)
 | beginGroup (UIContext)
 | beginPanel (UIContext)
 | Create (UIContext)
 | Destroy (UIContext)
 | doButton (UIContext)
 | doCheckButton (UIContext)
 | doComboBox (UIContext)
 | doHorizontalSlider (UIContext)
 | doLabel (UIContext)
 | doLineEdit (UIContext)
 | doListBox (UIContext)
 | doListItem (UIContext)
 | doRadioButton (UIContext)
 | doTextureView (UIContext)
 | endFrame (UIContext)
 | endGroup (UIContext)
 | endPanel (UIContext)
 | getCursorX (UIContext)
 | getCursorY (UIContext)
 | getGroupHeight (UIContext)
 | getGroupWidth (UIContext)
 | getMouseState (UIContext)
 | init (GlutUIContext)
 | isOnFocus (UIContext)
 | keyboard (UIContext)
 | mouse (UIContext)
 | mouse (GlutUIContext)
 | mouseMotion (UIContext)
pt | placeRect (UIContext)
 | reshape (UIContext)
 | specialKeyboard (GlutUIContext)
pt |


GlutUIContext

UIContext


GlutUIContext.init

One time initialization

Declaration

Source position: nvglutcontext.pas line 35

public function GlutUIContext.init(

  w: Integer;

  h: Integer

):Boolean;


GlutUIContext.mouse

UI method for processing GLUT mouse button events

Declaration

Source position: line 0

procedure GlutUIContext.mouse(

  button: Integer;

  state: Integer;

  modifier: Integer;

  x: Integer;

  y: Integer

);

procedure GlutUIContext.mouse(

  button: Integer;

  state: Integer;

  x: Integer;

  y: Integer

);

Description

Call this method from the glutMouseFunc callback, the modifier parameter maps to glutGetModifiers.


GlutUIContext.specialKeyboard

UI method for processing key events

Declaration

Source position: nvglutcontext.pas line 51

public procedure GlutUIContext.specialKeyboard(

  k: Integer;

  x: Integer;

  y: Integer

);

Description

Call this method from the glutReshapeFunc callback


Reference for unit 'nvGlutContext'

GLut adaptor class

uses
System,
SysUtils,
nvContext, | User Interface library
nvTypes; | Base types and constants

Overview

Adaptor classes to integrate the nvWidgets UI library with the GLUT windowing toolkit. The adaptors convert native GLUT UI data to native nvWidgets data. All adaptor classes are implemented as in-line code in this header. The adaptor defaults to using the standard OpenGL painter implementation.


Reference for unit 'nvGlutContext': Classes

GlutUIContext

GLut specific UI context


[Overview][Classes][Index] Reference for unit 'nvGlutContext' (#nvidia-widgets)

Index of all identifiers in unit 'nvGlutContext'

G

G

GlutUIContext


Reference for unit 'nvPainter'

Basic painter class

uses
System,
Classes,
SysUtils,
nvBaseFont, | Generic font support class
nvTypes; | Base types and constants


[Overview][Classes][Procedures and functions][Index] Reference for unit 'nvPainter' (#nvidia-widgets)

Reference for unit 'nvPainter': Classes

UIPainter

Basic painter class


[Overview][Classes][Procedures and functions][Index] Reference for unit 'nvPainter' (#nvidia-widgets)

Reference for unit 'nvPainter': Procedures and functions

EvalBool

Boolean evaluation function


[Overview][Classes][Procedures and functions][Index] Reference for unit 'nvPainter' (#nvidia-widgets)

Index of all identifiers in unit 'nvPainter'

E U

E

EvalBool

U

UIPainter


UIPainter

pl

Font


UIPainter
 | Create
 | _begin
 | _end
 | drawFrame
 | getLabelRect
 | drawLabel
 | getButtonRect
 | drawButton
 | getCheckRect
 | drawCheckButton
 | getRadioRect
 | drawRadioButton
 | getHorizontalSliderRect
 | drawHorizontalSlider
 | getItemRect
 | drawListItem
 | getListRect
 | drawListBox
 | getComboRect
 | getComboOptionsRect
 | drawComboBox
 | drawComboOptions
 | getLineEditRect
 | drawLineEdit
 | getPanelRect
 | drawPanel
 | getTextureViewRect
 | drawTextureView
 | getCanvasMargin
 | getCanvasSpace
 | getFontHeight
 | getTextLineWidth
 | getTextSize
 | getPickedCharNb
 | drawDebugRect
 | init


Create (UIPainter)

drawButton (UIPainter)

drawCheckButton (UIPainter)

drawComboBox (UIPainter)

drawComboOptions (UIPainter)

drawDebugRect (UIPainter)

drawFrame (UIPainter)

drawHorizontalSlider (UIPainter)

drawLabel (UIPainter)

drawLineEdit (UIPainter)

drawListBox (UIPainter)

drawListItem (UIPainter)

drawPanel (UIPainter)

drawRadioButton (UIPainter)

drawTextureView (UIPainter)

getButtonRect (UIPainter)

getCanvasMargin (UIPainter)

getCanvasSpace (UIPainter)

getCheckRect (UIPainter)

getComboOptionsRect (UIPainter)

getComboRect (UIPainter)

getFontHeight (UIPainter)

getHorizontalSliderRect (UIPainter)

getItemRect (UIPainter)

getLabelRect (UIPainter)

getLineEditRect (UIPainter)

getListRect (UIPainter)

getPanelRect (UIPainter)

getPickedCharNb (UIPainter)

getRadioRect (UIPainter)

getTextLineWidth (UIPainter)

getTextSize (UIPainter)

getTextureViewRect (UIPainter)

init (UIPainter)

_begin (UIPainter)

_end (UIPainter)


UIPainter


UIPainter._begin

Declaration

Source position: nvpainter.pas line 28

public procedure UIPainter._begin(

  const window: Rect

); virtual;


UIPainter._end

Declaration

Source position: nvpainter.pas line 29

public procedure UIPainter._end; virtual;


[Overview][Classes][Procedures and functions][Index] Reference for unit 'nvPainter' (#nvidia-widgets)

UIPainter.Create

Declaration

Source position: nvpainter.pas line 26

public constructor UIPainter.Create;


UIPainter.drawButton

Declaration

Source position: nvpainter.pas line 39

public procedure UIPainter.drawButton(

  const r: Rect;

  const Text: ;

  const rt: Rect;

  isDown: Boolean;

  isHover: Boolean;

  isFocus: Boolean;

  style: Integer

); virtual; abstract;


UIPainter.drawCheckButton

Declaration

Source position: nvpainter.pas line 42

public procedure UIPainter.drawCheckButton(

  const r: Rect;

  const Text: ;

  const rt: Rect;

  const rr: Rect;

  isChecked: Boolean;

  isHover: Boolean;

  isFocus: Boolean;

  style: Integer

); virtual; abstract;


UIPainter.drawComboBox

Declaration

Source position: nvpainter.pas line 58

public procedure UIPainter.drawComboBox(

  const rect: Rect;

  numOptions: Integer;

  const options: array of ;

  const rt: Rect;

  const ra: Rect;

  selected: Integer;

  isHover: Boolean;

  isFocus: Boolean;

  style: Integer

); virtual; abstract;


UIPainter.drawComboOptions

Declaration

Source position: nvpainter.pas line 59

public procedure UIPainter.drawComboOptions(

  const rect: Rect;

  numOptions: Integer;

  const options: array of ;

  const ri: Rect;

  const rit: Rect;

  selected: Integer;

  hovered: Integer;

  isHover: Boolean;

  isFocus: Boolean;

  style: Integer

); virtual; abstract;


UIPainter.drawDebugRect

Declaration

Source position: nvpainter.pas line 78

public procedure UIPainter.drawDebugRect(

  const r: Rect

); virtual; abstract;


UIPainter.drawFrame

Declaration

Source position: nvpainter.pas line 33

public procedure UIPainter.drawFrame(

  const r: Rect;

  margin: Integer;

  style: Integer

); virtual; abstract;


UIPainter.drawHorizontalSlider

Declaration

Source position: nvpainter.pas line 48

public procedure UIPainter.drawHorizontalSlider(

  const r: Rect;

  rs: Rect;

  v: Double;

  rc: Rect;

  isHover: Boolean;

  style: Integer

); virtual; abstract;


UIPainter.drawLabel

Declaration

Source position: nvpainter.pas line 36

public procedure UIPainter.drawLabel(

  const r: Rect;

  const Text: ;

  const rt: Rect;

  const nbLines: Integer;

  isHover: Boolean;

  style: Integer

); virtual; abstract;


UIPainter.drawLineEdit

Declaration

Source position: nvpainter.pas line 62

public procedure UIPainter.drawLineEdit(

  const r: Rect;

  const Text: ;

  const rt: Rect;

  caretPos: Integer;

  isSelected: Boolean;

  isHover: Boolean;

  style: Integer

); virtual; abstract;


UIPainter.drawListBox

Declaration

Source position: nvpainter.pas line 54

public procedure UIPainter.drawListBox(

  const r: Rect;

  numOptions: Integer;

  const options: array of ;

  const ri: Rect;

  const rt: Rect;

  selected: Integer;

  hovered: Integer;

  style: Integer

); virtual; abstract;


UIPainter.drawListItem

Declaration

Source position: nvpainter.pas line 51

public procedure UIPainter.drawListItem(

  const r: Rect;

  const Text: ;

  const rt: Rect;

  isSelected: Boolean;

  isHover: Boolean;

  style: Integer

); virtual; abstract;


UIPainter.drawPanel

Declaration

Source position: nvpainter.pas line 65

public procedure UIPainter.drawPanel(

  const rect: Rect;

  const Text: ;

  const rt: Rect;

  const ra: Rect;

  isUnfold: Boolean;

  isHover: Boolean;

  isFocus: Boolean;

  style: Integer

); virtual; abstract;


UIPainter.drawRadioButton

Declaration

Source position: nvpainter.pas line 45

public procedure UIPainter.drawRadioButton(

  const r: Rect;

  const Text: ;

  const rt: Rect;

  const rr: Rect;

  isOn: Boolean;

  isHover: Boolean;

  isFocus: Boolean;

  style: Integer

); virtual; abstract;


UIPainter.drawTextureView

Declaration

Source position: nvpainter.pas line 68

public procedure UIPainter.drawTextureView(

  const rect: Rect;

  const texID: Integer;

  const rt: Rect;

  const rz: Rect;

  mipLevel: Integer;

  texelScale: Double;

  texelOffset: Double;

  r: Integer;

  g: Integer;

  b: Integer;

  a: Integer;

  style: Integer

); virtual; abstract;


UIPainter.Font

Declaration

Source position: nvpainter.pas line 82

published property UIPainter.Font: TnvBaseFont
  read FFont
  write SetFont;


UIPainter.getButtonRect

Declaration

Source position: nvpainter.pas line 38

public function UIPainter.getButtonRect(

  const r: Rect;

  const Text: ;

  out rt: Rect

):Rect; virtual; abstract;


UIPainter.getCanvasMargin

Declaration

Source position: nvpainter.pas line 71

public function UIPainter.getCanvasMargin: Integer; virtual;


UIPainter.getCanvasSpace

Declaration

Source position: nvpainter.pas line 72

public function UIPainter.getCanvasSpace: Integer; virtual;


UIPainter.getCheckRect

Declaration

Source position: nvpainter.pas line 41

public function UIPainter.getCheckRect(

  const r: Rect;

  const Text: ;

  out rt: Rect;

  out rc: Rect

):Rect; virtual; abstract;


UIPainter.getComboOptionsRect

Declaration

Source position: nvpainter.pas line 57

public function UIPainter.getComboOptionsRect(

  const rCombo: Rect;

  numOptions: Integer;

  const options: array of ;

  out ri: Rect;

  out rit: Rect

):Rect; virtual; abstract;


UIPainter.getComboRect

Declaration

Source position: nvpainter.pas line 56

public function UIPainter.getComboRect(

  const r: Rect;

  numOptions: Integer;

  const options: array of ;

  selected: Integer;

  out rt: Rect;

  out ra: Rect

):Rect; virtual; abstract;


UIPainter.getFontHeight

Declaration

Source position: nvpainter.pas line 73

public function UIPainter.getFontHeight: Integer; virtual;


UIPainter.getHorizontalSliderRect

Declaration

Source position: nvpainter.pas line 47

public function UIPainter.getHorizontalSliderRect(

  const r: Rect;

  out rs: Rect;

  v: Double;

  out rc: Rect

):Rect; virtual; abstract;


UIPainter.getItemRect

Declaration

Source position: nvpainter.pas line 50

public function UIPainter.getItemRect(

  const r: Rect;

  const Text: ;

  out rt: Rect

):Rect; virtual; abstract;


UIPainter.getLabelRect

Declaration

Source position: nvpainter.pas line 35

public function UIPainter.getLabelRect(

  const r: Rect;

  const Text: ;

  out rt: Rect;

  out nbLines: Integer

):Rect; virtual; abstract;


UIPainter.getLineEditRect

Declaration

Source position: nvpainter.pas line 61

public function UIPainter.getLineEditRect(

  const r: Rect;

  const Text: ;

  out rt: Rect

):Rect; virtual; abstract;


UIPainter.getListRect

Declaration

Source position: nvpainter.pas line 53

public function UIPainter.getListRect(

  const r: Rect;

  numOptions: Integer;

  const options: array of ;

  out ri: Rect;

  out rt: Rect

):Rect; virtual; abstract;


UIPainter.getPanelRect

Declaration

Source position: nvpainter.pas line 64

public function UIPainter.getPanelRect(

  const r: Rect;

  const Text: ;

  out rt: Rect;

  out ra: Rect

):Rect; virtual; abstract;


UIPainter.getPickedCharNb

Declaration

Source position: nvpainter.pas line 76

public function UIPainter.getPickedCharNb(

  const Text: ;

  const at: Point

):Integer; virtual;


UIPainter.getRadioRect

Declaration

Source position: nvpainter.pas line 44

public function UIPainter.getRadioRect(

  const r: Rect;

  const Text: ;

  out rt: Rect;

  out rr: Rect

):Rect; virtual; abstract;


UIPainter.getTextLineWidth

Declaration

Source position: nvpainter.pas line 74

public function UIPainter.getTextLineWidth(

  const Text:

):Integer; virtual;


UIPainter.getTextSize

Declaration

Source position: nvpainter.pas line 75

public function UIPainter.getTextSize(

  const Text: ;

  out nbLines: Integer

):Integer; virtual;


UIPainter.getTextureViewRect

Declaration

Source position: nvpainter.pas line 67

public function UIPainter.getTextureViewRect(

  const rect: Rect;

  out rt: Rect

):Rect; virtual; abstract;


UIPainter.init

Declaration

Source position: nvpainter.pas line 80

public procedure UIPainter.init; virtual; abstract;


Reference for unit 'nvShaderUtils'

Utility functions for compiling shaders and programs

uses

  System,

  Classes,

  SysUtils,

  GL,

  GLext;


Reference for unit 'nvShaderUtils': Procedures and functions

CompileASMShader

CompileASMShaderFromFile

CompileGLSLShader

CompileGLSLShaderFromFile

LinkGLSLProgram

Create a program composed of vertex, geometry and fragment shaders.


Index of all identifiers in unit 'nvShaderUtils'

C L

C

CompileASMShader | CompileGLSLShader
CompileASMShaderFromFile | CompileGLSLShaderFromFile

L

LinkGLSLProgram


[Overview][Constants][Types][Classes][Procedures and functions][Index] Reference for unit 'nvTypes' (#nvidia-widgets)

ButtonFlags_Alt

Declaration

Source position: nvtypes.pas line 45

const ButtonFlags_Alt = $10;


[Overview][Constants][Types][Classes][Procedures and functions][Index] Reference for unit 'nvTypes' (#nvidia-widgets)

ButtonFlags_Begin

Declaration

Source position: nvtypes.pas line 42

const ButtonFlags_Begin = $2;


[Overview][Constants][Types][Classes][Procedures and functions][Index] Reference for unit 'nvTypes' (#nvidia-widgets)

ButtonFlags_Ctrl

Declaration

Source position: nvtypes.pas line 46

const ButtonFlags_Ctrl = $20;


[Overview][Constants][Types][Classes][Procedures and functions][Index] Reference for unit 'nvTypes' (#nvidia-widgets)

ButtonFlags_End

Declaration

Source position: nvtypes.pas line 43

const ButtonFlags_End = $4;


[Overview][Constants][Types][Classes][Procedures and functions][Index] Reference for unit 'nvTypes' (#nvidia-widgets)

ButtonFlags_Off

Declaration

Source position: nvtypes.pas line 40

const ButtonFlags_Off = $0;


[Overview][Constants][Types][Classes][Procedures and functions][Index] Reference for unit 'nvTypes' (#nvidia-widgets)

ButtonFlags_On

Declaration

Source position: nvtypes.pas line 41

const ButtonFlags_On = $1;


[Overview][Constants][Types][Classes][Procedures and functions][Index] Reference for unit 'nvTypes' (#nvidia-widgets)

ButtonFlags_Shift

Declaration

Source position: nvtypes.pas line 44

const ButtonFlags_Shift = $8;


ButtonState

Declaration

Source position: nvtypes.pas line 49

type ButtonState = record

  state: Integer;

  time: TDateTime;

  cursor: Point;

end;


Group

Group record

Declaration

Source position: nvtypes.pas line 128

type Group = record
bounds: Rect; | anchor point + width and height of the region
flags: Integer; | group behavior
margin: Integer; | border
space: Integer; | interior
end;


[Overview][Constants][Types][Classes][Procedures and functions][Index] Reference for unit 'nvTypes' (#nvidia-widgets)

GroupFlags_AlignBottom

Declaration

Source position: nvtypes.pas line 98

const GroupFlags_AlignBottom = $80;


[Overview][Constants][Types][Classes][Procedures and functions][Index] Reference for unit 'nvTypes' (#nvidia-widgets)

GroupFlags_AlignLeft

Declaration

Source position: nvtypes.pas line 95

const GroupFlags_AlignLeft = $10;


[Overview][Constants][Types][Classes][Procedures and functions][Index] Reference for unit 'nvTypes' (#nvidia-widgets)

GroupFlags_AlignMask

Declaration

Source position: nvtypes.pas line 99

const GroupFlags_AlignMask = $f0;


[Overview][Constants][Types][Classes][Procedures and functions][Index] Reference for unit 'nvTypes' (#nvidia-widgets)

GroupFlags_AlignRight

Declaration

Source position: nvtypes.pas line 96

const GroupFlags_AlignRight = $20;


[Overview][Constants][Types][Classes][Procedures and functions][Index] Reference for unit 'nvTypes' (#nvidia-widgets)

GroupFlags_AlignTop

Declaration

Source position: nvtypes.pas line 97

const GroupFlags_AlignTop = $40;


GroupFlags_AlignXMask

Declaration

Source position: nvtypes.pas line 100

const GroupFlags_AlignXMask = $ffff xor GroupFlags_AlignMask;


GroupFlags_GrowDownFromLeft

Declaration

Source position: nvtypes.pas line 123

const GroupFlags_GrowDownFromLeft = GroupFlags_LayoutVertical or GroupFlags_StartTop or GroupFlags_AlignTop or GroupFlags_StartLeft or GroupFlags_AlignLeft;


GroupFlags_GrowDownFromRight

Declaration

Source position: nvtypes.pas line 124

const GroupFlags_GrowDownFromRight = GroupFlags_LayoutVertical or GroupFlags_StartTop or GroupFlags_AlignTop or GroupFlags_StartRight or GroupFlags_AlignRight;


GroupFlags_GrowLeftFromBottom

Declaration

Source position: nvtypes.pas line 119

const GroupFlags_GrowLeftFromBottom = GroupFlags_LayoutHorizontal or GroupFlags_StartRight or GroupFlags_AlignRight or GroupFlags_StartBottom or GroupFlags_AlignBottom;


GroupFlags_GrowLeftFromTop

Declaration

Source position: nvtypes.pas line 120

const GroupFlags_GrowLeftFromTop = GroupFlags_LayoutHorizontal or GroupFlags_StartRight or GroupFlags_AlignRight or GroupFlags_StartTop or GroupFlags_AlignTop;


GroupFlags_GrowRightFromBottom

Declaration

Source position: nvtypes.pas line 115

const GroupFlags_GrowRightFromBottom = GroupFlags_LayoutHorizontal or GroupFlags_StartLeft or GroupFlags_AlignLeft or GroupFlags_StartBottom or GroupFlags_AlignBottom;


GroupFlags_GrowRightFromTop

Declaration

Source position: nvtypes.pas line 118

const GroupFlags_GrowRightFromTop = GroupFlags_LayoutHorizontal or GroupFlags_StartLeft or GroupFlags_AlignLeft or GroupFlags_StartTop or GroupFlags_AlignTop;


GroupFlags_GrowUpFromLeft

Declaration

Source position: nvtypes.pas line 121

const GroupFlags_GrowUpFromLeft = GroupFlags_LayoutVertical or GroupFlags_StartBottom or GroupFlags_AlignBottom or GroupFlags_StartLeft or GroupFlags_AlignLeft;


GroupFlags_GrowUpFromRight

Declaration

Source position: nvtypes.pas line 122

const GroupFlags_GrowUpFromRight = GroupFlags_LayoutVertical or GroupFlags_StartBottom or GroupFlags_AlignBottom or GroupFlags_StartRight or GroupFlags_AlignRight;


[Overview][Constants][Types][Classes][Procedures and functions][Index] Reference for unit 'nvTypes' (#nvidia-widgets)

GroupFlags_LayoutDefault

Declaration

Source position: nvtypes.pas line 112

const GroupFlags_LayoutDefault = $4000;


GroupFlags_LayoutDefaultFallback

Declaration

Source position: nvtypes.pas line 125

const GroupFlags_LayoutDefaultFallback = GroupFlags_GrowDownFromLeft;


[Overview][Constants][Types][Classes][Procedures and functions][Index] Reference for unit 'nvTypes' (#nvidia-widgets)

GroupFlags_LayoutForce

Declaration

Source position: nvtypes.pas line 111

const GroupFlags_LayoutForce = $8000;


[Overview][Constants][Types][Classes][Procedures and functions][Index] Reference for unit 'nvTypes' (#nvidia-widgets)

GroupFlags_LayoutHorizontal

Declaration

Source position: nvtypes.pas line 90

const GroupFlags_LayoutHorizontal = $04;


[Overview][Constants][Types][Classes][Procedures and functions][Index] Reference for unit 'nvTypes' (#nvidia-widgets)

GroupFlags_LayoutMask

Declaration

Source position: nvtypes.pas line 91

const GroupFlags_LayoutMask = $07;


[Overview][Constants][Types][Classes][Procedures and functions][Index] Reference for unit 'nvTypes' (#nvidia-widgets)

GroupFlags_LayoutNoMargin

Declaration

Source position: nvtypes.pas line 113

const GroupFlags_LayoutNoMargin = $2000;


[Overview][Constants][Types][Classes][Procedures and functions][Index] Reference for unit 'nvTypes' (#nvidia-widgets)

GroupFlags_LayoutNone

Declaration

Source position: nvtypes.pas line 88

const GroupFlags_LayoutNone = $01;


[Overview][Constants][Types][Classes][Procedures and functions][Index] Reference for unit 'nvTypes' (#nvidia-widgets)

GroupFlags_LayoutNoSpace

Declaration

Source position: nvtypes.pas line 114

const GroupFlags_LayoutNoSpace = $1000;


[Overview][Constants][Types][Classes][Procedures and functions][Index] Reference for unit 'nvTypes' (#nvidia-widgets)

GroupFlags_LayoutVertical

Declaration

Source position: nvtypes.pas line 89

const GroupFlags_LayoutVertical = $02;


GroupFlags_LayoutXMask

Declaration

Source position: nvtypes.pas line 92

const GroupFlags_LayoutXMask = $ffff xor GroupFlags_LayoutMask;


[Overview][Constants][Types][Classes][Procedures and functions][Index] Reference for unit 'nvTypes' (#nvidia-widgets)

GroupFlags_StartBottom

Declaration

Source position: nvtypes.pas line 106

const GroupFlags_StartBottom = $800;


[Overview][Constants][Types][Classes][Procedures and functions][Index] Reference for unit 'nvTypes' (#nvidia-widgets)

GroupFlags_StartLeft

Declaration

Source position: nvtypes.pas line 103

const GroupFlags_StartLeft = $100;


[Overview][Constants][Types][Classes][Procedures and functions][Index] Reference for unit 'nvTypes' (#nvidia-widgets)

GroupFlags_StartMask

Declaration

Source position: nvtypes.pas line 107

const GroupFlags_StartMask = $f00;


[Overview][Constants][Types][Classes][Procedures and functions][Index] Reference for unit 'nvTypes' (#nvidia-widgets)

GroupFlags_StartRight

Declaration

Source position: nvtypes.pas line 104

const GroupFlags_StartRight = $200;


[Overview][Constants][Types][Classes][Procedures and functions][Index] Reference for unit 'nvTypes' (#nvidia-widgets)

GroupFlags_StartTop

Declaration

Source position: nvtypes.pas line 105

const GroupFlags_StartTop = $400;


GroupFlags_StartXMask

Declaration

Source position: nvtypes.pas line 108

const GroupFlags_StartXMask = $ffff xor GroupFlags_StartMask;


[Overview][Constants][Types][Classes][Procedures and functions][Index] Reference for unit 'nvTypes' (#nvidia-widgets)

Reference for unit 'nvTypes'

Base types and constants

uses

  System,

  Classes,

  SysUtils;


Reference for unit 'nvTypes': Constants

ButtonFlags_Alt
ButtonFlags_Begin
ButtonFlags_Ctrl
ButtonFlags_End
ButtonFlags_Off
ButtonFlags_On
ButtonFlags_Shift
GroupFlags_AlignBottom
GroupFlags_AlignLeft
GroupFlags_AlignMask
GroupFlags_AlignRight
GroupFlags_AlignTop
GroupFlags_AlignXMask
GroupFlags_GrowDownFromLeft
GroupFlags_GrowDownFromRight
GroupFlags_GrowLeftFromBottom
GroupFlags_GrowLeftFromTop
GroupFlags_GrowRightFromBottom
GroupFlags_GrowRightFromTop
GroupFlags_GrowUpFromLeft
GroupFlags_GrowUpFromRight
GroupFlags_LayoutDefault
GroupFlags_LayoutDefaultFallback
GroupFlags_LayoutForce
GroupFlags_LayoutHorizontal
GroupFlags_LayoutMask
GroupFlags_LayoutNoMargin
GroupFlags_LayoutNone
GroupFlags_LayoutNoSpace
GroupFlags_LayoutVertical
GroupFlags_LayoutXMask
GroupFlags_StartBottom
GroupFlags_StartLeft
GroupFlags_StartMask
GroupFlags_StartRight
GroupFlags_StartTop
GroupFlags_StartXMask
Key_Down
Key_End
Key_F1
Key_F10
Key_F11
Key_F12
Key_F2
Key_F3
Key_F4
Key_F5
Key_F6
Key_F7
Key_F8
Key_F9
Key_Home
Key_Insert
Key_Left
Key_PageDown
Key_PageUp
Key_Right
Key_Up
MouseButton_Left | An enum to identify the left mouse button
MouseButton_Middle | An enum to identify the middle mouse button
MouseButton_Right | An enum to identify the right mouse button


[Overview][Constants][Types][Classes][Procedures and functions][Index] Reference for unit 'nvTypes' (#nvidia-widgets)

Reference for unit 'nvTypes': Types

ButtonState

Group

Group record

PGroup


[Overview][Constants][Types][Classes][Procedures and functions][Index] Reference for unit 'nvTypes' (#nvidia-widgets)

Reference for unit 'nvTypes': Classes

Point | 2D point object
Rect | Rectangle object


Reference for unit 'nvTypes': Procedures and functions

SetPoint | Helper function to initialize the point object
SetRect | Helper function to initialize the Rect object


Index of all identifiers in unit 'nvTypes'

B G K M P R S

B

ButtonFlags_Alt | ButtonFlags_End | ButtonFlags_Shift
ButtonFlags_Begin | ButtonFlags_Off | ButtonState
ButtonFlags_Ctrl | ButtonFlags_On |

G

Group | GroupFlags_GrowRightFromBottom | GroupFlags_LayoutNoSpace
GroupFlags_AlignBottom | GroupFlags_GrowRightFromTop | GroupFlags_LayoutVertical
GroupFlags_AlignLeft | GroupFlags_GrowUpFromLeft | GroupFlags_LayoutXMask
GroupFlags_AlignMask | GroupFlags_GrowUpFromRight | GroupFlags_StartBottom
GroupFlags_AlignRight | GroupFlags_LayoutDefault | GroupFlags_StartLeft
GroupFlags_AlignTop | GroupFlags_LayoutDefaultFallback | GroupFlags_StartMask
GroupFlags_AlignXMask | GroupFlags_LayoutForce | GroupFlags_StartRight
GroupFlags_GrowDownFromLeft | GroupFlags_LayoutHorizontal | GroupFlags_StartTop
GroupFlags_GrowDownFromRight | GroupFlags_LayoutMask | GroupFlags_StartXMask
GroupFlags_GrowLeftFromBottom | GroupFlags_LayoutNoMargin |
GroupFlags_GrowLeftFromTop | GroupFlags_LayoutNone |

K

Key_Down | Key_F3 | Key_Home
Key_End | Key_F4 | Key_Insert
Key_F1 | Key_F5 | Key_Left
Key_F10 | Key_F6 | Key_PageDown
Key_F11 | Key_F7 | Key_PageUp
Key_F12 | Key_F8 | Key_Right
Key_F2 | Key_F9 | Key_Up

M

MouseButton_Left MouseButton_Middle MouseButton_Right

P

PGroup Point

R

Rect

S

SetPoint SetRect


[Overview][Constants][Types][Classes][Procedures and functions][Index] Reference for unit 'nvTypes' (#nvidia-widgets)

Key_Down

Declaration

Source position: nvtypes.pas line 78

const Key_Down = 143;


[Overview][Constants][Types][Classes][Procedures and functions][Index] Reference for unit 'nvTypes' (#nvidia-widgets)

Key_End

Declaration

Source position: nvtypes.pas line 82

const Key_End = 147;


[Overview][Constants][Types][Classes][Procedures and functions][Index] Reference for unit 'nvTypes' (#nvidia-widgets)

Key_F1

Declaration

Source position: nvtypes.pas line 62

const Key_F1 = 128;


[Overview][Constants][Types][Classes][Procedures and functions][Index] Reference for unit 'nvTypes' (#nvidia-widgets)

Key_F2

Declaration

Source position: nvtypes.pas line 63

const Key_F2 = 129;


[Overview][Constants][Types][Classes][Procedures and functions][Index] Reference for unit 'nvTypes' (#nvidia-widgets)

Key_F3

Declaration

Source position: nvtypes.pas line 64

const Key_F3 = 130;


[Overview][Constants][Types][Classes][Procedures and functions][Index] Reference for unit 'nvTypes' (#nvidia-widgets)

Key_F4

Declaration

Source position: nvtypes.pas line 65

const Key_F4 = 131;


[Overview][Constants][Types][Classes][Procedures and functions][Index] Reference for unit 'nvTypes' (#nvidia-widgets)

Key_F5

Declaration

Source position: nvtypes.pas line 66

const Key_F5 = 132;


[Overview][Constants][Types][Classes][Procedures and functions][Index] Reference for unit 'nvTypes' (#nvidia-widgets)

Key_F6

Declaration

Source position: nvtypes.pas line 67

const Key_F6 = 133;


[Overview][Constants][Types][Classes][Procedures and functions][Index] Reference for unit 'nvTypes' (#nvidia-widgets)

Key_F7

Declaration

Source position: nvtypes.pas line 68

const Key_F7 = 134;


[Overview][Constants][Types][Classes][Procedures and functions][Index] Reference for unit 'nvTypes' (#nvidia-widgets)

Key_F8

Declaration

Source position: nvtypes.pas line 69

const Key_F8 = 135;


[Overview][Constants][Types][Classes][Procedures and functions][Index] Reference for unit 'nvTypes' (#nvidia-widgets)

Key_F9

Declaration

Source position: nvtypes.pas line 70

const Key_F9 = 136;


[Overview][Constants][Types][Classes][Procedures and functions][Index] Reference for unit 'nvTypes' (#nvidia-widgets)

Key_F10

Declaration

Source position: nvtypes.pas line 71

const Key_F10 = 137;


[Overview][Constants][Types][Classes][Procedures and functions][Index] Reference for unit 'nvTypes' (#nvidia-widgets)

Key_F11

Declaration

Source position: nvtypes.pas line 72

const Key_F11 = 138;


[Overview][Constants][Types][Classes][Procedures and functions][Index] Reference for unit 'nvTypes' (#nvidia-widgets)

Key_F12

Declaration

Source position: nvtypes.pas line 73

const Key_F12 = 139;


[Overview][Constants][Types][Classes][Procedures and functions][Index] Reference for unit 'nvTypes' (#nvidia-widgets)

Key_Home

Declaration

Source position: nvtypes.pas line 81

const Key_Home = 146;


[Overview][Constants][Types][Classes][Procedures and functions][Index] Reference for unit 'nvTypes' (#nvidia-widgets)

Key_Insert

Declaration

Source position: nvtypes.pas line 83

const Key_Insert = 148;


[Overview][Constants][Types][Classes][Procedures and functions][Index] Reference for unit 'nvTypes' (#nvidia-widgets)

Key_Left

Declaration

Source position: nvtypes.pas line 75

const Key_Left = 140;


[Overview][Constants][Types][Classes][Procedures and functions][Index] Reference for unit 'nvTypes' (#nvidia-widgets)

Key_PageDown

Declaration

Source position: nvtypes.pas line 80

const Key_PageDown = 145;


[Overview][Constants][Types][Classes][Procedures and functions][Index] Reference for unit 'nvTypes' (#nvidia-widgets)

Key_PageUp

Declaration

Source position: nvtypes.pas line 79

const Key_PageUp = 144;


[Overview][Constants][Types][Classes][Procedures and functions][Index] Reference for unit 'nvTypes' (#nvidia-widgets)

Key_Right

Declaration

Source position: nvtypes.pas line 77

const Key_Right = 142;


[Overview][Constants][Types][Classes][Procedures and functions][Index] Reference for unit 'nvTypes' (#nvidia-widgets)

Key_Up

Declaration

Source position: nvtypes.pas line 76

const Key_Up = 141;


MouseButton_Left

An enum to identify the left mouse button

Declaration

Source position: nvtypes.pas line 57

const MouseButton_Left = 1;


MouseButton_Middle

An enum to identify the middle mouse button

Declaration

Source position: nvtypes.pas line 58

const MouseButton_Middle = 2;


MouseButton_Right

An enum to identify the right mouse button

Declaration

Source position: nvtypes.pas line 59

const MouseButton_Right = 3;


[Overview][Constants][Types][Classes][Procedures and functions][Index] Reference for unit 'nvTypes' (#nvidia-widgets)

PGroup

Declaration

Source position: nvtypes.pas line 134

type PGroup = ^Group;


Point


Point

Point


Point (Point)


Point.Point

Constructor for the Point object

Declaration

Source position: line 0

constructor Point.Point;

constructor Point.Point(

  ix: Integer;

  iy: Integer

);

constructor Point.Point(

  const p: Point

);


[Overview][Constants][Types][Classes][Procedures and functions][Index] Reference for unit 'nvTypes' (#nvidia-widgets)

Point.x

X location

Declaration

Source position: nvtypes.pas line 15

Point.x: Integer;


[Overview][Constants][Types][Classes][Procedures and functions][Index] Reference for unit 'nvTypes' (#nvidia-widgets)

Point.y

Y location

Declaration

Source position: nvtypes.pas line 15

Point.y: Integer;


Rect


Rect

Rect


Rect (Rect)


[Overview][Constants][Types][Classes][Procedures and functions][Index] Reference for unit 'nvTypes' (#nvidia-widgets)

Rect.h

Height of rectangle

Declaration

Source position: nvtypes.pas line 28

Rect.h: Integer;


Rect.Rect

Constructor for the Rect object

Declaration

Source position: line 0

constructor Rect.Rect;

constructor Rect.Rect(

  const p: TPoint

);

constructor Rect.Rect(

  ix: Integer;

  iy: Integer;

  iw: Integer = 0;

  ih: Integer = 0

);

constructor Rect.Rect(

  const r: Rect

);


[Overview][Constants][Types][Classes][Procedures and functions][Index] Reference for unit 'nvTypes' (#nvidia-widgets)

Rect.w

Width of rectangle

Declaration

Source position: nvtypes.pas line 28

Rect.w: Integer;


[Overview][Constants][Types][Classes][Procedures and functions][Index] Reference for unit 'nvTypes' (#nvidia-widgets)

Rect.x

X position of top left point

Declaration

Source position: nvtypes.pas line 28

Rect.x: Integer;


[Overview][Constants][Types][Classes][Procedures and functions][Index] Reference for unit 'nvTypes' (#nvidia-widgets)

Rect.y

Y position of top left point

Declaration

Source position: nvtypes.pas line 28

Rect.y: Integer;