Classes

FPSpreadsheet
Classes

The following table lists classes in this documentation.

Classes
Name | Description
TsCellCombobox | TsCellCombobox is a multi-purpose combobox for selection of formatting items of a cell
TsCellEdit | TsCellEdit allows to edit the content or formula of the active cell of a worksheet, simular to Excel's cell editor above the cell grid.
TsCellIndicator | TsCellIndicator displays the address of the currently active cell of the worksheet and workbook. Editing the address allows to jump to the corresponding cell.
TsCellList |
TsCustomWorksheetGrid | TsCustomWorksheetGrid is the ancestor of TsWorksheetGrid and is able to display spreadsheet data along with their formatting.
TsNumFormatList | List containing parsed number format parameters
TsNumFormatParams | Describes a parsed number format and provides all the information to convert a number to a number or date/time string. These data are created by the number format parser from a format string.
TsSelPen |
TsSpreadsheetInspector | TsSpreadsheetInspector displays all properties of a workbook, worksheet, cell content and cell formatting in a way similar to the Object Inspector of Lazarus.
TsWorkbook |
TsWorkbookSource | TsWorkbookSource links a workbook to the visual spreadsheet controls and help to display or edit the workbook without written code.
TsWorkbookTabControl | TsWorkbookTabControl is a tab control which displays the sheets of the workbook currently loaded by the WorkbookSource in tabs. Selecting another tab is communicated to other spreadsheet controls via the WorkbookSource.
TsWorksheet | The worksheet contains a list of cells and provides a variety of methods to read or write data to the cells, or to change their formatting.
TsWorksheetGrid | TsWorksheetGrid is a grid which displays spreadsheet data along with formatting. As it is linked to an instance of TsWorkbook, it provides methods for reading data from or writing to spreadsheet files. It has the same funtionality as TsCustomWorksheetGrid, but has published all properties.
Copyright (c) 2008-2015

Made with Doc-O-Matic® Express


TsCellCombobox Class

TsCellCombobox Class
Class Hierarchy
  TsCellComboboxTsCellCombobox
Syntax
Pascal
TsCellCombobox = class(TCustomCombobox, IsSpreadsheetControl);
File

fpspreadsheetctrls

Description

TsCellCombobox is a multi-purpose combobox for selection of formatting items of a cell

Group

Classes


TsCellCombobox Members

TsCellCombobox Members

The following tables list the members exposed by TsCellCombobox.

Class

TsCellCombobox Class

Protected Methods
Name | Description
ApplyFormatToCell | Applies the format to a cell. Override according to the format item for which the combobox is responsible.
Change | The text of the currently selected combobox item has been changed. Calls "ProcessValue" to changes the selected cells according to the Mode property by calling ApplyFormatToCell.
DrawItem | Customdraws an item in the combobox. This is overridden to paint a color box for the color-related format items.
ExtractFromCell | Extracts the format item the combobox is responsible for from the cell and selectes the corresponding combobox item.
GetActiveCell | Returns the currently active cell of the worksheet
Loaded | Standard method. Overridden to populate combobox since items are not stored in lfm file.
Notification | Standard component notification method called when the WorkbookSource is deleted.
Populate | Descendants override this method to populate the items of the combobox. Color index into the workbook's palette is stored in the "Objects" property.
ProcessItem | Processes the selected combobox item after a new item has been selected or the item text has been edited. Changes the selected cells according to the Mode property by calling ApplyFormatToCell.
Select | A new item in the combobox is selected. Calls "ProcessValue" to changes the selected cells according to the Mode property by calling ApplyFormatToCell.
Protected Properties
Name | Description
Items |
Public Methods
Name | Description
Create | Constructor of the Cell Combobox. Populates the items list
Destroy | Destructor of the WorkbookTabControl. Removes itself from the WorkbookSource's listener list.
ListenerNotification | Notification procedure received whenver "something" changes in the workbook. Reacts on all events.
RemoveWorkbookSource | Removes the link of the CellCombobox to the WorkbookSource. Required before destruction.
Public Properties
Name | Description
Workbook | Refers to the underlying workbook
Worksheet | Refers to the underlying worksheet containing the displayed cell
Published Properties
Name | Description
Align |
Anchors |
ArrowKeysTraverseList |
AutoComplete |
AutoCompleteText |
AutoDropDown |
AutoSelect |
AutoSize |
BidiMode |
BorderSpacing |
BorderStyle |
CellFormatItem | Identifies the cell format property to be used in the combobox
CharCase |
Color |
ColorRectOffset | Margin around the color box
ColorRectWidth | Width of the color box shown for the color-related format items
Constraints |
DragCursor |
DragKind |
DragMode |
DropDownCount |
Enabled |
Font |
ItemIndex |
ItemWidth |
MaxLength |
OnChange |
OnChangeBounds |
OnClick |
OnCloseUp |
OnContextPopup |
OnDblClick |
OnDragDrop |
OnDragOver |
OnDrawItem |
OnDropDown |
OnEditingDone |
OnEndDrag |
OnEnter |
OnExit |
OnGetItems |
OnKeyDown |
OnKeyPress |
OnKeyUp |
OnMeasureItem |
OnMouseDown |
OnMouseEnter |
OnMouseLeave |
OnMouseMove |
OnMouseUp |
OnMouseWheel |
OnMouseWheelDown |
OnMouseWheelUp |
OnSelect |
OnStartDrag |
OnUTF8KeyPress |
ParentBidiMode |
ParentColor |
ParentFont |
ParentShowHint |
PopupMenu |
ShowHint |
Sorted |
TabOrder |
TabStop |
Text |
Visible |
WorkbookSource | Link to the WorkbookSource which provides the workbook and worksheet.


TsCellCombobox.Create Constructor

TsCellCombobox.Create Constructor
Syntax
Pascal
constructor Create(AOwner: TComponent); override;
Description

Constructor of the Cell Combobox. Populates the items list

Class

TsCellCombobox Class


TsCellCombobox.Destroy Destructor

TsCellCombobox.Destroy Destructor
Syntax
Pascal
destructor Destroy; override;
Description

Destructor of the WorkbookTabControl. Removes itself from the WorkbookSource's listener list.

Class

TsCellCombobox Class


TsCellCombobox Methods

TsCellCombobox Methods

The methods of the TsCellCombobox class are listed here.

Class

TsCellCombobox Class

Protected Methods
Name | Description
ApplyFormatToCell | Applies the format to a cell. Override according to the format item for which the combobox is responsible.
Change | The text of the currently selected combobox item has been changed. Calls "ProcessValue" to changes the selected cells according to the Mode property by calling ApplyFormatToCell.
DrawItem | Customdraws an item in the combobox. This is overridden to paint a color box for the color-related format items.
ExtractFromCell | Extracts the format item the combobox is responsible for from the cell and selectes the corresponding combobox item.
GetActiveCell | Returns the currently active cell of the worksheet
Loaded | Standard method. Overridden to populate combobox since items are not stored in lfm file.
Notification | Standard component notification method called when the WorkbookSource is deleted.
Populate | Descendants override this method to populate the items of the combobox. Color index into the workbook's palette is stored in the "Objects" property.
ProcessItem | Processes the selected combobox item after a new item has been selected or the item text has been edited. Changes the selected cells according to the Mode property by calling ApplyFormatToCell.
Select | A new item in the combobox is selected. Calls "ProcessValue" to changes the selected cells according to the Mode property by calling ApplyFormatToCell.
Public Methods
Name | Description
ListenerNotification | Notification procedure received whenver "something" changes in the workbook. Reacts on all events.
RemoveWorkbookSource | Removes the link of the CellCombobox to the WorkbookSource. Required before destruction.


TsCellCombobox.ApplyFormatToCell Method

TsCellCombobox.ApplyFormatToCell Method
Syntax
Pascal
procedure ApplyFormatToCell(ACell: PCell); virtual;
Description

Applies the format to a cell. Override according to the format item for which the combobox is responsible.

Group

TsCellCombobox Methods


TsCellCombobox.Change Method

TsCellCombobox.Change Method
Syntax
Pascal
procedure Change; override;
Description

The text of the currently selected combobox item has been changed. Calls "ProcessValue" to changes the selected cells according to the Mode property by calling ApplyFormatToCell.

Group

TsCellCombobox Methods


TsCellCombobox.DrawItem Method

TsCellCombobox.DrawItem Method
Syntax
Pascal
procedure DrawItem(AIndex: Integer; ARect: TRect; AState: TOwnerDrawState); override;
Description

Customdraws an item in the combobox. This is overridden to paint a color box for the color-related format items.

Group

TsCellCombobox Methods


TsCellCombobox.ExtractFromCell Method

TsCellCombobox.ExtractFromCell Method
Syntax
Pascal
procedure ExtractFromCell(ACell: PCell); virtual;
Description

Extracts the format item the combobox is responsible for from the cell and selectes the corresponding combobox item.

Group

TsCellCombobox Methods


TsCellCombobox.GetActiveCell Method

TsCellCombobox.GetActiveCell Method
Syntax
Pascal
function GetActiveCell: PCell;
Description

Returns the currently active cell of the worksheet

Group

TsCellCombobox Methods


TsCellCombobox.ListenerNotification Method

TsCellCombobox.ListenerNotification Method
Syntax
Pascal
procedure ListenerNotification(AChangedItems: TsNotificationItems; AData: Pointer = nil);
Parameters
Parameters | Description
AChangedItems: TsNotificationItems | Set with elements identifying whether workbook, worksheet cell or selection has changed.
AData: Pointer = nil | If AChangedItems contains nliCell then AData points to the modified cell.
Description

Notification procedure received whenver "something" changes in the workbook. Reacts on all events.

Group

TsCellCombobox Methods


TsCellCombobox.Loaded Method

TsCellCombobox.Loaded Method
Syntax
Pascal
procedure Loaded; override;
Description

Standard method. Overridden to populate combobox since items are not stored in lfm file.

Group

TsCellCombobox Methods


TsCellCombobox.Notification Method

TsCellCombobox.Notification Method
Syntax
Pascal
procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Description

Standard component notification method called when the WorkbookSource is deleted.

Group

TsCellCombobox Methods


TsCellCombobox.Populate Method

TsCellCombobox.Populate Method
Syntax
Pascal
procedure Populate; virtual;
Description

Descendants override this method to populate the items of the combobox. Color index into the workbook's palette is stored in the "Objects" property.

Group

TsCellCombobox Methods


TsCellCombobox.ProcessItem Method

TsCellCombobox.ProcessItem Method
Syntax
Pascal
procedure ProcessItem;
Description

Processes the selected combobox item after a new item has been selected or the item text has been edited. Changes the selected cells according to the Mode property by calling ApplyFormatToCell.

Group

TsCellCombobox Methods


TsCellCombobox.RemoveWorkbookSource Method

TsCellCombobox.RemoveWorkbookSource Method
Syntax
Pascal
procedure RemoveWorkbookSource;
Description

Removes the link of the CellCombobox to the WorkbookSource. Required before destruction.

Group

TsCellCombobox Methods


TsCellCombobox.Select Method

TsCellCombobox.Select Method
Syntax
Pascal
procedure Select; override;
Description

A new item in the combobox is selected. Calls "ProcessValue" to changes the selected cells according to the Mode property by calling ApplyFormatToCell.

Group

TsCellCombobox Methods


TsCellCombobox Properties

TsCellCombobox Properties

The properties of the TsCellCombobox class are listed here.

Class

TsCellCombobox Class

Protected Properties
Name | Description
Items |
Public Properties
Name | Description
Workbook | Refers to the underlying workbook
Worksheet | Refers to the underlying worksheet containing the displayed cell
Published Properties
Name | Description
Align |
Anchors |
ArrowKeysTraverseList |
AutoComplete |
AutoCompleteText |
AutoDropDown |
AutoSelect |
AutoSize |
BidiMode |
BorderSpacing |
BorderStyle |
CellFormatItem | Identifies the cell format property to be used in the combobox
CharCase |
Color |
ColorRectOffset | Margin around the color box
ColorRectWidth | Width of the color box shown for the color-related format items
Constraints |
DragCursor |
DragKind |
DragMode |
DropDownCount |
Enabled |
Font |
ItemIndex |
ItemWidth |
MaxLength |
OnChange |
OnChangeBounds |
OnClick |
OnCloseUp |
OnContextPopup |
OnDblClick |
OnDragDrop |
OnDragOver |
OnDrawItem |
OnDropDown |
OnEditingDone |
OnEndDrag |
OnEnter |
OnExit |
OnGetItems |
OnKeyDown |
OnKeyPress |
OnKeyUp |
OnMeasureItem |
OnMouseDown |
OnMouseEnter |
OnMouseLeave |
OnMouseMove |
OnMouseUp |
OnMouseWheel |
OnMouseWheelDown |
OnMouseWheelUp |
OnSelect |
OnStartDrag |
OnUTF8KeyPress |
ParentBidiMode |
ParentColor |
ParentFont |
ParentShowHint |
PopupMenu |
ShowHint |
Sorted |
TabOrder |
TabStop |
Text |
Visible |
WorkbookSource | Link to the WorkbookSource which provides the workbook and worksheet.


TsCellCombobox.Align Property

TsCellCombobox.Align Property
Syntax
Pascal
property Align;
Group

TsCellCombobox Properties


TsCellCombobox.Anchors Property

TsCellCombobox.Anchors Property
Syntax
Pascal
property Anchors;
Group

TsCellCombobox Properties


TsCellCombobox.ArrowKeysTraverseList Property

TsCellCombobox.ArrowKeysTraverseList Property
Syntax
Pascal
property ArrowKeysTraverseList;
Group

TsCellCombobox Properties


TsCellCombobox.AutoComplete Property

TsCellCombobox.AutoComplete Property
Syntax
Pascal
property AutoComplete;
Group

TsCellCombobox Properties


TsCellCombobox.AutoCompleteText Property

TsCellCombobox.AutoCompleteText Property
Syntax
Pascal
property AutoCompleteText;
Group

TsCellCombobox Properties


TsCellCombobox.AutoDropDown Property

TsCellCombobox.AutoDropDown Property
Syntax
Pascal
property AutoDropDown;
Group

TsCellCombobox Properties


TsCellCombobox.AutoSelect Property

TsCellCombobox.AutoSelect Property
Syntax
Pascal
property AutoSelect;
Group

TsCellCombobox Properties


TsCellCombobox.AutoSize Property

TsCellCombobox.AutoSize Property
Syntax
Pascal
property AutoSize;
Group

TsCellCombobox Properties


TsCellCombobox.BidiMode Property

TsCellCombobox.BidiMode Property
Syntax
Pascal
property BidiMode;
Group

TsCellCombobox Properties


TsCellCombobox.BorderSpacing Property

TsCellCombobox.BorderSpacing Property
Syntax
Pascal
property BorderSpacing;
Group

TsCellCombobox Properties


TsCellCombobox.BorderStyle Property

TsCellCombobox.BorderStyle Property
Syntax
Pascal
property BorderStyle;
Group

TsCellCombobox Properties


TsCellCombobox.CellFormatItem Property

TsCellCombobox.CellFormatItem Property
Syntax
Pascal
property CellFormatItem: TsCellFormatItem;
Description

Identifies the cell format property to be used in the combobox

Group

TsCellCombobox Properties


TsCellCombobox.CharCase Property

TsCellCombobox.CharCase Property
Syntax
Pascal
property CharCase;
Group

TsCellCombobox Properties


TsCellCombobox.Color Property

TsCellCombobox.Color Property
Syntax
Pascal
property Color;
Group

TsCellCombobox Properties


TsCellCombobox.ColorRectOffset Property

TsCellCombobox.ColorRectOffset Property
Syntax
Pascal
property ColorRectOffset: Integer;
Description

Margin around the color box

Group

TsCellCombobox Properties


TsCellCombobox.ColorRectWidth Property

TsCellCombobox.ColorRectWidth Property
Syntax
Pascal
property ColorRectWidth: Integer;
Description

Width of the color box shown for the color-related format items

Group

TsCellCombobox Properties


TsCellCombobox.Constraints Property

TsCellCombobox.Constraints Property
Syntax
Pascal
property Constraints;
Group

TsCellCombobox Properties


TsCellCombobox.DragCursor Property

TsCellCombobox.DragCursor Property
Syntax
Pascal
property DragCursor;
Group

TsCellCombobox Properties


TsCellCombobox.DragKind Property

TsCellCombobox.DragKind Property
Syntax
Pascal
property DragKind;
Group

TsCellCombobox Properties


TsCellCombobox.DragMode Property

TsCellCombobox.DragMode Property
Syntax
Pascal
property DragMode;
Group

TsCellCombobox Properties


TsCellCombobox.DropDownCount Property

TsCellCombobox.DropDownCount Property
Syntax
Pascal
property DropDownCount;
Group

TsCellCombobox Properties


TsCellCombobox.Enabled Property

TsCellCombobox.Enabled Property
Syntax
Pascal
property Enabled;
Group

TsCellCombobox Properties


TsCellCombobox.Font Property

TsCellCombobox.Font Property
Syntax
Pascal
property Font;
Group

TsCellCombobox Properties


TsCellCombobox.ItemIndex Property

TsCellCombobox.ItemIndex Property
Syntax
Pascal
property ItemIndex;
Group

TsCellCombobox Properties


TsCellCombobox.Items Property

TsCellCombobox.Items Property
Syntax
Pascal
property Items;
Group

TsCellCombobox Properties


TsCellCombobox.ItemWidth Property

TsCellCombobox.ItemWidth Property
Syntax
Pascal
property ItemWidth;
Group

TsCellCombobox Properties


TsCellCombobox.MaxLength Property

TsCellCombobox.MaxLength Property
Syntax
Pascal
property MaxLength;
Group

TsCellCombobox Properties


TsCellCombobox.OnChange Property

TsCellCombobox.OnChange Property
Syntax
Pascal
property OnChange;
Group

TsCellCombobox Properties


TsCellCombobox.OnChangeBounds Property

TsCellCombobox.OnChangeBounds Property
Syntax
Pascal
property OnChangeBounds;
Group

TsCellCombobox Properties


TsCellCombobox.OnClick Property

TsCellCombobox.OnClick Property
Syntax
Pascal
property OnClick;
Group

TsCellCombobox Properties


TsCellCombobox.OnCloseUp Property

TsCellCombobox.OnCloseUp Property
Syntax
Pascal
property OnCloseUp;
Group

TsCellCombobox Properties


TsCellCombobox.OnContextPopup Property

TsCellCombobox.OnContextPopup Property
Syntax
Pascal
property OnContextPopup;
Group

TsCellCombobox Properties


TsCellCombobox.OnDblClick Property

TsCellCombobox.OnDblClick Property
Syntax
Pascal
property OnDblClick;
Group

TsCellCombobox Properties


TsCellCombobox.OnDragDrop Property

TsCellCombobox.OnDragDrop Property
Syntax
Pascal
property OnDragDrop;
Group

TsCellCombobox Properties


TsCellCombobox.OnDragOver Property

TsCellCombobox.OnDragOver Property
Syntax
Pascal
property OnDragOver;
Group

TsCellCombobox Properties


TsCellCombobox.OnDrawItem Property

TsCellCombobox.OnDrawItem Property
Syntax
Pascal
property OnDrawItem;
Group

TsCellCombobox Properties


TsCellCombobox.OnDropDown Property

TsCellCombobox.OnDropDown Property
Syntax
Pascal
property OnDropDown;
Group

TsCellCombobox Properties


TsCellCombobox.OnEditingDone Property

TsCellCombobox.OnEditingDone Property
Syntax
Pascal
property OnEditingDone;
Group

TsCellCombobox Properties


TsCellCombobox.OnEndDrag Property

TsCellCombobox.OnEndDrag Property
Syntax
Pascal
property OnEndDrag;
Group

TsCellCombobox Properties


TsCellCombobox.OnEnter Property

TsCellCombobox.OnEnter Property
Syntax
Pascal
property OnEnter;
Group

TsCellCombobox Properties


TsCellCombobox.OnExit Property

TsCellCombobox.OnExit Property
Syntax
Pascal
property OnExit;
Group

TsCellCombobox Properties


TsCellCombobox.OnGetItems Property

TsCellCombobox.OnGetItems Property
Syntax
Pascal
property OnGetItems;
Group

TsCellCombobox Properties


TsCellCombobox.OnKeyDown Property

TsCellCombobox.OnKeyDown Property
Syntax
Pascal
property OnKeyDown;
Group

TsCellCombobox Properties


TsCellCombobox.OnKeyPress Property

TsCellCombobox.OnKeyPress Property
Syntax
Pascal
property OnKeyPress;
Group

TsCellCombobox Properties


TsCellCombobox.OnKeyUp Property

TsCellCombobox.OnKeyUp Property
Syntax
Pascal
property OnKeyUp;
Group

TsCellCombobox Properties


TsCellCombobox.OnMeasureItem Property

TsCellCombobox.OnMeasureItem Property
Syntax
Pascal
property OnMeasureItem;
Group

TsCellCombobox Properties


TsCellCombobox.OnMouseDown Property

TsCellCombobox.OnMouseDown Property
Syntax
Pascal
property OnMouseDown;
Group

TsCellCombobox Properties


TsCellCombobox.OnMouseEnter Property

TsCellCombobox.OnMouseEnter Property
Syntax
Pascal
property OnMouseEnter;
Group

TsCellCombobox Properties


TsCellCombobox.OnMouseLeave Property

TsCellCombobox.OnMouseLeave Property
Syntax
Pascal
property OnMouseLeave;
Group

TsCellCombobox Properties


TsCellCombobox.OnMouseMove Property

TsCellCombobox.OnMouseMove Property
Syntax
Pascal
property OnMouseMove;
Group

TsCellCombobox Properties


TsCellCombobox.OnMouseUp Property

TsCellCombobox.OnMouseUp Property
Syntax
Pascal
property OnMouseUp;
Group

TsCellCombobox Properties


TsCellCombobox.OnMouseWheel Property

TsCellCombobox.OnMouseWheel Property
Syntax
Pascal
property OnMouseWheel;
Group

TsCellCombobox Properties


TsCellCombobox.OnMouseWheelDown Property

TsCellCombobox.OnMouseWheelDown Property
Syntax
Pascal
property OnMouseWheelDown;
Group

TsCellCombobox Properties


TsCellCombobox.OnMouseWheelUp Property

TsCellCombobox.OnMouseWheelUp Property
Syntax
Pascal
property OnMouseWheelUp;
Group

TsCellCombobox Properties


TsCellCombobox.OnSelect Property

TsCellCombobox.OnSelect Property
Syntax
Pascal
property OnSelect;
Group

TsCellCombobox Properties


TsCellCombobox.OnStartDrag Property

TsCellCombobox.OnStartDrag Property
Syntax
Pascal
property OnStartDrag;
Group

TsCellCombobox Properties


TsCellCombobox.OnUTF8KeyPress Property

TsCellCombobox.OnUTF8KeyPress Property
Syntax
Pascal
property OnUTF8KeyPress;
Group

TsCellCombobox Properties


TsCellCombobox.ParentBidiMode Property

TsCellCombobox.ParentBidiMode Property
Syntax
Pascal
property ParentBidiMode;
Group

TsCellCombobox Properties


TsCellCombobox.ParentColor Property

TsCellCombobox.ParentColor Property
Syntax
Pascal
property ParentColor;
Group

TsCellCombobox Properties


TsCellCombobox.ParentFont Property

TsCellCombobox.ParentFont Property
Syntax
Pascal
property ParentFont;
Group

TsCellCombobox Properties


TsCellCombobox.ParentShowHint Property

TsCellCombobox.ParentShowHint Property
Syntax
Pascal
property ParentShowHint;
Group

TsCellCombobox Properties


TsCellCombobox.PopupMenu Property

TsCellCombobox.PopupMenu Property
Syntax
Pascal
property PopupMenu;
Group

TsCellCombobox Properties


TsCellCombobox.ShowHint Property

TsCellCombobox.ShowHint Property
Syntax
Pascal
property ShowHint;
Group

TsCellCombobox Properties


TsCellCombobox.Sorted Property

TsCellCombobox.Sorted Property
Syntax
Pascal
property Sorted;
Group

TsCellCombobox Properties


TsCellCombobox.TabOrder Property

TsCellCombobox.TabOrder Property
Syntax
Pascal
property TabOrder;
Group

TsCellCombobox Properties


TsCellCombobox.TabStop Property

TsCellCombobox.TabStop Property
Syntax
Pascal
property TabStop;
Group

TsCellCombobox Properties


TsCellCombobox.Text Property

TsCellCombobox.Text Property
Syntax
Pascal
property Text;
Group

TsCellCombobox Properties


TsCellCombobox.Visible Property

TsCellCombobox.Visible Property
Syntax
Pascal
property Visible;
Group

TsCellCombobox Properties


TsCellCombobox.Workbook Property

TsCellCombobox.Workbook Property
Syntax
Pascal
property Workbook: TsWorkbook;
Description

Refers to the underlying workbook

Group

TsCellCombobox Properties


TsCellCombobox.WorkbookSource Property

TsCellCombobox.WorkbookSource Property
Syntax
Pascal
property WorkbookSource: TsWorkbookSource;
Description

Link to the WorkbookSource which provides the workbook and worksheet.

Group

TsCellCombobox Properties


TsCellCombobox.Worksheet Property

TsCellCombobox.Worksheet Property
Syntax
Pascal
property Worksheet: TsWorksheet;
Description

Refers to the underlying worksheet containing the displayed cell

Group

TsCellCombobox Properties


TsCellEdit Class

TsCellEdit Class
Class Hierarchy
  TsCellEditTsCellEdit
Syntax
Pascal
TsCellEdit = class(TMemo, IsSpreadsheetControl);
File

fpspreadsheetctrls

Description

TsCellEdit allows to edit the content or formula of the active cell of a worksheet, simular to Excel's cell editor above the cell grid.

Group

Classes


TsCellEdit Members

TsCellEdit Members

The following tables list the members exposed by TsCellEdit.

Class

TsCellEdit Class

Protected Methods
Name | Description
Notification | Standard component notification. Called when the WorkbookSource is deleted.
ShowCell | Loads the contents of a cell into the editor. Shows the formula if available, but not the calculation result. Numbers are displayed in full precision. Date and time values are shown in the long formats.
Public Methods
Name | Description
Create | Constructor of the spreadsheet edit control. Disables RETURN and TAB keys. RETURN characters can still be entered into the edited text by pressing CTRL+RETURN
Destroy | Destructor of the TsCellEdit. Removes itself from the WorkbookSource's listener list.
EditingDone | EditingDone is called when the user presses the RETURN key to finish editing, or the TAB key which removes focus from the control, or clicks somewhere else The edited text is written to the worksheet which tries to figure out the data type. In particular, if the text begins with an equal sign ("=") then the text is assumed to be a formula.
ListenerNotification | Notification message received from the WorkbookSource telling which item of the spreadsheet has changed. Responds to selection and cell changes by updating the cell content.
RemoveWorkbookSource | Removes the link of the CellEdit to the WorkbookSource. Required before destruction.
Public Properties
Name | Description
SelectedCell | Pointer to the currently active cell in the workbook. This cell is displayed in the control and can be edited.
Workbook | Refers to the underlying workbook to which the edited cell belongs.
Worksheet | Refers to the underlying worksheet to which the edited cell belongs.
Published Properties
Name | Description
ShowHTMLText |
WorkbookSource | Link to the WorkbookSource which provides the workbook and worksheet.


TsCellEdit.Create Constructor

TsCellEdit.Create Constructor
Syntax
Pascal
constructor Create(AOwner: TComponent); override;
Parameters
Parameters | Description
AOwner: TComponent | Component which is responsible to destroy the CellEdit
Description

Constructor of the spreadsheet edit control. Disables RETURN and TAB keys. RETURN characters can still be entered into the edited text by pressing CTRL+RETURN

Class

TsCellEdit Class


TsCellEdit.Destroy Destructor

TsCellEdit.Destroy Destructor
Syntax
Pascal
destructor Destroy; override;
Description

Destructor of the TsCellEdit. Removes itself from the WorkbookSource's listener list.

Class

TsCellEdit Class


TsCellEdit Methods

TsCellEdit Methods

The methods of the TsCellEdit class are listed here.

Class

TsCellEdit Class

Protected Methods
Name | Description
Notification | Standard component notification. Called when the WorkbookSource is deleted.
ShowCell | Loads the contents of a cell into the editor. Shows the formula if available, but not the calculation result. Numbers are displayed in full precision. Date and time values are shown in the long formats.
Public Methods
Name | Description
EditingDone | EditingDone is called when the user presses the RETURN key to finish editing, or the TAB key which removes focus from the control, or clicks somewhere else The edited text is written to the worksheet which tries to figure out the data type. In particular, if the text begins with an equal sign ("=") then the text is assumed to be a formula.
ListenerNotification | Notification message received from the WorkbookSource telling which item of the spreadsheet has changed. Responds to selection and cell changes by updating the cell content.
RemoveWorkbookSource | Removes the link of the CellEdit to the WorkbookSource. Required before destruction.


TsCellEdit.EditingDone Method

TsCellEdit.EditingDone Method
Syntax
Pascal
procedure EditingDone; override;
Description

EditingDone is called when the user presses the RETURN key to finish editing, or the TAB key which removes focus from the control, or clicks somewhere else The edited text is written to the worksheet which tries to figure out the data type. In particular, if the text begins with an equal sign ("=") then the text is assumed to be a formula.

Group

TsCellEdit Methods


TsCellEdit.ListenerNotification Method

TsCellEdit.ListenerNotification Method
Syntax
Pascal
procedure ListenerNotification(AChangedItems: TsNotificationItems; AData: Pointer = nil);
Parameters
Parameters | Description
AChangedItems: TsNotificationItems | Set with elements identifying whether workbook, worksheet cell content or cell formatting has changed
AData: Pointer = nil | If AChangedItems contains nliCell then AData points to the modified cell.
Description

Notification message received from the WorkbookSource telling which item of the spreadsheet has changed. Responds to selection and cell changes by updating the cell content.

Group

TsCellEdit Methods


TsCellEdit.Notification Method

TsCellEdit.Notification Method
Syntax
Pascal
procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Description

Standard component notification. Called when the WorkbookSource is deleted.

Group

TsCellEdit Methods


TsCellEdit.RemoveWorkbookSource Method

TsCellEdit.RemoveWorkbookSource Method
Syntax
Pascal
procedure RemoveWorkbookSource;
Description

Removes the link of the CellEdit to the WorkbookSource. Required before destruction.

Group

TsCellEdit Methods


TsCellEdit.ShowCell Method

TsCellEdit.ShowCell Method
Syntax
Pascal
procedure ShowCell(ACell: PCell); virtual;
Parameters
Parameters | Description
ACell: PCell | Pointer to the cell loaded into the cell editor.
Description

Loads the contents of a cell into the editor. Shows the formula if available, but not the calculation result. Numbers are displayed in full precision. Date and time values are shown in the long formats.

Group

TsCellEdit Methods


TsCellEdit Properties

TsCellEdit Properties

The properties of the TsCellEdit class are listed here.

Class

TsCellEdit Class

Public Properties
Name | Description
SelectedCell | Pointer to the currently active cell in the workbook. This cell is displayed in the control and can be edited.
Workbook | Refers to the underlying workbook to which the edited cell belongs.
Worksheet | Refers to the underlying worksheet to which the edited cell belongs.
Published Properties
Name | Description
ShowHTMLText |
WorkbookSource | Link to the WorkbookSource which provides the workbook and worksheet.


TsCellEdit.SelectedCell Property

TsCellEdit.SelectedCell Property
Syntax
Pascal
property SelectedCell: PCell;
Description

Pointer to the currently active cell in the workbook. This cell is displayed in the control and can be edited.

Group

TsCellEdit Properties


TsCellEdit.ShowHTMLText Property

TsCellEdit.ShowHTMLText Property
Syntax
Pascal
property ShowHTMLText: Boolean;
Group

TsCellEdit Properties


TsCellEdit.Workbook Property

TsCellEdit.Workbook Property
Syntax
Pascal
property Workbook: TsWorkbook;
Description

Refers to the underlying workbook to which the edited cell belongs.

Group

TsCellEdit Properties


TsCellEdit.WorkbookSource Property

TsCellEdit.WorkbookSource Property
Syntax
Pascal
property WorkbookSource: TsWorkbookSource;
Description

Link to the WorkbookSource which provides the workbook and worksheet.

Group

TsCellEdit Properties


TsCellEdit.Worksheet Property

TsCellEdit.Worksheet Property
Syntax
Pascal
property Worksheet: TsWorksheet;
Description

Refers to the underlying worksheet to which the edited cell belongs.

Group

TsCellEdit Properties


TsCellIndicator Class

TsCellIndicator Class
Class Hierarchy
  TsCellIndicatorTsCellIndicator
Syntax
Pascal
TsCellIndicator = class(TEdit, IsSpreadsheetControl);
File

fpspreadsheetctrls

Description

TsCellIndicator displays the address of the currently active cell of the worksheet and workbook. Editing the address allows to jump to the corresponding cell.

Group

Classes


TsCellIndicator Members

TsCellIndicator Members

The following tables list the members exposed by TsCellIndicator.

Class

TsCellIndicator Class

Protected Methods
Name | Description
Notification | Standard component notification called when the WorkbookSource is deleted.
Public Methods
Name | Description
Create | Constructor of the TsCellIndicator class. Is overridden to set the default value of the Alignment property to taCenter.
Destroy | Destructor of the cell indicator. Removes itself from the WorkbookSource's listener list.
EditingDone | EditingDone is called when the user presses the RETURN key to finish editing, or the TAB key which removes focus from the control, or clicks somewhere else The edited text is interpreted as a cell address. The corresponding cell is selected.
ListenerNotification | The cell indicator reacts to notification that the selection has changed and displays the address of the newly selected cell as editable text.
RemoveWorkbookSource | Removes the link of the CellIndicator to the WorkbookSource. Required before destruction.
Public Properties
Name | Description
Workbook | Refers to the underlying worksheet to which the edited cell belongs.
Worksheet | Refers to the underlying worksheet to which the edited cell belongs.
Published Properties
Name | Description
Alignment | Inherited from TEdit, overridden to center the text in the control by default
WorkbookSource | Link to the WorkbookSource which provides the workbook and worksheet.


TsCellIndicator.Create Constructor

TsCellIndicator.Create Constructor
Syntax
Pascal
constructor Create(AOwner: TComponent); override;
Description

Constructor of the TsCellIndicator class. Is overridden to set the default value of the Alignment property to taCenter.

Class

TsCellIndicator Class


TsCellIndicator.Destroy Destructor

TsCellIndicator.Destroy Destructor
Syntax
Pascal
destructor Destroy; override;
Description

Destructor of the cell indicator. Removes itself from the WorkbookSource's listener list.

Class

TsCellIndicator Class


TsCellIndicator Methods

TsCellIndicator Methods

The methods of the TsCellIndicator class are listed here.

Class

TsCellIndicator Class

Protected Methods
Name | Description
Notification | Standard component notification called when the WorkbookSource is deleted.
Public Methods
Name | Description
EditingDone | EditingDone is called when the user presses the RETURN key to finish editing, or the TAB key which removes focus from the control, or clicks somewhere else The edited text is interpreted as a cell address. The corresponding cell is selected.
ListenerNotification | The cell indicator reacts to notification that the selection has changed and displays the address of the newly selected cell as editable text.
RemoveWorkbookSource | Removes the link of the CellIndicator to the WorkbookSource. Required before destruction.


TsCellIndicator.EditingDone Method

TsCellIndicator.EditingDone Method
Syntax
Pascal
procedure EditingDone; override;
Description

EditingDone is called when the user presses the RETURN key to finish editing, or the TAB key which removes focus from the control, or clicks somewhere else The edited text is interpreted as a cell address. The corresponding cell is selected.

Group

TsCellIndicator Methods


TsCellIndicator.ListenerNotification Method

TsCellIndicator.ListenerNotification Method
Syntax
Pascal
procedure ListenerNotification(AChangedItems: TsNotificationItems; AData: Pointer = nil);
Parameters
Parameters | Description
AChangedItems: TsNotificationItems | Set with elements identifying whether workbook, worksheet cell or selection has changed. Only the latter element is considered by the cell indicator.
AData: Pointer = nil | If AChangedItems contains nliCell then AData points to the modified cell.
Description

The cell indicator reacts to notification that the selection has changed and displays the address of the newly selected cell as editable text.

Group

TsCellIndicator Methods


TsCellIndicator.Notification Method

TsCellIndicator.Notification Method
Syntax
Pascal
procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Description

Standard component notification called when the WorkbookSource is deleted.

Group

TsCellIndicator Methods


TsCellIndicator.RemoveWorkbookSource Method

TsCellIndicator.RemoveWorkbookSource Method
Syntax
Pascal
procedure RemoveWorkbookSource;
Description

Removes the link of the CellIndicator to the WorkbookSource. Required before destruction.

Group

TsCellIndicator Methods


TsCellIndicator Properties

TsCellIndicator Properties

The properties of the TsCellIndicator class are listed here.

Class

TsCellIndicator Class

Public Properties
Name | Description
Workbook | Refers to the underlying worksheet to which the edited cell belongs.
Worksheet | Refers to the underlying worksheet to which the edited cell belongs.
Published Properties
Name | Description
Alignment | Inherited from TEdit, overridden to center the text in the control by default
WorkbookSource | Link to the WorkbookSource which provides the workbook and worksheet.


TsCellIndicator.Alignment Property

TsCellIndicator.Alignment Property
Syntax
Pascal
property Alignment;
Description

Inherited from TEdit, overridden to center the text in the control by default

Group

TsCellIndicator Properties


TsCellIndicator.Workbook Property

TsCellIndicator.Workbook Property
Syntax
Pascal
property Workbook: TsWorkbook;
Description

Refers to the underlying worksheet to which the edited cell belongs.

Group

TsCellIndicator Properties


TsCellIndicator.WorkbookSource Property

TsCellIndicator.WorkbookSource Property
Syntax
Pascal
property WorkbookSource: TsWorkbookSource;
Description

Link to the WorkbookSource which provides the workbook and worksheet.

Group

TsCellIndicator Properties


TsCellIndicator.Worksheet Property

TsCellIndicator.Worksheet Property
Syntax
Pascal
property Worksheet: TsWorksheet;
Description

Refers to the underlying worksheet to which the edited cell belongs.

Group

TsCellIndicator Properties


TsCellList Class

TsCellList Class
Class Hierarchy
  TsCellList
Syntax
Pascal
TsCellList = class(TList);
File

fpspreadsheetctrls

Group

Classes


TsCellList Members

TsCellList Members

The following tables list the members exposed by TsCellList.

Class

TsCellList Class

Public Methods
Name | Description
Add |
AddCell |
AddEmptyCell |
Clear |
Delete |
Destroy |
IndexOf |
Public Properties
Name | Description
CellByIndex |
MultipleRanges |


TsCellList.Destroy Destructor

TsCellList.Destroy Destructor
Syntax
Pascal
destructor Destroy; override;
Class

TsCellList Class


TsCellList Methods

TsCellList Methods

The methods of the TsCellList class are listed here.

Class

TsCellList Class

Public Methods
Name | Description
Add |
AddCell |
AddEmptyCell |
Clear |
Delete |
IndexOf |


TsCellList.Add Method

TsCellList.Add Method
Syntax
Pascal
function Add(ACell: PCell): Integer;
Group

TsCellList Methods


TsCellList.AddCell Method

TsCellList.AddCell Method
Syntax
Pascal
function AddCell(ACell: PCell): Integer;
Group

TsCellList Methods


TsCellList.AddEmptyCell Method

TsCellList.AddEmptyCell Method
Syntax
Pascal
function AddEmptyCell(ARow: Cardinal; ACol: Cardinal): Integer;
Group

TsCellList Methods


TsCellList.Clear Method

TsCellList.Clear Method
Syntax
Pascal
procedure Clear; override;
Group

TsCellList Methods


TsCellList.Delete Method

TsCellList.Delete Method
Syntax
Pascal
procedure Delete(AIndex: Integer);
Group

TsCellList Methods


TsCellList.IndexOf Method

TsCellList.IndexOf Method
Syntax
Pascal
function IndexOf(ACell: PCell): Integer;
Group

TsCellList Methods


TsCellList Properties

TsCellList Properties

The properties of the TsCellList class are listed here.

Class

TsCellList Class

Public Properties
Name | Description
CellByIndex |
MultipleRanges |


TsCellList.CellByIndex Property

TsCellList.CellByIndex Property
Syntax
Pascal
property CellByIndex [AIndex: Integer]: PCell;
Group

TsCellList Properties


TsCellList.MultipleRanges Property

TsCellList.MultipleRanges Property
Syntax
Pascal
property MultipleRanges: Boolean;
Group

TsCellList Properties


TsCustomWorksheetGrid Class

TsCustomWorksheetGrid Class
Class Hierarchy
  TsCustomWorksheetGridTsCustomWorksheetGrid
Syntax
Pascal
TsCustomWorksheetGrid = class(TCustomDrawGrid, IsSpreadsheetControl);
File

fpspreadsheetgrid

Description

TsCustomWorksheetGrid is the ancestor of TsWorksheetGrid and is able to display spreadsheet data along with their formatting.

Group

Classes


TsCustomWorksheetGrid Members

TsCustomWorksheetGrid Members

The following tables list the members exposed by TsCustomWorksheetGrid.

Class

TsCustomWorksheetGrid Class

Protected Events
Name | Description
OnClickHyperlink | Event called when an external hyperlink is clicked
Protected Methods
Name | Description
AutoAdjustColumn | Is called when goDblClickAutoSize is in the grid's options and a double click has occured at the border of a column header. Sets optimum column with.
AutoAdjustRow | Is called when goDblClickAutoSize is in the grid's options and a double click has occured at the border of a row header. Sets optimum row height.
AutoExpandToCol | Automatically expands the ColCount such that the specified column fits in
AutoExpandToRow | Automatically expands the RowCount such that the specified column fits in
CalcWorksheetColWidth | Converts the column height given in screen pixels to the units used by the worksheet.
CalcWorksheetRowHeight | Converts the row height given in screen pixels to the units used by the worksheet.
CellOverflow | Looks for overflowing cells: if the text of the given cell is longer than the cell width the function calculates the column indexes and the rectangle to show the complete text. Ony for non-wordwrapped label cells and for horizontal orientation. Function returns false if text overflow needs not to be considered.
CreateNewWorkbook | Creates a new empty workbook into which a file will be loaded. Destroys the previously used workbook.
DblClick | Is called when a Double-click occurs. Overrides the inherited method to react on double click on cell border in row headers to auto-adjust the row heights
DefineProperties |
DoCopyToClipboard |
DoCutToClipboard |
DoEditorShow |
DoOnResize |
DoPasteFromClipboard |
DoPrepareCanvas | Adjusts the grid's canvas before painting a given cell. Considers background color, horizontal alignment, vertical alignment, etc.
DrawAllRows | This method is inherited from TsCustomGrid, but is overridden here in order to paint the cell borders and the selection rectangle. Both features can extend into the neighboring cells and thus would be clipped at the cell borders by the standard painting mechanism. At the time when DrawAllRows is called, however, clipping at cell borders is no longer active.
DrawCellBorders | This is the overview for the DrawCellBorders method overload.
DrawCellGrid | Method inherited method from TCustomGrid. Is overridden here to avoid painting of the border of frozen cells in black under some circumstances.
DrawCommentMarker | Draws the red rectangle in the upper right corner of a cell to indicate that this cell contains a popup comment
DrawFocusRect | This procedure is responsible for painting the focus rectangle. We don't want the red dashed rectangle here, but prefer the thick Excel-like black border line. This new focus rectangle is drawn by the method DrawSelection because the thick Excel border reaches into adjacent cells.
DrawFrozenPaneBorders | Draws a solid line along the borders of frozen panes.
DrawRow | Draws a complete row of cells. Is mostly duplicated from Grids.pas, but adds code for merged cells and overflow text, the section for drawing the default focus rectangle is removed.
DrawSelection | Draws the selection rectangle around selected cells.
DrawTextInCell | Draws the cell text. Calls "GetCellText" to determine the text for the cell. Takes care of horizontal and vertical text alignment, text rotation and text wrapping.
ExecuteHyperlink | Executes a hyperlink stored in the FHyperlinkCell
GetCellHeight | Returns the height (in pixels) of the cell at ACol/ARow (of the grid).
GetCellHintText | This function defines the text to be displayed as a cell hint. By default, it is the comment and/or the hyperlink attached to a cell; it can further be modified by using the OnGetCellHint event. Option goCellHints must be active for the cell hint feature to work.
GetCellText | This function returns the text to be shown in a grid cell. The text is looked up in the corresponding cell of the worksheet by calling its ReadAsUTF8Text method. In case of "stacked" text rotation, line endings are inserted after each character.
GetDefaultHeaderColWidth | Returns the width of the fixed header column 0, in pixels
GetEditText | Determines the text to be passed to the cell editor. The text is determined from the underlying worksheet cell, but it is possible to intercept this by adding a handler for the OnGetEditText event.
HasBorder | Returns true if the cell has the given border. In case of merged cell the borders of the merge base are checked. Inner merged cells don't have a border.
HeaderSized | Inherited from TCustomGrid. Is called when column widths or row heights have changed. Stores the new column width or row height in the worksheet.
HeaderSizing | HeaderSizing is called while a column width or row height is resized by the mouse. Is overridden here to enforce a grid repaint if merged cells are affected by the resizing column/row. Otherwise parts of the merged cells would not be updated if the cell text moves during the resizing action.
InternalDrawTextInCell | Internal general text drawing method.
KeyDown | Standard key handling method inherited from TCustomGrid. Is overridden to catch some keys for special processing.
Loaded | Standard method inherited from TCustomGrid. Is overridden to create an empty workbook
MouseDown | Standard mouse down handler. Is overridden here to handle hyperlinks and to enter "enhanced edit mode" which removes formatting from the values and presents formulas for editing.
MouseMove | Standard mouse move handler. Is overridden because, if TextOverflow is active, overflown cell may be erased when the mouse leaves them; repaints entire grid instead.
MouseUp |
MoveSelection | Standard method inherited from TCustomGrid. Notifies the WorkbookSource of the changed selected cell. Repaints the grid after moving selection to avoid spurious rests of the old thick selection border.
Notification | Standard component notification: The grid is notified that the WorkbookLink is being removed.
SelectEditor | Standard method inherited from TCustomGrid: Is called when editing starts. Is overridden here to store the old text just in case that the user presses ESC to cancel editing.
SelPenChangeHandler |
SetEditText | Standard method inherited from TCustomGrid. Fetches the text that is currently in the editor. It is not yet transferred to the worksheet because input will be checked only at the end of editing.
Setup | Helper method for setting up the rows and columns after a new workbook is loaded or created. Sets up the grid's column and row count, as well as the initial column widths and row heights.
Sort | Sorts the grid by calling the corresponding method of the worksheet. Sorting extends across the entire worksheet. Sort direction is determined by the property "SortOrder". Other sorting criteria are "case-sensitive" and "numbers first".
TopLeftChanged | Inherited method called whenever to grid is scrolled, i.e. the top/left cell changes. Is overridden to calculate the row heights of the currently visible grid
TrimToCell | Modifies the text that is show for cells which are too narrow to hold the entire text. The method follows the behavior of Excel and Open/LibreOffice: If the specified cell contains a non-formatted number, then it is formatted such that the text fits into the cell. If the text is still too long or the cell does not contain a label then the cell is filled by '#' characters. Label cell texts are not modified, they can overflow into the adjacent cells.
UpdateColWidths | Updates column widths according to the data in the TCol records
UpdateRowHeights | Updates row heights by using the data from the TRow records or by auto- calculating the row height from the max of the cell heights
Protected Properties
Name | Description
AutoCalc | Automatically recalculate formulas whenever a cell value changes.
AutoExpand | Automatically expand grid dimensions
DisplayFixedColRow | Displays column and row headers in the fixed col/row style of the grid. Deprecated. Use ShowHeaders instead.
FrozenCols | This number of columns at the left is "frozen", i.e. it is not possible to scroll these columns
FrozenRows | This number of rows at the top is "frozen", i.e. it is not possible to scroll these rows.
ReadFormulas | Activates reading of RPN formulas. Should be turned off when non-implemented formulas crashe reading of the spreadsheet file.
SelectionPen | Pen used for drawing the selection rectangle
ShowGridLines | Shows/hides vertical and horizontal grid lines
ShowHeaders | Shows/hides column and row headers in the fixed col/row style of the grid.
TextOverflow | Activates text overflow (cells reaching into neighbors)
Public Methods
Name | Description
BeginUpdate | The BeginUpdate/EndUpdate pair suppresses unnecessary painting of the grid. Call BeginUpdate to stop refreshing the grid, and call EndUpdate to release the lock and to repaint the grid again.
CellRect |
Convert_Font_to_sFont | Converts a font used for painting (TCanvas.Font) to a spreadsheet font.
Convert_sFont_to_Font | Converts a spreadsheet font to a font used for painting (TCanvas.Font).
Create | Constructor of the grid. Activates the display of column and row headers and creates an internal "CellFont". Creates a pre-defined number of empty rows and columns.
DefaultDrawCell | This is one of the main painting methods inherited from TsCustomGrid. It is overridden here to achieve the feature of "frozen" cells which should be painted in the same style as normal cells. Internally, "frozen" cells are "fixed" cells of the grid. Therefore, it is not possible to select any cell within the frozen panes - in contrast to the standard spreadsheet applications.
DeleteCol | Deletes the column specified.
DeleteRow | Deletes the row specified.
Destroy | Destructor of the grid: Destroys the workbook and the internal CellFont.
EditingDone | This procedure is called when editing of a cell is completed. It determines the worksheet cell and writes the text into the worksheet. Tries to keep the format of the cell, but if it is a new cell, or the content type has changed, tries to figure out the content type (number, date/time, text).
EndUpdate | The BeginUpdate/EndUpdate pair suppresses unnecessary painting of the grid. Call BeginUpdate to stop refreshing the grid, and call EndUpdate to release the lock and to repaint the grid again.
GetGridCol | Converts a column index of the worksheet to a column index usable in the grid. This is required because worksheet indexes always start at zero while grid indexes also have to account for the column/row headers.
GetGridRow | Converts a row index of the worksheet to a row index usable in the grid. This is required because worksheet indexes always start at zero while grid indexes also have to account for the column/row headers.
GetSheets | Returns a list of worksheets contained in the file. Useful for assigning to user controls like TabControl, Combobox etc. in order to select a sheet.
GetWorksheetCol | Calculates the index of the worksheet column that is displayed in the given column of the grid. If the sheet headers are turned on, both numbers differ by 1, otherwise they are equal. Saves an "if" in cases.
GetWorksheetRow | Calculates the index of the worksheet row that is displayed in the given row of the grid. If the sheet headers are turned on, both numbers differ by 1, otherwise they are equal. Saves an "if" in some cases.
InsertCol | Inserts an empty column before the column specified
InsertRow | Inserts an empty row before the row specified
ListenerNotification | Notification message received from the WorkbookLink telling which item of the spreadsheet has changed.
LoadFromSpreadsheetFile | This is the overview for the LoadFromSpreadsheetFile method overload.
LoadFromWorkbook | Loads an existing workbook into the grid.
MergeCells | This is the overview for the MergeCells method overload.
NewWorkbook | Creates a new empty workbook with the specified number of columns and rows.
RemoveWorkbookSource | Removes the link of the WorksheetGrid to the WorkbookSource. Required before destruction.
SaveToSpreadsheetFile | This is the overview for the SaveToSpreadsheetFile method overload.
SelectSheetByIndex | Loads the workbook into the grid and selects the sheet with the given index. "Selected" means here that the sheet is loaded into the grid.
ShowCellBorders | Shows cell borders for the cells in the range between columns ALeft and ARight and rows ATop and ABottom. The border of the block's left outer edge is defined by ALeftOuterStyle, that of the block's top outer edge by ATopOuterStyle, etc. Set the color of a border style to scNotDefined or scTransparent in order to hide the corresponding border line, or use the constant NO_CELL_BORDER.
UnmergeCells | This is the overview for the UnmergeCells method overload.
Public Properties
Name | Description
BackgroundColor | Background color of the cell at the given column and row. Expressed as index into the workbook's color palette.
BackgroundColors | Common background color of the cells covered by the given rectangle. Expressed as index into the workbook's color palette.
CellBiDiMode | Override system or sheet right-to-left mode for cell
CellBorder | Set of flags indicating at which cell border a border line is drawn.
CellBorders | Set of flags indicating at which border of a range of cells a border line is drawn
CellBorderStyle | Style of the border line at the given border of the cell at column ACol and row ARow. Requires the cellborder flag of the border to be set for the border line to be shown
CellBorderStyles | Style of the border line at the given border of the cells within the range of colum/row indexes defined by the rectangle. Requires the cellborder flag of the border to be set for the border line to be shown
CellComment | Comment assigned to the cell at column ACol and row ARow
CellFont | Font to be used for text in the cell at column ACol and row ARow.
CellFontColor | Color of the font used for the cell in column ACol and row ARow
CellFontColors | Color of the font used for the cells within the range of column/row indexes defined by the rectangle, scUndefined if not constant.
CellFontName | Name of the font used for the cell in column ACol and row ARow
CellFontNames | Name of the font used for the cells within the range of column/row indexes defined by the rectangle.
CellFonts | Font to be used for the cells in the column/row index range given by the rectangle
CellFontSize | Size of the font (in points) used for the cell at column ACol and row ARow
CellFontSizes | Size of the font (in points) used for the cells within the range of column/row indexes defined by the rectangle.
CellFontStyle | Style of the font (bold, italic, ...) used for text in the cell at column ACol and row ARow.
CellFontStyles | Style of the font (bold, italic, ...) used for the cells within the range of column/row indexes defined by the rectangle.
Cells | Cell values
ColWidths | Column width, in pixels
DefaultColWidth | Default column width, in pixels
DefaultRowHeight | Default row height, in pixels
HeaderCount | Count of header lines - for conversion between grid- and workbook-based row and column indexes. Either 1 if row and column headers are shown or 0 if not
HorAlignment | Parameter for horizontal text alignment within the cell at column ACol and row ARow
HorAlignments | Parameter for the horizontal text alignments in all cells within the range cf column/row indexes defined by the rectangle.
Hyperlink | Hyperlink assigned to the cell in row ARow and column ACol
NumberFormat | Number format (as Excel string) to be applied to cell at column ACol and row ARow.
NumberFormats | Number format (as Excel string) to be applied to all cells within the range of column/row indexes defined by the rectangle.
RangeSelectMode | Allow multiple selections
RowHeights | Row height in pixels
TextRotation | Rotation of the text in the cell at column ACol and row ARow.
TextRotations | Rotation of the text in the cells within the range of column/row indexes defined by the rectangle.
VertAlignment | Parameter for vertical text alignment in the cell at column ACol and row ARow.
VertAlignments | Parameter for vertical text alignment in the cells having column/row indexes defined by the rectangle.
Wordwrap | If true, word-wrapping of text within the cell at column ACol and row ARow is activated.
Wordwraps | If true, word-wrapping of text within all cells within the range defined by the rectangle is activated.
Workbook | Workbook displayed in the grid
WorkbookSource | Link to the workbook
Worksheet | Currently selected worksheet of the workbook


TsCustomWorksheetGrid.Create Constructor

TsCustomWorksheetGrid.Create Constructor
Syntax
Pascal
constructor Create(AOwner: TComponent); override;
Parameters
Parameters | Description
AOwner: TComponent | Owner of the grid
Description

Constructor of the grid. Activates the display of column and row headers and creates an internal "CellFont". Creates a pre-defined number of empty rows and columns.

Class

TsCustomWorksheetGrid Class


TsCustomWorksheetGrid.Destroy Destructor

TsCustomWorksheetGrid.Destroy Destructor
Syntax
Pascal
destructor Destroy; override;
Description

Destructor of the grid: Destroys the workbook and the internal CellFont.

Class

TsCustomWorksheetGrid Class


TsCustomWorksheetGrid Methods

TsCustomWorksheetGrid Methods

The methods of the TsCustomWorksheetGrid class are listed here.

Class

TsCustomWorksheetGrid Class

Protected Methods
Name | Description
AutoAdjustColumn | Is called when goDblClickAutoSize is in the grid's options and a double click has occured at the border of a column header. Sets optimum column with.
AutoAdjustRow | Is called when goDblClickAutoSize is in the grid's options and a double click has occured at the border of a row header. Sets optimum row height.
AutoExpandToCol | Automatically expands the ColCount such that the specified column fits in
AutoExpandToRow | Automatically expands the RowCount such that the specified column fits in
CalcWorksheetColWidth | Converts the column height given in screen pixels to the units used by the worksheet.
CalcWorksheetRowHeight | Converts the row height given in screen pixels to the units used by the worksheet.
CellOverflow | Looks for overflowing cells: if the text of the given cell is longer than the cell width the function calculates the column indexes and the rectangle to show the complete text. Ony for non-wordwrapped label cells and for horizontal orientation. Function returns false if text overflow needs not to be considered.
CreateNewWorkbook | Creates a new empty workbook into which a file will be loaded. Destroys the previously used workbook.
DblClick | Is called when a Double-click occurs. Overrides the inherited method to react on double click on cell border in row headers to auto-adjust the row heights
DefineProperties |
DoCopyToClipboard |
DoCutToClipboard |
DoEditorShow |
DoOnResize |
DoPasteFromClipboard |
DoPrepareCanvas | Adjusts the grid's canvas before painting a given cell. Considers background color, horizontal alignment, vertical alignment, etc.
DrawAllRows | This method is inherited from TsCustomGrid, but is overridden here in order to paint the cell borders and the selection rectangle. Both features can extend into the neighboring cells and thus would be clipped at the cell borders by the standard painting mechanism. At the time when DrawAllRows is called, however, clipping at cell borders is no longer active.
DrawCellBorders | This is the overview for the DrawCellBorders method overload.
DrawCellGrid | Method inherited method from TCustomGrid. Is overridden here to avoid painting of the border of frozen cells in black under some circumstances.
DrawCommentMarker | Draws the red rectangle in the upper right corner of a cell to indicate that this cell contains a popup comment
DrawFocusRect | This procedure is responsible for painting the focus rectangle. We don't want the red dashed rectangle here, but prefer the thick Excel-like black border line. This new focus rectangle is drawn by the method DrawSelection because the thick Excel border reaches into adjacent cells.
DrawFrozenPaneBorders | Draws a solid line along the borders of frozen panes.
DrawRow | Draws a complete row of cells. Is mostly duplicated from Grids.pas, but adds code for merged cells and overflow text, the section for drawing the default focus rectangle is removed.
DrawSelection | Draws the selection rectangle around selected cells.
DrawTextInCell | Draws the cell text. Calls "GetCellText" to determine the text for the cell. Takes care of horizontal and vertical text alignment, text rotation and text wrapping.
ExecuteHyperlink | Executes a hyperlink stored in the FHyperlinkCell
GetCellHeight | Returns the height (in pixels) of the cell at ACol/ARow (of the grid).
GetCellHintText | This function defines the text to be displayed as a cell hint. By default, it is the comment and/or the hyperlink attached to a cell; it can further be modified by using the OnGetCellHint event. Option goCellHints must be active for the cell hint feature to work.
GetCellText | This function returns the text to be shown in a grid cell. The text is looked up in the corresponding cell of the worksheet by calling its ReadAsUTF8Text method. In case of "stacked" text rotation, line endings are inserted after each character.
GetDefaultHeaderColWidth | Returns the width of the fixed header column 0, in pixels
GetEditText | Determines the text to be passed to the cell editor. The text is determined from the underlying worksheet cell, but it is possible to intercept this by adding a handler for the OnGetEditText event.
HasBorder | Returns true if the cell has the given border. In case of merged cell the borders of the merge base are checked. Inner merged cells don't have a border.
HeaderSized | Inherited from TCustomGrid. Is called when column widths or row heights have changed. Stores the new column width or row height in the worksheet.
HeaderSizing | HeaderSizing is called while a column width or row height is resized by the mouse. Is overridden here to enforce a grid repaint if merged cells are affected by the resizing column/row. Otherwise parts of the merged cells would not be updated if the cell text moves during the resizing action.
InternalDrawTextInCell | Internal general text drawing method.
KeyDown | Standard key handling method inherited from TCustomGrid. Is overridden to catch some keys for special processing.
Loaded | Standard method inherited from TCustomGrid. Is overridden to create an empty workbook
MouseDown | Standard mouse down handler. Is overridden here to handle hyperlinks and to enter "enhanced edit mode" which removes formatting from the values and presents formulas for editing.
MouseMove | Standard mouse move handler. Is overridden because, if TextOverflow is active, overflown cell may be erased when the mouse leaves them; repaints entire grid instead.
MouseUp |
MoveSelection | Standard method inherited from TCustomGrid. Notifies the WorkbookSource of the changed selected cell. Repaints the grid after moving selection to avoid spurious rests of the old thick selection border.
Notification | Standard component notification: The grid is notified that the WorkbookLink is being removed.
SelectEditor | Standard method inherited from TCustomGrid: Is called when editing starts. Is overridden here to store the old text just in case that the user presses ESC to cancel editing.
SelPenChangeHandler |
SetEditText | Standard method inherited from TCustomGrid. Fetches the text that is currently in the editor. It is not yet transferred to the worksheet because input will be checked only at the end of editing.
Setup | Helper method for setting up the rows and columns after a new workbook is loaded or created. Sets up the grid's column and row count, as well as the initial column widths and row heights.
Sort | Sorts the grid by calling the corresponding method of the worksheet. Sorting extends across the entire worksheet. Sort direction is determined by the property "SortOrder". Other sorting criteria are "case-sensitive" and "numbers first".
TopLeftChanged | Inherited method called whenever to grid is scrolled, i.e. the top/left cell changes. Is overridden to calculate the row heights of the currently visible grid
TrimToCell | Modifies the text that is show for cells which are too narrow to hold the entire text. The method follows the behavior of Excel and Open/LibreOffice: If the specified cell contains a non-formatted number, then it is formatted such that the text fits into the cell. If the text is still too long or the cell does not contain a label then the cell is filled by '#' characters. Label cell texts are not modified, they can overflow into the adjacent cells.
UpdateColWidths | Updates column widths according to the data in the TCol records
UpdateRowHeights | Updates row heights by using the data from the TRow records or by auto- calculating the row height from the max of the cell heights
Public Methods
Name | Description
BeginUpdate | The BeginUpdate/EndUpdate pair suppresses unnecessary painting of the grid. Call BeginUpdate to stop refreshing the grid, and call EndUpdate to release the lock and to repaint the grid again.
CellRect |
Convert_Font_to_sFont | Converts a font used for painting (TCanvas.Font) to a spreadsheet font.
Convert_sFont_to_Font | Converts a spreadsheet font to a font used for painting (TCanvas.Font).
DefaultDrawCell | This is one of the main painting methods inherited from TsCustomGrid. It is overridden here to achieve the feature of "frozen" cells which should be painted in the same style as normal cells. Internally, "frozen" cells are "fixed" cells of the grid. Therefore, it is not possible to select any cell within the frozen panes - in contrast to the standard spreadsheet applications.
DeleteCol | Deletes the column specified.
DeleteRow | Deletes the row specified.
EditingDone | This procedure is called when editing of a cell is completed. It determines the worksheet cell and writes the text into the worksheet. Tries to keep the format of the cell, but if it is a new cell, or the content type has changed, tries to figure out the content type (number, date/time, text).
EndUpdate | The BeginUpdate/EndUpdate pair suppresses unnecessary painting of the grid. Call BeginUpdate to stop refreshing the grid, and call EndUpdate to release the lock and to repaint the grid again.
GetGridCol | Converts a column index of the worksheet to a column index usable in the grid. This is required because worksheet indexes always start at zero while grid indexes also have to account for the column/row headers.
GetGridRow | Converts a row index of the worksheet to a row index usable in the grid. This is required because worksheet indexes always start at zero while grid indexes also have to account for the column/row headers.
GetSheets | Returns a list of worksheets contained in the file. Useful for assigning to user controls like TabControl, Combobox etc. in order to select a sheet.
GetWorksheetCol | Calculates the index of the worksheet column that is displayed in the given column of the grid. If the sheet headers are turned on, both numbers differ by 1, otherwise they are equal. Saves an "if" in cases.
GetWorksheetRow | Calculates the index of the worksheet row that is displayed in the given row of the grid. If the sheet headers are turned on, both numbers differ by 1, otherwise they are equal. Saves an "if" in some cases.
InsertCol | Inserts an empty column before the column specified
InsertRow | Inserts an empty row before the row specified
ListenerNotification | Notification message received from the WorkbookLink telling which item of the spreadsheet has changed.
LoadFromSpreadsheetFile | This is the overview for the LoadFromSpreadsheetFile method overload.
LoadFromWorkbook | Loads an existing workbook into the grid.
MergeCells | This is the overview for the MergeCells method overload.
NewWorkbook | Creates a new empty workbook with the specified number of columns and rows.
RemoveWorkbookSource | Removes the link of the WorksheetGrid to the WorkbookSource. Required before destruction.
SaveToSpreadsheetFile | This is the overview for the SaveToSpreadsheetFile method overload.
SelectSheetByIndex | Loads the workbook into the grid and selects the sheet with the given index. "Selected" means here that the sheet is loaded into the grid.
ShowCellBorders | Shows cell borders for the cells in the range between columns ALeft and ARight and rows ATop and ABottom. The border of the block's left outer edge is defined by ALeftOuterStyle, that of the block's top outer edge by ATopOuterStyle, etc. Set the color of a border style to scNotDefined or scTransparent in order to hide the corresponding border line, or use the constant NO_CELL_BORDER.
UnmergeCells | This is the overview for the UnmergeCells method overload.


TsCustomWorksheetGrid.AutoAdjustColumn Method

TsCustomWorksheetGrid.AutoAdjustColumn Method
Syntax
Pascal
procedure AutoAdjustColumn(ACol: Integer); override;
Description

Is called when goDblClickAutoSize is in the grid's options and a double click has occured at the border of a column header. Sets optimum column with.

Group

TsCustomWorksheetGrid Methods


TsCustomWorksheetGrid.AutoAdjustRow Method

TsCustomWorksheetGrid.AutoAdjustRow Method
Syntax
Pascal
procedure AutoAdjustRow(ARow: Integer); virtual;
Description

Is called when goDblClickAutoSize is in the grid's options and a double click has occured at the border of a row header. Sets optimum row height.

Group

TsCustomWorksheetGrid Methods


TsCustomWorksheetGrid.AutoExpandToCol Method

TsCustomWorksheetGrid.AutoExpandToCol Method
Syntax
Pascal
procedure AutoExpandToCol(ACol: Integer; AMode: TsAutoExpandMode);
Description

Automatically expands the ColCount such that the specified column fits in

Group

TsCustomWorksheetGrid Methods


TsCustomWorksheetGrid.AutoExpandToRow Method

TsCustomWorksheetGrid.AutoExpandToRow Method
Syntax
Pascal
procedure AutoExpandToRow(ARow: Integer; AMode: TsAutoExpandMode);
Description

Automatically expands the RowCount such that the specified column fits in

Group

TsCustomWorksheetGrid Methods


TsCustomWorksheetGrid.BeginUpdate Method

TsCustomWorksheetGrid.BeginUpdate Method
Syntax
Pascal
procedure BeginUpdate;
Description

The BeginUpdate/EndUpdate pair suppresses unnecessary painting of the grid. Call BeginUpdate to stop refreshing the grid, and call EndUpdate to release the lock and to repaint the grid again.

Group

TsCustomWorksheetGrid Methods


TsCustomWorksheetGrid.CalcWorksheetColWidth Method

TsCustomWorksheetGrid.CalcWorksheetColWidth Method
Syntax
Pascal
function CalcWorksheetColWidth(AValue: Integer): Single;
Parameters
Parameters | Description
AValue: Integer | Column width in pixels result Count of characters '0' in the worksheet's default font.
Description

Converts the column height given in screen pixels to the units used by the worksheet.

Group

TsCustomWorksheetGrid Methods


TsCustomWorksheetGrid.CalcWorksheetRowHeight Method

TsCustomWorksheetGrid.CalcWorksheetRowHeight Method
Syntax
Pascal
function CalcWorksheetRowHeight(AValue: Integer): Single;
Parameters
Parameters | Description
AValue: Integer | Row height in pixels result Row height expressed as default font line count.
Description

Converts the row height given in screen pixels to the units used by the worksheet.

Group

TsCustomWorksheetGrid Methods


TsCustomWorksheetGrid.CellOverflow Method

TsCustomWorksheetGrid.CellOverflow Method
Syntax
Pascal
function CellOverflow(ACol: Integer; ARow: Integer; AState: TGridDrawState; out ACol1: Integer; out ACol2: Integer; var ARect: TRect): Boolean;
Parameters
Parameters | Description
ACol: Integer | , ARow Column and row indexes (in grid coordinates) of the cell to be drawn
AState: TGridDrawState | GridDrawState of the cell (normal, fixed, selected etc)
out ACol1: Integer | ,ACol2 (output) Index of the first and last column covered by the overflowing text
var ARect: TRect | (output) Pixel rectangle enclosing the cell and its neighbors affected
Returns

TRUE if text overflow into neighbor cells is to be considered, FALSE if not.

Description

Looks for overflowing cells: if the text of the given cell is longer than the cell width the function calculates the column indexes and the rectangle to show the complete text. Ony for non-wordwrapped label cells and for horizontal orientation. Function returns false if text overflow needs not to be considered.

Group

TsCustomWorksheetGrid Methods


TsCustomWorksheetGrid.CellRect Method

TsCustomWorksheetGrid.CellRect Method
Syntax
Pascal
function CellRect(ACol1: Integer; ARow1: Integer; ACol2: Integer; ARow2: Integer): TRect; overload;
Group

TsCustomWorksheetGrid Methods


TsCustomWorksheetGrid.Convert_Font_to_sFont Method

TsCustomWorksheetGrid.Convert_Font_to_sFont Method
Syntax
Pascal
procedure Convert_Font_to_sFont(AFont: TFont; sFont: TsFont);
Parameters
Parameters | Description
AFont: TFont | Font as used by TCanvas for painting (input)
sFont: TsFont | Font as used by fpspreadsheet (output)
Description

Converts a font used for painting (TCanvas.Font) to a spreadsheet font.

Group

TsCustomWorksheetGrid Methods


TsCustomWorksheetGrid.Convert_sFont_to_Font Method

TsCustomWorksheetGrid.Convert_sFont_to_Font Method
Syntax
Pascal
procedure Convert_sFont_to_Font(sFont: TsFont; AFont: TFont);
Parameters
Parameters | Description
sFont: TsFont | Font as used by fpspreadsheet (input)
AFont: TFont | Font as used by TCanvas for painting (output)
Description

Converts a spreadsheet font to a font used for painting (TCanvas.Font).

Group

TsCustomWorksheetGrid Methods


TsCustomWorksheetGrid.CreateNewWorkbook Method

TsCustomWorksheetGrid.CreateNewWorkbook Method
Syntax
Pascal
procedure CreateNewWorkbook;
Description

Creates a new empty workbook into which a file will be loaded. Destroys the previously used workbook.

Group

TsCustomWorksheetGrid Methods


TsCustomWorksheetGrid.DblClick Method

TsCustomWorksheetGrid.DblClick Method
Syntax
Pascal
procedure DblClick; override;
Description

Is called when a Double-click occurs. Overrides the inherited method to react on double click on cell border in row headers to auto-adjust the row heights

Group

TsCustomWorksheetGrid Methods


TsCustomWorksheetGrid.DefaultDrawCell Method

TsCustomWorksheetGrid.DefaultDrawCell Method
Syntax
Pascal
procedure DefaultDrawCell(ACol: Integer; ARow: Integer; var ARect: TRect; AState: TGridDrawState); override;
Parameters
Parameters | Description
ACol: Integer | Column index of the cell being drawn
ARow: Integer | Row index of the cell beging drawn
var ARect: TRect | Rectangle, in grid pixels, covered by the cell
AState: TGridDrawState | Grid drawing state, as defined by TsCustomGrid
Description

This is one of the main painting methods inherited from TsCustomGrid. It is overridden here to achieve the feature of "frozen" cells which should be painted in the same style as normal cells.

Internally, "frozen" cells are "fixed" cells of the grid. Therefore, it is not possible to select any cell within the frozen panes - in contrast to the standard spreadsheet applications.

Group

TsCustomWorksheetGrid Methods


TsCustomWorksheetGrid.DefineProperties Method

TsCustomWorksheetGrid.DefineProperties Method
Syntax
Pascal
procedure DefineProperties(Filer: TFiler); override;
Group

TsCustomWorksheetGrid Methods


TsCustomWorksheetGrid.DeleteCol Method

TsCustomWorksheetGrid.DeleteCol Method
Syntax
Pascal
procedure DeleteCol(AGridCol: Integer); reintroduce;
Parameters
Parameters | Description
AGridCol: Integer | Grid index of the column to be deleted
Description

Deletes the column specified.

Group

TsCustomWorksheetGrid Methods


TsCustomWorksheetGrid.DeleteRow Method

TsCustomWorksheetGrid.DeleteRow Method
Syntax
Pascal
procedure DeleteRow(AGridRow: Integer); reintroduce;
Parameters
Parameters | Description
AGridRow: Integer | Grid index of the row to be deleted
Description

Deletes the row specified.

Group

TsCustomWorksheetGrid Methods


TsCustomWorksheetGrid.DoCopyToClipboard Method

TsCustomWorksheetGrid.DoCopyToClipboard Method
Syntax
Pascal
procedure DoCopyToClipboard; override;
Group

TsCustomWorksheetGrid Methods


TsCustomWorksheetGrid.DoCutToClipboard Method

TsCustomWorksheetGrid.DoCutToClipboard Method
Syntax
Pascal
procedure DoCutToClipboard; override;
Group

TsCustomWorksheetGrid Methods


TsCustomWorksheetGrid.DoEditorShow Method

TsCustomWorksheetGrid.DoEditorShow Method
Syntax
Pascal
procedure DoEditorShow; override;
Group

TsCustomWorksheetGrid Methods


TsCustomWorksheetGrid.DoOnResize Method

TsCustomWorksheetGrid.DoOnResize Method
Syntax
Pascal
procedure DoOnResize; override;
Group

TsCustomWorksheetGrid Methods


TsCustomWorksheetGrid.DoPasteFromClipboard Method

TsCustomWorksheetGrid.DoPasteFromClipboard Method
Syntax
Pascal
procedure DoPasteFromClipboard; override;
Group

TsCustomWorksheetGrid Methods


TsCustomWorksheetGrid.DoPrepareCanvas Method

TsCustomWorksheetGrid.DoPrepareCanvas Method
Syntax
Pascal
procedure DoPrepareCanvas(ACol: Integer; ARow: Integer; AState: TGridDrawState); override;
Parameters
Parameters | Description
ACol: Integer | Column index of the cell being painted
ARow: Integer | Row index of the cell being painted
AState: TGridDrawState | Grid drawing state -- see TsCustomGrid.
Description

Adjusts the grid's canvas before painting a given cell. Considers background color, horizontal alignment, vertical alignment, etc.

Group

TsCustomWorksheetGrid Methods


TsCustomWorksheetGrid.DrawAllRows Method

TsCustomWorksheetGrid.DrawAllRows Method
Syntax
Pascal
procedure DrawAllRows; override;
Description

This method is inherited from TsCustomGrid, but is overridden here in order to paint the cell borders and the selection rectangle. Both features can extend into the neighboring cells and thus would be clipped at the cell borders by the standard painting mechanism. At the time when DrawAllRows is called, however, clipping at cell borders is no longer active.

Group

TsCustomWorksheetGrid Methods


DrawCellBorders Method

DrawCellBorders Method

This is the overview for the DrawCellBorders method overload.

Overload List
Name | Description
TsCustomWorksheetGrid.DrawCellBorders () | Draws the borders of all cells. Calls DrawCellBorders for each individual cell.
TsCustomWorksheetGrid.DrawCellBorders (Integer, Integer, TRect, PCell) | Draws the border lines around a given cell. Note that when this procedure is called the output is clipped by the cell rectangle, but thick and double border styles extend into the neighboring cell. Therefore, these border lines are drawn in parts.
Group

TsCustomWorksheetGrid Methods


TsCustomWorksheetGrid.DrawCellBorders Method ()

TsCustomWorksheetGrid.DrawCellBorders Method ()
Syntax
Pascal
procedure DrawCellBorders; overload;
Description

Draws the borders of all cells. Calls DrawCellBorders for each individual cell.

Group

DrawCellBorders Method


TsCustomWorksheetGrid.DrawCellBorders Method (Integer, Integer, TRect, PCell)

TsCustomWorksheetGrid.DrawCellBorders Method (Integer, Integer, TRect, PCell)
Syntax
Pascal
procedure DrawCellBorders(ACol: Integer; ARow: Integer; ARect: TRect; ACell: PCell); overload;
Parameters
Parameters | Description
ACol: Integer | Column Index
ARow: Integer | Row index
ARect: TRect | Rectangle in pixels occupied by the cell.
Description

Draws the border lines around a given cell. Note that when this procedure is called the output is clipped by the cell rectangle, but thick and double border styles extend into the neighboring cell. Therefore, these border lines are drawn in parts.

Group

DrawCellBorders Method


TsCustomWorksheetGrid.DrawCellGrid Method

TsCustomWorksheetGrid.DrawCellGrid Method
Syntax
Pascal
procedure DrawCellGrid(ACol: Integer; ARow: Integer; ARect: TRect; AState: TGridDrawState); override;
Description

Method inherited method from TCustomGrid. Is overridden here to avoid painting of the border of frozen cells in black under some circumstances.

Group

TsCustomWorksheetGrid Methods


TsCustomWorksheetGrid.DrawCommentMarker Method

TsCustomWorksheetGrid.DrawCommentMarker Method
Syntax
Pascal
procedure DrawCommentMarker(ARect: TRect);
Description

Draws the red rectangle in the upper right corner of a cell to indicate that this cell contains a popup comment

Group

TsCustomWorksheetGrid Methods


TsCustomWorksheetGrid.DrawFocusRect Method

TsCustomWorksheetGrid.DrawFocusRect Method
Syntax
Pascal
procedure DrawFocusRect(aCol: Integer; aRow: Integer; ARect: TRect); override;
Parameters
Parameters | Description
aCol: Integer | Grid column index of the focused cell
aRow: Integer | Grid row index of the focused cell
ARect: TRect | Rectangle in pixels covered by the focused cell
Description

This procedure is responsible for painting the focus rectangle. We don't want the red dashed rectangle here, but prefer the thick Excel-like black border line. This new focus rectangle is drawn by the method DrawSelection because the thick Excel border reaches into adjacent cells.

Group

TsCustomWorksheetGrid Methods


TsCustomWorksheetGrid.DrawFrozenPaneBorders Method

TsCustomWorksheetGrid.DrawFrozenPaneBorders Method
Syntax
Pascal
procedure DrawFrozenPaneBorders(ARect: TRect);
Parameters
Parameters | Description
ARect: TRect | This rectangle indicates the area containing scrollable cells. If the grid has frozen panes, a black line is drawn along the upper and/or left edge of this rectangle (depending on the value of FrozenRows and FrozenCols).
Description

Draws a solid line along the borders of frozen panes.

Group

TsCustomWorksheetGrid Methods


TsCustomWorksheetGrid.DrawRow Method

TsCustomWorksheetGrid.DrawRow Method
Syntax
Pascal
procedure DrawRow(aRow: Integer); override;
Parameters
Parameters | Description
aRow: Integer | Index of the row to be drawn (in grid coordinates)
Description

Draws a complete row of cells. Is mostly duplicated from Grids.pas, but adds code for merged cells and overflow text, the section for drawing the default focus rectangle is removed.

Group

TsCustomWorksheetGrid Methods


TsCustomWorksheetGrid.DrawSelection Method

TsCustomWorksheetGrid.DrawSelection Method
Syntax
Pascal
procedure DrawSelection;
Description

Draws the selection rectangle around selected cells.

Group

TsCustomWorksheetGrid Methods


TsCustomWorksheetGrid.DrawTextInCell Method

TsCustomWorksheetGrid.DrawTextInCell Method
Syntax
Pascal
procedure DrawTextInCell(ACol: Integer; ARow: Integer; ARect: TRect; AState: TGridDrawState); override;
Parameters
Parameters | Description
ACol: Integer | Grid column index of the cell
ARow: Integer | Grid row index of the cell
ARect: TRect | Rectangle in pixels occupied by the cell
AState: TGridDrawState | Drawing state of the grid -- see TCustomGrid
Description

Draws the cell text. Calls "GetCellText" to determine the text for the cell. Takes care of horizontal and vertical text alignment, text rotation and text wrapping.

Group

TsCustomWorksheetGrid Methods


TsCustomWorksheetGrid.EditingDone Method

TsCustomWorksheetGrid.EditingDone Method
Syntax
Pascal
procedure EditingDone; override;
Description

This procedure is called when editing of a cell is completed. It determines the worksheet cell and writes the text into the worksheet. Tries to keep the format of the cell, but if it is a new cell, or the content type has changed, tries to figure out the content type (number, date/time, text).

Group

TsCustomWorksheetGrid Methods


TsCustomWorksheetGrid.EndUpdate Method

TsCustomWorksheetGrid.EndUpdate Method
Syntax
Pascal
procedure EndUpdate;
Description

The BeginUpdate/EndUpdate pair suppresses unnecessary painting of the grid. Call BeginUpdate to stop refreshing the grid, and call EndUpdate to release the lock and to repaint the grid again.

Group

TsCustomWorksheetGrid Methods


TsCustomWorksheetGrid.ExecuteHyperlink Method

TsCustomWorksheetGrid.ExecuteHyperlink Method
Syntax
Pascal
procedure ExecuteHyperlink;
Description

Executes a hyperlink stored in the FHyperlinkCell

Group

TsCustomWorksheetGrid Methods


TsCustomWorksheetGrid.GetCellHeight Method

TsCustomWorksheetGrid.GetCellHeight Method
Syntax
Pascal
function GetCellHeight(ACol: Integer; ARow: Integer): Integer;
Parameters
Parameters | Description
ACol: Integer | Grid column index of the cell
ARow: Integer | Grid row index of the cell result Height of the cell in pixels. Wrapped text is handled correctly.
Description

Returns the height (in pixels) of the cell at ACol/ARow (of the grid).

Group

TsCustomWorksheetGrid Methods


TsCustomWorksheetGrid.GetCellHintText Method

TsCustomWorksheetGrid.GetCellHintText Method
Syntax
Pascal
function GetCellHintText(ACol: Integer; ARow: Integer): String; override;
Description

This function defines the text to be displayed as a cell hint. By default, it is the comment and/or the hyperlink attached to a cell; it can further be modified by using the OnGetCellHint event. Option goCellHints must be active for the cell hint feature to work.

Group

TsCustomWorksheetGrid Methods


TsCustomWorksheetGrid.GetCellText Method

TsCustomWorksheetGrid.GetCellText Method
Syntax
Pascal
function GetCellText(ACol: Integer; ARow: Integer): String;
Parameters
Parameters | Description
ACol: Integer | Grid column index of the cell
ARow: Integer | Grid row index of the cell
Returns

Text to be displayed in the cell.

Description

This function returns the text to be shown in a grid cell. The text is looked up in the corresponding cell of the worksheet by calling its ReadAsUTF8Text method. In case of "stacked" text rotation, line endings are inserted after each character.

Group

TsCustomWorksheetGrid Methods


TsCustomWorksheetGrid.GetDefaultHeaderColWidth Method

TsCustomWorksheetGrid.GetDefaultHeaderColWidth Method
Syntax
Pascal
function GetDefaultHeaderColWidth: Integer;
Description

Returns the width of the fixed header column 0, in pixels

Group

TsCustomWorksheetGrid Methods


TsCustomWorksheetGrid.GetEditText Method

TsCustomWorksheetGrid.GetEditText Method
Syntax
Pascal
function GetEditText(ACol: Integer; ARow: Integer): String; override;
Parameters
Parameters | Description
ACol: Integer | Grid column index of the cell being edited
ARow: Integer | Grid row index of the grid cell being edited
Returns

Text to be passed to the cell editor.

Description

Determines the text to be passed to the cell editor. The text is determined from the underlying worksheet cell, but it is possible to intercept this by adding a handler for the OnGetEditText event.

Group

TsCustomWorksheetGrid Methods


TsCustomWorksheetGrid.GetGridCol Method

TsCustomWorksheetGrid.GetGridCol Method
Syntax
Pascal
function GetGridCol(ASheetCol: Cardinal): Integer;
Parameters
Parameters | Description
ASheetCol: Cardinal | Worksheet column index
Returns

Grid column index

Description

Converts a column index of the worksheet to a column index usable in the grid. This is required because worksheet indexes always start at zero while grid indexes also have to account for the column/row headers.

Group

TsCustomWorksheetGrid Methods


TsCustomWorksheetGrid.GetGridRow Method

TsCustomWorksheetGrid.GetGridRow Method
Syntax
Pascal
function GetGridRow(ASheetRow: Cardinal): Integer;
Parameters
Parameters | Description
ASheetRow: Cardinal | Worksheet row index
Returns

Grid row index

Description

Converts a row index of the worksheet to a row index usable in the grid. This is required because worksheet indexes always start at zero while grid indexes also have to account for the column/row headers.

Group

TsCustomWorksheetGrid Methods


TsCustomWorksheetGrid.GetSheets Method

TsCustomWorksheetGrid.GetSheets Method
Syntax
Pascal
procedure GetSheets(const ASheets: TStrings);
Parameters
Parameters | Description
const ASheets: TStrings | List of strings containing the names of the worksheets of the workbook
Description

Returns a list of worksheets contained in the file. Useful for assigning to user controls like TabControl, Combobox etc. in order to select a sheet.

Group

TsCustomWorksheetGrid Methods


TsCustomWorksheetGrid.GetWorksheetCol Method

TsCustomWorksheetGrid.GetWorksheetCol Method
Syntax
Pascal
function GetWorksheetCol(AGridCol: Integer): Cardinal;
Parameters
Parameters | Description
AGridCol: Integer | Index of a grid column
Returns

Index of a the corresponding worksheet column

Description

Calculates the index of the worksheet column that is displayed in the given column of the grid. If the sheet headers are turned on, both numbers differ by 1, otherwise they are equal. Saves an "if" in cases.

Group

TsCustomWorksheetGrid Methods


TsCustomWorksheetGrid.GetWorksheetRow Method

TsCustomWorksheetGrid.GetWorksheetRow Method
Syntax
Pascal
function GetWorksheetRow(AGridRow: Integer): Cardinal;
Parameters
Parameters | Description
AGridRow: Integer | Index of a grid row resturn Index of the corresponding worksheet row.
Description

Calculates the index of the worksheet row that is displayed in the given row of the grid. If the sheet headers are turned on, both numbers differ by 1, otherwise they are equal. Saves an "if" in some cases.

Group

TsCustomWorksheetGrid Methods


TsCustomWorksheetGrid.HasBorder Method

TsCustomWorksheetGrid.HasBorder Method
Syntax
Pascal
function HasBorder(ACell: PCell; ABorder: TsCellBorder): Boolean;
Parameters
Parameters | Description
ACell: PCell | Pointer to cell considered
ABorder: TsCellBorder | Indicator for border to be checked for visibility
Description

Returns true if the cell has the given border. In case of merged cell the borders of the merge base are checked. Inner merged cells don't have a border.

Group

TsCustomWorksheetGrid Methods


TsCustomWorksheetGrid.HeaderSized Method

TsCustomWorksheetGrid.HeaderSized Method
Syntax
Pascal
procedure HeaderSized(IsColumn: Boolean; AIndex: Integer); override;
Parameters
Parameters | Description
IsColumn: Boolean | Specifies whether the changed parameter is a column width (true) or a row height (false)
Index | Index of the changed column or row
Description

Inherited from TCustomGrid. Is called when column widths or row heights have changed. Stores the new column width or row height in the worksheet.

Group

TsCustomWorksheetGrid Methods


TsCustomWorksheetGrid.HeaderSizing Method

TsCustomWorksheetGrid.HeaderSizing Method
Syntax
Pascal
procedure HeaderSizing(const IsColumn: boolean; const AIndex: Integer; const ASize: Integer); override;
Description

HeaderSizing is called while a column width or row height is resized by the mouse. Is overridden here to enforce a grid repaint if merged cells are affected by the resizing column/row. Otherwise parts of the merged cells would not be updated if the cell text moves during the resizing action.

Group

TsCustomWorksheetGrid Methods


TsCustomWorksheetGrid.InsertCol Method

TsCustomWorksheetGrid.InsertCol Method
Syntax
Pascal
procedure InsertCol(AGridCol: Integer);
Description

Inserts an empty column before the column specified

Group

TsCustomWorksheetGrid Methods


TsCustomWorksheetGrid.InsertRow Method

TsCustomWorksheetGrid.InsertRow Method
Syntax
Pascal
procedure InsertRow(AGridRow: Integer);
Description

Inserts an empty row before the row specified

Group

TsCustomWorksheetGrid Methods


TsCustomWorksheetGrid.InternalDrawTextInCell Method

TsCustomWorksheetGrid.InternalDrawTextInCell Method
Syntax
Pascal
procedure InternalDrawTextInCell(AText: String; ARect: TRect; ACellHorAlign: TsHorAlignment; ACellVertAlign: TsVertAlignment; ATextRot: TsTextRotation; ATextWrap: Boolean; AFontIndex: Integer; AOverrideTextColor: TColor; ARichTextParams: TsRichTextParams; AIsRightToLeft: Boolean);
Parameters
Parameters | Description
AText: String | Text to be drawn
ARect: TRect | Rectangle in which the text is drawn
ACellHorAlign: TsHorAlignment | Is the HorAlignment property stored in the cell
ACellVertAlign: TsVertAlignment | Is the VertAlignment property stored in the cell
ATextRot: TsTextRotation | Determines the rotation angle of the text.
ATextWrap: Boolean | Determines if the text can wrap into multiple lines
AFontIndex: Integer | Font index to be used for drawing non-rich-text.
ARichTextParams: TsRichTextParams | an array of character and font index combinations for rich-text formatting of text in cell
AIsRightToLeft: Boolean | if true cell must be drawn in right-to-left mode. Note The reason to separate AJustification from ACellHorAlign and ACelVertAlign is the output of nfAccounting formatted numbers where the numbers are always right-aligned, and the currency symbol is left-aligned. THIS FEATURE IS CURRENTLY NO LONGER SUPPORTED.
AMeasureText | Text used for checking if the text fits into the text rectangle. If too large and ReplaceTooLong = true, a series of # is drawn.
AJustification | Determines whether the text is drawn at the "start" (0), "center" (1) or "end" (2) of the drawing rectangle. Start/center/end are seen along the text drawing direction.
Description

Internal general text drawing method.

Group

TsCustomWorksheetGrid Methods


TsCustomWorksheetGrid.KeyDown Method

TsCustomWorksheetGrid.KeyDown Method
Syntax
Pascal
procedure KeyDown(var Key: Word; Shift: TShiftState); override;
Parameters
Parameters | Description
var Key: Word | Key which has been pressed
Shift: TShiftState | Additional shift keys which are pressed
Description

Standard key handling method inherited from TCustomGrid. Is overridden to catch some keys for special processing.

Group

TsCustomWorksheetGrid Methods


TsCustomWorksheetGrid.ListenerNotification Method

TsCustomWorksheetGrid.ListenerNotification Method
Syntax
Pascal
procedure ListenerNotification(AChangedItems: TsNotificationItems; AData: Pointer = nil);
Description

Notification message received from the WorkbookLink telling which item of the spreadsheet has changed.

Group

TsCustomWorksheetGrid Methods


TsCustomWorksheetGrid.Loaded Method

TsCustomWorksheetGrid.Loaded Method
Syntax
Pascal
procedure Loaded; override;
Description

Standard method inherited from TCustomGrid. Is overridden to create an empty workbook

Group

TsCustomWorksheetGrid Methods


LoadFromSpreadsheetFile Method

LoadFromSpreadsheetFile Method

This is the overview for the LoadFromSpreadsheetFile method overload.

Overload List
Name | Description
TsCustomWorksheetGrid.LoadFromSpreadsheetFile (string, Integer) | Creates a new workbook and loads the given file into it. The file format is determined automatically. Shows the sheet with the given sheet index.
TsCustomWorksheetGrid.LoadFromSpreadsheetFile (string, TsSpreadFormatID, Integer) | Creates a new workbook and loads the given file into it. The file is assumed to have the given file format. Shows the sheet with the given sheet index. Call this method for both built-in and user-provided file formats.
TsCustomWorksheetGrid.LoadFromSpreadsheetFile (string, TsSpreadsheetFormat, Integer) | Creates a new workbook and loads the given file into it. The file is assumed to have the given file format. Shows the sheet with the given sheet index. Call this method only for built-in file formats.
Group

TsCustomWorksheetGrid Methods


TsCustomWorksheetGrid.LoadFromSpreadsheetFile Method (string, Integer)

TsCustomWorksheetGrid.LoadFromSpreadsheetFile Method (string, Integer)
Syntax
Pascal
procedure LoadFromSpreadsheetFile(AFileName: string; AWorksheetIndex: Integer = -1); overload;
Parameters
Parameters | Description
AFileName: string | Name of the file to be loaded
AWorksheetIndex: Integer = -1 | Index of the worksheet to be shown in the grid (If empty then the active worksheet is loaded)
Description

Creates a new workbook and loads the given file into it. The file format is determined automatically. Shows the sheet with the given sheet index.

Group

LoadFromSpreadsheetFile Method


TsCustomWorksheetGrid.LoadFromSpreadsheetFile Method (string, TsSpreadFormatID, Integer)

TsCustomWorksheetGrid.LoadFromSpreadsheetFile Method (string, TsSpreadFormatID, Integer)
Syntax
Pascal
procedure LoadFromSpreadsheetFile(AFileName: string; AFormatID: TsSpreadFormatID; AWorksheetIndex: Integer = -1); overload;
Parameters
Parameters | Description
AFileName: string | Name of the file to be loaded
AFormatID: TsSpreadFormatID | Spreadsheet file format identifier assumed for the file
AWorksheetIndex: Integer = -1 | Index of the worksheet to be displayed in the grid (If empty then the active worksheet is loaded)
Description

Creates a new workbook and loads the given file into it. The file is assumed to have the given file format. Shows the sheet with the given sheet index.

Call this method for both built-in and user-provided file formats.

Group

LoadFromSpreadsheetFile Method


TsCustomWorksheetGrid.LoadFromSpreadsheetFile Method (string, TsSpreadsheetFormat, Integer)

TsCustomWorksheetGrid.LoadFromSpreadsheetFile Method (string, TsSpreadsheetFormat, Integer)
Syntax
Pascal
procedure LoadFromSpreadsheetFile(AFileName: string; AFormat: TsSpreadsheetFormat; AWorksheetIndex: Integer = -1); overload;
Parameters
Parameters | Description
AFileName: string | Name of the file to be loaded
AFormat: TsSpreadsheetFormat | Spreadsheet file format assumed for the file
AWorksheetIndex: Integer = -1 | Index of the worksheet to be displayed in the grid (If empty then the active worksheet is loaded)
Description

Creates a new workbook and loads the given file into it. The file is assumed to have the given file format. Shows the sheet with the given sheet index.

Call this method only for built-in file formats.

Group

LoadFromSpreadsheetFile Method


TsCustomWorksheetGrid.LoadFromWorkbook Method

TsCustomWorksheetGrid.LoadFromWorkbook Method
Syntax
Pascal
procedure LoadFromWorkbook(AWorkbook: TsWorkbook; AWorksheetIndex: Integer = -1);
Parameters
Parameters | Description
AWorkbook: TsWorkbook | Workbook that had been created/loaded before.
AWorksheetIndex: Integer = -1 | Index of the worksheet to be shown in the grid (If empty then the active worksheet is loaded) Note THE CALLING PROCEDURE MUST NOT DESTROY THE WORKBOOK! The workbook will be destroyed by the workbook source.
Description

Loads an existing workbook into the grid.

Group

TsCustomWorksheetGrid Methods


MergeCells Method

MergeCells Method

This is the overview for the MergeCells method overload.

Overload List
Name | Description
TsCustomWorksheetGrid.MergeCells () | Merges the selected cells to a single large cell Only the upper left cell can have content and formatting (which is extended into the other cells).
TsCustomWorksheetGrid.MergeCells (Integer, Integer, Integer, Integer) | Merges the cells of the specified cell block to a single large cell Only the upper left cell can have content and formatting (which is extended into the other cells).
TsCustomWorksheetGrid.MergeCells (TGridRect) | Merges the cells of the specified cell block to a single large cell Only the upper left cell can have content and formatting (which is extended into the other cells).
Group

TsCustomWorksheetGrid Methods


TsCustomWorksheetGrid.MergeCells Method ()

TsCustomWorksheetGrid.MergeCells Method ()
Syntax
Pascal
procedure MergeCells; overload;
Description

Merges the selected cells to a single large cell Only the upper left cell can have content and formatting (which is extended into the other cells).

Group

MergeCells Method


TsCustomWorksheetGrid.MergeCells Method (Integer, Integer, Integer, Integer)

TsCustomWorksheetGrid.MergeCells Method (Integer, Integer, Integer, Integer)
Syntax
Pascal
procedure MergeCells(ALeft: Integer; ATop: Integer; ARight: Integer; ABottom: Integer); overload;
Description

Merges the cells of the specified cell block to a single large cell Only the upper left cell can have content and formatting (which is extended into the other cells).

Group

MergeCells Method


TsCustomWorksheetGrid.MergeCells Method (TGridRect)

TsCustomWorksheetGrid.MergeCells Method (TGridRect)
Syntax
Pascal
procedure MergeCells(ARect: TGridRect); overload;
Description

Merges the cells of the specified cell block to a single large cell Only the upper left cell can have content and formatting (which is extended into the other cells).

Group

MergeCells Method


TsCustomWorksheetGrid.MouseDown Method

TsCustomWorksheetGrid.MouseDown Method
Syntax
Pascal
procedure MouseDown(Button: TMouseButton; Shift: TShiftState; X: Integer; Y: Integer); override;
Description

Standard mouse down handler. Is overridden here to handle hyperlinks and to enter "enhanced edit mode" which removes formatting from the values and presents formulas for editing.

Group

TsCustomWorksheetGrid Methods


TsCustomWorksheetGrid.MouseMove Method

TsCustomWorksheetGrid.MouseMove Method
Syntax
Pascal
procedure MouseMove(Shift: TShiftState; X: Integer; Y: Integer); override;
Description

Standard mouse move handler. Is overridden because, if TextOverflow is active, overflown cell may be erased when the mouse leaves them; repaints entire grid instead.

Group

TsCustomWorksheetGrid Methods


TsCustomWorksheetGrid.MouseUp Method

TsCustomWorksheetGrid.MouseUp Method
Syntax
Pascal
procedure MouseUp(Button: TMouseButton; Shift: TShiftState; X: Integer; Y: Integer); override;
Group

TsCustomWorksheetGrid Methods


TsCustomWorksheetGrid.MoveSelection Method

TsCustomWorksheetGrid.MoveSelection Method
Syntax
Pascal
procedure MoveSelection; override;
Description

Standard method inherited from TCustomGrid. Notifies the WorkbookSource of the changed selected cell. Repaints the grid after moving selection to avoid spurious rests of the old thick selection border.

Group

TsCustomWorksheetGrid Methods


TsCustomWorksheetGrid.NewWorkbook Method

TsCustomWorksheetGrid.NewWorkbook Method
Syntax
Pascal
procedure NewWorkbook(AColCount: Integer; ARowCount: Integer);
Parameters
Parameters | Description
AColCount: Integer | Number of columns
ARowCount: Integer | Number of rows
Description

Creates a new empty workbook with the specified number of columns and rows.

Group

TsCustomWorksheetGrid Methods


TsCustomWorksheetGrid.Notification Method

TsCustomWorksheetGrid.Notification Method
Syntax
Pascal
procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Description

Standard component notification: The grid is notified that the WorkbookLink is being removed.

Group

TsCustomWorksheetGrid Methods


TsCustomWorksheetGrid.RemoveWorkbookSource Method

TsCustomWorksheetGrid.RemoveWorkbookSource Method
Syntax
Pascal
procedure RemoveWorkbookSource;
Description

Removes the link of the WorksheetGrid to the WorkbookSource. Required before destruction.

Group

TsCustomWorksheetGrid Methods


SaveToSpreadsheetFile Method

SaveToSpreadsheetFile Method

This is the overview for the SaveToSpreadsheetFile method overload.

Overload List
Name | Description
TsCustomWorksheetGrid.SaveToSpreadsheetFile (string, Boolean) |
TsCustomWorksheetGrid.SaveToSpreadsheetFile (string, TsSpreadFormatID, Boolean) |
TsCustomWorksheetGrid.SaveToSpreadsheetFile (string, TsSpreadsheetFormat, Boolean) |
Group

TsCustomWorksheetGrid Methods


TsCustomWorksheetGrid.SaveToSpreadsheetFile Method (string, Boolean)

TsCustomWorksheetGrid.SaveToSpreadsheetFile Method (string, Boolean)
Syntax
Pascal
procedure SaveToSpreadsheetFile(AFileName: string; AOverwriteExisting: Boolean = true); overload;
Group

SaveToSpreadsheetFile Method


TsCustomWorksheetGrid.SaveToSpreadsheetFile Method (string, TsSpreadFormatID, Boolean)

TsCustomWorksheetGrid.SaveToSpreadsheetFile Method (string, TsSpreadFormatID, Boolean)
Syntax
Pascal
procedure SaveToSpreadsheetFile(AFileName: string; AFormatID: TsSpreadFormatID; AOverwriteExisting: Boolean = true); overload;
Group

SaveToSpreadsheetFile Method


TsCustomWorksheetGrid.SaveToSpreadsheetFile Method (string, TsSpreadsheetFormat, Boolean)

TsCustomWorksheetGrid.SaveToSpreadsheetFile Method (string, TsSpreadsheetFormat, Boolean)
Syntax
Pascal
procedure SaveToSpreadsheetFile(AFileName: string; AFormat: TsSpreadsheetFormat; AOverwriteExisting: Boolean = true); overload; deprecated;
Group

SaveToSpreadsheetFile Method


TsCustomWorksheetGrid.SelectEditor Method

TsCustomWorksheetGrid.SelectEditor Method
Syntax
Pascal
procedure SelectEditor; override;
Description

Standard method inherited from TCustomGrid: Is called when editing starts. Is overridden here to store the old text just in case that the user presses ESC to cancel editing.

Group

TsCustomWorksheetGrid Methods


TsCustomWorksheetGrid.SelectSheetByIndex Method

TsCustomWorksheetGrid.SelectSheetByIndex Method
Syntax
Pascal
procedure SelectSheetByIndex(AIndex: Integer);
Parameters
Parameters | Description
AIndex: Integer | Index of the worksheet to be shown in the grid
Description

Loads the workbook into the grid and selects the sheet with the given index. "Selected" means here that the sheet is loaded into the grid.

Group

TsCustomWorksheetGrid Methods


TsCustomWorksheetGrid.SelPenChangeHandler Method

TsCustomWorksheetGrid.SelPenChangeHandler Method
Syntax
Pascal
procedure SelPenChangeHandler(Sender: TObject);
Group

TsCustomWorksheetGrid Methods


TsCustomWorksheetGrid.SetEditText Method

TsCustomWorksheetGrid.SetEditText Method
Syntax
Pascal
procedure SetEditText(ACol: Longint; ARow: Longint; const AValue: string); override;
Parameters
Parameters | Description
ACol: Longint | Grid column index of the cell being edited
ARow: Longint | Grid row index of the cell being edited
const AValue: string | String which is currently in the cell editor
Description

Standard method inherited from TCustomGrid. Fetches the text that is currently in the editor. It is not yet transferred to the worksheet because input will be checked only at the end of editing.

Group

TsCustomWorksheetGrid Methods


TsCustomWorksheetGrid.Setup Method

TsCustomWorksheetGrid.Setup Method
Syntax
Pascal
procedure Setup;
Description

Helper method for setting up the rows and columns after a new workbook is loaded or created. Sets up the grid's column and row count, as well as the initial column widths and row heights.

Group

TsCustomWorksheetGrid Methods


TsCustomWorksheetGrid.ShowCellBorders Method

TsCustomWorksheetGrid.ShowCellBorders Method
Syntax
Pascal
procedure ShowCellBorders(ALeft: Integer; ATop: Integer; ARight: Integer; ABottom: Integer; const ALeftOuterStyle: TsCellBorderStyle; const ATopOuterStyle: TsCellBorderStyle; const ARightOuterStyle: TsCellBorderStyle; const ABottomOuterStyle: TsCellBorderStyle; const AHorInnerStyle: TsCellBorderStyle; const AVertInnerStyle: TsCellBorderStyle);
Description

Shows cell borders for the cells in the range between columns ALeft and ARight and rows ATop and ABottom. The border of the block's left outer edge is defined by ALeftOuterStyle, that of the block's top outer edge by ATopOuterStyle, etc. Set the color of a border style to scNotDefined or scTransparent in order to hide the corresponding border line, or use the constant NO_CELL_BORDER.

Group

TsCustomWorksheetGrid Methods


TsCustomWorksheetGrid.Sort Method

TsCustomWorksheetGrid.Sort Method
Syntax
Pascal
procedure Sort(AColSorting: Boolean; AIndex: Integer; AIndxFrom: Integer; AIndxTo: Integer); override;
Parameters
Parameters | Description
AColSorting: Boolean | If true the grid is sorted from top to bottom and the next parameter, "Index", refers to a column. Otherweise sorting goes from left to right and "Index" refers to a row.
AIndex: Integer | Index of the column (if ColSorting=true) or row (ColSorting = false) which is sorted.
AIndxFrom: Integer | Sorting starts at this row (ColSorting=true) / column (ColSorting=false)
AIndxTo: Integer | Sorting ends at this row (ColSorting=true) / column (ColSorting=false)
Description

Sorts the grid by calling the corresponding method of the worksheet. Sorting extends across the entire worksheet. Sort direction is determined by the property "SortOrder". Other sorting criteria are "case-sensitive" and "numbers first".

Group

TsCustomWorksheetGrid Methods


TsCustomWorksheetGrid.TopLeftChanged Method

TsCustomWorksheetGrid.TopLeftChanged Method
Syntax
Pascal
procedure TopLeftChanged; override;
Description

Inherited method called whenever to grid is scrolled, i.e. the top/left cell changes. Is overridden to calculate the row heights of the currently visible grid

Group

TsCustomWorksheetGrid Methods


TsCustomWorksheetGrid.TrimToCell Method

TsCustomWorksheetGrid.TrimToCell Method
Syntax
Pascal
function TrimToCell(ACell: PCell): String;
Description

Modifies the text that is show for cells which are too narrow to hold the entire text. The method follows the behavior of Excel and Open/LibreOffice: If the specified cell contains a non-formatted number, then it is formatted such that the text fits into the cell. If the text is still too long or the cell does not contain a label then the cell is filled by '#' characters. Label cell texts are not modified, they can overflow into the adjacent cells.

Group

TsCustomWorksheetGrid Methods


UnmergeCells Method

UnmergeCells Method

This is the overview for the UnmergeCells method overload.

Overload List
Name | Description
TsCustomWorksheetGrid.UnmergeCells () | Splits a merged cell block into single cells
TsCustomWorksheetGrid.UnmergeCells (Integer, Integer) | If the specified cell belongs to a merged block, the merged block is split into single cells
Group

TsCustomWorksheetGrid Methods


TsCustomWorksheetGrid.UnmergeCells Method ()

TsCustomWorksheetGrid.UnmergeCells Method ()
Syntax
Pascal
procedure UnmergeCells; overload;
Description

Splits a merged cell block into single cells

Group

UnmergeCells Method


TsCustomWorksheetGrid.UnmergeCells Method (Integer, Integer)

TsCustomWorksheetGrid.UnmergeCells Method (Integer, Integer)
Syntax
Pascal
procedure UnmergeCells(ACol: Integer; ARow: Integer); overload;
Description

If the specified cell belongs to a merged block, the merged block is split into single cells

Group

UnmergeCells Method


TsCustomWorksheetGrid.UpdateColWidths Method

TsCustomWorksheetGrid.UpdateColWidths Method
Syntax
Pascal
procedure UpdateColWidths(AStartIndex: Integer = 0);
Description

Updates column widths according to the data in the TCol records

Group

TsCustomWorksheetGrid Methods


TsCustomWorksheetGrid.UpdateRowHeights Method

TsCustomWorksheetGrid.UpdateRowHeights Method
Syntax
Pascal
procedure UpdateRowHeights(AStartIndex: Integer = 0);
Description

Updates row heights by using the data from the TRow records or by auto- calculating the row height from the max of the cell heights

Group

TsCustomWorksheetGrid Methods


TsCustomWorksheetGrid Properties

TsCustomWorksheetGrid Properties

The properties of the TsCustomWorksheetGrid class are listed here.

Class

TsCustomWorksheetGrid Class

Protected Properties
Name | Description
AutoCalc | Automatically recalculate formulas whenever a cell value changes.
AutoExpand | Automatically expand grid dimensions
DisplayFixedColRow | Displays column and row headers in the fixed col/row style of the grid. Deprecated. Use ShowHeaders instead.
FrozenCols | This number of columns at the left is "frozen", i.e. it is not possible to scroll these columns
FrozenRows | This number of rows at the top is "frozen", i.e. it is not possible to scroll these rows.
ReadFormulas | Activates reading of RPN formulas. Should be turned off when non-implemented formulas crashe reading of the spreadsheet file.
SelectionPen | Pen used for drawing the selection rectangle
ShowGridLines | Shows/hides vertical and horizontal grid lines
ShowHeaders | Shows/hides column and row headers in the fixed col/row style of the grid.
TextOverflow | Activates text overflow (cells reaching into neighbors)
Public Properties
Name | Description
BackgroundColor | Background color of the cell at the given column and row. Expressed as index into the workbook's color palette.
BackgroundColors | Common background color of the cells covered by the given rectangle. Expressed as index into the workbook's color palette.
CellBiDiMode | Override system or sheet right-to-left mode for cell
CellBorder | Set of flags indicating at which cell border a border line is drawn.
CellBorders | Set of flags indicating at which border of a range of cells a border line is drawn
CellBorderStyle | Style of the border line at the given border of the cell at column ACol and row ARow. Requires the cellborder flag of the border to be set for the border line to be shown
CellBorderStyles | Style of the border line at the given border of the cells within the range of colum/row indexes defined by the rectangle. Requires the cellborder flag of the border to be set for the border line to be shown
CellComment | Comment assigned to the cell at column ACol and row ARow
CellFont | Font to be used for text in the cell at column ACol and row ARow.
CellFontColor | Color of the font used for the cell in column ACol and row ARow
CellFontColors | Color of the font used for the cells within the range of column/row indexes defined by the rectangle, scUndefined if not constant.
CellFontName | Name of the font used for the cell in column ACol and row ARow
CellFontNames | Name of the font used for the cells within the range of column/row indexes defined by the rectangle.
CellFonts | Font to be used for the cells in the column/row index range given by the rectangle
CellFontSize | Size of the font (in points) used for the cell at column ACol and row ARow
CellFontSizes | Size of the font (in points) used for the cells within the range of column/row indexes defined by the rectangle.
CellFontStyle | Style of the font (bold, italic, ...) used for text in the cell at column ACol and row ARow.
CellFontStyles | Style of the font (bold, italic, ...) used for the cells within the range of column/row indexes defined by the rectangle.
Cells | Cell values
ColWidths | Column width, in pixels
DefaultColWidth | Default column width, in pixels
DefaultRowHeight | Default row height, in pixels
HeaderCount | Count of header lines - for conversion between grid- and workbook-based row and column indexes. Either 1 if row and column headers are shown or 0 if not
HorAlignment | Parameter for horizontal text alignment within the cell at column ACol and row ARow
HorAlignments | Parameter for the horizontal text alignments in all cells within the range cf column/row indexes defined by the rectangle.
Hyperlink | Hyperlink assigned to the cell in row ARow and column ACol
NumberFormat | Number format (as Excel string) to be applied to cell at column ACol and row ARow.
NumberFormats | Number format (as Excel string) to be applied to all cells within the range of column/row indexes defined by the rectangle.
RangeSelectMode | Allow multiple selections
RowHeights | Row height in pixels
TextRotation | Rotation of the text in the cell at column ACol and row ARow.
TextRotations | Rotation of the text in the cells within the range of column/row indexes defined by the rectangle.
VertAlignment | Parameter for vertical text alignment in the cell at column ACol and row ARow.
VertAlignments | Parameter for vertical text alignment in the cells having column/row indexes defined by the rectangle.
Wordwrap | If true, word-wrapping of text within the cell at column ACol and row ARow is activated.
Wordwraps | If true, word-wrapping of text within all cells within the range defined by the rectangle is activated.
Workbook | Workbook displayed in the grid
WorkbookSource | Link to the workbook
Worksheet | Currently selected worksheet of the workbook


TsCustomWorksheetGrid.AutoCalc Property

TsCustomWorksheetGrid.AutoCalc Property
Syntax
Pascal
property AutoCalc: Boolean;
Description

Automatically recalculate formulas whenever a cell value changes.

Group

TsCustomWorksheetGrid Properties


TsCustomWorksheetGrid.AutoExpand Property

TsCustomWorksheetGrid.AutoExpand Property
Syntax
Pascal
property AutoExpand: TsAutoExpandModes;
Description

Automatically expand grid dimensions

Group

TsCustomWorksheetGrid Properties


TsCustomWorksheetGrid.BackgroundColor Property

TsCustomWorksheetGrid.BackgroundColor Property
Syntax
Pascal
property BackgroundColor [ACol, ARow: Integer]: TsColor;
Description

Background color of the cell at the given column and row. Expressed as index into the workbook's color palette.

Group

TsCustomWorksheetGrid Properties


TsCustomWorksheetGrid.BackgroundColors Property

TsCustomWorksheetGrid.BackgroundColors Property
Syntax
Pascal
property BackgroundColors [ALeft, ATop, ARight, ABottom: Integer]: TsColor;
Description

Common background color of the cells covered by the given rectangle. Expressed as index into the workbook's color palette.

Group

TsCustomWorksheetGrid Properties


TsCustomWorksheetGrid.CellBiDiMode Property

TsCustomWorksheetGrid.CellBiDiMode Property
Syntax
Pascal
property CellBiDiMode [ACol,ARow: Integer]: TsBiDiMode;
Description

Override system or sheet right-to-left mode for cell

Group

TsCustomWorksheetGrid Properties


TsCustomWorksheetGrid.CellBorder Property

TsCustomWorksheetGrid.CellBorder Property
Syntax
Pascal
property CellBorder [ACol, ARow: Integer]: TsCellBorders;
Description

Set of flags indicating at which cell border a border line is drawn.

Group

TsCustomWorksheetGrid Properties


TsCustomWorksheetGrid.CellBorders Property

TsCustomWorksheetGrid.CellBorders Property
Syntax
Pascal
property CellBorders [ALeft, ATop, ARight, ABottom: Integer]: TsCellBorders;
Description

Set of flags indicating at which border of a range of cells a border line is drawn

Group

TsCustomWorksheetGrid Properties


TsCustomWorksheetGrid.CellBorderStyle Property

TsCustomWorksheetGrid.CellBorderStyle Property
Syntax
Pascal
property CellBorderStyle [ACol, ARow: Integer; ABorder: TsCellBorder]: TsCellBorderStyle;
Description

Style of the border line at the given border of the cell at column ACol and row ARow. Requires the cellborder flag of the border to be set for the border line to be shown

Group

TsCustomWorksheetGrid Properties


TsCustomWorksheetGrid.CellBorderStyles Property

TsCustomWorksheetGrid.CellBorderStyles Property
Syntax
Pascal
property CellBorderStyles [ALeft, ATop, ARight, ABottom: Integer; ABorder: TsCellBorder]: TsCellBorderStyle;
Description

Style of the border line at the given border of the cells within the range of colum/row indexes defined by the rectangle. Requires the cellborder flag of the border to be set for the border line to be shown

Group

TsCustomWorksheetGrid Properties


TsCustomWorksheetGrid.CellComment Property

TsCustomWorksheetGrid.CellComment Property
Syntax
Pascal
property CellComment [ACol, ARow: Integer]: String;
Description

Comment assigned to the cell at column ACol and row ARow

Group

TsCustomWorksheetGrid Properties


TsCustomWorksheetGrid.CellFont Property

TsCustomWorksheetGrid.CellFont Property
Syntax
Pascal
property CellFont [ACol, ARow: Integer]: TFont;
Description

Font to be used for text in the cell at column ACol and row ARow.

Group

TsCustomWorksheetGrid Properties


TsCustomWorksheetGrid.CellFontColor Property

TsCustomWorksheetGrid.CellFontColor Property
Syntax
Pascal
property CellFontColor [ACol, ARow: Integer]: TsColor;
Description

Color of the font used for the cell in column ACol and row ARow

Group

TsCustomWorksheetGrid Properties


TsCustomWorksheetGrid.CellFontColors Property

TsCustomWorksheetGrid.CellFontColors Property
Syntax
Pascal
property CellFontColors [ALeft, ATop, ARight, ABottom: Integer]: TsColor;
Description

Color of the font used for the cells within the range of column/row indexes defined by the rectangle, scUndefined if not constant.

Group

TsCustomWorksheetGrid Properties


TsCustomWorksheetGrid.CellFontName Property

TsCustomWorksheetGrid.CellFontName Property
Syntax
Pascal
property CellFontName [ACol, ARow: Integer]: String;
Description

Name of the font used for the cell in column ACol and row ARow

Group

TsCustomWorksheetGrid Properties


TsCustomWorksheetGrid.CellFontNames Property

TsCustomWorksheetGrid.CellFontNames Property
Syntax
Pascal
property CellFontNames [ALeft, ATop, ARight, ABottom: Integer]: String;
Description

Name of the font used for the cells within the range of column/row indexes defined by the rectangle.

Group

TsCustomWorksheetGrid Properties


TsCustomWorksheetGrid.CellFonts Property

TsCustomWorksheetGrid.CellFonts Property
Syntax
Pascal
property CellFonts [ALeft, ATop, ARight, ABottom: Integer]: TFont;
Description

Font to be used for the cells in the column/row index range given by the rectangle

Group

TsCustomWorksheetGrid Properties


TsCustomWorksheetGrid.CellFontSize Property

TsCustomWorksheetGrid.CellFontSize Property
Syntax
Pascal
property CellFontSize [ACol, ARow: Integer]: Single;
Description

Size of the font (in points) used for the cell at column ACol and row ARow

Group

TsCustomWorksheetGrid Properties


TsCustomWorksheetGrid.CellFontSizes Property

TsCustomWorksheetGrid.CellFontSizes Property
Syntax
Pascal
property CellFontSizes [ALeft, ATop, ARight, ABottom: Integer]: Single;
Description

Size of the font (in points) used for the cells within the range of column/row indexes defined by the rectangle.

Group

TsCustomWorksheetGrid Properties


TsCustomWorksheetGrid.CellFontStyle Property

TsCustomWorksheetGrid.CellFontStyle Property
Syntax
Pascal
property CellFontStyle [ACol, ARow: Integer]: TsFontStyles;
Description

Style of the font (bold, italic, ...) used for text in the cell at column ACol and row ARow.

Group

TsCustomWorksheetGrid Properties


TsCustomWorksheetGrid.CellFontStyles Property

TsCustomWorksheetGrid.CellFontStyles Property
Syntax
Pascal
property CellFontStyles [ALeft, ATop, ARight, ABottom: Integer]: TsFontStyles;
Description

Style of the font (bold, italic, ...) used for the cells within the range of column/row indexes defined by the rectangle.

Group

TsCustomWorksheetGrid Properties


TsCustomWorksheetGrid.Cells Property

TsCustomWorksheetGrid.Cells Property
Syntax
Pascal
property Cells [ACol, ARow: Integer]: Variant;
Description

Cell values

Group

TsCustomWorksheetGrid Properties


TsCustomWorksheetGrid.ColWidths Property

TsCustomWorksheetGrid.ColWidths Property
Syntax
Pascal
property ColWidths [ACol: Integer]: Integer;
Description

Column width, in pixels

Group

TsCustomWorksheetGrid Properties


TsCustomWorksheetGrid.DefaultColWidth Property

TsCustomWorksheetGrid.DefaultColWidth Property
Syntax
Pascal
property DefaultColWidth: Integer;
Description

Default column width, in pixels

Group

TsCustomWorksheetGrid Properties


TsCustomWorksheetGrid.DefaultRowHeight Property

TsCustomWorksheetGrid.DefaultRowHeight Property
Syntax
Pascal
property DefaultRowHeight: Integer;
Description

Default row height, in pixels

Group

TsCustomWorksheetGrid Properties


TsCustomWorksheetGrid.DisplayFixedColRow Property

TsCustomWorksheetGrid.DisplayFixedColRow Property
Syntax
Pascal
property DisplayFixedColRow: Boolean;
Description

Displays column and row headers in the fixed col/row style of the grid. Deprecated. Use ShowHeaders instead.

Group

TsCustomWorksheetGrid Properties


TsCustomWorksheetGrid.FrozenCols Property

TsCustomWorksheetGrid.FrozenCols Property
Syntax
Pascal
property FrozenCols: Integer;
Description

This number of columns at the left is "frozen", i.e. it is not possible to scroll these columns

Group

TsCustomWorksheetGrid Properties


TsCustomWorksheetGrid.FrozenRows Property

TsCustomWorksheetGrid.FrozenRows Property
Syntax
Pascal
property FrozenRows: Integer;
Description

This number of rows at the top is "frozen", i.e. it is not possible to scroll these rows.

Group

TsCustomWorksheetGrid Properties


TsCustomWorksheetGrid.HeaderCount Property

TsCustomWorksheetGrid.HeaderCount Property
Syntax
Pascal
property HeaderCount: Integer;
Description

Count of header lines - for conversion between grid- and workbook-based row and column indexes. Either 1 if row and column headers are shown or 0 if not

Group

TsCustomWorksheetGrid Properties


TsCustomWorksheetGrid.HorAlignment Property

TsCustomWorksheetGrid.HorAlignment Property
Syntax
Pascal
property HorAlignment [ACol, ARow: Integer]: TsHorAlignment;
Description

Parameter for horizontal text alignment within the cell at column ACol and row ARow

Group

TsCustomWorksheetGrid Properties


TsCustomWorksheetGrid.HorAlignments Property

TsCustomWorksheetGrid.HorAlignments Property
Syntax
Pascal
property HorAlignments [ALeft, ATop, ARight, ABottom: Integer]: TsHorAlignment;
Description

Parameter for the horizontal text alignments in all cells within the range cf column/row indexes defined by the rectangle.

Group

TsCustomWorksheetGrid Properties


TsCustomWorksheetGrid.Hyperlink Property

TsCustomWorksheetGrid.Hyperlink Property
Syntax
Pascal
property Hyperlink [ACol, ARow: Integer]: String;
Description

Hyperlink assigned to the cell in row ARow and column ACol

Group

TsCustomWorksheetGrid Properties


TsCustomWorksheetGrid.NumberFormat Property

TsCustomWorksheetGrid.NumberFormat Property
Syntax
Pascal
property NumberFormat [ACol, ARow: Integer]: String;
Description

Number format (as Excel string) to be applied to cell at column ACol and row ARow.

Group

TsCustomWorksheetGrid Properties


TsCustomWorksheetGrid.NumberFormats Property

TsCustomWorksheetGrid.NumberFormats Property
Syntax
Pascal
property NumberFormats [ALeft, ATop, ARight, ABottom: Integer]: String;
Description

Number format (as Excel string) to be applied to all cells within the range of column/row indexes defined by the rectangle.

Group

TsCustomWorksheetGrid Properties


TsCustomWorksheetGrid.RangeSelectMode Property

TsCustomWorksheetGrid.RangeSelectMode Property
Syntax
Pascal
property RangeSelectMode;
Description

Allow multiple selections

Group

TsCustomWorksheetGrid Properties


TsCustomWorksheetGrid.ReadFormulas Property

TsCustomWorksheetGrid.ReadFormulas Property
Syntax
Pascal
property ReadFormulas: Boolean;
Description

Activates reading of RPN formulas. Should be turned off when non-implemented formulas crashe reading of the spreadsheet file.

Group

TsCustomWorksheetGrid Properties


TsCustomWorksheetGrid.RowHeights Property

TsCustomWorksheetGrid.RowHeights Property
Syntax
Pascal
property RowHeights [ARow: Integer]: Integer;
Description

Row height in pixels

Group

TsCustomWorksheetGrid Properties


TsCustomWorksheetGrid.SelectionPen Property

TsCustomWorksheetGrid.SelectionPen Property
Syntax
Pascal
property SelectionPen: TsSelPen;
Description

Pen used for drawing the selection rectangle

Group

TsCustomWorksheetGrid Properties


TsCustomWorksheetGrid.ShowGridLines Property

TsCustomWorksheetGrid.ShowGridLines Property
Syntax
Pascal
property ShowGridLines: Boolean;
Description

Shows/hides vertical and horizontal grid lines

Group

TsCustomWorksheetGrid Properties


TsCustomWorksheetGrid.ShowHeaders Property

TsCustomWorksheetGrid.ShowHeaders Property
Syntax
Pascal
property ShowHeaders: Boolean;
Description

Shows/hides column and row headers in the fixed col/row style of the grid.

Group

TsCustomWorksheetGrid Properties


TsCustomWorksheetGrid.TextOverflow Property

TsCustomWorksheetGrid.TextOverflow Property
Syntax
Pascal
property TextOverflow: Boolean;
Description

Activates text overflow (cells reaching into neighbors)

Group

TsCustomWorksheetGrid Properties


TsCustomWorksheetGrid.TextRotation Property

TsCustomWorksheetGrid.TextRotation Property
Syntax
Pascal
property TextRotation [ACol, ARow: Integer]: TsTextRotation;
Description

Rotation of the text in the cell at column ACol and row ARow.

Group

TsCustomWorksheetGrid Properties


TsCustomWorksheetGrid.TextRotations Property

TsCustomWorksheetGrid.TextRotations Property
Syntax
Pascal
property TextRotations [ALeft, ATop, ARight, ABottom: Integer]: TsTextRotation;
Description

Rotation of the text in the cells within the range of column/row indexes defined by the rectangle.

Group

TsCustomWorksheetGrid Properties


TsCustomWorksheetGrid.VertAlignment Property

TsCustomWorksheetGrid.VertAlignment Property
Syntax
Pascal
property VertAlignment [ACol, ARow: Integer]: TsVertAlignment;
Description

Parameter for vertical text alignment in the cell at column ACol and row ARow.

Group

TsCustomWorksheetGrid Properties


TsCustomWorksheetGrid.VertAlignments Property

TsCustomWorksheetGrid.VertAlignments Property
Syntax
Pascal
property VertAlignments [ALeft, ATop, ARight, ABottom: Integer]: TsVertAlignment;
Description

Parameter for vertical text alignment in the cells having column/row indexes defined by the rectangle.

Group

TsCustomWorksheetGrid Properties


TsCustomWorksheetGrid.Wordwrap Property

TsCustomWorksheetGrid.Wordwrap Property
Syntax
Pascal
property Wordwrap [ACol, ARow: Integer]: Boolean;
Description

If true, word-wrapping of text within the cell at column ACol and row ARow is activated.

Group

TsCustomWorksheetGrid Properties


TsCustomWorksheetGrid.Wordwraps Property

TsCustomWorksheetGrid.Wordwraps Property
Syntax
Pascal
property Wordwraps [ALeft, ATop, ARight, ABottom: Integer]: Boolean;
Description

If true, word-wrapping of text within all cells within the range defined by the rectangle is activated.

Group

TsCustomWorksheetGrid Properties


TsCustomWorksheetGrid.Workbook Property

TsCustomWorksheetGrid.Workbook Property
Syntax
Pascal
property Workbook: TsWorkbook;
Description

Workbook displayed in the grid

Group

TsCustomWorksheetGrid Properties


TsCustomWorksheetGrid.WorkbookSource Property

TsCustomWorksheetGrid.WorkbookSource Property
Syntax
Pascal
property WorkbookSource: TsWorkbookSource;
Description

Link to the workbook

Group

TsCustomWorksheetGrid Properties


TsCustomWorksheetGrid.Worksheet Property

TsCustomWorksheetGrid.Worksheet Property
Syntax
Pascal
property Worksheet: TsWorksheet;
Description

Currently selected worksheet of the workbook

Group

TsCustomWorksheetGrid Properties


TsCustomWorksheetGrid Events

TsCustomWorksheetGrid Events

The events of the TsCustomWorksheetGrid class are listed here.

Class

TsCustomWorksheetGrid Class

Protected Events
Name | Description
OnClickHyperlink | Event called when an external hyperlink is clicked


TsCustomWorksheetGrid.OnClickHyperlink Event

TsCustomWorksheetGrid.OnClickHyperlink Event
Syntax
Pascal
property OnClickHyperlink: TsHyperlinkClickEvent;
Description

Event called when an external hyperlink is clicked

Group

TsCustomWorksheetGrid Events


TsNumFormatList Class

TsNumFormatList Class
Class Hierarchy
  TsNumFormatList
Syntax
Pascal
TsNumFormatList = class(TFPList);
File

fpsnumformat

Description

List containing parsed number format parameters

Group

Classes


TsNumFormatList Members

TsNumFormatList Members

The following tables list the members exposed by TsNumFormatList.

Class

TsNumFormatList Class

Protected Fields
Name | Description
FClass |
FFormatSettings |
Protected Methods
Name | Description
AddBuiltinFormats | Adds the number formats to the list which are built into the file format. Does nothing here. Must be overridden by derived classes for each file format.
Public Methods
Name | Description
AddFormat | This is the overview for the AddFormat method overload.
Clear | Clears the list. If the list "owns" the format items they are destroyed.
Create | Constructor of the number format list class.
Delete | Deletes the number format item having the specified index in the list. If the list "owns" the format items, the item is destroyed.
Destroy | Destructor of the number format list class. Clears the list items if the list "owns" the data.
Find | This is the overview for the Find method overload.
Public Properties
Name | Description
Items |


TsNumFormatList.Create Constructor

TsNumFormatList.Create Constructor
Syntax
Pascal
constructor Create(AFormatSettings: TFormatSettings; AOwnsData: Boolean);
Parameters
Parameters | Description
AFormatSettings: TFormatSettings | Format settings needed internally by the number format parser (currency symbol, etc.)
AOwnsData: Boolean | If true then the list is responsible to destroy the list items
Description

Constructor of the number format list class.

Class

TsNumFormatList Class


TsNumFormatList.Destroy Destructor

TsNumFormatList.Destroy Destructor
Syntax
Pascal
destructor Destroy; override;
Description

Destructor of the number format list class.

Clears the list items if the list "owns" the data.

Class

TsNumFormatList Class


TsNumFormatList Fields

TsNumFormatList Fields

The fields of the TsNumFormatList class are listed here.

Class

TsNumFormatList Class

Protected Fields
Name | Description
FClass |
FFormatSettings |


TsNumFormatList.FClass Field

TsNumFormatList.FClass Field
Syntax
Pascal
FClass: TsNumFormatParamsClass;
Group

TsNumFormatList Fields


TsNumFormatList.FFormatSettings Field

TsNumFormatList.FFormatSettings Field
Syntax
Pascal
FFormatSettings: TFormatSettings;
Group

TsNumFormatList Fields


TsNumFormatList Methods

TsNumFormatList Methods

The methods of the TsNumFormatList class are listed here.

Class

TsNumFormatList Class

Protected Methods
Name | Description
AddBuiltinFormats | Adds the number formats to the list which are built into the file format. Does nothing here. Must be overridden by derived classes for each file format.
Public Methods
Name | Description
AddFormat | This is the overview for the AddFormat method overload.
Clear | Clears the list. If the list "owns" the format items they are destroyed.
Delete | Deletes the number format item having the specified index in the list. If the list "owns" the format items, the item is destroyed.
Find | This is the overview for the Find method overload.


TsNumFormatList.AddBuiltinFormats Method

TsNumFormatList.AddBuiltinFormats Method
Syntax
Pascal
procedure AddBuiltinFormats; virtual;
Description

Adds the number formats to the list which are built into the file format.

Does nothing here. Must be overridden by derived classes for each file format.

Group

TsNumFormatList Methods


AddFormat Method

AddFormat Method

This is the overview for the AddFormat method overload.

Overload List
Name | Description
TsNumFormatList.AddFormat (String) | Adds a number format as specified by a format string to the list Uses the number format parser to convert the format string to format sections and elements. Duplicates are not checked before adding the format item.
TsNumFormatList.AddFormat (TsNumFormatSections) | Adds the specified sections of a parsed number format to the list. Duplicates are not checked before adding the format item.
Group

TsNumFormatList Methods


TsNumFormatList.AddFormat Method (String)

TsNumFormatList.AddFormat Method (String)
Syntax
Pascal
function AddFormat(AFormatStr: String): Integer; overload;
Parameters
Parameters | Description
AFormatStr: String | Excel-like format string describing the format to be added
Returns

Index of the format item in the list

Description

Adds a number format as specified by a format string to the list Uses the number format parser to convert the format string to format sections and elements.

Duplicates are not checked before adding the format item.

Group

AddFormat Method


TsNumFormatList.AddFormat Method (TsNumFormatSections)

TsNumFormatList.AddFormat Method (TsNumFormatSections)
Syntax
Pascal
function AddFormat(ASections: TsNumFormatSections): Integer; overload;
Parameters
Parameters | Description
ASections: TsNumFormatSections | Array of number format sections as obtained by the number format parser for a given format string
Returns

Index of the format item in the list.

Description

Adds the specified sections of a parsed number format to the list. Duplicates are not checked before adding the format item.

Group

AddFormat Method


TsNumFormatList.Clear Method

TsNumFormatList.Clear Method
Syntax
Pascal
procedure Clear;
Description

Clears the list. If the list "owns" the format items they are destroyed.

See Also

TsNumFormatList.Create

Group

TsNumFormatList Methods


TsNumFormatList.Delete Method

TsNumFormatList.Delete Method
Syntax
Pascal
procedure Delete(AIndex: Integer);
Parameters
Parameters | Description
AIndex: Integer | Index of the format item to be deleted
Description

Deletes the number format item having the specified index in the list. If the list "owns" the format items, the item is destroyed.

See Also

TsNumformatList.Create

Group

TsNumFormatList Methods


Find Method

Find Method

This is the overview for the Find method overload.

Overload List
Name | Description
TsNumFormatList.Find (String) | Checks whether a format item corresponding to the specified format string is contained in the list and returns its index if found, or -1 if not. Should be called before adding a format to the list to avoid duplicates.
TsNumFormatList.Find (TsNumFormatSections) | Checks whether a parsed format item having the specified format sections is contained in the list and returns its index if found, or -1 if not found.
Group

TsNumFormatList Methods


TsNumFormatList.Find Method (String)

TsNumFormatList.Find Method (String)
Syntax
Pascal
function Find(AFormatstr: String): Integer; overload;
Parameters
Parameters | Description
AFormatstr: String | Number format string of the format item which is seeked
Returns

Index of the found format item, or -1 if not found

Description

Checks whether a format item corresponding to the specified format string is contained in the list and returns its index if found, or -1 if not.

Should be called before adding a format to the list to avoid duplicates.

See Also

TsNumFormatList.Add

Group

Find Method


TsNumFormatList.Find Method (TsNumFormatSections)

TsNumFormatList.Find Method (TsNumFormatSections)
Syntax
Pascal
function Find(ASections: TsNumFormatSections): Integer; overload;
Parameters
Parameters | Description
ASections: TsNumFormatSections | Array of number format sections as obtained by the number format parser for a given format string
Returns

Index of the found format item, or -1 if not found

Description

Checks whether a parsed format item having the specified format sections is contained in the list and returns its index if found, or -1 if not found.

Group

Find Method


TsNumFormatList Properties

TsNumFormatList Properties

The properties of the TsNumFormatList class are listed here.

Class

TsNumFormatList Class

Public Properties
Name | Description
Items |


TsNumFormatList.Items Property

TsNumFormatList.Items Property
Syntax
Pascal
property Items [AIndex: Integer]: TsNumFormatParams;
Group

TsNumFormatList Properties


TsNumFormatParams Class

TsNumFormatParams Class
Class Hierarchy
  TsNumFormatParams
Syntax
Pascal
TsNumFormatParams = class(TObject);
File

fpsnumformat

Description

Describes a parsed number format and provides all the information to convert a number to a number or date/time string. These data are created by the number format parser from a format string.

Group

Classes


TsNumFormatParams Members

TsNumFormatParams Members

The following tables list the members exposed by TsNumFormatParams.

Class

TsNumFormatParams Class

Protected Methods
Name | Description
GetNumFormat | Creates the built-in number format identifier from the parsed number format sections and elements
GetNumFormatStr | Constructs the number format string from the parsed sections and elements. The format symbols are selected according to Excel syntax.
Public Fields
Name | Description
Sections | Array of the format sections
Public Methods
Name | Description
DeleteElement | Deletes a parsed number format element from the specified format section.
InsertElement | Inserts a parsed format token into the specified format section before the specified element.
SectionsEqualTo | Checks whether the parsed format sections passed as a parameter are identical to the interal section array.
SetCurrSymbol | Defines the currency symbol used in the format params sequence
SetDecimals |
SetNegativeRed | If AEnable is true a format section for negative numbers is added (or an existing one is modified) such that negative numbers are displayed in red. If AEnable is false the format tokens are modified such that negative values are displayed in default color.
SetThousandSep | Inserts a thousand separator token into the format elements at the appropriate position, or removes it
Public Properties
Name | Description
NumFormat |
NumFormatStr |


TsNumFormatParams Fields

TsNumFormatParams Fields

The fields of the TsNumFormatParams class are listed here.

Class

TsNumFormatParams Class

Public Fields
Name | Description
Sections | Array of the format sections


TsNumFormatParams.Sections Field

TsNumFormatParams.Sections Field
Syntax
Pascal
Sections: TsNumFormatSections;
Description

Array of the format sections

Group

TsNumFormatParams Fields


TsNumFormatParams Methods

TsNumFormatParams Methods

The methods of the TsNumFormatParams class are listed here.

Class

TsNumFormatParams Class

Protected Methods
Name | Description
GetNumFormat | Creates the built-in number format identifier from the parsed number format sections and elements
GetNumFormatStr | Constructs the number format string from the parsed sections and elements. The format symbols are selected according to Excel syntax.
Public Methods
Name | Description
DeleteElement | Deletes a parsed number format element from the specified format section.
InsertElement | Inserts a parsed format token into the specified format section before the specified element.
SectionsEqualTo | Checks whether the parsed format sections passed as a parameter are identical to the interal section array.
SetCurrSymbol | Defines the currency symbol used in the format params sequence
SetDecimals |
SetNegativeRed | If AEnable is true a format section for negative numbers is added (or an existing one is modified) such that negative numbers are displayed in red. If AEnable is false the format tokens are modified such that negative values are displayed in default color.
SetThousandSep | Inserts a thousand separator token into the format elements at the appropriate position, or removes it


TsNumFormatParams.DeleteElement Method

TsNumFormatParams.DeleteElement Method
Syntax
Pascal
procedure DeleteElement(ASectionIndex: Integer; AElementIndex: Integer);
Parameters
Parameters | Description
ASectionIndex: Integer | Index of the format section containing the element to be deleted
AElementIndex: Integer | Index of the format element to be deleted
Description

Deletes a parsed number format element from the specified format section.

Group

TsNumFormatParams Methods


TsNumFormatParams.GetNumFormat Method

TsNumFormatParams.GetNumFormat Method
Syntax
Pascal
function GetNumFormat: TsNumberFormat; virtual;
Returns

Built-in number format identifer if the format is built into fpspreadsheet, or nfCustom otherwise

Description

Creates the built-in number format identifier from the parsed number format sections and elements

See Also

TsNumFormat

Group

TsNumFormatParams Methods


TsNumFormatParams.GetNumFormatStr Method

TsNumFormatParams.GetNumFormatStr Method
Syntax
Pascal
function GetNumFormatStr: String; virtual;
Returns

Excel-compatible number format string.

Description

Constructs the number format string from the parsed sections and elements. The format symbols are selected according to Excel syntax.

Group

TsNumFormatParams Methods


TsNumFormatParams.InsertElement Method

TsNumFormatParams.InsertElement Method
Syntax
Pascal
procedure InsertElement(ASectionIndex: Integer; AElementIndex: Integer; AToken: TsNumFormatToken);
Parameters
Parameters | Description
ASectionIndex: Integer | Index of the parsed format section into which the token is to be inserted
AElementIndex: Integer | Index of the format element before which the token is to be inserted
AToken: TsNumFormatToken | Parsed format token to be inserted
Description

Inserts a parsed format token into the specified format section before the specified element.

See Also

TsNumFormatToken

Group

TsNumFormatParams Methods


TsNumFormatParams.SectionsEqualTo Method

TsNumFormatParams.SectionsEqualTo Method
Syntax
Pascal
function SectionsEqualTo(ASections: TsNumFormatSections): Boolean;
Parameters
Parameters | Description
ASections: TsNumFormatSections | Array of parsed format sections to be compared with the internal format sections
Description

Checks whether the parsed format sections passed as a parameter are identical to the interal section array.

Group

TsNumFormatParams Methods


TsNumFormatParams.SetCurrSymbol Method

TsNumFormatParams.SetCurrSymbol Method
Syntax
Pascal
procedure SetCurrSymbol(AValue: String);
Parameters
Parameters | Description
AValue: String | String containing the currency symbol to be used in the converted numbers
Description

Defines the currency symbol used in the format params sequence

Group

TsNumFormatParams Methods


TsNumFormatParams.SetDecimals Method

TsNumFormatParams.SetDecimals Method
Syntax
Pascal
procedure SetDecimals(AValue: Byte);
Group

TsNumFormatParams Methods


TsNumFormatParams.SetNegativeRed Method

TsNumFormatParams.SetNegativeRed Method
Syntax
Pascal
procedure SetNegativeRed(AEnable: Boolean);
Parameters
Parameters | Description
AEnable: Boolean | The format tokens are modified such as to display negative values in red if AEnable is true.
Description

If AEnable is true a format section for negative numbers is added (or an existing one is modified) such that negative numbers are displayed in red. If AEnable is false the format tokens are modified such that negative values are displayed in default color.

Group

TsNumFormatParams Methods


TsNumFormatParams.SetThousandSep Method

TsNumFormatParams.SetThousandSep Method
Syntax
Pascal
procedure SetThousandSep(AEnable: Boolean);
Parameters
Parameters | Description
AEnable: Boolean | A thousand separator is inserted if AEnable is true, or else deleted.
Description

Inserts a thousand separator token into the format elements at the appropriate position, or removes it

Group

TsNumFormatParams Methods


TsNumFormatParams Properties

TsNumFormatParams Properties

The properties of the TsNumFormatParams class are listed here.

Class

TsNumFormatParams Class

Public Properties
Name | Description
NumFormat |
NumFormatStr |


TsNumFormatParams.NumFormat Property

TsNumFormatParams.NumFormat Property
Syntax
Pascal
property NumFormat: TsNumberFormat;
Group

TsNumFormatParams Properties


TsNumFormatParams.NumFormatStr Property

TsNumFormatParams.NumFormatStr Property
Syntax
Pascal
property NumFormatStr: String;
Group

TsNumFormatParams Properties


TsSelPen Class

TsSelPen Class
Class Hierarchy
  TsSelPen
Syntax
Pascal
TsSelPen = class(TPen);
File

fpspreadsheetgrid

Group

Classes


TsSelPen Members

TsSelPen Members

The following tables list the members exposed by TsSelPen.

Class

TsSelPen Class

Public Methods
Name | Description
Create |
Published Properties
Name | Description
JoinStyle |
Width |


TsSelPen.Create Constructor

TsSelPen.Create Constructor
Syntax
Pascal
constructor Create; override;
Class

TsSelPen Class


TsSelPen Properties

TsSelPen Properties

The properties of the TsSelPen class are listed here.

Class

TsSelPen Class

Published Properties
Name | Description
JoinStyle |
Width |


TsSelPen.JoinStyle Property

TsSelPen.JoinStyle Property
Syntax
Pascal
property JoinStyle;
Group

TsSelPen Properties


TsSelPen.Width Property

TsSelPen.Width Property
Syntax
Pascal
property Width;
Group

TsSelPen Properties


TsSpreadsheetInspector Class

TsSpreadsheetInspector Class
Class Hierarchy
  TsSpreadsheetInspectorTsSpreadsheetInspector
Syntax
Pascal
TsSpreadsheetInspector = class(TValueListEditor, IsSpreadsheetControl);
File

fpspreadsheetctrls

Description

TsSpreadsheetInspector displays all properties of a workbook, worksheet, cell content and cell formatting in a way similar to the Object Inspector of Lazarus.

Group

Classes


TsSpreadsheetInspector Members

TsSpreadsheetInspector Members

The following tables list the members exposed by TsSpreadsheetInspector.

Class

TsSpreadsheetInspector Class

Protected Methods
Name | Description
DblClick | Double-click on an expandable line expands or collapsed the sub-items
DoUpdate | Updates the data shown by the inspector grid. Display depends on the FMode setting (workbook, worksheet, cell values, cell properties).
Notification | Standard component notification method called when the WorkbookSource is deleted.
UpdateCellProperties | Creates a string list containing the formatting properties of a specific cell. The string list items are name-value pairs in the format "name=value". The string list is displayed in the inspector's grid.
UpdateCellValue | Creates a string list containing the value data of a specific cell. The string list items are name-value pairs in the format "name=value". The string list is displayed in the inspector's grid.
UpdateWorkbook | Creates a string list containing the properties of the workbook. The string list items are name-value pairs in the format "name=value". The string list is displayed in the inspector's grid.
UpdateWorksheet | Creates a string list containing the properties of a worksheet. The string list items are name-value pairs in the format "name=value". The string list is displayed in the inspector's grid.
Public Methods
Name | Description
Create | Constructor of the TsSpreadsheetInspector class. Is overridden to set the default values of DisplayOptions and FixedCols, and to define the column captions.
Destroy | Destructor of the spreadsheet inspector. Removes itself from the WorkbookSource's listener list.
ListenerNotification | Notification procedure received whenver "something" changes in the workbook. Reacts on all events.
RemoveWorkbookSource | Removes the link of the SpreadsheetInspector to the WorkbookSource. Required before destruction.
Public Properties
Name | Description
Workbook | Refers to the underlying workbook which is displayed by the inspector.
Worksheet | Refers to the underlying worksheet which is displayed by the inspector.
Published Properties
Name | Description
DisplayOptions | inherited from TValueListEditor, activates column titles and automatic column width adjustment by default
ExpandedNodes | Displays subproperties
ExtendedColSizing | inherited from TStringGrid, but not published in TValueListEditor.
FixedCols | inherited from TValueListEditor. Turns of the fixed column by default
Mode | Classification of data displayed by the SpreadsheetInspector. Each mode can be assigned to a tab of a TabControl.
WorkbookSource | Refers to the underlying worksheet from which the active cell is taken


TsSpreadsheetInspector.Create Constructor

TsSpreadsheetInspector.Create Constructor
Syntax
Pascal
constructor Create(AOwner: TComponent); override;
Description

Constructor of the TsSpreadsheetInspector class. Is overridden to set the default values of DisplayOptions and FixedCols, and to define the column captions.

Class

TsSpreadsheetInspector Class


TsSpreadsheetInspector.Destroy Destructor

TsSpreadsheetInspector.Destroy Destructor
Syntax
Pascal
destructor Destroy; override;
Description

Destructor of the spreadsheet inspector. Removes itself from the WorkbookSource's listener list.

Class

TsSpreadsheetInspector Class


TsSpreadsheetInspector Methods

TsSpreadsheetInspector Methods

The methods of the TsSpreadsheetInspector class are listed here.

Class

TsSpreadsheetInspector Class

Protected Methods
Name | Description
DblClick | Double-click on an expandable line expands or collapsed the sub-items
DoUpdate | Updates the data shown by the inspector grid. Display depends on the FMode setting (workbook, worksheet, cell values, cell properties).
Notification | Standard component notification method called when the WorkbookSource is deleted.
UpdateCellProperties | Creates a string list containing the formatting properties of a specific cell. The string list items are name-value pairs in the format "name=value". The string list is displayed in the inspector's grid.
UpdateCellValue | Creates a string list containing the value data of a specific cell. The string list items are name-value pairs in the format "name=value". The string list is displayed in the inspector's grid.
UpdateWorkbook | Creates a string list containing the properties of the workbook. The string list items are name-value pairs in the format "name=value". The string list is displayed in the inspector's grid.
UpdateWorksheet | Creates a string list containing the properties of a worksheet. The string list items are name-value pairs in the format "name=value". The string list is displayed in the inspector's grid.
Public Methods
Name | Description
ListenerNotification | Notification procedure received whenver "something" changes in the workbook. Reacts on all events.
RemoveWorkbookSource | Removes the link of the SpreadsheetInspector to the WorkbookSource. Required before destruction.


TsSpreadsheetInspector.DblClick Method

TsSpreadsheetInspector.DblClick Method
Syntax
Pascal
procedure DblClick; override;
Description

Double-click on an expandable line expands or collapsed the sub-items

Group

TsSpreadsheetInspector Methods


TsSpreadsheetInspector.DoUpdate Method

TsSpreadsheetInspector.DoUpdate Method
Syntax
Pascal
procedure DoUpdate; virtual;
Description

Updates the data shown by the inspector grid. Display depends on the FMode setting (workbook, worksheet, cell values, cell properties).

Group

TsSpreadsheetInspector Methods


TsSpreadsheetInspector.ListenerNotification Method

TsSpreadsheetInspector.ListenerNotification Method
Syntax
Pascal
procedure ListenerNotification(AChangedItems: TsNotificationItems; AData: Pointer = nil);
Parameters
Parameters | Description
AChangedItems: TsNotificationItems | Set with elements identifying whether workbook, worksheet cell or selection has changed.
AData: Pointer = nil | If AChangedItems contains nliCell then AData points to the modified cell.
Description

Notification procedure received whenver "something" changes in the workbook. Reacts on all events.

Group

TsSpreadsheetInspector Methods


TsSpreadsheetInspector.Notification Method

TsSpreadsheetInspector.Notification Method
Syntax
Pascal
procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Description

Standard component notification method called when the WorkbookSource is deleted.

Group

TsSpreadsheetInspector Methods


TsSpreadsheetInspector.RemoveWorkbookSource Method

TsSpreadsheetInspector.RemoveWorkbookSource Method
Syntax
Pascal
procedure RemoveWorkbookSource;
Description

Removes the link of the SpreadsheetInspector to the WorkbookSource. Required before destruction.

Group

TsSpreadsheetInspector Methods


TsSpreadsheetInspector.UpdateCellProperties Method

TsSpreadsheetInspector.UpdateCellProperties Method
Syntax
Pascal
procedure UpdateCellProperties(ACell: PCell; AStrings: TStrings); virtual;
Parameters
Parameters | Description
ACell: PCell | Pointer to cell under investigation
AStrings: TStrings | Stringlist receiving the name-value pairs.
Description

Creates a string list containing the formatting properties of a specific cell. The string list items are name-value pairs in the format "name=value". The string list is displayed in the inspector's grid.

Group

TsSpreadsheetInspector Methods


TsSpreadsheetInspector.UpdateCellValue Method

TsSpreadsheetInspector.UpdateCellValue Method
Syntax
Pascal
procedure UpdateCellValue(ACell: PCell; AStrings: TStrings); virtual;
Parameters
Parameters | Description
ACell: PCell | Pointer to cell under investigation
AStrings: TStrings | Stringlist receiving the name-value pairs.
Description

Creates a string list containing the value data of a specific cell. The string list items are name-value pairs in the format "name=value". The string list is displayed in the inspector's grid.

Group

TsSpreadsheetInspector Methods


TsSpreadsheetInspector.UpdateWorkbook Method

TsSpreadsheetInspector.UpdateWorkbook Method
Syntax
Pascal
procedure UpdateWorkbook(AWorkbook: TsWorkbook; AStrings: TStrings); virtual;
Parameters
Parameters | Description
AWorkbook: TsWorkbook | Workbook under investigation
AStrings: TStrings | Stringlist receiving the name-value pairs.
Description

Creates a string list containing the properties of the workbook. The string list items are name-value pairs in the format "name=value". The string list is displayed in the inspector's grid.

Group

TsSpreadsheetInspector Methods


TsSpreadsheetInspector.UpdateWorksheet Method

TsSpreadsheetInspector.UpdateWorksheet Method
Syntax
Pascal
procedure UpdateWorksheet(ASheet: TsWorksheet; AStrings: TStrings); virtual;
Parameters
Parameters | Description
ASheet: TsWorksheet | Worksheet under investigation
AStrings: TStrings | Stringlist receiving the name-value pairs.
Description

Creates a string list containing the properties of a worksheet. The string list items are name-value pairs in the format "name=value". The string list is displayed in the inspector's grid.

Group

TsSpreadsheetInspector Methods


TsSpreadsheetInspector Properties

TsSpreadsheetInspector Properties

The properties of the TsSpreadsheetInspector class are listed here.

Class

TsSpreadsheetInspector Class

Public Properties
Name | Description
Workbook | Refers to the underlying workbook which is displayed by the inspector.
Worksheet | Refers to the underlying worksheet which is displayed by the inspector.
Published Properties
Name | Description
DisplayOptions | inherited from TValueListEditor, activates column titles and automatic column width adjustment by default
ExpandedNodes | Displays subproperties
ExtendedColSizing | inherited from TStringGrid, but not published in TValueListEditor.
FixedCols | inherited from TValueListEditor. Turns of the fixed column by default
Mode | Classification of data displayed by the SpreadsheetInspector. Each mode can be assigned to a tab of a TabControl.
WorkbookSource | Refers to the underlying worksheet from which the active cell is taken


TsSpreadsheetInspector.DisplayOptions Property

TsSpreadsheetInspector.DisplayOptions Property
Syntax
Pascal
property DisplayOptions;
Description

inherited from TValueListEditor, activates column titles and automatic column width adjustment by default

Group

TsSpreadsheetInspector Properties


TsSpreadsheetInspector.ExpandedNodes Property

TsSpreadsheetInspector.ExpandedNodes Property
Syntax
Pascal
property ExpandedNodes: TsInspectorExpandedNodes;
Description

Displays subproperties

Group

TsSpreadsheetInspector Properties


TsSpreadsheetInspector.ExtendedColSizing Property

TsSpreadsheetInspector.ExtendedColSizing Property
Syntax
Pascal
property ExtendedColSizing;
Description

inherited from TStringGrid, but not published in TValueListEditor.

Group

TsSpreadsheetInspector Properties


TsSpreadsheetInspector.FixedCols Property

TsSpreadsheetInspector.FixedCols Property
Syntax
Pascal
property FixedCols;
Description

inherited from TValueListEditor. Turns of the fixed column by default

Group

TsSpreadsheetInspector Properties


TsSpreadsheetInspector.Mode Property

TsSpreadsheetInspector.Mode Property
Syntax
Pascal
property Mode: TsInspectorMode;
Description

Classification of data displayed by the SpreadsheetInspector. Each mode can be assigned to a tab of a TabControl.

Group

TsSpreadsheetInspector Properties


TsSpreadsheetInspector.Workbook Property

TsSpreadsheetInspector.Workbook Property
Syntax
Pascal
property Workbook: TsWorkbook;
Description

Refers to the underlying workbook which is displayed by the inspector.

Group

TsSpreadsheetInspector Properties


TsSpreadsheetInspector.WorkbookSource Property

TsSpreadsheetInspector.WorkbookSource Property
Syntax
Pascal
property WorkbookSource: TsWorkbookSource;
Description

Refers to the underlying worksheet from which the active cell is taken

Group

TsSpreadsheetInspector Properties


TsSpreadsheetInspector.Worksheet Property

TsSpreadsheetInspector.Worksheet Property
Syntax
Pascal
property Worksheet: TsWorksheet;
Description

Refers to the underlying worksheet which is displayed by the inspector.

Group

TsSpreadsheetInspector Properties


TsWorkbook Class

TsWorkbook Class
Class Hierarchy
  TsWorkbook
Syntax
Pascal
TsWorkbook = class;
File

fpspreadsheet

Group

Classes


TsWorkbook Members

TsWorkbook Members

The following tables list the members exposed by TsWorkbook.

Class

TsWorkbook Class

Protected Fields
Name | Description
FCellFormatList |
FEmbeddedStreamList |
FFontList |
FNumFormatList |
Protected Methods
Name | Description
GetFormatFromFileHeader | This is the overview for the GetFormatFromFileHeader method overload.
PrepareBeforeReading | Helper method called before reading the workbook. Clears the error log.
PrepareBeforeSaving | Helper method called before saving the workbook. Clears the error log, and calculates the formulas in all worksheets if workbook option soCalcBeforeSaving is set.
ReCalc |
Public Events
Name | Description
OnAddWorksheet | This event fires whenever a new worksheet is added
OnChangeWorksheet | This event fires whenever a worksheet is changed
OnReadCellData | This event accepts cell data while reading a spreadsheet file. Data are not encorporated in a spreadsheet, they are just passed through to the event handler for processing. Requires option boVirtualMode to be set.
OnRemoveWorksheet | This event fires AFTER a worksheet has been deleted
OnRemovingWorksheet | This event fires BEFORE a worksheet is deleted
OnRenameWorksheet | This event fires whenever a worksheet is renamed
OnSelectWorksheet | This event fires when a worksheet is made "active
OnWriteCellData | This event allows to provide external cell data for writing to file, standard cells are ignored. Intended for converting large database files to a spreadsheet format. Requires Option boVirtualMode to be set.
Public Fields
Name | Description
FormatSettings | A copy of SysUtil's DefaultFormatSettings (converted to UTF8) to provide some kind of localization to some formatting strings. Can be modified before loading/writing files
Public Methods
Name | Description
AddCellFormat | Adds the specified format record to the internal list and returns the index in the list. If the record had already been added before the function only returns the index.
AddEmbeddedStream | Creates a new stream with the specified name, adds it to the internal list and returns its index. Embedded streams are used to store embedded images. AName is normally the filename of the image. The image will be loaded to the stream later.
AddErrorMsg | This is the overview for the AddErrorMsg method overload.
AddFont | This is the overview for the AddFont method overload.
AddNumberFormat | Adds a number format to the internal list. Returns the list index if already present, or creates a new format item and returns its index.
AddWorksheet | Adds a new worksheet to the workbook. It is put to the end of the worksheet list.
ClearErrorList | Clears the internal error message list
CopyToClipboardStream | Writes the selected cells to a stream for usage in the clipboard. Transfer to the clipboard has do be done by the calling routine since fpspreadsheet does not "know" the system's clipboard.
CopyWorksheetFrom |
Create | Constructor of the workbook class. Among others, it initializes the built-in fonts, defines the default font, and sets up the FormatSettings for localization of some number formats.
DeleteFont | Deletes a font. Use with caution because this will screw up the font assignment to cells. The only legal reason to call this method is from a reader of a file format in which the missing font #4 of BIFF does exist.
Destroy | Destructor of the workbook class
DisableNotifications | Helper method to disable notification of visual controls
EnableNotifications | Helper method to enable notification of visual controls
FindEmbeddedStream | Checks whether an embedded stream with the specified name already exists. If yes, returns its index in the stream list, or -1 if no.
FindFont | Checks whether the font with the given specification is already contained in the font list. Returns the index, or -1 if not found.
GetBuiltinFontCount | Returns the count of built-in fonts (default font, hyperlink font, bold font by default).
GetCellFormat | Returns the contents of the format record with the specified index.
GetCellFormatAsString | Returns a string describing the cell format with the specified index.
GetDefaultFont | Returns the default font. This is the first font (index 0) in the font list
GetDefaultFontSize | Returns the point size of the default font
GetEmbeddedStream | Returns the embedded stream stored in the embedded stream list at the specified index.
GetEmbeddedStreamCount | Returns the count of embedded streams
GetFirstWorksheet | Quick helper routine which returns the first worksheet
GetFont | Returns the font with the given index.
GetFontAsString | Returns a string which identifies the font with a given index.
GetFontCount | Returns the count of registered fonts
GetHyperlinkFont | Returns the hypertext font. This is font with index 6 in the font list
GetLastRowColIndex | Determines the maximum index of used columns and rows in all sheets of this workbook. Respects VirtualMode. Is needed to disable saving when limitations of the format is exceeded.
GetNumberFormat | Returns the parameters of the number format stored in the NumFormatList at the specified index. "General" number format is returned as nil.
GetNumberFormatCount | Returns the count of number format records stored in the NumFormatList
GetNumCellFormats | Returns the count of format records used all over the workbook
GetPointerToCellFormat | Returns a pointer to the format record with the specified index
GetWorksheetByIndex | Gets the worksheet with a given index The index is zero-based, so the first worksheet added has index 0, the second 1, etc.
GetWorksheetByName | Gets the worksheet with a given worksheet name
GetWorksheetCount | The number of worksheets on the workbook
GetWorksheetIndex | Returns the index of a worksheet in the worksheet list
HasEmbeddedSheetImages | Returns true if there is at least one worksheet with an embedded images.
InitFonts | Initializes the font list by adding 5 fonts: 0: default font 1: like default font, but blue and underlined (for hyperlinks) 2: like default font, but bold 3: like default font, but italic
NotificationsEnabled | Helper method to determine whether visual controls are notified of changes
PasteFromClipboardStream | Copies the cells stored in the specified stream to the active worksheet. The provided stream contains data from the system's clipboard. Note that transfer from the clipboard to the stream has to be done by the calling routine since fpspreadsheet does not "know" the system's clipboard.
ReadFromFile | This is the overview for the ReadFromFile method overload.
ReadFromFileIgnoringExtension | Reads the document from a file, but ignores the extension.
ReadFromStream | This is the overview for the ReadFromStream method overload.
RemoveAllEmbeddedStreams | Removes all embedded streams
RemoveAllFonts | Clears the list of fonts and releases their memory.
RemoveAllWorksheets | Clears the list of Worksheets and releases their memory.
RemoveWorksheet | Removes the specified worksheet: Removes the sheet from the internal sheet list, generates an event OnRemoveWorksheet, and releases all memory. The event handler specifies the index of the deleted worksheet; the worksheet itself does no longer exist.
ReplaceFont | Replaces the built-in font at a specific index with different font parameters
SelectWorksheet | Makes the specified worksheet "active". Only needed for visual controls. The active worksheet is displayed in a TsWorksheetGrid and in the selected tab of a TsWorkbookTabControl.
SetDefaultFont | Defines the default font. This is the font with index 0 in the FontList. The next built-in fonts will have the same font name and size
TryStrToCell | Analyses a string which can contain an array of cell ranges along with a worksheet name. Extracts the worksheet (if missing the "active" worksheet of the workbook is returned) and the cell's row and column indexes.
TryStrToCellRange | Analyses a string which can contain an array of cell ranges along with a worksheet name. Extracts the worksheet (if missing the "active" worksheet of the workbook is returned) and the cell range (or the first cell range, if there are several ranges).
TryStrToCellRanges | Analyses a string which can contain an array of cell ranges along with a worksheet name. Extracts the worksheet (if missing the "active" worksheet of the workbook is returned) and the range array.
UpdateCaches | Helper method to update internal caching variables
ValidWorksheetName | Checks whether the passed string is a valid worksheet name according to Excel (ODS seems to be a bit less restrictive, but if we follow Excel's convention we always have valid sheet names independent of the format.
WriteToFile | This is the overview for the WriteToFile method overload.
WriteToStream | This is the overview for the WriteToStream method overload.
Public Properties
Name | Description
ActiveWorksheet | Identifies the "active" worksheet (only for visual controls)
ErrorMsg | Retrieves error messages collected during reading/writing
FileFormatID | Identifies the file format which was detected when reading the file
FileName | Filename of the saved workbook
OnOpenWorkbook | This event fires whenever a workbook is loaded
Options |
VirtualColCount |
VirtualRowCount |


TsWorkbook.Create Constructor

TsWorkbook.Create Constructor
Syntax
Pascal
constructor Create;
Description

Constructor of the workbook class. Among others, it initializes the built-in fonts, defines the default font, and sets up the FormatSettings for localization of some number formats.

Class

TsWorkbook Class


TsWorkbook.Destroy Destructor

TsWorkbook.Destroy Destructor
Syntax
Pascal
destructor Destroy; override;
Description

Destructor of the workbook class

Class

TsWorkbook Class


TsWorkbook Fields

TsWorkbook Fields

The fields of the TsWorkbook class are listed here.

Class

TsWorkbook Class

Protected Fields
Name | Description
FCellFormatList |
FEmbeddedStreamList |
FFontList |
FNumFormatList |
Public Fields
Name | Description
FormatSettings | A copy of SysUtil's DefaultFormatSettings (converted to UTF8) to provide some kind of localization to some formatting strings. Can be modified before loading/writing files


TsWorkbook.FCellFormatList Field

TsWorkbook.FCellFormatList Field
Syntax
Pascal
FCellFormatList: TsCellFormatList;
Group

TsWorkbook Fields


TsWorkbook.FEmbeddedStreamList Field

TsWorkbook.FEmbeddedStreamList Field
Syntax
Pascal
FEmbeddedStreamList: TFPList;
Group

TsWorkbook Fields


TsWorkbook.FFontList Field

TsWorkbook.FFontList Field
Syntax
Pascal
FFontList: TFPList;
Group

TsWorkbook Fields


TsWorkbook.FNumFormatList Field

TsWorkbook.FNumFormatList Field
Syntax
Pascal
FNumFormatList: TFPList;
Group

TsWorkbook Fields


TsWorkbook.FormatSettings Field

TsWorkbook.FormatSettings Field
Syntax
Pascal
FormatSettings: TFormatSettings;
Description

A copy of SysUtil's DefaultFormatSettings (converted to UTF8) to provide some kind of localization to some formatting strings. Can be modified before loading/writing files

Group

TsWorkbook Fields


TsWorkbook Methods

TsWorkbook Methods

The methods of the TsWorkbook class are listed here.

Class

TsWorkbook Class

Protected Methods
Name | Description
GetFormatFromFileHeader | This is the overview for the GetFormatFromFileHeader method overload.
PrepareBeforeReading | Helper method called before reading the workbook. Clears the error log.
PrepareBeforeSaving | Helper method called before saving the workbook. Clears the error log, and calculates the formulas in all worksheets if workbook option soCalcBeforeSaving is set.
ReCalc |
Public Methods
Name | Description
AddCellFormat | Adds the specified format record to the internal list and returns the index in the list. If the record had already been added before the function only returns the index.
AddEmbeddedStream | Creates a new stream with the specified name, adds it to the internal list and returns its index. Embedded streams are used to store embedded images. AName is normally the filename of the image. The image will be loaded to the stream later.
AddErrorMsg | This is the overview for the AddErrorMsg method overload.
AddFont | This is the overview for the AddFont method overload.
AddNumberFormat | Adds a number format to the internal list. Returns the list index if already present, or creates a new format item and returns its index.
AddWorksheet | Adds a new worksheet to the workbook. It is put to the end of the worksheet list.
ClearErrorList | Clears the internal error message list
CopyToClipboardStream | Writes the selected cells to a stream for usage in the clipboard. Transfer to the clipboard has do be done by the calling routine since fpspreadsheet does not "know" the system's clipboard.
CopyWorksheetFrom |
DeleteFont | Deletes a font. Use with caution because this will screw up the font assignment to cells. The only legal reason to call this method is from a reader of a file format in which the missing font #4 of BIFF does exist.
DisableNotifications | Helper method to disable notification of visual controls
EnableNotifications | Helper method to enable notification of visual controls
FindEmbeddedStream | Checks whether an embedded stream with the specified name already exists. If yes, returns its index in the stream list, or -1 if no.
FindFont | Checks whether the font with the given specification is already contained in the font list. Returns the index, or -1 if not found.
GetBuiltinFontCount | Returns the count of built-in fonts (default font, hyperlink font, bold font by default).
GetCellFormat | Returns the contents of the format record with the specified index.
GetCellFormatAsString | Returns a string describing the cell format with the specified index.
GetDefaultFont | Returns the default font. This is the first font (index 0) in the font list
GetDefaultFontSize | Returns the point size of the default font
GetEmbeddedStream | Returns the embedded stream stored in the embedded stream list at the specified index.
GetEmbeddedStreamCount | Returns the count of embedded streams
GetFirstWorksheet | Quick helper routine which returns the first worksheet
GetFont | Returns the font with the given index.
GetFontAsString | Returns a string which identifies the font with a given index.
GetFontCount | Returns the count of registered fonts
GetHyperlinkFont | Returns the hypertext font. This is font with index 6 in the font list
GetLastRowColIndex | Determines the maximum index of used columns and rows in all sheets of this workbook. Respects VirtualMode. Is needed to disable saving when limitations of the format is exceeded.
GetNumberFormat | Returns the parameters of the number format stored in the NumFormatList at the specified index. "General" number format is returned as nil.
GetNumberFormatCount | Returns the count of number format records stored in the NumFormatList
GetNumCellFormats | Returns the count of format records used all over the workbook
GetPointerToCellFormat | Returns a pointer to the format record with the specified index
GetWorksheetByIndex | Gets the worksheet with a given index The index is zero-based, so the first worksheet added has index 0, the second 1, etc.
GetWorksheetByName | Gets the worksheet with a given worksheet name
GetWorksheetCount | The number of worksheets on the workbook
GetWorksheetIndex | Returns the index of a worksheet in the worksheet list
HasEmbeddedSheetImages | Returns true if there is at least one worksheet with an embedded images.
InitFonts | Initializes the font list by adding 5 fonts: 0: default font 1: like default font, but blue and underlined (for hyperlinks) 2: like default font, but bold 3: like default font, but italic
NotificationsEnabled | Helper method to determine whether visual controls are notified of changes
PasteFromClipboardStream | Copies the cells stored in the specified stream to the active worksheet. The provided stream contains data from the system's clipboard. Note that transfer from the clipboard to the stream has to be done by the calling routine since fpspreadsheet does not "know" the system's clipboard.
ReadFromFile | This is the overview for the ReadFromFile method overload.
ReadFromFileIgnoringExtension | Reads the document from a file, but ignores the extension.
ReadFromStream | This is the overview for the ReadFromStream method overload.
RemoveAllEmbeddedStreams | Removes all embedded streams
RemoveAllFonts | Clears the list of fonts and releases their memory.
RemoveAllWorksheets | Clears the list of Worksheets and releases their memory.
RemoveWorksheet | Removes the specified worksheet: Removes the sheet from the internal sheet list, generates an event OnRemoveWorksheet, and releases all memory. The event handler specifies the index of the deleted worksheet; the worksheet itself does no longer exist.
ReplaceFont | Replaces the built-in font at a specific index with different font parameters
SelectWorksheet | Makes the specified worksheet "active". Only needed for visual controls. The active worksheet is displayed in a TsWorksheetGrid and in the selected tab of a TsWorkbookTabControl.
SetDefaultFont | Defines the default font. This is the font with index 0 in the FontList. The next built-in fonts will have the same font name and size
TryStrToCell | Analyses a string which can contain an array of cell ranges along with a worksheet name. Extracts the worksheet (if missing the "active" worksheet of the workbook is returned) and the cell's row and column indexes.
TryStrToCellRange | Analyses a string which can contain an array of cell ranges along with a worksheet name. Extracts the worksheet (if missing the "active" worksheet of the workbook is returned) and the cell range (or the first cell range, if there are several ranges).
TryStrToCellRanges | Analyses a string which can contain an array of cell ranges along with a worksheet name. Extracts the worksheet (if missing the "active" worksheet of the workbook is returned) and the range array.
UpdateCaches | Helper method to update internal caching variables
ValidWorksheetName | Checks whether the passed string is a valid worksheet name according to Excel (ODS seems to be a bit less restrictive, but if we follow Excel's convention we always have valid sheet names independent of the format.
WriteToFile | This is the overview for the WriteToFile method overload.
WriteToStream | This is the overview for the WriteToStream method overload.


TsWorkbook.AddCellFormat Method

TsWorkbook.AddCellFormat Method
Syntax
Pascal
function AddCellFormat(const AValue: TsCellFormat): Integer;
Description

Adds the specified format record to the internal list and returns the index in the list. If the record had already been added before the function only returns the index.

Group

TsWorkbook Methods


TsWorkbook.AddEmbeddedStream Method

TsWorkbook.AddEmbeddedStream Method
Syntax
Pascal
function AddEmbeddedStream(const AName: String): Integer;
Description

Creates a new stream with the specified name, adds it to the internal list and returns its index. Embedded streams are used to store embedded images. AName is normally the filename of the image. The image will be loaded to the stream later.

Group

TsWorkbook Methods


AddErrorMsg Method

AddErrorMsg Method

This is the overview for the AddErrorMsg method overload.

Overload List
Name | Description
TsWorkbook.AddErrorMsg (String) | Adds a (simple) error message to an internal list
TsWorkbook.AddErrorMsg (String, array of const) |
Group

TsWorkbook Methods


TsWorkbook.AddErrorMsg Method (String)

TsWorkbook.AddErrorMsg Method (String)
Syntax
Pascal
procedure AddErrorMsg(const AMsg: String); overload;
Parameters
Parameters | Description
const AMsg: String | Error text to be stored in the list
Description

Adds a (simple) error message to an internal list

Group

AddErrorMsg Method


TsWorkbook.AddErrorMsg Method (String, array of const)

TsWorkbook.AddErrorMsg Method (String, array of const)
Syntax
Pascal
procedure AddErrorMsg(const AMsg: String; const Args: array of const); overload;
Group

AddErrorMsg Method


AddFont Method

AddFont Method

This is the overview for the AddFont method overload.

Overload List
Name | Description
TsWorkbook.AddFont (String, Single, TsFontStyles, TsColor, TsFontPosition) | Adds a font to the font list. Returns the index in the font list.
TsWorkbook.AddFont (TsFont) | Adds a font to the font list. Returns the index in the font list.
Group

TsWorkbook Methods


TsWorkbook.AddFont Method (String, Single, TsFontStyles, TsColor, TsFontPosition)

TsWorkbook.AddFont Method (String, Single, TsFontStyles, TsColor, TsFontPosition)
Syntax
Pascal
function AddFont(const AFontName: String; ASize: Single; AStyle: TsFontStyles; AColor: TsColor; APosition: TsFontPosition = fpNormal): Integer; overload;
Parameters
Parameters | Description
const AFontName: String | Name of the font (like 'Arial')
ASize: Single | Size of the font in points
AStyle: TsFontStyles | Style of the font, a combination of TsFontStyle elements
AColor: TsColor | RGB valoe of the font color
APosition: TsFontPosition = fpNormal | Specifies subscript or superscript text.
Returns

Index of the font in the workbook's font list

Description

Adds a font to the font list. Returns the index in the font list.

Group

AddFont Method


TsWorkbook.AddFont Method (TsFont)

TsWorkbook.AddFont Method (TsFont)
Syntax
Pascal
function AddFont(const AFont: TsFont): Integer; overload;
Parameters
Parameters | Description
const AFont: TsFont | TsFont record containing all font parameters
Returns

Index of the font in the workbook's font list

Description

Adds a font to the font list. Returns the index in the font list.

Group

AddFont Method


TsWorkbook.AddNumberFormat Method

TsWorkbook.AddNumberFormat Method
Syntax
Pascal
function AddNumberFormat(AFormatStr: String): Integer;
Description

Adds a number format to the internal list. Returns the list index if already present, or creates a new format item and returns its index.

Group

TsWorkbook Methods


TsWorkbook.AddWorksheet Method

TsWorkbook.AddWorksheet Method
Syntax
Pascal
function AddWorksheet(AName: string; ReplaceDuplicateName: Boolean = false): TsWorksheet;
Parameters
Parameters | Description
AName: string | The name of the new worksheet
ReplaceDupliateName | If true and the sheet name already exists then a number is added to the sheet name to make it unique.
Returns

The instance of the newly created worksheet

Description

Adds a new worksheet to the workbook. It is put to the end of the worksheet list.

See Also

TsWorksheet

Group

TsWorkbook Methods


TsWorkbook.ClearErrorList Method

TsWorkbook.ClearErrorList Method
Syntax
Pascal
procedure ClearErrorList;
Description

Clears the internal error message list

Group

TsWorkbook Methods


TsWorkbook.CopyToClipboardStream Method

TsWorkbook.CopyToClipboardStream Method
Syntax
Pascal
procedure CopyToClipboardStream(AStream: TStream; AFormat: TsSpreadsheetFormat; AParams: TsStreamParams = []);
Description

Writes the selected cells to a stream for usage in the clipboard. Transfer to the clipboard has do be done by the calling routine since fpspreadsheet does not "know" the system's clipboard.

Group

TsWorkbook Methods


TsWorkbook.CopyWorksheetFrom Method

TsWorkbook.CopyWorksheetFrom Method
Syntax
Pascal
function CopyWorksheetFrom(AWorksheet: TsWorksheet; ReplaceDuplicateName: Boolean = false): TsWorksheet;
Group

TsWorkbook Methods


TsWorkbook.DeleteFont Method

TsWorkbook.DeleteFont Method
Syntax
Pascal
procedure DeleteFont(AFontIndex: Integer);
Description

Deletes a font. Use with caution because this will screw up the font assignment to cells. The only legal reason to call this method is from a reader of a file format in which the missing font #4 of BIFF does exist.

Group

TsWorkbook Methods


TsWorkbook.DisableNotifications Method

TsWorkbook.DisableNotifications Method
Syntax
Pascal
procedure DisableNotifications;
Description

Helper method to disable notification of visual controls

Group

TsWorkbook Methods


TsWorkbook.EnableNotifications Method

TsWorkbook.EnableNotifications Method
Syntax
Pascal
procedure EnableNotifications;
Description

Helper method to enable notification of visual controls

Group

TsWorkbook Methods


TsWorkbook.FindEmbeddedStream Method

TsWorkbook.FindEmbeddedStream Method
Syntax
Pascal
function FindEmbeddedStream(const AName: String): Integer;
Description

Checks whether an embedded stream with the specified name already exists. If yes, returns its index in the stream list, or -1 if no.

Group

TsWorkbook Methods


TsWorkbook.FindFont Method

TsWorkbook.FindFont Method
Syntax
Pascal
function FindFont(const AFontName: String; ASize: Single; AStyle: TsFontStyles; AColor: TsColor; APosition: TsFontPosition = fpNormal): Integer;
Parameters
Parameters | Description
const AFontName: String | Name of the font (like 'Arial')
ASize: Single | Size of the font in points
AStyle: TsFontStyles | Style of the font, a combination of TsFontStyle elements
AColor: TsColor | RGB value of the font color
APosition: TsFontPosition = fpNormal | Specified subscript or superscript text.
Returns

Index of the font in the font list, or -1 if not found.

Description

Checks whether the font with the given specification is already contained in the font list. Returns the index, or -1 if not found.

Group

TsWorkbook Methods


TsWorkbook.GetBuiltinFontCount Method

TsWorkbook.GetBuiltinFontCount Method
Syntax
Pascal
function GetBuiltinFontCount: Integer;
Description

Returns the count of built-in fonts (default font, hyperlink font, bold font by default).

Group

TsWorkbook Methods


TsWorkbook.GetCellFormat Method

TsWorkbook.GetCellFormat Method
Syntax
Pascal
function GetCellFormat(AIndex: Integer): TsCellFormat;
Description

Returns the contents of the format record with the specified index.

Group

TsWorkbook Methods


TsWorkbook.GetCellFormatAsString Method

TsWorkbook.GetCellFormatAsString Method
Syntax
Pascal
function GetCellFormatAsString(AIndex: Integer): String;
Description

Returns a string describing the cell format with the specified index.

Group

TsWorkbook Methods


TsWorkbook.GetDefaultFont Method

TsWorkbook.GetDefaultFont Method
Syntax
Pascal
function GetDefaultFont: TsFont;
Description

Returns the default font. This is the first font (index 0) in the font list

Group

TsWorkbook Methods


TsWorkbook.GetDefaultFontSize Method

TsWorkbook.GetDefaultFontSize Method
Syntax
Pascal
function GetDefaultFontSize: Single;
Description

Returns the point size of the default font

Group

TsWorkbook Methods


TsWorkbook.GetEmbeddedStream Method

TsWorkbook.GetEmbeddedStream Method
Syntax
Pascal
function GetEmbeddedStream(AIndex: Integer): TsEmbeddedStream;
Description

Returns the embedded stream stored in the embedded stream list at the specified index.

Group

TsWorkbook Methods


TsWorkbook.GetEmbeddedStreamCount Method

TsWorkbook.GetEmbeddedStreamCount Method
Syntax
Pascal
function GetEmbeddedStreamCount: Integer;
Description

Returns the count of embedded streams

Group

TsWorkbook Methods


TsWorkbook.GetFirstWorksheet Method

TsWorkbook.GetFirstWorksheet Method
Syntax
Pascal
function GetFirstWorksheet: TsWorksheet;
Returns

A TsWorksheet instance if at least one is present. nil otherwise.

Description

Quick helper routine which returns the first worksheet

See Also

TsWorkbook.GetWorksheetByIndex, TsWorkbook.GetWorksheetByName, TsWorksheet

Group

TsWorkbook Methods


TsWorkbook.GetFont Method

TsWorkbook.GetFont Method
Syntax
Pascal
function GetFont(AIndex: Integer): TsFont;
Parameters
Parameters | Description
AIndex: Integer | Index of the font to be considered
Returns

Record containing all parameters of the font (or nil if not found).

Description

Returns the font with the given index.

Group

TsWorkbook Methods


TsWorkbook.GetFontAsString Method

TsWorkbook.GetFontAsString Method
Syntax
Pascal
function GetFontAsString(AIndex: Integer): String;
Parameters
Parameters | Description
AIndex: Integer | Index of the font
Returns

String with font name, font size etc.

Description

Returns a string which identifies the font with a given index.

Group

TsWorkbook Methods


TsWorkbook.GetFontCount Method

TsWorkbook.GetFontCount Method
Syntax
Pascal
function GetFontCount: Integer;
Description

Returns the count of registered fonts

Group

TsWorkbook Methods


GetFormatFromFileHeader Method

GetFormatFromFileHeader Method

This is the overview for the GetFormatFromFileHeader method overload.

Overload List
Name | Description
TsWorkbook.GetFormatFromFileHeader (TFileName, TsSpreadFormatID) | Helper method for determining the spreadsheet type. Read the first few bytes of a file and determines the spreadsheet type from the characteristic signature. Only implemented for xls files where several file types have the same extension
TsWorkbook.GetFormatFromFileHeader (TStream, TsSpreadFormatID) | Helper method for determining the spreadsheet format. Read the first few bytes of a stream and determines the spreadsheet type from the characteristic signature. Only implemented for xls where several file types have the same extension.
Group

TsWorkbook Methods


TsWorkbook.GetFormatFromFileHeader Method (TFileName, TsSpreadFormatID)

TsWorkbook.GetFormatFromFileHeader Method (TFileName, TsSpreadFormatID)
Syntax
Pascal
class function GetFormatFromFileHeader(const AFileName: TFileName; out AFormatID: TsSpreadFormatID): Boolean; overload;
Description

Helper method for determining the spreadsheet type. Read the first few bytes of a file and determines the spreadsheet type from the characteristic signature. Only implemented for xls files where several file types have the same extension

Group

GetFormatFromFileHeader Method


TsWorkbook.GetFormatFromFileHeader Method (TStream, TsSpreadFormatID)

TsWorkbook.GetFormatFromFileHeader Method (TStream, TsSpreadFormatID)
Syntax
Pascal
class function GetFormatFromFileHeader(AStream: TStream; out AFormatID: TsSpreadFormatID): Boolean; overload;
Description

Helper method for determining the spreadsheet format. Read the first few bytes of a stream and determines the spreadsheet type from the characteristic signature. Only implemented for xls where several file types have the same extension.

Group

GetFormatFromFileHeader Method


TsWorkbook.GetHyperlinkFont Method

TsWorkbook.GetHyperlinkFont Method
Syntax
Pascal
function GetHyperlinkFont: TsFont;
Description

Returns the hypertext font. This is font with index 6 in the font list

Group

TsWorkbook Methods


TsWorkbook.GetLastRowColIndex Method

TsWorkbook.GetLastRowColIndex Method
Syntax
Pascal
procedure GetLastRowColIndex(out ALastRow: Cardinal; out ALastCol: Cardinal);
Description

Determines the maximum index of used columns and rows in all sheets of this workbook. Respects VirtualMode. Is needed to disable saving when limitations of the format is exceeded.

Group

TsWorkbook Methods


TsWorkbook.GetNumberFormat Method

TsWorkbook.GetNumberFormat Method
Syntax
Pascal
function GetNumberFormat(AIndex: Integer): TsNumFormatParams;
Description

Returns the parameters of the number format stored in the NumFormatList at the specified index. "General" number format is returned as nil.

Group

TsWorkbook Methods


TsWorkbook.GetNumberFormatCount Method

TsWorkbook.GetNumberFormatCount Method
Syntax
Pascal
function GetNumberFormatCount: Integer;
Description

Returns the count of number format records stored in the NumFormatList

Group

TsWorkbook Methods


TsWorkbook.GetNumCellFormats Method

TsWorkbook.GetNumCellFormats Method
Syntax
Pascal
function GetNumCellFormats: Integer;
Description

Returns the count of format records used all over the workbook

Group

TsWorkbook Methods


TsWorkbook.GetPointerToCellFormat Method

TsWorkbook.GetPointerToCellFormat Method
Syntax
Pascal
function GetPointerToCellFormat(AIndex: Integer): PsCellFormat;
Description

Returns a pointer to the format record with the specified index

Group

TsWorkbook Methods


TsWorkbook.GetWorksheetByIndex Method

TsWorkbook.GetWorksheetByIndex Method
Syntax
Pascal
function GetWorksheetByIndex(AIndex: Integer): TsWorksheet;
Parameters
Parameters | Description
AIndex: Integer | The index of the worksheet (0-based)
Returns

A TsWorksheet instance if one is present at that index. nil otherwise.

Description

Gets the worksheet with a given index

The index is zero-based, so the first worksheet added has index 0, the second 1, etc.

See Also

TsWorkbook.GetFirstWorksheet, TsWorkbook.GetWorksheetByName, TsWorksheet

Group

TsWorkbook Methods


TsWorkbook.GetWorksheetByName Method

TsWorkbook.GetWorksheetByName Method
Syntax
Pascal
function GetWorksheetByName(AName: String): TsWorksheet;
Parameters
Parameters | Description
AName: String | The name of the worksheet
Returns

A TsWorksheet instance if one is found with that name, nil otherwise. Case is ignored.

Description

Gets the worksheet with a given worksheet name

See Also

TsWorkbook.GetFirstWorksheet, TsWorkbook.GetWorksheetByIndex, TsWorksheet

Group

TsWorkbook Methods


TsWorkbook.GetWorksheetCount Method

TsWorkbook.GetWorksheetCount Method
Syntax
Pascal
function GetWorksheetCount: Integer;
Description

The number of worksheets on the workbook

See Also

TsWorksheet

Group

TsWorkbook Methods


TsWorkbook.GetWorksheetIndex Method

TsWorkbook.GetWorksheetIndex Method
Syntax
Pascal
function GetWorksheetIndex(AWorksheet: TsWorksheet): Integer;
Description

Returns the index of a worksheet in the worksheet list

Group

TsWorkbook Methods


TsWorkbook.HasEmbeddedSheetImages Method

TsWorkbook.HasEmbeddedSheetImages Method
Syntax
Pascal
function HasEmbeddedSheetImages: Boolean;
Description

Returns true if there is at least one worksheet with an embedded images.

Group

TsWorkbook Methods


TsWorkbook.InitFonts Method

TsWorkbook.InitFonts Method
Syntax
Pascal
procedure InitFonts;
Description

Initializes the font list by adding 5 fonts:

0: default font 1: like default font, but blue and underlined (for hyperlinks) 2: like default font, but bold 3: like default font, but italic

Group

TsWorkbook Methods


TsWorkbook.NotificationsEnabled Method

TsWorkbook.NotificationsEnabled Method
Syntax
Pascal
function NotificationsEnabled: Boolean;
Description

Helper method to determine whether visual controls are notified of changes

Group

TsWorkbook Methods


TsWorkbook.PasteFromClipboardStream Method

TsWorkbook.PasteFromClipboardStream Method
Syntax
Pascal
procedure PasteFromClipboardStream(AStream: TStream; AFormat: TsSpreadsheetFormat; AOperation: TsCopyOperation; AParams: TsStreamParams = []; ATransposed: Boolean = false);
Description

Copies the cells stored in the specified stream to the active worksheet. The provided stream contains data from the system's clipboard. Note that transfer from the clipboard to the stream has to be done by the calling routine since fpspreadsheet does not "know" the system's clipboard.

Group

TsWorkbook Methods


TsWorkbook.PrepareBeforeReading Method

TsWorkbook.PrepareBeforeReading Method
Syntax
Pascal
procedure PrepareBeforeReading;
Description

Helper method called before reading the workbook. Clears the error log.

Group

TsWorkbook Methods


TsWorkbook.PrepareBeforeSaving Method

TsWorkbook.PrepareBeforeSaving Method
Syntax
Pascal
procedure PrepareBeforeSaving;
Description

Helper method called before saving the workbook. Clears the error log, and calculates the formulas in all worksheets if workbook option soCalcBeforeSaving is set.

Group

TsWorkbook Methods


ReadFromFile Method

ReadFromFile Method

This is the overview for the ReadFromFile method overload.

Overload List
Name | Description
TsWorkbook.ReadFromFile (string, TsSpreadFormatID, TsStreamParams) | Reads the document from a file. It is assumed to have the given file format. Works also for user-provided file formats.
TsWorkbook.ReadFromFile (string, TsSpreadsheetFormat, TsStreamParams) | Reads the document from a file. It is assumed to have the given file format. This method is intended for built-in file formats only. For user-provided formats, call the overloaded method with the FormadID parameter.
TsWorkbook.ReadFromFile (string, TsStreamParams) | Reads the document from a file. This method will try to guess the format from the extension. In the case of the ambiguous xls extension, it will simply assume that it is BIFF8. Note that it could be BIFF2 or 5 as well.
Group

TsWorkbook Methods


TsWorkbook.ReadFromFile Method (string, TsSpreadFormatID, TsStreamParams)

TsWorkbook.ReadFromFile Method (string, TsSpreadFormatID, TsStreamParams)
Syntax
Pascal
procedure ReadFromFile(AFileName: string; AFormatID: TsSpreadFormatID; AParams: TsStreamParams = []); overload;
Parameters
Parameters | Description
AFileName: string | Name of the file to be read
AFormatID: TsSpreadFormatID | Identifier of the file format assumed
Description

Reads the document from a file. It is assumed to have the given file format. Works also for user-provided file formats.

Group

ReadFromFile Method


TsWorkbook.ReadFromFile Method (string, TsSpreadsheetFormat, TsStreamParams)

TsWorkbook.ReadFromFile Method (string, TsSpreadsheetFormat, TsStreamParams)
Syntax
Pascal
procedure ReadFromFile(AFileName: string; AFormat: TsSpreadsheetFormat; AParams: TsStreamParams = []); overload;
Parameters
Parameters | Description
AFileName: string | Name of the file to be read
AFormat: TsSpreadsheetFormat | File format assumed
Description

Reads the document from a file. It is assumed to have the given file format.

This method is intended for built-in file formats only. For user-provided formats, call the overloaded method with the FormadID parameter.

Group

ReadFromFile Method


TsWorkbook.ReadFromFile Method (string, TsStreamParams)

TsWorkbook.ReadFromFile Method (string, TsStreamParams)
Syntax
Pascal
procedure ReadFromFile(AFileName: string; AParams: TsStreamParams = []); overload;
Description

Reads the document from a file. This method will try to guess the format from the extension. In the case of the ambiguous xls extension, it will simply assume that it is BIFF8. Note that it could be BIFF2 or 5 as well.

Group

ReadFromFile Method


TsWorkbook.ReadFromFileIgnoringExtension Method

TsWorkbook.ReadFromFileIgnoringExtension Method
Syntax
Pascal
procedure ReadFromFileIgnoringExtension(AFileName: string; AParams: TsStreamParams = []);
Description

Reads the document from a file, but ignores the extension.

Group

TsWorkbook Methods


ReadFromStream Method

ReadFromStream Method

This is the overview for the ReadFromStream method overload.

Overload List
Name | Description
TsWorkbook.ReadFromStream (TStream, TsSpreadFormatID, TsStreamParams) | Reads the document from a seekable stream.
TsWorkbook.ReadFromStream (TStream, TsSpreadsheetFormat, TsStreamParams) | Reads the document from a seekable stream.
Group

TsWorkbook Methods


TsWorkbook.ReadFromStream Method (TStream, TsSpreadFormatID, TsStreamParams)

TsWorkbook.ReadFromStream Method (TStream, TsSpreadFormatID, TsStreamParams)
Syntax
Pascal
procedure ReadFromStream(AStream: TStream; AFormatID: TsSpreadFormatID; AParams: TsStreamParams = []); overload;
Parameters
Parameters | Description
AStream: TStream | Stream being read
AFormatID: TsSpreadFormatID | Identifier of the file format assumed.
AParams: TsStreamParams = [] | Optional parameters to control stream access.
Description

Reads the document from a seekable stream.

Group

ReadFromStream Method


TsWorkbook.ReadFromStream Method (TStream, TsSpreadsheetFormat, TsStreamParams)

TsWorkbook.ReadFromStream Method (TStream, TsSpreadsheetFormat, TsStreamParams)
Syntax
Pascal
procedure ReadFromStream(AStream: TStream; AFormat: TsSpreadsheetFormat; AParams: TsStreamParams = []); overload;
Parameters
Parameters | Description
AStream: TStream | Stream being read
AFormat: TsSpreadsheetFormat | File format assumed.
AParams: TsStreamParams = [] | Optional parameters to control stream access.
Description

Reads the document from a seekable stream.

Group

ReadFromStream Method


TsWorkbook.ReCalc Method

TsWorkbook.ReCalc Method
Syntax
Pascal
procedure ReCalc;
Group

TsWorkbook Methods


TsWorkbook.RemoveAllEmbeddedStreams Method

TsWorkbook.RemoveAllEmbeddedStreams Method
Syntax
Pascal
procedure RemoveAllEmbeddedStreams;
Description

Removes all embedded streams

Group

TsWorkbook Methods


TsWorkbook.RemoveAllFonts Method

TsWorkbook.RemoveAllFonts Method
Syntax
Pascal
procedure RemoveAllFonts;
Description

Clears the list of fonts and releases their memory.

Group

TsWorkbook Methods


TsWorkbook.RemoveAllWorksheets Method

TsWorkbook.RemoveAllWorksheets Method
Syntax
Pascal
procedure RemoveAllWorksheets;
Description

Clears the list of Worksheets and releases their memory.

Notes

This procedure conflicts with the WorkbookLink mechanism which requires at least 1 worksheet per workbook!

Group

TsWorkbook Methods


TsWorkbook.RemoveWorksheet Method

TsWorkbook.RemoveWorksheet Method
Syntax
Pascal
procedure RemoveWorksheet(AWorksheet: TsWorksheet);
Description

Removes the specified worksheet: Removes the sheet from the internal sheet list, generates an event OnRemoveWorksheet, and releases all memory. The event handler specifies the index of the deleted worksheet; the worksheet itself does no longer exist.

Group

TsWorkbook Methods


TsWorkbook.ReplaceFont Method

TsWorkbook.ReplaceFont Method
Syntax
Pascal
procedure ReplaceFont(AFontIndex: Integer; AFontName: String; ASize: Single; AStyle: TsFontStyles; AColor: TsColor; APosition: TsFontPosition = fpNormal);
Description

Replaces the built-in font at a specific index with different font parameters

Group

TsWorkbook Methods


TsWorkbook.SelectWorksheet Method

TsWorkbook.SelectWorksheet Method
Syntax
Pascal
procedure SelectWorksheet(AWorksheet: TsWorksheet);
Description

Makes the specified worksheet "active". Only needed for visual controls. The active worksheet is displayed in a TsWorksheetGrid and in the selected tab of a TsWorkbookTabControl.

Group

TsWorkbook Methods


TsWorkbook.SetDefaultFont Method

TsWorkbook.SetDefaultFont Method
Syntax
Pascal
procedure SetDefaultFont(const AFontName: String; ASize: Single);
Description

Defines the default font. This is the font with index 0 in the FontList. The next built-in fonts will have the same font name and size

Group

TsWorkbook Methods


TsWorkbook.TryStrToCell Method

TsWorkbook.TryStrToCell Method
Syntax
Pascal
function TryStrToCell(AText: String; out AWorksheet: TsWorksheet; out ARow: Cardinal; out ACol: Cardinal; AListSeparator: Char = #0): Boolean;
Parameters
Parameters | Description
AText: String | General cell range string in Excel notation, i.e. worksheet name + ! + cell in A1 notation.
out AWorksheet: TsWorksheet | Pointer to the worksheet referred to by AText. If AText does not contain the worksheet name, the active worksheet of the workbook is returned
out ARow: Cardinal | , ACol Zero-based row and column index of the cell identified by ATest. If AText contains one ore more cell ranges then the upper left corner of the first range is returned.
AListSeparator: Char = #0 | Character to separate the cell blocks in the text If #0 then the ListSeparator of the workbook's FormatSettings is used.
Returns

TRUE if AText is a valid list of cell ranges, FALSE if not. If the result is FALSE then AWorksheet, ARow and ACol may have unpredictable values.

Description

Analyses a string which can contain an array of cell ranges along with a worksheet name. Extracts the worksheet (if missing the "active" worksheet of the workbook is returned) and the cell's row and column indexes.

Example

Sheet1!A1:A10; A1:A10 or A1 are valid as well.

Group

TsWorkbook Methods


TsWorkbook.TryStrToCellRange Method

TsWorkbook.TryStrToCellRange Method
Syntax
Pascal
function TryStrToCellRange(AText: String; out AWorksheet: TsWorksheet; out ARange: TsCellRange; AListSeparator: Char = #0): Boolean;
Parameters
Parameters | Description
AText: String | General cell range string in Excel notation, i.e. worksheet name + ! + cell in A1 notation.
out AWorksheet: TsWorksheet | Pointer to the worksheet referred to by AText. If AText does not contain the worksheet name, the active worksheet of the workbook is returned
out ARange: TsCellRange | TsCellRange records identifying the cell block. If AText contains several cell ranges the first one is returned.
AListSeparator: Char = #0 | Character to separate the cell blocks in the text If #0 then the ListSeparator of the workbook's FormatSettings is used.
Returns

TRUE if AText is a valid cell range, FALSE if not. If the result is FALSE then AWorksheet and ARange may have unpredictable values.

Description

Analyses a string which can contain an array of cell ranges along with a worksheet name. Extracts the worksheet (if missing the "active" worksheet of the workbook is returned) and the cell range (or the first cell range, if there are several ranges).

Example

Sheet1!A1:A10; A1:A10 or A1 are valid as well.

Group

TsWorkbook Methods


TsWorkbook.TryStrToCellRanges Method

TsWorkbook.TryStrToCellRanges Method
Syntax
Pascal
function TryStrToCellRanges(AText: String; out AWorksheet: TsWorksheet; out ARanges: TsCellRangeArray; AListSeparator: Char = #0): Boolean;
Parameters
Parameters | Description
AText: String | General cell range string in Excel notation, i.e. worksheet name + ! + cell in A1 notation.
out AWorksheet: TsWorksheet | Pointer to the worksheet referred to by AText. If AText does not contain the worksheet name, the active worksheet of the workbook is returned
out ARanges: TsCellRangeArray | Array of TsCellRange records identifying the cell blocks
AListSeparator: Char = #0 | Character to separate the cell blocks in the text If #0 then the ListSeparator of the workbook's FormatSettings is used.
Returns

TRUE if AText is a valid list of cell ranges, FALSE if not. If the result is FALSE then AWorksheet and ARanges may have unpredictable values.

Description

Analyses a string which can contain an array of cell ranges along with a worksheet name. Extracts the worksheet (if missing the "active" worksheet of the workbook is returned) and the range array.

Example

Sheet1!A1:A10; A1:A10 or A1 are valid as well.

Group

TsWorkbook Methods


TsWorkbook.UpdateCaches Method

TsWorkbook.UpdateCaches Method
Syntax
Pascal
procedure UpdateCaches;
Description

Helper method to update internal caching variables

Group

TsWorkbook Methods


TsWorkbook.ValidWorksheetName Method

TsWorkbook.ValidWorksheetName Method
Syntax
Pascal
function ValidWorksheetName(var AName: String; ReplaceDuplicateName: Boolean = false): Boolean;
Parameters
Parameters | Description
var AName: String | Name to be checked.
ReplaceDuplicateName: Boolean = false | If there exists already a sheet name equal to AName then a number is added to AName such that the name is unique.
Returns

TRUE if it is a valid worksheet name, FALSE otherwise

Description

Checks whether the passed string is a valid worksheet name according to Excel (ODS seems to be a bit less restrictive, but if we follow Excel's convention we always have valid sheet names independent of the format.

Group

TsWorkbook Methods


WriteToFile Method

WriteToFile Method

This is the overview for the WriteToFile method overload.

Overload List
Name | Description
TsWorkbook.WriteToFile (String, Boolean, TsStreamParams) | Writes the document to file based on the extension. If this was an earlier sfExcel type file, it will be upgraded to sfExcel8.
TsWorkbook.WriteToFile (string, TsSpreadFormatID, Boolean, TsStreamParams) | Writes the document to a file. If the file doesn't exist, it will be created. Can be used for both built-in and user-provided file formats.
TsWorkbook.WriteToFile (string, TsSpreadsheetFormat, Boolean, TsStreamParams) | Writes the document to a file. If the file doesn't exist, it will be created. Can be used only for built-in file formats.
Group

TsWorkbook Methods


TsWorkbook.WriteToFile Method (String, Boolean, TsStreamParams)

TsWorkbook.WriteToFile Method (String, Boolean, TsStreamParams)
Syntax
Pascal
procedure WriteToFile(const AFileName: String; const AOverwriteExisting: Boolean = False; AParams: TsStreamParams = []); overload;
Parameters
Parameters | Description
const AFileName: String | Name of the destination file
const AOverwriteExisting: Boolean = False | If the file already exists it will be overwritten of AOverwriteExisting is true. In case of false, an exception will be raised.
AParams: TsStreamParams = [] | Optional parameters to control stream access
Description

Writes the document to file based on the extension. If this was an earlier sfExcel type file, it will be upgraded to sfExcel8.

Group

WriteToFile Method


TsWorkbook.WriteToFile Method (string, TsSpreadFormatID, Boolean, TsStreamParams)

TsWorkbook.WriteToFile Method (string, TsSpreadFormatID, Boolean, TsStreamParams)
Syntax
Pascal
procedure WriteToFile(const AFileName: string; const AFormatID: TsSpreadFormatID; const AOverwriteExisting: Boolean = False; AParams: TsStreamParams = []); overload;
Parameters
Parameters | Description
const AFileName: string | Name of the file to be written
const AFormatID: TsSpreadFormatID | The file will be written in the file format identified by this number.
const AOverwriteExisting: Boolean = False | If the file is already existing it will be overwritten in case of AOverwriteExisting = true. If the parameter is FALSE then an exception will be raised.
AParams: TsStreamParams = [] | Optional parameters to control stream access.
Description

Writes the document to a file. If the file doesn't exist, it will be created. Can be used for both built-in and user-provided file formats.

Group

WriteToFile Method


TsWorkbook.WriteToFile Method (string, TsSpreadsheetFormat, Boolean, TsStreamParams)

TsWorkbook.WriteToFile Method (string, TsSpreadsheetFormat, Boolean, TsStreamParams)
Syntax
Pascal
procedure WriteToFile(const AFileName: string; const AFormat: TsSpreadsheetFormat; const AOverwriteExisting: Boolean = False; AParams: TsStreamParams = []); overload;
Parameters
Parameters | Description
const AFileName: string | Name of the file to be written
const AFormat: TsSpreadsheetFormat | The file will be written in this file format.
const AOverwriteExisting: Boolean = False | If the file is already existing it will be overwritten in case of AOverwriteExisting = true. If false an exception will be raised.
AParams: TsStreamParams = [] | Optional parameters to control stream access.
Description

Writes the document to a file. If the file doesn't exist, it will be created. Can be used only for built-in file formats.

Group

WriteToFile Method


WriteToStream Method

WriteToStream Method

This is the overview for the WriteToStream method overload.

Overload List
Name | Description
TsWorkbook.WriteToStream (TStream, TsSpreadFormatID, TsStreamParams) | Writes the document to a stream Can be used for both built-in and userprovided file formats.
TsWorkbook.WriteToStream (TStream, TsSpreadsheetFormat, TsStreamParams) | Writes the document to a stream Can be used only for built-in file formats.
Group

TsWorkbook Methods


TsWorkbook.WriteToStream Method (TStream, TsSpreadFormatID, TsStreamParams)

TsWorkbook.WriteToStream Method (TStream, TsSpreadFormatID, TsStreamParams)
Syntax
Pascal
procedure WriteToStream(AStream: TStream; AFormatID: TsSpreadFormatID; AParams: TsStreamParams = []); overload;
Parameters
Parameters | Description
AStream: TStream | Instance of the stream being written to
AFormatID: TsSpreadFormatID | Identifier of the file format to be written.
AParams: TsStreamParams = [] | Optional parameters to control stream access The HTML writer, for example, can be forced to write a valid html document in Windows.
AClipboardMode | Stream will be used by calling method for clipboard access
Description

Writes the document to a stream

Can be used for both built-in and userprovided file formats.

Group

WriteToStream Method


TsWorkbook.WriteToStream Method (TStream, TsSpreadsheetFormat, TsStreamParams)

TsWorkbook.WriteToStream Method (TStream, TsSpreadsheetFormat, TsStreamParams)
Syntax
Pascal
procedure WriteToStream(AStream: TStream; AFormat: TsSpreadsheetFormat; AParams: TsStreamParams = []); overload;
Parameters
Parameters | Description
AStream: TStream | Instance of the stream being written to
AFormat: TsSpreadsheetFormat | File format to be written.
AParams: TsStreamParams = [] | Optional parameters to control stream access The HTML writer, for example, can be forced to write a valid html document in Windows.
AClipboardMode | Stream will be used by calling method for clipboard access
Description

Writes the document to a stream

Can be used only for built-in file formats.

Group

WriteToStream Method


TsWorkbook Properties

TsWorkbook Properties

The properties of the TsWorkbook class are listed here.

Class

TsWorkbook Class

Public Properties
Name | Description
ActiveWorksheet | Identifies the "active" worksheet (only for visual controls)
ErrorMsg | Retrieves error messages collected during reading/writing
FileFormatID | Identifies the file format which was detected when reading the file
FileName | Filename of the saved workbook
OnOpenWorkbook | This event fires whenever a workbook is loaded
Options |
VirtualColCount |
VirtualRowCount |


TsWorkbook.ActiveWorksheet Property

TsWorkbook.ActiveWorksheet Property
Syntax
Pascal
property ActiveWorksheet: TsWorksheet;
Description

Identifies the "active" worksheet (only for visual controls)

Group

TsWorkbook Properties


TsWorkbook.ErrorMsg Property

TsWorkbook.ErrorMsg Property
Syntax
Pascal
property ErrorMsg: String;
Description

Retrieves error messages collected during reading/writing

Group

TsWorkbook Properties


TsWorkbook.FileFormatID Property

TsWorkbook.FileFormatID Property
Syntax
Pascal
property FileFormatID: TsSpreadFormatID;
Description

Identifies the file format which was detected when reading the file

Group

TsWorkbook Properties


TsWorkbook.FileName Property

TsWorkbook.FileName Property
Syntax
Pascal
property FileName: String;
Description

Filename of the saved workbook

Group

TsWorkbook Properties


TsWorkbook.OnOpenWorkbook Property

TsWorkbook.OnOpenWorkbook Property
Syntax
Pascal
property OnOpenWorkbook: TNotifyEvent;
Description

This event fires whenever a workbook is loaded

Group

TsWorkbook Properties


TsWorkbook.Options Property

TsWorkbook.Options Property
Syntax
Pascal
property Options: TsWorkbookOptions;
Group

TsWorkbook Properties


TsWorkbook.VirtualColCount Property

TsWorkbook.VirtualColCount Property
Syntax
Pascal
property VirtualColCount: cardinal;
Group

TsWorkbook Properties


TsWorkbook.VirtualRowCount Property

TsWorkbook.VirtualRowCount Property
Syntax
Pascal
property VirtualRowCount: cardinal;
Group

TsWorkbook Properties


TsWorkbook Events

TsWorkbook Events

The events of the TsWorkbook class are listed here.

Class

TsWorkbook Class

Public Events
Name | Description
OnAddWorksheet | This event fires whenever a new worksheet is added
OnChangeWorksheet | This event fires whenever a worksheet is changed
OnReadCellData | This event accepts cell data while reading a spreadsheet file. Data are not encorporated in a spreadsheet, they are just passed through to the event handler for processing. Requires option boVirtualMode to be set.
OnRemoveWorksheet | This event fires AFTER a worksheet has been deleted
OnRemovingWorksheet | This event fires BEFORE a worksheet is deleted
OnRenameWorksheet | This event fires whenever a worksheet is renamed
OnSelectWorksheet | This event fires when a worksheet is made "active
OnWriteCellData | This event allows to provide external cell data for writing to file, standard cells are ignored. Intended for converting large database files to a spreadsheet format. Requires Option boVirtualMode to be set.


TsWorkbook.OnAddWorksheet Event

TsWorkbook.OnAddWorksheet Event
Syntax
Pascal
property OnAddWorksheet: TsWorksheetEvent;
Description

This event fires whenever a new worksheet is added

Group

TsWorkbook Events


TsWorkbook.OnChangeWorksheet Event

TsWorkbook.OnChangeWorksheet Event
Syntax
Pascal
property OnChangeWorksheet: TsWorksheetEvent;
Description

This event fires whenever a worksheet is changed

Group

TsWorkbook Events


TsWorkbook.OnReadCellData Event

TsWorkbook.OnReadCellData Event
Syntax
Pascal
property OnReadCellData: TsWorkbookReadCellDataEvent;
Description

This event accepts cell data while reading a spreadsheet file. Data are not encorporated in a spreadsheet, they are just passed through to the event handler for processing. Requires option boVirtualMode to be set.

Group

TsWorkbook Events


TsWorkbook.OnRemoveWorksheet Event

TsWorkbook.OnRemoveWorksheet Event
Syntax
Pascal
property OnRemoveWorksheet: TsRemoveWorksheetEvent;
Description

This event fires AFTER a worksheet has been deleted

Group

TsWorkbook Events


TsWorkbook.OnRemovingWorksheet Event

TsWorkbook.OnRemovingWorksheet Event
Syntax
Pascal
property OnRemovingWorksheet: TsWorksheetEvent;
Description

This event fires BEFORE a worksheet is deleted

Group

TsWorkbook Events


TsWorkbook.OnRenameWorksheet Event

TsWorkbook.OnRenameWorksheet Event
Syntax
Pascal
property OnRenameWorksheet: TsWorksheetEvent;
Description

This event fires whenever a worksheet is renamed

Group

TsWorkbook Events


TsWorkbook.OnSelectWorksheet Event

TsWorkbook.OnSelectWorksheet Event
Syntax
Pascal
property OnSelectWorksheet: TsWorksheetEvent;
Description

This event fires when a worksheet is made "active

Group

TsWorkbook Events


TsWorkbook.OnWriteCellData Event

TsWorkbook.OnWriteCellData Event
Syntax
Pascal
property OnWriteCellData: TsWorkbookWriteCellDataEvent;
Description

This event allows to provide external cell data for writing to file, standard cells are ignored. Intended for converting large database files to a spreadsheet format. Requires Option boVirtualMode to be set.

Group

TsWorkbook Events


TsWorkbookSource Class

TsWorkbookSource Class
Class Hierarchy
  TsWorkbookSource
Syntax
Pascal
TsWorkbookSource = class(TComponent);
File

fpspreadsheetctrls

Description

TsWorkbookSource links a workbook to the visual spreadsheet controls and help to display or edit the workbook without written code.

Group

Classes


TsWorkbookSource Members

TsWorkbookSource Members

The following tables list the members exposed by TsWorkbookSource.

Class

TsWorkbookSource Class

Protected Methods
Name | Description
AbortSelection | Generates a message to the grid to abort the selection process. Needed when copying a format (e.g.) cannot be executed due to overlapping ranges. Without the message, the grid would still be in selection mode.
DoShowError | An error has occured during loading of the workbook. Shows a message box by default. But a different behavior can be obtained by means of the OnError event.
InternalCreateNewWorkbook | Internal helper method which creates a new workbook without sheets
InternalLoadFromFile | Internal loader for the spreadsheet file. Is called with various combinations of arguments from several procedures.
InternalLoadFromWorkbook |
Loaded | Inherited method which is called after reading the WorkbookSource from the lfm file. Is overridden here to open a spreadsheet file if a file name has been assigned to the FileName property at design-time.
Public Methods
Name | Description
AddListener | Adds a component to the listener list. All these components are notified of changes in the workbook.
CopyCellsToClipboard | Copies the selected cells of the worksheet to an internal list ("Clipboard"). Note that this is not the system clipboard in the current implementation.
Create | Constructor of the WorkbookSource class. Creates the internal list for the notified ("listening") components, and creates an empty workbook.
CreateNewWorkbook | Creates a new empty workbook and adds a single worksheet
CutCellsToClipboard | Copies the selected cells of the worksheet to an internal list ("Clipboard") and deletes them afterwards.
Destroy | Destructor of the WorkbookSource class. Cleans up the of listening component list and destroys the linked workbook.
DisableControls | Disables notification of listening controls
EnableControls | Enables notification of listening controls
ExecutePendingOperation | Executes a "pending operation
LoadFromSpreadsheetFile | This is the overview for the LoadFromSpreadsheetFile method overload.
LoadFromWorkbook | Uses an already existing workbook in the visual controls. IMPORTANT: THE CALLING ROUTINE MUST NOT DESTROY THE WORKBOOK, it is destroyed here by the TsWorkbookSource.
NotifyListeners | Notifies listeners of workbook, worksheet, cell, or selection changes. The changed item is identified by the parameter AChangedItems.
PasteCellsFromClipboard | Pastes the cells stored in the internal list "Clipboard" into the worksheet. Using their stored row/col indexes the stored cells are translated such that the first stored cell appears at the currently active cell in the worksheet. AOperation determines which "item" of the cell (all, values, formats, formula) is pasted. If ATranspose is TRUE then rows and columns are interchanged.
RemoveListener | Removes a component from the listener list. The component is no longer notified of changes in workbook, worksheet or cells
SaveToSpreadsheetFile | This is the overview for the SaveToSpreadsheetFile method overload.
SelectCell | Usually called by code or from the spreadsheet grid component. The method identifies a cell to be "selected". Stores its coordinates in the worksheet ("active cell") and notifies the listening controls
SelectWorksheet | Selects a worksheet and notifies the controls. This method is usually called by code or from the worksheet tabcontrol.
SetPendingOperation | Defines a "pending operation" which will be executed at next cell select. Source of the operation is the selection passes as a parameter.
Public Properties
Name | Description
FileFormatID | File format identifier of the next spreadsheet file to be loaded by means of the Filename property. Not used when AutoDetectFormat is TRUE. Unlike the published property "FileFormat" the FileFormatID also takes care of user-defined formats.
PendingOperation | Indicates that which operation is waiting to be executed at next cell select
Workbook | Workbook linked to the WorkbookSource
Worksheet | Currently selected worksheet of the workbook
Published Events
Name | Description
OnError | A message box is displayey if an error occurs during loading of a spreadsheet. This behavior can be replaced by means of the event OnError.
Published Properties
Name | Description
AutoDetectFormat | Automatically detects the fileformat when loading the spreadsheet file specified by FileName
FileFormat | File format of the next spreadsheet file to be loaded by means of the Filename property. Not used when AutoDetectFormat is TRUE. Note that if FileFormat is sfUser then the format ID must be specified at runtime.
FileName | Name of the loaded spreadsheet file which is loaded by assigning a file name to this property. Format detection is determined by the properties AutoDetectFormat and FileFormat. Using this property loads the file at design-time.
Options | A set of options to be transferred to the workbook, for e.g. formula calculation etc.


TsWorkbookSource.Create Constructor

TsWorkbookSource.Create Constructor
Syntax
Pascal
constructor Create(AOwner: TComponent); override;
Parameters
Parameters | Description
AOwner: TComponent | Component which is responsibile for destroying the WorkbookSource.
Description

Constructor of the WorkbookSource class. Creates the internal list for the notified ("listening") components, and creates an empty workbook.

Class

TsWorkbookSource Class


TsWorkbookSource.Destroy Destructor

TsWorkbookSource.Destroy Destructor
Syntax
Pascal
destructor Destroy; override;
Description

Destructor of the WorkbookSource class. Cleans up the of listening component list and destroys the linked workbook.

Class

TsWorkbookSource Class


TsWorkbookSource Methods

TsWorkbookSource Methods

The methods of the TsWorkbookSource class are listed here.

Class

TsWorkbookSource Class

Protected Methods
Name | Description
AbortSelection | Generates a message to the grid to abort the selection process. Needed when copying a format (e.g.) cannot be executed due to overlapping ranges. Without the message, the grid would still be in selection mode.
DoShowError | An error has occured during loading of the workbook. Shows a message box by default. But a different behavior can be obtained by means of the OnError event.
InternalCreateNewWorkbook | Internal helper method which creates a new workbook without sheets
InternalLoadFromFile | Internal loader for the spreadsheet file. Is called with various combinations of arguments from several procedures.
InternalLoadFromWorkbook |
Loaded | Inherited method which is called after reading the WorkbookSource from the lfm file. Is overridden here to open a spreadsheet file if a file name has been assigned to the FileName property at design-time.
Public Methods
Name | Description
AddListener | Adds a component to the listener list. All these components are notified of changes in the workbook.
CopyCellsToClipboard | Copies the selected cells of the worksheet to an internal list ("Clipboard"). Note that this is not the system clipboard in the current implementation.
CreateNewWorkbook | Creates a new empty workbook and adds a single worksheet
CutCellsToClipboard | Copies the selected cells of the worksheet to an internal list ("Clipboard") and deletes them afterwards.
DisableControls | Disables notification of listening controls
EnableControls | Enables notification of listening controls
ExecutePendingOperation | Executes a "pending operation
LoadFromSpreadsheetFile | This is the overview for the LoadFromSpreadsheetFile method overload.
LoadFromWorkbook | Uses an already existing workbook in the visual controls. IMPORTANT: THE CALLING ROUTINE MUST NOT DESTROY THE WORKBOOK, it is destroyed here by the TsWorkbookSource.
NotifyListeners | Notifies listeners of workbook, worksheet, cell, or selection changes. The changed item is identified by the parameter AChangedItems.
PasteCellsFromClipboard | Pastes the cells stored in the internal list "Clipboard" into the worksheet. Using their stored row/col indexes the stored cells are translated such that the first stored cell appears at the currently active cell in the worksheet. AOperation determines which "item" of the cell (all, values, formats, formula) is pasted. If ATranspose is TRUE then rows and columns are interchanged.
RemoveListener | Removes a component from the listener list. The component is no longer notified of changes in workbook, worksheet or cells
SaveToSpreadsheetFile | This is the overview for the SaveToSpreadsheetFile method overload.
SelectCell | Usually called by code or from the spreadsheet grid component. The method identifies a cell to be "selected". Stores its coordinates in the worksheet ("active cell") and notifies the listening controls
SelectWorksheet | Selects a worksheet and notifies the controls. This method is usually called by code or from the worksheet tabcontrol.
SetPendingOperation | Defines a "pending operation" which will be executed at next cell select. Source of the operation is the selection passes as a parameter.


TsWorkbookSource.AbortSelection Method

TsWorkbookSource.AbortSelection Method
Syntax
Pascal
procedure AbortSelection;
Description

Generates a message to the grid to abort the selection process. Needed when copying a format (e.g.) cannot be executed due to overlapping ranges. Without the message, the grid would still be in selection mode.

Group

TsWorkbookSource Methods


TsWorkbookSource.AddListener Method

TsWorkbookSource.AddListener Method
Syntax
Pascal
procedure AddListener(AListener: TComponent);
Parameters
Parameters | Description
AListener: TComponent | Component to be added to the listener list notified of changes
Description

Adds a component to the listener list. All these components are notified of changes in the workbook.

Group

TsWorkbookSource Methods


TsWorkbookSource.CopyCellsToClipboard Method

TsWorkbookSource.CopyCellsToClipboard Method
Syntax
Pascal
procedure CopyCellsToClipboard;
Description

Copies the selected cells of the worksheet to an internal list ("Clipboard"). Note that this is not the system clipboard in the current implementation.

Group

TsWorkbookSource Methods


TsWorkbookSource.CreateNewWorkbook Method

TsWorkbookSource.CreateNewWorkbook Method
Syntax
Pascal
procedure CreateNewWorkbook;
Description

Creates a new empty workbook and adds a single worksheet

Group

TsWorkbookSource Methods


TsWorkbookSource.CutCellsToClipboard Method

TsWorkbookSource.CutCellsToClipboard Method
Syntax
Pascal
procedure CutCellsToClipboard;
Description

Copies the selected cells of the worksheet to an internal list ("Clipboard") and deletes them afterwards.

Group

TsWorkbookSource Methods


TsWorkbookSource.DisableControls Method

TsWorkbookSource.DisableControls Method
Syntax
Pascal
procedure DisableControls;
Description

Disables notification of listening controls

Group

TsWorkbookSource Methods


TsWorkbookSource.DoShowError Method

TsWorkbookSource.DoShowError Method
Syntax
Pascal
procedure DoShowError(const AErrorMsg: String);
Parameters
Parameters | Description
const AErrorMsg: String | Error message text created by the workbook reader and to be displayed in a messagebox or by means of the OnError handler.
Description

An error has occured during loading of the workbook. Shows a message box by default. But a different behavior can be obtained by means of the OnError event.

Group

TsWorkbookSource Methods


TsWorkbookSource.EnableControls Method

TsWorkbookSource.EnableControls Method
Syntax
Pascal
procedure EnableControls;
Description

Enables notification of listening controls

Group

TsWorkbookSource Methods


TsWorkbookSource.ExecutePendingOperation Method

TsWorkbookSource.ExecutePendingOperation Method
Syntax
Pascal
procedure ExecutePendingOperation;
Description

Executes a "pending operation

Group

TsWorkbookSource Methods


TsWorkbookSource.InternalCreateNewWorkbook Method

TsWorkbookSource.InternalCreateNewWorkbook Method
Syntax
Pascal
procedure InternalCreateNewWorkbook(AWorkbook: TsWorkbook = nil);
Description

Internal helper method which creates a new workbook without sheets

Group

TsWorkbookSource Methods


TsWorkbookSource.InternalLoadFromFile Method

TsWorkbookSource.InternalLoadFromFile Method
Syntax
Pascal
procedure InternalLoadFromFile(AFileName: string; AAutoDetect: Boolean; AFormatID: TsSpreadFormatID; AWorksheetIndex: Integer = -1);
Parameters
Parameters | Description
AFileName: string | Name of the spreadsheet file to be loaded
AAutoDetect: Boolean | Instructs the loader to automatically detect the file format from the file extension or by temporarily opening the file in all available formats. Note that an exception is raised in the IDE when an incorrect format is tested.
AFormatID: TsSpreadFormatID | Identifier of the spreadsheet file format assumed for the loader. Is ignored when AAutoDetect is false.
AWorksheetIndex: Integer = -1 | Index of the worksheet to be selected after loading.
Description

Internal loader for the spreadsheet file. Is called with various combinations of arguments from several procedures.

Group

TsWorkbookSource Methods


TsWorkbookSource.InternalLoadFromWorkbook Method

TsWorkbookSource.InternalLoadFromWorkbook Method
Syntax
Pascal
procedure InternalLoadFromWorkbook(AWorkbook: TsWorkbook; AWorksheetIndex: Integer = -1);
Group

TsWorkbookSource Methods


TsWorkbookSource.Loaded Method

TsWorkbookSource.Loaded Method
Syntax
Pascal
procedure Loaded; override;
Description

Inherited method which is called after reading the WorkbookSource from the lfm file. Is overridden here to open a spreadsheet file if a file name has been assigned to the FileName property at design-time.

Group

TsWorkbookSource Methods


LoadFromSpreadsheetFile Method

LoadFromSpreadsheetFile Method

This is the overview for the LoadFromSpreadsheetFile method overload.

Overload List
Name | Description
TsWorkbookSource.LoadFromSpreadsheetFile (string, TsSpreadFormatID, Integer) | Public spreadsheet loader to be used if file format is known. Call this methdd for both built-in and user-provided file formats.
TsWorkbookSource.LoadFromSpreadsheetFile (string, TsSpreadsheetFormat, Integer) | Public spreadsheet loader to be used if file format is known. Call this method only for built-in file formats.
Group

TsWorkbookSource Methods


TsWorkbookSource.LoadFromSpreadsheetFile Method (string, TsSpreadFormatID, Integer)

TsWorkbookSource.LoadFromSpreadsheetFile Method (string, TsSpreadFormatID, Integer)
Syntax
Pascal
procedure LoadFromSpreadsheetFile(AFileName: string; AFormatID: TsSpreadFormatID = sfidUnknown; AWorksheetIndex: Integer = -1); overload;
Parameters
Parameters | Description
AFileName: string | Name of the spreadsheet file to be loaded
AFormatID: TsSpreadFormatID = sfidUnknown | Identifier of the spreadsheet file format assumed for the file
AWorksheetIndex: Integer = -1 | Index of the worksheet to be selected after loading. (If empty then the active worksheet is loaded)
Description

Public spreadsheet loader to be used if file format is known.

Call this methdd for both built-in and user-provided file formats.

Group

LoadFromSpreadsheetFile Method


TsWorkbookSource.LoadFromSpreadsheetFile Method (string, TsSpreadsheetFormat, Integer)

TsWorkbookSource.LoadFromSpreadsheetFile Method (string, TsSpreadsheetFormat, Integer)
Syntax
Pascal
procedure LoadFromSpreadsheetFile(AFileName: string; AFormat: TsSpreadsheetFormat; AWorksheetIndex: Integer = -1); overload;
Parameters
Parameters | Description
AFileName: string | Name of the spreadsheet file to be loaded
AFormat: TsSpreadsheetFormat | Spreadsheet file format assumed for the file
AWorksheetIndex: Integer = -1 | Index of the worksheet to be selected after loading. (If empty then the active worksheet is loaded)
Description

Public spreadsheet loader to be used if file format is known.

Call this method only for built-in file formats.

Group

LoadFromSpreadsheetFile Method


TsWorkbookSource.LoadFromWorkbook Method

TsWorkbookSource.LoadFromWorkbook Method
Syntax
Pascal
procedure LoadFromWorkbook(AWorkbook: TsWorkbook; AWorksheetIndex: Integer = -1);
Description

Uses an already existing workbook in the visual controls.

IMPORTANT: THE CALLING ROUTINE MUST NOT DESTROY THE WORKBOOK, it is destroyed here by the TsWorkbookSource.

Group

TsWorkbookSource Methods


TsWorkbookSource.NotifyListeners Method

TsWorkbookSource.NotifyListeners Method
Syntax
Pascal
procedure NotifyListeners(AChangedItems: TsNotificationItems; AData: Pointer = nil);
Parameters
Parameters | Description
AChangedItems: TsNotificationItems | A set of elements lniWorkbook, lniWorksheet, lniCell, lniSelection which indicate which item has changed.
AData: Pointer = nil | Additional information on the change. Is used only for lniCell and points to the cell having a changed value or formatting.
Description

Notifies listeners of workbook, worksheet, cell, or selection changes. The changed item is identified by the parameter AChangedItems.

Group

TsWorkbookSource Methods


TsWorkbookSource.PasteCellsFromClipboard Method

TsWorkbookSource.PasteCellsFromClipboard Method
Syntax
Pascal
procedure PasteCellsFromClipboard(AItem: TsCopyOperation; ATransposed: Boolean = false);
Description

Pastes the cells stored in the internal list "Clipboard" into the worksheet. Using their stored row/col indexes the stored cells are translated such that the first stored cell appears at the currently active cell in the worksheet.

AOperation determines which "item" of the cell (all, values, formats, formula) is pasted.

If ATranspose is TRUE then rows and columns are interchanged.

Group

TsWorkbookSource Methods


TsWorkbookSource.RemoveListener Method

TsWorkbookSource.RemoveListener Method
Syntax
Pascal
procedure RemoveListener(AListener: TComponent);
Parameters
Parameters | Description
AListener: TComponent | Listening component to be removed
Description

Removes a component from the listener list. The component is no longer notified of changes in workbook, worksheet or cells

Group

TsWorkbookSource Methods


SaveToSpreadsheetFile Method

SaveToSpreadsheetFile Method

This is the overview for the SaveToSpreadsheetFile method overload.

Overload List
Name | Description
TsWorkbookSource.SaveToSpreadsheetFile (string, Boolean) |
TsWorkbookSource.SaveToSpreadsheetFile (string, TsSpreadFormatID, Boolean) |
TsWorkbookSource.SaveToSpreadsheetFile (string, TsSpreadsheetFormat, Boolean) |
Group

TsWorkbookSource Methods


TsWorkbookSource.SaveToSpreadsheetFile Method (string, Boolean)

TsWorkbookSource.SaveToSpreadsheetFile Method (string, Boolean)
Syntax
Pascal
procedure SaveToSpreadsheetFile(AFileName: string; AOverwriteExisting: Boolean = true); overload;
Group

SaveToSpreadsheetFile Method


TsWorkbookSource.SaveToSpreadsheetFile Method (string, TsSpreadFormatID, Boolean)

TsWorkbookSource.SaveToSpreadsheetFile Method (string, TsSpreadFormatID, Boolean)
Syntax
Pascal
procedure SaveToSpreadsheetFile(AFileName: string; AFormatID: TsSpreadFormatID; AOverwriteExisting: Boolean = true); overload;
Group

SaveToSpreadsheetFile Method


TsWorkbookSource.SaveToSpreadsheetFile Method (string, TsSpreadsheetFormat, Boolean)

TsWorkbookSource.SaveToSpreadsheetFile Method (string, TsSpreadsheetFormat, Boolean)
Syntax
Pascal
procedure SaveToSpreadsheetFile(AFileName: string; AFormat: TsSpreadsheetFormat; AOverwriteExisting: Boolean = true); overload;
Group

SaveToSpreadsheetFile Method


TsWorkbookSource.SelectCell Method

TsWorkbookSource.SelectCell Method
Syntax
Pascal
procedure SelectCell(ASheetRow: Cardinal; ASheetCol: Cardinal);
Description

Usually called by code or from the spreadsheet grid component. The method identifies a cell to be "selected". Stores its coordinates in the worksheet ("active cell") and notifies the listening controls

Group

TsWorkbookSource Methods


TsWorkbookSource.SelectWorksheet Method

TsWorkbookSource.SelectWorksheet Method
Syntax
Pascal
procedure SelectWorksheet(AWorkSheet: TsWorksheet);
Parameters
Parameters | Description
AWorkSheet: TsWorksheet | Instance of the newly selected worksheet.
Description

Selects a worksheet and notifies the controls. This method is usually called by code or from the worksheet tabcontrol.

Group

TsWorkbookSource Methods


TsWorkbookSource.SetPendingOperation Method

TsWorkbookSource.SetPendingOperation Method
Syntax
Pascal
procedure SetPendingOperation(AOperation: TsCopyOperation; const ASelection: TsCellRangeArray);
Description

Defines a "pending operation" which will be executed at next cell select. Source of the operation is the selection passes as a parameter.

Group

TsWorkbookSource Methods


TsWorkbookSource Properties

TsWorkbookSource Properties

The properties of the TsWorkbookSource class are listed here.

Class

TsWorkbookSource Class

Public Properties
Name | Description
FileFormatID | File format identifier of the next spreadsheet file to be loaded by means of the Filename property. Not used when AutoDetectFormat is TRUE. Unlike the published property "FileFormat" the FileFormatID also takes care of user-defined formats.
PendingOperation | Indicates that which operation is waiting to be executed at next cell select
Workbook | Workbook linked to the WorkbookSource
Worksheet | Currently selected worksheet of the workbook
Published Properties
Name | Description
AutoDetectFormat | Automatically detects the fileformat when loading the spreadsheet file specified by FileName
FileFormat | File format of the next spreadsheet file to be loaded by means of the Filename property. Not used when AutoDetectFormat is TRUE. Note that if FileFormat is sfUser then the format ID must be specified at runtime.
FileName | Name of the loaded spreadsheet file which is loaded by assigning a file name to this property. Format detection is determined by the properties AutoDetectFormat and FileFormat. Using this property loads the file at design-time.
Options | A set of options to be transferred to the workbook, for e.g. formula calculation etc.


TsWorkbookSource.AutoDetectFormat Property

TsWorkbookSource.AutoDetectFormat Property
Syntax
Pascal
property AutoDetectFormat: Boolean;
Description

Automatically detects the fileformat when loading the spreadsheet file specified by FileName

Group

TsWorkbookSource Properties


TsWorkbookSource.FileFormat Property

TsWorkbookSource.FileFormat Property
Syntax
Pascal
property FileFormat: TsSpreadsheetFormat;
Description

File format of the next spreadsheet file to be loaded by means of the Filename property. Not used when AutoDetectFormat is TRUE. Note that if FileFormat is sfUser then the format ID must be specified at runtime.

Group

TsWorkbookSource Properties


TsWorkbookSource.FileFormatID Property

TsWorkbookSource.FileFormatID Property
Syntax
Pascal
property FileFormatID: TsSpreadFormatID;
Description

File format identifier of the next spreadsheet file to be loaded by means of the Filename property. Not used when AutoDetectFormat is TRUE. Unlike the published property "FileFormat" the FileFormatID also takes care of user-defined formats.

Group

TsWorkbookSource Properties


TsWorkbookSource.FileName Property

TsWorkbookSource.FileName Property
Syntax
Pascal
property FileName: TFileName;
Description

Name of the loaded spreadsheet file which is loaded by assigning a file name to this property. Format detection is determined by the properties AutoDetectFormat and FileFormat. Using this property loads the file at design-time.

Group

TsWorkbookSource Properties


TsWorkbookSource.Options Property

TsWorkbookSource.Options Property
Syntax
Pascal
property Options: TsWorkbookOptions;
Description

A set of options to be transferred to the workbook, for e.g. formula calculation etc.

Group

TsWorkbookSource Properties


TsWorkbookSource.PendingOperation Property

TsWorkbookSource.PendingOperation Property
Syntax
Pascal
property PendingOperation: TsCopyOperation;
Description

Indicates that which operation is waiting to be executed at next cell select

Group

TsWorkbookSource Properties


TsWorkbookSource.Workbook Property

TsWorkbookSource.Workbook Property
Syntax
Pascal
property Workbook: TsWorkbook;
Description

Workbook linked to the WorkbookSource

Group

TsWorkbookSource Properties


TsWorkbookSource.Worksheet Property

TsWorkbookSource.Worksheet Property
Syntax
Pascal
property Worksheet: TsWorksheet;
Description

Currently selected worksheet of the workbook

Group

TsWorkbookSource Properties


TsWorkbookSource Events

TsWorkbookSource Events

The events of the TsWorkbookSource class are listed here.

Class

TsWorkbookSource Class

Published Events
Name | Description
OnError | A message box is displayey if an error occurs during loading of a spreadsheet. This behavior can be replaced by means of the event OnError.


TsWorkbookSource.OnError Event

TsWorkbookSource.OnError Event
Syntax
Pascal
property OnError: TsWorkbookSourceErrorEvent;
Description

A message box is displayey if an error occurs during loading of a spreadsheet. This behavior can be replaced by means of the event OnError.

Group

TsWorkbookSource Events


TsWorkbookTabControl Class

TsWorkbookTabControl Class
Class Hierarchy
  TsWorkbookTabControlTsWorkbookTabControl
Syntax
Pascal
TsWorkbookTabControl = class(TTabControl, IsSpreadsheetControl);
File

fpspreadsheetctrls

Description

TsWorkbookTabControl is a tab control which displays the sheets of the workbook currently loaded by the WorkbookSource in tabs. Selecting another tab is communicated to other spreadsheet controls via the WorkbookSource.

Group

Classes


TsWorkbookTabControl Members

TsWorkbookTabControl Members

The following tables list the members exposed by TsWorkbookTabControl.

Class

TsWorkbookTabControl Class

Protected Methods
Name | Description
Change | The currently active tab has been changed. The WorkbookSource must activate the corresponding worksheet and notify its listening components of the change.
GetSheetList | Creates a (string) list containing the names of the workbook's sheet names. Is called whenever the workbook changes.
GetWorkbook | Getter method for property "Workbook
GetWorksheet | Getter method for property "Worksheet
Notification | Standard component notification. Must clean up the WorkbookSource field when the workbook source is going to be deleted.
Public Methods
Name | Description
Destroy | Destructor of the WorkbookTabControl. Removes itself from the WorkbookSource's listener list.
ListenerNotification | Notification message received from the WorkbookSource telling which spreadsheet item has changed. Responds to workbook changes by reading the worksheet names into the tabs, and to worksheet changes by selecting the tab corresponding to the selected worksheet.
RemoveWorkbookSource | Removes the link of the TabControl to the WorkbookSource. Required before destruction.
Public Properties
Name | Description
Workbook | The worksheet names of this workbook are currently displayed as tabs of the TabControl.
Worksheet | Identifies the worksheet which corresponds to the selected tab
Published Properties
Name | Description
WorkbookSource | Link to the WorkbookSource which provides the data.


TsWorkbookTabControl.Destroy Destructor

TsWorkbookTabControl.Destroy Destructor
Syntax
Pascal
destructor Destroy; override;
Description

Destructor of the WorkbookTabControl. Removes itself from the WorkbookSource's listener list.

Class

TsWorkbookTabControl Class


TsWorkbookTabControl Methods

TsWorkbookTabControl Methods

The methods of the TsWorkbookTabControl class are listed here.

Class

TsWorkbookTabControl Class

Protected Methods
Name | Description
Change | The currently active tab has been changed. The WorkbookSource must activate the corresponding worksheet and notify its listening components of the change.
GetSheetList | Creates a (string) list containing the names of the workbook's sheet names. Is called whenever the workbook changes.
GetWorkbook | Getter method for property "Workbook
GetWorksheet | Getter method for property "Worksheet
Notification | Standard component notification. Must clean up the WorkbookSource field when the workbook source is going to be deleted.
Public Methods
Name | Description
ListenerNotification | Notification message received from the WorkbookSource telling which spreadsheet item has changed. Responds to workbook changes by reading the worksheet names into the tabs, and to worksheet changes by selecting the tab corresponding to the selected worksheet.
RemoveWorkbookSource | Removes the link of the TabControl to the WorkbookSource. Required before destruction.


TsWorkbookTabControl.Change Method

TsWorkbookTabControl.Change Method
Syntax
Pascal
procedure Change; override;
Description

The currently active tab has been changed. The WorkbookSource must activate the corresponding worksheet and notify its listening components of the change.

Group

TsWorkbookTabControl Methods


TsWorkbookTabControl.GetSheetList Method

TsWorkbookTabControl.GetSheetList Method
Syntax
Pascal
procedure GetSheetList(AList: TStrings);
Description

Creates a (string) list containing the names of the workbook's sheet names. Is called whenever the workbook changes.

Group

TsWorkbookTabControl Methods


TsWorkbookTabControl.GetWorkbook Method

TsWorkbookTabControl.GetWorkbook Method
Syntax
Pascal
function GetWorkbook: TsWorkbook;
Description

Getter method for property "Workbook

Group

TsWorkbookTabControl Methods


TsWorkbookTabControl.GetWorksheet Method

TsWorkbookTabControl.GetWorksheet Method
Syntax
Pascal
function GetWorksheet: TsWorksheet;
Description

Getter method for property "Worksheet

Group

TsWorkbookTabControl Methods


TsWorkbookTabControl.ListenerNotification Method

TsWorkbookTabControl.ListenerNotification Method
Syntax
Pascal
procedure ListenerNotification(AChangedItems: TsNotificationItems; AData: Pointer = nil);
Parameters
Parameters | Description
AChangedItems: TsNotificationItems | Set with elements identifying whether workbook, worksheet cell content or cell formatting has changed
AData: Pointer = nil | Additional data, not used here
Description

Notification message received from the WorkbookSource telling which spreadsheet item has changed. Responds to workbook changes by reading the worksheet names into the tabs, and to worksheet changes by selecting the tab corresponding to the selected worksheet.

Group

TsWorkbookTabControl Methods


TsWorkbookTabControl.Notification Method

TsWorkbookTabControl.Notification Method
Syntax
Pascal
procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Description

Standard component notification. Must clean up the WorkbookSource field when the workbook source is going to be deleted.

Group

TsWorkbookTabControl Methods


TsWorkbookTabControl.RemoveWorkbookSource Method

TsWorkbookTabControl.RemoveWorkbookSource Method
Syntax
Pascal
procedure RemoveWorkbookSource;
Description

Removes the link of the TabControl to the WorkbookSource. Required before destruction.

Group

TsWorkbookTabControl Methods


TsWorkbookTabControl Properties

TsWorkbookTabControl Properties

The properties of the TsWorkbookTabControl class are listed here.

Class

TsWorkbookTabControl Class

Public Properties
Name | Description
Workbook | The worksheet names of this workbook are currently displayed as tabs of the TabControl.
Worksheet | Identifies the worksheet which corresponds to the selected tab
Published Properties
Name | Description
WorkbookSource | Link to the WorkbookSource which provides the data.


TsWorkbookTabControl.Workbook Property

TsWorkbookTabControl.Workbook Property
Syntax
Pascal
property Workbook: TsWorkbook;
Description

The worksheet names of this workbook are currently displayed as tabs of the TabControl.

Group

TsWorkbookTabControl Properties


TsWorkbookTabControl.WorkbookSource Property

TsWorkbookTabControl.WorkbookSource Property
Syntax
Pascal
property WorkbookSource: TsWorkbookSource;
Description

Link to the WorkbookSource which provides the data.

Group

TsWorkbookTabControl Properties


TsWorkbookTabControl.Worksheet Property

TsWorkbookTabControl.Worksheet Property
Syntax
Pascal
property Worksheet: TsWorksheet;
Description

Identifies the worksheet which corresponds to the selected tab

Group

TsWorkbookTabControl Properties


TsWorksheet Class

TsWorksheet Class
Class Hierarchy
  TsWorksheet
Syntax
Pascal
TsWorksheet = class;
File

fpspreadsheet

Description

The worksheet contains a list of cells and provides a variety of methods to read or write data to the cells, or to change their formatting.

Group

Classes


TsWorksheet Members

TsWorksheet Members

The following tables list the members exposed by TsWorksheet.

Class

TsWorksheet Class

Protected Methods
Name | Description
CellUsedInFormula | Checks entire workbook, whether this cell is used in any formula.
DoCompareCells | Compare function for sorting of rows and columns called directly by Sort() The compare algorithm starts with the first key parameters. If cells are found to be "equal" the next parameter is set is used until a difference is found, or all parameters are used.
DoExchangeColRow | Exchanges columns or rows, depending on value of "AIsColumn"
DoInternalCompareCells | Compare function for sorting of rows and columns. Called by DoCompareCells.
ExchangeCells | Exchanges two cells
RemoveAndFreeCell | Removes a cell and releases its memory. If a comment is attached to the cell then it is removed and releaded as well. Just for internal usage since it does not modify the other cells affected. And it does not change other records depending on the cell (comments, merged ranges etc).
RemoveCell | Removes a cell from its tree container. DOES NOT RELEASE ITS MEMORY!
Public Events
Name | Description
OnChangeCell | Event fired when cell contents or formatting changes
OnChangeFont | Event fired when the font size in a cell changes
OnCompareCells | Event to override cell comparison for sorting
OnSelectCell | Event fired when a cell is "selected".
Public Methods
Name
Description
AddCell
Adds a new cell at a specified row and column index to the Cells list.
BuildRPNFormula
Helper function which constructs an rpn formula from the cell's string formula. This is needed, for example, when writing a formula to xls biff file format. The formula is stored in ACell. If ADestCell is not nil then the relative references are adjusted as seen from ADestCell. This means that this function returns the formula that would be created if ACell is copied to the location of ADestCell. Needed for copying formulas and for splitting shared formulas.
CalcAutoRowHeight
Calculates the optimum height of a given row. Depends on the font size of the individual cells in the row.
CalcFormula
Calculates the formula in a cell Should not be called by itself because the result may depend on other cells which may have not yet been calculated. It is better to call CalcFormulas instead.
CalcFormulas
Calculates all formulas of the worksheet.
Since formulas may reference not-yet-calculated cells, this occurs in two steps:
  1. All formula cells are marked as "not calculated".
  2. Cells are calculated. If referenced cells are found as being "not calculated" they are calculated and then tagged as "calculated".
This results in an iterative calculation procedure. In the end, all cells are calculated.
CalcImageExtent
Calculates image extent
CellInRange
Checks whether a cell given by its row and column indexes belongs to a specified rectangular cell range.
CellPosToText
Converts a FPSpreadsheet cell position, which is Row, Col in numbers and zero based - e.g. 0,0 - to a textual representation which is [Col][Row], where the Col is in letters and the row is in 1-based numbers - e.g. A1
ChangedCell
Is called whenever a cell value or formatting has changed. Fires an event "OnChangeCell". This is handled by TsWorksheetGrid to update the grid cell.
ChangedFont
Is called whenever a font height changes. Fires an even "OnChangeFont" which is handled by TsWorksheetGrid to update the row heights.
ClearSelection
Clears the list of seleccted cell ranges Only needed by the visual controls.
ConvertFormulaDialect
ConvertRPNFormulaToStringFormula
Converts an RPN formula (as read from an xls biff file, for example) to a string formula.
CopyCell
This is the overview for the CopyCell method overload.
CopyFormat
This is the overview for the CopyFormat method overload.
CopyFormula
This is the overview for the CopyFormula method overload.
CopyValue
This is the overview for the CopyValue method overload.
Create
Constructor of the TsWorksheet class.
DeleteCell
Deletes a specified cell. If the cell belongs to a merged block its content and formatting is erased. Otherwise the cell is destroyed and its memory is released.
DeleteCol
Deletes the column at the index specified. Cells with greader column indexes are moved one column to the left. Merged cell blocks and cell references in formulas are considered as well.
DeleteRichTextParams
Removes any previously assigned richtext parameters from a specific cell. This action fully restores the font of the cell.
DeleteRow
Deletes the row at the index specified. Cells with greader row indexes are moved one row up. Merged cell blocks and cell references in formulas are considered as well.
DeleteSelection
Deletes all selected cells (delete = make them empty)
Destroy
Destructor of the TsWorksheet class. Releases all memory, but does not delete from the workbook's worksheetList !!!
EraseCell
Erases content and formatting of a cell. The cell still occupies memory.
FindCell
This is the overview for the FindCell method overload.
FindCol
Checks if a column record exists for the given column index and returns a pointer to the TCol record, or nil if not found
FindComment
Checks whether a cell contains a comment and returns a pointer to the comment data.
FindHyperlink
Checks whether the specified cell contains a hyperlink and returns a pointer to the hyperlink data.
FindMergeBase
Finds the upper left cell of a merged block to which a specified cell belongs. This is the "merge base". Returns nil if the cell is not merged.
FindMergedRange
Determines the merged cell block to which a particular cell belongs
FindNextCellInCol
FindNextCellInRow
FindPrevCellInCol
FindPrevCellInRow
FindRow
Checks if a row record exists for the given row index and returns a pointer to the row record, or nil if not found
GetCalcState
Returns the CalcState flag of the specified cell. This flag tells whether a formula in the cell has not yet been calculated (csNotCalculated), is currently being calculated (csCalculating), or has already been calculated (csCalculated.
GetCell
This is the overview for the GetCell method overload.
GetCellCount
Returns the number of cells in the worksheet with contents.
GetCellCountInCol
Counts how many cells exist in the given column. Blank cells do contribute to the sum, as well as formatted cells.
GetCellCountInRow
Counts how many cells exist in the given row. Blank cells do contribute to the sum, as well as formatted cell.s
GetCol
Checks if a column record exists for the given column index and creates it if not found.
GetColWidth
Returns the width of the given column. If there is no column record then the default column width is returned.
GetDisplayedDecimals
Determines the number of decimals displayed for the number in the cell
GetFirstColIndex
Returns the 0-based index of the first column with a cell with contents.
If no cells have contents, zero will be returned, which is also a valid value.
Use GetCellCount to verify if there is at least one cell with contents in the worksheet.
GetFirstRowIndex
Returns the 0-based index of the first row with a cell with data or formatting. If no cells have contents, -1 will be returned.
GetImage
Returns the parameters of the image stored in the internal image list at the specified index.
GetImageCount
Returns the count of images that are embedded into this sheet.
GetLastColIndex
Returns the 0-based index of the last column containing a cell with a column record (due to content or formatting), or containing a Col record.
If no cells have contents or there are no column records, zero will be returned, which is also a valid value.
Use GetCellCount to verify if there is at least one cell with contents in the worksheet.
GetLastColNumber
Deprecated, use GetLastColIndex instead
GetLastOccupiedColIndex
Returns the 0-based index of the last column with a cell with contents. If no cells have contents, zero will be returned, which is also a valid value.
Use GetCellCount to verify if there is at least one cell with contents in the worksheet.
GetLastOccupiedRowIndex
Returns the 0-based index of the last row with a cell with contents. If no cells have contents, zero will be returned, which is also a valid value.
Use GetCellCount to verify if there is at least one cell with contents in the worksheet.
GetLastRowIndex
Returns the 0-based index of the last row with a cell with contents or with a ROW record.
If no cells have contents, zero will be returned, which is also a valid value.
Use GetCellCount to verify if there is at least one cell with contents in the worksheet.
GetLastRowNumber
Deprecated, use GetLastColIndex instead
GetNumberFormatAttributes
GetRow
Checks if a row record exists for the given row index and creates it if not found.
GetRowHeight
Returns the height of the given row. If there is no row record then the default row height is returned
GetSelection
Returns the list of selected cell ranges
GetSelectionAsString
Returns all selection ranges as an Excel string
GetSelectionCount
Returns the number of selected cell ranges
GetSelectionRangeIndexOfActiveCell
Returns the index of the selected block which contains the active cell
HasComment
Checks whether a specific cell contains a comment
HasHyperlink
Checks whether the specified cell contains a hyperlink
InSameMergedRange
Checks whether the two specified cells belong to the same merged cell block.
InsertCol
Inserts a column BEFORE the index specified. Cells with greater column indexes are moved one column to the right. Merged cell blocks and cell references in formulas are considered as well.
InsertRow
Inserts a row BEFORE the row specified. Cells with greater row indexes are moved one row down. Merged cell blocks and cell references in formulas are considered as well.
IsMergeBase
Returns true if the specified cell is the base of a merged cell range, i.e. the upper left corner of that range.
IsMerged
Returns TRUE if the specified cell belongs to a merged block
MergeCells
This is the overview for the MergeCells method overload.
ReadAsDateTime
This is the overview for the ReadAsDateTime method overload.
ReadAsNumber
This is the overview for the ReadAsNumber method overload.
ReadAsText
This is the overview for the ReadAsText method overload.
ReadAsUTF8Text
This is the overview for the ReadAsUTF8Text method overload.
ReadBackground
Returns the background fill pattern and colors of a cell.
ReadBackgroundColor
Returns the background color of a cell as rbg value
ReadBiDiMode
Returns the BiDi mode of the cell (right-to-left or left-to-right)
ReadCellBorders
Determines which borders are drawn around a specific cell
ReadCellBorderStyle
ReadCellBorderStyles
Determines which all border styles of a given cell
ReadCellFont
Determines the font used by a specified cell. Returns the workbook's default font if the cell does not exist.
ReadCellFontIndex
Determines the index of the font used by a specified cell, referring to the workbooks font list. Returns 0 (the default font index) if the cell does not exist.
ReadCellFormat
Returns the format record that is assigned to a specified cell
ReadComment
This is the overview for the ReadComment method overload.
ReadFormulaAsString
If a cell contains a formula (string formula or RPN formula) the formula is returned as a string in Excel syntax.
ReadHorAlignment
Returns the horizontal alignment of a specific cell
ReadHyperlink
Reads the hyperlink information of a specified cell.
ReadNumericValue
Returns to numeric equivalent of the cell contents. This is the NumberValue of a number cell, the DateTimeValue of a date/time cell, the ordinal BoolValue of a boolean cell, or the string converted to a number of a string cell. All other cases return NaN.
ReadNumFormat
Returns the number format type and format string used in a specific cell
ReadTextRotation
Returns the text orientation of a specific cell
ReadUsedFormatting
Reads the set of used formatting fields of a cell.
Each cell contains a set of "used formatting fields". Formatting is applied only if the corresponding element is contained in the set.
ReadVertAlignment
Returns the vertical alignment of a specific cell
ReadWordwrap
Returns whether a specific cell support word-wrapping.
RemoveAllCols
Removes all column records from the worksheet and frees the occupied memory.
RemoveAllImages
RemoveAllRows
Removes all row records from the worksheet and frees the occupied memory.
RemoveCol
Removes a specified column record from the worksheet and frees the occupied memory. This resets its column width to default.
RemoveComment
Removes the comment from a cell and releases the memory occupied by the node.
RemoveHyperlink
Removes a hyperlink from the specified cell. Releaes memory occupied by the associated TsHyperlink record. Cell content type is converted to cctUTF8String.
RemoveImage
Removes an image from the internal image list. The image is identified by its index. The image stream (stored by the workbook) is retained.
RemoveRow
Removes a specified row record from the worksheet and frees the occupied memory. This resets the its row height to default.
SelectCell
Marks a specified cell as "selected". Only needed by the visual controls.
SetCalcState
Set the CalcState flag of the specified cell. This flag tells whether a formula in the cell has not yet been calculated (csNotCalculated), is currently being calculated (csCalculating), or has already been calculated (csCalculated).
For internal use only!
SetSelection
Marks an array of cell ranges as "selected". Only needed for visual controls
Sort
This is the overview for the Sort method overload.
UnmergeCells
This is the overview for the UnmergeCells method overload.
UpdateCaches
Helper method to update internal caching variables
ValidHyperlink
Checks whether the passed string represents a valid hyperlink target
WriteBackground
This is the overview for the WriteBackground method overload.
WriteBackgroundColor
This is the overview for the WriteBackgroundColor method overload.
WriteBiDiMode
This is the overview for the WriteBiDiMode method overload.
WriteBlank
This is the overview for the WriteBlank method overload.
WriteBoolValue
This is the overview for the WriteBoolValue method overload.
WriteBorderColor
This is the overview for the WriteBorderColor method overload.
WriteBorderLineStyle
This is the overview for the WriteBorderLineStyle method overload.
WriteBorders
This is the overview for the WriteBorders method overload.
WriteBorderStyle
This is the overview for the WriteBorderStyle method overload.
WriteBorderStyles
This is the overview for the WriteBorderStyles method overload.
WriteCellFormat
Assigns a complete cell format record to a cell
WriteCellValueAsString
This is the overview for the WriteCellValueAsString method overload.
WriteColInfo
Writes a column record for the column at a given index to the spreadsheet. Currently the column record contains only the column width (and the column index, of course).
Creates a new column record if it does not yet exist.
WriteColWidth
Sets the column width for a given column. Creates a new column record if it does not yet exist.
WriteComment
This is the overview for the WriteComment method overload.
WriteCurrency
This is the overview for the WriteCurrency method overload.
WriteDateTime
This is the overview for the WriteDateTime method overload.
WriteDateTimeFormat
This is the overview for the WriteDateTimeFormat method overload.
WriteDecimals
This is the overview for the WriteDecimals method overload.
WriteErrorValue
This is the overview for the WriteErrorValue method overload.
WriteFont
This is the overview for the WriteFont method overload.
WriteFontColor
This is the overview for the WriteFontColor method overload.
WriteFontName
This is the overview for the WriteFontName method overload.
WriteFontSize
This is the overview for the WriteFontSize method overload.
WriteFontStyle
This is the overview for the WriteFontStyle method overload.
WriteFormula
This is the overview for the WriteFormula method overload.
WriteFractionFormat
This is the overview for the WriteFractionFormat method overload.
WriteHorAlignment
This is the overview for the WriteHorAlignment method overload.
WriteHyperlink
This is the overview for the WriteHyperlink method overload.
WriteImage
Adds an embedded image to the worksheet
WriteNumber
This is the overview for the WriteNumber method overload.
WriteNumberFormat
This is the overview for the WriteNumberFormat method overload.
WriteRowHeight
Sets the row height for a given row. Creates a new row record if it does not yet exist.
WriteRowInfo
Writes a row record for the row at a given index to the spreadsheet. Currently the row record contains only the row height (and the row index, of course).
Creates a new row record if it does not yet exist.
WriteRPNFormula
This is the overview for the WriteRPNFormula method overload.
WriteText
This is the overview for the WriteText method overload.
WriteTextAsHTML
This is the overview for the WriteTextAsHTML method overload.
WriteTextRotation
This is the overview for the WriteTextRotation method overload.
WriteUsedFormatting
This is the overview for the WriteUsedFormatting method overload.
WriteUTF8Text
This is the overview for the WriteUTF8Text method overload.
WriteVertAlignment
This is the overview for the WriteVertAlignment method overload.
WriteWordwrap
This is the overview for the WriteWordwrap method overload.
Public Properties
Name | Description
ActiveCellCol | Column index of the selected cell of this worksheet
ActiveCellRow | Row index of the selected cell of this worksheet
BiDiMode |
Cells | List of cells of the worksheet. Only cells with contents or with formatting are listed
Cols | List of all column records of the worksheet having a non-standard column width
Comments | List of all comment records
DefaultColWidth | The default column width given in "character units" (width of the character "0" in the default font)
DefaultRowHeight | The default row height is given in "line count" (height of the default font
FormatSettings | FormatSettings for localization of some formatting strings
Hyperlinks | List of hyperlink information records
LeftPaneWidth | Number of frozen columns which do not scroll
MergedCells | List of merged cells (contains TsCellRange records)
Name | Name of the sheet. In the popular spreadsheet applications this is displayed at the tab of the sheet.
Options | Parameters controlling visibility of grid lines and row/column headers, usage of frozen panes etc.
PageLayout | Parameters to be used for printing by the Office applications
Rows | List of all row records of the worksheet having a non-standard row height
TopPaneHeight | Number of frozen rows which do not scroll
Workbook | Workbook to which the worksheet belongs


TsWorksheet.Create Constructor

TsWorksheet.Create Constructor
Syntax
Pascal
constructor Create;
Description

Constructor of the TsWorksheet class.

Class

TsWorksheet Class


TsWorksheet.Destroy Destructor

TsWorksheet.Destroy Destructor
Syntax
Pascal
destructor Destroy; override;
Description

Destructor of the TsWorksheet class. Releases all memory, but does not delete from the workbook's worksheetList !!!

Notes

Don't call directly. Always use Workbook.RemoveWorksheet to remove a worksheet from a workbook.

Class

TsWorksheet Class


TsWorksheet Methods

TsWorksheet Methods

The methods of the TsWorksheet class are listed here.

Class

TsWorksheet Class

Protected Methods
Name | Description
CellUsedInFormula | Checks entire workbook, whether this cell is used in any formula.
DoCompareCells | Compare function for sorting of rows and columns called directly by Sort() The compare algorithm starts with the first key parameters. If cells are found to be "equal" the next parameter is set is used until a difference is found, or all parameters are used.
DoExchangeColRow | Exchanges columns or rows, depending on value of "AIsColumn"
DoInternalCompareCells | Compare function for sorting of rows and columns. Called by DoCompareCells.
ExchangeCells | Exchanges two cells
RemoveAndFreeCell | Removes a cell and releases its memory. If a comment is attached to the cell then it is removed and releaded as well. Just for internal usage since it does not modify the other cells affected. And it does not change other records depending on the cell (comments, merged ranges etc).
RemoveCell | Removes a cell from its tree container. DOES NOT RELEASE ITS MEMORY!
Public Methods
Name
Description
AddCell
Adds a new cell at a specified row and column index to the Cells list.
BuildRPNFormula
Helper function which constructs an rpn formula from the cell's string formula. This is needed, for example, when writing a formula to xls biff file format. The formula is stored in ACell. If ADestCell is not nil then the relative references are adjusted as seen from ADestCell. This means that this function returns the formula that would be created if ACell is copied to the location of ADestCell. Needed for copying formulas and for splitting shared formulas.
CalcAutoRowHeight
Calculates the optimum height of a given row. Depends on the font size of the individual cells in the row.
CalcFormula
Calculates the formula in a cell Should not be called by itself because the result may depend on other cells which may have not yet been calculated. It is better to call CalcFormulas instead.
CalcFormulas
Calculates all formulas of the worksheet.
Since formulas may reference not-yet-calculated cells, this occurs in two steps:
  1. All formula cells are marked as "not calculated".
  2. Cells are calculated. If referenced cells are found as being "not calculated" they are calculated and then tagged as "calculated".
This results in an iterative calculation procedure. In the end, all cells are calculated.
CalcImageExtent
Calculates image extent
CellInRange
Checks whether a cell given by its row and column indexes belongs to a specified rectangular cell range.
CellPosToText
Converts a FPSpreadsheet cell position, which is Row, Col in numbers and zero based - e.g. 0,0 - to a textual representation which is [Col][Row], where the Col is in letters and the row is in 1-based numbers - e.g. A1
ChangedCell
Is called whenever a cell value or formatting has changed. Fires an event "OnChangeCell". This is handled by TsWorksheetGrid to update the grid cell.
ChangedFont
Is called whenever a font height changes. Fires an even "OnChangeFont" which is handled by TsWorksheetGrid to update the row heights.
ClearSelection
Clears the list of seleccted cell ranges Only needed by the visual controls.
ConvertFormulaDialect
ConvertRPNFormulaToStringFormula
Converts an RPN formula (as read from an xls biff file, for example) to a string formula.
CopyCell
This is the overview for the CopyCell method overload.
CopyFormat
This is the overview for the CopyFormat method overload.
CopyFormula
This is the overview for the CopyFormula method overload.
CopyValue
This is the overview for the CopyValue method overload.
DeleteCell
Deletes a specified cell. If the cell belongs to a merged block its content and formatting is erased. Otherwise the cell is destroyed and its memory is released.
DeleteCol
Deletes the column at the index specified. Cells with greader column indexes are moved one column to the left. Merged cell blocks and cell references in formulas are considered as well.
DeleteRichTextParams
Removes any previously assigned richtext parameters from a specific cell. This action fully restores the font of the cell.
DeleteRow
Deletes the row at the index specified. Cells with greader row indexes are moved one row up. Merged cell blocks and cell references in formulas are considered as well.
DeleteSelection
Deletes all selected cells (delete = make them empty)
EraseCell
Erases content and formatting of a cell. The cell still occupies memory.
FindCell
This is the overview for the FindCell method overload.
FindCol
Checks if a column record exists for the given column index and returns a pointer to the TCol record, or nil if not found
FindComment
Checks whether a cell contains a comment and returns a pointer to the comment data.
FindHyperlink
Checks whether the specified cell contains a hyperlink and returns a pointer to the hyperlink data.
FindMergeBase
Finds the upper left cell of a merged block to which a specified cell belongs. This is the "merge base". Returns nil if the cell is not merged.
FindMergedRange
Determines the merged cell block to which a particular cell belongs
FindNextCellInCol
FindNextCellInRow
FindPrevCellInCol
FindPrevCellInRow
FindRow
Checks if a row record exists for the given row index and returns a pointer to the row record, or nil if not found
GetCalcState
Returns the CalcState flag of the specified cell. This flag tells whether a formula in the cell has not yet been calculated (csNotCalculated), is currently being calculated (csCalculating), or has already been calculated (csCalculated.
GetCell
This is the overview for the GetCell method overload.
GetCellCount
Returns the number of cells in the worksheet with contents.
GetCellCountInCol
Counts how many cells exist in the given column. Blank cells do contribute to the sum, as well as formatted cells.
GetCellCountInRow
Counts how many cells exist in the given row. Blank cells do contribute to the sum, as well as formatted cell.s
GetCol
Checks if a column record exists for the given column index and creates it if not found.
GetColWidth
Returns the width of the given column. If there is no column record then the default column width is returned.
GetDisplayedDecimals
Determines the number of decimals displayed for the number in the cell
GetFirstColIndex
Returns the 0-based index of the first column with a cell with contents.
If no cells have contents, zero will be returned, which is also a valid value.
Use GetCellCount to verify if there is at least one cell with contents in the worksheet.
GetFirstRowIndex
Returns the 0-based index of the first row with a cell with data or formatting. If no cells have contents, -1 will be returned.
GetImage
Returns the parameters of the image stored in the internal image list at the specified index.
GetImageCount
Returns the count of images that are embedded into this sheet.
GetLastColIndex
Returns the 0-based index of the last column containing a cell with a column record (due to content or formatting), or containing a Col record.
If no cells have contents or there are no column records, zero will be returned, which is also a valid value.
Use GetCellCount to verify if there is at least one cell with contents in the worksheet.
GetLastColNumber
Deprecated, use GetLastColIndex instead
GetLastOccupiedColIndex
Returns the 0-based index of the last column with a cell with contents. If no cells have contents, zero will be returned, which is also a valid value.
Use GetCellCount to verify if there is at least one cell with contents in the worksheet.
GetLastOccupiedRowIndex
Returns the 0-based index of the last row with a cell with contents. If no cells have contents, zero will be returned, which is also a valid value.
Use GetCellCount to verify if there is at least one cell with contents in the worksheet.
GetLastRowIndex
Returns the 0-based index of the last row with a cell with contents or with a ROW record.
If no cells have contents, zero will be returned, which is also a valid value.
Use GetCellCount to verify if there is at least one cell with contents in the worksheet.
GetLastRowNumber
Deprecated, use GetLastColIndex instead
GetNumberFormatAttributes
GetRow
Checks if a row record exists for the given row index and creates it if not found.
GetRowHeight
Returns the height of the given row. If there is no row record then the default row height is returned
GetSelection
Returns the list of selected cell ranges
GetSelectionAsString
Returns all selection ranges as an Excel string
GetSelectionCount
Returns the number of selected cell ranges
GetSelectionRangeIndexOfActiveCell
Returns the index of the selected block which contains the active cell
HasComment
Checks whether a specific cell contains a comment
HasHyperlink
Checks whether the specified cell contains a hyperlink
InSameMergedRange
Checks whether the two specified cells belong to the same merged cell block.
InsertCol
Inserts a column BEFORE the index specified. Cells with greater column indexes are moved one column to the right. Merged cell blocks and cell references in formulas are considered as well.
InsertRow
Inserts a row BEFORE the row specified. Cells with greater row indexes are moved one row down. Merged cell blocks and cell references in formulas are considered as well.
IsMergeBase
Returns true if the specified cell is the base of a merged cell range, i.e. the upper left corner of that range.
IsMerged
Returns TRUE if the specified cell belongs to a merged block
MergeCells
This is the overview for the MergeCells method overload.
ReadAsDateTime
This is the overview for the ReadAsDateTime method overload.
ReadAsNumber
This is the overview for the ReadAsNumber method overload.
ReadAsText
This is the overview for the ReadAsText method overload.
ReadAsUTF8Text
This is the overview for the ReadAsUTF8Text method overload.
ReadBackground
Returns the background fill pattern and colors of a cell.
ReadBackgroundColor
Returns the background color of a cell as rbg value
ReadBiDiMode
Returns the BiDi mode of the cell (right-to-left or left-to-right)
ReadCellBorders
Determines which borders are drawn around a specific cell
ReadCellBorderStyle
ReadCellBorderStyles
Determines which all border styles of a given cell
ReadCellFont
Determines the font used by a specified cell. Returns the workbook's default font if the cell does not exist.
ReadCellFontIndex
Determines the index of the font used by a specified cell, referring to the workbooks font list. Returns 0 (the default font index) if the cell does not exist.
ReadCellFormat
Returns the format record that is assigned to a specified cell
ReadComment
This is the overview for the ReadComment method overload.
ReadFormulaAsString
If a cell contains a formula (string formula or RPN formula) the formula is returned as a string in Excel syntax.
ReadHorAlignment
Returns the horizontal alignment of a specific cell
ReadHyperlink
Reads the hyperlink information of a specified cell.
ReadNumericValue
Returns to numeric equivalent of the cell contents. This is the NumberValue of a number cell, the DateTimeValue of a date/time cell, the ordinal BoolValue of a boolean cell, or the string converted to a number of a string cell. All other cases return NaN.
ReadNumFormat
Returns the number format type and format string used in a specific cell
ReadTextRotation
Returns the text orientation of a specific cell
ReadUsedFormatting
Reads the set of used formatting fields of a cell.
Each cell contains a set of "used formatting fields". Formatting is applied only if the corresponding element is contained in the set.
ReadVertAlignment
Returns the vertical alignment of a specific cell
ReadWordwrap
Returns whether a specific cell support word-wrapping.
RemoveAllCols
Removes all column records from the worksheet and frees the occupied memory.
RemoveAllImages
RemoveAllRows
Removes all row records from the worksheet and frees the occupied memory.
RemoveCol
Removes a specified column record from the worksheet and frees the occupied memory. This resets its column width to default.
RemoveComment
Removes the comment from a cell and releases the memory occupied by the node.
RemoveHyperlink
Removes a hyperlink from the specified cell. Releaes memory occupied by the associated TsHyperlink record. Cell content type is converted to cctUTF8String.
RemoveImage
Removes an image from the internal image list. The image is identified by its index. The image stream (stored by the workbook) is retained.
RemoveRow
Removes a specified row record from the worksheet and frees the occupied memory. This resets the its row height to default.
SelectCell
Marks a specified cell as "selected". Only needed by the visual controls.
SetCalcState
Set the CalcState flag of the specified cell. This flag tells whether a formula in the cell has not yet been calculated (csNotCalculated), is currently being calculated (csCalculating), or has already been calculated (csCalculated).
For internal use only!
SetSelection
Marks an array of cell ranges as "selected". Only needed for visual controls
Sort
This is the overview for the Sort method overload.
UnmergeCells
This is the overview for the UnmergeCells method overload.
UpdateCaches
Helper method to update internal caching variables
ValidHyperlink
Checks whether the passed string represents a valid hyperlink target
WriteBackground
This is the overview for the WriteBackground method overload.
WriteBackgroundColor
This is the overview for the WriteBackgroundColor method overload.
WriteBiDiMode
This is the overview for the WriteBiDiMode method overload.
WriteBlank
This is the overview for the WriteBlank method overload.
WriteBoolValue
This is the overview for the WriteBoolValue method overload.
WriteBorderColor
This is the overview for the WriteBorderColor method overload.
WriteBorderLineStyle
This is the overview for the WriteBorderLineStyle method overload.
WriteBorders
This is the overview for the WriteBorders method overload.
WriteBorderStyle
This is the overview for the WriteBorderStyle method overload.
WriteBorderStyles
This is the overview for the WriteBorderStyles method overload.
WriteCellFormat
Assigns a complete cell format record to a cell
WriteCellValueAsString
This is the overview for the WriteCellValueAsString method overload.
WriteColInfo
Writes a column record for the column at a given index to the spreadsheet. Currently the column record contains only the column width (and the column index, of course).
Creates a new column record if it does not yet exist.
WriteColWidth
Sets the column width for a given column. Creates a new column record if it does not yet exist.
WriteComment
This is the overview for the WriteComment method overload.
WriteCurrency
This is the overview for the WriteCurrency method overload.
WriteDateTime
This is the overview for the WriteDateTime method overload.
WriteDateTimeFormat
This is the overview for the WriteDateTimeFormat method overload.
WriteDecimals
This is the overview for the WriteDecimals method overload.
WriteErrorValue
This is the overview for the WriteErrorValue method overload.
WriteFont
This is the overview for the WriteFont method overload.
WriteFontColor
This is the overview for the WriteFontColor method overload.
WriteFontName
This is the overview for the WriteFontName method overload.
WriteFontSize
This is the overview for the WriteFontSize method overload.
WriteFontStyle
This is the overview for the WriteFontStyle method overload.
WriteFormula
This is the overview for the WriteFormula method overload.
WriteFractionFormat
This is the overview for the WriteFractionFormat method overload.
WriteHorAlignment
This is the overview for the WriteHorAlignment method overload.
WriteHyperlink
This is the overview for the WriteHyperlink method overload.
WriteImage
Adds an embedded image to the worksheet
WriteNumber
This is the overview for the WriteNumber method overload.
WriteNumberFormat
This is the overview for the WriteNumberFormat method overload.
WriteRowHeight
Sets the row height for a given row. Creates a new row record if it does not yet exist.
WriteRowInfo
Writes a row record for the row at a given index to the spreadsheet. Currently the row record contains only the row height (and the row index, of course).
Creates a new row record if it does not yet exist.
WriteRPNFormula
This is the overview for the WriteRPNFormula method overload.
WriteText
This is the overview for the WriteText method overload.
WriteTextAsHTML
This is the overview for the WriteTextAsHTML method overload.
WriteTextRotation
This is the overview for the WriteTextRotation method overload.
WriteUsedFormatting
This is the overview for the WriteUsedFormatting method overload.
WriteUTF8Text
This is the overview for the WriteUTF8Text method overload.
WriteVertAlignment
This is the overview for the WriteVertAlignment method overload.
WriteWordwrap
This is the overview for the WriteWordwrap method overload.


TsWorksheet.AddCell Method

TsWorksheet.AddCell Method
Syntax
Pascal
function AddCell(ARow: Cardinal; ACol: Cardinal): PCell;
Description

Adds a new cell at a specified row and column index to the Cells list.

Notes

It is not checked if there exists already another cell at this location. This case must be avoided. USE CAREFULLY WITHOUT FindCell (e.g., during reading into empty worksheets).

Group

TsWorksheet Methods


TsWorksheet.BuildRPNFormula Method

TsWorksheet.BuildRPNFormula Method
Syntax
Pascal
function BuildRPNFormula(ACell: PCell; ADestCell: PCell = nil): TsRPNFormula;
Description

Helper function which constructs an rpn formula from the cell's string formula. This is needed, for example, when writing a formula to xls biff file format. The formula is stored in ACell. If ADestCell is not nil then the relative references are adjusted as seen from ADestCell. This means that this function returns the formula that would be created if ACell is copied to the location of ADestCell. Needed for copying formulas and for splitting shared formulas.

Group

TsWorksheet Methods


TsWorksheet.CalcAutoRowHeight Method

TsWorksheet.CalcAutoRowHeight Method
Syntax
Pascal
function CalcAutoRowHeight(ARow: Cardinal): Single;
Parameters
Parameters | Description
ARow: Cardinal | Index of the row to be considered
Returns

Row height in line count of the default font.

Description

Calculates the optimum height of a given row. Depends on the font size of the individual cells in the row.

Group

TsWorksheet Methods


TsWorksheet.CalcFormula Method

TsWorksheet.CalcFormula Method
Syntax
Pascal
procedure CalcFormula(ACell: PCell);
Parameters
Parameters | Description
ACell: PCell | Cell containing the formula.
Description

Calculates the formula in a cell Should not be called by itself because the result may depend on other cells which may have not yet been calculated. It is better to call CalcFormulas instead.

Group

TsWorksheet Methods


TsWorksheet.CalcFormulas Method

TsWorksheet.CalcFormulas Method
Syntax
Pascal
procedure CalcFormulas;
Description

Calculates all formulas of the worksheet.

Since formulas may reference not-yet-calculated cells, this occurs in two steps:

  1. All formula cells are marked as "not calculated".
  2. Cells are calculated. If referenced cells are found as being "not calculated" they are calculated and then tagged as "calculated".

This results in an iterative calculation procedure. In the end, all cells are calculated.

Group

TsWorksheet Methods


TsWorksheet.CalcImageExtent Method

TsWorksheet.CalcImageExtent Method
Syntax
Pascal
function CalcImageExtent(AIndex: Integer; out ARow1: Cardinal; out ACol1: Cardinal; out ARow2: Cardinal; out ACol2: Cardinal; out ARowOffs1: Double; out AColOffs1: Double; out ARowOffs2: Double; out AColOffs2: Double; out x: Double; out y: Double; out AWidth: Double; out AHeight: Double): Boolean;
Parameters
Parameters | Description
out ARow1: Cardinal | Index of the row containing the top edge of the image
out ACol1: Cardinal | Index of the column containing the left edege of the image
out ARow2: Cardinal | Index of the row containing the right edge of the image
out ACol2: Cardinal | Index of the column containing the bottom edge of the image
out ARowOffs1: Double | Distance between the top edge of image and row 1, in mm
out AColOffs1: Double | Distance between the left edge of image and column 1, in mm
out ARowOffs2: Double | Distance between the bottom edge of image and top of row 2, in mm
out AColOffs2: Double | Distance between the right edge of image and left of col 2, in mm
out x: Double | Absolute coordinate of left edge of image, in mm
out y: Double | Absolute coordinate of top edge of image, in mm
out AWidth: Double | Width of the image, in mm
out AHeight: Double | Height of the image, in mm
Returns

FALSE if the image stream cannot be read or the format is unsupported.

Description

Calculates image extent

Group

TsWorksheet Methods


TsWorksheet.CellInRange Method

TsWorksheet.CellInRange Method
Syntax
Pascal
class function CellInRange(ARow: Cardinal; ACol: Cardinal; ARange: TsCellRange): Boolean;
Description

Checks whether a cell given by its row and column indexes belongs to a specified rectangular cell range.

Group

TsWorksheet Methods


TsWorksheet.CellPosToText Method

TsWorksheet.CellPosToText Method
Syntax
Pascal
class function CellPosToText(ARow: Cardinal; ACol: Cardinal): string;
Description

Converts a FPSpreadsheet cell position, which is Row, Col in numbers and zero based - e.g. 0,0 - to a textual representation which is [Col][Row], where the Col is in letters and the row is in 1-based numbers - e.g. A1

Group

TsWorksheet Methods


TsWorksheet.CellUsedInFormula Method

TsWorksheet.CellUsedInFormula Method
Syntax
Pascal
function CellUsedInFormula(ARow: Cardinal; ACol: Cardinal): Boolean;
Parameters
Parameters | Description
ARow: Cardinal | Row index of the cell considered
ACol: Cardinal | Column index of the cell considered
Returns

TRUE if the cell is used in a formula, FALSE if not

Description

Checks entire workbook, whether this cell is used in any formula.

Group

TsWorksheet Methods


TsWorksheet.ChangedCell Method

TsWorksheet.ChangedCell Method
Syntax
Pascal
procedure ChangedCell(ARow: Cardinal; ACol: Cardinal);
Parameters
Parameters | Description
ARow: Cardinal | Row index of the cell which has been changed
ACol: Cardinal | Column index of the cell which has been changed
Description

Is called whenever a cell value or formatting has changed. Fires an event "OnChangeCell". This is handled by TsWorksheetGrid to update the grid cell.

Group

TsWorksheet Methods


TsWorksheet.ChangedFont Method

TsWorksheet.ChangedFont Method
Syntax
Pascal
procedure ChangedFont(ARow: Cardinal; ACol: Cardinal);
Parameters
Parameters | Description
ARow: Cardinal | Row index of the cell for which the font height has changed
ACol: Cardinal | Column index of the cell for which the font height has changed.
Description

Is called whenever a font height changes. Fires an even "OnChangeFont" which is handled by TsWorksheetGrid to update the row heights.

Group

TsWorksheet Methods


TsWorksheet.ClearSelection Method

TsWorksheet.ClearSelection Method
Syntax
Pascal
procedure ClearSelection;
Description

Clears the list of seleccted cell ranges Only needed by the visual controls.

Group

TsWorksheet Methods


TsWorksheet.ConvertFormulaDialect Method

TsWorksheet.ConvertFormulaDialect Method
Syntax
Pascal
function ConvertFormulaDialect(ACell: PCell; ADialect: TsFormulaDialect): String;
Group

TsWorksheet Methods


TsWorksheet.ConvertRPNFormulaToStringFormula Method

TsWorksheet.ConvertRPNFormulaToStringFormula Method
Syntax
Pascal
function ConvertRPNFormulaToStringFormula(const AFormula: TsRPNFormula): String;
Parameters
Parameters | Description
const AFormula: TsRPNFormula | Array of rpn formula tokens
Returns

Formula string in Excel syntax (without leading "=")

Description

Converts an RPN formula (as read from an xls biff file, for example) to a string formula.

Group

TsWorksheet Methods


CopyCell Method

CopyCell Method

This is the overview for the CopyCell method overload.

Overload List
Name | Description
TsWorksheet.CopyCell (Cardinal, Cardinal, Cardinal, Cardinal, TsWorksheet) | Copies a cell. The source cell can be located in a different worksheet, while the destination cell must be in the same worksheet which calls the methode.
TsWorksheet.CopyCell (PCell, PCell) | Copies a cell to a cell at another location. The new cell has the same values and the same formatting. It differs in formula (adapted relative references) and col/row indexes.
Group

TsWorksheet Methods


TsWorksheet.CopyCell Method (Cardinal, Cardinal, Cardinal, Cardinal, TsWorksheet)

TsWorksheet.CopyCell Method (Cardinal, Cardinal, Cardinal, Cardinal, TsWorksheet)
Syntax
Pascal
procedure CopyCell(AFromRow: Cardinal; AFromCol: Cardinal; AToRow: Cardinal; AToCol: Cardinal; AFromWorksheet: TsWorksheet = nil); overload;
Parameters
Parameters | Description
AFromRow: Cardinal | Row index of the source cell
AFromCol: Cardinal | Column index of the source cell
AToRow: Cardinal | Row index of the destination cell
AToCol: Cardinal | Column index of the destination cell
AFromWorksheet: TsWorksheet = nil | Worksheet containing the source cell. Self, if omitted.
Description

Copies a cell. The source cell can be located in a different worksheet, while the destination cell must be in the same worksheet which calls the methode.

Group

CopyCell Method


TsWorksheet.CopyCell Method (PCell, PCell)

TsWorksheet.CopyCell Method (PCell, PCell)
Syntax
Pascal
procedure CopyCell(AFromCell: PCell; AToCell: PCell); overload;
Parameters
Parameters | Description
FromCell | Pointer to the source cell which will be copied
ToCell | Pointer to the destination cell
Description

Copies a cell to a cell at another location. The new cell has the same values and the same formatting. It differs in formula (adapted relative references) and col/row indexes.

Group

CopyCell Method


CopyFormat Method

CopyFormat Method

This is the overview for the CopyFormat method overload.

Overload List
Name | Description
TsWorksheet.CopyFormat (PCell, Cardinal, Cardinal) | Copies all format parameters from a given cell to another cell identified by its row/column indexes.
TsWorksheet.CopyFormat (PCell, PCell) | Copies all format parameters from the format cell to another cell.
Group

TsWorksheet Methods


TsWorksheet.CopyFormat Method (PCell, Cardinal, Cardinal)

TsWorksheet.CopyFormat Method (PCell, Cardinal, Cardinal)
Syntax
Pascal
procedure CopyFormat(AFormatCell: PCell; AToRow: Cardinal; AToCol: Cardinal); overload;
Parameters
Parameters | Description
AFormatCell: PCell | Pointer to the source cell from which the format is copied.
AToRow: Cardinal | Row index of the destination cell
AToCol: Cardinal | Column index of the destination cell
Description

Copies all format parameters from a given cell to another cell identified by its row/column indexes.

Group

CopyFormat Method


TsWorksheet.CopyFormat Method (PCell, PCell)

TsWorksheet.CopyFormat Method (PCell, PCell)
Syntax
Pascal
procedure CopyFormat(AFromCell: PCell; AToCell: PCell); overload;
Parameters
Parameters | Description
AFromCell: PCell | Pointer to source cell
AToCell: PCell | Pointer to destination cell
Description

Copies all format parameters from the format cell to another cell.

Group

CopyFormat Method


CopyFormula Method

CopyFormula Method

This is the overview for the CopyFormula method overload.

Overload List
Name | Description
TsWorksheet.CopyFormula (PCell, Cardinal, Cardinal) | Copies the formula of a specified cell to another cell given by its row and column index. Relative cell references are adapted to the new cell.
TsWorksheet.CopyFormula (PCell, PCell) | Copies the formula of a specified cell to another cell. Adapts relative cell references to the new cell.
Group

TsWorksheet Methods


TsWorksheet.CopyFormula Method (PCell, Cardinal, Cardinal)

TsWorksheet.CopyFormula Method (PCell, Cardinal, Cardinal)
Syntax
Pascal
procedure CopyFormula(AFormulaCell: PCell; AToRow: Cardinal; AToCol: Cardinal); overload;
Parameters
Parameters | Description
AToRow: Cardinal | Row index of the destination cell
AToCol: Cardinal | Column index of the destination cell
AFormatCell | Pointer to the source cell containing the formula to be copied
Description

Copies the formula of a specified cell to another cell given by its row and column index. Relative cell references are adapted to the new cell.

Group

CopyFormula Method


TsWorksheet.CopyFormula Method (PCell, PCell)

TsWorksheet.CopyFormula Method (PCell, PCell)
Syntax
Pascal
procedure CopyFormula(AFromCell: PCell; AToCell: PCell); overload;
Parameters
Parameters | Description
AFromCell: PCell | Pointer to the source cell from which the formula is to be copied
AToCell: PCell | Pointer to the destination cell
Description

Copies the formula of a specified cell to another cell. Adapts relative cell references to the new cell.

Group

CopyFormula Method


CopyValue Method

CopyValue Method

This is the overview for the CopyValue method overload.

Overload List
Name | Description
TsWorksheet.CopyValue (PCell, Cardinal, Cardinal) | Copies the value of a specified cell to another cell given by its row and column index
TsWorksheet.CopyValue (PCell, PCell) | Copies the value of a specified cell to another cell (without copying formulas or formats)
Group

TsWorksheet Methods


TsWorksheet.CopyValue Method (PCell, Cardinal, Cardinal)

TsWorksheet.CopyValue Method (PCell, Cardinal, Cardinal)
Syntax
Pascal
procedure CopyValue(AValueCell: PCell; AToRow: Cardinal; AToCol: Cardinal); overload;
Parameters
Parameters | Description
AValueCell: PCell | Pointer to the cell containing the value to be copied
AToRow: Cardinal | Row index of the destination cell
AToCol: Cardinal | Column index of the destination cell
Description

Copies the value of a specified cell to another cell given by its row and column index

Group

CopyValue Method


TsWorksheet.CopyValue Method (PCell, PCell)

TsWorksheet.CopyValue Method (PCell, PCell)
Syntax
Pascal
procedure CopyValue(AFromCell: PCell; AToCell: PCell); overload;
Parameters
Parameters | Description
AFromCell: PCell | Pointer to the source cell providing the value to be copied
AToCell: PCell | Pointer to the destination cell
Description

Copies the value of a specified cell to another cell (without copying formulas or formats)

Group

CopyValue Method


TsWorksheet.DeleteCell Method

TsWorksheet.DeleteCell Method
Syntax
Pascal
procedure DeleteCell(ACell: PCell);
Description

Deletes a specified cell. If the cell belongs to a merged block its content and formatting is erased. Otherwise the cell is destroyed and its memory is released.

Group

TsWorksheet Methods


TsWorksheet.DeleteCol Method

TsWorksheet.DeleteCol Method
Syntax
Pascal
procedure DeleteCol(ACol: Cardinal);
Parameters
Parameters | Description
ACol: Cardinal | Index of the column to be deleted
Description

Deletes the column at the index specified. Cells with greader column indexes are moved one column to the left. Merged cell blocks and cell references in formulas are considered as well.

Group

TsWorksheet Methods


TsWorksheet.DeleteRichTextParams Method

TsWorksheet.DeleteRichTextParams Method
Syntax
Pascal
procedure DeleteRichTextParams(ACell: PCell);
Description

Removes any previously assigned richtext parameters from a specific cell. This action fully restores the font of the cell.

Group

TsWorksheet Methods


TsWorksheet.DeleteRow Method

TsWorksheet.DeleteRow Method
Syntax
Pascal
procedure DeleteRow(ARow: Cardinal);
Parameters
Parameters | Description
ARow: Cardinal | Index of the row to be deleted
Description

Deletes the row at the index specified. Cells with greader row indexes are moved one row up. Merged cell blocks and cell references in formulas are considered as well.

Group

TsWorksheet Methods


TsWorksheet.DeleteSelection Method

TsWorksheet.DeleteSelection Method
Syntax
Pascal
procedure DeleteSelection;
Description

Deletes all selected cells (delete = make them empty)

Group

TsWorksheet Methods


TsWorksheet.DoCompareCells Method

TsWorksheet.DoCompareCells Method
Syntax
Pascal
function DoCompareCells(ARow1: Cardinal; ACol1: Cardinal; ARow2: Cardinal; ACol2: Cardinal; ASortOptions: TsSortOptions): Integer;
Parameters
Parameters | Description
ARow1: Cardinal | Row index of the first cell to be compared
ACol1: Cardinal | Column index of the first cell to be compared
ARow2: Cardinal | Row index of the second cell to be compared parem ACol2 Column index of the second cell to be compared
ASortOptions: TsSortOptions | Sorting options: case-insensitive and/or descending
Returns

-1 if the first cell is "smaller", i.e. is sorted in front of the second one +1 if the first cell is "larger", i.e. is behind the second one 0 if both cells are equal

Description

Compare function for sorting of rows and columns called directly by Sort() The compare algorithm starts with the first key parameters. If cells are found to be "equal" the next parameter is set is used until a difference is found, or all parameters are used.

Group

TsWorksheet Methods


TsWorksheet.DoExchangeColRow Method

TsWorksheet.DoExchangeColRow Method
Syntax
Pascal
procedure DoExchangeColRow(AIsColumn: Boolean; AIndex: Cardinal; WithIndex: Cardinal; AFromIndex: Cardinal; AToIndex: Cardinal);
Parameters
Parameters | Description
AIsColumn: Boolean | if true the exchange is done for columns, otherwise for rows
AIndex: Cardinal | Index of the column (if AIsColumn is true) or the row (if AIsColumn is false) which is to be exchanged with the one having index "WidthIndex"
WithIndex: Cardinal | Index of the column (if AIsColumn is true) or the row (if AIsColumn is false) with which "AIndex" is to be replaced.
AFromIndex: Cardinal | First row (if AIsColumn is true) or column (if AIsColumn is false) which is affected by the exchange
AToIndex: Cardinal | Last row (if AIsColumn is true) or column (if AsColumn is false) which is affected by the exchange
Description

Exchanges columns or rows, depending on value of "AIsColumn"

Group

TsWorksheet Methods


TsWorksheet.DoInternalCompareCells Method

TsWorksheet.DoInternalCompareCells Method
Syntax
Pascal
function DoInternalCompareCells(ACell1: PCell; ACell2: PCell; ASortOptions: TsSortOptions): Integer;
Parameters
Parameters | Description
ACell1: PCell | Pointer to the first cell of the comparison
ACell2: PCell | Pointer to the second cell of the comparison
ASortOptions: TsSortOptions | Options for sorting: descending and/or case-insensitive
Returns

-1 if the first cell is "smaller" +1 if the first cell is "larger", 0 if both cells are "equal"

Date/time and boolean cells are sorted like number cells according to their number value Label cells are sorted as UTF8 strings.

In case of mixed cell content types the order is determined by the parameter Priority of the SortParams. Empty cells are always at the end (in both ascending and descending order)

Description

Compare function for sorting of rows and columns. Called by DoCompareCells.

Group

TsWorksheet Methods


TsWorksheet.EraseCell Method

TsWorksheet.EraseCell Method
Syntax
Pascal
procedure EraseCell(ACell: PCell);
Parameters
Parameters | Description
ACell: PCell | Pointer to cell to be erased.
Description

Erases content and formatting of a cell. The cell still occupies memory.

Group

TsWorksheet Methods


TsWorksheet.ExchangeCells Method

TsWorksheet.ExchangeCells Method
Syntax
Pascal
procedure ExchangeCells(ARow1: Cardinal; ACol1: Cardinal; ARow2: Cardinal; ACol2: Cardinal);
Parameters
Parameters | Description
ARow1: Cardinal | Row index of the first cell
ACol1: Cardinal | Column index of the first cell
ARow2: Cardinal | Row index of the second cell
ACol2: Cardinal | Column index of the second cell note This method does not take care of merged cells and does not check for this situation. Therefore, the method is not public!
Description

Exchanges two cells

Group

TsWorksheet Methods


FindCell Method

FindCell Method

This is the overview for the FindCell method overload.

Overload List
Name | Description
TsWorksheet.FindCell (Cardinal, Cardinal) | Tries to locate a Cell in the list of already written Cells
TsWorksheet.FindCell (String) | Tries to locate a cell in the list of already written cells
Group

TsWorksheet Methods


TsWorksheet.FindCell Method (Cardinal, Cardinal)

TsWorksheet.FindCell Method (Cardinal, Cardinal)
Syntax
Pascal
function FindCell(ARow: Cardinal; ACol: Cardinal): PCell; overload;
Parameters
Parameters | Description
ARow: Cardinal | The row of the cell
ACol: Cardinal | The column of the cell
Returns

Pointer to the cell if found, or nil if not found

Description

Tries to locate a Cell in the list of already written Cells

See Also

TCell

Group

FindCell Method


TsWorksheet.FindCell Method (String)

TsWorksheet.FindCell Method (String)
Syntax
Pascal
function FindCell(AddressStr: String): PCell; overload;
Parameters
Parameters | Description
AddressStr: String | Address of the cell in Excel A1 notation
Returns

Pointer to the cell if found, or nil if not found

Description

Tries to locate a cell in the list of already written cells

See Also

TCell

Group

FindCell Method


TsWorksheet.FindCol Method

TsWorksheet.FindCol Method
Syntax
Pascal
function FindCol(ACol: Cardinal): PCol;
Parameters
Parameters | Description
ACol: Cardinal | Index of the column looked for
Returns

Pointer to the column record with this column index, or nil if not found

Description

Checks if a column record exists for the given column index and returns a pointer to the TCol record, or nil if not found

Group

TsWorksheet Methods


TsWorksheet.FindComment Method

TsWorksheet.FindComment Method
Syntax
Pascal
function FindComment(ACell: PCell): PsComment;
Parameters
Parameters | Description
ACell: PCell | Pointer to the cell
Returns

Pointer to the TsComment record (nil, if the cell does not have a comment)

Description

Checks whether a cell contains a comment and returns a pointer to the comment data.

Group

TsWorksheet Methods


TsWorksheet.FindHyperlink Method

TsWorksheet.FindHyperlink Method
Syntax
Pascal
function FindHyperlink(ACell: PCell): PsHyperlink;
Parameters
Parameters | Description
ACell: PCell | Pointer to the cell
Returns

Pointer to the TsHyperlink record, or NIL if the cell does not contain a hyperlink.

Description

Checks whether the specified cell contains a hyperlink and returns a pointer to the hyperlink data.

Group

TsWorksheet Methods


TsWorksheet.FindMergeBase Method

TsWorksheet.FindMergeBase Method
Syntax
Pascal
function FindMergeBase(ACell: PCell): PCell;
Parameters
Parameters | Description
ACell: PCell | Cell under investigation
Returns

A pointer to the cell in the upper left corner of the merged block to which ACell belongs. If ACell is isolated then the function returns nil.

Description

Finds the upper left cell of a merged block to which a specified cell belongs. This is the "merge base". Returns nil if the cell is not merged.

Group

TsWorksheet Methods


TsWorksheet.FindMergedRange Method

TsWorksheet.FindMergedRange Method
Syntax
Pascal
function FindMergedRange(ACell: PCell; out ARow1: Cardinal; out ACol1: Cardinal; out ARow2: Cardinal; out ACol2: Cardinal): Boolean;
Parameters
Parameters | Description
ACell: PCell | Pointer to the cell being investigated
out ARow1: Cardinal | (output) Top row index of the merged block
out ACol1: Cardinal | (outout) Left column index of the merged block
out ARow2: Cardinal | (output) Bottom row index of the merged block
out ACol2: Cardinal | (output) Right column index of the merged block
Returns

True if the cell belongs to a merged block, False if not, or if the cell does not exist at all.

Description

Determines the merged cell block to which a particular cell belongs

Group

TsWorksheet Methods


TsWorksheet.FindNextCellInCol Method

TsWorksheet.FindNextCellInCol Method
Syntax
Pascal
function FindNextCellInCol(ARow: Cardinal; ACol: Cardinal): PCell;
Group

TsWorksheet Methods


TsWorksheet.FindNextCellInRow Method

TsWorksheet.FindNextCellInRow Method
Syntax
Pascal
function FindNextCellInRow(ARow: Cardinal; ACol: Cardinal): PCell;
Group

TsWorksheet Methods


TsWorksheet.FindPrevCellInCol Method

TsWorksheet.FindPrevCellInCol Method
Syntax
Pascal
function FindPrevCellInCol(ARow: Cardinal; ACol: Cardinal): PCell;
Group

TsWorksheet Methods


TsWorksheet.FindPrevCellInRow Method

TsWorksheet.FindPrevCellInRow Method
Syntax
Pascal
function FindPrevCellInRow(ARow: Cardinal; ACol: Cardinal): PCell;
Group

TsWorksheet Methods


TsWorksheet.FindRow Method

TsWorksheet.FindRow Method
Syntax
Pascal
function FindRow(ARow: Cardinal): PRow;
Parameters
Parameters | Description
ARow: Cardinal | Index of the row looked for
Returns

Pointer to the row record with this row index, or nil if not found

Description

Checks if a row record exists for the given row index and returns a pointer to the row record, or nil if not found

Group

TsWorksheet Methods


TsWorksheet.GetCalcState Method

TsWorksheet.GetCalcState Method
Syntax
Pascal
function GetCalcState(ACell: PCell): TsCalcState;
Parameters
Parameters | Description
ACell: PCell | Pointer to cell considered
Returns

Enumerated value of the cell's calculation state (csNotCalculated, csCalculating, csCalculated)

Description

Returns the CalcState flag of the specified cell. This flag tells whether a formula in the cell has not yet been calculated (csNotCalculated), is currently being calculated (csCalculating), or has already been calculated (csCalculated.

Group

TsWorksheet Methods


GetCell Method

GetCell Method

This is the overview for the GetCell method overload.

Overload List
Name | Description
TsWorksheet.GetCell (Cardinal, Cardinal) | Obtains an allocated cell at the desired location. If the cell already exists, a pointer to it will be returned. If not, then new memory for the cell will be allocated, a pointer to it will be returned and it will be added to the list of cells.
TsWorksheet.GetCell (String) | Obtains an allocated cell at the desired location. If the Cell already exists, a pointer to it will be returned. If not, then new memory for the cell will be allocated, a pointer to it will be returned and it will be added to the list of cells.
Group

TsWorksheet Methods


TsWorksheet.GetCell Method (Cardinal, Cardinal)

TsWorksheet.GetCell Method (Cardinal, Cardinal)
Syntax
Pascal
function GetCell(ARow: Cardinal; ACol: Cardinal): PCell; overload;
Parameters
Parameters | Description
ARow: Cardinal | Row index of the cell
ACol: Cardinal | Column index of the cell
Returns

A pointer to the cell at the desired location.

Description

Obtains an allocated cell at the desired location.

If the cell already exists, a pointer to it will be returned.

If not, then new memory for the cell will be allocated, a pointer to it will be returned and it will be added to the list of cells.

See Also

TCell

Group

GetCell Method


TsWorksheet.GetCell Method (String)

TsWorksheet.GetCell Method (String)
Syntax
Pascal
function GetCell(AddressStr: String): PCell; overload;
Parameters
Parameters | Description
AddressStr: String | Address of the cell in Excel A1 notation (an exception is raised in case on an invalid cell address).
Returns

A pointer to the cell at the desired location.

Description

Obtains an allocated cell at the desired location.

If the Cell already exists, a pointer to it will be returned.

If not, then new memory for the cell will be allocated, a pointer to it will be returned and it will be added to the list of cells.

See Also

TCell

Group

GetCell Method


TsWorksheet.GetCellCount Method

TsWorksheet.GetCellCount Method
Syntax
Pascal
function GetCellCount: Cardinal;
Returns

The number of cells with contents in the worksheet

Description

Returns the number of cells in the worksheet with contents.

Group

TsWorksheet Methods


TsWorksheet.GetCellCountInCol Method

TsWorksheet.GetCellCountInCol Method
Syntax
Pascal
function GetCellCountInCol(ACol: Cardinal): Cardinal;
Parameters
Parameters | Description
ACol: Cardinal | Index of the column considered
Returns

Count of cells with value or format in this column

Description

Counts how many cells exist in the given column. Blank cells do contribute to the sum, as well as formatted cells.

Group

TsWorksheet Methods


TsWorksheet.GetCellCountInRow Method

TsWorksheet.GetCellCountInRow Method
Syntax
Pascal
function GetCellCountInRow(ARow: Cardinal): Cardinal;
Parameters
Parameters | Description
ARow: Cardinal | Index of the row considered
Returns

Count of cells with value or format in this row

Description

Counts how many cells exist in the given row. Blank cells do contribute to the sum, as well as formatted cell.s

Group

TsWorksheet Methods


TsWorksheet.GetCol Method

TsWorksheet.GetCol Method
Syntax
Pascal
function GetCol(ACol: Cardinal): PCol;
Parameters
Parameters | Description
ACol: Cardinal | Index of the column looked for
Returns

Pointer to the TCol record with this column index. It can safely be assumed that this column record exists.

Description

Checks if a column record exists for the given column index and creates it if not found.

Group

TsWorksheet Methods


TsWorksheet.GetColWidth Method

TsWorksheet.GetColWidth Method
Syntax
Pascal
function GetColWidth(ACol: Cardinal): Single;
Parameters
Parameters | Description
ACol: Cardinal | Index of the column considered
Returns

Width of the column (in count of "0" characters of the default font)

Description

Returns the width of the given column. If there is no column record then the default column width is returned.

Group

TsWorksheet Methods


TsWorksheet.GetDisplayedDecimals Method

TsWorksheet.GetDisplayedDecimals Method
Syntax
Pascal
function GetDisplayedDecimals(ACell: PCell): Byte;
Parameters
Parameters | Description
ACell: PCell | Pointer to the cell under investigation
Returns

Number of decimals places used in the string display of the cell.

Description

Determines the number of decimals displayed for the number in the cell

Group

TsWorksheet Methods


TsWorksheet.GetFirstColIndex Method

TsWorksheet.GetFirstColIndex Method
Syntax
Pascal
function GetFirstColIndex(AForceCalculation: Boolean = false): Cardinal;
Parameters
Parameters | Description
AForceCalculation: Boolean = false | The index of the first column is continuously updated whenever a new cell is created. If AForceCalculation is true all cells are scanned to determine the index of the first column.
Description

Returns the 0-based index of the first column with a cell with contents.

If no cells have contents, zero will be returned, which is also a valid value.

Use GetCellCount to verify if there is at least one cell with contents in the worksheet.

See Also

GetCellCount

Group

TsWorksheet Methods


TsWorksheet.GetFirstRowIndex Method

TsWorksheet.GetFirstRowIndex Method
Syntax
Pascal
function GetFirstRowIndex(AForceCalculation: Boolean = false): Cardinal;
Parameters
Parameters | Description
AForceCalculation: Boolean = false | The index of the first row is continuously updated whenever a new cell is created. If AForceCalculation is true all cells are scanned to determine the index of the first row.
Description

Returns the 0-based index of the first row with a cell with data or formatting. If no cells have contents, -1 will be returned.

See Also

GetCellCount

Group

TsWorksheet Methods


TsWorksheet.GetImage Method

TsWorksheet.GetImage Method
Syntax
Pascal
function GetImage(AIndex: Integer): TsImage;
Parameters
Parameters | Description
AIndex: Integer | Index of the image to be retrieved
Returns

TsImage record with all image parameters.

Description

Returns the parameters of the image stored in the internal image list at the specified index.

Group

TsWorksheet Methods


TsWorksheet.GetImageCount Method

TsWorksheet.GetImageCount Method
Syntax
Pascal
function GetImageCount: Integer;
Description

Returns the count of images that are embedded into this sheet.

Group

TsWorksheet Methods


TsWorksheet.GetLastColIndex Method

TsWorksheet.GetLastColIndex Method
Syntax
Pascal
function GetLastColIndex(AForceCalculation: Boolean = false): Cardinal;
Parameters
Parameters | Description
AForceCalculation: Boolean = false | The index of the last column is continuously updated whenever a new cell is created. If AForceCalculation is true all cells are scanned to determine the index of the last column.
Description

Returns the 0-based index of the last column containing a cell with a column record (due to content or formatting), or containing a Col record.

If no cells have contents or there are no column records, zero will be returned, which is also a valid value.

Use GetCellCount to verify if there is at least one cell with contents in the worksheet.

See Also

GetCellCount, GetLastOccupiedColIndex

Group

TsWorksheet Methods


TsWorksheet.GetLastColNumber Method

TsWorksheet.GetLastColNumber Method
Syntax
Pascal
function GetLastColNumber: Cardinal; deprecated;
Description

Deprecated, use GetLastColIndex instead

See Also

GetLastColIndex

Group

TsWorksheet Methods


TsWorksheet.GetLastOccupiedColIndex Method

TsWorksheet.GetLastOccupiedColIndex Method
Syntax
Pascal
function GetLastOccupiedColIndex: Cardinal;
Description

Returns the 0-based index of the last column with a cell with contents. If no cells have contents, zero will be returned, which is also a valid value.

Use GetCellCount to verify if there is at least one cell with contents in the worksheet.

See Also

GetCellCount, GetLastColIndex

Group

TsWorksheet Methods


TsWorksheet.GetLastOccupiedRowIndex Method

TsWorksheet.GetLastOccupiedRowIndex Method
Syntax
Pascal
function GetLastOccupiedRowIndex: Cardinal;
Description

Returns the 0-based index of the last row with a cell with contents. If no cells have contents, zero will be returned, which is also a valid value.

Use GetCellCount to verify if there is at least one cell with contents in the worksheet.

See Also

GetCellCount, GetLastRowIndex

Group

TsWorksheet Methods


TsWorksheet.GetLastRowIndex Method

TsWorksheet.GetLastRowIndex Method
Syntax
Pascal
function GetLastRowIndex(AForceCalculation: Boolean = false): Cardinal;
Parameters
Parameters | Description
AForceCalculation: Boolean = false | The index of the last row is continuously updated whenever a new cell is created. If AForceCalculation is true all cells are scanned to determine the index of the last row.
Description

Returns the 0-based index of the last row with a cell with contents or with a ROW record.

If no cells have contents, zero will be returned, which is also a valid value.

Use GetCellCount to verify if there is at least one cell with contents in the worksheet.

See Also

GetCellCount, GetLastOccupiedRowIndex

Group

TsWorksheet Methods


TsWorksheet.GetLastRowNumber Method

TsWorksheet.GetLastRowNumber Method
Syntax
Pascal
function GetLastRowNumber: Cardinal; deprecated;
Description

Deprecated, use GetLastColIndex instead

See Also

GetLastColIndex

Group

TsWorksheet Methods


TsWorksheet.GetNumberFormatAttributes Method

TsWorksheet.GetNumberFormatAttributes Method
Syntax
Pascal
function GetNumberFormatAttributes(ACell: PCell; out ADecimals: Byte; out ACurrencySymbol: String): Boolean;
Group

TsWorksheet Methods


TsWorksheet.GetRow Method

TsWorksheet.GetRow Method
Syntax
Pascal
function GetRow(ARow: Cardinal): PRow;
Parameters
Parameters | Description
ARow: Cardinal | Index of the row looked for
Returns

Pointer to the row record with this row index. It can safely be assumed that this row record exists.

Description

Checks if a row record exists for the given row index and creates it if not found.

Group

TsWorksheet Methods


TsWorksheet.GetRowHeight Method

TsWorksheet.GetRowHeight Method
Syntax
Pascal
function GetRowHeight(ARow: Cardinal): Single;
Parameters
Parameters | Description
ARow: Cardinal | Index of the row considered
Returns

Height of the row (in line count of the default font).

Description

Returns the height of the given row. If there is no row record then the default row height is returned

Group

TsWorksheet Methods


TsWorksheet.GetSelection Method

TsWorksheet.GetSelection Method
Syntax
Pascal
function GetSelection: TsCellRangeArray;
Description

Returns the list of selected cell ranges

Group

TsWorksheet Methods


TsWorksheet.GetSelectionAsString Method

TsWorksheet.GetSelectionAsString Method
Syntax
Pascal
function GetSelectionAsString: String;
Description

Returns all selection ranges as an Excel string

Group

TsWorksheet Methods


TsWorksheet.GetSelectionCount Method

TsWorksheet.GetSelectionCount Method
Syntax
Pascal
function GetSelectionCount: Integer;
Description

Returns the number of selected cell ranges

Group

TsWorksheet Methods


TsWorksheet.GetSelectionRangeIndexOfActiveCell Method

TsWorksheet.GetSelectionRangeIndexOfActiveCell Method
Syntax
Pascal
function GetSelectionRangeIndexOfActiveCell: Integer;
Description

Returns the index of the selected block which contains the active cell

Group

TsWorksheet Methods


TsWorksheet.HasComment Method

TsWorksheet.HasComment Method
Syntax
Pascal
function HasComment(ACell: PCell): Boolean;
Description

Checks whether a specific cell contains a comment

Group

TsWorksheet Methods


TsWorksheet.HasHyperlink Method

TsWorksheet.HasHyperlink Method
Syntax
Pascal
function HasHyperlink(ACell: PCell): Boolean;
Description

Checks whether the specified cell contains a hyperlink

Group

TsWorksheet Methods


TsWorksheet.InSameMergedRange Method

TsWorksheet.InSameMergedRange Method
Syntax
Pascal
function InSameMergedRange(ACell1: PCell; ACell2: PCell): Boolean;
Parameters
Parameters | Description
ACell1: PCell | Pointer to the first cell
ACell2: PCell | Pointer to the second cell reult TRUE if both cells belong to the same merged cell block FALSE if the cells are not merged or are in different blocks
Description

Checks whether the two specified cells belong to the same merged cell block.

Group

TsWorksheet Methods


TsWorksheet.InsertCol Method

TsWorksheet.InsertCol Method
Syntax
Pascal
procedure InsertCol(ACol: Cardinal);
Parameters
Parameters | Description
ACol: Cardinal | Index of the column before which a new column is inserted.
Description

Inserts a column BEFORE the index specified. Cells with greater column indexes are moved one column to the right. Merged cell blocks and cell references in formulas are considered as well.

Group

TsWorksheet Methods


TsWorksheet.InsertRow Method

TsWorksheet.InsertRow Method
Syntax
Pascal
procedure InsertRow(ARow: Cardinal);
Parameters
Parameters | Description
ARow: Cardinal | Index of the row before which a new row is inserted.
Description

Inserts a row BEFORE the row specified. Cells with greater row indexes are moved one row down. Merged cell blocks and cell references in formulas are considered as well.

Group

TsWorksheet Methods


TsWorksheet.IsMergeBase Method

TsWorksheet.IsMergeBase Method
Syntax
Pascal
function IsMergeBase(ACell: PCell): Boolean;
Parameters
Parameters | Description
ACell: PCell | Pointer to the cell being considered
Returns

True if the cell is the upper left corner of a merged range False if not

Description

Returns true if the specified cell is the base of a merged cell range, i.e. the upper left corner of that range.

Group

TsWorksheet Methods


TsWorksheet.IsMerged Method

TsWorksheet.IsMerged Method
Syntax
Pascal
function IsMerged(ACell: PCell): Boolean;
Parameters
Parameters | Description
ACell: PCell | Pointer to the cell of interest
Returns

TRUE if the cell belongs to a merged block, FALSE if not.

Description

Returns TRUE if the specified cell belongs to a merged block

Group

TsWorksheet Methods


MergeCells Method

MergeCells Method

This is the overview for the MergeCells method overload.

Overload List
Name | Description
TsWorksheet.MergeCells (Cardinal, Cardinal, Cardinal, Cardinal) | Merges adjacent individual cells to a larger single cell
TsWorksheet.MergeCells (String) | Merges adjacent individual cells to a larger single cell
Group

TsWorksheet Methods


TsWorksheet.MergeCells Method (Cardinal, Cardinal, Cardinal, Cardinal)

TsWorksheet.MergeCells Method (Cardinal, Cardinal, Cardinal, Cardinal)
Syntax
Pascal
procedure MergeCells(ARow1: Cardinal; ACol1: Cardinal; ARow2: Cardinal; ACol2: Cardinal); overload;
Parameters
Parameters | Description
ARow1: Cardinal | Row index of the upper left corner of the cell range
ACol1: Cardinal | Column index of the upper left corner of the cell range
ARow2: Cardinal | Row index of the lower right corner of the cell range
ACol2: Cardinal | Column index of the lower right corner of the cell range
Description

Merges adjacent individual cells to a larger single cell

Group

MergeCells Method


TsWorksheet.MergeCells Method (String)

TsWorksheet.MergeCells Method (String)
Syntax
Pascal
procedure MergeCells(ARange: String); overload;
Parameters
Parameters | Description
ARange: String | Cell range string given in Excel notation (e.g: A1:D5). A non-range string (e.g. A1) is not allowed.
Description

Merges adjacent individual cells to a larger single cell

Group

MergeCells Method


ReadAsDateTime Method

ReadAsDateTime Method

This is the overview for the ReadAsDateTime method overload.

Overload List
Name | Description
TsWorksheet.ReadAsDateTime (Cardinal, Cardinal, TDateTime) | Reads the contents of a cell and returns the date/time value of the cell.
TsWorksheet.ReadAsDateTime (PCell, TDateTime) | Reads the contents of a cell and returns the date/time value of the cell.
Group

TsWorksheet Methods


TsWorksheet.ReadAsDateTime Method (Cardinal, Cardinal, TDateTime)

TsWorksheet.ReadAsDateTime Method (Cardinal, Cardinal, TDateTime)
Syntax
Pascal
function ReadAsDateTime(ARow: Cardinal; ACol: Cardinal; out AResult: TDateTime): Boolean; overload;
Parameters
Parameters | Description
ARow: Cardinal | The row of the cell
ACol: Cardinal | The column of the cell
out AResult: TDateTime | Date/time value of the cell (or 0.0, if no date/time cell)
Returns

True if the cell is a datetime value, false otherwise

Description

Reads the contents of a cell and returns the date/time value of the cell.

Group

ReadAsDateTime Method


TsWorksheet.ReadAsDateTime Method (PCell, TDateTime)

TsWorksheet.ReadAsDateTime Method (PCell, TDateTime)
Syntax
Pascal
function ReadAsDateTime(ACell: PCell; out AResult: TDateTime): Boolean; overload;
Parameters
Parameters | Description
ACell: PCell | Pointer to the cell
out AResult: TDateTime | Date/time value of the cell (or 0.0, if no date/time cell)
Returns

True if the cell is a datetime value, false otherwise

Description

Reads the contents of a cell and returns the date/time value of the cell.

Group

ReadAsDateTime Method


ReadAsNumber Method

ReadAsNumber Method

This is the overview for the ReadAsNumber method overload.

Overload List
Name | Description
TsWorksheet.ReadAsNumber (Cardinal, Cardinal) | Returns the value of a cell as a number. If the cell contains a date/time value its serial value is returned (as FPC TDateTime). If the cell contains a text value it is attempted to convert it to a number. If the cell is empty or its contents cannot be represented as a number the value 0.0 is returned.
TsWorksheet.ReadAsNumber (PCell) | Returns the value of a cell as a number. If the cell contains a date/time value its serial value is returned (as FPC TDateTime). If the cell contains a text value it is attempted to convert it to a number. If the cell is empty or its contents cannot be represented as a number the value 0.0 is returned.
Group

TsWorksheet Methods


TsWorksheet.ReadAsNumber Method (Cardinal, Cardinal)

TsWorksheet.ReadAsNumber Method (Cardinal, Cardinal)
Syntax
Pascal
function ReadAsNumber(ARow: Cardinal; ACol: Cardinal): Double; overload;
Parameters
Parameters | Description
ARow: Cardinal | The row of the cell
ACol: Cardinal | The column of the cell
Returns

Floating-point value representing the cell contents, or 0.0 if cell does not exist or its contents cannot be converted to a number.

Description

Returns the value of a cell as a number.

If the cell contains a date/time value its serial value is returned (as FPC TDateTime).

If the cell contains a text value it is attempted to convert it to a number.

If the cell is empty or its contents cannot be represented as a number the value 0.0 is returned.

Group

ReadAsNumber Method


TsWorksheet.ReadAsNumber Method (PCell)

TsWorksheet.ReadAsNumber Method (PCell)
Syntax
Pascal
function ReadAsNumber(ACell: PCell): Double; overload;
Parameters
Parameters | Description
ACell: PCell | Pointer to the cell
Returns

Floating-point value representing the cell contents, or 0.0 if cell does not exist or its contents cannot be converted to a number.

Description

Returns the value of a cell as a number.

If the cell contains a date/time value its serial value is returned (as FPC TDateTime).

If the cell contains a text value it is attempted to convert it to a number.

If the cell is empty or its contents cannot be represented as a number the value 0.0 is returned.

Group

ReadAsNumber Method


ReadAsText Method

ReadAsText Method

This is the overview for the ReadAsText method overload.

Overload List
Name | Description
TsWorksheet.ReadAsText (Cardinal, Cardinal) | Reads the contents of a cell and returns an user readable text representing the contents of the cell. The resulting string is UTF-8 encoded.
TsWorksheet.ReadAsText (PCell) | Reads the contents of a cell and returns an user readable text representing the contents of the cell. The resulting string is UTF-8 encoded.
TsWorksheet.ReadAsText (PCell, TFormatSettings) | Reads the contents of a cell and returns an user readable text representing the contents of the cell. The resulting string is UTF-8 encoded.
Group

TsWorksheet Methods


TsWorksheet.ReadAsText Method (Cardinal, Cardinal)

TsWorksheet.ReadAsText Method (Cardinal, Cardinal)
Syntax
Pascal
function ReadAsText(ARow: Cardinal; ACol: Cardinal): string; overload;
Parameters
Parameters | Description
ARow: Cardinal | The row of the cell
ACol: Cardinal | The column of the cell
Returns

The text representation of the cell

Description

Reads the contents of a cell and returns an user readable text representing the contents of the cell.

The resulting string is UTF-8 encoded.

Group

ReadAsText Method


TsWorksheet.ReadAsText Method (PCell)

TsWorksheet.ReadAsText Method (PCell)
Syntax
Pascal
function ReadAsText(ACell: PCell): string; overload;
Parameters
Parameters | Description
ACell: PCell | Pointer to the cell
Returns

The text representation of the cell

Description

Reads the contents of a cell and returns an user readable text representing the contents of the cell.

The resulting string is UTF-8 encoded.

Group

ReadAsText Method


TsWorksheet.ReadAsText Method (PCell, TFormatSettings)

TsWorksheet.ReadAsText Method (PCell, TFormatSettings)
Syntax
Pascal
function ReadAsText(ACell: PCell; AFormatSettings: TFormatSettings): string; overload;
Parameters
Parameters | Description
ACell: PCell | Pointer to the cell
AFormatSettings: TFormatSettings | Format settings to be used for string conversion of numbers and date/times.
Returns

The text representation of the cell

Description

Reads the contents of a cell and returns an user readable text representing the contents of the cell.

The resulting string is UTF-8 encoded.

Group

ReadAsText Method


ReadAsUTF8Text Method

ReadAsUTF8Text Method

This is the overview for the ReadAsUTF8Text method overload.

Overload List
Name | Description
TsWorksheet.ReadAsUTF8Text (Cardinal, Cardinal) |
TsWorksheet.ReadAsUTF8Text (PCell) |
TsWorksheet.ReadAsUTF8Text (PCell, TFormatSettings) |
Group

TsWorksheet Methods


TsWorksheet.ReadAsUTF8Text Method (Cardinal, Cardinal)

TsWorksheet.ReadAsUTF8Text Method (Cardinal, Cardinal)
Syntax
Pascal
function ReadAsUTF8Text(ARow: Cardinal; ACol: Cardinal): string; overload; deprecated;
Group

ReadAsUTF8Text Method


TsWorksheet.ReadAsUTF8Text Method (PCell)

TsWorksheet.ReadAsUTF8Text Method (PCell)
Syntax
Pascal
function ReadAsUTF8Text(ACell: PCell): string; overload; deprecated;
Group

ReadAsUTF8Text Method


TsWorksheet.ReadAsUTF8Text Method (PCell, TFormatSettings)

TsWorksheet.ReadAsUTF8Text Method (PCell, TFormatSettings)
Syntax
Pascal
function ReadAsUTF8Text(ACell: PCell; AFormatSettings: TFormatSettings): string; overload; deprecated;
Group

ReadAsUTF8Text Method


TsWorksheet.ReadBackground Method

TsWorksheet.ReadBackground Method
Syntax
Pascal
function ReadBackground(ACell: PCell): TsFillPattern;
Parameters
Parameters | Description
ACell: PCell | Pointer to the cell
Returns

TsFillPattern record (or EMPTY_FILL, if the cell does not have a filled background

Description

Returns the background fill pattern and colors of a cell.

Group

TsWorksheet Methods


TsWorksheet.ReadBackgroundColor Method

TsWorksheet.ReadBackgroundColor Method
Syntax
Pascal
function ReadBackgroundColor(ACell: PCell): TsColor;
Parameters
Parameters | Description
ACell: PCell | Pointer to the cell
Returns

Value containing the rgb bytes in little-endian order

Description

Returns the background color of a cell as rbg value

Group

TsWorksheet Methods


TsWorksheet.ReadBiDiMode Method

TsWorksheet.ReadBiDiMode Method
Syntax
Pascal
function ReadBiDiMode(ACell: PCell): TsBiDiMode;
Description

Returns the BiDi mode of the cell (right-to-left or left-to-right)

Group

TsWorksheet Methods


TsWorksheet.ReadCellBorders Method

TsWorksheet.ReadCellBorders Method
Syntax
Pascal
function ReadCellBorders(ACell: PCell): TsCellBorders;
Description

Determines which borders are drawn around a specific cell

Group

TsWorksheet Methods


TsWorksheet.ReadCellBorderStyle Method

TsWorksheet.ReadCellBorderStyle Method
Syntax
Pascal
function ReadCellBorderStyle(ACell: PCell; ABorder: TsCellBorder): TsCellBorderStyle;
Group

TsWorksheet Methods


TsWorksheet.ReadCellBorderStyles Method

TsWorksheet.ReadCellBorderStyles Method
Syntax
Pascal
function ReadCellBorderStyles(ACell: PCell): TsCellBorderStyles;
Description

Determines which all border styles of a given cell

Group

TsWorksheet Methods


TsWorksheet.ReadCellFont Method

TsWorksheet.ReadCellFont Method
Syntax
Pascal
function ReadCellFont(ACell: PCell): TsFont;
Description

Determines the font used by a specified cell. Returns the workbook's default font if the cell does not exist.

Group

TsWorksheet Methods


TsWorksheet.ReadCellFontIndex Method

TsWorksheet.ReadCellFontIndex Method
Syntax
Pascal
function ReadCellFontIndex(ACell: PCell): Integer;
Description

Determines the index of the font used by a specified cell, referring to the workbooks font list. Returns 0 (the default font index) if the cell does not exist.

Group

TsWorksheet Methods


TsWorksheet.ReadCellFormat Method

TsWorksheet.ReadCellFormat Method
Syntax
Pascal
function ReadCellFormat(ACell: PCell): TsCellFormat;
Description

Returns the format record that is assigned to a specified cell

Group

TsWorksheet Methods


ReadComment Method

ReadComment Method

This is the overview for the ReadComment method overload.

Overload List
Name | Description
TsWorksheet.ReadComment (Cardinal, Cardinal) | Returns the comment text attached to a specific cell
TsWorksheet.ReadComment (PCell) | Returns the comment text attached to a specific cell
Group

TsWorksheet Methods


TsWorksheet.ReadComment Method (Cardinal, Cardinal)

TsWorksheet.ReadComment Method (Cardinal, Cardinal)
Syntax
Pascal
function ReadComment(ARow: Cardinal; ACol: Cardinal): String; overload;
Parameters
Parameters | Description
ARow: Cardinal | (0-based) index to the row
ACol: Cardinal | (0-based) index to the column
Returns

Text assigned to the cell as a comment

Description

Returns the comment text attached to a specific cell

Group

ReadComment Method


TsWorksheet.ReadComment Method (PCell)

TsWorksheet.ReadComment Method (PCell)
Syntax
Pascal
function ReadComment(ACell: PCell): string; overload;
Parameters
Parameters | Description
ACell: PCell | Pointer to the cell
Returns

Text assigned to the cell as a comment

Description

Returns the comment text attached to a specific cell

Group

ReadComment Method


TsWorksheet.ReadFormulaAsString Method

TsWorksheet.ReadFormulaAsString Method
Syntax
Pascal
function ReadFormulaAsString(ACell: PCell; ALocalized: Boolean = false): String;
Parameters
Parameters | Description
ACell: PCell | Pointer to the cell considered
ALocalized: Boolean = false | If true, the formula is returned with decimal and list separators accoding to the workbook's FormatSettings. Otherwise it uses dot and comma, respectively.
Returns

Formula string in Excel syntax (does not contain a leading "=")

Description

If a cell contains a formula (string formula or RPN formula) the formula is returned as a string in Excel syntax.

Group

TsWorksheet Methods


TsWorksheet.ReadHorAlignment Method

TsWorksheet.ReadHorAlignment Method
Syntax
Pascal
function ReadHorAlignment(ACell: PCell): TsHorAlignment;
Description

Returns the horizontal alignment of a specific cell

Group

TsWorksheet Methods


TsWorksheet.ReadHyperlink Method

TsWorksheet.ReadHyperlink Method
Syntax
Pascal
function ReadHyperlink(ACell: PCell): TsHyperlink;
Parameters
Parameters | Description
ACell: PCell | Pointer to the cell considered
Returns

Record with the hyperlink data assigned to the cell. If the cell is not a hyperlink the result field Kind is hkNone.

Description

Reads the hyperlink information of a specified cell.

Group

TsWorksheet Methods


TsWorksheet.ReadNumericValue Method

TsWorksheet.ReadNumericValue Method
Syntax
Pascal
function ReadNumericValue(ACell: PCell; out AValue: Double): Boolean;
Parameters
Parameters | Description
ACell: PCell | Cell to be considered
out AValue: Double | (output) extracted numeric value
Returns

True if conversion to number is successful, otherwise false

Description

Returns to numeric equivalent of the cell contents. This is the NumberValue of a number cell, the DateTimeValue of a date/time cell, the ordinal BoolValue of a boolean cell, or the string converted to a number of a string cell. All other cases return NaN.

Group

TsWorksheet Methods


TsWorksheet.ReadNumFormat Method

TsWorksheet.ReadNumFormat Method
Syntax
Pascal
procedure ReadNumFormat(ACell: PCell; out ANumFormat: TsNumberFormat; out ANumFormatStr: String);
Description

Returns the number format type and format string used in a specific cell

Group

TsWorksheet Methods


TsWorksheet.ReadTextRotation Method

TsWorksheet.ReadTextRotation Method
Syntax
Pascal
function ReadTextRotation(ACell: PCell): TsTextRotation;
Description

Returns the text orientation of a specific cell

Group

TsWorksheet Methods


TsWorksheet.ReadUsedFormatting Method

TsWorksheet.ReadUsedFormatting Method
Syntax
Pascal
function ReadUsedFormatting(ACell: PCell): TsUsedFormattingFields;
Parameters
Parameters | Description
ACell: PCell | Pointer to the cell
Returns

Set of elements used in formatting the cell

Description

Reads the set of used formatting fields of a cell.

Each cell contains a set of "used formatting fields". Formatting is applied only if the corresponding element is contained in the set.

Group

TsWorksheet Methods


TsWorksheet.ReadVertAlignment Method

TsWorksheet.ReadVertAlignment Method
Syntax
Pascal
function ReadVertAlignment(ACell: PCell): TsVertAlignment;
Description

Returns the vertical alignment of a specific cell

Group

TsWorksheet Methods


TsWorksheet.ReadWordwrap Method

TsWorksheet.ReadWordwrap Method
Syntax
Pascal
function ReadWordwrap(ACell: PCell): boolean;
Description

Returns whether a specific cell support word-wrapping.

Group

TsWorksheet Methods


TsWorksheet.RemoveAllCols Method

TsWorksheet.RemoveAllCols Method
Syntax
Pascal
procedure RemoveAllCols;
Description

Removes all column records from the worksheet and frees the occupied memory.

Notes

Cells are retained.

Group

TsWorksheet Methods


TsWorksheet.RemoveAllImages Method

TsWorksheet.RemoveAllImages Method
Syntax
Pascal
procedure RemoveAllImages;
Group

TsWorksheet Methods


TsWorksheet.RemoveAllRows Method

TsWorksheet.RemoveAllRows Method
Syntax
Pascal
procedure RemoveAllRows;
Description

Removes all row records from the worksheet and frees the occupied memory.

Notes

Cells are retained.

Group

TsWorksheet Methods


TsWorksheet.RemoveAndFreeCell Method

TsWorksheet.RemoveAndFreeCell Method
Syntax
Pascal
procedure RemoveAndFreeCell(ARow: Cardinal; ACol: Cardinal);
Parameters
Parameters | Description
ARow: Cardinal | Row index of the cell to be removed
ACol: Cardinal | Column index of the cell to be removed
Description

Removes a cell and releases its memory. If a comment is attached to the cell then it is removed and releaded as well.

Just for internal usage since it does not modify the other cells affected. And it does not change other records depending on the cell (comments, merged ranges etc).

Group

TsWorksheet Methods


TsWorksheet.RemoveCell Method

TsWorksheet.RemoveCell Method
Syntax
Pascal
function RemoveCell(ARow: Cardinal; ACol: Cardinal): PCell;
Parameters
Parameters | Description
ARow: Cardinal | Row index of the cell to be removed
ACol: Cardinal | Column index of the cell to be removed
Returns

Pointer to the cell removed

Description

Removes a cell from its tree container. DOES NOT RELEASE ITS MEMORY!

Group

TsWorksheet Methods


TsWorksheet.RemoveCol Method

TsWorksheet.RemoveCol Method
Syntax
Pascal
procedure RemoveCol(ACol: Cardinal);
Description

Removes a specified column record from the worksheet and frees the occupied memory. This resets its column width to default.

Notes

Cells in that column are retained.

Group

TsWorksheet Methods


TsWorksheet.RemoveComment Method

TsWorksheet.RemoveComment Method
Syntax
Pascal
procedure RemoveComment(ACell: PCell);
Description

Removes the comment from a cell and releases the memory occupied by the node.

Group

TsWorksheet Methods


TsWorksheet.RemoveHyperlink Method

TsWorksheet.RemoveHyperlink Method
Syntax
Pascal
procedure RemoveHyperlink(ACell: PCell);
Description

Removes a hyperlink from the specified cell. Releaes memory occupied by the associated TsHyperlink record. Cell content type is converted to cctUTF8String.

Group

TsWorksheet Methods


TsWorksheet.RemoveImage Method

TsWorksheet.RemoveImage Method
Syntax
Pascal
procedure RemoveImage(AIndex: Integer);
Description

Removes an image from the internal image list. The image is identified by its index. The image stream (stored by the workbook) is retained.

Group

TsWorksheet Methods


TsWorksheet.RemoveRow Method

TsWorksheet.RemoveRow Method
Syntax
Pascal
procedure RemoveRow(ARow: Cardinal);
Description

Removes a specified row record from the worksheet and frees the occupied memory. This resets the its row height to default.

Notes

Cells in that row are retained.

Group

TsWorksheet Methods


TsWorksheet.SelectCell Method

TsWorksheet.SelectCell Method
Syntax
Pascal
procedure SelectCell(ARow: Cardinal; ACol: Cardinal);
Description

Marks a specified cell as "selected". Only needed by the visual controls.

Group

TsWorksheet Methods


TsWorksheet.SetCalcState Method

TsWorksheet.SetCalcState Method
Syntax
Pascal
procedure SetCalcState(ACell: PCell; AValue: TsCalcState);
Parameters
Parameters | Description
ACell: PCell | Pointer to cell considered
AValue: TsCalcState | New value for the calculation state of the cell (csNotCalculated, csCalculating, csCalculated)
Description

Set the CalcState flag of the specified cell. This flag tells whether a formula in the cell has not yet been calculated (csNotCalculated), is currently being calculated (csCalculating), or has already been calculated (csCalculated).

For internal use only!

Group

TsWorksheet Methods


TsWorksheet.SetSelection Method

TsWorksheet.SetSelection Method
Syntax
Pascal
procedure SetSelection(const ASelection: TsCellRangeArray);
Description

Marks an array of cell ranges as "selected". Only needed for visual controls

Group

TsWorksheet Methods


Sort Method

Sort Method

This is the overview for the Sort method overload.

Overload List
Name | Description
TsWorksheet.Sort (TsSortParams, Cardinal, Cardinal, Cardinal, Cardinal) | Sorts a range of cells defined by the cell rectangle from ARowFrom/AColFrom to ARowTo/AColTo according to the parameters specified in ASortParams
TsWorksheet.Sort (TsSortParams, String) | Sorts a range of cells defined by the cell rectangle from ARowFrom/AColFrom to ARowTo/AColTo according to the parameters specified in ASortParams
Group

TsWorksheet Methods


TsWorksheet.Sort Method (TsSortParams, Cardinal, Cardinal, Cardinal, Cardinal)

TsWorksheet.Sort Method (TsSortParams, Cardinal, Cardinal, Cardinal, Cardinal)
Syntax
Pascal
procedure Sort(const ASortParams: TsSortParams; ARowFrom: Cardinal; AColFrom: Cardinal; ARowTo: Cardinal; AColTo: Cardinal); overload;
Parameters
Parameters | Description
const ASortParams: TsSortParams | Set of parameters to define sorting along rows or colums, the sorting key column or row indexes, and the sorting directions
ARowFrom: Cardinal | Top row of the range to be sorted
AColFrom: Cardinal | Left column of the range to be sorted
ARowTo: Cardinal | Last row of the range to be sorted
AColTo: Cardinal | Right column of the range to be sorted
Description

Sorts a range of cells defined by the cell rectangle from ARowFrom/AColFrom to ARowTo/AColTo according to the parameters specified in ASortParams

Group

Sort Method


TsWorksheet.Sort Method (TsSortParams, String)

TsWorksheet.Sort Method (TsSortParams, String)
Syntax
Pascal
procedure Sort(ASortParams: TsSortParams; ARange: String); overload;
Parameters
Parameters | Description
ASortParams: TsSortParams | Set of parameters to define sorting along rows or colums, the sorting key column or row indexes, and the sorting directions
ARange: String | Cell range to be sorted, in Excel notation, such as 'A1:C8'
Description

Sorts a range of cells defined by the cell rectangle from ARowFrom/AColFrom to ARowTo/AColTo according to the parameters specified in ASortParams

Group

Sort Method


UnmergeCells Method

UnmergeCells Method

This is the overview for the UnmergeCells method overload.

Overload List
Name | Description
TsWorksheet.UnmergeCells (Cardinal, Cardinal) | Disconnects merged cells to make them individual cells again. Input parameter is a cell which belongs to the range to be unmerged.
TsWorksheet.UnmergeCells (String) | Disconnects merged cells to make them individual cells again.
Group

TsWorksheet Methods


TsWorksheet.UnmergeCells Method (Cardinal, Cardinal)

TsWorksheet.UnmergeCells Method (Cardinal, Cardinal)
Syntax
Pascal
procedure UnmergeCells(ARow: Cardinal; ACol: Cardinal); overload;
Parameters
Parameters | Description
ARow: Cardinal | Row index of a cell considered to belong to the cell block
ACol: Cardinal | Column index of a cell considered to belong to the cell block
Description

Disconnects merged cells to make them individual cells again.

Input parameter is a cell which belongs to the range to be unmerged.

Group

UnmergeCells Method


TsWorksheet.UnmergeCells Method (String)

TsWorksheet.UnmergeCells Method (String)
Syntax
Pascal
procedure UnmergeCells(ARange: String); overload;
Parameters
Parameters | Description
ARange: String | Cell (range) string given in Excel notation (e.g: A1, or A1:D5) In case of a range string, only the upper left corner cell is considered. It must belong to the merged range of cells to be unmerged.
Description

Disconnects merged cells to make them individual cells again.

Group

UnmergeCells Method


TsWorksheet.UpdateCaches Method

TsWorksheet.UpdateCaches Method
Syntax
Pascal
procedure UpdateCaches;
Description

Helper method to update internal caching variables

Group

TsWorksheet Methods


TsWorksheet.ValidHyperlink Method

TsWorksheet.ValidHyperlink Method
Syntax
Pascal
function ValidHyperlink(AValue: String; out AErrMsg: String): Boolean;
Parameters
Parameters | Description
AValue: String | String to be checked. Must be either a fully qualified URI, a local relative (!) file name, or a # followed by a cell address in the current workbook
out AErrMsg: String | Error message in case that the string is not correct.
Returns

TRUE if the string is correct, FALSE otherwise

Description

Checks whether the passed string represents a valid hyperlink target

Group

TsWorksheet Methods


WriteBackground Method

WriteBackground Method

This is the overview for the WriteBackground method overload.

Overload List
Name | Description
TsWorksheet.WriteBackground (Cardinal, Cardinal, TsFillStyle, TsColor, TsColor) | Defines a background pattern for a cell
TsWorksheet.WriteBackground (PCell, TsFillStyle, TsColor, TsColor) | Defines a background pattern for a cell
Group

TsWorksheet Methods


TsWorksheet.WriteBackground Method (Cardinal, Cardinal, TsFillStyle, TsColor, TsColor)

TsWorksheet.WriteBackground Method (Cardinal, Cardinal, TsFillStyle, TsColor, TsColor)
Syntax
Pascal
function WriteBackground(ARow: Cardinal; ACol: Cardinal; AStyle: TsFillStyle; APatternColor: TsColor = scTransparent; ABackgroundColor: TsColor = scTransparent): PCell; overload;
Parameters
Parameters | Description
ARow: Cardinal | Row index of the cell
ACol: Cardinal | Column index of the cell
APatternColor: TsColor = scTransparent | RGB value of the pattern color
ABackgroundColor: TsColor = scTransparent | RGB value of the background color
AFillStyle | Fill style to be used - see TsFillStyle
Returns

Pointer to cell

NOTE Is replaced by uniform fill if WriteBackgroundColor is called later.

Description

Defines a background pattern for a cell

Group

WriteBackground Method


TsWorksheet.WriteBackground Method (PCell, TsFillStyle, TsColor, TsColor)

TsWorksheet.WriteBackground Method (PCell, TsFillStyle, TsColor, TsColor)
Syntax
Pascal
procedure WriteBackground(ACell: PCell; AStyle: TsFillStyle; APatternColor: TsColor = scTransparent; ABackgroundColor: TsColor = scTransparent); overload;
Parameters
Parameters | Description
ACell: PCell | Pointer to the cell
AStyle: TsFillStyle | Fill style ("pattern") to be used - see TsFillStyle
APatternColor: TsColor = scTransparent | RGB value of the pattern color
ABackgroundColor: TsColor = scTransparent | RGB value of the background color NOTE Is replaced by uniform fill if WriteBackgroundColor is called later.
Description

Defines a background pattern for a cell

Group

WriteBackground Method


WriteBackgroundColor Method

WriteBackgroundColor Method

This is the overview for the WriteBackgroundColor method overload.

Overload List
Name | Description
TsWorksheet.WriteBackgroundColor (Cardinal, Cardinal, TsColor) | Sets a uniform background color of a cell.
TsWorksheet.WriteBackgroundColor (PCell, TsColor) | Sets a uniform background color of a cell.
Group

TsWorksheet Methods


TsWorksheet.WriteBackgroundColor Method (Cardinal, Cardinal, TsColor)

TsWorksheet.WriteBackgroundColor Method (Cardinal, Cardinal, TsColor)
Syntax
Pascal
function WriteBackgroundColor(ARow: Cardinal; ACol: Cardinal; AColor: TsColor): PCell; overload;
Parameters
Parameters | Description
ARow: Cardinal | Row index of the cell
ACol: Cardinal | Column index of the cell
AColor: TsColor | RGB value of the new background color. Use the value "scTransparent" to clear an existing background color.
Returns

Pointer to cell

Description

Sets a uniform background color of a cell.

Group

WriteBackgroundColor Method


TsWorksheet.WriteBackgroundColor Method (PCell, TsColor)

TsWorksheet.WriteBackgroundColor Method (PCell, TsColor)
Syntax
Pascal
procedure WriteBackgroundColor(ACell: PCell; AColor: TsColor); overload;
Parameters
Parameters | Description
ACell: PCell | Pointer to cell
AColor: TsColor | RGB value of the new background color. Use the value "scTransparent" to clear an existing background color.
Description

Sets a uniform background color of a cell.

Group

WriteBackgroundColor Method


WriteBiDiMode Method

WriteBiDiMode Method

This is the overview for the WriteBiDiMode method overload.

Overload List
Name | Description
TsWorksheet.WriteBiDiMode (Cardinal, Cardinal, TsBiDiMode) |
TsWorksheet.WriteBiDiMode (PCell, TsBiDiMode) |
Group

TsWorksheet Methods


TsWorksheet.WriteBiDiMode Method (Cardinal, Cardinal, TsBiDiMode)

TsWorksheet.WriteBiDiMode Method (Cardinal, Cardinal, TsBiDiMode)
Syntax
Pascal
function WriteBiDiMode(ARow: Cardinal; ACol: Cardinal; AValue: TsBiDiMode): PCell; overload;
Group

WriteBiDiMode Method


TsWorksheet.WriteBiDiMode Method (PCell, TsBiDiMode)

TsWorksheet.WriteBiDiMode Method (PCell, TsBiDiMode)
Syntax
Pascal
procedure WriteBiDiMode(ACell: PCell; AValue: TsBiDiMode); overload;
Group

WriteBiDiMode Method


WriteBlank Method

WriteBlank Method

This is the overview for the WriteBlank method overload.

Overload List
Name | Description
TsWorksheet.WriteBlank (Cardinal, Cardinal) | Writes an empty cell
TsWorksheet.WriteBlank (PCell) | Writes an empty cell
Group

TsWorksheet Methods


TsWorksheet.WriteBlank Method (Cardinal, Cardinal)

TsWorksheet.WriteBlank Method (Cardinal, Cardinal)
Syntax
Pascal
function WriteBlank(ARow: Cardinal; ACol: Cardinal): PCell; overload;
Parameters
Parameters | Description
ARow: Cardinal | The row of the cell
ACol: Cardinal | The column of the cell
Returns

Pointer to the cell

Description

Writes an empty cell

Notes

Empty cells are useful when, for example, a border line extends along a range of cells including empty cells.

Group

WriteBlank Method


TsWorksheet.WriteBlank Method (PCell)

TsWorksheet.WriteBlank Method (PCell)
Syntax
Pascal
procedure WriteBlank(ACell: PCell); overload;
Parameters
Parameters | Description
ACel | Pointer to the cell
Description

Writes an empty cell

Notes

Empty cells are useful when, for example, a border line extends along a range of cells including empty cells.

Group

WriteBlank Method


WriteBoolValue Method

WriteBoolValue Method

This is the overview for the WriteBoolValue method overload.

Overload List
Name | Description
TsWorksheet.WriteBoolValue (Cardinal, Cardinal, Boolean) | Writes a boolean cell
TsWorksheet.WriteBoolValue (PCell, Boolean) | Writes a boolean cell
Group

TsWorksheet Methods


TsWorksheet.WriteBoolValue Method (Cardinal, Cardinal, Boolean)

TsWorksheet.WriteBoolValue Method (Cardinal, Cardinal, Boolean)
Syntax
Pascal
function WriteBoolValue(ARow: Cardinal; ACol: Cardinal; AValue: Boolean): PCell; overload;
Parameters
Parameters | Description
ARow: Cardinal | The row of the cell
ACol: Cardinal | The column of the cell
AValue: Boolean | The boolean value
Returns

Pointer to the cell

Description

Writes a boolean cell

Group

WriteBoolValue Method


TsWorksheet.WriteBoolValue Method (PCell, Boolean)

TsWorksheet.WriteBoolValue Method (PCell, Boolean)
Syntax
Pascal
procedure WriteBoolValue(ACell: PCell; AValue: Boolean); overload;
Parameters
Parameters | Description
ACell: PCell | Pointer to the cell
AValue: Boolean | The boolean value
Description

Writes a boolean cell

Group

WriteBoolValue Method


WriteBorderColor Method

WriteBorderColor Method

This is the overview for the WriteBorderColor method overload.

Overload List
Name | Description
TsWorksheet.WriteBorderColor (Cardinal, Cardinal, TsCellBorder, TsColor) | Sets the color of a cell border line.
TsWorksheet.WriteBorderColor (PCell, TsCellBorder, TsColor) | Sets the color of a cell border line.
Group

TsWorksheet Methods


TsWorksheet.WriteBorderColor Method (Cardinal, Cardinal, TsCellBorder, TsColor)

TsWorksheet.WriteBorderColor Method (Cardinal, Cardinal, TsCellBorder, TsColor)
Syntax
Pascal
function WriteBorderColor(ARow: Cardinal; ACol: Cardinal; ABorder: TsCellBorder; AColor: TsColor): PCell; overload;
Parameters
Parameters | Description
ARow: Cardinal | Row index of the cell
ACol: Cardinal | Column index of the cell
ABorder: TsCellBorder | Indicates to which border (left/top etc) this color is to be applied
AColor: TsColor | RGB value of the new border color
Returns

Pointer to cell

Description

Sets the color of a cell border line.

Notes

the border must be included in Borders set in order to be shown!

Group

WriteBorderColor Method


TsWorksheet.WriteBorderColor Method (PCell, TsCellBorder, TsColor)

TsWorksheet.WriteBorderColor Method (PCell, TsCellBorder, TsColor)
Syntax
Pascal
procedure WriteBorderColor(ACell: PCell; ABorder: TsCellBorder; AColor: TsColor); overload;
Parameters
Parameters | Description
ACell: PCell | Pointer to cell
ABorder: TsCellBorder | Indicates to which border (left/top etc) this color is to be applied
AColor: TsColor | RGB value of the new border color
Description

Sets the color of a cell border line.

Notes

the border must be included in Borders set in order to be shown!

Group

WriteBorderColor Method


WriteBorderLineStyle Method

WriteBorderLineStyle Method

This is the overview for the WriteBorderLineStyle method overload.

Overload List
Name | Description
TsWorksheet.WriteBorderLineStyle (Cardinal, Cardinal, TsCellBorder, TsLineStyle) | Sets the linestyle of a cell border.
TsWorksheet.WriteBorderLineStyle (PCell, TsCellBorder, TsLineStyle) | Sets the linestyle of a cell border.
Group

TsWorksheet Methods


TsWorksheet.WriteBorderLineStyle Method (Cardinal, Cardinal, TsCellBorder, TsLineStyle)

TsWorksheet.WriteBorderLineStyle Method (Cardinal, Cardinal, TsCellBorder, TsLineStyle)
Syntax
Pascal
function WriteBorderLineStyle(ARow: Cardinal; ACol: Cardinal; ABorder: TsCellBorder; ALineStyle: TsLineStyle): PCell; overload;
Parameters
Parameters | Description
ARow: Cardinal | Row index of the cell
ACol: Cardinal | Column index of the cell
ABorder: TsCellBorder | Indicates to which border (left/top etc) this color is to be applied
ALineStyle: TsLineStyle | Identifier of the new line style to be applied.
Returns

Pointer to cell

Description

Sets the linestyle of a cell border.

Notes

the border must be included in the "Borders" set in order to be shown!

See Also

TsLineStyle

Group

WriteBorderLineStyle Method


TsWorksheet.WriteBorderLineStyle Method (PCell, TsCellBorder, TsLineStyle)

TsWorksheet.WriteBorderLineStyle Method (PCell, TsCellBorder, TsLineStyle)
Syntax
Pascal
procedure WriteBorderLineStyle(ACell: PCell; ABorder: TsCellBorder; ALineStyle: TsLineStyle); overload;
Parameters
Parameters | Description
ACell: PCell | Pointer to cell
ABorder: TsCellBorder | Indicates to which border (left/top etc) this color is to be applied
ALineStyle: TsLineStyle | Identifier of the new line style to be applied.
Description

Sets the linestyle of a cell border.

Notes

the border must be included in the "Borders" set in order to be shown!

See Also

TsLineStyle

Group

WriteBorderLineStyle Method


WriteBorders Method

WriteBorders Method

This is the overview for the WriteBorders method overload.

Overload List
Name | Description
TsWorksheet.WriteBorders (Cardinal, Cardinal, TsCellBorders) | Shows the cell borders included in the set ABorders. No border lines are drawn for those not included. The borders are drawn using the "BorderStyles" assigned to the cell.
TsWorksheet.WriteBorders (PCell, TsCellBorders) | Shows the cell borders included in the set ABorders. No border lines are drawn for those not included. The borders are drawn using the "BorderStyles" assigned to the cell.
Group

TsWorksheet Methods


TsWorksheet.WriteBorders Method (Cardinal, Cardinal, TsCellBorders)

TsWorksheet.WriteBorders Method (Cardinal, Cardinal, TsCellBorders)
Syntax
Pascal
function WriteBorders(ARow: Cardinal; ACol: Cardinal; ABorders: TsCellBorders): PCell; overload;
Parameters
Parameters | Description
ARow: Cardinal | Row index of the cell
ACol: Cardinal | Column index of the cell
ABorders: TsCellBorders | Set with elements to identify the border(s) to will be shown
Returns

Pointer to cell

Description

Shows the cell borders included in the set ABorders. No border lines are drawn for those not included.

The borders are drawn using the "BorderStyles" assigned to the cell.

See Also

TsCellBorder

Group

WriteBorders Method


TsWorksheet.WriteBorders Method (PCell, TsCellBorders)

TsWorksheet.WriteBorders Method (PCell, TsCellBorders)
Syntax
Pascal
procedure WriteBorders(ACell: PCell; ABorders: TsCellBorders); overload;
Parameters
Parameters | Description
ACell: PCell | Pointer to cell
ABorders: TsCellBorders | Set with elements to identify the border(s) to will be shown
Description

Shows the cell borders included in the set ABorders. No border lines are drawn for those not included.

The borders are drawn using the "BorderStyles" assigned to the cell.

See Also

TsCellBorder

Group

WriteBorders Method


WriteBorderStyle Method

WriteBorderStyle Method

This is the overview for the WriteBorderStyle method overload.

Overload List
Name | Description
TsWorksheet.WriteBorderStyle (Cardinal, Cardinal, TsCellBorder, TsCellBorderStyle) | Sets the style of a cell border, i.e. line style and line color.
TsWorksheet.WriteBorderStyle (Cardinal, Cardinal, TsCellBorder, TsLineStyle, TsColor) |
TsWorksheet.WriteBorderStyle (PCell, TsCellBorder, TsCellBorderStyle) | Sets the style of a cell border, i.e. line style and line color.
TsWorksheet.WriteBorderStyle (PCell, TsCellBorder, TsLineStyle, TsColor) |
Group

TsWorksheet Methods


TsWorksheet.WriteBorderStyle Method (Cardinal, Cardinal, TsCellBorder, TsCellBorderStyle)

TsWorksheet.WriteBorderStyle Method (Cardinal, Cardinal, TsCellBorder, TsCellBorderStyle)
Syntax
Pascal
function WriteBorderStyle(ARow: Cardinal; ACol: Cardinal; ABorder: TsCellBorder; AStyle: TsCellBorderStyle): PCell; overload;
Parameters
Parameters | Description
ARow: Cardinal | Row index of the cell considered
ACol: Cardinal | Column index of the cell considered
ABorder: TsCellBorder | Identifies the border to be modified (left/top/right/bottom)
AStyle: TsCellBorderStyle | record of parameters controlling how the border line is drawn (line style, line color) result Pointer to cell
Description

Sets the style of a cell border, i.e. line style and line color.

Notes

the border must be included in the "Borders" set in order to be shown!

Group

WriteBorderStyle Method


TsWorksheet.WriteBorderStyle Method (Cardinal, Cardinal, TsCellBorder, TsLineStyle, TsColor)

TsWorksheet.WriteBorderStyle Method (Cardinal, Cardinal, TsCellBorder, TsLineStyle, TsColor)
Syntax
Pascal
function WriteBorderStyle(ARow: Cardinal; ACol: Cardinal; ABorder: TsCellBorder; ALineStyle: TsLineStyle; AColor: TsColor): PCell; overload;
Group

WriteBorderStyle Method


TsWorksheet.WriteBorderStyle Method (PCell, TsCellBorder, TsCellBorderStyle)

TsWorksheet.WriteBorderStyle Method (PCell, TsCellBorder, TsCellBorderStyle)
Syntax
Pascal
procedure WriteBorderStyle(ACell: PCell; ABorder: TsCellBorder; AStyle: TsCellBorderStyle); overload;
Parameters
Parameters | Description
ACell: PCell | Pointer to cell
ABorder: TsCellBorder | Identifies the border to be modified (left/top/right/bottom)
AStyle: TsCellBorderStyle | record of parameters controlling how the border line is drawn (line style, line color)
Description

Sets the style of a cell border, i.e. line style and line color.

Notes

the border must be included in the "Borders" set in order to be shown!

Group

WriteBorderStyle Method


TsWorksheet.WriteBorderStyle Method (PCell, TsCellBorder, TsLineStyle, TsColor)

TsWorksheet.WriteBorderStyle Method (PCell, TsCellBorder, TsLineStyle, TsColor)
Syntax
Pascal
procedure WriteBorderStyle(ACell: PCell; ABorder: TsCellBorder; ALineStyle: TsLineStyle; AColor: TsColor); overload;
Group

WriteBorderStyle Method


WriteBorderStyles Method

WriteBorderStyles Method

This is the overview for the WriteBorderStyles method overload.

Overload List
Name | Description
TsWorksheet.WriteBorderStyles (Cardinal, Cardinal, TsCellBorderStyles) | Sets the style of all cell border of a cell, i.e. line style and line color.
TsWorksheet.WriteBorderStyles (PCell, TsCellBorderStyles) | Sets the style of all cell border of a cell, i.e. line style and line color.
Group

TsWorksheet Methods


TsWorksheet.WriteBorderStyles Method (Cardinal, Cardinal, TsCellBorderStyles)

TsWorksheet.WriteBorderStyles Method (Cardinal, Cardinal, TsCellBorderStyles)
Syntax
Pascal
function WriteBorderStyles(ARow: Cardinal; ACol: Cardinal; const AStyles: TsCellBorderStyles): PCell; overload;
Parameters
Parameters | Description
ARow: Cardinal | Row index of the considered cell
ACol: Cardinal | Column index of the considered cell
const AStyles: TsCellBorderStyles | Array of CellBorderStyles for each cell border.
Returns

Pointer to cell

Description

Sets the style of all cell border of a cell, i.e. line style and line color.

Notes

Only those borders included in the "Borders" set are shown!

See Also

WriteBorderStyle

Group

WriteBorderStyles Method


TsWorksheet.WriteBorderStyles Method (PCell, TsCellBorderStyles)

TsWorksheet.WriteBorderStyles Method (PCell, TsCellBorderStyles)
Syntax
Pascal
procedure WriteBorderStyles(ACell: PCell; const AStyles: TsCellBorderStyles); overload;
Parameters
Parameters | Description
ACell: PCell | Pointer to cell
const AStyles: TsCellBorderStyles | Array of CellBorderStyles for each cell border.
ACol | Column index of the considered cell
Description

Sets the style of all cell border of a cell, i.e. line style and line color.

Notes

Only those borders included in the "Borders" set are shown!

See Also

WriteBorderStyle

Group

WriteBorderStyles Method


TsWorksheet.WriteCellFormat Method

TsWorksheet.WriteCellFormat Method
Syntax
Pascal
procedure WriteCellFormat(ACell: PCell; const ACellFormat: TsCellFormat);
Parameters
Parameters | Description
ACell: PCell | Pointer to the cell to be modified
const ACellFormat: TsCellFormat | Cell format record to be used by the cell
Description

Assigns a complete cell format record to a cell

See Also

TsCellFormat

Group

TsWorksheet Methods


WriteCellValueAsString Method

WriteCellValueAsString Method

This is the overview for the WriteCellValueAsString method overload.

Overload List
Name | Description
TsWorksheet.WriteCellValueAsString (Cardinal, Cardinal, String) | Writes data defined as a string into a cell. Depending on the structure of the string, the worksheet tries to guess whether it is a number, a date/time or a text and calls the corresponding writing method.
TsWorksheet.WriteCellValueAsString (PCell, String) | Writes data defined as a string into a cell. Depending on the structure of the string, the worksheet tries to guess whether it is a number, a date/time or a text and calls the corresponding writing method.
Group

TsWorksheet Methods


TsWorksheet.WriteCellValueAsString Method (Cardinal, Cardinal, String)

TsWorksheet.WriteCellValueAsString Method (Cardinal, Cardinal, String)
Syntax
Pascal
function WriteCellValueAsString(ARow: Cardinal; ACol: Cardinal; AValue: String): PCell; overload;
Parameters
Parameters | Description
ARow: Cardinal | Row index of the cell
ACol: Cardinal | Column index of the cell
AValue: String | Value to be written into the cell given as a string. Depending on the structure of the string, however, the value is written as a number, a date/time or a text.
Returns

Pointer to the cell

Description

Writes data defined as a string into a cell. Depending on the structure of the string, the worksheet tries to guess whether it is a number, a date/time or a text and calls the corresponding writing method.

Group

WriteCellValueAsString Method


TsWorksheet.WriteCellValueAsString Method (PCell, String)

TsWorksheet.WriteCellValueAsString Method (PCell, String)
Syntax
Pascal
procedure WriteCellValueAsString(ACell: PCell; AValue: String); overload;
Parameters
Parameters | Description
ACell: PCell | Pointer to the cell
AValue: String | Value to be written into the cell given as a string. Depending on the structure of the string, however, the value is written as a number, a date/time or a text.
Description

Writes data defined as a string into a cell. Depending on the structure of the string, the worksheet tries to guess whether it is a number, a date/time or a text and calls the corresponding writing method.

Group

WriteCellValueAsString Method


TsWorksheet.WriteColInfo Method

TsWorksheet.WriteColInfo Method
Syntax
Pascal
procedure WriteColInfo(ACol: Cardinal; AData: TCol);
Parameters
Parameters | Description
ACol: Cardinal | Index of the column record which will be created or modified
AData: TCol | Data to be written (essentially column width).
Description

Writes a column record for the column at a given index to the spreadsheet. Currently the column record contains only the column width (and the column index, of course).

Creates a new column record if it does not yet exist.

Group

TsWorksheet Methods


TsWorksheet.WriteColWidth Method

TsWorksheet.WriteColWidth Method
Syntax
Pascal
procedure WriteColWidth(ACol: Cardinal; AWidth: Single);
Parameters
Parameters | Description
ACol: Cardinal | Index of the column to be considered
AWidth: Single | Width to be assigned to the column. The column width is expressed as the count of "0" characters of the default font.
Description

Sets the column width for a given column. Creates a new column record if it does not yet exist.

Group

TsWorksheet Methods


WriteComment Method

WriteComment Method

This is the overview for the WriteComment method overload.

Overload List
Name | Description
TsWorksheet.WriteComment (Cardinal, Cardinal, String) | Adds a comment to a specific cell
TsWorksheet.WriteComment (PCell, String) | Adds a comment to a specific cell
Group

TsWorksheet Methods


TsWorksheet.WriteComment Method (Cardinal, Cardinal, String)

TsWorksheet.WriteComment Method (Cardinal, Cardinal, String)
Syntax
Pascal
function WriteComment(ARow: Cardinal; ACol: Cardinal; AText: String): PCell; overload;
Parameters
Parameters | Description
ARow: Cardinal | (0-based) row index of the cell
ACol: Cardinal | (0-based) column index of the cell
AText: String | Comment text
Returns

Pointer to the cell containing the comment

Description

Adds a comment to a specific cell

Group

WriteComment Method


TsWorksheet.WriteComment Method (PCell, String)

TsWorksheet.WriteComment Method (PCell, String)
Syntax
Pascal
procedure WriteComment(ACell: PCell; AText: String); overload;
Parameters
Parameters | Description
ACell: PCell | Pointer to the cell
AText: String | Comment text
Description

Adds a comment to a specific cell

Group

WriteComment Method


WriteCurrency Method

WriteCurrency Method

This is the overview for the WriteCurrency method overload.

Overload List
Name | Description
TsWorksheet.WriteCurrency (Cardinal, Cardinal, Double, TsNumberFormat, Integer, String, Integer, Integer) | Writes a currency value to a given cell. Its number format can be provided optionally by specifying various parameters.
TsWorksheet.WriteCurrency (Cardinal, Cardinal, Double, TsNumberFormat, String) | Writes a currency value to a given cell. Its number format is specified by means of a format string.
TsWorksheet.WriteCurrency (PCell, Double, TsNumberFormat, Integer, String, Integer, Integer) | Writes a currency value to a given cell. Its number format can be provided optionally by specifying various parameters.
TsWorksheet.WriteCurrency (PCell, Double, TsNumberFormat, String) | Writes a currency value to a given cell. Its number format is specified by means of a format string.
Group

TsWorksheet Methods


TsWorksheet.WriteCurrency Method (Cardinal, Cardinal, Double, TsNumberFormat, Integer, String, Integer, Integer)

TsWorksheet.WriteCurrency Method (Cardinal, Cardinal, Double, TsNumberFormat, Integer, String, Integer, Integer)
Syntax
Pascal
function WriteCurrency(ARow: Cardinal; ACol: Cardinal; AValue: Double; ANumFormat: TsNumberFormat = nfCurrency; ADecimals: Integer = 2; ACurrencySymbol: String = '?'; APosCurrFormat: Integer = -1; ANegCurrFormat: Integer = -1): PCell; overload;
Parameters
Parameters | Description
ARow: Cardinal | Cell row index
ACol: Cardinal | Cell column index
AValue: Double | Number value to be written
ANumFormat: TsNumberFormat = nfCurrency | Format identifier, must be nfCurrency, or nfCurrencyRed.
ADecimals: Integer = 2 | Number of decimal places
ACurrencySymbol: String = '?' | String to be shown as currency, such as '$', or 'EUR'. In case of '?' the currency symbol defined in the workbook's FormatSettings is used.
APosCurrFormat: Integer = -1 | Code specifying the order of value, currency symbol and spaces (see pcfXXXX constants)
ANegCurrFormat: Integer = -1 | Code specifying the order of value, currency symbol, spaces, and how negative values are shown (see ncfXXXX constants)
Returns

Pointer to the cell

Description

Writes a currency value to a given cell. Its number format can be provided optionally by specifying various parameters.

Group

WriteCurrency Method


TsWorksheet.WriteCurrency Method (Cardinal, Cardinal, Double, TsNumberFormat, String)

TsWorksheet.WriteCurrency Method (Cardinal, Cardinal, Double, TsNumberFormat, String)
Syntax
Pascal
function WriteCurrency(ARow: Cardinal; ACol: Cardinal; AValue: Double; ANumFormat: TsNumberFormat; ANumFormatString: String): PCell; overload;
Parameters
Parameters | Description
ARow: Cardinal | Cell row index
ACol: Cardinal | Cell column index
AValue: Double | Number value to be written
ANumFormat: TsNumberFormat | Format identifier, must be nfCurrency or nfCurrencyRed.
ANumFormatString: String | String of formatting codes, including currency symbol. Can contain sections for different formatting of positive and negative number.
Returns

Pointer to the cell

Description

Writes a currency value to a given cell. Its number format is specified by means of a format string.

Example

'"EUR" #,##0.00;("EUR" #,##0.00)'

Group

WriteCurrency Method


TsWorksheet.WriteCurrency Method (PCell, Double, TsNumberFormat, Integer, String, Integer, Integer)

TsWorksheet.WriteCurrency Method (PCell, Double, TsNumberFormat, Integer, String, Integer, Integer)
Syntax
Pascal
procedure WriteCurrency(ACell: PCell; AValue: Double; ANumFormat: TsNumberFormat = nfCurrency; ADecimals: Integer = -1; ACurrencySymbol: String = '?'; APosCurrFormat: Integer = -1; ANegCurrFormat: Integer = -1); overload;
Parameters
Parameters | Description
ACell: PCell | Pointer to the cell considered
AValue: Double | Number value to be written
ANumFormat: TsNumberFormat = nfCurrency | Format identifier, must be nfCurrency or nfCurrencyRed.
ADecimals: Integer = -1 | Number of decimal places
ACurrencySymbol: String = '?' | String to be shown as currency, such as '$', or 'EUR'. In case of '?' the currency symbol defined in the workbook's FormatSettings is used.
APosCurrFormat: Integer = -1 | Code specifying the order of value, currency symbol and spaces (see pcfXXXX constants)
ANegCurrFormat: Integer = -1 | Code specifying the order of value, currency symbol, spaces, and how negative values are shown (see ncfXXXX constants)
Description

Writes a currency value to a given cell. Its number format can be provided optionally by specifying various parameters.

Group

WriteCurrency Method


TsWorksheet.WriteCurrency Method (PCell, Double, TsNumberFormat, String)

TsWorksheet.WriteCurrency Method (PCell, Double, TsNumberFormat, String)
Syntax
Pascal
procedure WriteCurrency(ACell: PCell; AValue: Double; ANumFormat: TsNumberFormat; ANumFormatString: String); overload;
Parameters
Parameters | Description
ACell: PCell | Pointer to the cell considered
AValue: Double | Number value to be written
ANumFormat: TsNumberFormat | Format identifier, must be nfCurrency or nfCurrencyRed.
ANumFormatString: String | String of formatting codes, including currency symbol. Can contain sections for different formatting of positive and negative number.
Description

Writes a currency value to a given cell. Its number format is specified by means of a format string.

Example

'"EUR" #,##0.00;("EUR" #,##0.00)'

Group

WriteCurrency Method


WriteDateTime Method

WriteDateTime Method

This is the overview for the WriteDateTime method overload.

Overload List
Name | Description
TsWorksheet.WriteDateTime (Cardinal, Cardinal, TDateTime) | Writes a date/time value to a cell, does not change number format
TsWorksheet.WriteDateTime (Cardinal, Cardinal, TDateTime, String) | Writes a date/time value to a cell
TsWorksheet.WriteDateTime (Cardinal, Cardinal, TDateTime, TsNumberFormat, String) | Writes a date/time value to a cell
TsWorksheet.WriteDateTime (PCell, TDateTime) | Writes a date/time value to a cell. Does not change number format
TsWorksheet.WriteDateTime (PCell, TDateTime, String) | Writes a date/time value to a cell
TsWorksheet.WriteDateTime (PCell, TDateTime, TsNumberFormat, String) | Writes a date/time value to a cell
Group

TsWorksheet Methods


TsWorksheet.WriteDateTime Method (Cardinal, Cardinal, TDateTime)

TsWorksheet.WriteDateTime Method (Cardinal, Cardinal, TDateTime)
Syntax
Pascal
function WriteDateTime(ARow: Cardinal; ACol: Cardinal; AValue: TDateTime): PCell; overload;
Parameters
Parameters | Description
ARow: Cardinal | The row of the cell
ACol: Cardinal | The column of the cell
AValue: TDateTime | The date/time/datetime to be written
Returns

Pointer to the cell

Description

Writes a date/time value to a cell, does not change number format

Group

WriteDateTime Method


TsWorksheet.WriteDateTime Method (Cardinal, Cardinal, TDateTime, String)

TsWorksheet.WriteDateTime Method (Cardinal, Cardinal, TDateTime, String)
Syntax
Pascal
function WriteDateTime(ARow: Cardinal; ACol: Cardinal; AValue: TDateTime; ANumFormatStr: String): PCell; overload;
Parameters
Parameters | Description
ARow: Cardinal | The row index of the cell
ACol: Cardinal | The column index of the cell
AValue: TDateTime | The date/time/datetime to be written
ANumFormatStr: String | Format string (the format identifier nfCustom is used to classify the format).
Returns

Pointer to the cell

Description

Writes a date/time value to a cell

Notes

at least Excel xls does not recognize a separate datetime cell type: a datetime is stored as a (floating point) number, and the cell is formatted as a date (either built-in or a custom format).

Group

WriteDateTime Method


TsWorksheet.WriteDateTime Method (Cardinal, Cardinal, TDateTime, TsNumberFormat, String)

TsWorksheet.WriteDateTime Method (Cardinal, Cardinal, TDateTime, TsNumberFormat, String)
Syntax
Pascal
function WriteDateTime(ARow: Cardinal; ACol: Cardinal; AValue: TDateTime; ANumFormat: TsNumberFormat; ANumFormatStr: String = ''): PCell; overload;
Parameters
Parameters | Description
ARow: Cardinal | The row of the cell
ACol: Cardinal | The column of the cell
AValue: TDateTime | The date/time/datetime to be written
ANumFormat: TsNumberFormat | The format specifier, e.g. nfShortDate (optional) If not specified format is not changed.
ANumFormatStr: String = '' | Format string, used only for nfCustom or nfTimeInterval.
Returns

Pointer to the cell

Description

Writes a date/time value to a cell

Notes

at least Excel xls does not recognize a separate datetime cell type: a datetime is stored as a (floating point) number, and the cell is formatted as a date (either built-in or a custom format).

Group

WriteDateTime Method


TsWorksheet.WriteDateTime Method (PCell, TDateTime)

TsWorksheet.WriteDateTime Method (PCell, TDateTime)
Syntax
Pascal
procedure WriteDateTime(ACell: PCell; AValue: TDateTime); overload;
Parameters
Parameters | Description
ACell: PCell | Pointer to the cell considered
AValue: TDateTime | The date/time/datetime to be written
Description

Writes a date/time value to a cell. Does not change number format

Group

WriteDateTime Method


TsWorksheet.WriteDateTime Method (PCell, TDateTime, String)

TsWorksheet.WriteDateTime Method (PCell, TDateTime, String)
Syntax
Pascal
procedure WriteDateTime(ACell: PCell; AValue: TDateTime; ANumFormatStr: String); overload;
Parameters
Parameters | Description
ACell: PCell | Pointer to the cell considered
AValue: TDateTime | The date/time/datetime to be written
ANumFormatStr: String | Format string (the format identifier nfCustom is used to classify the format).
Description

Writes a date/time value to a cell

Notes

at least Excel xls does not recognize a separate datetime cell type: a datetime is stored as a (floating point) number, and the cell is formatted as a date (either built-in or a custom format).

Group

WriteDateTime Method


TsWorksheet.WriteDateTime Method (PCell, TDateTime, TsNumberFormat, String)

TsWorksheet.WriteDateTime Method (PCell, TDateTime, TsNumberFormat, String)
Syntax
Pascal
procedure WriteDateTime(ACell: PCell; AValue: TDateTime; ANumFormat: TsNumberFormat; ANumFormatStr: String = ''); overload;
Parameters
Parameters | Description
ACell: PCell | Pointer to the cell considered
AValue: TDateTime | The date/time/datetime to be written
ANumFormat: TsNumberFormat | The format specifier, e.g. nfShortDate (optional) If not specified format is not changed.
ANumFormatStr: String = '' | Format string, used only for nfCustom or nfTimeInterval.
Description

Writes a date/time value to a cell

Notes

at least Excel xls does not recognize a separate datetime cell type: a datetime is stored as a (floating point) number, and the cell is formatted as a date (either built-in or a custom format).

Group

WriteDateTime Method


WriteDateTimeFormat Method

WriteDateTimeFormat Method

This is the overview for the WriteDateTimeFormat method overload.

Overload List
Name | Description
TsWorksheet.WriteDateTimeFormat (Cardinal, Cardinal, TsNumberFormat, String) | Adds a date/time format to the formatting of a cell
TsWorksheet.WriteDateTimeFormat (PCell, TsNumberFormat, String) | Adds a date/time format to the formatting of a cell
Group

TsWorksheet Methods


TsWorksheet.WriteDateTimeFormat Method (Cardinal, Cardinal, TsNumberFormat, String)

TsWorksheet.WriteDateTimeFormat Method (Cardinal, Cardinal, TsNumberFormat, String)
Syntax
Pascal
function WriteDateTimeFormat(ARow: Cardinal; ACol: Cardinal; ANumFormat: TsNumberFormat; const ANumFormatString: String = ''): PCell; overload;
Parameters
Parameters | Description
ARow: Cardinal | The row of the cell
ACol: Cardinal | The column of the cell
ANumFormat: TsNumberFormat | Identifier of the format to be applied (nfXXXX constant)
const ANumFormatString: String = '' | Optional string of formatting codes. Is only considered if ANumberFormat is nfCustom.
Returns

Pointer to the cell

Description

Adds a date/time format to the formatting of a cell

See Also

TsNumberFormat

Group

WriteDateTimeFormat Method


TsWorksheet.WriteDateTimeFormat Method (PCell, TsNumberFormat, String)

TsWorksheet.WriteDateTimeFormat Method (PCell, TsNumberFormat, String)
Syntax
Pascal
procedure WriteDateTimeFormat(ACell: PCell; ANumFormat: TsNumberFormat; const ANumFormatString: String = ''); overload;
Parameters
Parameters | Description
ACell: PCell | Pointer to the cell considered
ANumFormat: TsNumberFormat | Identifier of the format to be applied (nxXXXX constant)
const ANumFormatString: String = '' | optional string of formatting codes. Is only considered if ANumberFormat is nfCustom.
Description

Adds a date/time format to the formatting of a cell

See Also

TsNumberFormat

Group

WriteDateTimeFormat Method


WriteDecimals Method

WriteDecimals Method

This is the overview for the WriteDecimals method overload.

Overload List
Name | Description
TsWorksheet.WriteDecimals (Cardinal, Cardinal, byte) |
TsWorksheet.WriteDecimals (PCell, Byte) | Formats the number in a cell to show a given count of decimal places. Is ignored for non-decimal formats (such as most date/time formats).
Group

TsWorksheet Methods


TsWorksheet.WriteDecimals Method (Cardinal, Cardinal, byte)

TsWorksheet.WriteDecimals Method (Cardinal, Cardinal, byte)
Syntax
Pascal
function WriteDecimals(ARow: Cardinal; ACol: Cardinal; ADecimals: byte): PCell; overload;
Group

WriteDecimals Method


TsWorksheet.WriteDecimals Method (PCell, Byte)

TsWorksheet.WriteDecimals Method (PCell, Byte)
Syntax
Pascal
procedure WriteDecimals(ACell: PCell; ADecimals: Byte); overload;
Parameters
Parameters | Description
ACell: PCell | Pointer to the cell considered
ADecimals: Byte | Number of decimal places to be displayed
Description

Formats the number in a cell to show a given count of decimal places. Is ignored for non-decimal formats (such as most date/time formats).

See Also

TsNumberFormat

Group

WriteDecimals Method


WriteErrorValue Method

WriteErrorValue Method

This is the overview for the WriteErrorValue method overload.

Overload List
Name | Description
TsWorksheet.WriteErrorValue (Cardinal, Cardinal, TsErrorValue) | Writes an error value to a cell.
TsWorksheet.WriteErrorValue (PCell, TsErrorValue) | Writes an error value to a cell.
Group

TsWorksheet Methods


TsWorksheet.WriteErrorValue Method (Cardinal, Cardinal, TsErrorValue)

TsWorksheet.WriteErrorValue Method (Cardinal, Cardinal, TsErrorValue)
Syntax
Pascal
function WriteErrorValue(ARow: Cardinal; ACol: Cardinal; AValue: TsErrorValue): PCell; overload;
Parameters
Parameters | Description
ARow: Cardinal | The row of the cell
ACol: Cardinal | The column of the cell
AValue: TsErrorValue | The error code value
Returns

Pointer to the cell

Description

Writes an error value to a cell.

See Also

TsErrorValue

Group

WriteErrorValue Method


TsWorksheet.WriteErrorValue Method (PCell, TsErrorValue)

TsWorksheet.WriteErrorValue Method (PCell, TsErrorValue)
Syntax
Pascal
procedure WriteErrorValue(ACell: PCell; AValue: TsErrorValue); overload;
Parameters
Parameters | Description
AValue: TsErrorValue | The error code value
ACol | Pointer to the cell to be written
Description

Writes an error value to a cell.

See Also

TsErrorValue

Group

WriteErrorValue Method


WriteFont Method

WriteFont Method

This is the overview for the WriteFont method overload.

Overload List
Name | Description
TsWorksheet.WriteFont (Cardinal, Cardinal, Integer) | Applies a font to the formatting of a cell. The font is determined by its index in the workbook's font list:
TsWorksheet.WriteFont (Cardinal, Cardinal, String, Single, TsFontStyles, TsColor, TsFontPosition) | Adds font specification to the formatting of a cell. Looks in the workbook's FontList and creates an new entry if the font is not used so far. Returns the index of the font in the font list.
TsWorksheet.WriteFont (PCell, Integer) | Applies a font to the formatting of a cell. The font is determined by its index in the workbook's font list:
TsWorksheet.WriteFont (PCell, String, Single, TsFontStyles, TsColor, TsFontPosition) | Adds font specification to the formatting of a cell. Looks in the workbook's FontList and creates an new entry if the font is not used so far. Returns the index of the font in the font list.
Group

TsWorksheet Methods


TsWorksheet.WriteFont Method (Cardinal, Cardinal, Integer)

TsWorksheet.WriteFont Method (Cardinal, Cardinal, Integer)
Syntax
Pascal
function WriteFont(ARow: Cardinal; ACol: Cardinal; AFontIndex: Integer): PCell; overload;
Parameters
Parameters | Description
ARow: Cardinal | The row of the cell
ACol: Cardinal | The column of the cell
AFontIndex: Integer | Index of the font in the workbook's font list
Returns

Pointer to the cell

Description

Applies a font to the formatting of a cell. The font is determined by its index in the workbook's font list:

Group

WriteFont Method


TsWorksheet.WriteFont Method (Cardinal, Cardinal, String, Single, TsFontStyles, TsColor, TsFontPosition)

TsWorksheet.WriteFont Method (Cardinal, Cardinal, String, Single, TsFontStyles, TsColor, TsFontPosition)
Syntax
Pascal
function WriteFont(ARow: Cardinal; ACol: Cardinal; const AFontName: String; AFontSize: Single; AFontStyle: TsFontStyles; AFontColor: TsColor; APosition: TsFontPosition = fpNormal): Integer; overload;
Parameters
Parameters | Description
ARow: Cardinal | The row of the cell
ACol: Cardinal | The column of the cell
const AFontName: String | Name of the font
AFontSize: Single | Size of the font, in points
AFontStyle: TsFontStyles | Set with font style attributes (don't use those of unit "graphics" !)
AFontColor: TsColor | RGB value of the font's color
APosition: TsFontPosition = fpNormal | Specifies sub- or superscript text
Returns

Index of the font in the workbook's font list.

Description

Adds font specification to the formatting of a cell. Looks in the workbook's FontList and creates an new entry if the font is not used so far. Returns the index of the font in the font list.

Group

WriteFont Method


TsWorksheet.WriteFont Method (PCell, Integer)

TsWorksheet.WriteFont Method (PCell, Integer)
Syntax
Pascal
procedure WriteFont(ACell: PCell; AFontIndex: Integer); overload;
Parameters
Parameters | Description
ACell: PCell | Pointer to the cell considered
AFontIndex: Integer | Index of the font in the workbook's font list
Description

Applies a font to the formatting of a cell. The font is determined by its index in the workbook's font list:

Group

WriteFont Method


TsWorksheet.WriteFont Method (PCell, String, Single, TsFontStyles, TsColor, TsFontPosition)

TsWorksheet.WriteFont Method (PCell, String, Single, TsFontStyles, TsColor, TsFontPosition)
Syntax
Pascal
function WriteFont(ACell: PCell; const AFontName: String; AFontSize: Single; AFontStyle: TsFontStyles; AFontColor: TsColor; APosition: TsFontPosition = fpNormal): Integer; overload;
Parameters
Parameters | Description
ACell: PCell | Pointer to the cell considered
const AFontName: String | Name of the font
AFontSize: Single | Size of the font, in points
AFontStyle: TsFontStyles | Set with font style attributes (don't use those of unit "graphics" !)
AFontColor: TsColor | RGB value of the font's color
APosition: TsFontPosition = fpNormal | Specified subscript or superscript text.
Returns

Index of the font in the workbook's font list.

Description

Adds font specification to the formatting of a cell. Looks in the workbook's FontList and creates an new entry if the font is not used so far. Returns the index of the font in the font list.

Group

WriteFont Method


WriteFontColor Method

WriteFontColor Method

This is the overview for the WriteFontColor method overload.

Overload List
Name | Description
TsWorksheet.WriteFontColor (Cardinal, Cardinal, TsColor) | Replaces the text color used in formatting of a cell. Looks in the workbook's font list if this modified font has already been used. If not a new font entry is created. Returns the index of this font in the font list.
TsWorksheet.WriteFontColor (PCell, TsColor) | Replaces the text color used in formatting of a cell. Looks in the workbook's font list if this modified font has already been used. If not a new font entry is created. Returns the index of this font in the font list.
Group

TsWorksheet Methods


TsWorksheet.WriteFontColor Method (Cardinal, Cardinal, TsColor)

TsWorksheet.WriteFontColor Method (Cardinal, Cardinal, TsColor)
Syntax
Pascal
function WriteFontColor(ARow: Cardinal; ACol: Cardinal; AFontColor: TsColor): Integer; overload;
Parameters
Parameters | Description
ARow: Cardinal | The row of the cell
ACol: Cardinal | The column of the cell
AFontColor: TsColor | RGB value of the new text color
Returns

Index of the font in the workbook's font list.

Description

Replaces the text color used in formatting of a cell. Looks in the workbook's font list if this modified font has already been used. If not a new font entry is created. Returns the index of this font in the font list.

Group

WriteFontColor Method


TsWorksheet.WriteFontColor Method (PCell, TsColor)

TsWorksheet.WriteFontColor Method (PCell, TsColor)
Syntax
Pascal
function WriteFontColor(ACell: PCell; AFontColor: TsColor): Integer; overload;
Parameters
Parameters | Description
ACell: PCell | Pointer to the cell
AFontColor: TsColor | RGB value of the new text color
Returns

Index of the font in the workbook's font list.

Description

Replaces the text color used in formatting of a cell. Looks in the workbook's font list if this modified font has already been used. If not a new font entry is created. Returns the index of this font in the font list.

Group

WriteFontColor Method


WriteFontName Method

WriteFontName Method

This is the overview for the WriteFontName method overload.

Overload List
Name | Description
TsWorksheet.WriteFontName (Cardinal, Cardinal, String) | Replaces the font used in formatting of a cell considering only the font face and leaving font size, style and color unchanged. Looks in the workbook's font list if this modified font has already been used. If not a new font entry is created. Returns the index of this font in the font list.
TsWorksheet.WriteFontName (PCell, String) | Replaces the font used in formatting of a cell considering only the font face and leaving font size, style and color unchanged. Looks in the workbook's font list if this modified font has already been used. If not a new font entry is created. Returns the index of this font in the font list.
Group

TsWorksheet Methods


TsWorksheet.WriteFontName Method (Cardinal, Cardinal, String)

TsWorksheet.WriteFontName Method (Cardinal, Cardinal, String)
Syntax
Pascal
function WriteFontName(ARow: Cardinal; ACol: Cardinal; AFontName: String): Integer; overload;
Parameters
Parameters | Description
ARow: Cardinal | The row of the cell
ACol: Cardinal | The column of the cell
AFontName: String | Name of the new font to be used
Returns

Index of the font in the workbook's font list.

Description

Replaces the font used in formatting of a cell considering only the font face and leaving font size, style and color unchanged. Looks in the workbook's font list if this modified font has already been used. If not a new font entry is created. Returns the index of this font in the font list.

Group

WriteFontName Method


TsWorksheet.WriteFontName Method (PCell, String)

TsWorksheet.WriteFontName Method (PCell, String)
Syntax
Pascal
function WriteFontName(ACell: PCell; AFontName: String): Integer; overload;
Parameters
Parameters | Description
ACell: PCell | Pointer to the cell
AFontName: String | Name of the new font to be used
Returns

Index of the font in the workbook's font list.

Description

Replaces the font used in formatting of a cell considering only the font face and leaving font size, style and color unchanged. Looks in the workbook's font list if this modified font has already been used. If not a new font entry is created. Returns the index of this font in the font list.

Group

WriteFontName Method


WriteFontSize Method

WriteFontSize Method

This is the overview for the WriteFontSize method overload.

Overload List
Name | Description
TsWorksheet.WriteFontSize (Cardinal, Cardinal, Single) | Replaces the font size in formatting of a cell. Looks in the workbook's font list if this modified font has already been used. If not a new font entry is created. Returns the index of this font in the font list.
TsWorksheet.WriteFontSize (PCell, Single) | Replaces the font size in formatting of a cell. Looks in the workbook's font list if this modified font has already been used. If not a new font entry is created. Returns the index of this font in the font list.
Group

TsWorksheet Methods


TsWorksheet.WriteFontSize Method (Cardinal, Cardinal, Single)

TsWorksheet.WriteFontSize Method (Cardinal, Cardinal, Single)
Syntax
Pascal
function WriteFontSize(ARow: Cardinal; ACol: Cardinal; ASize: Single): Integer; overload;
Parameters
Parameters | Description
ARow: Cardinal | The row of the cell
ACol: Cardinal | The column of the cell
ASize: Single | Size of the font to be used (in points).
Returns

Index of the font in the workbook's font list.

Description

Replaces the font size in formatting of a cell. Looks in the workbook's font list if this modified font has already been used. If not a new font entry is created. Returns the index of this font in the font list.

Group

WriteFontSize Method


TsWorksheet.WriteFontSize Method (PCell, Single)

TsWorksheet.WriteFontSize Method (PCell, Single)
Syntax
Pascal
function WriteFontSize(ACell: PCell; ASize: Single): Integer; overload;
Parameters
Parameters | Description
ACell: PCell | Pointer to the cell
ASize: Single | Size of the font to be used (in points).
Returns

Index of the font in the workbook's font list.

Description

Replaces the font size in formatting of a cell. Looks in the workbook's font list if this modified font has already been used. If not a new font entry is created. Returns the index of this font in the font list.

Group

WriteFontSize Method


WriteFontStyle Method

WriteFontStyle Method

This is the overview for the WriteFontStyle method overload.

Overload List
Name | Description
TsWorksheet.WriteFontStyle (Cardinal, Cardinal, TsFontStyles) | Replaces the font style (bold, italic, etc) in formatting of a cell. Looks in the workbook's font list if this modified font has already been used. If not a new font entry is created. Returns the index of this font in the font list.
TsWorksheet.WriteFontStyle (PCell, TsFontStyles) | Replaces the font style (bold, italic, etc) in formatting of a cell. Looks in the workbook's font list if this modified font has already been used. If not a new font entry is created. Returns the index of this font in the font list.
Group

TsWorksheet Methods


TsWorksheet.WriteFontStyle Method (Cardinal, Cardinal, TsFontStyles)

TsWorksheet.WriteFontStyle Method (Cardinal, Cardinal, TsFontStyles)
Syntax
Pascal
function WriteFontStyle(ARow: Cardinal; ACol: Cardinal; AStyle: TsFontStyles): Integer; overload;
Parameters
Parameters | Description
ARow: Cardinal | The row of the cell
ACol: Cardinal | The column of the cell
AStyle: TsFontStyles | New font style to be used
Returns

Index of the font in the workbook's font list.

Description

Replaces the font style (bold, italic, etc) in formatting of a cell. Looks in the workbook's font list if this modified font has already been used. If not a new font entry is created. Returns the index of this font in the font list.

See Also

TsFontStyle

Group

WriteFontStyle Method


TsWorksheet.WriteFontStyle Method (PCell, TsFontStyles)

TsWorksheet.WriteFontStyle Method (PCell, TsFontStyles)
Syntax
Pascal
function WriteFontStyle(ACell: PCell; AStyle: TsFontStyles): Integer; overload;
Parameters
Parameters | Description
ACell: PCell | Pointer to the cell considered
AStyle: TsFontStyles | New font style to be used
Returns

Index of the font in the workbook's font list.

Description

Replaces the font style (bold, italic, etc) in formatting of a cell. Looks in the workbook's font list if this modified font has already been used. If not a new font entry is created. Returns the index of this font in the font list.

See Also

TsFontStyle

Group

WriteFontStyle Method


WriteFormula Method

WriteFormula Method

This is the overview for the WriteFormula method overload.

Overload List
Name | Description
TsWorksheet.WriteFormula (Cardinal, Cardinal, String, Boolean) |
TsWorksheet.WriteFormula (PCell, String, Boolean) |
Group

TsWorksheet Methods


TsWorksheet.WriteFormula Method (Cardinal, Cardinal, String, Boolean)

TsWorksheet.WriteFormula Method (Cardinal, Cardinal, String, Boolean)
Syntax
Pascal
function WriteFormula(ARow: Cardinal; ACol: Cardinal; AFormula: String; ALocalized: Boolean = false): PCell; overload;
Group

WriteFormula Method


TsWorksheet.WriteFormula Method (PCell, String, Boolean)

TsWorksheet.WriteFormula Method (PCell, String, Boolean)
Syntax
Pascal
procedure WriteFormula(ACell: PCell; AFormula: String; ALocalized: Boolean = false); overload;
Group

WriteFormula Method


WriteFractionFormat Method

WriteFractionFormat Method

This is the overview for the WriteFractionFormat method overload.

Overload List
Name | Description
TsWorksheet.WriteFractionFormat (Cardinal, Cardinal, Boolean, Integer, Integer) | Formats a number as a fraction
TsWorksheet.WriteFractionFormat (PCell, Boolean, Integer, Integer) | Formats a number as a fraction
Group

TsWorksheet Methods


TsWorksheet.WriteFractionFormat Method (Cardinal, Cardinal, Boolean, Integer, Integer)

TsWorksheet.WriteFractionFormat Method (Cardinal, Cardinal, Boolean, Integer, Integer)
Syntax
Pascal
function WriteFractionFormat(ARow: Cardinal; ACol: Cardinal; AMixedFraction: Boolean; ANumeratorDigits: Integer; ADenominatorDigits: Integer): PCell; overload;
Parameters
Parameters | Description
ARow: Cardinal | Row index of the cell
ACol: Cardinal | Column index of the cell
ADenominatorDigits: Integer | Count of denominator digits
ANumFormat | Identifier of the format to be applied. Must be either nfFraction or nfMixedFraction
ANumeratorDigts | Count of numerator digits
Returns

Pointer to the cell

Description

Formats a number as a fraction

See Also

TsNumberFormat

Group

WriteFractionFormat Method


TsWorksheet.WriteFractionFormat Method (PCell, Boolean, Integer, Integer)

TsWorksheet.WriteFractionFormat Method (PCell, Boolean, Integer, Integer)
Syntax
Pascal
procedure WriteFractionFormat(ACell: PCell; AMixedFraction: Boolean; ANumeratorDigits: Integer; ADenominatorDigits: Integer); overload;
Parameters
Parameters | Description
ACell: PCell | Pointer to the cell to be formatted
ADenominatorDigits: Integer | Count of denominator digits
ANumFormat | Identifier of the format to be applied. Must be either nfFraction or nfMixedFraction
ANumeratorDigts | Count of numerator digits
Description

Formats a number as a fraction

See Also

TsNumberFormat

Group

WriteFractionFormat Method


WriteHorAlignment Method

WriteHorAlignment Method

This is the overview for the WriteHorAlignment method overload.

Overload List
Name | Description
TsWorksheet.WriteHorAlignment (Cardinal, Cardinal, TsHorAlignment) | Defines the horizontal alignment of text in a cell.
TsWorksheet.WriteHorAlignment (PCell, TsHorAlignment) | Defines the horizontal alignment of text in a cell.
Group

TsWorksheet Methods


TsWorksheet.WriteHorAlignment Method (Cardinal, Cardinal, TsHorAlignment)

TsWorksheet.WriteHorAlignment Method (Cardinal, Cardinal, TsHorAlignment)
Syntax
Pascal
function WriteHorAlignment(ARow: Cardinal; ACol: Cardinal; AValue: TsHorAlignment): PCell; overload;
Parameters
Parameters | Description
ARow: Cardinal | Row index of the cell considered
ACol: Cardinal | Column index of the cell considered
AValue: TsHorAlignment | Parameter for horizontal text alignment (haDefault, vaLeft, haCenter, haRight) By default, texts are left-aligned, numbers and dates are right-aligned.
Returns

Pointer to cell

Description

Defines the horizontal alignment of text in a cell.

Group

WriteHorAlignment Method


TsWorksheet.WriteHorAlignment Method (PCell, TsHorAlignment)

TsWorksheet.WriteHorAlignment Method (PCell, TsHorAlignment)
Syntax
Pascal
procedure WriteHorAlignment(ACell: PCell; AValue: TsHorAlignment); overload;
Parameters
Parameters | Description
ACell: PCell | Pointer to the cell considered
AValue: TsHorAlignment | Parameter for horizontal text alignment (haDefault, vaLeft, haCenter, haRight) By default, texts are left-aligned, numbers and dates are right-aligned.
Description

Defines the horizontal alignment of text in a cell.

Group

WriteHorAlignment Method


WriteHyperlink Method

WriteHyperlink Method

This is the overview for the WriteHyperlink method overload.

Overload List
Name | Description
TsWorksheet.WriteHyperlink (Cardinal, Cardinal, String, String) | Assigns a hyperlink to the cell at the specified row and column Cell content is not affected by the presence of a hyperlink.
TsWorksheet.WriteHyperlink (PCell, String, String) | Assigns a hyperlink to the specified cell.
Group

TsWorksheet Methods


TsWorksheet.WriteHyperlink Method (Cardinal, Cardinal, String, String)

TsWorksheet.WriteHyperlink Method (Cardinal, Cardinal, String, String)
Syntax
Pascal
function WriteHyperlink(ARow: Cardinal; ACol: Cardinal; ATarget: String; ATooltip: String = ''): PCell; overload;
Parameters
Parameters | Description
ARow: Cardinal | Row index of the cell considered
ACol: Cardinal | Column index of the cell considered
ATarget: String | Hyperlink address given as a fully qualitifed URI for external links, or as a # followed by a cell address for internal links.
ATooltip: String = '' | Text for popup tooltip hint used by Excel
Returns

Pointer to the cell with the hyperlink

Description

Assigns a hyperlink to the cell at the specified row and column Cell content is not affected by the presence of a hyperlink.

Group

WriteHyperlink Method


TsWorksheet.WriteHyperlink Method (PCell, String, String)

TsWorksheet.WriteHyperlink Method (PCell, String, String)
Syntax
Pascal
procedure WriteHyperlink(ACell: PCell; ATarget: String; ATooltip: String = ''); overload;
Parameters
Parameters | Description
ACell: PCell | Pointer to the cell considered
ATarget: String | Hyperlink address given as a fully qualitifed URI for external links, or as a # followed by a cell address for internal links. Local files can be specified also by their name relative to the workbook. An existing hyperlink is removed if ATarget is empty.
ATooltip: String = '' | Text for popup tooltip hint used by Excel
Description

Assigns a hyperlink to the specified cell.

Group

WriteHyperlink Method


TsWorksheet.WriteImage Method

TsWorksheet.WriteImage Method
Syntax
Pascal
function WriteImage(ARow: Cardinal; ACol: Cardinal; AFileName: String; AOffsetX: Double = 0.0; AOffsetY: Double = 0.0; AScaleX: Double = 1.0; AScaleY: Double = 1.0): Integer;
Parameters
Parameters | Description
ARow: Cardinal | Index of the row at which the image begins (top edge)
ACol: Cardinal | Index of the column at which the image begins (left edge)
AFileName: String | Name of the image file
AOffsetX: Double = 0.0 | The image is offset horizontally from the left edge of the anchor cell. May reach into another cell. Value is in millimeters.
AOffsetY: Double = 0.0 | The image is offset vertically from the top edge of the anchor cell. May reach into another cell. Value is in millimeters.
AScaleX: Double = 1.0 | Horizontal scaling factor of the image
AScaleY: Double = 1.0 | Vertical scaling factor of the image
Returns

Index into the internal image list.

Description

Adds an embedded image to the worksheet

Group

TsWorksheet Methods


WriteNumber Method

WriteNumber Method

This is the overview for the WriteNumber method overload.

Overload List
Name | Description
TsWorksheet.WriteNumber (Cardinal, Cardinal, double) | Writes a floating-point number to a cell, does not change the number format
TsWorksheet.WriteNumber (Cardinal, Cardinal, double, TsNumberFormat, Byte) | Writes a floating-point number to a cell
TsWorksheet.WriteNumber (Cardinal, Cardinal, double, TsNumberFormat, String) |
TsWorksheet.WriteNumber (PCell, Double) | Writes a floating-point number to a cell, does not change the number format
TsWorksheet.WriteNumber (PCell, Double, TsNumberFormat, Byte) | Writes a floating-point number to a cell
TsWorksheet.WriteNumber (PCell, Double, TsNumberFormat, String) | Writes a floating point number to the cell and uses a custom number format specified by the format string. Note that fpspreadsheet may not be able to detect the formatting when reading the file.
Group

TsWorksheet Methods


TsWorksheet.WriteNumber Method (Cardinal, Cardinal, double)

TsWorksheet.WriteNumber Method (Cardinal, Cardinal, double)
Syntax
Pascal
function WriteNumber(ARow: Cardinal; ACol: Cardinal; ANumber: double): PCell; overload;
Parameters
Parameters | Description
ARow: Cardinal | Cell row index
ACol: Cardinal | Cell column index
ANumber: double | Number to be written
Returns

Pointer to cell created or used

Description

Writes a floating-point number to a cell, does not change the number format

Group

WriteNumber Method


TsWorksheet.WriteNumber Method (Cardinal, Cardinal, double, TsNumberFormat, Byte)

TsWorksheet.WriteNumber Method (Cardinal, Cardinal, double, TsNumberFormat, Byte)
Syntax
Pascal
function WriteNumber(ARow: Cardinal; ACol: Cardinal; ANumber: double; ANumFormat: TsNumberFormat; ADecimals: Byte = 2): PCell; overload;
Parameters
Parameters | Description
ARow: Cardinal | Cell row index
ACol: Cardinal | Cell column index
ANumber: double | Number to be written
ANumFormat: TsNumberFormat | Identifier for a built-in number format, e.g. nfFixed (optional)
ADecimals: Byte = 2 | Number of decimal places used for formatting (optional)
Returns

Pointer to cell created or used

Description

Writes a floating-point number to a cell

See Also

TsNumberFormat

Group

WriteNumber Method


TsWorksheet.WriteNumber Method (Cardinal, Cardinal, double, TsNumberFormat, String)

TsWorksheet.WriteNumber Method (Cardinal, Cardinal, double, TsNumberFormat, String)
Syntax
Pascal
function WriteNumber(ARow: Cardinal; ACol: Cardinal; ANumber: double; ANumFormat: TsNumberFormat; ANumFormatString: String): PCell; overload;
Group

WriteNumber Method


TsWorksheet.WriteNumber Method (PCell, Double)

TsWorksheet.WriteNumber Method (PCell, Double)
Syntax
Pascal
procedure WriteNumber(ACell: PCell; ANumber: Double); overload;
Parameters
Parameters | Description
ACell: PCell | Pointer to the cell
ANumber: Double | Number to be written
Description

Writes a floating-point number to a cell, does not change the number format

Group

WriteNumber Method


TsWorksheet.WriteNumber Method (PCell, Double, TsNumberFormat, Byte)

TsWorksheet.WriteNumber Method (PCell, Double, TsNumberFormat, Byte)
Syntax
Pascal
procedure WriteNumber(ACell: PCell; ANumber: Double; ANumFormat: TsNumberFormat; ADecimals: Byte = 2); overload;
Parameters
Parameters | Description
ACell: PCell | Pointer to the cell
ANumber: Double | Number to be written
ANumFormat: TsNumberFormat | Identifier for a built-in number format, e.g. nfFixed
ADecimals: Byte = 2 | Optional number of decimal places used for formatting If ANumFormat is nfFraction the ADecimals defines the digits of Numerator and denominator.
Description

Writes a floating-point number to a cell

See Also

TsNumberFormat

Group

WriteNumber Method


TsWorksheet.WriteNumber Method (PCell, Double, TsNumberFormat, String)

TsWorksheet.WriteNumber Method (PCell, Double, TsNumberFormat, String)
Syntax
Pascal
procedure WriteNumber(ACell: PCell; ANumber: Double; ANumFormat: TsNumberFormat; ANumFormatString: String); overload;
Parameters
Parameters | Description
ACell: PCell | Pointer to the cell considered
ANumber: Double | Number to be written
ANumFormat: TsNumberFormat | Format identifier (nfCustom)
ANumFormatString: String | String of formatting codes (such as 'dd/mmm' )
Description

Writes a floating point number to the cell and uses a custom number format specified by the format string. Note that fpspreadsheet may not be able to detect the formatting when reading the file.

Group

WriteNumber Method


WriteNumberFormat Method

WriteNumberFormat Method

This is the overview for the WriteNumberFormat method overload.

Overload List
Name | Description
TsWorksheet.WriteNumberFormat (Cardinal, Cardinal, TsNumberFormat, Integer, String, Integer, Integer) | Adds a number format to the formatting of a cell
TsWorksheet.WriteNumberFormat (Cardinal, Cardinal, TsNumberFormat, String) | Adds a number format to the formatting of a cell
TsWorksheet.WriteNumberFormat (PCell, TsNumberFormat, Integer, String, Integer, Integer) | Adds a number format to the formatting of a cell
TsWorksheet.WriteNumberFormat (PCell, TsNumberFormat, String) | Adds a number format to the formatting of a cell
Group

TsWorksheet Methods


TsWorksheet.WriteNumberFormat Method (Cardinal, Cardinal, TsNumberFormat, Integer, String, Integer, Integer)

TsWorksheet.WriteNumberFormat Method (Cardinal, Cardinal, TsNumberFormat, Integer, String, Integer, Integer)
Syntax
Pascal
function WriteNumberFormat(ARow: Cardinal; ACol: Cardinal; ANumFormat: TsNumberFormat; ADecimals: Integer; ACurrencySymbol: String = ''; APosCurrFormat: Integer = -1; ANegCurrFormat: Integer = -1): PCell; overload;
Parameters
Parameters | Description
ARow: Cardinal | The row of the cell
ACol: Cardinal | The column of the cell
ANumFormat: TsNumberFormat | Identifier of the format to be applied
ADecimals: Integer | Number of decimal places
ACurrencySymbol: String = '' | optional currency symbol in case of nfCurrency
APosCurrFormat: Integer = -1 | optional identifier for positive currencies
ANegCurrFormat: Integer = -1 | optional identifier for negative currencies
Returns

Pointer to the cell

Description

Adds a number format to the formatting of a cell

See Also

TsNumberFormat

Group

WriteNumberFormat Method


TsWorksheet.WriteNumberFormat Method (Cardinal, Cardinal, TsNumberFormat, String)

TsWorksheet.WriteNumberFormat Method (Cardinal, Cardinal, TsNumberFormat, String)
Syntax
Pascal
function WriteNumberFormat(ARow: Cardinal; ACol: Cardinal; ANumFormat: TsNumberFormat; const ANumFormatString: String = ''): PCell; overload;
Parameters
Parameters | Description
ARow: Cardinal | The row of the cell
ACol: Cardinal | The column of the cell
ANumFormat: TsNumberFormat | Identifier of the format to be applied
const ANumFormatString: String = '' | Optional string of formatting codes. Is only considered if ANumberFormat is nfCustom.
Returns

Pointer to the cell

Description

Adds a number format to the formatting of a cell

See Also

TsNumberFormat

Group

WriteNumberFormat Method


TsWorksheet.WriteNumberFormat Method (PCell, TsNumberFormat, Integer, String, Integer, Integer)

TsWorksheet.WriteNumberFormat Method (PCell, TsNumberFormat, Integer, String, Integer, Integer)
Syntax
Pascal
procedure WriteNumberFormat(ACell: PCell; ANumFormat: TsNumberFormat; ADecimals: Integer; ACurrencySymbol: String = ''; APosCurrFormat: Integer = -1; ANegCurrFormat: Integer = -1); overload;
Parameters
Parameters | Description
ANumFormat: TsNumberFormat | Identifier of the format to be applied
ADecimals: Integer | Number of decimal places
ACurrencySymbol: String = '' | optional currency symbol in case of nfCurrency
APosCurrFormat: Integer = -1 | optional identifier for positive currencies
ANegCurrFormat: Integer = -1 | optional identifier for negative currencies
ARow | The row of the cell
ACol | The column of the cell
Description

Adds a number format to the formatting of a cell

See Also

TsNumberFormat

Group

WriteNumberFormat Method


TsWorksheet.WriteNumberFormat Method (PCell, TsNumberFormat, String)

TsWorksheet.WriteNumberFormat Method (PCell, TsNumberFormat, String)
Syntax
Pascal
procedure WriteNumberFormat(ACell: PCell; ANumFormat: TsNumberFormat; const ANumFormatString: String = ''); overload;
Parameters
Parameters | Description
ACell: PCell | Pointer to the cell considered
ANumFormat: TsNumberFormat | Identifier of the format to be applied
const ANumFormatString: String = '' | Optional string of formatting codes. Is only considered if ANumberFormat is nfCustom.
Description

Adds a number format to the formatting of a cell

See Also

TsNumberFormat

Group

WriteNumberFormat Method


TsWorksheet.WriteRowHeight Method

TsWorksheet.WriteRowHeight Method
Syntax
Pascal
procedure WriteRowHeight(ARow: Cardinal; AHeight: Single);
Parameters
Parameters | Description
ARow: Cardinal | Index of the row to be considered
AHeight: Single | Row height to be assigned to the row. The row height is expressed as the line count of the default font size.
Description

Sets the row height for a given row. Creates a new row record if it does not yet exist.

Group

TsWorksheet Methods


TsWorksheet.WriteRowInfo Method

TsWorksheet.WriteRowInfo Method
Syntax
Pascal
procedure WriteRowInfo(ARow: Cardinal; AData: TRow);
Parameters
Parameters | Description
ARow: Cardinal | Index of the row record which will be created or modified
AData: TRow | Data to be written.
Description

Writes a row record for the row at a given index to the spreadsheet. Currently the row record contains only the row height (and the row index, of course).

Creates a new row record if it does not yet exist.

Group

TsWorksheet Methods


WriteRPNFormula Method

WriteRPNFormula Method

This is the overview for the WriteRPNFormula method overload.

Overload List
Name | Description
TsWorksheet.WriteRPNFormula (Cardinal, Cardinal, TsRPNFormula) | Writes an RPN formula to a cell. An RPN formula is an array of tokens describing the calculation to be performed.
TsWorksheet.WriteRPNFormula (PCell, TsRPNFormula) | Writes an RPN formula to a cell. An RPN formula is an array of tokens describing the calculation to be performed. In addition,the RPN formula is converted to a string formula.
Group

TsWorksheet Methods


TsWorksheet.WriteRPNFormula Method (Cardinal, Cardinal, TsRPNFormula)

TsWorksheet.WriteRPNFormula Method (Cardinal, Cardinal, TsRPNFormula)
Syntax
Pascal
function WriteRPNFormula(ARow: Cardinal; ACol: Cardinal; AFormula: TsRPNFormula): PCell; overload;
Parameters
Parameters | Description
ARow: Cardinal | Row indows of the cell considered
ACol: Cardinal | Column index of the cell
AFormula: TsRPNFormula | Array of TsFormulaElements. The array can be created by using "CreateRPNFormla".
Returns

Pointer to the cell

Description

Writes an RPN formula to a cell. An RPN formula is an array of tokens describing the calculation to be performed.

See Also

TsNumberFormat, TsFormulaElements, CreateRPNFormula

Group

WriteRPNFormula Method


TsWorksheet.WriteRPNFormula Method (PCell, TsRPNFormula)

TsWorksheet.WriteRPNFormula Method (PCell, TsRPNFormula)
Syntax
Pascal
procedure WriteRPNFormula(ACell: PCell; AFormula: TsRPNFormula); overload;
Parameters
Parameters | Description
ACell: PCell | Pointer to the cell
AFormula: TsRPNFormula | Array of TsFormulaElements. The array can be created by using "CreateRPNFormla".
Description

Writes an RPN formula to a cell. An RPN formula is an array of tokens describing the calculation to be performed. In addition,the RPN formula is converted to a string formula.

See Also

TsNumberFormat, TsFormulaElements, CreateRPNFormula

Group

WriteRPNFormula Method


WriteText Method

WriteText Method

This is the overview for the WriteText method overload.

Overload List
Name | Description
TsWorksheet.WriteText (Cardinal, Cardinal, String, TsRichTextParams) | Writes UTF-8 encoded text to a cell. On formats that don't support unicode, the text will be converted to ISO Latin 1.
TsWorksheet.WriteText (PCell, String, TsRichTextParams) | Writes UTF-8 encoded text to a cell.
Group

TsWorksheet Methods


TsWorksheet.WriteText Method (Cardinal, Cardinal, String, TsRichTextParams)

TsWorksheet.WriteText Method (Cardinal, Cardinal, String, TsRichTextParams)
Syntax
Pascal
function WriteText(ARow: Cardinal; ACol: Cardinal; AText: String; ARichTextParams: TsRichTextParams = nil): PCell; overload;
Parameters
Parameters | Description
ARow: Cardinal | The row of the cell
ACol: Cardinal | The column of the cell
AText: String | The text to be written encoded in utf-8
ARichTextParams: TsRichTextParams = nil | Array of formatting instructions for characters or groups of characters (see TsRichTextParam).
Returns

Pointer to cell created or used

Description

Writes UTF-8 encoded text to a cell.

On formats that don't support unicode, the text will be converted to ISO Latin 1.

See Also

TsRichTextParams, TsRichTextParam

Group

WriteText Method


TsWorksheet.WriteText Method (PCell, String, TsRichTextParams)

TsWorksheet.WriteText Method (PCell, String, TsRichTextParams)
Syntax
Pascal
procedure WriteText(ACell: PCell; AText: String; ARichTextparams: TsRichTextParams = nil); overload;
Parameters
Parameters | Description
ACell: PCell | Pointer to the cell
AText: String | The text to be written encoded in utf-8
ARichTextparams: TsRichTextParams = nil | Array of formatting instructions for characters or groups of characters (see TsRichTextParam).
Description

Writes UTF-8 encoded text to a cell.

See Also

TsRichTextParams, TsRichTextParam

Group

WriteText Method


WriteTextAsHTML Method

WriteTextAsHTML Method

This is the overview for the WriteTextAsHTML method overload.

Overload List
Name | Description
TsWorksheet.WriteTextAsHTML (Cardinal, Cardinal, String) | Writes text containing HTML codes to a cell. Here are the allowed HTML codes: , ... bold text , ........ italic text , ....... underlined text , ....... strike-out text ............ subscript ............ superscript ...... full font selection. "tags" can be: face="..." ... font name size="..." ... font size, in pt, em, px, % (add units!) color="..." .. font color (e.g. red, or #FF0000).
TsWorksheet.WriteTextAsHTML (PCell, String) | Writes text containing HTML codes to a cell. Here are the allowed HTML codes: , ... bold text , ........ italic text , ....... underlined text , ....... strike-out text ............ subscript ............ superscript ...... full font selection. "tags" can be: face="..." ... font name size="..." ... font size, in pt, em, px, % (add units!) color="..." .. font color (e.g. red, or #FF0000).
Group

TsWorksheet Methods


TsWorksheet.WriteTextAsHTML Method (Cardinal, Cardinal, String)

TsWorksheet.WriteTextAsHTML Method (Cardinal, Cardinal, String)
Syntax
Pascal
function WriteTextAsHTML(ARow: Cardinal; ACol: Cardinal; AText: String): PCell; overload;
Parameters
Parameters | Description
ARow: Cardinal | The row of the cell
ACol: Cardinal | The column of the cell
AText: String | The text containing the html codes
Returns

Pointer to cell created or used

Description

Writes text containing HTML codes to a cell. Here are the allowed HTML codes: , ... bold text , ........ italic text , ....... underlined text , ....... strike-out text ............ subscript ............ superscript ...... full font selection. "tags" can be: face="..." ... font name size="..." ... font size, in pt, em, px, % (add units!) color="..." .. font color (e.g. red, or #FF0000).

See Also

TsRichTextParams, TsRichTextParam

Group

WriteTextAsHTML Method


TsWorksheet.WriteTextAsHTML Method (PCell, String)

TsWorksheet.WriteTextAsHTML Method (PCell, String)
Syntax
Pascal
procedure WriteTextAsHTML(ACell: PCell; AText: String); overload;
Parameters
Parameters | Description
ACell: PCell | Pointer to the cell
AText: String | The text containing the html codes
Description

Writes text containing HTML codes to a cell. Here are the allowed HTML codes: , ... bold text , ........ italic text , ....... underlined text , ....... strike-out text ............ subscript ............ superscript ...... full font selection. "tags" can be: face="..." ... font name size="..." ... font size, in pt, em, px, % (add units!) color="..." .. font color (e.g. red, or #FF0000).

See Also

TsRichTextParams, TsRichTextParam

Group

WriteTextAsHTML Method


WriteTextRotation Method

WriteTextRotation Method

This is the overview for the WriteTextRotation method overload.

Overload List
Name | Description
TsWorksheet.WriteTextRotation (Cardinal, Cardinal, TsTextRotation) | Adds text rotation to the formatting of a cell
TsWorksheet.WriteTextRotation (PCell, TsTextRotation) | Adds text rotation to the formatting of a cell
Group

TsWorksheet Methods


TsWorksheet.WriteTextRotation Method (Cardinal, Cardinal, TsTextRotation)

TsWorksheet.WriteTextRotation Method (Cardinal, Cardinal, TsTextRotation)
Syntax
Pascal
function WriteTextRotation(ARow: Cardinal; ACol: Cardinal; ARotation: TsTextRotation): PCell; overload;
Parameters
Parameters | Description
ARow: Cardinal | The row of the cell
ACol: Cardinal | The column of the cell
ARotation: TsTextRotation | How to rotate the text
Returns

Pointer to cell

Description

Adds text rotation to the formatting of a cell

See Also

TsTextRotation

Group

WriteTextRotation Method


TsWorksheet.WriteTextRotation Method (PCell, TsTextRotation)

TsWorksheet.WriteTextRotation Method (PCell, TsTextRotation)
Syntax
Pascal
procedure WriteTextRotation(ACell: PCell; ARotation: TsTextRotation); overload;
Parameters
Parameters | Description
ACell: PCell | Pointer to the cell
ARotation: TsTextRotation | How to rotate the text
Description

Adds text rotation to the formatting of a cell

See Also

TsTextRotation

Group

WriteTextRotation Method


WriteUsedFormatting Method

WriteUsedFormatting Method

This is the overview for the WriteUsedFormatting method overload.

Overload List
Name | Description
TsWorksheet.WriteUsedFormatting (Cardinal, Cardinal, TsUsedFormattingFields) | Directly modifies the used formatting fields of a cell. Only formatting corresponding to items included in this set is executed.
TsWorksheet.WriteUsedFormatting (PCell, TsUsedFormattingFields) | Directly modifies the used formatting fields of an existing cell. Only formatting corresponding to items included in this set is executed.
Group

TsWorksheet Methods


TsWorksheet.WriteUsedFormatting Method (Cardinal, Cardinal, TsUsedFormattingFields)

TsWorksheet.WriteUsedFormatting Method (Cardinal, Cardinal, TsUsedFormattingFields)
Syntax
Pascal
function WriteUsedFormatting(ARow: Cardinal; ACol: Cardinal; AUsedFormatting: TsUsedFormattingFields): PCell; overload;
Parameters
Parameters | Description
ARow: Cardinal | The row of the cell
ACol: Cardinal | The column of the cell
AUsedFormatting: TsUsedFormattingFields | set of the used formatting fields
Returns

Pointer to the (existing or created) cell

Description

Directly modifies the used formatting fields of a cell. Only formatting corresponding to items included in this set is executed.

See Also

TsUsedFormattingFields, TCell

Group

WriteUsedFormatting Method


TsWorksheet.WriteUsedFormatting Method (PCell, TsUsedFormattingFields)

TsWorksheet.WriteUsedFormatting Method (PCell, TsUsedFormattingFields)
Syntax
Pascal
procedure WriteUsedFormatting(ACell: PCell; AUsedFormatting: TsUsedFormattingFields); overload;
Parameters
Parameters | Description
ACell: PCell | Pointer to the cell to be modified
AUsedFormatting: TsUsedFormattingFields | set of the used formatting fields
Description

Directly modifies the used formatting fields of an existing cell. Only formatting corresponding to items included in this set is executed.

See Also

TsUsedFormattingFields, TCell

Group

WriteUsedFormatting Method


WriteUTF8Text Method

WriteUTF8Text Method

This is the overview for the WriteUTF8Text method overload.

Overload List
Name | Description
TsWorksheet.WriteUTF8Text (Cardinal, Cardinal, String, TsRichTextParams) |
TsWorksheet.WriteUTF8Text (PCell, String, TsRichTextParams) |
Group

TsWorksheet Methods


TsWorksheet.WriteUTF8Text Method (Cardinal, Cardinal, String, TsRichTextParams)

TsWorksheet.WriteUTF8Text Method (Cardinal, Cardinal, String, TsRichTextParams)
Syntax
Pascal
function WriteUTF8Text(ARow: Cardinal; ACol: Cardinal; AText: String; ARichTextParams: TsRichTextParams = nil): PCell; overload; deprecated;
Group

WriteUTF8Text Method


TsWorksheet.WriteUTF8Text Method (PCell, String, TsRichTextParams)

TsWorksheet.WriteUTF8Text Method (PCell, String, TsRichTextParams)
Syntax
Pascal
procedure WriteUTF8Text(ACell: PCell; AText: String; ARichTextparams: TsRichTextParams = nil); overload; deprecated;
Group

WriteUTF8Text Method


WriteVertAlignment Method

WriteVertAlignment Method

This is the overview for the WriteVertAlignment method overload.

Overload List
Name | Description
TsWorksheet.WriteVertAlignment (Cardinal, Cardinal, TsVertAlignment) | Defines the vertical alignment of text in a cell.
TsWorksheet.WriteVertAlignment (PCell, TsVertAlignment) | Defines the vertical alignment of text in a cell.
Group

TsWorksheet Methods


TsWorksheet.WriteVertAlignment Method (Cardinal, Cardinal, TsVertAlignment)

TsWorksheet.WriteVertAlignment Method (Cardinal, Cardinal, TsVertAlignment)
Syntax
Pascal
function WriteVertAlignment(ARow: Cardinal; ACol: Cardinal; AValue: TsVertAlignment): PCell; overload;
Parameters
Parameters | Description
ARow: Cardinal | Row index of the cell considered
ACol: Cardinal | Column index of the cell considered
AValue: TsVertAlignment | Parameter for vertical text alignment (vaDefault, vaTop, vaCenter, vaBottom) By default, texts are bottom-aligned.
Returns

Pointer to cell

Description

Defines the vertical alignment of text in a cell.

Group

WriteVertAlignment Method


TsWorksheet.WriteVertAlignment Method (PCell, TsVertAlignment)

TsWorksheet.WriteVertAlignment Method (PCell, TsVertAlignment)
Syntax
Pascal
procedure WriteVertAlignment(ACell: PCell; AValue: TsVertAlignment); overload;
Parameters
Parameters | Description
ACell: PCell | Poiner to the cell considered
AValue: TsVertAlignment | Parameter for vertical text alignment (vaDefault, vaTop, vaCenter, vaBottom) By default, texts are bottom-aligned.
Description

Defines the vertical alignment of text in a cell.

Group

WriteVertAlignment Method


WriteWordwrap Method

WriteWordwrap Method

This is the overview for the WriteWordwrap method overload.

Overload List
Name | Description
TsWorksheet.WriteWordwrap (Cardinal, Cardinal, boolean) | Enables or disables the word-wrapping feature for a cell.
TsWorksheet.WriteWordwrap (PCell, boolean) | Enables or disables the word-wrapping feature for a cell.
Group

TsWorksheet Methods


TsWorksheet.WriteWordwrap Method (Cardinal, Cardinal, boolean)

TsWorksheet.WriteWordwrap Method (Cardinal, Cardinal, boolean)
Syntax
Pascal
function WriteWordwrap(ARow: Cardinal; ACol: Cardinal; AValue: boolean): PCell; overload;
Parameters
Parameters | Description
ARow: Cardinal | Row index of the cell considered
ACol: Cardinal | Column index of the cell considered
AValue: boolean | true = word-wrapping enabled, false = disabled.
Returns

Pointer to cell

Description

Enables or disables the word-wrapping feature for a cell.

Group

WriteWordwrap Method


TsWorksheet.WriteWordwrap Method (PCell, boolean)

TsWorksheet.WriteWordwrap Method (PCell, boolean)
Syntax
Pascal
procedure WriteWordwrap(ACell: PCell; AValue: boolean); overload;
Parameters
Parameters | Description
AValue: boolean | true = word-wrapping enabled, false = disabled.
ACel | Pointer to the cell considered
Description

Enables or disables the word-wrapping feature for a cell.

Group

WriteWordwrap Method


TsWorksheet Properties

TsWorksheet Properties

The properties of the TsWorksheet class are listed here.

Class

TsWorksheet Class

Public Properties
Name | Description
ActiveCellCol | Column index of the selected cell of this worksheet
ActiveCellRow | Row index of the selected cell of this worksheet
BiDiMode |
Cells | List of cells of the worksheet. Only cells with contents or with formatting are listed
Cols | List of all column records of the worksheet having a non-standard column width
Comments | List of all comment records
DefaultColWidth | The default column width given in "character units" (width of the character "0" in the default font)
DefaultRowHeight | The default row height is given in "line count" (height of the default font
FormatSettings | FormatSettings for localization of some formatting strings
Hyperlinks | List of hyperlink information records
LeftPaneWidth | Number of frozen columns which do not scroll
MergedCells | List of merged cells (contains TsCellRange records)
Name | Name of the sheet. In the popular spreadsheet applications this is displayed at the tab of the sheet.
Options | Parameters controlling visibility of grid lines and row/column headers, usage of frozen panes etc.
PageLayout | Parameters to be used for printing by the Office applications
Rows | List of all row records of the worksheet having a non-standard row height
TopPaneHeight | Number of frozen rows which do not scroll
Workbook | Workbook to which the worksheet belongs


TsWorksheet.ActiveCellCol Property

TsWorksheet.ActiveCellCol Property
Syntax
Pascal
property ActiveCellCol: Cardinal;
Description

Column index of the selected cell of this worksheet

Group

TsWorksheet Properties


TsWorksheet.ActiveCellRow Property

TsWorksheet.ActiveCellRow Property
Syntax
Pascal
property ActiveCellRow: Cardinal;
Description

Row index of the selected cell of this worksheet

Group

TsWorksheet Properties


TsWorksheet.BiDiMode Property

TsWorksheet.BiDiMode Property
Syntax
Pascal
property BiDiMode: TsBiDiMode;
Group

TsWorksheet Properties


TsWorksheet.Cells Property

TsWorksheet.Cells Property
Syntax
Pascal
property Cells: TsCells;
Description

List of cells of the worksheet. Only cells with contents or with formatting are listed

Group

TsWorksheet Properties


TsWorksheet.Cols Property

TsWorksheet.Cols Property
Syntax
Pascal
property Cols: TIndexedAVLTree;
Description

List of all column records of the worksheet having a non-standard column width

Group

TsWorksheet Properties


TsWorksheet.Comments Property

TsWorksheet.Comments Property
Syntax
Pascal
property Comments: TsComments;
Description

List of all comment records

Group

TsWorksheet Properties


TsWorksheet.DefaultColWidth Property

TsWorksheet.DefaultColWidth Property
Syntax
Pascal
property DefaultColWidth: Single;
Description

The default column width given in "character units" (width of the character "0" in the default font)

Group

TsWorksheet Properties


TsWorksheet.DefaultRowHeight Property

TsWorksheet.DefaultRowHeight Property
Syntax
Pascal
property DefaultRowHeight: Single;
Description

The default row height is given in "line count" (height of the default font

Group

TsWorksheet Properties


TsWorksheet.FormatSettings Property

TsWorksheet.FormatSettings Property
Syntax
Pascal
property FormatSettings: TFormatSettings;
Description

FormatSettings for localization of some formatting strings

Group

TsWorksheet Properties


TsWorksheet.Hyperlinks Property

TsWorksheet.Hyperlinks Property
Syntax
Pascal
property Hyperlinks: TsHyperlinks;
Description

List of hyperlink information records

Group

TsWorksheet Properties


TsWorksheet.LeftPaneWidth Property

TsWorksheet.LeftPaneWidth Property
Syntax
Pascal
property LeftPaneWidth: Integer;
Description

Number of frozen columns which do not scroll

Group

TsWorksheet Properties


TsWorksheet.MergedCells Property

TsWorksheet.MergedCells Property
Syntax
Pascal
property MergedCells: TsMergedCells;
Description

List of merged cells (contains TsCellRange records)

Group

TsWorksheet Properties


TsWorksheet.Name Property

TsWorksheet.Name Property
Syntax
Pascal
property Name: string;
Description

Name of the sheet. In the popular spreadsheet applications this is displayed at the tab of the sheet.

Group

TsWorksheet Properties


TsWorksheet.Options Property

TsWorksheet.Options Property
Syntax
Pascal
property Options: TsSheetOptions;
Description

Parameters controlling visibility of grid lines and row/column headers, usage of frozen panes etc.

Group

TsWorksheet Properties


TsWorksheet.PageLayout Property

TsWorksheet.PageLayout Property
Syntax
Pascal
property PageLayout: TsPageLayout;
Description

Parameters to be used for printing by the Office applications

Group

TsWorksheet Properties


TsWorksheet.Rows Property

TsWorksheet.Rows Property
Syntax
Pascal
property Rows: TIndexedAVLTree;
Description

List of all row records of the worksheet having a non-standard row height

Group

TsWorksheet Properties


TsWorksheet.TopPaneHeight Property

TsWorksheet.TopPaneHeight Property
Syntax
Pascal
property TopPaneHeight: Integer;
Description

Number of frozen rows which do not scroll

Group

TsWorksheet Properties


TsWorksheet.Workbook Property

TsWorksheet.Workbook Property
Syntax
Pascal
property Workbook: TsWorkbook;
Description

Workbook to which the worksheet belongs

Group

TsWorksheet Properties


TsWorksheet Events

TsWorksheet Events

The events of the TsWorksheet class are listed here.

Class

TsWorksheet Class

Public Events
Name | Description
OnChangeCell | Event fired when cell contents or formatting changes
OnChangeFont | Event fired when the font size in a cell changes
OnCompareCells | Event to override cell comparison for sorting
OnSelectCell | Event fired when a cell is "selected".


TsWorksheet.OnChangeCell Event

TsWorksheet.OnChangeCell Event
Syntax
Pascal
property OnChangeCell: TsCellEvent;
Description

Event fired when cell contents or formatting changes

Group

TsWorksheet Events


TsWorksheet.OnChangeFont Event

TsWorksheet.OnChangeFont Event
Syntax
Pascal
property OnChangeFont: TsCellEvent;
Description

Event fired when the font size in a cell changes

Group

TsWorksheet Events


TsWorksheet.OnCompareCells Event

TsWorksheet.OnCompareCells Event
Syntax
Pascal
property OnCompareCells: TsCellCompareEvent;
Description

Event to override cell comparison for sorting

Group

TsWorksheet Events


TsWorksheet.OnSelectCell Event

TsWorksheet.OnSelectCell Event
Syntax
Pascal
property OnSelectCell: TsCellEvent;
Description

Event fired when a cell is "selected".

Group

TsWorksheet Events


TsWorksheetGrid Class

TsWorksheetGrid Class
Class Hierarchy
  TsWorksheetGridTsWorksheetGridTsWorksheetGrid
Syntax
Pascal
TsWorksheetGrid = class(TsCustomWorksheetGrid);
File

fpspreadsheetgrid

Description

TsWorksheetGrid is a grid which displays spreadsheet data along with formatting. As it is linked to an instance of TsWorkbook, it provides methods for reading data from or writing to spreadsheet files. It has the same funtionality as TsCustomWorksheetGrid, but has published all properties.

Group

Classes


TsWorksheetGrid Members

TsWorksheetGrid Members

The following tables list the members exposed by TsWorksheetGrid.

Class

TsWorksheetGrid Class

Protected Methods
Name | Description
AutoAdjustColumn | Is called when goDblClickAutoSize is in the grid's options and a double click has occured at the border of a column header. Sets optimum column with.
AutoAdjustRow | Is called when goDblClickAutoSize is in the grid's options and a double click has occured at the border of a row header. Sets optimum row height.
AutoExpandToCol | Automatically expands the ColCount such that the specified column fits in
AutoExpandToRow | Automatically expands the RowCount such that the specified column fits in
CalcWorksheetColWidth | Converts the column height given in screen pixels to the units used by the worksheet.
CalcWorksheetRowHeight | Converts the row height given in screen pixels to the units used by the worksheet.
CellOverflow | Looks for overflowing cells: if the text of the given cell is longer than the cell width the function calculates the column indexes and the rectangle to show the complete text. Ony for non-wordwrapped label cells and for horizontal orientation. Function returns false if text overflow needs not to be considered.
CreateNewWorkbook | Creates a new empty workbook into which a file will be loaded. Destroys the previously used workbook.
DblClick | Is called when a Double-click occurs. Overrides the inherited method to react on double click on cell border in row headers to auto-adjust the row heights
DefineProperties |
DoCopyToClipboard |
DoCutToClipboard |
DoEditorShow |
DoOnResize |
DoPasteFromClipboard |
DoPrepareCanvas | Adjusts the grid's canvas before painting a given cell. Considers background color, horizontal alignment, vertical alignment, etc.
DrawAllRows | This method is inherited from TsCustomGrid, but is overridden here in order to paint the cell borders and the selection rectangle. Both features can extend into the neighboring cells and thus would be clipped at the cell borders by the standard painting mechanism. At the time when DrawAllRows is called, however, clipping at cell borders is no longer active.
DrawCellBorders | This is the overview for the DrawCellBorders method overload.
DrawCellGrid | Method inherited method from TCustomGrid. Is overridden here to avoid painting of the border of frozen cells in black under some circumstances.
DrawCommentMarker | Draws the red rectangle in the upper right corner of a cell to indicate that this cell contains a popup comment
DrawFocusRect | This procedure is responsible for painting the focus rectangle. We don't want the red dashed rectangle here, but prefer the thick Excel-like black border line. This new focus rectangle is drawn by the method DrawSelection because the thick Excel border reaches into adjacent cells.
DrawFrozenPaneBorders | Draws a solid line along the borders of frozen panes.
DrawRow | Draws a complete row of cells. Is mostly duplicated from Grids.pas, but adds code for merged cells and overflow text, the section for drawing the default focus rectangle is removed.
DrawSelection | Draws the selection rectangle around selected cells.
DrawTextInCell | Draws the cell text. Calls "GetCellText" to determine the text for the cell. Takes care of horizontal and vertical text alignment, text rotation and text wrapping.
ExecuteHyperlink | Executes a hyperlink stored in the FHyperlinkCell
GetCellHeight | Returns the height (in pixels) of the cell at ACol/ARow (of the grid).
GetCellHintText | This function defines the text to be displayed as a cell hint. By default, it is the comment and/or the hyperlink attached to a cell; it can further be modified by using the OnGetCellHint event. Option goCellHints must be active for the cell hint feature to work.
GetCellText | This function returns the text to be shown in a grid cell. The text is looked up in the corresponding cell of the worksheet by calling its ReadAsUTF8Text method. In case of "stacked" text rotation, line endings are inserted after each character.
GetDefaultHeaderColWidth | Returns the width of the fixed header column 0, in pixels
GetEditText | Determines the text to be passed to the cell editor. The text is determined from the underlying worksheet cell, but it is possible to intercept this by adding a handler for the OnGetEditText event.
HasBorder | Returns true if the cell has the given border. In case of merged cell the borders of the merge base are checked. Inner merged cells don't have a border.
HeaderSized | Inherited from TCustomGrid. Is called when column widths or row heights have changed. Stores the new column width or row height in the worksheet.
HeaderSizing | HeaderSizing is called while a column width or row height is resized by the mouse. Is overridden here to enforce a grid repaint if merged cells are affected by the resizing column/row. Otherwise parts of the merged cells would not be updated if the cell text moves during the resizing action.
InternalDrawTextInCell | Internal general text drawing method.
KeyDown | Standard key handling method inherited from TCustomGrid. Is overridden to catch some keys for special processing.
Loaded | Standard method inherited from TCustomGrid. Is overridden to create an empty workbook
MouseDown | Standard mouse down handler. Is overridden here to handle hyperlinks and to enter "enhanced edit mode" which removes formatting from the values and presents formulas for editing.
MouseMove | Standard mouse move handler. Is overridden because, if TextOverflow is active, overflown cell may be erased when the mouse leaves them; repaints entire grid instead.
MouseUp |
MoveSelection | Standard method inherited from TCustomGrid. Notifies the WorkbookSource of the changed selected cell. Repaints the grid after moving selection to avoid spurious rests of the old thick selection border.
Notification | Standard component notification: The grid is notified that the WorkbookLink is being removed.
SelectEditor | Standard method inherited from TCustomGrid: Is called when editing starts. Is overridden here to store the old text just in case that the user presses ESC to cancel editing.
SelPenChangeHandler |
SetEditText | Standard method inherited from TCustomGrid. Fetches the text that is currently in the editor. It is not yet transferred to the worksheet because input will be checked only at the end of editing.
Setup | Helper method for setting up the rows and columns after a new workbook is loaded or created. Sets up the grid's column and row count, as well as the initial column widths and row heights.
Sort | Sorts the grid by calling the corresponding method of the worksheet. Sorting extends across the entire worksheet. Sort direction is determined by the property "SortOrder". Other sorting criteria are "case-sensitive" and "numbers first".
TopLeftChanged | Inherited method called whenever to grid is scrolled, i.e. the top/left cell changes. Is overridden to calculate the row heights of the currently visible grid
TrimToCell | Modifies the text that is show for cells which are too narrow to hold the entire text. The method follows the behavior of Excel and Open/LibreOffice: If the specified cell contains a non-formatted number, then it is formatted such that the text fits into the cell. If the text is still too long or the cell does not contain a label then the cell is filled by '#' characters. Label cell texts are not modified, they can overflow into the adjacent cells.
UpdateColWidths | Updates column widths according to the data in the TCol records
UpdateRowHeights | Updates row heights by using the data from the TRow records or by auto- calculating the row height from the max of the cell heights
Public Methods
Name | Description
BeginUpdate | The BeginUpdate/EndUpdate pair suppresses unnecessary painting of the grid. Call BeginUpdate to stop refreshing the grid, and call EndUpdate to release the lock and to repaint the grid again.
CellRect |
Convert_Font_to_sFont | Converts a font used for painting (TCanvas.Font) to a spreadsheet font.
Convert_sFont_to_Font | Converts a spreadsheet font to a font used for painting (TCanvas.Font).
Create | Constructor of the grid. Activates the display of column and row headers and creates an internal "CellFont". Creates a pre-defined number of empty rows and columns.
DefaultDrawCell | This is one of the main painting methods inherited from TsCustomGrid. It is overridden here to achieve the feature of "frozen" cells which should be painted in the same style as normal cells. Internally, "frozen" cells are "fixed" cells of the grid. Therefore, it is not possible to select any cell within the frozen panes - in contrast to the standard spreadsheet applications.
DeleteCol | Deletes the column specified.
DeleteRow | Deletes the row specified.
Destroy | Destructor of the grid: Destroys the workbook and the internal CellFont.
EditingDone | This procedure is called when editing of a cell is completed. It determines the worksheet cell and writes the text into the worksheet. Tries to keep the format of the cell, but if it is a new cell, or the content type has changed, tries to figure out the content type (number, date/time, text).
EndUpdate | The BeginUpdate/EndUpdate pair suppresses unnecessary painting of the grid. Call BeginUpdate to stop refreshing the grid, and call EndUpdate to release the lock and to repaint the grid again.
GetGridCol | Converts a column index of the worksheet to a column index usable in the grid. This is required because worksheet indexes always start at zero while grid indexes also have to account for the column/row headers.
GetGridRow | Converts a row index of the worksheet to a row index usable in the grid. This is required because worksheet indexes always start at zero while grid indexes also have to account for the column/row headers.
GetSheets | Returns a list of worksheets contained in the file. Useful for assigning to user controls like TabControl, Combobox etc. in order to select a sheet.
GetWorksheetCol | Calculates the index of the worksheet column that is displayed in the given column of the grid. If the sheet headers are turned on, both numbers differ by 1, otherwise they are equal. Saves an "if" in cases.
GetWorksheetRow | Calculates the index of the worksheet row that is displayed in the given row of the grid. If the sheet headers are turned on, both numbers differ by 1, otherwise they are equal. Saves an "if" in some cases.
InsertCol | Inserts an empty column before the column specified
InsertRow | Inserts an empty row before the row specified
ListenerNotification |
ListenerNotification | Notification message received from the WorkbookLink telling which item of the spreadsheet has changed.
LoadFromSpreadsheetFile | This is the overview for the LoadFromSpreadsheetFile method overload.
LoadFromWorkbook | Loads an existing workbook into the grid.
MergeCells | This is the overview for the MergeCells method overload.
NewWorkbook | Creates a new empty workbook with the specified number of columns and rows.
RemoveWorkbookSource |
RemoveWorkbookSource | Removes the link of the WorksheetGrid to the WorkbookSource. Required before destruction.
SaveToSpreadsheetFile | This is the overview for the SaveToSpreadsheetFile method overload.
SelectSheetByIndex | Loads the workbook into the grid and selects the sheet with the given index. "Selected" means here that the sheet is loaded into the grid.
ShowCellBorders | Shows cell borders for the cells in the range between columns ALeft and ARight and rows ATop and ABottom. The border of the block's left outer edge is defined by ALeftOuterStyle, that of the block's top outer edge by ATopOuterStyle, etc. Set the color of a border style to scNotDefined or scTransparent in order to hide the corresponding border line, or use the constant NO_CELL_BORDER.
UnmergeCells | This is the overview for the UnmergeCells method overload.
Public Properties
Name | Description
BackgroundColor | Background color of the cell at the given column and row. Expressed as index into the workbook's color palette.
BackgroundColors | Common background color of the cells covered by the given rectangle. Expressed as index into the workbook's color palette.
CellBiDiMode | Override system or sheet right-to-left mode for cell
CellBorder | Set of flags indicating at which cell border a border line is drawn.
CellBorders | Set of flags indicating at which border of a range of cells a border line is drawn
CellBorderStyle | Style of the border line at the given border of the cell at column ACol and row ARow. Requires the cellborder flag of the border to be set for the border line to be shown
CellBorderStyles | Style of the border line at the given border of the cells within the range of colum/row indexes defined by the rectangle. Requires the cellborder flag of the border to be set for the border line to be shown
CellComment | Comment assigned to the cell at column ACol and row ARow
CellFont | Font to be used for text in the cell at column ACol and row ARow.
CellFontColor | Color of the font used for the cell in column ACol and row ARow
CellFontColors | Color of the font used for the cells within the range of column/row indexes defined by the rectangle, scUndefined if not constant.
CellFontName | Name of the font used for the cell in column ACol and row ARow
CellFontNames | Name of the font used for the cells within the range of column/row indexes defined by the rectangle.
CellFonts | Font to be used for the cells in the column/row index range given by the rectangle
CellFontSize | Size of the font (in points) used for the cell at column ACol and row ARow
CellFontSizes | Size of the font (in points) used for the cells within the range of column/row indexes defined by the rectangle.
CellFontStyle | Style of the font (bold, italic, ...) used for text in the cell at column ACol and row ARow.
CellFontStyles | Style of the font (bold, italic, ...) used for the cells within the range of column/row indexes defined by the rectangle.
Cells | Cell values
ColWidths | Column width, in pixels
HeaderCount | Count of header lines - for conversion between grid- and workbook-based row and column indexes. Either 1 if row and column headers are shown or 0 if not
HorAlignment | Parameter for horizontal text alignment within the cell at column ACol and row ARow
HorAlignments | Parameter for the horizontal text alignments in all cells within the range cf column/row indexes defined by the rectangle.
Hyperlink | Hyperlink assigned to the cell in row ARow and column ACol
NumberFormat | Number format (as Excel string) to be applied to cell at column ACol and row ARow.
NumberFormats | Number format (as Excel string) to be applied to all cells within the range of column/row indexes defined by the rectangle.
RangeSelectMode | Allow multiple selections
RowHeights | Row height in pixels
TextRotation | Rotation of the text in the cell at column ACol and row ARow.
TextRotations | Rotation of the text in the cells within the range of column/row indexes defined by the rectangle.
VertAlignment | Parameter for vertical text alignment in the cell at column ACol and row ARow.
VertAlignments | Parameter for vertical text alignment in the cells having column/row indexes defined by the rectangle.
Wordwrap | If true, word-wrapping of text within the cell at column ACol and row ARow is activated.
Wordwraps | If true, word-wrapping of text within all cells within the range defined by the rectangle is activated.
Workbook | Workbook displayed in the grid
Worksheet | Currently selected worksheet of the workbook
Published Events
Name | Description
OnClickHyperlink | inherited from TCustomWorksheetGrid
Published Properties
Name | Description
Align | inherited from ancestors
AlternateColor | inherited from ancestors
Anchors | inherited from ancestors
AutoAdvance | inherited from ancestors
AutoCalc | Automatically recalculates the worksheet if a cell value changes.
AutoEdit | inherited from ancestors
AutoExpand | Automatically expand grid dimensions
AutoFillColumns | inherited from ancestors
BorderSpacing | inherited from ancestors
BorderStyle | inherited from ancestors
CellHintPriority | inherited from ancestors
ColCount | inherited from ancestors
Color | inherited from ancestors
Constraints | inherited from ancestors
DefaultColWidth | inherited from ancestors
DefaultDrawing | inherited from ancestors
DefaultRowHeight | inherited from ancestors
DisplayFixedColRow | Displays column and row headers in the fixed col/row style of the grid. Deprecated. Use ShowHeaders instead.
DragCursor | inherited from ancestors
DragKind | inherited from ancestors
DragMode | inherited from ancestors
Enabled | inherited from ancestors
ExtendedSelect | inherited from ancestors
FixedColor | inherited from ancestors
Flat | inherited from ancestors
Font | inherited from ancestors
FrozenCols | This number of columns at the left is "frozen", i.e. it is not possible to scroll these columns.
FrozenRows | This number of rows at the top is "frozen", i.e. it is not possible to scroll these rows.
GridLineWidth | inherited from ancestors
HeaderHotZones | inherited from ancestors
HeaderPushZones | inherited from ancestors
MouseWheelOption | inherited from ancestors
OnBeforeSelection | inherited from ancestors
OnChangeBounds | inherited from ancestors
OnClick | inherited from ancestors
OnColRowDeleted | inherited from ancestors
OnColRowExchanged | inherited from ancestors
OnColRowInserted | inherited from ancestors
OnColRowMoved | inherited from ancestors
OnContextPopup | inherited from ancestors
OnDblClick | inherited from ancestors
OnDragDrop | inherited from ancestors
OnDragOver | inherited from ancestors
OnDrawCell | inherited from ancestors
OnEditButtonClick | inherited from ancestors
OnEditingDone | inherited from ancestors
OnEndDock | inherited from ancestors
OnEndDrag | inherited from ancestors
OnEnter | inherited from ancestors
OnExit | inherited from ancestors
OnGetEditMask | inherited from ancestors
OnGetEditText | inherited from ancestors
OnHeaderClick | inherited from ancestors
OnHeaderSized | inherited from ancestors
OnHeaderSizing | inherited from ancestors
OnKeyDown | inherited from ancestors
OnKeyPress | inherited from ancestors
OnKeyUp | inherited from ancestors
OnMouseDown | inherited from ancestors
OnMouseMove | inherited from ancestors
OnMouseUp | inherited from ancestors
OnMouseWheel | inherited from ancestors
OnMouseWheelDown | inherited from ancestors
OnMouseWheelUp | inherited from ancestors
OnPickListSelect | inherited from ancestors
OnPrepareCanvas | inherited from ancestors
OnResize | inherited from ancestors
OnSelectCell | inherited from ancestors
OnSelectEditor | inherited from ancestors
OnSelection | inherited from ancestors
OnSetEditText | inherited from ancestors
OnShowHint | inherited from ancestors
OnStartDock | inherited from ancestors
OnStartDrag | inherited from ancestors
OnTopLeftChanged | inherited from ancestors
OnUTF8KeyPress | inherited from ancestors
OnValidateEntry | inherited from ancestors
Options | inherited from TCustomGrid. Select the option goEditing to make the grid editable!
ParentBiDiMode | inherited from ancestors
ParentColor | inherited from ancestors
ParentFont | inherited from ancestors
ParentShowHint | inherited from ancestors
PopupMenu | inherited from ancestors
ReadFormulas | Activates reading of RPN formulas. Should be turned off when non-implemented formulas crashe reading of the spreadsheet file.
RowCount | inherited from ancestors
ScrollBars | inherited from ancestors
SelectionPen | Pen used for drawing the selection rectangle
ShowGridLines | Shows/hides vertical and horizontal grid lines.
ShowHeaders | Shows/hides column and row headers in the fixed col/row style of the grid.
ShowHint | inherited from ancestors
TabOrder | inherited from ancestors
TabStop | inherited from ancestors
TextOverflow | Activates text overflow (cells reaching into neighbors)
TitleFont | inherited from ancestors
TitleImageList | inherited from ancestors
TitleStyle | inherited from ancestors
UseXORFeatures | inherited from ancestors
Visible | inherited from ancestors
VisibleColCount | inherited from ancestors
VisibleRowCount | inherited from ancestors
WorkbookSource | Link to the workbook


TsWorksheetGrid Properties

TsWorksheetGrid Properties

The properties of the TsWorksheetGrid class are listed here.

Class

TsWorksheetGrid Class

Published Properties
Name | Description
Align | inherited from ancestors
AlternateColor | inherited from ancestors
Anchors | inherited from ancestors
AutoAdvance | inherited from ancestors
AutoCalc | Automatically recalculates the worksheet if a cell value changes.
AutoEdit | inherited from ancestors
AutoExpand | Automatically expand grid dimensions
AutoFillColumns | inherited from ancestors
BorderSpacing | inherited from ancestors
BorderStyle | inherited from ancestors
CellHintPriority | inherited from ancestors
ColCount | inherited from ancestors
Color | inherited from ancestors
Constraints | inherited from ancestors
DefaultColWidth | inherited from ancestors
DefaultDrawing | inherited from ancestors
DefaultRowHeight | inherited from ancestors
DisplayFixedColRow | Displays column and row headers in the fixed col/row style of the grid. Deprecated. Use ShowHeaders instead.
DragCursor | inherited from ancestors
DragKind | inherited from ancestors
DragMode | inherited from ancestors
Enabled | inherited from ancestors
ExtendedSelect | inherited from ancestors
FixedColor | inherited from ancestors
Flat | inherited from ancestors
Font | inherited from ancestors
FrozenCols | This number of columns at the left is "frozen", i.e. it is not possible to scroll these columns.
FrozenRows | This number of rows at the top is "frozen", i.e. it is not possible to scroll these rows.
GridLineWidth | inherited from ancestors
HeaderHotZones | inherited from ancestors
HeaderPushZones | inherited from ancestors
MouseWheelOption | inherited from ancestors
OnBeforeSelection | inherited from ancestors
OnChangeBounds | inherited from ancestors
OnClick | inherited from ancestors
OnColRowDeleted | inherited from ancestors
OnColRowExchanged | inherited from ancestors
OnColRowInserted | inherited from ancestors
OnColRowMoved | inherited from ancestors
OnContextPopup | inherited from ancestors
OnDblClick | inherited from ancestors
OnDragDrop | inherited from ancestors
OnDragOver | inherited from ancestors
OnDrawCell | inherited from ancestors
OnEditButtonClick | inherited from ancestors
OnEditingDone | inherited from ancestors
OnEndDock | inherited from ancestors
OnEndDrag | inherited from ancestors
OnEnter | inherited from ancestors
OnExit | inherited from ancestors
OnGetEditMask | inherited from ancestors
OnGetEditText | inherited from ancestors
OnHeaderClick | inherited from ancestors
OnHeaderSized | inherited from ancestors
OnHeaderSizing | inherited from ancestors
OnKeyDown | inherited from ancestors
OnKeyPress | inherited from ancestors
OnKeyUp | inherited from ancestors
OnMouseDown | inherited from ancestors
OnMouseMove | inherited from ancestors
OnMouseUp | inherited from ancestors
OnMouseWheel | inherited from ancestors
OnMouseWheelDown | inherited from ancestors
OnMouseWheelUp | inherited from ancestors
OnPickListSelect | inherited from ancestors
OnPrepareCanvas | inherited from ancestors
OnResize | inherited from ancestors
OnSelectCell | inherited from ancestors
OnSelectEditor | inherited from ancestors
OnSelection | inherited from ancestors
OnSetEditText | inherited from ancestors
OnShowHint | inherited from ancestors
OnStartDock | inherited from ancestors
OnStartDrag | inherited from ancestors
OnTopLeftChanged | inherited from ancestors
OnUTF8KeyPress | inherited from ancestors
OnValidateEntry | inherited from ancestors
Options | inherited from TCustomGrid. Select the option goEditing to make the grid editable!
ParentBiDiMode | inherited from ancestors
ParentColor | inherited from ancestors
ParentFont | inherited from ancestors
ParentShowHint | inherited from ancestors
PopupMenu | inherited from ancestors
ReadFormulas | Activates reading of RPN formulas. Should be turned off when non-implemented formulas crashe reading of the spreadsheet file.
RowCount | inherited from ancestors
ScrollBars | inherited from ancestors
SelectionPen | Pen used for drawing the selection rectangle
ShowGridLines | Shows/hides vertical and horizontal grid lines.
ShowHeaders | Shows/hides column and row headers in the fixed col/row style of the grid.
ShowHint | inherited from ancestors
TabOrder | inherited from ancestors
TabStop | inherited from ancestors
TextOverflow | Activates text overflow (cells reaching into neighbors)
TitleFont | inherited from ancestors
TitleImageList | inherited from ancestors
TitleStyle | inherited from ancestors
UseXORFeatures | inherited from ancestors
Visible | inherited from ancestors
VisibleColCount | inherited from ancestors
VisibleRowCount | inherited from ancestors
WorkbookSource | Link to the workbook


TsWorksheetGrid.Align Property

TsWorksheetGrid.Align Property
Syntax
Pascal
property Align;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.AlternateColor Property

TsWorksheetGrid.AlternateColor Property
Syntax
Pascal
property AlternateColor;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.Anchors Property

TsWorksheetGrid.Anchors Property
Syntax
Pascal
property Anchors;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.AutoAdvance Property

TsWorksheetGrid.AutoAdvance Property
Syntax
Pascal
property AutoAdvance;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.AutoCalc Property

TsWorksheetGrid.AutoCalc Property
Syntax
Pascal
property AutoCalc: Boolean;
Description

Automatically recalculates the worksheet if a cell value changes.

Group

TsWorksheetGrid Properties


TsWorksheetGrid.AutoEdit Property

TsWorksheetGrid.AutoEdit Property
Syntax
Pascal
property AutoEdit;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.AutoExpand Property

TsWorksheetGrid.AutoExpand Property
Syntax
Pascal
property AutoExpand: TsAutoExpandModes;
Description

Automatically expand grid dimensions

Group

TsWorksheetGrid Properties


TsWorksheetGrid.AutoFillColumns Property

TsWorksheetGrid.AutoFillColumns Property
Syntax
Pascal
property AutoFillColumns;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.BorderSpacing Property

TsWorksheetGrid.BorderSpacing Property
Syntax
Pascal
property BorderSpacing;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.BorderStyle Property

TsWorksheetGrid.BorderStyle Property
Syntax
Pascal
property BorderStyle;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.CellHintPriority Property

TsWorksheetGrid.CellHintPriority Property
Syntax
Pascal
property CellHintPriority;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.ColCount Property

TsWorksheetGrid.ColCount Property
Syntax
Pascal
property ColCount;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.Color Property

TsWorksheetGrid.Color Property
Syntax
Pascal
property Color;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.Constraints Property

TsWorksheetGrid.Constraints Property
Syntax
Pascal
property Constraints;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.DefaultColWidth Property

TsWorksheetGrid.DefaultColWidth Property
Syntax
Pascal
property DefaultColWidth: Integer;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.DefaultDrawing Property

TsWorksheetGrid.DefaultDrawing Property
Syntax
Pascal
property DefaultDrawing;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.DefaultRowHeight Property

TsWorksheetGrid.DefaultRowHeight Property
Syntax
Pascal
property DefaultRowHeight: Integer;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.DisplayFixedColRow Property

TsWorksheetGrid.DisplayFixedColRow Property
Syntax
Pascal
property DisplayFixedColRow: Boolean;
Description

Displays column and row headers in the fixed col/row style of the grid. Deprecated. Use ShowHeaders instead.

Group

TsWorksheetGrid Properties


TsWorksheetGrid.DragCursor Property

TsWorksheetGrid.DragCursor Property
Syntax
Pascal
property DragCursor;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.DragKind Property

TsWorksheetGrid.DragKind Property
Syntax
Pascal
property DragKind;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.DragMode Property

TsWorksheetGrid.DragMode Property
Syntax
Pascal
property DragMode;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.Enabled Property

TsWorksheetGrid.Enabled Property
Syntax
Pascal
property Enabled;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.ExtendedSelect Property

TsWorksheetGrid.ExtendedSelect Property
Syntax
Pascal
property ExtendedSelect;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.FixedColor Property

TsWorksheetGrid.FixedColor Property
Syntax
Pascal
property FixedColor;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.Flat Property

TsWorksheetGrid.Flat Property
Syntax
Pascal
property Flat;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.Font Property

TsWorksheetGrid.Font Property
Syntax
Pascal
property Font;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.FrozenCols Property

TsWorksheetGrid.FrozenCols Property
Syntax
Pascal
property FrozenCols: Integer;
Description

This number of columns at the left is "frozen", i.e. it is not possible to scroll these columns.

Group

TsWorksheetGrid Properties


TsWorksheetGrid.FrozenRows Property

TsWorksheetGrid.FrozenRows Property
Syntax
Pascal
property FrozenRows: Integer;
Description

This number of rows at the top is "frozen", i.e. it is not possible to scroll these rows.

Group

TsWorksheetGrid Properties


TsWorksheetGrid.GridLineWidth Property

TsWorksheetGrid.GridLineWidth Property
Syntax
Pascal
property GridLineWidth;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.HeaderHotZones Property

TsWorksheetGrid.HeaderHotZones Property
Syntax
Pascal
property HeaderHotZones;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.HeaderPushZones Property

TsWorksheetGrid.HeaderPushZones Property
Syntax
Pascal
property HeaderPushZones;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.MouseWheelOption Property

TsWorksheetGrid.MouseWheelOption Property
Syntax
Pascal
property MouseWheelOption;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.OnBeforeSelection Property

TsWorksheetGrid.OnBeforeSelection Property
Syntax
Pascal
property OnBeforeSelection;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.OnChangeBounds Property

TsWorksheetGrid.OnChangeBounds Property
Syntax
Pascal
property OnChangeBounds;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.OnClick Property

TsWorksheetGrid.OnClick Property
Syntax
Pascal
property OnClick;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.OnColRowDeleted Property

TsWorksheetGrid.OnColRowDeleted Property
Syntax
Pascal
property OnColRowDeleted;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.OnColRowExchanged Property

TsWorksheetGrid.OnColRowExchanged Property
Syntax
Pascal
property OnColRowExchanged;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.OnColRowInserted Property

TsWorksheetGrid.OnColRowInserted Property
Syntax
Pascal
property OnColRowInserted;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.OnColRowMoved Property

TsWorksheetGrid.OnColRowMoved Property
Syntax
Pascal
property OnColRowMoved;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.OnContextPopup Property

TsWorksheetGrid.OnContextPopup Property
Syntax
Pascal
property OnContextPopup;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.OnDblClick Property

TsWorksheetGrid.OnDblClick Property
Syntax
Pascal
property OnDblClick;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.OnDragDrop Property

TsWorksheetGrid.OnDragDrop Property
Syntax
Pascal
property OnDragDrop;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.OnDragOver Property

TsWorksheetGrid.OnDragOver Property
Syntax
Pascal
property OnDragOver;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.OnDrawCell Property

TsWorksheetGrid.OnDrawCell Property
Syntax
Pascal
property OnDrawCell;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.OnEditButtonClick Property

TsWorksheetGrid.OnEditButtonClick Property
Syntax
Pascal
property OnEditButtonClick;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.OnEditingDone Property

TsWorksheetGrid.OnEditingDone Property
Syntax
Pascal
property OnEditingDone;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.OnEndDock Property

TsWorksheetGrid.OnEndDock Property
Syntax
Pascal
property OnEndDock;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.OnEndDrag Property

TsWorksheetGrid.OnEndDrag Property
Syntax
Pascal
property OnEndDrag;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.OnEnter Property

TsWorksheetGrid.OnEnter Property
Syntax
Pascal
property OnEnter;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.OnExit Property

TsWorksheetGrid.OnExit Property
Syntax
Pascal
property OnExit;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.OnGetEditMask Property

TsWorksheetGrid.OnGetEditMask Property
Syntax
Pascal
property OnGetEditMask;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.OnGetEditText Property

TsWorksheetGrid.OnGetEditText Property
Syntax
Pascal
property OnGetEditText;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.OnHeaderClick Property

TsWorksheetGrid.OnHeaderClick Property
Syntax
Pascal
property OnHeaderClick;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.OnHeaderSized Property

TsWorksheetGrid.OnHeaderSized Property
Syntax
Pascal
property OnHeaderSized;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.OnHeaderSizing Property

TsWorksheetGrid.OnHeaderSizing Property
Syntax
Pascal
property OnHeaderSizing;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.OnKeyDown Property

TsWorksheetGrid.OnKeyDown Property
Syntax
Pascal
property OnKeyDown;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.OnKeyPress Property

TsWorksheetGrid.OnKeyPress Property
Syntax
Pascal
property OnKeyPress;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.OnKeyUp Property

TsWorksheetGrid.OnKeyUp Property
Syntax
Pascal
property OnKeyUp;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.OnMouseDown Property

TsWorksheetGrid.OnMouseDown Property
Syntax
Pascal
property OnMouseDown;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.OnMouseMove Property

TsWorksheetGrid.OnMouseMove Property
Syntax
Pascal
property OnMouseMove;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.OnMouseUp Property

TsWorksheetGrid.OnMouseUp Property
Syntax
Pascal
property OnMouseUp;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.OnMouseWheel Property

TsWorksheetGrid.OnMouseWheel Property
Syntax
Pascal
property OnMouseWheel;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.OnMouseWheelDown Property

TsWorksheetGrid.OnMouseWheelDown Property
Syntax
Pascal
property OnMouseWheelDown;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.OnMouseWheelUp Property

TsWorksheetGrid.OnMouseWheelUp Property
Syntax
Pascal
property OnMouseWheelUp;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.OnPickListSelect Property

TsWorksheetGrid.OnPickListSelect Property
Syntax
Pascal
property OnPickListSelect;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.OnPrepareCanvas Property

TsWorksheetGrid.OnPrepareCanvas Property
Syntax
Pascal
property OnPrepareCanvas;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.OnResize Property

TsWorksheetGrid.OnResize Property
Syntax
Pascal
property OnResize;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.OnSelectCell Property

TsWorksheetGrid.OnSelectCell Property
Syntax
Pascal
property OnSelectCell;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.OnSelectEditor Property

TsWorksheetGrid.OnSelectEditor Property
Syntax
Pascal
property OnSelectEditor;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.OnSelection Property

TsWorksheetGrid.OnSelection Property
Syntax
Pascal
property OnSelection;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.OnSetEditText Property

TsWorksheetGrid.OnSetEditText Property
Syntax
Pascal
property OnSetEditText;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.OnShowHint Property

TsWorksheetGrid.OnShowHint Property
Syntax
Pascal
property OnShowHint;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.OnStartDock Property

TsWorksheetGrid.OnStartDock Property
Syntax
Pascal
property OnStartDock;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.OnStartDrag Property

TsWorksheetGrid.OnStartDrag Property
Syntax
Pascal
property OnStartDrag;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.OnTopLeftChanged Property

TsWorksheetGrid.OnTopLeftChanged Property
Syntax
Pascal
property OnTopLeftChanged;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.OnUTF8KeyPress Property

TsWorksheetGrid.OnUTF8KeyPress Property
Syntax
Pascal
property OnUTF8KeyPress;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.OnValidateEntry Property

TsWorksheetGrid.OnValidateEntry Property
Syntax
Pascal
property OnValidateEntry;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.Options Property

TsWorksheetGrid.Options Property
Syntax
Pascal
property Options;
Description

inherited from TCustomGrid. Select the option goEditing to make the grid editable!

Group

TsWorksheetGrid Properties


TsWorksheetGrid.ParentBiDiMode Property

TsWorksheetGrid.ParentBiDiMode Property
Syntax
Pascal
property ParentBiDiMode;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.ParentColor Property

TsWorksheetGrid.ParentColor Property
Syntax
Pascal
property ParentColor;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.ParentFont Property

TsWorksheetGrid.ParentFont Property
Syntax
Pascal
property ParentFont;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.ParentShowHint Property

TsWorksheetGrid.ParentShowHint Property
Syntax
Pascal
property ParentShowHint;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.PopupMenu Property

TsWorksheetGrid.PopupMenu Property
Syntax
Pascal
property PopupMenu;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.ReadFormulas Property

TsWorksheetGrid.ReadFormulas Property
Syntax
Pascal
property ReadFormulas: Boolean;
Description

Activates reading of RPN formulas. Should be turned off when non-implemented formulas crashe reading of the spreadsheet file.

Group

TsWorksheetGrid Properties


TsWorksheetGrid.RowCount Property

TsWorksheetGrid.RowCount Property
Syntax
Pascal
property RowCount;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.ScrollBars Property

TsWorksheetGrid.ScrollBars Property
Syntax
Pascal
property ScrollBars;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.SelectionPen Property

TsWorksheetGrid.SelectionPen Property
Syntax
Pascal
property SelectionPen: TsSelPen;
Description

Pen used for drawing the selection rectangle

Group

TsWorksheetGrid Properties


TsWorksheetGrid.ShowGridLines Property

TsWorksheetGrid.ShowGridLines Property
Syntax
Pascal
property ShowGridLines: Boolean;
Description

Shows/hides vertical and horizontal grid lines.

Group

TsWorksheetGrid Properties


TsWorksheetGrid.ShowHeaders Property

TsWorksheetGrid.ShowHeaders Property
Syntax
Pascal
property ShowHeaders: Boolean;
Description

Shows/hides column and row headers in the fixed col/row style of the grid.

Group

TsWorksheetGrid Properties


TsWorksheetGrid.ShowHint Property

TsWorksheetGrid.ShowHint Property
Syntax
Pascal
property ShowHint;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.TabOrder Property

TsWorksheetGrid.TabOrder Property
Syntax
Pascal
property TabOrder;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.TabStop Property

TsWorksheetGrid.TabStop Property
Syntax
Pascal
property TabStop;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.TextOverflow Property

TsWorksheetGrid.TextOverflow Property
Syntax
Pascal
property TextOverflow: Boolean;
Description

Activates text overflow (cells reaching into neighbors)

Group

TsWorksheetGrid Properties


TsWorksheetGrid.TitleFont Property

TsWorksheetGrid.TitleFont Property
Syntax
Pascal
property TitleFont;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.TitleImageList Property

TsWorksheetGrid.TitleImageList Property
Syntax
Pascal
property TitleImageList;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.TitleStyle Property

TsWorksheetGrid.TitleStyle Property
Syntax
Pascal
property TitleStyle;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.UseXORFeatures Property

TsWorksheetGrid.UseXORFeatures Property
Syntax
Pascal
property UseXORFeatures;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.Visible Property

TsWorksheetGrid.Visible Property
Syntax
Pascal
property Visible;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.VisibleColCount Property

TsWorksheetGrid.VisibleColCount Property
Syntax
Pascal
property VisibleColCount;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.VisibleRowCount Property

TsWorksheetGrid.VisibleRowCount Property
Syntax
Pascal
property VisibleRowCount;
Description

inherited from ancestors

Group

TsWorksheetGrid Properties


TsWorksheetGrid.WorkbookSource Property

TsWorksheetGrid.WorkbookSource Property
Syntax
Pascal
property WorkbookSource: TsWorkbookSource;
Description

Link to the workbook

Group

TsWorksheetGrid Properties


TsWorksheetGrid Events

TsWorksheetGrid Events

The events of the TsWorksheetGrid class are listed here.

Class

TsWorksheetGrid Class

Published Events
Name | Description
OnClickHyperlink | inherited from TCustomWorksheetGrid


TsWorksheetGrid.OnClickHyperlink Event

TsWorksheetGrid.OnClickHyperlink Event
Syntax
Pascal
property OnClickHyperlink: TsHyperlinkClickEvent;
Description

inherited from TCustomWorksheetGrid

Group

TsWorksheetGrid Events


Interfaces

Interfaces

The following table lists interfaces in this documentation.

Interfaces
Name | Description
IsSpreadsheetControl | Interface which allows the workbook source to notify linked controls of changes in the associated workbook.


IsSpreadsheetControl Interface

IsSpreadsheetControl Interface
Class Hierarchy
  IsSpreadsheetControl
Syntax
Pascal
IsSpreadsheetControl = interface;
File

fpspreadsheetctrls

Description

Interface which allows the workbook source to notify linked controls of changes in the associated workbook.

Group

Interfaces


IsSpreadsheetControl Members

IsSpreadsheetControl Members

The following tables list the members exposed by IsSpreadsheetControl.

Interface

IsSpreadsheetControl Interface

Public Methods
Name | Description
ListenerNotification |
RemoveWorkbookSource |


IsSpreadsheetControl Methods

IsSpreadsheetControl Methods

The methods of the IsSpreadsheetControl class are listed here.

Interface

IsSpreadsheetControl Interface

Public Methods
Name | Description
ListenerNotification |
RemoveWorkbookSource |


IsSpreadsheetControl.ListenerNotification Method

IsSpreadsheetControl.ListenerNotification Method
Syntax
Pascal
[GUID_SpreadsheetControl]
procedure ListenerNotification(AChangedItems: TsNotificationItems; AData: Pointer = nil);
Group

IsSpreadsheetControl Methods


IsSpreadsheetControl.RemoveWorkbookSource Method

IsSpreadsheetControl.RemoveWorkbookSource Method
Syntax
Pascal
procedure RemoveWorkbookSource;
Group

IsSpreadsheetControl Methods


Functions

Functions

The following table lists functions in this documentation.

Functions
Name | Description
AddAMPM | Adds an AM/PM format code to a pre-built time formatting string. The strings replacing "AM" or "PM" in the final formatted number are taken from the TimeAMString or TimePMString of the specified FormatSettings.
AddIntervalBrackets | The given format string is assumed to represent a time interval, i.e. its first time symbol must be enclosed by square brackets. Checks if this is true, and adds the brackes if not.
AnalyzeCompareStr |
AppendToStream |
AppendToStream | Appends two strings to a stream
AppendToStream | Appends three strings to a stream
ApplyTextFormat | Applies a text format to a text. The text placeholder is @. Supports appending and prepending text.
BuildCurrencyFormatList | Builds a string list with samples of the predefined currency formats
BuildCurrencyFormatString | Builds a currency format string. The presentation of negative values (brackets, or minus signs) is taken from the provided format settings. The format string consists of three sections, separated by semicolons.
BuildDateTimeFormatString | Builds a date/time format string from the number format code.
BuildFormatStringFromSection | Creates a format string for the specified parsed number format section. The format string is created according to Excel convention (which is understood by ODS as well).
BuildFractionFormatString | Builds a number format string for fraction formatting from the number format code and the count of numerator and denominator digits.
BuildNumberFormatString | Builds a number format string from the number format code and the count of decimal places.
cmToPts | Converts centimeters to points (72 pts = 1 inch)
ColorToHTMLColorStr | Converts an rgb color value to a string as used in HTML code (for ods)
ConvertFloatToStr | Converts a floating point number to a string as determined by the specified number format parameters
CopyCellFormat | Copies the format of a cell to another one.
CopyCellValue | Copies the value of a cell to another one. Does not copy the formula, erases the formula of the destination cell if there is one!
CountDecs | Counts how many decimal places are coded into a given number format string.
DWordLEtoN | Converts a DWord value from little-endian to big-endian byte-order.
DWordToLE | DWordLEToLE converts a DWord value from big-endian to little-endian byte-order.
EMUToIn | Converts EMU (English metric units) to inches
EMUToMM | Converts EMU to millimeters
EnsureOrder |
EnsureOrder | Helper procedure which guarantees that a is not larger than b
FixHyperlinkPathDelims | Replaces backslashes by forward slashes in hyperlink path names
FixLineEndings | Replaces CRLF line endings by LF (#10) alone because this is what xml returns. This is required to keep the character indexes of the rich text formatting runs in synch when reading xml files.
FloatToFraction | Approximates a floating point value as a fraction and returns the values of numerator and denominator.
GetCellRangeString | Calculates a cell range address string from zero-based column and row indexes and the relative address state flags.
GetCellRangeString | Calculates a cell range address string from a TsCellRange record and the relative address state flags.
GetCellString | Calculates a cell address string from zero-based column and row indexes and the relative address state flags.
GetCellString_R1C1 | Calculates a cell address string in R1C1 notation from zero-based column and row indexes and the relative address state flags.
GetColorName | Determines the name of a color from its rgb value
GetColString | Calculates an Excel column name ('A', 'B' etc) from the zero-based column index
GetErrorValueStr | Returns the message text assigned to an error value
GetFileFormatName | Returns the name of the given spreadsheet file format.
GetFormatFromFileName | Determines the spreadsheet type from the file type extension
GetFormatFromFileName | Determines the spreadsheet type from the file type extension
GetImageInfo | Returns the width and height of the image loaded into the specified stream.
GetImageInfo | Returns the width and height of the image loaded into the specified stream.
GetImageMimeType | Returns the MimeType of the specified image type
GetImageTypeFromFileName | Extracts the image file type identifier from the extension of the specified file name.
GetTIFSize |
HasFormula | Returns TRUE if the cell contains a formula.
HighContrastColor | Returns the color index for black or white depending on a color being "bright" or "dark".
HTMLColorStrToColor | Converts a HTML color string to a TsColor alue. Needed for the ODS file format.
HTMLLengthStrToPts | Converts a HTML length string to points. The units are assumed to be the last two digits of the string, such as '1.25in'
IfThen |
IfThen | Helper function to reduce typing: "if a conditions is true return the first number format, otherwise return the second format"
InitCell | Initalizes a new cell and presets the row and column fields of the cell record to the parameters passed to the procedure.
InitCell | Initalizes a new cell.
InitFormatRecord | Initializes the fields of a TsCellFormaRecord
InitFormatSettings | Initializes the FormatSettings of file a import/export parameters record to default values which can be replaced by the FormatSettings of the workbook's FormatSettings
InitHeaderFooterImageRecord | Initializes the fields of a TsHeaderFooterImage record
InitImageRecord | Initializes the fields of a TsImage record
InitSortParams | Initializes a Sortparams record. This record sets paramaters used when cells are sorted.
IntegerToLE | Converts an integer value from big-endian to little-endian byte-order.
InToEMU | Converts inches to EMU (English metric units)
InToMM | Converts inches to millimeters
InToPts | Converts inches to points (72 pts = 1 inch)
IsBoolValue | Checks whether the specified text corresponds to a boolean value. For this, it must match the specified TRUE and FALSE text phrases.
IsCurrencyFormat | Checks whether the specified number format parameters apply to currency values.
IsCurrencyFormat | Checks whether the given number format code is for currency, i.e. requires a currency symbol.
IsDateFormat | Checks whether the specified number format parameters apply to a date value.
IsDateTimeFormat |
IsDateTimeFormat | Checks whether the specified number format parameters apply to date/time values.
IsDateTimeFormat | Checks whether the given number format code is for date/time values.
IsDateTimeValue | Checks whether the specified text corresponds to a date/time value and returns true, its numerical value and its built-in numberformat if it is.
IsLongTimeFormat |
IsNumberValue | Checks whether the specified text corresponds to a numerical value. If it is then the function result is TRUE, and the number value and its formatting parameters are returned.
IsPaletteIndex | Checks whether the specified TsColor represents a palette index
IsTextFormat |
IsTimeFormat | Checks whether the given string with formatting codes is for time values.
IsTimeFormat | Checks whether the specified number format parameters apply to time values.
IsTimeFormat | Checks whether the given built-in number format code is for time values.
IsTimeIntervalFormat | Checks whether the specified number format parameters is a time interval format.
LongRGBToExcelPhysical | Converts the RGB part of a LongRGB logical structure to its physical representation. In other words: RGBA (where A is 0 and omitted in the function call) => ABGR Needed for conversion of palette colors.
MakeLongDateFormat | Creates a long date format string out of a short date format string. Retains the order of year-month-day and the separators, but uses 4 digits for year and 3 digits of month.
MakeShortDateFormat | Modifies the short date format such that it has a two-digit year and a two-digit month. Retains the order of year-month-day and the separators.
MakeTimeIntervalMask | Creates a "time interval" format string having the first time code identifier in square brackets.
mmToEMU | Converts millimeters to EMU (english metric units, 1 cm = 360000 EMU)
mmToIn | Converts millimeters to inches
mmToPts | Converts millimeters to points (72 pts = 1 inch)
ParseCellColString | Parses a cell column string, like 'A' or 'CZ', into a zero-based column number. Note that there can be several letters to address more than 26 columns.
ParseCellRangeString | Parses strings like A5:C10 into a range selection information. Information on relative/absolute cells is ignored.
ParseCellRangeString | Parses strings like A5:C10 into a range selection information. Returns in AFlags also information on relative/absolute cells.
ParseCellRangeString | Parses strings like A5:C10 into a range selection information. Information on relative/absolute cells is ignored.
ParseCellRangeString | Parses strings like A5:C10 into a range selection information. Returns in AFlags also information on relative/absolute cells.
ParseCellRangeString_R1C1 | Extracts information on cell range from a cellrange string in "R1C1" notation. Returns in AFlags also information on relative/absolute cells.
ParseCellRowString | Parses a cell row string to a zero-based row number.
ParseCellString | Parses a cell string, like 'A1' into zero-based column and row numbers Note that there can be several letters to address for more than 26 columns. For compatibility with old version which does not return flags for relative cell addresses.
ParseCellString |
ParseCellString_R1C1 | Parses a cell string in "R1C1" notation into zero-based column and row numbers 'AFlags' indicates relative addresses.
ParseCellString_R1C1 | Parses a cell string in "R1C1" notation into zero-based column and row numbers For compatibility with old version which does not return flags for relative cell addresses.
ParseIntervalString | Parses strings like A5:A10 into an selection interval information
ParseSheetCellString |
PtsToCm | Converts points to centimeters
PtsToIn | Converts points to inches (72 pts = 1 inch)
PtsToMM | Converts points to millimeters
PtsToPx | Converts points to pixels
PtsToTwips | Converts points to twips (1 twip = 1/20 point)
pxToPts | Converts pixels to points.
Range | Creates a TsCellRange record from the provided cell corner coordinates. Put the coordinates into right order if needed.
Register | Registers the worksheet grid in the Lazarus component palette, page "FPSpreadsheet".
RegisterImageType | Registers an image type for usage in fpspreadsheet
ReplaceFormatSettings | Replaces in AFormatSettings all members marked as having default values (#0, 1, '') by the corresponding values of the ADefaultFormats record
SameCellBorders | Checks whether two format records have same border attributes
SameFont | Checks whether two fonts are equal
SameFont | Checks whether two fonts are equal
SetAsPaletteIndex | Constructs a TsColor from a palette index. It has bit 15 in the high-order byte set.
SplitHyperlink | Splits a hyperlink string at the # character.
SplitStr | Splits a string at the specified delimiters into individual strings and passes them in an array.
SpreadsheetFormatInClipboard | Returns TRUE if the clipboard contains a format good for pasting into a worksheet grid.
StripAMPM | Removes an AM/PM formatting code from a given time formatting string. Variants of "AM/PM" are considered as well. The string is left unchanged if it does not contain AM/PM codes.
TintedColor | Excel defines theme colors and applies a "tint" factor (-1...+1) to darken or brighten them. This method "tints" a given color with a factor The algorithm is described in http://msdn.microsoft.com/en-us/library/documentformat.openxml.spreadsheet.backgroundcolor.aspx
TryFractionStrToFloat | Assumes that the specified text is a string representation of a mathematical fraction and tries to extract the floating point value of this number. Returns also the maximum count of digits used in the numerator or denominator of the fraction
TryStrToErrorValue | Returns the error value code from a string. Result is false, if the string does not match one of the predefined error strings.
TryStrToFloatAuto | Converts a string to a floating point number. No assumption on decimal and thousand separator are made. Is needed for reading CSV files.
TwipsToPts | Excel's unit of row heights is "twips", i.e. 1/20 point. Converts Twips to points.
UnquoteStr | Removes quotation characters which enclose a string
Unused | Silence warnings due to an unused parameter
Unused | Silence warnings due to two unused parameters
Unused | Silence warnings due to three unused parameters
WideStringLEToN | Converts a widestring from little-endian to big-endian byte-order.
WideStringToLE | Converts a widestring from big-endian to little-endian byte-order.
WordLEtoN | Converts a word value from little-endian to big-endian byte-order.
WordToLE | WordLEToLE converts a word value from big-endian to little-endian byte order.


AddAMPM Function

AddAMPM Function
Syntax
Pascal
function AddAMPM(const ATimeFormatString: String; const AFormatSettings: TFormatSettings): String;
File

fpsnumformat

Parameters
Parameters | Description
const ATimeFormatString: String | String of time formatting codes (such as 'hh:nn')
const AFormatSettings: TFormatSettings | FormatSettings for locale-dependent information result Formatting string with AM/PM option activated.
Description

Adds an AM/PM format code to a pre-built time formatting string. The strings replacing "AM" or "PM" in the final formatted number are taken from the TimeAMString or TimePMString of the specified FormatSettings.

Example

ATimeFormatString = 'hh:nn' ==> 'hh:nn AM/PM'

Group

Functions


AddIntervalBrackets Function

AddIntervalBrackets Function
Syntax
Pascal
function AddIntervalBrackets(AFormatString: String): String;
File

fpsnumformat

Parameters
Parameters | Description
AFormatString: String | String with time formatting codes
Returns

Unchanged format string if its first time code is in square brackets (as in '[h]:nn:ss'). If not, the first time code is enclosed in square brackets.

Description

The given format string is assumed to represent a time interval, i.e. its first time symbol must be enclosed by square brackets. Checks if this is true, and adds the brackes if not.

Group

Functions


AnalyzeCompareStr Function

AnalyzeCompareStr Function
Syntax
Pascal
function AnalyzeCompareStr(AString: String; out ACompareOp: TsCompareOperation): String;
File

fpsutils

Group

Functions


AppendToStream Function

AppendToStream Function
Syntax
Pascal
procedure AppendToStream(AStream: TStream; const AString: String);
File

fpsutils

Group

Functions


AppendToStream Function

AppendToStream Function
Syntax
Pascal
procedure AppendToStream(AStream: TStream; const AString1: String; const AString2: String);
File

fpsutils

Parameters
Parameters | Description
AStream: TStream | Stream to which the strings will be added
const AString1: String | First string to be written to the stream
const AString2: String | Second string to be written to the stream
Description

Appends two strings to a stream

Group

Functions


AppendToStream Function

AppendToStream Function
Syntax
Pascal
procedure AppendToStream(AStream: TStream; const AString1: String; const AString2: String; const AString3: String);
File

fpsutils

Parameters
Parameters | Description
AStream: TStream | Stream to which the strings will be added
const AString1: String | First string to be written to the stream
const AString2: String | Second string to be written to the stream
const AString3: String | Third string to be written to the stream
Description

Appends three strings to a stream

Group

Functions


ApplyTextFormat Function

ApplyTextFormat Function
Syntax
Pascal
function ApplyTextFormat(AText: String; AParams: TsNumFormatParams): String;
File

fpsnumformat

Description

Applies a text format to a text. The text placeholder is @. Supports appending and prepending text.

Group

Functions


BuildCurrencyFormatList Function

BuildCurrencyFormatList Function
Syntax
Pascal
procedure BuildCurrencyFormatList(AList: TStrings; APositive: Boolean; AValue: Double; const ACurrencySymbol: String);
File

fpsnumformat

Parameters
Parameters | Description
AList: TStrings | String list in which the format samples are stored
APositive: Boolean | If true, samples are built for positive currency values, otherwise for negative values
AValue: Double | Currency value to be used when calculating the sample strings
const ACurrencySymbol: String | Currency symbol string to be used in the samples
Description

Builds a string list with samples of the predefined currency formats

Group

Functions


BuildCurrencyFormatString Function

BuildCurrencyFormatString Function
Syntax
Pascal
function BuildCurrencyFormatString(ANumberFormat: TsNumberFormat; const AFormatSettings: TFormatSettings; ADecimals: Integer; APosCurrFmt: Integer; ANegCurrFmt: Integer; ACurrencySymbol: String; Accounting: Boolean = false): String;
File

fpsnumformat

Parameters
Parameters
Description
ANumberFormat: TsNumberFormat
Identifier of the built-in number format for which the format string is to be generated.
const AFormatSettings: TFormatSettings
FormatSettings to be applied (used to extract default values for the parameters following)
ADecimals: Integer
number of decimal places. If < 0, the CurrencyDecimals of the FormatSettings is used.
APosCurrFmt: Integer
Identifier for the order of currency symbol, value and spaces of positive values
  • see pcfXXXX constants in fpsTypes.pas.
If < 0, the CurrencyFormat of the FormatSettings is used.
ANegCurrFmt: Integer
Identifier for the order of currency symbol, value and spaces of negative values. Specifies also usage of ().
  • see ncfXXXX constants in fpsTypes.pas.
If < 0, the NegCurrFormat of the FormatSettings is used.
ACurrencySymbol: String
String to identify the currency, like $ or USD. If ? the CurrencyString of the FormatSettings is used.
Accounting: Boolean = false
If true, adds spaces for alignment of decimals
Returns

String of formatting codes

Description

Builds a currency format string. The presentation of negative values (brackets, or minus signs) is taken from the provided format settings. The format string consists of three sections, separated by semicolons.

Example

'"$"#,##0.00;("$"#,##0.00);"$"0.00'

Group

Functions


BuildDateTimeFormatString Function

BuildDateTimeFormatString Function
Syntax
Pascal
function BuildDateTimeFormatString(ANumberFormat: TsNumberFormat; const AFormatSettings: TFormatSettings; AFormatString: String = ''): String;
File

fpsnumformat

Parameters
Parameters | Description
ANumberFormat: TsNumberFormat | built-in number format identifier
const AFormatSettings: TFormatSettings | Format settings from which locale-dependent information like day-month-year order is taken.
AFormatString: String = '' | Optional pre-built formatting string. It is used only for the format nfInterval where square brackets are added to the first time code field.
Returns

String of date/time formatting code constructed from the built-in format information.

Description

Builds a date/time format string from the number format code.

Group

Functions


BuildFormatStringFromSection Function

BuildFormatStringFromSection Function
Syntax
Pascal
function BuildFormatStringFromSection(const ASection: TsNumFormatSection): String;
File

fpsnumformat

Parameters
Parameters | Description
const ASection: TsNumFormatSection | Parsed section of number format elements as created by the number format parser
Returns

Excel-compatible format string

Description

Creates a format string for the specified parsed number format section. The format string is created according to Excel convention (which is understood by ODS as well).

Group

Functions


BuildFractionFormatString Function

BuildFractionFormatString Function
Syntax
Pascal
function BuildFractionFormatString(AMixedFraction: Boolean; ANumeratorDigits: Integer; ADenominatorDigits: Integer): String;
File

fpsnumformat

Parameters
Parameters | Description
AMixedFraction: Boolean | If TRUE, fraction is presented as mixed fraction
ANumeratorDigits: Integer | Count of numerator digits
ADenominatorDigits: Integer | Count of denominator digits. If the value is negative then its absolute value is inserted literally as as denominator.
Returns

String of formatting code, here something like: '##/##' or '# ##/##'

Description

Builds a number format string for fraction formatting from the number format code and the count of numerator and denominator digits.

Group

Functions


BuildNumberFormatString Function

BuildNumberFormatString Function
Syntax
Pascal
function BuildNumberFormatString(ANumberFormat: TsNumberFormat; const AFormatSettings: TFormatSettings; ADecimals: Integer = -1): String;
File

fpsnumformat

Parameters
Parameters | Description
ANumberFormat: TsNumberFormat | Identifier of the built-in numberformat for which a format string is to be generated
const AFormatSettings: TFormatSettings | FormatSettings for default parameters
ADecimals: Integer = -1 | Number of decimal places. If < 0 the CurrencyDecimals value of the FormatSettings is used. In case of a fraction format "ADecimals" refers to the maximum count digits of the denominator.
Returns

String of formatting codes

Description

Builds a number format string from the number format code and the count of decimal places.

Example

ANumberFormat = nfFixedTh, ADecimals = 2 --> '#,##0.00'

Group

Functions


cmToPts Function

cmToPts Function
Syntax
Pascal
function cmToPts(AValue: Double): Double;
File

fpsutils

Parameters
Parameters | Description
AValue: Double | Length value in centimeters
Returns

Value converted to points

Description

Converts centimeters to points (72 pts = 1 inch)

Group

Functions


ColorToHTMLColorStr Function

ColorToHTMLColorStr Function
Syntax
Pascal
function ColorToHTMLColorStr(AValue: TsColor; AExcelDialect: Boolean = false): String;
File

fpsutils

Parameters
Parameters | Description
AValue: TsColor | RGB color value (compatible with the TColor data type of the graphics unit)
AExcelDialect: Boolean = false | If TRUE, returned string is in Excels format for xlsx, i.e. in AARRGGBB notation, like '00FF0000' for "red"
Returns

HTML-compatible string, like '#FF0000' (AExcelDialect = false)

Description

Converts an rgb color value to a string as used in HTML code (for ods)

Group

Functions


ConvertFloatToStr Function

ConvertFloatToStr Function
Syntax
Pascal
function ConvertFloatToStr(AValue: Double; AParams: TsNumFormatParams; AFormatSettings: TFormatSettings): String;
File

fpsnumformat

Parameters
Parameters | Description
AValue: Double | Value to be converted to a string
AParams: TsNumFormatParams | Number format parameters which will be applied in the conversion. The number format params are obtained by the number format parser from the number format string.
AFormatSettings: TFormatSettings | Format settings needed by the number format parser for the conversion
Returns

Converted string

Description

Converts a floating point number to a string as determined by the specified number format parameters

Group

Functions


CopyCellFormat Function

CopyCellFormat Function
Syntax
Pascal
procedure CopyCellFormat(AFromCell: PCell; AToCell: PCell);
File

fpspreadsheet

Parameters
Parameters | Description
AFromCell: PCell | Cell from which the format is to be copied
AToCell: PCell | Cell to which the format is to be copied
Description

Copies the format of a cell to another one.

Group

Functions


CopyCellValue Function

CopyCellValue Function
Syntax
Pascal
procedure CopyCellValue(AFromCell: PCell; AToCell: PCell);
File

fpsutils

Parameters
Parameters | Description
AFromCell: PCell | Cell from which the value is to be copied
AToCell: PCell | Cell to which the value is to be copied
Description

Copies the value of a cell to another one. Does not copy the formula, erases the formula of the destination cell if there is one!

Group

Functions


CountDecs Function

CountDecs Function
Syntax
Pascal
function CountDecs(AFormatString: String; ADecChars: TsDecsChars = ['0']): Byte;
File

fpsnumformat

Parameters
Parameters | Description
AFormatString: String | String with number format codes, such as '0.000'
ADecChars: TsDecsChars = ['0'] | Characters which are considered as symbols for decimals. For the fixed decimals, this is the '0'. Optional decimals are encoced as '#'.
Returns

Count of decimal places found (3 in above example).

Description

Counts how many decimal places are coded into a given number format string.

Group

Functions


DWordLEtoN Function

DWordLEtoN Function
Syntax
Pascal
function DWordLEtoN(AValue: Cardinal): Cardinal;
File

fpsutils

Parameters
Parameters | Description
AValue: Cardinal | Little-endian DWord value
Returns

Big-endian DWord value

Description

Converts a DWord value from little-endian to big-endian byte-order.

Group

Functions


DWordToLE Function

DWordToLE Function
Syntax
Pascal
function DWordToLE(AValue: Cardinal): Cardinal;
File

fpsutils

Parameters
Parameters | Description
AValue: Cardinal | Big-endian DWord value
Returns

Little-endian DWord value

Description

DWordLEToLE converts a DWord value from big-endian to little-endian byte-order.

Group

Functions


EMUToIn Function

EMUToIn Function
Syntax
Pascal
function EMUToIn(AValue: Int64): Double;
File

fpsutils

Parameters
Parameters | Description
AValue: Int64 | Length value in EMU
Returns

Value converted to inches

Description

Converts EMU (English metric units) to inches

Group

Functions


EMUToMM Function

EMUToMM Function
Syntax
Pascal
function EMUToMM(AValue: Int64): Double;
File

fpsutils

Parameters
Parameters | Description
AValue: Int64 | Length value in EMU (1 cm = 360000 EMU)
Returns

Value converted to millimeters

Description

Converts EMU to millimeters

Group

Functions


EnsureOrder Function

EnsureOrder Function
Syntax
Pascal
procedure EnsureOrder(var a: Cardinal; var b: Cardinal); overload;
File

fpsutils

Group

Functions


EnsureOrder Function

EnsureOrder Function
Syntax
Pascal
procedure EnsureOrder(var a: Integer; var b: Integer); overload;
File

fpsutils

Description

Helper procedure which guarantees that a is not larger than b

Group

Functions


FixHyperlinkPathDelims Function

FixHyperlinkPathDelims Function
Syntax
Pascal
procedure FixHyperlinkPathDelims(var ATarget: String);
File

fpsutils

Description

Replaces backslashes by forward slashes in hyperlink path names

Group

Functions


FixLineEndings Function

FixLineEndings Function
Syntax
Pascal
procedure FixLineEndings(var AText: String; var ARichTextParams: TsRichTextParams);
File

fpsutils

Description

Replaces CRLF line endings by LF (#10) alone because this is what xml returns. This is required to keep the character indexes of the rich text formatting runs in synch when reading xml files.

Group

Functions


FloatToFraction Function

FloatToFraction Function
Syntax
Pascal
procedure FloatToFraction(AValue: Double; AMaxDenominator: Int64; out ANumerator: Int64; out ADenominator: Int64);
File

fpsutils

Parameters
Parameters | Description
AValue: Double | Floating point value to be analyzed
AMaxDenominator: Int64 | Maximum value of the denominator allowed
out ANumerator: Int64 | (out) Numerator of the best approximating fraction
out ADenominator: Int64 | (out) Denominator of the best approximating fraction
Description

Approximates a floating point value as a fraction and returns the values of numerator and denominator.

Group

Functions


GetCellRangeString Function

GetCellRangeString Function
Syntax
Pascal
function GetCellRangeString(ARow1: Cardinal; ACol1: Cardinal; ARow2: Cardinal; ACol2: Cardinal; AFlags: TsRelFlags = rfAllRel; Compact: Boolean = false): String; overload;
File

fpsutils

Parameters
Parameters | Description
ARow1: Cardinal | Zero-based index of the first row in the range
ACol1: Cardinal | Zero-based index of the first column in the range
ARow2: Cardinal | Zero-based index of the last row in the range
ACol2: Cardinal | Zero-based index of the last column in the range
AFlags: TsRelFlags = rfAllRel | A set containing an entry for first and last column and row if their addresses are relative.
Compact: Boolean = false | If the range consists only of a single cell and compact is true then the simple cell string is returned (e.g. A1). If compact is false then the cell is repeated (e.g. A1:A1)
Returns

Excel type of cell address range containing '$' characters for absolute address parts and a ':' to separate the first and last cells of the range

Description

Calculates a cell range address string from zero-based column and row indexes and the relative address state flags.

Example

ARow1 = 0, ACol1 = 0, ARow = 2, ACol = 1, AFlags = [rfRelRow, rfRelRow2] --> $A1:$B3

Group

Functions


GetCellRangeString Function

GetCellRangeString Function
Syntax
Pascal
function GetCellRangeString(ARange: TsCellRange; AFlags: TsRelFlags = rfAllRel; Compact: Boolean = false): String; overload;
File

fpsutils

Parameters
Parameters | Description
ARange: TsCellRange | TsCellRange record containing the zero-based indexes of the first and last row and columns of the range
AFlags: TsRelFlags = rfAllRel | A set containing an entry for first and last column and row if their addresses are relative.
Compact: Boolean = false | If the range consists only of a single cell and compact is true then the simple cell string is returned (e.g. A1). If compact is false then the cell is repeated (e.g. A1:A1)
Returns

Excel type of cell address range containing '$' characters for absolute address parts and a ':' to separate the first and last cells of the range

Description

Calculates a cell range address string from a TsCellRange record and the relative address state flags.

Group

Functions


GetCellString Function

GetCellString Function
Syntax
Pascal
function GetCellString(ARow: Cardinal; ACol: Cardinal; AFlags: TsRelFlags = [rfRelRow, rfRelCol]): String;
File

fpsutils

Parameters
Parameters | Description
AFlags: TsRelFlags = [rfRelRow, rfRelCol] | An optional set containing an entry for column and row if these addresses are relative. By default, relative addresses are assumed.
ARowIndex | Zero-based row index
AColIndex | Zero-based column index
Returns

Excel type of cell address containing $ characters for absolute address parts.

Description

Calculates a cell address string from zero-based column and row indexes and the relative address state flags.

Example

ARowIndex = 0, AColIndex = 0, AFlags = [rfRelRow] --> $A1

Group

Functions


GetCellString_R1C1 Function

GetCellString_R1C1 Function
Syntax
Pascal
function GetCellString_R1C1(ARow: Cardinal; ACol: Cardinal; AFlags: TsRelFlags = [rfRelRow, rfRelCol]; ARefRow: Cardinal = Cardinal(-1); ARefCol: Cardinal = Cardinal(-1)): String;
File

fpsutils

Parameters
Parameters | Description
ARow: Cardinal | Zero-based row index
ACol: Cardinal | Zero-based column index
AFlags: TsRelFlags = [rfRelRow, rfRelCol] | An optional set containing an entry for column and row if these addresses are relative. By default, relative addresses are assumed. param @ARefRow Zero-based row index of the reference cell in case of relative address. param @ARefCol Zero-based column index of the reference cell in case of relative address.
Returns

Excel type of cell address in R1C1 notation.

Description

Calculates a cell address string in R1C1 notation from zero-based column and row indexes and the relative address state flags.

Group

Functions


GetColorName Function

GetColorName Function
Syntax
Pascal
function GetColorName(AColor: TsColor): String;
File

fpsutils

Description

Determines the name of a color from its rgb value

Group

Functions


GetColString Function

GetColString Function
Syntax
Pascal
function GetColString(AColIndex: Integer): String;
File

fpsutils

Parameters
Parameters | Description
AColIndex: Integer | Zero-based column index
Returns

Letter-based column name string. Can contain several letter in case of more than 26 columns

Description

Calculates an Excel column name ('A', 'B' etc) from the zero-based column index

Group

Functions


GetErrorValueStr Function

GetErrorValueStr Function
Syntax
Pascal
function GetErrorValueStr(AErrorValue: TsErrorValue): String;
File

fpsutils

Parameters
Parameters | Description
AErrorValue: TsErrorValue | Error code as defined by TsErrorvalue
Returns

Text corresponding to the error code.

Description

Returns the message text assigned to an error value

Group

Functions


GetFileFormatName Function

GetFileFormatName Function
Syntax
Pascal
function GetFileFormatName(AFormat: TsSpreadsheetFormat): string; deprecated;
File

fpsutils

Parameters
Parameters | Description
AFormat: TsSpreadsheetFormat | Identifier of the file format
Returns

'BIFF2', 'BIFF3', 'BIFF4', 'BIFF5', 'BIFF8', 'OOXML', 'Open Document', 'CSV, 'WikiTable Pipes', or 'WikiTable WikiMedia"

Note This function is deprecated. Use GetSpreadFormatName or GetSpreadTechnicalName of fpsRegFileformats instead in order to be able to process user-defined formats as well.

Description

Returns the name of the given spreadsheet file format.

Group

Functions


GetFormatFromFileName Function

GetFormatFromFileName Function
Syntax
Pascal
function GetFormatFromFileName(const AFileName: TFileName; out AFormatID: TsSpreadFormatID): Boolean; overload;
File

fpsutils

Parameters
Parameters | Description
const AFileName: TFileName | Name of the file to be considered
out AFormatID: TsSpreadFormatID | File format ID found from analysis of the extension (output)
Returns

True if the file matches any of the registered formats, false otherwise

Description

Determines the spreadsheet type from the file type extension

Group

Functions


GetFormatFromFileName Function

GetFormatFromFileName Function
Syntax
Pascal
function GetFormatFromFileName(const AFileName: TFileName; out SheetType: TsSpreadsheetFormat): Boolean; overload; deprecated;
File

fpsutils

Parameters
Parameters | Description
const AFileName: TFileName | Name of the file to be considered
out SheetType: TsSpreadsheetFormat | Built-in file format found from analysis of the extension (output)
Returns

True if the file matches any of the built-in formats, false otherwise

Description

Determines the spreadsheet type from the file type extension

Group

Functions


GetImageInfo Function

GetImageInfo Function
Syntax
Pascal
function GetImageInfo(AStream: TStream; out AWidth: DWord; out AHeight: DWord; out dpiX: Double; out dpiY: Double; AImageType: TsImageType = itUnknown): TsImageType; overload;
File

fpsimages

Parameters
Parameters | Description
AStream: TStream | Stream containing the image to be analyzed. It is assumed that the image begins at stream start.
out AWidth: DWord | Image width, in pixels
out AHeight: DWord | Image height, in pixels
out dpiX: Double | Pixel density in x direction, per inch
out dpiY: Double | Pixel density in y direction, per inch
AImageType: TsImageType = itUnknown | Type of the image to be assumed. If this parameter is missing or itUnknown then the image type is determined from the file header.
Returns

Image type code found from the file header.

Description

Returns the width and height of the image loaded into the specified stream.

See Also

RegisterImageType

Group

Functions


GetImageInfo Function

GetImageInfo Function
Syntax
Pascal
function GetImageInfo(AStream: TStream; out AWidthInches: Double; out AHeightInches: Double; AImagetype: TsImageType = itUnknown): TsImageType; overload;
File

fpsimages

Parameters
Parameters | Description
AStream: TStream | Stream containing the image to be analyzed. It is assumed that the image begins at stream start.
out AWidthInches: Double | Image width, in inches
out AHeightInches: Double | Image height, in inches
AImagetype: TsImageType = itUnknown | Type of the image to be assumed. If this parameter is missing or itUnknown then the image type is determined from the file header.
Returns

Image type code found from the file header.

Description

Returns the width and height of the image loaded into the specified stream.

See Also

RegisterImageType

Group

Functions


GetImageMimeType Function

GetImageMimeType Function
Syntax
Pascal
function GetImageMimeType(AImageType: TsImageType): String;
File

fpsimages

Parameters
Parameters | Description
AImageType: TsImageType | Format code of the image type as returned from the image registration procedure
Returns

MimeType of the file format

Description

Returns the MimeType of the specified image type

Group

Functions


GetImageTypeFromFileName Function

GetImageTypeFromFileName Function
Syntax
Pascal
function GetImageTypeFromFileName(const AFilename: String): TsImageType;
File

fpsimages

Parameters
Parameters | Description
const AFilename: String | Name of the file to be analyzed
Returns

Format code value as returned from the image registration procedure

Description

Extracts the image file type identifier from the extension of the specified file name.

See Also

RegisterImageType, itXXXX values.

Group

Functions


GetTIFSize Function

GetTIFSize Function
Syntax
Pascal
function GetTIFSize(AStream: TStream; out AWidth: DWord; out AHeight: DWord; out dpiX: Double; out dpiY: Double): Boolean;
File

fpsimages

Group

Functions


HasFormula Function

HasFormula Function
Syntax
Pascal
function HasFormula(ACell: PCell): Boolean;
File

fpsutils

Parameters
Parameters | Description
ACell: PCell | Pointer to the cell checked
Description

Returns TRUE if the cell contains a formula.

Group

Functions


HighContrastColor Function

HighContrastColor Function
Syntax
Pascal
function HighContrastColor(AColor: TsColor): TsColor;
File

fpsutils

Parameters
Parameters | Description
AColor: TsColor | rgb color to be analyzed
Returns

The color index for black (scBlack) if AColorValue is a "bright" color, or white (scWhite) if AColorValue is a "dark" color.

Description

Returns the color index for black or white depending on a color being "bright" or "dark".

Group

Functions


HTMLColorStrToColor Function

HTMLColorStrToColor Function
Syntax
Pascal
function HTMLColorStrToColor(AValue: String): TsColor;
File

fpsutils

Parameters
Parameters | Description
AValue: String | HTML color string, such as '#FF0000'
Returns

rgb color value in little endian byte-sequence. This value is compatible with the TColor data type of the graphics unit.

Description

Converts a HTML color string to a TsColor alue. Needed for the ODS file format.

Group

Functions


HTMLLengthStrToPts Function

HTMLLengthStrToPts Function
Syntax
Pascal
function HTMLLengthStrToPts(AValue: String; DefaultUnits: String = 'pt'): Double;
File

fpsutils

Parameters
Parameters | Description
AValue: String | HTML string representing a length with appended units code, such as '1.25in'. These unit codes are accepted: 'px' (pixels), 'pt' (points), 'in' (inches), 'mm' (millimeters), 'cm' (centimeters).
DefaultUnits: String = 'pt' | String identifying the units to be used if not contained in AValue.
Returns

Extracted length in points

Description

Converts a HTML length string to points. The units are assumed to be the last two digits of the string, such as '1.25in'

Group

Functions


IfThen Function

IfThen Function
Syntax
Pascal
function IfThen(ACondition: Boolean; AValue1: Char; AValue2: Char): Char; overload;
File

fpsutils

Group

Functions


IfThen Function

IfThen Function
Syntax
Pascal
function IfThen(ACondition: Boolean; AValue1: TsNumberFormat; AValue2: TsNumberFormat): TsNumberFormat; overload;
File

fpsutils

Parameters
Parameters | Description
ACondition: Boolean | Boolean expression
AValue1: TsNumberFormat | First built-in number format code
AValue2: TsNumberFormat | Second built-in number format code
Returns

AValue1 if ACondition is true, AValue2 otherwise.

Description

Helper function to reduce typing: "if a conditions is true return the first number format, otherwise return the second format"

Group

Functions


InitCell Function

InitCell Function
Syntax
Pascal
procedure InitCell(ARow: Cardinal; ACol: Cardinal; out ACell: TCell); overload;
File

fpsutils

Parameters
Parameters | Description
ARow: Cardinal | Row index of the new cell
ACol: Cardinal | Column index of the new cell
Returns

New cell record with row and column fields preset to passed values.

Description

Initalizes a new cell and presets the row and column fields of the cell record to the parameters passed to the procedure.

Group

Functions


InitCell Function

InitCell Function
Syntax
Pascal
procedure InitCell(out ACell: TCell); overload;
File

fpsutils

Returns

New cell record

Description

Initalizes a new cell.

Group

Functions


InitFormatRecord Function

InitFormatRecord Function
Syntax
Pascal
procedure InitFormatRecord(out AValue: TsCellFormat);
File

fpsutils

Description

Initializes the fields of a TsCellFormaRecord

Group

Functions


InitFormatSettings Function

InitFormatSettings Function
Syntax
Pascal
procedure InitFormatSettings(out AFormatSettings: TFormatSettings);
File

fpsnumformat

Description

Initializes the FormatSettings of file a import/export parameters record to default values which can be replaced by the FormatSettings of the workbook's FormatSettings

Group

Functions


InitHeaderFooterImageRecord Function

InitHeaderFooterImageRecord Function
Syntax
Pascal
procedure InitHeaderFooterImageRecord(out AImage: TsHeaderFooterImage);
File

fpsutils

Description

Initializes the fields of a TsHeaderFooterImage record

Group

Functions


InitImageRecord Function

InitImageRecord Function
Syntax
Pascal
procedure InitImageRecord(out AValue: TsImage; ARow: Cardinal; ACol: Cardinal; AOffsetX: Double; AOffsetY: Double; AScaleX: Double; AScaleY: Double);
File

fpsutils

Description

Initializes the fields of a TsImage record

Group

Functions


InitSortParams Function

InitSortParams Function
Syntax
Pascal
function InitSortParams(ASortByCols: Boolean = true; ANumSortKeys: Integer = 1; ASortPriority: TsSortPriority = spNumAlpha): TsSortParams;
File

fpsutils

Parameters
Parameters | Description
ASortByCols: Boolean = true | If true sorting occurs along columns, i.e. the ColRowIndex of the sorting keys refer to column indexes. If False, sorting occurs along rows, and the ColRowIndexes refer to row indexes Default: true
ANumSortKeys: Integer = 1 | Determines how many columns or rows are used as sorting keys. (Default: 1). Every sort key is initialized for ascending sort direction and case-sensitive comparison.
ASortPriority: TsSortPriority = spNumAlpha | Determines the order or text and numeric data in mixed content type cell ranges. Default: spNumAlpha, i.e. numbers before text (in ascending sort)
Returns

The initializaed TsSortParams record

Description

Initializes a Sortparams record. This record sets paramaters used when cells are sorted.

Group

Functions


IntegerToLE Function

IntegerToLE Function
Syntax
Pascal
function IntegerToLE(AValue: Integer): Integer;
File

fpsutils

Parameters
Parameters | Description
AValue: Integer | Big-endian integer value
Returns

Little-endian integer value

Description

Converts an integer value from big-endian to little-endian byte-order.

Group

Functions


InToEMU Function

InToEMU Function
Syntax
Pascal
function InToEMU(AValue: Double): Int64;
File

fpsutils

Parameters
Parameters | Description
AValue: Double | Length value in inches
Returns

Value converted to EMU

Description

Converts inches to EMU (English metric units)

Group

Functions


InToMM Function

InToMM Function
Syntax
Pascal
function InToMM(AValue: Double): Double;
File

fpsutils

Parameters
Parameters | Description
AValue: Double | Length value in inches
Returns

Value converted to mm

Description

Converts inches to millimeters

Group

Functions


InToPts Function

InToPts Function
Syntax
Pascal
function InToPts(AValue: Double): Double;
File

fpsutils

Parameters
Parameters | Description
AValue: Double | Length value in inches
Returns

Value converted to points

Description

Converts inches to points (72 pts = 1 inch)

Group

Functions


IsBoolValue Function

IsBoolValue Function
Syntax
Pascal
function IsBoolValue(const AText: String; const ATrueText: String; const AFalseText: String; out AValue: Boolean): Boolean;
File

fpsnumformat

Description

Checks whether the specified text corresponds to a boolean value. For this, it must match the specified TRUE and FALSE text phrases.

Group

Functions


IsCurrencyFormat Function

IsCurrencyFormat Function
Syntax
Pascal
function IsCurrencyFormat(ANumFormat: TsNumFormatParams): Boolean; overload;
File

fpsnumformat

Parameters
Parameters | Description
ANumFormat: TsNumFormatParams | Number format parameters
Returns

True if Kind of the 1st format parameter section contains the nfkCurrency elements; false otherwise

Description

Checks whether the specified number format parameters apply to currency values.

Group

Functions


IsCurrencyFormat Function

IsCurrencyFormat Function
Syntax
Pascal
function IsCurrencyFormat(AFormat: TsNumberFormat): Boolean; overload;
File

fpsnumformat

Parameters
Parameters | Description
AFormat: TsNumberFormat | Built-in number format identifier to be checked
Returns

True if AFormat is nfCurrency or nfCurrencyRed, false otherwise.

Description

Checks whether the given number format code is for currency, i.e. requires a currency symbol.

Group

Functions


IsDateFormat Function

IsDateFormat Function
Syntax
Pascal
function IsDateFormat(ANumFormat: TsNumFormatParams): Boolean;
File

fpsnumformat

Parameters
Parameters | Description
ANumFormat: TsNumFormatParams | Number format parameters
Returns

True if Kind of the 1st format parameter section contains the nfkDate, but no nfkTime tags; false otherwise

Description

Checks whether the specified number format parameters apply to a date value.

Group

Functions


IsDateTimeFormat Function

IsDateTimeFormat Function
Syntax
Pascal
function IsDateTimeFormat(AFormatStr: String): Boolean; overload;
File

fpsnumformat

Group

Functions


IsDateTimeFormat Function

IsDateTimeFormat Function
Syntax
Pascal
function IsDateTimeFormat(ANumFormat: TsNumFormatParams): Boolean; overload;
File

fpsnumformat

Parameters
Parameters | Description
ANumFormat: TsNumFormatParams | Number format parameters
Returns

True if Kind of the 1st format parameter section contains the nfkDate or nfkTime elements; false otherwise

Description

Checks whether the specified number format parameters apply to date/time values.

Group

Functions


IsDateTimeFormat Function

IsDateTimeFormat Function
Syntax
Pascal
function IsDateTimeFormat(AFormat: TsNumberFormat): Boolean; overload;
File

fpsnumformat

Parameters
Parameters | Description
AFormat: TsNumberFormat | Built-in number format identifier to be checked
Returns

True if AFormat is a date/time format (such as nfShortTime), false otherwise

Description

Checks whether the given number format code is for date/time values.

Group

Functions


IsDateTimeValue Function

IsDateTimeValue Function
Syntax
Pascal
function IsDateTimeValue(AText: String; const AFormatSettings: TFormatSettings; out ADateTime: TDateTime; out ANumFormat: TsNumberFormat): Boolean;
File

fpsnumformat

Description

Checks whether the specified text corresponds to a date/time value and returns true, its numerical value and its built-in numberformat if it is.

Group

Functions


IsLongTimeFormat Function

IsLongTimeFormat Function
Syntax
Pascal
function IsLongTimeFormat(AFormatStr: String; ATimeSeparator: char): Boolean; overload;
File

fpsnumformat

Group

Functions


IsNumberValue Function

IsNumberValue Function
Syntax
Pascal
function IsNumberValue(AText: String; AutoDetectNumberFormat: Boolean; const AFormatSettings: TFormatSettings; out ANumber: Double; out ANumFormat: TsNumberFormat; out ADecimals: Integer; out ACurrencySymbol: String; out AWarning: String): Boolean;
File

fpsnumformat

Description

Checks whether the specified text corresponds to a numerical value. If it is then the function result is TRUE, and the number value and its formatting parameters are returned.

Group

Functions


IsPaletteIndex Function

IsPaletteIndex Function
Syntax
Pascal
function IsPaletteIndex(AColor: TsColor): Boolean;
File

fpsutils

Description

Checks whether the specified TsColor represents a palette index

Group

Functions


IsTextFormat Function

IsTextFormat Function
Syntax
Pascal
function IsTextFormat(ANumFormat: TsNumFormatParams): Boolean;
File

fpsnumformat

Group

Functions


IsTimeFormat Function

IsTimeFormat Function
Syntax
Pascal
function IsTimeFormat(AFormatStr: String): Boolean; overload;
File

fpsnumformat

Parameters
Parameters | Description
AFormatStr: String | String with formatting codes to be checked
Returns

True if AFormatStr represents a time-format, false otherwise

Description

Checks whether the given string with formatting codes is for time values.

Group

Functions


IsTimeFormat Function

IsTimeFormat Function
Syntax
Pascal
function IsTimeFormat(ANumFormat: TsNumFormatParams): Boolean; overload;
File

fpsnumformat

Parameters
Parameters | Description
ANumFormat: TsNumFormatParams | Number format parameters
Returns

True if Kind of the 1st format parameter section contains the nfkTime, but no nfkDate elements; false otherwise

Description

Checks whether the specified number format parameters apply to time values.

Group

Functions


IsTimeFormat Function

IsTimeFormat Function
Syntax
Pascal
function IsTimeFormat(AFormat: TsNumberFormat): Boolean; overload;
File

fpsnumformat

Parameters
Parameters | Description
AFormat: TsNumberFormat | Built-in number format identifier to be checked
Returns

True if AFormat represents to a time-format, false otherwise

Description

Checks whether the given built-in number format code is for time values.

Group

Functions


IsTimeIntervalFormat Function

IsTimeIntervalFormat Function
Syntax
Pascal
function IsTimeIntervalFormat(ANumFormat: TsNumFormatParams): Boolean;
File

fpsnumformat

Parameters
Parameters | Description
ANumFormat: TsNumFormatParams | Number format parameters
Returns

True if Kind of the 1st format parameter section contains the nfkTimeInterval elements; false otherwise

Description

Checks whether the specified number format parameters is a time interval format.

Group

Functions


LongRGBToExcelPhysical Function

LongRGBToExcelPhysical Function
Syntax
Pascal
function LongRGBToExcelPhysical(const RGB: DWord): DWord;
File

fpsutils

Parameters
Parameters | Description
const RGB: DWord | DWord value containing RGBA bytes in big endian byte-order
Returns

DWord containing RGB bytes in little-endian byte-order (A = 0)

Description

Converts the RGB part of a LongRGB logical structure to its physical representation. In other words: RGBA (where A is 0 and omitted in the function call) => ABGR Needed for conversion of palette colors.

Group

Functions


MakeLongDateFormat Function

MakeLongDateFormat Function
Syntax
Pascal
function MakeLongDateFormat(ADateFormat: String): String;
File

fpsnumformat

Parameters
Parameters | Description
ADateFormat: String | String with date formatting code representing a "short" date, such as 'dd/mm/yy'
Returns

Format string modified to represent a "long" date, such as 'dd/mmm/yyyy'

Description

Creates a long date format string out of a short date format string. Retains the order of year-month-day and the separators, but uses 4 digits for year and 3 digits of month.

Group

Functions


MakeShortDateFormat Function

MakeShortDateFormat Function
Syntax
Pascal
function MakeShortDateFormat(ADateFormat: String): String;
File

fpsnumformat

Parameters
Parameters | Description
ADateFormat: String | String with date formatting codes representing a "long" date, such as 'dd/mmm/yyyy'
Returns

Format string modified to represent a "short" date, such as 'dd/mm/yy'

Description

Modifies the short date format such that it has a two-digit year and a two-digit month. Retains the order of year-month-day and the separators.

Group

Functions


MakeTimeIntervalMask Function

MakeTimeIntervalMask Function
Syntax
Pascal
procedure MakeTimeIntervalMask(Src: String; var Dest: String);
File

fpsnumformat

Parameters
Parameters | Description
Src: String | Source format string, must be a time format string, like 'hh:nn'
var Dest: String | Destination format string, will have the first time code element of the src format string in square brackets, like '[hh]:nn'.
Description

Creates a "time interval" format string having the first time code identifier in square brackets.

Group

Functions


mmToEMU Function

mmToEMU Function
Syntax
Pascal
function mmToEMU(AValue: Double): Int64;
File

fpsutils

Parameters
Parameters | Description
AValue: Double | Length value in millimeters
Returns

Value converted to EMU

Description

Converts millimeters to EMU (english metric units, 1 cm = 360000 EMU)

Group

Functions


mmToIn Function

mmToIn Function
Syntax
Pascal
function mmToIn(AValue: Double): Double;
File

fpsutils

Parameters
Parameters | Description
AValue: Double | Length value in millimeters
Returns

Value converted to inches

Description

Converts millimeters to inches

Group

Functions


mmToPts Function

mmToPts Function
Syntax
Pascal
function mmToPts(AValue: Double): Double;
File

fpsutils

Parameters
Parameters | Description
AValue: Double | Length value in millimeters
Returns

Value converted to points

Description

Converts millimeters to points (72 pts = 1 inch)

Group

Functions


ParseCellColString Function

ParseCellColString Function
Syntax
Pascal
function ParseCellColString(const AStr: string; out ACol: Cardinal): Boolean;
File

fpsutils

Parameters
Parameters | Description
const AStr: string | Cell range string, such as A1
out ACol: Cardinal | Zero-based index of the column (output)
Returns

False if the string is not a valid cell column string

Description

Parses a cell column string, like 'A' or 'CZ', into a zero-based column number. Note that there can be several letters to address more than 26 columns.

Group

Functions


ParseCellRangeString Function

ParseCellRangeString Function
Syntax
Pascal
function ParseCellRangeString(const AStr: String; out ARange: TsCellRange): Boolean; overload;
File

fpsutils

Parameters
Parameters | Description
const AStr: String | Cell range string, such as A5:C10
out ARange: TsCellRange | TsCellRange record of the zero-based row and column indexes of the top/left and right/bottom corrners
Returns

false if the string is not a valid cell range

Description

Parses strings like A5:C10 into a range selection information. Information on relative/absolute cells is ignored.

Group

Functions


ParseCellRangeString Function

ParseCellRangeString Function
Syntax
Pascal
function ParseCellRangeString(const AStr: String; out ARange: TsCellRange; out AFlags: TsRelFlags): Boolean; overload;
File

fpsutils

Parameters
Parameters | Description
const AStr: String | Cell range string, such as A5:C10
out ARange: TsCellRange | TsCellRange record of the zero-based row and column indexes of the top/left and right/bottom corrners
out AFlags: TsRelFlags | a set containing an element for ARange.Row1 (top row), ARange.Col1 (left column), ARange.Row2 (bottom row), ARange.Col2 (right column) if they represent relative cell addresses.
Returns

false if the string is not a valid cell range

Description

Parses strings like A5:C10 into a range selection information. Returns in AFlags also information on relative/absolute cells.

Group

Functions


ParseCellRangeString Function

ParseCellRangeString Function
Syntax
Pascal
function ParseCellRangeString(const AStr: string; out AFirstCellRow: Cardinal; out AFirstCellCol: Cardinal; out ALastCellRow: Cardinal; out ALastCellCol: Cardinal): Boolean; overload;
File

fpsutils

Parameters
Parameters | Description
const AStr: string | Cell range string, such as A5:C10
out AFirstCellRow: Cardinal | Row index of the top/left cell of the range (output)
out AFirstCellCol: Cardinal | Column index of the top/left cell of the range (output)
out ALastCellRow: Cardinal | Row index of the bottom/right cell of the range (output)
out ALastCellCol: Cardinal | Column index of the bottom/right cell of the range (output)
Returns

false if the string is not a valid cell range

Description

Parses strings like A5:C10 into a range selection information. Information on relative/absolute cells is ignored.

Group

Functions


ParseCellRangeString Function

ParseCellRangeString Function
Syntax
Pascal
function ParseCellRangeString(const AStr: string; out AFirstCellRow: Cardinal; out AFirstCellCol: Cardinal; out ALastCellRow: Cardinal; out ALastCellCol: Cardinal; out AFlags: TsRelFlags): Boolean; overload;
File

fpsutils

Parameters
Parameters | Description
const AStr: string | Cell range string, such as A5:C10
out AFirstCellRow: Cardinal | Row index of the top/left cell of the range (output)
out AFirstCellCol: Cardinal | Column index of the top/left cell of the range (output)
out ALastCellRow: Cardinal | Row index of the bottom/right cell of the range (output)
out ALastCellCol: Cardinal | Column index of the bottom/right cell of the range (output)
out AFlags: TsRelFlags | a set containing an element for AFirstCellRow, AFirstCellCol, ALastCellRow, ALastCellCol if they represent relative cell addresses.
Returns

false if the string is not a valid cell range

Description

Parses strings like A5:C10 into a range selection information. Returns in AFlags also information on relative/absolute cells.

Group

Functions


ParseCellRangeString_R1C1 Function

ParseCellRangeString_R1C1 Function
Syntax
Pascal
function ParseCellRangeString_R1C1(const AStr: string; ABaseRow: Cardinal; ABaseCol: Cardinal; out AFirstCellRow: Cardinal; out AFirstCellCol: Cardinal; out ALastCellRow: Cardinal; out ALastCellCol: Cardinal; out AFlags: TsRelFlags): Boolean;
File

fpsutils

Parameters
Parameters | Description
const AStr: string | Cell range string, in R1C1 syntax, such as R[2]C[3]:R[4]C[8]
ABaseRow: Cardinal | Row index from which the cell reference is seen.
ABaseCol: Cardinal | Column index from which the cell reference is seen.
out AFirstCellRow: Cardinal | Row index of the top/left cell of the range (output)
out AFirstCellCol: Cardinal | Column index of the top/left cell of the range (output)
out ALastCellRow: Cardinal | Row index of the bottom/right cell of the range (output)
out ALastCellCol: Cardinal | Column index of the bottom/right cell of the rng (output)
out AFlags: TsRelFlags | A set containing an element for AFirstCellRow, AFirstCellCol, ALastCellRow, ALastCellCol if they represent a relative cell address.
Returns

FALSE if the string is not a valid cell range

Description

Extracts information on cell range from a cellrange string in "R1C1" notation. Returns in AFlags also information on relative/absolute cells.

Group

Functions


ParseCellRowString Function

ParseCellRowString Function
Syntax
Pascal
function ParseCellRowString(const AStr: string; out ARow: Cardinal): Boolean;
File

fpsutils

Parameters
Parameters | Description
const AStr: string | Cell row string, such as '1', 1-based!
out ARow: Cardinal | Index of the row (zero-based!) (putput)
Returns

False if the string is not a valid cell row string

Description

Parses a cell row string to a zero-based row number.

Group

Functions


ParseCellString Function

ParseCellString Function
Syntax
Pascal
function ParseCellString(const AStr: string; out ACellRow: Cardinal; out ACellCol: Cardinal): Boolean; overload;
File

fpsutils

Parameters
Parameters | Description
const AStr: string | Cell range string, such as A1
out ACellRow: Cardinal | Row index of the top/left cell of the range (output)
out ACellCol: Cardinal | Column index of the top/left cell of the range (output)
Returns

False if the string is not a valid cell range

Description

Parses a cell string, like 'A1' into zero-based column and row numbers Note that there can be several letters to address for more than 26 columns.

For compatibility with old version which does not return flags for relative cell addresses.

Group

Functions


ParseCellString Function

ParseCellString Function
Syntax
Pascal
function ParseCellString(const AStr: string; out ACellRow: Cardinal; out ACellCol: Cardinal; out AFlags: TsRelFlags): Boolean; overload;
File

fpsutils

Group

Functions


ParseCellString_R1C1 Function

ParseCellString_R1C1 Function
Syntax
Pascal
function ParseCellString_R1C1(const AStr: String; ABaseRow: Cardinal; ABaseCol: Cardinal; out ACellRow: Cardinal; out ACellCol: Cardinal; out AFlags: TsRelFlags): Boolean; overload;
File

fpsutils

Parameters
Parameters | Description
const AStr: String | Cell reference in R1C1 syntax, such as R[2]C[3] or R1C5
ABaseRow: Cardinal | Row index from which the cell reference is seen.
ABaseCol: Cardinal | Column index from which the cell reference is seen.
out ACellRow: Cardinal | Row index of the top/left cell of the range (output)
out ACellCol: Cardinal | Column index of the top/left cell of the range (output)
out AFlags: TsRelFlags | A set containing an element for ACellRow and/or ACellCol, if they represent a relative cell address.
Returns

FALSE if the string is not a valid cell range

Description

Parses a cell string in "R1C1" notation into zero-based column and row numbers 'AFlags' indicates relative addresses.

Group

Functions


ParseCellString_R1C1 Function

ParseCellString_R1C1 Function
Syntax
Pascal
function ParseCellString_R1C1(const AStr: string; ABaseRow: Cardinal; ABaseCol: Cardinal; out ACellRow: Cardinal; out ACellCol: Cardinal): Boolean; overload;
File

fpsutils

Parameters
Parameters | Description
const AStr: string | Cell reference in R1C1 syntax, such as R[2]C[3] or R1C5
ABaseRow: Cardinal | Row index from which the cell reference is seen.
ABaseCol: Cardinal | Column index from which the cell reference is seen.
out ACellRow: Cardinal | Row index of the top/left cell of the range (output)
out ACellCol: Cardinal | Column index of the top/left cell of the range (output)
Description

Parses a cell string in "R1C1" notation into zero-based column and row numbers

For compatibility with old version which does not return flags for relative cell addresses.

Group

Functions


ParseIntervalString Function

ParseIntervalString Function
Syntax
Pascal
function ParseIntervalString(const AStr: string; out AFirstCellRow: Cardinal; out AFirstCellCol: Cardinal; out ACount: Cardinal; out ADirection: TsSelectionDirection): Boolean;
File

fpsutils

Parameters
Parameters | Description
const AStr: string | Cell range string, such as A5:A10
out AFirstCellRow: Cardinal | Row index of the first cell of the range (output)
out AFirstCellCol: Cardinal | Column index of the first cell of the range (output)
out ACount: Cardinal | Number of cells included in the range (output)
out ADirection: TsSelectionDirection | fpsVerticalSelection if the range is along a column, fpsHorizontalSelection if the range is along a row
Returns

false if the string is not a valid cell range

Description

Parses strings like A5:A10 into an selection interval information

Group

Functions


ParseSheetCellString Function

ParseSheetCellString Function
Syntax
Pascal
function ParseSheetCellString(const AStr: String; out ASheetName: String; out ACellRow: Cardinal; out ACellCol: Cardinal; ASheetSeparator: Char = '!'): Boolean;
File

fpsutils

Group

Functions


PtsToCm Function

PtsToCm Function
Syntax
Pascal
function PtsToCm(AValue: Double): Double;
File

fpsutils

Parameters
Parameters | Description
AValue: Double | Length value in points
Returns

Value converted to centimeters

Description

Converts points to centimeters

Group

Functions


PtsToIn Function

PtsToIn Function
Syntax
Pascal
function PtsToIn(AValue: Double): Double;
File

fpsutils

Parameters
Parameters | Description
AValue: Double | Length value in points
Returns

Value converted to inches

Description

Converts points to inches (72 pts = 1 inch)

Group

Functions


PtsToMM Function

PtsToMM Function
Syntax
Pascal
function PtsToMM(AValue: Double): Double;
File

fpsutils

Parameters
Parameters | Description
AValue: Double | Length value in points
Returns

Value converted to millimeters

Description

Converts points to millimeters

Group

Functions


PtsToPx Function

PtsToPx Function
Syntax
Pascal
function PtsToPx(AValue: Double; AScreenPixelsPerInch: Integer): Integer;
File

fpsutils

Parameters
Parameters | Description
AValue: Double | Length value given in points
AScreenPixelsPerInch: Integer | Pixels per inch of the screen
Returns

Value converted to pixels

Description

Converts points to pixels

Group

Functions


PtsToTwips Function

PtsToTwips Function
Syntax
Pascal
function PtsToTwips(AValue: Single): Integer;
File

fpsutils

Parameters
Parameters | Description
AValue: Single | Length value in points
Returns

Value converted to twips

Description

Converts points to twips (1 twip = 1/20 point)

Group

Functions


pxToPts Function

pxToPts Function
Syntax
Pascal
function pxToPts(AValue: Integer; AScreenPixelsPerInch: Integer): Double;
File

fpsutils

Parameters
Parameters | Description
AValue: Integer | Length value given in pixels
AScreenPixelsPerInch: Integer | Pixels per inch of the screen
Returns

Value converted to points

Description

Converts pixels to points.

Group

Functions


Range Function

Range Function
Syntax
Pascal
function Range(ARow1: Cardinal; ACol1: Cardinal; ARow2: Cardinal; ACol2: Cardinal): TsCellRange;
File

fpsutils

Description

Creates a TsCellRange record from the provided cell corner coordinates. Put the coordinates into right order if needed.

Group

Functions


Register Function

Register Function
Syntax
Pascal
procedure Register;
File

fpspreadsheetgrid

Description

Registers the worksheet grid in the Lazarus component palette, page "FPSpreadsheet".

Group

Functions


RegisterImageType Function

RegisterImageType Function
Syntax
Pascal
function RegisterImageType(AMimeType: String; AExt: String; AGetImageSize: TGetImageSizeFunc): TsImageType;
File

fpsimages

Parameters
Parameters | Description
AMimeType: String | MimeType of the file format, for usage by ods
AExt: String | Extension(s) of the file format. Separate by "|" if a file format can use several extensions.
AGetImageSize: TGetImageSizeFunc | Function which can extract the image size and pixel density. It should only read the file header.
Returns

Identifier of the image type (consecutive number)

Description

Registers an image type for usage in fpspreadsheet

Group

Functions


ReplaceFormatSettings Function

ReplaceFormatSettings Function
Syntax
Pascal
procedure ReplaceFormatSettings(var AFormatSettings: TFormatSettings; const ADefaultFormats: TFormatSettings);
File

fpsnumformat

Description

Replaces in AFormatSettings all members marked as having default values (#0, 1, '') by the corresponding values of the ADefaultFormats record

Group

Functions


SameCellBorders Function

SameCellBorders Function
Syntax
Pascal
function SameCellBorders(AFormat1: PsCellFormat; AFormat2: PsCellFormat): Boolean;
File

fpsutils

Parameters
Parameters | Description
AFormat1: PsCellFormat | Pointer to the first one of the two format records to be compared
AFormat2: PsCellFormat | Pointer to the second one of the two format records to be compared
Description

Checks whether two format records have same border attributes

Group

Functions


SameFont Function

SameFont Function
Syntax
Pascal
function SameFont(AFont: TsFont; AFontName: String; AFontSize: Single; AStyle: TsFontStyles; AColor: TsColor; APos: TsFontPosition): Boolean; overload;
File

fpsutils

Parameters
Parameters | Description
AFont1 | Pointer to the first font to be compared
AFont2 | Pointer to the second font to be compared
Description

Checks whether two fonts are equal

Group

Functions


SameFont Function

SameFont Function
Syntax
Pascal
function SameFont(AFont1: TsFont; AFont2: TsFont): Boolean; overload;
File

fpsutils

Parameters
Parameters | Description
AFont1: TsFont | Pointer to the first font to be compared
AFont2: TsFont | Pointer to the second font to be compared
Description

Checks whether two fonts are equal

Group

Functions


SetAsPaletteIndex Function

SetAsPaletteIndex Function
Syntax
Pascal
function SetAsPaletteIndex(AIndex: Integer): TsColor;
File

fpsutils

Description

Constructs a TsColor from a palette index. It has bit 15 in the high-order byte set.

Group

Functions


SplitHyperlink Function

SplitHyperlink Function
Syntax
Pascal
procedure SplitHyperlink(AValue: String; out ATarget: String; out ABookmark: String);
File

fpsutils

Parameters
Parameters | Description
AValue: String | Hyperlink string to be processed
out ATarget: String | Part before the # ("Target")
out ABookmark: String | Part after the # ("Bookmark")
Description

Splits a hyperlink string at the # character.

Group

Functions


SplitStr Function

SplitStr Function
Syntax
Pascal
function SplitStr(const AText: String; ADelimiter: Char): TStringArray;
File

fpsutils

Description

Splits a string at the specified delimiters into individual strings and passes them in an array.

Group

Functions


SpreadsheetFormatInClipboard Function

SpreadsheetFormatInClipboard Function
Syntax
Pascal
function SpreadsheetFormatInClipboard: Boolean;
File

fpspreadsheetctrls

Description

Returns TRUE if the clipboard contains a format good for pasting into a worksheet grid.

Group

Functions


StripAMPM Function

StripAMPM Function
Syntax
Pascal
function StripAMPM(const ATimeFormatString: String): String;
File

fpsnumformat

Parameters
Parameters | Description
const ATimeFormatString: String | String of time formatting codes (such as 'hh:nn AM/PM')
Returns

Formatting string with AM/PM being removed (--> 'hh:nn')

Description

Removes an AM/PM formatting code from a given time formatting string. Variants of "AM/PM" are considered as well. The string is left unchanged if it does not contain AM/PM codes.

Group

Functions


TintedColor Function

TintedColor Function
Syntax
Pascal
function TintedColor(AColor: TsColor; tint: Double): TsColor;
File

fpsutils

Parameters
Parameters | Description
AColor: TsColor | rgb color to be modified
tint: Double | Factor (-1...+1) to be used for the operation
Returns

Modified color

Description

Excel defines theme colors and applies a "tint" factor (-1...+1) to darken or brighten them.

This method "tints" a given color with a factor

The algorithm is described in http://msdn.microsoft.com/en-us/library/documentformat.openxml.spreadsheet.backgroundcolor.aspx

Group

Functions


TryFractionStrToFloat Function

TryFractionStrToFloat Function
Syntax
Pascal
function TryFractionStrToFloat(AText: String; out ANumber: Double; out AIsMixed: Boolean; out AMaxDigits: Integer): Boolean;
File

fpsutils

Parameters
Parameters | Description
AText: String | String to be considered
out ANumber: Double | (out) value of the converted floating point number
out AMaxDigits: Integer | Maximum count of digits used in the numerator or denominator of the fraction
Returns

TRUE if a number value can be retrieved successfully, FALSE otherwise

Description

Assumes that the specified text is a string representation of a mathematical fraction and tries to extract the floating point value of this number. Returns also the maximum count of digits used in the numerator or denominator of the fraction

Example

AText := '1 3/4' --> ANumber = 1.75; AMaxDigits = 1; Result = true

Group

Functions


TryStrToErrorValue Function

TryStrToErrorValue Function
Syntax
Pascal
function TryStrToErrorValue(AErrorStr: String; out AErr: TsErrorValue): boolean;
File

fpsutils

Parameters
Parameters | Description
AErrorStr: String | Error string
out AErr: TsErrorValue | Corresponding error value code (type TsErrorValue) result TRUE if error code could be determined from the error string, FALSE otherwise.
Description

Returns the error value code from a string. Result is false, if the string does not match one of the predefined error strings.

Group

Functions


TryStrToFloatAuto Function

TryStrToFloatAuto Function
Syntax
Pascal
function TryStrToFloatAuto(AText: String; out ANumber: Double; out ADecimalSeparator: Char; out AThousandSeparator: Char; out AWarning: String): Boolean;
File

fpsutils

Description

Converts a string to a floating point number. No assumption on decimal and thousand separator are made. Is needed for reading CSV files.

Group

Functions


TwipsToPts Function

TwipsToPts Function
Syntax
Pascal
function TwipsToPts(AValue: Integer): Single;
File

fpsutils

Parameters
Parameters | Description
AValue: Integer | Length value in twips
Returns

Value converted to points

Description

Excel's unit of row heights is "twips", i.e. 1/20 point. Converts Twips to points.

Group

Functions


UnquoteStr Function

UnquoteStr Function
Syntax
Pascal
function UnquoteStr(AString: String): String;
File

fpsutils

Description

Removes quotation characters which enclose a string

Group

Functions


Unused Function

Unused Function
Syntax
Pascal
procedure Unused(const A1);
File

fpsutils

Description

Silence warnings due to an unused parameter

Group

Functions


Unused Function

Unused Function
Syntax
Pascal
procedure Unused(const A1; const A2);
File

fpsutils

Description

Silence warnings due to two unused parameters

Group

Functions


Unused Function

Unused Function
Syntax
Pascal
procedure Unused(const A1; const A2; const A3);
File

fpsutils

Description

Silence warnings due to three unused parameters

Group

Functions


WideStringLEToN Function

WideStringLEToN Function
Syntax
Pascal
function WideStringLEToN(const AValue: WideString): WideString;
File

fpsutils

Parameters
Parameters | Description
const AValue: WideString | Little-endian widestring
Returns

Big-endian widestring

Description

Converts a widestring from little-endian to big-endian byte-order.

Group

Functions


WideStringToLE Function

WideStringToLE Function
Syntax
Pascal
function WideStringToLE(const AValue: WideString): WideString;
File

fpsutils

Parameters
Parameters | Description
const AValue: WideString | Big-endian widestring
Returns

Little-endian widestring

Description

Converts a widestring from big-endian to little-endian byte-order.

Group

Functions


WordLEtoN Function

WordLEtoN Function
Syntax
Pascal
function WordLEtoN(AValue: Word): Word;
File

fpsutils

Parameters
Parameters | Description
AValue: Word | Little-endian word value
Returns

Big-endian word value

Description

Converts a word value from little-endian to big-endian byte-order.

Group

Functions


WordToLE Function

WordToLE Function
Syntax
Pascal
function WordToLE(AValue: Word): Word;
File

fpsutils

Parameters
Parameters | Description
AValue: Word | Big-endian word value
Returns

Little-endian word value

Description

WordLEToLE converts a word value from big-endian to little-endian byte order.

Group

Functions


Structs, Records, Enums

Structs, Records, Enums

The following table lists structs, records, enums in this documentation.

Enumerations
Name
Description
TByteOrder
TsAutoExpandMode
TsCellFormatItem
TsInspectorExpandedNode
Inspector expanded nodes
TsInspectorMode
Classification of data displayed by the SpreadsheetInspector. Each item can be assigned to a tab of a TabControl.
TsNotificationItem
Describes during communication between WorkbookSource and visual controls which kind of item has changed: the workbook, the worksheet, a cell value, or a cell formatting, etc.
TsNumFormatKind
Summary information classifying a number format section
TsNumFormatToken
Tokens used by the elements of the number format parser. If, e.g. a format string is "0.000" then the number format parser detects the following three tokens
  • nftIntZeroDigit with integer value 1 (i.e. 1 zero-digit for the integer part)
  • nftDecSep (i.e. decimal separator)
  • ntZeroDecs with integer value 2 (i.e. 3 decimal places.
TsSelectionDirection
Selection direction along column or along row
TsSheetOption
Worksheet user interface options:
TsWorkbookOption
Option flags for the workbook
Records
Name | Description
TCol | The record TCol contains information about a spreadsheet column:
TImageTypeRecord |
TRGBA | Color value, composed of r(ed), g(reen) and b(lue) components
TRow | The record TRow contains information about a spreadsheet row:
TsNumFormatElement | Element of the parsed number format sequence. Each element is identified by a token and has optional parameters stored as integer, float, and/or text.
TsNumFormatSection | Number format string can be composed of several parts separated by a semicolon. The number format parser extracts the format information into individual sections for each part


TByteOrder Enumeration

TByteOrder Enumeration
Syntax
Pascal
TByteOrder = (
  boLE,
  boBE
);
File

fpsimages

Group

Structs, Records, Enums


TCol Record

TCol Record
Syntax
Pascal
TCol = record
  Col: Cardinal;
  Width: Single;
end;
File

fpspreadsheet

Parameters
Parameters | Description
Col | The index of the column (beginning with 0)
Width | The width of the column (expressed in character count of the "0" character of the default font. Only columns with non-default widths have a column record.
Description

The record TCol contains information about a spreadsheet column:

Group

Structs, Records, Enums


TImageTypeRecord Record

TImageTypeRecord Record
Syntax
Pascal
TImageTypeRecord = record
  Ext: String;
  MimeType: String;
  GetImageSize: TGetImageSizeFunc;
end;
File

fpsimages

Group

Structs, Records, Enums


TRGBA Record

TRGBA Record
Syntax
Pascal
TRGBA = record
  a: byte;
  b: byte;
  g: byte;
  r: byte;
end;
File

fpsutils

Description

Color value, composed of r(ed), g(reen) and b(lue) components

Group

Structs, Records, Enums


TRow Record

TRow Record
Syntax
Pascal
TRow = record
  Row: Cardinal;
  Height: Single;
end;
File

fpspreadsheet

Parameters
Parameters | Description
Row | The index of the row (beginning with 0)
Height | The height of the row (expressed as lines count of the default font) Only rows with heights that cannot be derived from the font height have a row record.
Description

The record TRow contains information about a spreadsheet row:

Group

Structs, Records, Enums


TsAutoExpandMode Enumeration

TsAutoExpandMode Enumeration
Syntax
Pascal
TsAutoExpandMode = (
  aeData,
  aeNavigation
);
File

fpspreadsheetgrid

Group

Structs, Records, Enums


TsCellFormatItem Enumeration

TsCellFormatItem Enumeration
Syntax
Pascal
TsCellFormatItem = (
  cfiFontName,
  cfiFontSize,
  cfiFontColor,
  cfiBackgroundColor,
  cfiBorderColor
);
File

fpspreadsheetctrls

Group

Structs, Records, Enums


TsInspectorExpandedNode Enumeration

TsInspectorExpandedNode Enumeration
Syntax
Pascal
TsInspectorExpandedNode = (
  ienFormatSettings,
  ienPageLayout
);
File

fpspreadsheetctrls

Description

Inspector expanded nodes

Group

Structs, Records, Enums


TsInspectorMode Enumeration

TsInspectorMode Enumeration
Syntax
Pascal
TsInspectorMode = (
  imWorkbook,
  imWorksheet,
  imCellValue,
  imCellProperties
);
File

fpspreadsheetctrls

Description

Classification of data displayed by the SpreadsheetInspector. Each item can be assigned to a tab of a TabControl.

Group

Structs, Records, Enums


TsNotificationItem Enumeration

TsNotificationItem Enumeration
Syntax
Pascal
TsNotificationItem = (
  lniWorkbook,
  lniWorksheet,
  lniWorksheetAdd,
  lniWorksheetRemoving,
  lniWorksheetRemove,
  lniWorksheetRename,
  lniCell,
  lniSelection,
  lniAbortSelection,
  lniRow
);
File

fpspreadsheetctrls

Description

Describes during communication between WorkbookSource and visual controls which kind of item has changed: the workbook, the worksheet, a cell value, or a cell formatting, etc.

Group

Structs, Records, Enums


TsNumFormatElement Record

TsNumFormatElement Record
Syntax
Pascal
TsNumFormatElement = record
  Token: TsNumFormatToken;
  IntValue: Integer;
  FloatValue: Double;
  TextValue: String;
end;
File

fpsnumformat

Members
Members | Description
Token: TsNumFormatToken; | Token identifying the number format element
IntValue: Integer; | Integer value associated with the number format element
FloatValue: Double; | Floating point value associated with the number format element
TextValue: String; | String value associated with the number format element
Description

Element of the parsed number format sequence. Each element is identified by a token and has optional parameters stored as integer, float, and/or text.

Group

Structs, Records, Enums


TsNumFormatKind Enumeration

TsNumFormatKind Enumeration
Syntax
Pascal
TsNumFormatKind = (
  nfkPercent,
  nfkExp,
  nfkCurrency,
  nfkFraction,
  nfkDate,
  nfkTime,
  nfkTimeInterval,
  nfkText,
  nfkHasColor,
  nfkHasThSep,
  nfkHasFactor
);
File

fpsnumformat

Description

Summary information classifying a number format section

Group

Structs, Records, Enums


TsNumFormatSection Record

TsNumFormatSection Record
Syntax
Pascal
TsNumFormatSection = record
  Elements: TsNumFormatElements;
  Kind: TsNumFormatKinds;
  NumFormat: TsNumberFormat;
  Decimals: Byte;
  Factor: Double;
  FracInt: Integer;
  FracNumerator: Integer;
  FracDenominator: Integer;
  CurrencySymbol: String;
  Color: TsColor;
end;
File

fpsnumformat

Members
Members | Description
Elements: TsNumFormatElements; | Parser number format elements used by this section
Kind: TsNumFormatKinds; | Summary information describing the section
NumFormat: TsNumberFormat; | Reconstructed number format identifier for the built-in fps formats
Decimals: Byte; | Number of decimal places used by the format string
Factor: Double; | Factor by which a number will be multiplied before converting to string
FracInt: Integer; | Digits to be used for the integer part of a fraction
FracNumerator: Integer; | Digits to be used for the numerator part of a fraction
FracDenominator: Integer; | Digits to be used for the denominator part of a fraction
CurrencySymbol: String; | Currency string to be used in case of currency/accounting formats
Color: TsColor; | Color to be used when displaying the converted string
Description

Number format string can be composed of several parts separated by a semicolon. The number format parser extracts the format information into individual sections for each part

Group

Structs, Records, Enums


TsNumFormatToken Enumeration

TsNumFormatToken Enumeration
Syntax
Pascal
TsNumFormatToken = (
  nftGeneral,
  nftText,
  nftThSep,
  nftDecSep,
  nftYear,
  nftMonth,
  nftDay,
  nftHour,
  nftMinute,
  nftSecond,
  nftMilliseconds,
  nftAMPM,
  nftMonthMinute,
  nftDateTimeSep,
  nftSign,
  nftSignBracket,
  nftIntOptDigit,
  nftIntZeroDigit,
  nftIntSpaceDigit,
  nftIntTh,
  nftZeroDecs,
  nftOptDecs,
  nftSpaceDecs,
  nftExpChar,
  nftExpSign,
  nftExpDigits,
  nftPercent,
  nftFactor,
  nftFracSymbol,
  nftFracNumOptDigit,
  nftFracNumSpaceDigit,
  nftFracNumZeroDigit,
  nftFracDenomOptDigit,
  nftFracDenomSpaceDigit,
  nftFracDenomZeroDigit,
  nftFracDenom,
  nftCurrSymbol,
  nftCountry,
  nftColor,
  nftCompareOp,
  nftCompareValue,
  nftSpace,
  nftEscaped,
  nftRepeat,
  nftEmptyCharWidth,
  nftTextFormat
);
File

fpsnumformat

Description

Tokens used by the elements of the number format parser. If, e.g. a format string is "0.000" then the number format parser detects the following three tokens

  • nftIntZeroDigit with integer value 1 (i.e. 1 zero-digit for the integer part)
  • nftDecSep (i.e. decimal separator)
  • ntZeroDecs with integer value 2 (i.e. 3 decimal places.
Group

Structs, Records, Enums


TsSelectionDirection Enumeration

TsSelectionDirection Enumeration
Syntax
Pascal
TsSelectionDirection = (
  fpsVerticalSelection,
  fpsHorizontalSelection
);
File

fpsutils

Description

Selection direction along column or along row

Group

Structs, Records, Enums


TsSheetOption Enumeration

TsSheetOption Enumeration
Syntax
Pascal
TsSheetOption = (
  soShowGridLines,
  soShowHeaders,
  soHasFrozenPanes
);
File

fpspreadsheet

Parameters
Parameters | Description
soShowGridLines | Show or hide the grid lines in the spreadsheet
soShowHeaders | Show or hide the column or row headers of the spreadsheet
soHasFrozenPanes | If set a number of rows and columns of the spreadsheet is fixed and does not scroll. The number is defined by LeftPaneWidth and TopPaneHeight.
Description

Worksheet user interface options:

Group

Structs, Records, Enums


TsWorkbookOption Enumeration

TsWorkbookOption Enumeration
Syntax
Pascal
TsWorkbookOption = (
  boVirtualMode,
  boBufStream,
  boFileStream,
  boAutoCalc,
  boCalcBeforeSaving,
  boReadFormulas
);
File

fpspreadsheet

Parameters
Parameters | Description
boVirtualMode | If in virtual mode date are not taken from cells when a spreadsheet is written to file, but are provided by means of the event OnWriteCellData. Similarly, when data are read they are not added as cells but passed the the event OnReadCellData;
boBufStream | When this option is set a buffered stream is used for writing (a memory stream swapping to disk) or reading (a file stream pre-reading chunks of data to memory)
boFileStream | Uses file streams and temporary files during reading and writing. Lowest memory consumptions, but slow.
boAutoCalc | Automatically recalculate rpn formulas whenever a cell value changes.
boCalcBeforeSaving | Calculates formulas before saving the file. Otherwise there are no results when the file is loaded back by fpspreadsheet.
boReadFormulas | Allows to turn off reading of rpn formulas; this is a precaution since formulas not correctly implemented by fpspreadsheet could crash the reading operation.
Description

Option flags for the workbook

Group

Structs, Records, Enums


Types

Types

The following table lists types in this documentation.

Types
Name | Description
PCol | Pointer to a TCol record
PRow | Pointer to a TRow record
PsNumFormatSection | Pointer to a parsed number format section
TAnsiCharSet | Set of ansi characters
TGetImageSizeFunc |
TsAutoExpandModes |
TsCellCompareEvent | This event can be used to override the built-in comparing function which is called when cells are sorted.
TsCellEvent | This event fires whenever a cell value or cell formatting changes. It is handled by TsWorkbookLink to update the listening controls.
TsDecsChars | Set of characters
TsHyperlinkClickEvent |
TsImageType |
TsInspectorExpandedNodes |
TsNotificationItems | This set accompanies the notification between WorkbookSource and visual controls and describes which items have changed in the spreadsheet.
TsNumFormatElements | Array of parsed number format elements
TsNumFormatKinds | Set of summary elements classifying and describing a number format section
TsNumFormatParamsClass | Class of number format parameters
TsNumFormatSections | Array of parsed number format sections
TsNumFormatTokenSet | Set of parsed number format tokens
TsRemoveWorksheetEvent | Event procedure called when a worksheet is removed
TsSheetOptions | Set of user interface options @ see TsSheetOption
TStringArray | Array of strings
TsWorkbookOptions | Set of option flags for the workbook
TsWorkbookReadCellDataEvent | Event fired when reading a file in virtual mode. Read data are provided in the "ADataCell" (which is not added to the worksheet in virtual mode).
TsWorkbookSourceErrorEvent | Event handler procedure for displaying a message if an error or warning occurs during reading of a workbook.
TsWorkbookWriteCellDataEvent | Event fired when writing a file in virtual mode. The event handler has to pass data ("AValue") and formatting style to be copied from a template cell ("AStyleCell") to the writer
TsWorksheetEvent | Event procedure containing a specific worksheet


PCol Type

PCol Type
Syntax
Pascal
PCol = ^TCol;
File

fpspreadsheet

Description

Pointer to a TCol record

Group

Types


PRow Type

PRow Type
Syntax
Pascal
PRow = ^TRow;
File

fpspreadsheet

Description

Pointer to a TRow record

Group

Types


PsNumFormatSection Type

PsNumFormatSection Type
Syntax
Pascal
PsNumFormatSection = ^TsNumFormatSection;
File

fpsnumformat

Description

Pointer to a parsed number format section

Group

Types


TAnsiCharSet Type

TAnsiCharSet Type
Syntax
Pascal
TAnsiCharSet = set of ansichar;
File

fpsutils

Description

Set of ansi characters

Group

Types


TGetImageSizeFunc Type

TGetImageSizeFunc Type
Syntax
Pascal
TGetImageSizeFunc = function (AStream: TStream; out AWidth, AHeight: DWord; out dpiX, dpiY: Double): Boolean;
File

fpsimages

Group

Types


TsAutoExpandModes Type

TsAutoExpandModes Type
Syntax
Pascal
TsAutoExpandModes = set of TsAutoExpandMode;
File

fpspreadsheetgrid

Group

Types


TsCellCompareEvent Type

TsCellCompareEvent Type
Syntax
Pascal
TsCellCompareEvent = procedure (Sender: TObject; ACell1, ACell2: PCell; var AResult: Integer) of object;
File

fpspreadsheet

Description

This event can be used to override the built-in comparing function which is called when cells are sorted.

Group

Types


TsCellEvent Type

TsCellEvent Type
Syntax
Pascal
TsCellEvent = procedure (Sender: TObject; ARow, ACol: Cardinal) of object;
File

fpspreadsheet

Description

This event fires whenever a cell value or cell formatting changes. It is handled by TsWorkbookLink to update the listening controls.

Group

Types


TsDecsChars Type

TsDecsChars Type
Syntax
Pascal
TsDecsChars = set of char;
File

fpsnumformat

Description

Set of characters

Group

Types


TsHyperlinkClickEvent Type

TsHyperlinkClickEvent Type
Syntax
Pascal
TsHyperlinkClickEvent = procedure (Sender: TObject; const AHyperlink: TsHyperlink) of object;
File

fpspreadsheetgrid

Group

Types


TsImageType Type

TsImageType Type
Syntax
Pascal
TsImageType = integer;
File

fpsimages

Group

Types


TsInspectorExpandedNodes Type

TsInspectorExpandedNodes Type
Syntax
Pascal
TsInspectorExpandedNodes = set of TsInspectorExpandedNode;
File

fpspreadsheetctrls

Group

Types


TsNotificationItems Type

TsNotificationItems Type
Syntax
Pascal
TsNotificationItems = set of TsNotificationItem;
File

fpspreadsheetctrls

Description

This set accompanies the notification between WorkbookSource and visual controls and describes which items have changed in the spreadsheet.

Group

Types


TsNumFormatElements Type

TsNumFormatElements Type
Syntax
Pascal
TsNumFormatElements = array of TsNumFormatElement;
File

fpsnumformat

Description

Array of parsed number format elements

Group

Types


TsNumFormatKinds Type

TsNumFormatKinds Type
Syntax
Pascal
TsNumFormatKinds = set of TsNumFormatKind;
File

fpsnumformat

Description

Set of summary elements classifying and describing a number format section

Group

Types


TsNumFormatParamsClass Type

TsNumFormatParamsClass Type
Syntax
Pascal
TsNumFormatParamsClass = class of TsNumFormatParams;
File

fpsnumformat

Description

Class of number format parameters

Group

Types


TsNumFormatSections Type

TsNumFormatSections Type
Syntax
Pascal
TsNumFormatSections = array of TsNumFormatSection;
File

fpsnumformat

Description

Array of parsed number format sections

Group

Types


TsNumFormatTokenSet Type

TsNumFormatTokenSet Type
Syntax
Pascal
TsNumFormatTokenSet = set of TsNumFormatToken;
File

fpsnumformat

Description

Set of parsed number format tokens

Group

Types


TsRemoveWorksheetEvent Type

TsRemoveWorksheetEvent Type
Syntax
Pascal
TsRemoveWorksheetEvent = procedure (Sender: TObject; ASheetIndex: Integer) of object;
File

fpspreadsheet

Description

Event procedure called when a worksheet is removed

Group

Types


TsSheetOptions Type

TsSheetOptions Type
Syntax
Pascal
TsSheetOptions = set of TsSheetOption;
File

fpspreadsheet

Description

Set of user interface options @ see TsSheetOption

Group

Types


TStringArray Type

TStringArray Type
Syntax
Pascal
TStringArray = array of string;
File

fpsutils

Description

Array of strings

Group

Types


TsWorkbookOptions Type

TsWorkbookOptions Type
Syntax
Pascal
TsWorkbookOptions = set of TsWorkbookOption;
File

fpspreadsheet

Description

Set of option flags for the workbook

Group

Types


TsWorkbookReadCellDataEvent Type

TsWorkbookReadCellDataEvent Type
Syntax
Pascal
TsWorkbookReadCellDataEvent = procedure (Sender: TObject; ARow, ACol: Cardinal; const ADataCell: PCell) of object;
File

fpspreadsheet

Description

Event fired when reading a file in virtual mode. Read data are provided in the "ADataCell" (which is not added to the worksheet in virtual mode).

Group

Types


TsWorkbookSourceErrorEvent Type

TsWorkbookSourceErrorEvent Type
Syntax
Pascal
TsWorkbookSourceErrorEvent = procedure (Sender: TObject; const AMsg: String) of object;
File

fpspreadsheetctrls

Description

Event handler procedure for displaying a message if an error or warning occurs during reading of a workbook.

Group

Types


TsWorkbookWriteCellDataEvent Type

TsWorkbookWriteCellDataEvent Type
Syntax
Pascal
TsWorkbookWriteCellDataEvent = procedure (Sender: TObject; ARow, ACol: Cardinal; var AValue: variant; var AStyleCell: PCell) of object;
File

fpspreadsheet

Description

Event fired when writing a file in virtual mode. The event handler has to pass data ("AValue") and formatting style to be copied from a template cell ("AStyleCell") to the writer

Group

Types


TsWorksheetEvent Type

TsWorksheetEvent Type
Syntax
Pascal
TsWorksheetEvent = procedure (Sender: TObject; ASheet: TsWorksheet) of object;
File

fpspreadsheet

Description

Event procedure containing a specific worksheet

Group

Types


Variables

Variables

The following table lists variables in this documentation.

Variables
Name | Description
cfBiff5Format |
cfBiff8Format |
cfCSVFormat |
cfHTMLFormat |
cfTextHTMLFormat |
ComboColors |
FillPatternBgColor |
FillPatternBitmap | Auxiliary bitmap containing the previously used non-trivial fill pattern
FillPatternFgColor |
FillPatternStyle |
ImageTypeRegistry |
itBMP |
itEMF |
itGIF |
itJPEG |
itPCX |
itPNG |
itSVG |
itTIFF |
itWMF |
ScreenPixelsPerInch | Default value for the screen pixel density (pixels per inch). Is needed for conversion of distances to pixels
UTF8FormatSettings | FPC format settings for which all strings have been converted to UTF8


cfBiff5Format Variable

cfBiff5Format Variable
Syntax
Pascal
cfBiff5Format: Integer = 0;
File

fpspreadsheetctrls

Group

Variables


cfBiff8Format Variable

cfBiff8Format Variable
Syntax
Pascal
cfBiff8Format: Integer = 0;
File

fpspreadsheetctrls

Group

Variables


cfCSVFormat Variable

cfCSVFormat Variable
Syntax
Pascal
cfCSVFormat: Integer = 0;
File

fpspreadsheetctrls

Group

Variables


cfHTMLFormat Variable

cfHTMLFormat Variable
Syntax
Pascal
cfHTMLFormat: Integer = 0;
File

fpspreadsheetctrls

Group

Variables


cfTextHTMLFormat Variable

cfTextHTMLFormat Variable
Syntax
Pascal
cfTextHTMLFormat: Integer = 0;
File

fpspreadsheetctrls

Group

Variables


ComboColors Variable

ComboColors Variable
Syntax
Pascal
ComboColors: TsPalette = nil;
File

fpspreadsheetctrls

Group

Variables


FillPatternBgColor Variable

FillPatternBgColor Variable
Syntax
Pascal
FillPatternBgColor: TColor;
File

fpspreadsheetgrid

Group

Variables


FillPatternBitmap Variable

FillPatternBitmap Variable
Syntax
Pascal
FillPatternBitmap: TBitmap = nil;
File

fpspreadsheetgrid

Description

Auxiliary bitmap containing the previously used non-trivial fill pattern

Group

Variables


FillPatternFgColor Variable

FillPatternFgColor Variable
Syntax
Pascal
FillPatternFgColor: TColor;
File

fpspreadsheetgrid

Group

Variables


FillPatternStyle Variable

FillPatternStyle Variable
Syntax
Pascal
FillPatternStyle: TsFillStyle;
File

fpspreadsheetgrid

Group

Variables


ImageTypeRegistry Variable

ImageTypeRegistry Variable
Syntax
Pascal
ImageTypeRegistry: array of TImageTypeRecord;
File

fpsimages

Group

Variables


itBMP Variable

itBMP Variable
Syntax
Pascal
itBMP: TsImageType;
File

fpsimages

Group

Variables


itEMF Variable

itEMF Variable
Syntax
Pascal
itEMF: TsImageType;
File

fpsimages

Group

Variables


itGIF Variable

itGIF Variable
Syntax
Pascal
itGIF: TsImageType;
File

fpsimages

Group

Variables


itJPEG Variable

itJPEG Variable
Syntax
Pascal
itJPEG: TsImageType;
File

fpsimages

Group

Variables


itPCX Variable

itPCX Variable
Syntax
Pascal
itPCX: TsImageType;
File

fpsimages

Group

Variables


itPNG Variable

itPNG Variable
Syntax
Pascal
itPNG: TsImageType;
File

fpsimages

Group

Variables


itSVG Variable

itSVG Variable
Syntax
Pascal
itSVG: TsImageType;
File

fpsimages

Group

Variables


itTIFF Variable

itTIFF Variable
Syntax
Pascal
itTIFF: TsImageType;
File

fpsimages

Group

Variables


itWMF Variable

itWMF Variable
Syntax
Pascal
itWMF: TsImageType;
File

fpsimages

Group

Variables


ScreenPixelsPerInch Variable

ScreenPixelsPerInch Variable
Syntax
Pascal
ScreenPixelsPerInch: Integer = 96;
File

fpsutils

Description

Default value for the screen pixel density (pixels per inch). Is needed for conversion of distances to pixels

Group

Variables


UTF8FormatSettings Variable

UTF8FormatSettings Variable
Syntax
Pascal
UTF8FormatSettings: TFormatSettings;
File

fpsutils

Description

FPC format settings for which all strings have been converted to UTF8

Group

Variables


Constants

Constants

The following table lists constants in this documentation.

Constants
Name | Description
DECS_TOKENS | Set of tokens which describe the decimals of a number format
DEFAULT_COL_COUNT | Default number of columns prepared for a new empty worksheet
DEFAULT_ROW_COUNT | Default number of rows prepared for a new empty worksheet
EXP_TOKENS | Set of tokens which describe the exponent in exponential formatting of a number
FRACDENOM_TOKENS | Set of tokens which describe the denominator of a fraction format
FRACNUM_TOKENS | Set of tokens which describe the numerator of a fraction format
GUID_SpreadsheetControl |
HUE_000 |
HUE_060 |
HUE_120 |
HUE_180 |
HUE_240 |
HYPERLINK_TIMER_INTERVAL | Interval how long the mouse buttons has to be held down on a hyperlink cell until the associated hyperlink is executed.
INT_NUM_LETTERS |
INT_TOKENS | Set of tokens which describe the integer part of a number format
ISO8601Format | Date formatting string for unambiguous date/time display as strings Can be used for text output when date/time cell support is not available
ISO8601FormatDateOnly | ISO 8601 date-only format, used in ODF/opendocument
ISO8601FormatExtended | Extended ISO 8601 date/time format, used in e.g. ODF/opendocument
ISO8601FormatHoursOverflow | ISO 8601 time-only format, with hours overflow
ISO8601FormatTimeOnly | ISO 8601 time-only format, used in ODF/opendocument
itUnknown |
NEG_CURR_FMT | Array of format strings identifying the order of number and currency symbol of a negative currency value. The sign is shown as a dash character ("-") or by means of brackets. The number is expected at index 0, the currency symbol at index 1 of the parameter array for the fpc Format() function.
NO_CELL_BORDER |
POS_CURR_FMT | Array of format strings identifying the order of number and currency symbol of a positive currency value. The number is expected at index 0, the currency symbol at index 1 of the parameter array used by the fpc Format() function.
RELCHAR |
TERMINATING_TOKENS | Set of tokens which terminate number information in a format string


DECS_TOKENS Constant

DECS_TOKENS Constant
Syntax
Pascal
DECS_TOKENS: TsNumFormatTokenSet = [nftZeroDecs, nftOptDecs, nftSpaceDecs];
File

fpsnumformat

Description

Set of tokens which describe the decimals of a number format

Group

Constants


DEFAULT_COL_COUNT Constant

DEFAULT_COL_COUNT Constant
Syntax
Pascal
DEFAULT_COL_COUNT = 26;
File

fpspreadsheetgrid

Description

Default number of columns prepared for a new empty worksheet

Group

Constants


DEFAULT_ROW_COUNT Constant

DEFAULT_ROW_COUNT Constant
Syntax
Pascal
DEFAULT_ROW_COUNT = 100;
File

fpspreadsheetgrid

Description

Default number of rows prepared for a new empty worksheet

Group

Constants


EXP_TOKENS Constant

EXP_TOKENS Constant
Syntax
Pascal
EXP_TOKENS: TsNumFormatTokenSet = [nftExpDigits];
File

fpsnumformat

Description

Set of tokens which describe the exponent in exponential formatting of a number

Group

Constants


FRACDENOM_TOKENS Constant

FRACDENOM_TOKENS Constant
Syntax
Pascal
FRACDENOM_TOKENS: TsNumFormatTokenSet = [nftFracDenomOptDigit, nftFracDenomZeroDigit, nftFracDenomSpaceDigit, nftFracDenom];
File

fpsnumformat

Description

Set of tokens which describe the denominator of a fraction format

Group

Constants


FRACNUM_TOKENS Constant

FRACNUM_TOKENS Constant
Syntax
Pascal
FRACNUM_TOKENS: TsNumFormatTokenSet = [nftFracNumOptDigit, nftFracNumZeroDigit, nftFracNumSpaceDigit];
File

fpsnumformat

Description

Set of tokens which describe the numerator of a fraction format

Group

Constants


GUID_SpreadsheetControl Constant

GUID_SpreadsheetControl Constant
Syntax
Pascal
GUID_SpreadsheetControl = '{CBCAAE52-D29E-4D0C-A7F4-1016C873448A}';
File

fpspreadsheetctrls

Group

Constants


HUE_000 Constant

HUE_000 Constant
Syntax
Pascal
HUE_000 = 0;
File

fpsutils

Group

Constants


HUE_060 Constant

HUE_060 Constant
Syntax
Pascal
HUE_060 = 43;
File

fpsutils

Group

Constants


HUE_120 Constant

HUE_120 Constant
Syntax
Pascal
HUE_120 = 85;
File

fpsutils

Group

Constants


HUE_180 Constant

HUE_180 Constant
Syntax
Pascal
HUE_180 = 128;
File

fpsutils

Group

Constants


HUE_240 Constant

HUE_240 Constant
Syntax
Pascal
HUE_240 = 170;
File

fpsutils

Group

Constants


HYPERLINK_TIMER_INTERVAL Constant

HYPERLINK_TIMER_INTERVAL Constant
Syntax
Pascal
HYPERLINK_TIMER_INTERVAL = 500;
File

fpspreadsheetgrid

Description

Interval how long the mouse buttons has to be held down on a hyperlink cell until the associated hyperlink is executed.

Group

Constants


INT_NUM_LETTERS Constant

INT_NUM_LETTERS Constant
Syntax
Pascal
INT_NUM_LETTERS = 26;
File

fpsutils

Group

Constants


INT_TOKENS Constant

INT_TOKENS Constant
Syntax
Pascal
INT_TOKENS: TsNumFormatTokenSet = [nftIntOptDigit, nftIntZeroDigit, nftIntSpaceDigit];
File

fpsnumformat

Description

Set of tokens which describe the integer part of a number format

Group

Constants


ISO8601Format Constant

ISO8601Format Constant
Syntax
Pascal
ISO8601Format = 'yyyymmdd"T"hhmmss';
File

fpsutils

Description

Date formatting string for unambiguous date/time display as strings Can be used for text output when date/time cell support is not available

Group

Constants


ISO8601FormatDateOnly Constant

ISO8601FormatDateOnly Constant
Syntax
Pascal
ISO8601FormatDateOnly = 'yyyy"-"mm"-"dd';
File

fpsutils

Description

ISO 8601 date-only format, used in ODF/opendocument

Group

Constants


ISO8601FormatExtended Constant

ISO8601FormatExtended Constant
Syntax
Pascal
ISO8601FormatExtended = 'yyyy"-"mm"-"dd"T"hh":"mm":"ss';
File

fpsutils

Description

Extended ISO 8601 date/time format, used in e.g. ODF/opendocument

Group

Constants


ISO8601FormatHoursOverflow Constant

ISO8601FormatHoursOverflow Constant
Syntax
Pascal
ISO8601FormatHoursOverflow = '"PT"[hh]"H"nn"M"ss.zz"S"';
File

fpsutils

Description

ISO 8601 time-only format, with hours overflow

Group

Constants


ISO8601FormatTimeOnly Constant

ISO8601FormatTimeOnly Constant
Syntax
Pascal
ISO8601FormatTimeOnly = '"PT"hh"H"nn"M"ss"S"';
File

fpsutils

Description

ISO 8601 time-only format, used in ODF/opendocument

Group

Constants


itUnknown Constant

itUnknown Constant
Syntax
Pascal
itUnknown = -1;
File

fpsimages

Group

Constants


NEG_CURR_FMT Constant

NEG_CURR_FMT Constant
Syntax
Pascal
NEG_CURR_FMT: array[0..15] of string = ( ('(%1:s%0:s)'), ('-%1:s%0:s'), ('%1:s-%0:s'), ('%1:s%0:s-'), ('(%0:s%1:s)'), ('-%0:s%1:s'), ('%0:s-%1:s'), ('%0:s%1:s-'), ('-%0:s %1:s'), ('-%1:s %0:s'), ('%0:s %1:s-'), ('%1:s %0:s-'), ('%1:s -%0:s'), ('%0:s- %1:s'), ('(%1:s %0:s)'), ('(%0:s %1:s)') );
File

fpsnumformat

Description

Array of format strings identifying the order of number and currency symbol of a negative currency value. The sign is shown as a dash character ("-") or by means of brackets. The number is expected at index 0, the currency symbol at index 1 of the parameter array for the fpc Format() function.

Group

Constants


NO_CELL_BORDER Constant

NO_CELL_BORDER Constant
Syntax
Pascal
NO_CELL_BORDER: TsCellBorderStyle = (LineStyle: lsThin; Color: scNotDefined);
File

fpspreadsheetgrid

Group

Constants


POS_CURR_FMT Constant

POS_CURR_FMT Constant
Syntax
Pascal
POS_CURR_FMT: array[0..3] of string = ( ('%1:s%0:s'), ('%0:s%1:s'), ('%1:s %0:s'), ('%0:s %1:s') );
File

fpsnumformat

Description

Array of format strings identifying the order of number and currency symbol of a positive currency value. The number is expected at index 0, the currency symbol at index 1 of the parameter array used by the fpc Format() function.

Group

Constants


RELCHAR Constant

RELCHAR Constant
Syntax
Pascal
RELCHAR: Array[boolean] of String = ('$', '');
File

fpsutils

Group

Constants


TERMINATING_TOKENS Constant

TERMINATING_TOKENS Constant
Syntax
Pascal
TERMINATING_TOKENS: TsNumFormatTokenSet = [nftSpace, nftText, nftEscaped, nftPercent, nftCurrSymbol, nftSign, nftSignBracket];
File

fpsnumformat

Description

Set of tokens which terminate number information in a format string

Group

Constants


Files

Files

The following table lists files in this documentation.

Units
Name | Description
fpsimages.pas |
fpsnumformat.pas | Unit fpsNumFormat contains classes and procedures to analyze and process number formats.
fpspreadsheet.pas | Unit fpspreadsheet implements spreadsheet documents and their properties and methods.
fpspreadsheetctrls.pas | Unit fpspreadsheetctrls implements some visual controls which help to create a spreadsheet application without writing too much code.
fpspreadsheetgrid.pas | Unit fpspreadsheet implements a grid component which can load and write data from/to FPSpreadsheet documents. Can either be used alone or in combination with a TsWorkbookSource component. The latter method requires less written code.
fpsutils.pas | Unit fpsUtils provides a variety of utility functions used throughout the fpspreadsheet library.


fpsimages.pas

fpsimages.pas
Constants
Name | Description
itUnknown |
Enumerations
Name | Description
TByteOrder |
Functions
Name | Description
GetImageInfo | Returns the width and height of the image loaded into the specified stream.
GetImageInfo | Returns the width and height of the image loaded into the specified stream.
GetImageMimeType | Returns the MimeType of the specified image type
GetImageTypeFromFileName | Extracts the image file type identifier from the extension of the specified file name.
GetTIFSize |
RegisterImageType | Registers an image type for usage in fpspreadsheet
Group

Files

Records
Name | Description
TImageTypeRecord |
Types
Name | Description
TGetImageSizeFunc |
TsImageType |
Variables
Name | Description
ImageTypeRegistry |
itBMP |
itEMF |
itGIF |
itJPEG |
itPCX |
itPNG |
itSVG |
itTIFF |
itWMF |


fpsnumformat.pas

fpsnumformat.pas

Unit fpsNumFormat contains classes and procedures to analyze and process number formats.

Author

Werner Pamler

Classes
Name | Description
TsNumFormatList | List containing parsed number format parameters
TsNumFormatParams | Describes a parsed number format and provides all the information to convert a number to a number or date/time string. These data are created by the number format parser from a format string.
Constants
Name | Description
DECS_TOKENS | Set of tokens which describe the decimals of a number format
EXP_TOKENS | Set of tokens which describe the exponent in exponential formatting of a number
FRACDENOM_TOKENS | Set of tokens which describe the denominator of a fraction format
FRACNUM_TOKENS | Set of tokens which describe the numerator of a fraction format
INT_TOKENS | Set of tokens which describe the integer part of a number format
NEG_CURR_FMT | Array of format strings identifying the order of number and currency symbol of a negative currency value. The sign is shown as a dash character ("-") or by means of brackets. The number is expected at index 0, the currency symbol at index 1 of the parameter array for the fpc Format() function.
POS_CURR_FMT | Array of format strings identifying the order of number and currency symbol of a positive currency value. The number is expected at index 0, the currency symbol at index 1 of the parameter array used by the fpc Format() function.
TERMINATING_TOKENS | Set of tokens which terminate number information in a format string
Enumerations
Name
Description
TsNumFormatKind
Summary information classifying a number format section
TsNumFormatToken
Tokens used by the elements of the number format parser. If, e.g. a format string is "0.000" then the number format parser detects the following three tokens
  • nftIntZeroDigit with integer value 1 (i.e. 1 zero-digit for the integer part)
  • nftDecSep (i.e. decimal separator)
  • ntZeroDecs with integer value 2 (i.e. 3 decimal places.
Functions
Name | Description
AddAMPM | Adds an AM/PM format code to a pre-built time formatting string. The strings replacing "AM" or "PM" in the final formatted number are taken from the TimeAMString or TimePMString of the specified FormatSettings.
AddIntervalBrackets | The given format string is assumed to represent a time interval, i.e. its first time symbol must be enclosed by square brackets. Checks if this is true, and adds the brackes if not.
ApplyTextFormat | Applies a text format to a text. The text placeholder is @. Supports appending and prepending text.
BuildCurrencyFormatList | Builds a string list with samples of the predefined currency formats
BuildCurrencyFormatString | Builds a currency format string. The presentation of negative values (brackets, or minus signs) is taken from the provided format settings. The format string consists of three sections, separated by semicolons.
BuildDateTimeFormatString | Builds a date/time format string from the number format code.
BuildFormatStringFromSection | Creates a format string for the specified parsed number format section. The format string is created according to Excel convention (which is understood by ODS as well).
BuildFractionFormatString | Builds a number format string for fraction formatting from the number format code and the count of numerator and denominator digits.
BuildNumberFormatString | Builds a number format string from the number format code and the count of decimal places.
ConvertFloatToStr | Converts a floating point number to a string as determined by the specified number format parameters
CountDecs | Counts how many decimal places are coded into a given number format string.
InitFormatSettings | Initializes the FormatSettings of file a import/export parameters record to default values which can be replaced by the FormatSettings of the workbook's FormatSettings
IsBoolValue | Checks whether the specified text corresponds to a boolean value. For this, it must match the specified TRUE and FALSE text phrases.
IsCurrencyFormat | Checks whether the specified number format parameters apply to currency values.
IsCurrencyFormat | Checks whether the given number format code is for currency, i.e. requires a currency symbol.
IsDateFormat | Checks whether the specified number format parameters apply to a date value.
IsDateTimeFormat |
IsDateTimeFormat | Checks whether the specified number format parameters apply to date/time values.
IsDateTimeFormat | Checks whether the given number format code is for date/time values.
IsDateTimeValue | Checks whether the specified text corresponds to a date/time value and returns true, its numerical value and its built-in numberformat if it is.
IsLongTimeFormat |
IsNumberValue | Checks whether the specified text corresponds to a numerical value. If it is then the function result is TRUE, and the number value and its formatting parameters are returned.
IsTextFormat |
IsTimeFormat | Checks whether the given string with formatting codes is for time values.
IsTimeFormat | Checks whether the specified number format parameters apply to time values.
IsTimeFormat | Checks whether the given built-in number format code is for time values.
IsTimeIntervalFormat | Checks whether the specified number format parameters is a time interval format.
MakeLongDateFormat | Creates a long date format string out of a short date format string. Retains the order of year-month-day and the separators, but uses 4 digits for year and 3 digits of month.
MakeShortDateFormat | Modifies the short date format such that it has a two-digit year and a two-digit month. Retains the order of year-month-day and the separators.
MakeTimeIntervalMask | Creates a "time interval" format string having the first time code identifier in square brackets.
ReplaceFormatSettings | Replaces in AFormatSettings all members marked as having default values (#0, 1, '') by the corresponding values of the ADefaultFormats record
StripAMPM | Removes an AM/PM formatting code from a given time formatting string. Variants of "AM/PM" are considered as well. The string is left unchanged if it does not contain AM/PM codes.
Group

Files

Records
Name | Description
TsNumFormatElement | Element of the parsed number format sequence. Each element is identified by a token and has optional parameters stored as integer, float, and/or text.
TsNumFormatSection | Number format string can be composed of several parts separated by a semicolon. The number format parser extracts the format information into individual sections for each part
Types
Name | Description
PsNumFormatSection | Pointer to a parsed number format section
TsDecsChars | Set of characters
TsNumFormatElements | Array of parsed number format elements
TsNumFormatKinds | Set of summary elements classifying and describing a number format section
TsNumFormatParamsClass | Class of number format parameters
TsNumFormatSections | Array of parsed number format sections
TsNumFormatTokenSet | Set of parsed number format tokens
License

See the file COPYING.modifiedLGPL.txt, included in the Lazarus distribution, for details about the license.


fpspreadsheet.pas

fpspreadsheet.pas

Unit fpspreadsheet implements spreadsheet documents and their properties and methods.

Author

Felipe Monteiro de Carvalho, Reinier Olislagers, Werner Pamler

Classes
Name | Description
TsWorkbook |
TsWorksheet | The worksheet contains a list of cells and provides a variety of methods to read or write data to the cells, or to change their formatting.
Enumerations
Name | Description
TsSheetOption | Worksheet user interface options:
TsWorkbookOption | Option flags for the workbook
Functions
Name | Description
CopyCellFormat | Copies the format of a cell to another one.
Group

Files

Records
Name | Description
TCol | The record TCol contains information about a spreadsheet column:
TRow | The record TRow contains information about a spreadsheet row:
Types
Name | Description
PCol | Pointer to a TCol record
PRow | Pointer to a TRow record
TsCellCompareEvent | This event can be used to override the built-in comparing function which is called when cells are sorted.
TsCellEvent | This event fires whenever a cell value or cell formatting changes. It is handled by TsWorkbookLink to update the listening controls.
TsRemoveWorksheetEvent | Event procedure called when a worksheet is removed
TsSheetOptions | Set of user interface options @ see TsSheetOption
TsWorkbookOptions | Set of option flags for the workbook
TsWorkbookReadCellDataEvent | Event fired when reading a file in virtual mode. Read data are provided in the "ADataCell" (which is not added to the worksheet in virtual mode).
TsWorkbookWriteCellDataEvent | Event fired when writing a file in virtual mode. The event handler has to pass data ("AValue") and formatting style to be copied from a template cell ("AStyleCell") to the writer
TsWorksheetEvent | Event procedure containing a specific worksheet
License

See the file COPYING.modifiedLGPL.txt, included in the Lazarus distribution, for details about the license.


fpspreadsheetctrls.pas

fpspreadsheetctrls.pas

Unit fpspreadsheetctrls implements some visual controls which help to create a spreadsheet application without writing too much code.

Author

Werner Pamler

Example
  • Add a WorkbookSource component to the form.
  • Add a WorksheetTabControl
  • Add a WorksheetGrid (from unit fpspreadsheetgrid)
  • Link their WorkbookSource properties to the added WorkbookSource component
  • Set the property FileName of the WorkbookSource to a spreadsheet file.

As a result, the WorksheetTabControl displays tabs for each worksheet in the file, and the WorksheetGrid displays the worksheet according to the selected tab.

Classes
Name | Description
TsCellCombobox | TsCellCombobox is a multi-purpose combobox for selection of formatting items of a cell
TsCellEdit | TsCellEdit allows to edit the content or formula of the active cell of a worksheet, simular to Excel's cell editor above the cell grid.
TsCellIndicator | TsCellIndicator displays the address of the currently active cell of the worksheet and workbook. Editing the address allows to jump to the corresponding cell.
TsCellList |
TsSpreadsheetInspector | TsSpreadsheetInspector displays all properties of a workbook, worksheet, cell content and cell formatting in a way similar to the Object Inspector of Lazarus.
TsWorkbookSource | TsWorkbookSource links a workbook to the visual spreadsheet controls and help to display or edit the workbook without written code.
TsWorkbookTabControl | TsWorkbookTabControl is a tab control which displays the sheets of the workbook currently loaded by the WorkbookSource in tabs. Selecting another tab is communicated to other spreadsheet controls via the WorkbookSource.
Constants
Name | Description
GUID_SpreadsheetControl |
Enumerations
Name | Description
TsCellFormatItem |
TsInspectorExpandedNode | Inspector expanded nodes
TsInspectorMode | Classification of data displayed by the SpreadsheetInspector. Each item can be assigned to a tab of a TabControl.
TsNotificationItem | Describes during communication between WorkbookSource and visual controls which kind of item has changed: the workbook, the worksheet, a cell value, or a cell formatting, etc.
Functions
Name | Description
SpreadsheetFormatInClipboard | Returns TRUE if the clipboard contains a format good for pasting into a worksheet grid.
Group

Files

Interfaces
Name | Description
IsSpreadsheetControl | Interface which allows the workbook source to notify linked controls of changes in the associated workbook.
Types
Name | Description
TsInspectorExpandedNodes |
TsNotificationItems | This set accompanies the notification between WorkbookSource and visual controls and describes which items have changed in the spreadsheet.
TsWorkbookSourceErrorEvent | Event handler procedure for displaying a message if an error or warning occurs during reading of a workbook.
Variables
Name | Description
cfBiff5Format |
cfBiff8Format |
cfCSVFormat |
cfHTMLFormat |
cfTextHTMLFormat |
ComboColors |
License

See the file COPYING.modifiedLGPL.txt, included in the Lazarus distribution, for details about the license.


fpspreadsheetgrid.pas

fpspreadsheetgrid.pas

Unit fpspreadsheet implements a grid component which can load and write data from/to FPSpreadsheet documents.

Can either be used alone or in combination with a TsWorkbookSource component. The latter method requires less written code.

Author

Felipe Monteiro de Carvalho, Werner Pamler

Classes
Name | Description
TsCustomWorksheetGrid | TsCustomWorksheetGrid is the ancestor of TsWorksheetGrid and is able to display spreadsheet data along with their formatting.
TsSelPen |
TsWorksheetGrid | TsWorksheetGrid is a grid which displays spreadsheet data along with formatting. As it is linked to an instance of TsWorkbook, it provides methods for reading data from or writing to spreadsheet files. It has the same funtionality as TsCustomWorksheetGrid, but has published all properties.
Constants
Name | Description
DEFAULT_COL_COUNT | Default number of columns prepared for a new empty worksheet
DEFAULT_ROW_COUNT | Default number of rows prepared for a new empty worksheet
HYPERLINK_TIMER_INTERVAL | Interval how long the mouse buttons has to be held down on a hyperlink cell until the associated hyperlink is executed.
NO_CELL_BORDER |
Enumerations
Name | Description
TsAutoExpandMode |
Functions
Name | Description
Register | Registers the worksheet grid in the Lazarus component palette, page "FPSpreadsheet".
Group

Files

Types
Name | Description
TsAutoExpandModes |
TsHyperlinkClickEvent |
Variables
Name | Description
FillPatternBgColor |
FillPatternBitmap | Auxiliary bitmap containing the previously used non-trivial fill pattern
FillPatternFgColor |
FillPatternStyle |
License

See the file COPYING.modifiedLGPL.txt, included in the Lazarus distribution, for details about the license.


fpsutils.pas

fpsutils.pas

Unit fpsUtils provides a variety of utility functions used throughout the fpspreadsheet library.

Constants
Name | Description
HUE_000 |
HUE_060 |
HUE_120 |
HUE_180 |
HUE_240 |
INT_NUM_LETTERS |
ISO8601Format | Date formatting string for unambiguous date/time display as strings Can be used for text output when date/time cell support is not available
ISO8601FormatDateOnly | ISO 8601 date-only format, used in ODF/opendocument
ISO8601FormatExtended | Extended ISO 8601 date/time format, used in e.g. ODF/opendocument
ISO8601FormatHoursOverflow | ISO 8601 time-only format, with hours overflow
ISO8601FormatTimeOnly | ISO 8601 time-only format, used in ODF/opendocument
RELCHAR |
Enumerations
Name | Description
TsSelectionDirection | Selection direction along column or along row
Functions
Name | Description
AnalyzeCompareStr |
AppendToStream |
AppendToStream | Appends two strings to a stream
AppendToStream | Appends three strings to a stream
cmToPts | Converts centimeters to points (72 pts = 1 inch)
ColorToHTMLColorStr | Converts an rgb color value to a string as used in HTML code (for ods)
CopyCellValue | Copies the value of a cell to another one. Does not copy the formula, erases the formula of the destination cell if there is one!
DWordLEtoN | Converts a DWord value from little-endian to big-endian byte-order.
DWordToLE | DWordLEToLE converts a DWord value from big-endian to little-endian byte-order.
EMUToIn | Converts EMU (English metric units) to inches
EMUToMM | Converts EMU to millimeters
EnsureOrder |
EnsureOrder | Helper procedure which guarantees that a is not larger than b
FixHyperlinkPathDelims | Replaces backslashes by forward slashes in hyperlink path names
FixLineEndings | Replaces CRLF line endings by LF (#10) alone because this is what xml returns. This is required to keep the character indexes of the rich text formatting runs in synch when reading xml files.
FloatToFraction | Approximates a floating point value as a fraction and returns the values of numerator and denominator.
GetCellRangeString | Calculates a cell range address string from zero-based column and row indexes and the relative address state flags.
GetCellRangeString | Calculates a cell range address string from a TsCellRange record and the relative address state flags.
GetCellString | Calculates a cell address string from zero-based column and row indexes and the relative address state flags.
GetCellString_R1C1 | Calculates a cell address string in R1C1 notation from zero-based column and row indexes and the relative address state flags.
GetColorName | Determines the name of a color from its rgb value
GetColString | Calculates an Excel column name ('A', 'B' etc) from the zero-based column index
GetErrorValueStr | Returns the message text assigned to an error value
GetFileFormatName | Returns the name of the given spreadsheet file format.
GetFormatFromFileName | Determines the spreadsheet type from the file type extension
GetFormatFromFileName | Determines the spreadsheet type from the file type extension
HasFormula | Returns TRUE if the cell contains a formula.
HighContrastColor | Returns the color index for black or white depending on a color being "bright" or "dark".
HTMLColorStrToColor | Converts a HTML color string to a TsColor alue. Needed for the ODS file format.
HTMLLengthStrToPts | Converts a HTML length string to points. The units are assumed to be the last two digits of the string, such as '1.25in'
IfThen |
IfThen | Helper function to reduce typing: "if a conditions is true return the first number format, otherwise return the second format"
InitCell | Initalizes a new cell and presets the row and column fields of the cell record to the parameters passed to the procedure.
InitCell | Initalizes a new cell.
InitFormatRecord | Initializes the fields of a TsCellFormaRecord
InitHeaderFooterImageRecord | Initializes the fields of a TsHeaderFooterImage record
InitImageRecord | Initializes the fields of a TsImage record
InitSortParams | Initializes a Sortparams record. This record sets paramaters used when cells are sorted.
IntegerToLE | Converts an integer value from big-endian to little-endian byte-order.
InToEMU | Converts inches to EMU (English metric units)
InToMM | Converts inches to millimeters
InToPts | Converts inches to points (72 pts = 1 inch)
IsPaletteIndex | Checks whether the specified TsColor represents a palette index
LongRGBToExcelPhysical | Converts the RGB part of a LongRGB logical structure to its physical representation. In other words: RGBA (where A is 0 and omitted in the function call) => ABGR Needed for conversion of palette colors.
mmToEMU | Converts millimeters to EMU (english metric units, 1 cm = 360000 EMU)
mmToIn | Converts millimeters to inches
mmToPts | Converts millimeters to points (72 pts = 1 inch)
ParseCellColString | Parses a cell column string, like 'A' or 'CZ', into a zero-based column number. Note that there can be several letters to address more than 26 columns.
ParseCellRangeString | Parses strings like A5:C10 into a range selection information. Information on relative/absolute cells is ignored.
ParseCellRangeString | Parses strings like A5:C10 into a range selection information. Returns in AFlags also information on relative/absolute cells.
ParseCellRangeString | Parses strings like A5:C10 into a range selection information. Information on relative/absolute cells is ignored.
ParseCellRangeString | Parses strings like A5:C10 into a range selection information. Returns in AFlags also information on relative/absolute cells.
ParseCellRangeString_R1C1 | Extracts information on cell range from a cellrange string in "R1C1" notation. Returns in AFlags also information on relative/absolute cells.
ParseCellRowString | Parses a cell row string to a zero-based row number.
ParseCellString | Parses a cell string, like 'A1' into zero-based column and row numbers Note that there can be several letters to address for more than 26 columns. For compatibility with old version which does not return flags for relative cell addresses.
ParseCellString |
ParseCellString_R1C1 | Parses a cell string in "R1C1" notation into zero-based column and row numbers 'AFlags' indicates relative addresses.
ParseCellString_R1C1 | Parses a cell string in "R1C1" notation into zero-based column and row numbers For compatibility with old version which does not return flags for relative cell addresses.
ParseIntervalString | Parses strings like A5:A10 into an selection interval information
ParseSheetCellString |
PtsToCm | Converts points to centimeters
PtsToIn | Converts points to inches (72 pts = 1 inch)
PtsToMM | Converts points to millimeters
PtsToPx | Converts points to pixels
PtsToTwips | Converts points to twips (1 twip = 1/20 point)
pxToPts | Converts pixels to points.
Range | Creates a TsCellRange record from the provided cell corner coordinates. Put the coordinates into right order if needed.
SameCellBorders | Checks whether two format records have same border attributes
SameFont | Checks whether two fonts are equal
SameFont | Checks whether two fonts are equal
SetAsPaletteIndex | Constructs a TsColor from a palette index. It has bit 15 in the high-order byte set.
SplitHyperlink | Splits a hyperlink string at the # character.
SplitStr | Splits a string at the specified delimiters into individual strings and passes them in an array.
TintedColor | Excel defines theme colors and applies a "tint" factor (-1...+1) to darken or brighten them. This method "tints" a given color with a factor The algorithm is described in http://msdn.microsoft.com/en-us/library/documentformat.openxml.spreadsheet.backgroundcolor.aspx
TryFractionStrToFloat | Assumes that the specified text is a string representation of a mathematical fraction and tries to extract the floating point value of this number. Returns also the maximum count of digits used in the numerator or denominator of the fraction
TryStrToErrorValue | Returns the error value code from a string. Result is false, if the string does not match one of the predefined error strings.
TryStrToFloatAuto | Converts a string to a floating point number. No assumption on decimal and thousand separator are made. Is needed for reading CSV files.
TwipsToPts | Excel's unit of row heights is "twips", i.e. 1/20 point. Converts Twips to points.
UnquoteStr | Removes quotation characters which enclose a string
Unused | Silence warnings due to an unused parameter
Unused | Silence warnings due to two unused parameters
Unused | Silence warnings due to three unused parameters
WideStringLEToN | Converts a widestring from little-endian to big-endian byte-order.
WideStringToLE | Converts a widestring from big-endian to little-endian byte-order.
WordLEtoN | Converts a word value from little-endian to big-endian byte-order.
WordToLE | WordLEToLE converts a word value from big-endian to little-endian byte order.
Group

Files

Records
Name | Description
TRGBA | Color value, composed of r(ed), g(reen) and b(lue) components
Types
Name | Description
TAnsiCharSet | Set of ansi characters
TStringArray | Array of strings
Variables
Name | Description
ScreenPixelsPerInch | Default value for the screen pixel density (pixels per inch). Is needed for conversion of distances to pixels
UTF8FormatSettings | FPC format settings for which all strings have been converted to UTF8
License

See the file COPYING.modifiedLGPL.txt, included in the Lazarus distribution, for details about the license.


Contents

Contents
Symbol Reference
Classes
TsCellCombobox Class
TsCellCombobox Members
TsCellCombobox.Create Constructor
TsCellCombobox.Destroy Destructor
TsCellCombobox Methods
TsCellCombobox.ApplyFormatToCell Method
TsCellCombobox.Change Method
TsCellCombobox.DrawItem Method
TsCellCombobox.ExtractFromCell Method
TsCellCombobox.GetActiveCell Method
TsCellCombobox.ListenerNotification Method
TsCellCombobox.Loaded Method
TsCellCombobox.Notification Method
TsCellCombobox.Populate Method
TsCellCombobox.ProcessItem Method
TsCellCombobox.RemoveWorkbookSource Method
TsCellCombobox.Select Method
TsCellCombobox Properties
TsCellCombobox.Align Property
TsCellCombobox.Anchors Property
TsCellCombobox.ArrowKeysTraverseList Property
TsCellCombobox.AutoComplete Property
TsCellCombobox.AutoCompleteText Property
TsCellCombobox.AutoDropDown Property
TsCellCombobox.AutoSelect Property
TsCellCombobox.AutoSize Property
TsCellCombobox.BidiMode Property
TsCellCombobox.BorderSpacing Property
TsCellCombobox.BorderStyle Property
TsCellCombobox.CellFormatItem Property
TsCellCombobox.CharCase Property
TsCellCombobox.Color Property
TsCellCombobox.ColorRectOffset Property
TsCellCombobox.ColorRectWidth Property
TsCellCombobox.Constraints Property
TsCellCombobox.DragCursor Property
TsCellCombobox.DragKind Property
TsCellCombobox.DragMode Property
TsCellCombobox.DropDownCount Property
TsCellCombobox.Enabled Property
TsCellCombobox.Font Property
TsCellCombobox.ItemIndex Property
TsCellCombobox.Items Property
TsCellCombobox.ItemWidth Property
TsCellCombobox.MaxLength Property
TsCellCombobox.OnChange Property
TsCellCombobox.OnChangeBounds Property
TsCellCombobox.OnClick Property
TsCellCombobox.OnCloseUp Property
TsCellCombobox.OnContextPopup Property
TsCellCombobox.OnDblClick Property
TsCellCombobox.OnDragDrop Property
TsCellCombobox.OnDragOver Property
TsCellCombobox.OnDrawItem Property
TsCellCombobox.OnDropDown Property
TsCellCombobox.OnEditingDone Property
TsCellCombobox.OnEndDrag Property
TsCellCombobox.OnEnter Property
TsCellCombobox.OnExit Property
TsCellCombobox.OnGetItems Property
TsCellCombobox.OnKeyDown Property
TsCellCombobox.OnKeyPress Property
TsCellCombobox.OnKeyUp Property
TsCellCombobox.OnMeasureItem Property
TsCellCombobox.OnMouseDown Property
TsCellCombobox.OnMouseEnter Property
TsCellCombobox.OnMouseLeave Property
TsCellCombobox.OnMouseMove Property
TsCellCombobox.OnMouseUp Property
TsCellCombobox.OnMouseWheel Property
TsCellCombobox.OnMouseWheelDown Property
TsCellCombobox.OnMouseWheelUp Property
TsCellCombobox.OnSelect Property
TsCellCombobox.OnStartDrag Property
TsCellCombobox.OnUTF8KeyPress Property
TsCellCombobox.ParentBidiMode Property
TsCellCombobox.ParentColor Property
TsCellCombobox.ParentFont Property
TsCellCombobox.ParentShowHint Property
TsCellCombobox.PopupMenu Property
TsCellCombobox.ShowHint Property
TsCellCombobox.Sorted Property
TsCellCombobox.TabOrder Property
TsCellCombobox.TabStop Property
TsCellCombobox.Text Property
TsCellCombobox.Visible Property
TsCellCombobox.Workbook Property
TsCellCombobox.WorkbookSource Property
TsCellCombobox.Worksheet Property
TsCellEdit Class
TsCellEdit Members
TsCellEdit.Create Constructor
TsCellEdit.Destroy Destructor
TsCellEdit Methods
TsCellEdit.EditingDone Method
TsCellEdit.ListenerNotification Method
TsCellEdit.Notification Method
TsCellEdit.RemoveWorkbookSource Method
TsCellEdit.ShowCell Method
TsCellEdit Properties
TsCellEdit.SelectedCell Property
TsCellEdit.ShowHTMLText Property
TsCellEdit.Workbook Property
TsCellEdit.WorkbookSource Property
TsCellEdit.Worksheet Property
TsCellIndicator Class
TsCellIndicator Members
TsCellIndicator.Create Constructor
TsCellIndicator.Destroy Destructor
TsCellIndicator Methods
TsCellIndicator.EditingDone Method
TsCellIndicator.ListenerNotification Method
TsCellIndicator.Notification Method
TsCellIndicator.RemoveWorkbookSource Method
TsCellIndicator Properties
TsCellIndicator.Alignment Property
TsCellIndicator.Workbook Property
TsCellIndicator.WorkbookSource Property
TsCellIndicator.Worksheet Property
TsCellList Class
TsCellList Members
TsCellList.Destroy Destructor
TsCellList Methods
TsCellList.Add Method
TsCellList.AddCell Method
TsCellList.AddEmptyCell Method
TsCellList.Clear Method
TsCellList.Delete Method
TsCellList.IndexOf Method
TsCellList Properties
TsCellList.CellByIndex Property
TsCellList.MultipleRanges Property
TsCustomWorksheetGrid Class
TsCustomWorksheetGrid Members
TsCustomWorksheetGrid.Create Constructor
TsCustomWorksheetGrid.Destroy Destructor
TsCustomWorksheetGrid Methods
TsCustomWorksheetGrid.AutoAdjustColumn Method
TsCustomWorksheetGrid.AutoAdjustRow Method
TsCustomWorksheetGrid.AutoExpandToCol Method
TsCustomWorksheetGrid.AutoExpandToRow Method
TsCustomWorksheetGrid.BeginUpdate Method
TsCustomWorksheetGrid.CalcWorksheetColWidth Method
TsCustomWorksheetGrid.CalcWorksheetRowHeight Method
TsCustomWorksheetGrid.CellOverflow Method
TsCustomWorksheetGrid.CellRect Method
TsCustomWorksheetGrid.Convert_Font_to_sFont Method
TsCustomWorksheetGrid.Convert_sFont_to_Font Method
TsCustomWorksheetGrid.CreateNewWorkbook Method
TsCustomWorksheetGrid.DblClick Method
TsCustomWorksheetGrid.DefaultDrawCell Method
TsCustomWorksheetGrid.DefineProperties Method
TsCustomWorksheetGrid.DeleteCol Method
TsCustomWorksheetGrid.DeleteRow Method
TsCustomWorksheetGrid.DoCopyToClipboard Method
TsCustomWorksheetGrid.DoCutToClipboard Method
TsCustomWorksheetGrid.DoEditorShow Method
TsCustomWorksheetGrid.DoOnResize Method
TsCustomWorksheetGrid.DoPasteFromClipboard Method
TsCustomWorksheetGrid.DoPrepareCanvas Method
TsCustomWorksheetGrid.DrawAllRows Method
DrawCellBorders Method
TsCustomWorksheetGrid.DrawCellBorders Method ()
TsCustomWorksheetGrid.DrawCellBorders Method (Integer, Integer, TRect, PCell)
TsCustomWorksheetGrid.DrawCellGrid Method
TsCustomWorksheetGrid.DrawCommentMarker Method
TsCustomWorksheetGrid.DrawFocusRect Method
TsCustomWorksheetGrid.DrawFrozenPaneBorders Method
TsCustomWorksheetGrid.DrawRow Method
TsCustomWorksheetGrid.DrawSelection Method
TsCustomWorksheetGrid.DrawTextInCell Method
TsCustomWorksheetGrid.EditingDone Method
TsCustomWorksheetGrid.EndUpdate Method
TsCustomWorksheetGrid.ExecuteHyperlink Method
TsCustomWorksheetGrid.GetCellHeight Method
TsCustomWorksheetGrid.GetCellHintText Method
TsCustomWorksheetGrid.GetCellText Method
TsCustomWorksheetGrid.GetDefaultHeaderColWidth Method
TsCustomWorksheetGrid.GetEditText Method
TsCustomWorksheetGrid.GetGridCol Method
TsCustomWorksheetGrid.GetGridRow Method
TsCustomWorksheetGrid.GetSheets Method
TsCustomWorksheetGrid.GetWorksheetCol Method
TsCustomWorksheetGrid.GetWorksheetRow Method
TsCustomWorksheetGrid.HasBorder Method
TsCustomWorksheetGrid.HeaderSized Method
TsCustomWorksheetGrid.HeaderSizing Method
TsCustomWorksheetGrid.InsertCol Method
TsCustomWorksheetGrid.InsertRow Method
TsCustomWorksheetGrid.InternalDrawTextInCell Method
TsCustomWorksheetGrid.KeyDown Method
TsCustomWorksheetGrid.ListenerNotification Method
TsCustomWorksheetGrid.Loaded Method
LoadFromSpreadsheetFile Method
TsCustomWorksheetGrid.LoadFromSpreadsheetFile Method (string, Integer)
TsCustomWorksheetGrid.LoadFromSpreadsheetFile Method (string, TsSpreadFormatID, Integer)
TsCustomWorksheetGrid.LoadFromSpreadsheetFile Method (string, TsSpreadsheetFormat, Integer)
TsCustomWorksheetGrid.LoadFromWorkbook Method
MergeCells Method
TsCustomWorksheetGrid.MergeCells Method ()
TsCustomWorksheetGrid.MergeCells Method (Integer, Integer, Integer, Integer)
TsCustomWorksheetGrid.MergeCells Method (TGridRect)
TsCustomWorksheetGrid.MouseDown Method
TsCustomWorksheetGrid.MouseMove Method
TsCustomWorksheetGrid.MouseUp Method
TsCustomWorksheetGrid.MoveSelection Method
TsCustomWorksheetGrid.NewWorkbook Method
TsCustomWorksheetGrid.Notification Method
TsCustomWorksheetGrid.RemoveWorkbookSource Method
SaveToSpreadsheetFile Method
TsCustomWorksheetGrid.SaveToSpreadsheetFile Method (string, Boolean)
TsCustomWorksheetGrid.SaveToSpreadsheetFile Method (string, TsSpreadFormatID, Boolean)
TsCustomWorksheetGrid.SaveToSpreadsheetFile Method (string, TsSpreadsheetFormat, Boolean)
TsCustomWorksheetGrid.SelectEditor Method
TsCustomWorksheetGrid.SelectSheetByIndex Method
TsCustomWorksheetGrid.SelPenChangeHandler Method
TsCustomWorksheetGrid.SetEditText Method
TsCustomWorksheetGrid.Setup Method
TsCustomWorksheetGrid.ShowCellBorders Method
TsCustomWorksheetGrid.Sort Method
TsCustomWorksheetGrid.TopLeftChanged Method
TsCustomWorksheetGrid.TrimToCell Method
UnmergeCells Method
TsCustomWorksheetGrid.UnmergeCells Method ()
TsCustomWorksheetGrid.UnmergeCells Method (Integer, Integer)
TsCustomWorksheetGrid.UpdateColWidths Method
TsCustomWorksheetGrid.UpdateRowHeights Method
TsCustomWorksheetGrid Properties
TsCustomWorksheetGrid.AutoCalc Property
TsCustomWorksheetGrid.AutoExpand Property
TsCustomWorksheetGrid.BackgroundColor Property
TsCustomWorksheetGrid.BackgroundColors Property
TsCustomWorksheetGrid.CellBiDiMode Property
TsCustomWorksheetGrid.CellBorder Property
TsCustomWorksheetGrid.CellBorders Property
TsCustomWorksheetGrid.CellBorderStyle Property
TsCustomWorksheetGrid.CellBorderStyles Property
TsCustomWorksheetGrid.CellComment Property
TsCustomWorksheetGrid.CellFont Property
TsCustomWorksheetGrid.CellFontColor Property
TsCustomWorksheetGrid.CellFontColors Property
TsCustomWorksheetGrid.CellFontName Property
TsCustomWorksheetGrid.CellFontNames Property
TsCustomWorksheetGrid.CellFonts Property
TsCustomWorksheetGrid.CellFontSize Property
TsCustomWorksheetGrid.CellFontSizes Property
TsCustomWorksheetGrid.CellFontStyle Property
TsCustomWorksheetGrid.CellFontStyles Property
TsCustomWorksheetGrid.Cells Property
TsCustomWorksheetGrid.ColWidths Property
TsCustomWorksheetGrid.DefaultColWidth Property
TsCustomWorksheetGrid.DefaultRowHeight Property
TsCustomWorksheetGrid.DisplayFixedColRow Property
TsCustomWorksheetGrid.FrozenCols Property
TsCustomWorksheetGrid.FrozenRows Property
TsCustomWorksheetGrid.HeaderCount Property
TsCustomWorksheetGrid.HorAlignment Property
TsCustomWorksheetGrid.HorAlignments Property
TsCustomWorksheetGrid.Hyperlink Property
TsCustomWorksheetGrid.NumberFormat Property
TsCustomWorksheetGrid.NumberFormats Property
TsCustomWorksheetGrid.RangeSelectMode Property
TsCustomWorksheetGrid.ReadFormulas Property
TsCustomWorksheetGrid.RowHeights Property
TsCustomWorksheetGrid.SelectionPen Property
TsCustomWorksheetGrid.ShowGridLines Property
TsCustomWorksheetGrid.ShowHeaders Property
TsCustomWorksheetGrid.TextOverflow Property
TsCustomWorksheetGrid.TextRotation Property
TsCustomWorksheetGrid.TextRotations Property
TsCustomWorksheetGrid.VertAlignment Property
TsCustomWorksheetGrid.VertAlignments Property
TsCustomWorksheetGrid.Wordwrap Property
TsCustomWorksheetGrid.Wordwraps Property
TsCustomWorksheetGrid.Workbook Property
TsCustomWorksheetGrid.WorkbookSource Property
TsCustomWorksheetGrid.Worksheet Property
TsCustomWorksheetGrid Events
TsCustomWorksheetGrid.OnClickHyperlink Event
TsNumFormatList Class
TsNumFormatList Members
TsNumFormatList.Create Constructor
TsNumFormatList.Destroy Destructor
TsNumFormatList Fields
TsNumFormatList.FClass Field
TsNumFormatList.FFormatSettings Field
TsNumFormatList Methods
TsNumFormatList.AddBuiltinFormats Method
AddFormat Method
TsNumFormatList.AddFormat Method (String)
TsNumFormatList.AddFormat Method (TsNumFormatSections)
TsNumFormatList.Clear Method
TsNumFormatList.Delete Method
Find Method
TsNumFormatList.Find Method (String)
TsNumFormatList.Find Method (TsNumFormatSections)
TsNumFormatList Properties
TsNumFormatList.Items Property
TsNumFormatParams Class
TsNumFormatParams Members
TsNumFormatParams Fields
TsNumFormatParams.Sections Field
TsNumFormatParams Methods
TsNumFormatParams.DeleteElement Method
TsNumFormatParams.GetNumFormat Method
TsNumFormatParams.GetNumFormatStr Method
TsNumFormatParams.InsertElement Method
TsNumFormatParams.SectionsEqualTo Method
TsNumFormatParams.SetCurrSymbol Method
TsNumFormatParams.SetDecimals Method
TsNumFormatParams.SetNegativeRed Method
TsNumFormatParams.SetThousandSep Method
TsNumFormatParams Properties
TsNumFormatParams.NumFormat Property
TsNumFormatParams.NumFormatStr Property
TsSelPen Class
TsSelPen Members
TsSelPen.Create Constructor
TsSelPen Properties
TsSelPen.JoinStyle Property
TsSelPen.Width Property
TsSpreadsheetInspector Class
TsSpreadsheetInspector Members
TsSpreadsheetInspector.Create Constructor
TsSpreadsheetInspector.Destroy Destructor
TsSpreadsheetInspector Methods
TsSpreadsheetInspector.DblClick Method
TsSpreadsheetInspector.DoUpdate Method
TsSpreadsheetInspector.ListenerNotification Method
TsSpreadsheetInspector.Notification Method
TsSpreadsheetInspector.RemoveWorkbookSource Method
TsSpreadsheetInspector.UpdateCellProperties Method
TsSpreadsheetInspector.UpdateCellValue Method
TsSpreadsheetInspector.UpdateWorkbook Method
TsSpreadsheetInspector.UpdateWorksheet Method
TsSpreadsheetInspector Properties
TsSpreadsheetInspector.DisplayOptions Property
TsSpreadsheetInspector.ExpandedNodes Property
TsSpreadsheetInspector.ExtendedColSizing Property
TsSpreadsheetInspector.FixedCols Property
TsSpreadsheetInspector.Mode Property
TsSpreadsheetInspector.Workbook Property
TsSpreadsheetInspector.WorkbookSource Property
TsSpreadsheetInspector.Worksheet Property
TsWorkbook Class
TsWorkbook Members
TsWorkbook.Create Constructor
TsWorkbook.Destroy Destructor
TsWorkbook Fields
TsWorkbook.FCellFormatList Field
TsWorkbook.FEmbeddedStreamList Field
TsWorkbook.FFontList Field
TsWorkbook.FNumFormatList Field
TsWorkbook.FormatSettings Field
TsWorkbook Methods
TsWorkbook.AddCellFormat Method
TsWorkbook.AddEmbeddedStream Method
AddErrorMsg Method
TsWorkbook.AddErrorMsg Method (String)
TsWorkbook.AddErrorMsg Method (String, array of const)
AddFont Method
TsWorkbook.AddFont Method (String, Single, TsFontStyles, TsColor, TsFontPosition)
TsWorkbook.AddFont Method (TsFont)
TsWorkbook.AddNumberFormat Method
TsWorkbook.AddWorksheet Method
TsWorkbook.ClearErrorList Method
TsWorkbook.CopyToClipboardStream Method
TsWorkbook.CopyWorksheetFrom Method
TsWorkbook.DeleteFont Method
TsWorkbook.DisableNotifications Method
TsWorkbook.EnableNotifications Method
TsWorkbook.FindEmbeddedStream Method
TsWorkbook.FindFont Method
TsWorkbook.GetBuiltinFontCount Method
TsWorkbook.GetCellFormat Method
TsWorkbook.GetCellFormatAsString Method
TsWorkbook.GetDefaultFont Method
TsWorkbook.GetDefaultFontSize Method
TsWorkbook.GetEmbeddedStream Method
TsWorkbook.GetEmbeddedStreamCount Method
TsWorkbook.GetFirstWorksheet Method
TsWorkbook.GetFont Method
TsWorkbook.GetFontAsString Method
TsWorkbook.GetFontCount Method
GetFormatFromFileHeader Method
TsWorkbook.GetFormatFromFileHeader Method (TFileName, TsSpreadFormatID)
TsWorkbook.GetFormatFromFileHeader Method (TStream, TsSpreadFormatID)
TsWorkbook.GetHyperlinkFont Method
TsWorkbook.GetLastRowColIndex Method
TsWorkbook.GetNumberFormat Method
TsWorkbook.GetNumberFormatCount Method
TsWorkbook.GetNumCellFormats Method
TsWorkbook.GetPointerToCellFormat Method
TsWorkbook.GetWorksheetByIndex Method
TsWorkbook.GetWorksheetByName Method
TsWorkbook.GetWorksheetCount Method
TsWorkbook.GetWorksheetIndex Method
TsWorkbook.HasEmbeddedSheetImages Method
TsWorkbook.InitFonts Method
TsWorkbook.NotificationsEnabled Method
TsWorkbook.PasteFromClipboardStream Method
TsWorkbook.PrepareBeforeReading Method
TsWorkbook.PrepareBeforeSaving Method
ReadFromFile Method
TsWorkbook.ReadFromFile Method (string, TsSpreadFormatID, TsStreamParams)
TsWorkbook.ReadFromFile Method (string, TsSpreadsheetFormat, TsStreamParams)
TsWorkbook.ReadFromFile Method (string, TsStreamParams)
TsWorkbook.ReadFromFileIgnoringExtension Method
ReadFromStream Method
TsWorkbook.ReadFromStream Method (TStream, TsSpreadFormatID, TsStreamParams)
TsWorkbook.ReadFromStream Method (TStream, TsSpreadsheetFormat, TsStreamParams)
TsWorkbook.ReCalc Method
TsWorkbook.RemoveAllEmbeddedStreams Method
TsWorkbook.RemoveAllFonts Method
TsWorkbook.RemoveAllWorksheets Method
TsWorkbook.RemoveWorksheet Method
TsWorkbook.ReplaceFont Method
TsWorkbook.SelectWorksheet Method
TsWorkbook.SetDefaultFont Method
TsWorkbook.TryStrToCell Method
TsWorkbook.TryStrToCellRange Method
TsWorkbook.TryStrToCellRanges Method
TsWorkbook.UpdateCaches Method
TsWorkbook.ValidWorksheetName Method
WriteToFile Method
TsWorkbook.WriteToFile Method (String, Boolean, TsStreamParams)
TsWorkbook.WriteToFile Method (string, TsSpreadFormatID, Boolean, TsStreamParams)
TsWorkbook.WriteToFile Method (string, TsSpreadsheetFormat, Boolean, TsStreamParams)
WriteToStream Method
TsWorkbook.WriteToStream Method (TStream, TsSpreadFormatID, TsStreamParams)
TsWorkbook.WriteToStream Method (TStream, TsSpreadsheetFormat, TsStreamParams)
TsWorkbook Properties
TsWorkbook.ActiveWorksheet Property
TsWorkbook.ErrorMsg Property
TsWorkbook.FileFormatID Property
TsWorkbook.FileName Property
TsWorkbook.OnOpenWorkbook Property
TsWorkbook.Options Property
TsWorkbook.VirtualColCount Property
TsWorkbook.VirtualRowCount Property
TsWorkbook Events
TsWorkbook.OnAddWorksheet Event
TsWorkbook.OnChangeWorksheet Event
TsWorkbook.OnReadCellData Event
TsWorkbook.OnRemoveWorksheet Event
TsWorkbook.OnRemovingWorksheet Event
TsWorkbook.OnRenameWorksheet Event
TsWorkbook.OnSelectWorksheet Event
TsWorkbook.OnWriteCellData Event
TsWorkbookSource Class
TsWorkbookSource Members
TsWorkbookSource.Create Constructor
TsWorkbookSource.Destroy Destructor
TsWorkbookSource Methods
TsWorkbookSource.AbortSelection Method
TsWorkbookSource.AddListener Method
TsWorkbookSource.CopyCellsToClipboard Method
TsWorkbookSource.CreateNewWorkbook Method
TsWorkbookSource.CutCellsToClipboard Method
TsWorkbookSource.DisableControls Method
TsWorkbookSource.DoShowError Method
TsWorkbookSource.EnableControls Method
TsWorkbookSource.ExecutePendingOperation Method
TsWorkbookSource.InternalCreateNewWorkbook Method
TsWorkbookSource.InternalLoadFromFile Method
TsWorkbookSource.InternalLoadFromWorkbook Method
TsWorkbookSource.Loaded Method
LoadFromSpreadsheetFile Method
TsWorkbookSource.LoadFromSpreadsheetFile Method (string, TsSpreadFormatID, Integer)
TsWorkbookSource.LoadFromSpreadsheetFile Method (string, TsSpreadsheetFormat, Integer)
TsWorkbookSource.LoadFromWorkbook Method
TsWorkbookSource.NotifyListeners Method
TsWorkbookSource.PasteCellsFromClipboard Method
TsWorkbookSource.RemoveListener Method
SaveToSpreadsheetFile Method
TsWorkbookSource.SaveToSpreadsheetFile Method (string, Boolean)
TsWorkbookSource.SaveToSpreadsheetFile Method (string, TsSpreadFormatID, Boolean)
TsWorkbookSource.SaveToSpreadsheetFile Method (string, TsSpreadsheetFormat, Boolean)
TsWorkbookSource.SelectCell Method
TsWorkbookSource.SelectWorksheet Method
TsWorkbookSource.SetPendingOperation Method
TsWorkbookSource Properties
TsWorkbookSource.AutoDetectFormat Property
TsWorkbookSource.FileFormat Property
TsWorkbookSource.FileFormatID Property
TsWorkbookSource.FileName Property
TsWorkbookSource.Options Property
TsWorkbookSource.PendingOperation Property
TsWorkbookSource.Workbook Property
TsWorkbookSource.Worksheet Property
TsWorkbookSource Events
TsWorkbookSource.OnError Event
TsWorkbookTabControl Class
TsWorkbookTabControl Members
TsWorkbookTabControl.Destroy Destructor
TsWorkbookTabControl Methods
TsWorkbookTabControl.Change Method
TsWorkbookTabControl.GetSheetList Method
TsWorkbookTabControl.GetWorkbook Method
TsWorkbookTabControl.GetWorksheet Method
TsWorkbookTabControl.ListenerNotification Method
TsWorkbookTabControl.Notification Method
TsWorkbookTabControl.RemoveWorkbookSource Method
TsWorkbookTabControl Properties
TsWorkbookTabControl.Workbook Property
TsWorkbookTabControl.WorkbookSource Property
TsWorkbookTabControl.Worksheet Property
TsWorksheet Class
TsWorksheet Members
TsWorksheet.Create Constructor
TsWorksheet.Destroy Destructor
TsWorksheet Methods
TsWorksheet.AddCell Method
TsWorksheet.BuildRPNFormula Method
TsWorksheet.CalcAutoRowHeight Method
TsWorksheet.CalcFormula Method
TsWorksheet.CalcFormulas Method
TsWorksheet.CalcImageExtent Method
TsWorksheet.CellInRange Method
TsWorksheet.CellPosToText Method
TsWorksheet.CellUsedInFormula Method
TsWorksheet.ChangedCell Method
TsWorksheet.ChangedFont Method
TsWorksheet.ClearSelection Method
TsWorksheet.ConvertFormulaDialect Method
TsWorksheet.ConvertRPNFormulaToStringFormula Method
CopyCell Method
TsWorksheet.CopyCell Method (Cardinal, Cardinal, Cardinal, Cardinal, TsWorksheet)
TsWorksheet.CopyCell Method (PCell, PCell)
CopyFormat Method
TsWorksheet.CopyFormat Method (PCell, Cardinal, Cardinal)
TsWorksheet.CopyFormat Method (PCell, PCell)
CopyFormula Method
TsWorksheet.CopyFormula Method (PCell, Cardinal, Cardinal)
TsWorksheet.CopyFormula Method (PCell, PCell)
CopyValue Method
TsWorksheet.CopyValue Method (PCell, Cardinal, Cardinal)
TsWorksheet.CopyValue Method (PCell, PCell)
TsWorksheet.DeleteCell Method
TsWorksheet.DeleteCol Method
TsWorksheet.DeleteRichTextParams Method
TsWorksheet.DeleteRow Method
TsWorksheet.DeleteSelection Method
TsWorksheet.DoCompareCells Method
TsWorksheet.DoExchangeColRow Method
TsWorksheet.DoInternalCompareCells Method
TsWorksheet.EraseCell Method
TsWorksheet.ExchangeCells Method
FindCell Method
TsWorksheet.FindCell Method (Cardinal, Cardinal)
TsWorksheet.FindCell Method (String)
TsWorksheet.FindCol Method
TsWorksheet.FindComment Method
TsWorksheet.FindHyperlink Method
TsWorksheet.FindMergeBase Method
TsWorksheet.FindMergedRange Method
TsWorksheet.FindNextCellInCol Method
TsWorksheet.FindNextCellInRow Method
TsWorksheet.FindPrevCellInCol Method
TsWorksheet.FindPrevCellInRow Method
TsWorksheet.FindRow Method
TsWorksheet.GetCalcState Method
GetCell Method
TsWorksheet.GetCell Method (Cardinal, Cardinal)
TsWorksheet.GetCell Method (String)
TsWorksheet.GetCellCount Method
TsWorksheet.GetCellCountInCol Method
TsWorksheet.GetCellCountInRow Method
TsWorksheet.GetCol Method
TsWorksheet.GetColWidth Method
TsWorksheet.GetDisplayedDecimals Method
TsWorksheet.GetFirstColIndex Method
TsWorksheet.GetFirstRowIndex Method
TsWorksheet.GetImage Method
TsWorksheet.GetImageCount Method
TsWorksheet.GetLastColIndex Method
TsWorksheet.GetLastColNumber Method
TsWorksheet.GetLastOccupiedColIndex Method
TsWorksheet.GetLastOccupiedRowIndex Method
TsWorksheet.GetLastRowIndex Method
TsWorksheet.GetLastRowNumber Method
TsWorksheet.GetNumberFormatAttributes Method
TsWorksheet.GetRow Method
TsWorksheet.GetRowHeight Method
TsWorksheet.GetSelection Method
TsWorksheet.GetSelectionAsString Method
TsWorksheet.GetSelectionCount Method
TsWorksheet.GetSelectionRangeIndexOfActiveCell Method
TsWorksheet.HasComment Method
TsWorksheet.HasHyperlink Method
TsWorksheet.InSameMergedRange Method
TsWorksheet.InsertCol Method
TsWorksheet.InsertRow Method
TsWorksheet.IsMergeBase Method
TsWorksheet.IsMerged Method
MergeCells Method
TsWorksheet.MergeCells Method (Cardinal, Cardinal, Cardinal, Cardinal)
TsWorksheet.MergeCells Method (String)
ReadAsDateTime Method
TsWorksheet.ReadAsDateTime Method (Cardinal, Cardinal, TDateTime)
TsWorksheet.ReadAsDateTime Method (PCell, TDateTime)
ReadAsNumber Method
TsWorksheet.ReadAsNumber Method (Cardinal, Cardinal)
TsWorksheet.ReadAsNumber Method (PCell)
ReadAsText Method
TsWorksheet.ReadAsText Method (Cardinal, Cardinal)
TsWorksheet.ReadAsText Method (PCell)
TsWorksheet.ReadAsText Method (PCell, TFormatSettings)
ReadAsUTF8Text Method
TsWorksheet.ReadAsUTF8Text Method (Cardinal, Cardinal)
TsWorksheet.ReadAsUTF8Text Method (PCell)
TsWorksheet.ReadAsUTF8Text Method (PCell, TFormatSettings)
TsWorksheet.ReadBackground Method
TsWorksheet.ReadBackgroundColor Method
TsWorksheet.ReadBiDiMode Method
TsWorksheet.ReadCellBorders Method
TsWorksheet.ReadCellBorderStyle Method
TsWorksheet.ReadCellBorderStyles Method
TsWorksheet.ReadCellFont Method
TsWorksheet.ReadCellFontIndex Method
TsWorksheet.ReadCellFormat Method
ReadComment Method
TsWorksheet.ReadComment Method (Cardinal, Cardinal)
TsWorksheet.ReadComment Method (PCell)
TsWorksheet.ReadFormulaAsString Method
TsWorksheet.ReadHorAlignment Method
TsWorksheet.ReadHyperlink Method
TsWorksheet.ReadNumericValue Method
TsWorksheet.ReadNumFormat Method
TsWorksheet.ReadTextRotation Method
TsWorksheet.ReadUsedFormatting Method
TsWorksheet.ReadVertAlignment Method
TsWorksheet.ReadWordwrap Method
TsWorksheet.RemoveAllCols Method
TsWorksheet.RemoveAllImages Method
TsWorksheet.RemoveAllRows Method
TsWorksheet.RemoveAndFreeCell Method
TsWorksheet.RemoveCell Method
TsWorksheet.RemoveCol Method
TsWorksheet.RemoveComment Method
TsWorksheet.RemoveHyperlink Method
TsWorksheet.RemoveImage Method
TsWorksheet.RemoveRow Method
TsWorksheet.SelectCell Method
TsWorksheet.SetCalcState Method
TsWorksheet.SetSelection Method
Sort Method
TsWorksheet.Sort Method (TsSortParams, Cardinal, Cardinal, Cardinal, Cardinal)
TsWorksheet.Sort Method (TsSortParams, String)
UnmergeCells Method
TsWorksheet.UnmergeCells Method (Cardinal, Cardinal)
TsWorksheet.UnmergeCells Method (String)
TsWorksheet.UpdateCaches Method
TsWorksheet.ValidHyperlink Method
WriteBackground Method
TsWorksheet.WriteBackground Method (Cardinal, Cardinal, TsFillStyle, TsColor, TsColor)
TsWorksheet.WriteBackground Method (PCell, TsFillStyle, TsColor, TsColor)
WriteBackgroundColor Method
TsWorksheet.WriteBackgroundColor Method (Cardinal, Cardinal, TsColor)
TsWorksheet.WriteBackgroundColor Method (PCell, TsColor)
WriteBiDiMode Method
TsWorksheet.WriteBiDiMode Method (Cardinal, Cardinal, TsBiDiMode)
TsWorksheet.WriteBiDiMode Method (PCell, TsBiDiMode)
WriteBlank Method
TsWorksheet.WriteBlank Method (Cardinal, Cardinal)
TsWorksheet.WriteBlank Method (PCell)
WriteBoolValue Method
TsWorksheet.WriteBoolValue Method (Cardinal, Cardinal, Boolean)
TsWorksheet.WriteBoolValue Method (PCell, Boolean)
WriteBorderColor Method
TsWorksheet.WriteBorderColor Method (Cardinal, Cardinal, TsCellBorder, TsColor)
TsWorksheet.WriteBorderColor Method (PCell, TsCellBorder, TsColor)
WriteBorderLineStyle Method
TsWorksheet.WriteBorderLineStyle Method (Cardinal, Cardinal, TsCellBorder, TsLineStyle)
TsWorksheet.WriteBorderLineStyle Method (PCell, TsCellBorder, TsLineStyle)
WriteBorders Method
TsWorksheet.WriteBorders Method (Cardinal, Cardinal, TsCellBorders)
TsWorksheet.WriteBorders Method (PCell, TsCellBorders)
WriteBorderStyle Method
TsWorksheet.WriteBorderStyle Method (Cardinal, Cardinal, TsCellBorder, TsCellBorderStyle)
TsWorksheet.WriteBorderStyle Method (Cardinal, Cardinal, TsCellBorder, TsLineStyle, TsColor)
TsWorksheet.WriteBorderStyle Method (PCell, TsCellBorder, TsCellBorderStyle)
TsWorksheet.WriteBorderStyle Method (PCell, TsCellBorder, TsLineStyle, TsColor)
WriteBorderStyles Method
TsWorksheet.WriteBorderStyles Method (Cardinal, Cardinal, TsCellBorderStyles)
TsWorksheet.WriteBorderStyles Method (PCell, TsCellBorderStyles)
TsWorksheet.WriteCellFormat Method
WriteCellValueAsString Method
TsWorksheet.WriteCellValueAsString Method (Cardinal, Cardinal, String)
TsWorksheet.WriteCellValueAsString Method (PCell, String)
TsWorksheet.WriteColInfo Method
TsWorksheet.WriteColWidth Method
WriteComment Method
TsWorksheet.WriteComment Method (Cardinal, Cardinal, String)
TsWorksheet.WriteComment Method (PCell, String)
WriteCurrency Method
TsWorksheet.WriteCurrency Method (Cardinal, Cardinal, Double, TsNumberFormat, Integer, String, Integer, Integer)
TsWorksheet.WriteCurrency Method (Cardinal, Cardinal, Double, TsNumberFormat, String)
TsWorksheet.WriteCurrency Method (PCell, Double, TsNumberFormat, Integer, String, Integer, Integer)
TsWorksheet.WriteCurrency Method (PCell, Double, TsNumberFormat, String)
WriteDateTime Method
TsWorksheet.WriteDateTime Method (Cardinal, Cardinal, TDateTime)
TsWorksheet.WriteDateTime Method (Cardinal, Cardinal, TDateTime, String)
TsWorksheet.WriteDateTime Method (Cardinal, Cardinal, TDateTime, TsNumberFormat, String)
TsWorksheet.WriteDateTime Method (PCell, TDateTime)
TsWorksheet.WriteDateTime Method (PCell, TDateTime, String)
TsWorksheet.WriteDateTime Method (PCell, TDateTime, TsNumberFormat, String)
WriteDateTimeFormat Method
TsWorksheet.WriteDateTimeFormat Method (Cardinal, Cardinal, TsNumberFormat, String)
TsWorksheet.WriteDateTimeFormat Method (PCell, TsNumberFormat, String)
WriteDecimals Method
TsWorksheet.WriteDecimals Method (Cardinal, Cardinal, byte)
TsWorksheet.WriteDecimals Method (PCell, Byte)
WriteErrorValue Method
TsWorksheet.WriteErrorValue Method (Cardinal, Cardinal, TsErrorValue)
TsWorksheet.WriteErrorValue Method (PCell, TsErrorValue)
WriteFont Method
TsWorksheet.WriteFont Method (Cardinal, Cardinal, Integer)
TsWorksheet.WriteFont Method (Cardinal, Cardinal, String, Single, TsFontStyles, TsColor, TsFontPosition)
TsWorksheet.WriteFont Method (PCell, Integer)
TsWorksheet.WriteFont Method (PCell, String, Single, TsFontStyles, TsColor, TsFontPosition)
WriteFontColor Method
TsWorksheet.WriteFontColor Method (Cardinal, Cardinal, TsColor)
TsWorksheet.WriteFontColor Method (PCell, TsColor)
WriteFontName Method
TsWorksheet.WriteFontName Method (Cardinal, Cardinal, String)
TsWorksheet.WriteFontName Method (PCell, String)
WriteFontSize Method
TsWorksheet.WriteFontSize Method (Cardinal, Cardinal, Single)
TsWorksheet.WriteFontSize Method (PCell, Single)
WriteFontStyle Method
TsWorksheet.WriteFontStyle Method (Cardinal, Cardinal, TsFontStyles)
TsWorksheet.WriteFontStyle Method (PCell, TsFontStyles)
WriteFormula Method
TsWorksheet.WriteFormula Method (Cardinal, Cardinal, String, Boolean)
TsWorksheet.WriteFormula Method (PCell, String, Boolean)
WriteFractionFormat Method
TsWorksheet.WriteFractionFormat Method (Cardinal, Cardinal, Boolean, Integer, Integer)
TsWorksheet.WriteFractionFormat Method (PCell, Boolean, Integer, Integer)
WriteHorAlignment Method
TsWorksheet.WriteHorAlignment Method (Cardinal, Cardinal, TsHorAlignment)
TsWorksheet.WriteHorAlignment Method (PCell, TsHorAlignment)
WriteHyperlink Method
TsWorksheet.WriteHyperlink Method (Cardinal, Cardinal, String, String)
TsWorksheet.WriteHyperlink Method (PCell, String, String)
TsWorksheet.WriteImage Method
WriteNumber Method
TsWorksheet.WriteNumber Method (Cardinal, Cardinal, double)
TsWorksheet.WriteNumber Method (Cardinal, Cardinal, double, TsNumberFormat, Byte)
TsWorksheet.WriteNumber Method (Cardinal, Cardinal, double, TsNumberFormat, String)
TsWorksheet.WriteNumber Method (PCell, Double)
TsWorksheet.WriteNumber Method (PCell, Double, TsNumberFormat, Byte)
TsWorksheet.WriteNumber Method (PCell, Double, TsNumberFormat, String)
WriteNumberFormat Method
TsWorksheet.WriteNumberFormat Method (Cardinal, Cardinal, TsNumberFormat, Integer, String, Integer, Integer)
TsWorksheet.WriteNumberFormat Method (Cardinal, Cardinal, TsNumberFormat, String)
TsWorksheet.WriteNumberFormat Method (PCell, TsNumberFormat, Integer, String, Integer, Integer)
TsWorksheet.WriteNumberFormat Method (PCell, TsNumberFormat, String)
TsWorksheet.WriteRowHeight Method
TsWorksheet.WriteRowInfo Method
WriteRPNFormula Method
TsWorksheet.WriteRPNFormula Method (Cardinal, Cardinal, TsRPNFormula)
TsWorksheet.WriteRPNFormula Method (PCell, TsRPNFormula)
WriteText Method
TsWorksheet.WriteText Method (Cardinal, Cardinal, String, TsRichTextParams)
TsWorksheet.WriteText Method (PCell, String, TsRichTextParams)
WriteTextAsHTML Method
TsWorksheet.WriteTextAsHTML Method (Cardinal, Cardinal, String)
TsWorksheet.WriteTextAsHTML Method (PCell, String)
WriteTextRotation Method
TsWorksheet.WriteTextRotation Method (Cardinal, Cardinal, TsTextRotation)
TsWorksheet.WriteTextRotation Method (PCell, TsTextRotation)
WriteUsedFormatting Method
TsWorksheet.WriteUsedFormatting Method (Cardinal, Cardinal, TsUsedFormattingFields)
TsWorksheet.WriteUsedFormatting Method (PCell, TsUsedFormattingFields)
WriteUTF8Text Method
TsWorksheet.WriteUTF8Text Method (Cardinal, Cardinal, String, TsRichTextParams)
TsWorksheet.WriteUTF8Text Method (PCell, String, TsRichTextParams)
WriteVertAlignment Method
TsWorksheet.WriteVertAlignment Method (Cardinal, Cardinal, TsVertAlignment)
TsWorksheet.WriteVertAlignment Method (PCell, TsVertAlignment)
WriteWordwrap Method
TsWorksheet.WriteWordwrap Method (Cardinal, Cardinal, boolean)
TsWorksheet.WriteWordwrap Method (PCell, boolean)
TsWorksheet Properties
TsWorksheet.ActiveCellCol Property
TsWorksheet.ActiveCellRow Property
TsWorksheet.BiDiMode Property
TsWorksheet.Cells Property
TsWorksheet.Cols Property
TsWorksheet.Comments Property
TsWorksheet.DefaultColWidth Property
TsWorksheet.DefaultRowHeight Property
TsWorksheet.FormatSettings Property
TsWorksheet.Hyperlinks Property
TsWorksheet.LeftPaneWidth Property
TsWorksheet.MergedCells Property
TsWorksheet.Name Property
TsWorksheet.Options Property
TsWorksheet.PageLayout Property
TsWorksheet.Rows Property
TsWorksheet.TopPaneHeight Property
TsWorksheet.Workbook Property
TsWorksheet Events
TsWorksheet.OnChangeCell Event
TsWorksheet.OnChangeFont Event
TsWorksheet.OnCompareCells Event
TsWorksheet.OnSelectCell Event
TsWorksheetGrid Class
TsWorksheetGrid Members
TsWorksheetGrid Properties
TsWorksheetGrid.Align Property
TsWorksheetGrid.AlternateColor Property
TsWorksheetGrid.Anchors Property
TsWorksheetGrid.AutoAdvance Property
TsWorksheetGrid.AutoCalc Property
TsWorksheetGrid.AutoEdit Property
TsWorksheetGrid.AutoExpand Property
TsWorksheetGrid.AutoFillColumns Property
TsWorksheetGrid.BorderSpacing Property
TsWorksheetGrid.BorderStyle Property
TsWorksheetGrid.CellHintPriority Property
TsWorksheetGrid.ColCount Property
TsWorksheetGrid.Color Property
TsWorksheetGrid.Constraints Property
TsWorksheetGrid.DefaultColWidth Property
TsWorksheetGrid.DefaultDrawing Property
TsWorksheetGrid.DefaultRowHeight Property
TsWorksheetGrid.DisplayFixedColRow Property
TsWorksheetGrid.DragCursor Property
TsWorksheetGrid.DragKind Property
TsWorksheetGrid.DragMode Property
TsWorksheetGrid.Enabled Property
TsWorksheetGrid.ExtendedSelect Property
TsWorksheetGrid.FixedColor Property
TsWorksheetGrid.Flat Property
TsWorksheetGrid.Font Property
TsWorksheetGrid.FrozenCols Property
TsWorksheetGrid.FrozenRows Property
TsWorksheetGrid.GridLineWidth Property
TsWorksheetGrid.HeaderHotZones Property
TsWorksheetGrid.HeaderPushZones Property
TsWorksheetGrid.MouseWheelOption Property
TsWorksheetGrid.OnBeforeSelection Property
TsWorksheetGrid.OnChangeBounds Property
TsWorksheetGrid.OnClick Property
TsWorksheetGrid.OnColRowDeleted Property
TsWorksheetGrid.OnColRowExchanged Property
TsWorksheetGrid.OnColRowInserted Property
TsWorksheetGrid.OnColRowMoved Property
TsWorksheetGrid.OnContextPopup Property
TsWorksheetGrid.OnDblClick Property
TsWorksheetGrid.OnDragDrop Property
TsWorksheetGrid.OnDragOver Property
TsWorksheetGrid.OnDrawCell Property
TsWorksheetGrid.OnEditButtonClick Property
TsWorksheetGrid.OnEditingDone Property
TsWorksheetGrid.OnEndDock Property
TsWorksheetGrid.OnEndDrag Property
TsWorksheetGrid.OnEnter Property
TsWorksheetGrid.OnExit Property
TsWorksheetGrid.OnGetEditMask Property
TsWorksheetGrid.OnGetEditText Property
TsWorksheetGrid.OnHeaderClick Property
TsWorksheetGrid.OnHeaderSized Property
TsWorksheetGrid.OnHeaderSizing Property
TsWorksheetGrid.OnKeyDown Property
TsWorksheetGrid.OnKeyPress Property
TsWorksheetGrid.OnKeyUp Property
TsWorksheetGrid.OnMouseDown Property
TsWorksheetGrid.OnMouseMove Property
TsWorksheetGrid.OnMouseUp Property
TsWorksheetGrid.OnMouseWheel Property
TsWorksheetGrid.OnMouseWheelDown Property
TsWorksheetGrid.OnMouseWheelUp Property
TsWorksheetGrid.OnPickListSelect Property
TsWorksheetGrid.OnPrepareCanvas Property
TsWorksheetGrid.OnResize Property
TsWorksheetGrid.OnSelectCell Property
TsWorksheetGrid.OnSelectEditor Property
TsWorksheetGrid.OnSelection Property
TsWorksheetGrid.OnSetEditText Property
TsWorksheetGrid.OnShowHint Property
TsWorksheetGrid.OnStartDock Property
TsWorksheetGrid.OnStartDrag Property
TsWorksheetGrid.OnTopLeftChanged Property
TsWorksheetGrid.OnUTF8KeyPress Property
TsWorksheetGrid.OnValidateEntry Property
TsWorksheetGrid.Options Property
TsWorksheetGrid.ParentBiDiMode Property
TsWorksheetGrid.ParentColor Property
TsWorksheetGrid.ParentFont Property
TsWorksheetGrid.ParentShowHint Property
TsWorksheetGrid.PopupMenu Property
TsWorksheetGrid.ReadFormulas Property
TsWorksheetGrid.RowCount Property
TsWorksheetGrid.ScrollBars Property
TsWorksheetGrid.SelectionPen Property
TsWorksheetGrid.ShowGridLines Property
TsWorksheetGrid.ShowHeaders Property
TsWorksheetGrid.ShowHint Property
TsWorksheetGrid.TabOrder Property
TsWorksheetGrid.TabStop Property
TsWorksheetGrid.TextOverflow Property
TsWorksheetGrid.TitleFont Property
TsWorksheetGrid.TitleImageList Property
TsWorksheetGrid.TitleStyle Property
TsWorksheetGrid.UseXORFeatures Property
TsWorksheetGrid.Visible Property
TsWorksheetGrid.VisibleColCount Property
TsWorksheetGrid.VisibleRowCount Property
TsWorksheetGrid.WorkbookSource Property
TsWorksheetGrid Events
TsWorksheetGrid.OnClickHyperlink Event
Interfaces
IsSpreadsheetControl Interface
IsSpreadsheetControl Members
IsSpreadsheetControl Methods
IsSpreadsheetControl.ListenerNotification Method
IsSpreadsheetControl.RemoveWorkbookSource Method
Functions
AddAMPM Function
AddIntervalBrackets Function
AnalyzeCompareStr Function
AppendToStream Function
AppendToStream Function
AppendToStream Function
ApplyTextFormat Function
BuildCurrencyFormatList Function
BuildCurrencyFormatString Function
BuildDateTimeFormatString Function
BuildFormatStringFromSection Function
BuildFractionFormatString Function
BuildNumberFormatString Function
cmToPts Function
ColorToHTMLColorStr Function
ConvertFloatToStr Function
CopyCellFormat Function
CopyCellValue Function
CountDecs Function
DWordLEtoN Function
DWordToLE Function
EMUToIn Function
EMUToMM Function
EnsureOrder Function
EnsureOrder Function
FixHyperlinkPathDelims Function
FixLineEndings Function
FloatToFraction Function
GetCellRangeString Function
GetCellRangeString Function
GetCellString Function
GetCellString_R1C1 Function
GetColorName Function
GetColString Function
GetErrorValueStr Function
GetFileFormatName Function
GetFormatFromFileName Function
GetFormatFromFileName Function
GetImageInfo Function
GetImageInfo Function
GetImageMimeType Function
GetImageTypeFromFileName Function
GetTIFSize Function
HasFormula Function
HighContrastColor Function
HTMLColorStrToColor Function
HTMLLengthStrToPts Function
IfThen Function
IfThen Function
InitCell Function
InitCell Function
InitFormatRecord Function
InitFormatSettings Function
InitHeaderFooterImageRecord Function
InitImageRecord Function
InitSortParams Function
IntegerToLE Function
InToEMU Function
InToMM Function
InToPts Function
IsBoolValue Function
IsCurrencyFormat Function
IsCurrencyFormat Function
IsDateFormat Function
IsDateTimeFormat Function
IsDateTimeFormat Function
IsDateTimeFormat Function
IsDateTimeValue Function
IsLongTimeFormat Function
IsNumberValue Function
IsPaletteIndex Function
IsTextFormat Function
IsTimeFormat Function
IsTimeFormat Function
IsTimeFormat Function
IsTimeIntervalFormat Function
LongRGBToExcelPhysical Function
MakeLongDateFormat Function
MakeShortDateFormat Function
MakeTimeIntervalMask Function
mmToEMU Function
mmToIn Function
mmToPts Function
ParseCellColString Function
ParseCellRangeString Function
ParseCellRangeString Function
ParseCellRangeString Function
ParseCellRangeString Function
ParseCellRangeString_R1C1 Function
ParseCellRowString Function
ParseCellString Function
ParseCellString Function
ParseCellString_R1C1 Function
ParseCellString_R1C1 Function
ParseIntervalString Function
ParseSheetCellString Function
PtsToCm Function
PtsToIn Function
PtsToMM Function
PtsToPx Function
PtsToTwips Function
pxToPts Function
Range Function
Register Function
RegisterImageType Function
ReplaceFormatSettings Function
SameCellBorders Function
SameFont Function
SameFont Function
SetAsPaletteIndex Function
SplitHyperlink Function
SplitStr Function
SpreadsheetFormatInClipboard Function
StripAMPM Function
TintedColor Function
TryFractionStrToFloat Function
TryStrToErrorValue Function
TryStrToFloatAuto Function
TwipsToPts Function
UnquoteStr Function
Unused Function
Unused Function
Unused Function
WideStringLEToN Function
WideStringToLE Function
WordLEtoN Function
WordToLE Function
Structs, Records, Enums
TByteOrder Enumeration
TCol Record
TImageTypeRecord Record
TRGBA Record
TRow Record
TsAutoExpandMode Enumeration
TsCellFormatItem Enumeration
TsInspectorExpandedNode Enumeration
TsInspectorMode Enumeration
TsNotificationItem Enumeration
TsNumFormatElement Record
TsNumFormatKind Enumeration
TsNumFormatSection Record
TsNumFormatToken Enumeration
TsSelectionDirection Enumeration
TsSheetOption Enumeration
TsWorkbookOption Enumeration
Types
PCol Type
PRow Type
PsNumFormatSection Type
TAnsiCharSet Type
TGetImageSizeFunc Type
TsAutoExpandModes Type
TsCellCompareEvent Type
TsCellEvent Type
TsDecsChars Type
TsHyperlinkClickEvent Type
TsImageType Type
TsInspectorExpandedNodes Type
TsNotificationItems Type
TsNumFormatElements Type
TsNumFormatKinds Type
TsNumFormatParamsClass Type
TsNumFormatSections Type
TsNumFormatTokenSet Type
TsRemoveWorksheetEvent Type
TsSheetOptions Type
TStringArray Type
TsWorkbookOptions Type
TsWorkbookReadCellDataEvent Type
TsWorkbookSourceErrorEvent Type
TsWorkbookWriteCellDataEvent Type
TsWorksheetEvent Type
Variables
cfBiff5Format Variable
cfBiff8Format Variable
cfCSVFormat Variable
cfHTMLFormat Variable
cfTextHTMLFormat Variable
ComboColors Variable
FillPatternBgColor Variable
FillPatternBitmap Variable
FillPatternFgColor Variable
FillPatternStyle Variable
ImageTypeRegistry Variable
itBMP Variable
itEMF Variable
itGIF Variable
itJPEG Variable
itPCX Variable
itPNG Variable
itSVG Variable
itTIFF Variable
itWMF Variable
ScreenPixelsPerInch Variable
UTF8FormatSettings Variable
Constants
DECS_TOKENS Constant
DEFAULT_COL_COUNT Constant
DEFAULT_ROW_COUNT Constant
EXP_TOKENS Constant
FRACDENOM_TOKENS Constant
FRACNUM_TOKENS Constant
GUID_SpreadsheetControl Constant
HUE_000 Constant
HUE_060 Constant
HUE_120 Constant
HUE_180 Constant
HUE_240 Constant
HYPERLINK_TIMER_INTERVAL Constant
INT_NUM_LETTERS Constant
INT_TOKENS Constant
ISO8601Format Constant
ISO8601FormatDateOnly Constant
ISO8601FormatExtended Constant
ISO8601FormatHoursOverflow Constant
ISO8601FormatTimeOnly Constant
itUnknown Constant
NEG_CURR_FMT Constant
NO_CELL_BORDER Constant
POS_CURR_FMT Constant
RELCHAR Constant
TERMINATING_TOKENS Constant
Files
fpsimages.pas
fpsnumformat.pas
fpspreadsheet.pas
fpspreadsheetctrls.pas
fpspreadsheetgrid.pas
fpsutils.pas


Index

Index
A | B | C | D | E | F | G | H | I | L | M | N | P | R | S | T | U | V | W
A
AddAMPM
AddAMPM function
AddIntervalBrackets
AddIntervalBrackets function
aeData enumeration member
aeNavigation enumeration member
AnalyzeCompareStr
AnalyzeCompareStr function
AppendToStream
AppendToStream function
ApplyTextFormat
ApplyTextFormat function
B
boAutoCalc enumeration member
boBE enumeration member
boBufStream enumeration member
boCalcBeforeSaving enumeration member
boFileStream enumeration member
boLE enumeration member
boReadFormulas enumeration member
boVirtualMode enumeration member
BuildCurrencyFormatList
BuildCurrencyFormatList function
BuildCurrencyFormatString
BuildCurrencyFormatString function
BuildDateTimeFormatString
BuildDateTimeFormatString function
BuildFormatStringFromSection
BuildFormatStringFromSection function
BuildFractionFormatString
BuildFractionFormatString function
BuildNumberFormatString
BuildNumberFormatString function
C
cfBiff5Format
cfBiff5Format variable
cfBiff8Format
cfBiff8Format variable
cfCSVFormat
cfCSVFormat variable
cfHTMLFormat
cfHTMLFormat variable
cfiBackgroundColor enumeration member
cfiBorderColor enumeration member
cfiFontColor enumeration member
cfiFontName enumeration member
cfiFontSize enumeration member
cfTextHTMLFormat
cfTextHTMLFormat variable
Classes
cmToPts
cmToPts function
ColorToHTMLColorStr
ColorToHTMLColorStr function
ComboColors
ComboColors variable
Constants
ConvertFloatToStr
ConvertFloatToStr function
CopyCellFormat
CopyCellFormat function
CopyCellValue
CopyCellValue function
CountDecs
CountDecs function
D
DECS_TOKENS
DECS_TOKENS constant
DEFAULT_COL_COUNT
DEFAULT_COL_COUNT constant
DEFAULT_ROW_COUNT
DEFAULT_ROW_COUNT constant
DWordLEtoN
DWordLEtoN function
DWordToLE
DWordToLE function
E
EMUToIn
EMUToIn function
EMUToMM
EMUToMM function
EnsureOrder
EnsureOrder function
EXP_TOKENS
EXP_TOKENS constant
F
Files
FillPatternBgColor
FillPatternBgColor variable
FillPatternBitmap
FillPatternBitmap variable
FillPatternFgColor
FillPatternFgColor variable
FillPatternStyle
FillPatternStyle variable
FixHyperlinkPathDelims
FixHyperlinkPathDelims function
FixLineEndings
FixLineEndings function
FloatToFraction
FloatToFraction function
fpsHorizontalSelection enumeration member
fpsimages.pas
fpsnumformat.pas
fpspreadsheet.pas
fpspreadsheetctrls.pas
fpspreadsheetgrid.pas
fpsutils.pas
fpsVerticalSelection enumeration member
FRACDENOM_TOKENS
FRACDENOM_TOKENS constant
FRACNUM_TOKENS
FRACNUM_TOKENS constant
Functions
G
GetCellRangeString
GetCellRangeString function
GetCellString
GetCellString function
GetCellString_R1C1
GetCellString_R1C1 function
GetColorName
GetColorName function
GetColString
GetColString function
GetErrorValueStr
GetErrorValueStr function
GetFileFormatName
GetFileFormatName function
GetFormatFromFileName
GetFormatFromFileName function
GetImageInfo
GetImageInfo function
GetImageMimeType
GetImageMimeType function
GetImageTypeFromFileName
GetImageTypeFromFileName function
GetTIFSize
GetTIFSize function
GUID_SpreadsheetControl
GUID_SpreadsheetControl constant
H
HasFormula
HasFormula function
HighContrastColor
HighContrastColor function
HTMLColorStrToColor
HTMLColorStrToColor function
HTMLLengthStrToPts
HTMLLengthStrToPts function
HUE_000
HUE_000 constant
HUE_060
HUE_060 constant
HUE_120
HUE_120 constant
HUE_180
HUE_180 constant
HUE_240
HUE_240 constant
HYPERLINK_TIMER_INTERVAL
HYPERLINK_TIMER_INTERVAL constant
I
ienFormatSettings enumeration member
ienPageLayout enumeration member
IfThen
IfThen function
ImageTypeRegistry
ImageTypeRegistry variable
imCellProperties enumeration member
imCellValue enumeration member
imWorkbook enumeration member
imWorksheet enumeration member
InitCell
InitCell function
InitFormatRecord
InitFormatRecord function
InitFormatSettings
InitFormatSettings function
InitHeaderFooterImageRecord
InitHeaderFooterImageRecord function
InitImageRecord
InitImageRecord function
InitSortParams
InitSortParams function
INT_NUM_LETTERS
INT_NUM_LETTERS constant
INT_TOKENS
INT_TOKENS constant
IntegerToLE
IntegerToLE function
Interfaces
InToEMU
InToEMU function
InToMM
InToMM function
InToPts
InToPts function
IsBoolValue
IsBoolValue function
IsCurrencyFormat
IsCurrencyFormat function
IsDateFormat
IsDateFormat function
IsDateTimeFormat
IsDateTimeFormat function
IsDateTimeValue
IsDateTimeValue function
IsLongTimeFormat
IsLongTimeFormat function
IsNumberValue
IsNumberValue function
ISO8601Format
ISO8601Format constant
ISO8601FormatDateOnly
ISO8601FormatDateOnly constant
ISO8601FormatExtended
ISO8601FormatExtended constant
ISO8601FormatHoursOverflow
ISO8601FormatHoursOverflow constant
ISO8601FormatTimeOnly
ISO8601FormatTimeOnly constant
IsPaletteIndex
IsPaletteIndex function
IsSpreadsheetControl
IsSpreadsheetControl interface
about IsSpreadsheetControl interface
IsSpreadsheetControl members
IsSpreadsheetControl methods
ListenerNotification
RemoveWorkbookSource
IsSpreadsheetControl.ListenerNotification
IsSpreadsheetControl.RemoveWorkbookSource
IsTextFormat
IsTextFormat function
IsTimeFormat
IsTimeFormat function
IsTimeIntervalFormat
IsTimeIntervalFormat function
itBMP
itBMP variable
itEMF
itEMF variable
itGIF
itGIF variable
itJPEG
itJPEG variable
itPCX
itPCX variable
itPNG
itPNG variable
itSVG
itSVG variable
itTIFF
itTIFF variable
itUnknown
itUnknown constant
itWMF
itWMF variable
L
lniAbortSelection enumeration member
lniCell enumeration member
lniRow enumeration member
lniSelection enumeration member
lniWorkbook enumeration member
lniWorksheet enumeration member
lniWorksheetAdd enumeration member
lniWorksheetRemove enumeration member
lniWorksheetRemoving enumeration member
lniWorksheetRename enumeration member
LongRGBToExcelPhysical
LongRGBToExcelPhysical function
M
MakeLongDateFormat
MakeLongDateFormat function
MakeShortDateFormat
MakeShortDateFormat function
MakeTimeIntervalMask
MakeTimeIntervalMask function
mmToEMU
mmToEMU function
mmToIn
mmToIn function
mmToPts
mmToPts function
N
NEG_CURR_FMT
NEG_CURR_FMT constant
nfkCurrency enumeration member
nfkDate enumeration member
nfkExp enumeration member
nfkFraction enumeration member
nfkHasColor enumeration member
nfkHasFactor enumeration member
nfkHasThSep enumeration member
nfkPercent enumeration member
nfkText enumeration member
nfkTime enumeration member
nfkTimeInterval enumeration member
nftAMPM enumeration member
nftColor enumeration member
nftCompareOp enumeration member
nftCompareValue enumeration member
nftCountry enumeration member
nftCurrSymbol enumeration member
nftDateTimeSep enumeration member
nftDay enumeration member
nftDecSep enumeration member
nftEmptyCharWidth enumeration member
nftEscaped enumeration member
nftExpChar enumeration member
nftExpDigits enumeration member
nftExpSign enumeration member
nftFactor enumeration member
nftFracDenom enumeration member
nftFracDenomOptDigit enumeration member
nftFracDenomSpaceDigit enumeration member
nftFracDenomZeroDigit enumeration member
nftFracNumOptDigit enumeration member
nftFracNumSpaceDigit enumeration member
nftFracNumZeroDigit enumeration member
nftFracSymbol enumeration member
nftGeneral enumeration member
nftHour enumeration member
nftIntOptDigit enumeration member
nftIntSpaceDigit enumeration member
nftIntTh enumeration member
nftIntZeroDigit enumeration member
nftMilliseconds enumeration member
nftMinute enumeration member
nftMonth enumeration member
nftMonthMinute enumeration member
nftOptDecs enumeration member
nftPercent enumeration member
nftRepeat enumeration member
nftSecond enumeration member
nftSign enumeration member
nftSignBracket enumeration member
nftSpace enumeration member
nftSpaceDecs enumeration member
nftText enumeration member
nftTextFormat enumeration member
nftThSep enumeration member
nftYear enumeration member
nftZeroDecs enumeration member
NO_CELL_BORDER
NO_CELL_BORDER constant
P
ParseCellColString
ParseCellColString function
ParseCellRangeString
ParseCellRangeString function
ParseCellRangeString_R1C1
ParseCellRangeString_R1C1 function
ParseCellRowString
ParseCellRowString function
ParseCellString
ParseCellString function
ParseCellString_R1C1
ParseCellString_R1C1 function
ParseIntervalString
ParseIntervalString function
ParseSheetCellString
ParseSheetCellString function
PCol
PCol type
POS_CURR_FMT
POS_CURR_FMT constant
PRow
PRow type
PsNumFormatSection
PsNumFormatSection type
PtsToCm
PtsToCm function
PtsToIn
PtsToIn function
PtsToMM
PtsToMM function
PtsToPx
PtsToPx function
PtsToTwips
PtsToTwips function
pxToPts
pxToPts function
R
Range
Range function
Register
Register function
RegisterImageType
RegisterImageType function
RELCHAR
RELCHAR constant
ReplaceFormatSettings
ReplaceFormatSettings function
S
SameCellBorders
SameCellBorders function
SameFont
SameFont function
ScreenPixelsPerInch
ScreenPixelsPerInch variable
SetAsPaletteIndex
SetAsPaletteIndex function
soHasFrozenPanes enumeration member
soShowGridLines enumeration member
soShowHeaders enumeration member
SplitHyperlink
SplitHyperlink function
SplitStr
SplitStr function
SpreadsheetFormatInClipboard
SpreadsheetFormatInClipboard function
StripAMPM
StripAMPM function
Structs, Records, Enums
T
TAnsiCharSet
TAnsiCharSet type
TByteOrder
TByteOrder enumeration
TCol
TCol record
TERMINATING_TOKENS
TERMINATING_TOKENS constant
TGetImageSizeFunc
TGetImageSizeFunc type
TImageTypeRecord
TImageTypeRecord record
TintedColor
TintedColor function
TRGBA
TRGBA record
TRow
TRow record
TryFractionStrToFloat
TryFractionStrToFloat function
TryStrToErrorValue
TryStrToErrorValue function
TryStrToFloatAuto
TryStrToFloatAuto function
TsAutoExpandMode
TsAutoExpandMode enumeration
TsAutoExpandModes
TsAutoExpandModes type
TsCellCombobox
TsCellCombobox class
about TsCellCombobox class
Align
Anchors
ApplyFormatToCell
ArrowKeysTraverseList
AutoComplete
AutoCompleteText
AutoDropDown
AutoSelect
AutoSize
BidiMode
BorderSpacing
BorderStyle
CellFormatItem
Change
CharCase
Color
ColorRectOffset
ColorRectWidth
Constraints
Create
Destroy
DragCursor
DragKind
DragMode
DrawItem
DropDownCount
Enabled
ExtractFromCell
Font
GetActiveCell
ItemIndex
Items
ItemWidth
ListenerNotification
Loaded
MaxLength
Notification
OnChange
OnChangeBounds
OnClick
OnCloseUp
OnContextPopup
OnDblClick
OnDragDrop
OnDragOver
OnDrawItem
OnDropDown
OnEditingDone
OnEndDrag
OnEnter
OnExit
OnGetItems
OnKeyDown
OnKeyPress
OnKeyUp
OnMeasureItem
OnMouseDown
OnMouseEnter
OnMouseLeave
OnMouseMove
OnMouseUp
OnMouseWheel
OnMouseWheelDown
OnMouseWheelUp
OnSelect
OnStartDrag
OnUTF8KeyPress
ParentBidiMode
ParentColor
ParentFont
ParentShowHint
Populate
PopupMenu
ProcessItem
RemoveWorkbookSource
Select
ShowHint
Sorted
TabOrder
TabStop
Text
TsCellCombobox members
TsCellCombobox methods
TsCellCombobox properties
Visible
Workbook
WorkbookSource
Worksheet
TsCellCombobox.Align
TsCellCombobox.Anchors
TsCellCombobox.ApplyFormatToCell
TsCellCombobox.ArrowKeysTraverseList
TsCellCombobox.AutoComplete
TsCellCombobox.AutoCompleteText
TsCellCombobox.AutoDropDown
TsCellCombobox.AutoSelect
TsCellCombobox.AutoSize
TsCellCombobox.BidiMode
TsCellCombobox.BorderSpacing
TsCellCombobox.BorderStyle
TsCellCombobox.CellFormatItem
TsCellCombobox.Change
TsCellCombobox.CharCase
TsCellCombobox.Color
TsCellCombobox.ColorRectOffset
TsCellCombobox.ColorRectWidth
TsCellCombobox.Constraints
TsCellCombobox.Create
TsCellCombobox.Destroy
TsCellCombobox.DragCursor
TsCellCombobox.DragKind
TsCellCombobox.DragMode
TsCellCombobox.DrawItem
TsCellCombobox.DropDownCount
TsCellCombobox.Enabled
TsCellCombobox.ExtractFromCell
TsCellCombobox.Font
TsCellCombobox.GetActiveCell
TsCellCombobox.ItemIndex
TsCellCombobox.Items
TsCellCombobox.ItemWidth
TsCellCombobox.ListenerNotification
TsCellCombobox.Loaded
TsCellCombobox.MaxLength
TsCellCombobox.Notification
TsCellCombobox.OnChange
TsCellCombobox.OnChangeBounds
TsCellCombobox.OnClick
TsCellCombobox.OnCloseUp
TsCellCombobox.OnContextPopup
TsCellCombobox.OnDblClick
TsCellCombobox.OnDragDrop
TsCellCombobox.OnDragOver
TsCellCombobox.OnDrawItem
TsCellCombobox.OnDropDown
TsCellCombobox.OnEditingDone
TsCellCombobox.OnEndDrag
TsCellCombobox.OnEnter
TsCellCombobox.OnExit
TsCellCombobox.OnGetItems
TsCellCombobox.OnKeyDown
TsCellCombobox.OnKeyPress
TsCellCombobox.OnKeyUp
TsCellCombobox.OnMeasureItem
TsCellCombobox.OnMouseDown
TsCellCombobox.OnMouseEnter
TsCellCombobox.OnMouseLeave
TsCellCombobox.OnMouseMove
TsCellCombobox.OnMouseUp
TsCellCombobox.OnMouseWheel
TsCellCombobox.OnMouseWheelDown
TsCellCombobox.OnMouseWheelUp
TsCellCombobox.OnSelect
TsCellCombobox.OnStartDrag
TsCellCombobox.OnUTF8KeyPress
TsCellCombobox.ParentBidiMode
TsCellCombobox.ParentColor
TsCellCombobox.ParentFont
TsCellCombobox.ParentShowHint
TsCellCombobox.Populate
TsCellCombobox.PopupMenu
TsCellCombobox.ProcessItem
TsCellCombobox.RemoveWorkbookSource
TsCellCombobox.Select
TsCellCombobox.ShowHint
TsCellCombobox.Sorted
TsCellCombobox.TabOrder
TsCellCombobox.TabStop
TsCellCombobox.Text
TsCellCombobox.Visible
TsCellCombobox.Workbook
TsCellCombobox.WorkbookSource
TsCellCombobox.Worksheet
TsCellCompareEvent
TsCellCompareEvent type
TsCellEdit
TsCellEdit class
about TsCellEdit class
Create
Destroy
EditingDone
ListenerNotification
Notification
RemoveWorkbookSource
SelectedCell
ShowCell
ShowHTMLText
TsCellEdit members
TsCellEdit methods
TsCellEdit properties
Workbook
WorkbookSource
Worksheet
TsCellEdit.Create
TsCellEdit.Destroy
TsCellEdit.EditingDone
TsCellEdit.ListenerNotification
TsCellEdit.Notification
TsCellEdit.RemoveWorkbookSource
TsCellEdit.SelectedCell
TsCellEdit.ShowCell
TsCellEdit.ShowHTMLText
TsCellEdit.Workbook
TsCellEdit.WorkbookSource
TsCellEdit.Worksheet
TsCellEvent
TsCellEvent type
TsCellFormatItem
TsCellFormatItem enumeration
TsCellIndicator
TsCellIndicator class
about TsCellIndicator class
Alignment
Create
Destroy
EditingDone
ListenerNotification
Notification
RemoveWorkbookSource
TsCellIndicator members
TsCellIndicator methods
TsCellIndicator properties
Workbook
WorkbookSource
Worksheet
TsCellIndicator.Alignment
TsCellIndicator.Create
TsCellIndicator.Destroy
TsCellIndicator.EditingDone
TsCellIndicator.ListenerNotification
TsCellIndicator.Notification
TsCellIndicator.RemoveWorkbookSource
TsCellIndicator.Workbook
TsCellIndicator.WorkbookSource
TsCellIndicator.Worksheet
TsCellList
TsCellList class
about TsCellList class
Add
AddCell
AddEmptyCell
CellByIndex
Clear
Delete
Destroy
IndexOf
MultipleRanges
TsCellList members
TsCellList methods
TsCellList properties
TsCellList.Add
TsCellList.AddCell
TsCellList.AddEmptyCell
TsCellList.CellByIndex
TsCellList.Clear
TsCellList.Delete
TsCellList.Destroy
TsCellList.IndexOf
TsCellList.MultipleRanges
TsCustomWorksheetGrid
TsCustomWorksheetGrid class
about TsCustomWorksheetGrid class
AutoAdjustColumn
AutoAdjustRow
AutoCalc
AutoExpand
AutoExpandToCol
AutoExpandToRow
BackgroundColor
BackgroundColors
BeginUpdate
CalcWorksheetColWidth
CalcWorksheetRowHeight
CellBiDiMode
CellBorder
CellBorders
CellBorderStyle
CellBorderStyles
CellComment
CellFont
CellFontColor
CellFontColors
CellFontName
CellFontNames
CellFonts
CellFontSize
CellFontSizes
CellFontStyle
CellFontStyles
CellOverflow
CellRect
Cells
ColWidths
Convert_Font_to_sFont
Convert_sFont_to_Font
Create
CreateNewWorkbook
DblClick
DefaultColWidth
DefaultDrawCell
DefaultRowHeight
DefineProperties
DeleteCol
DeleteRow
Destroy
DisplayFixedColRow
DoCopyToClipboard
DoCutToClipboard
DoEditorShow
DoOnResize
DoPasteFromClipboard
DoPrepareCanvas
DrawAllRows
DrawCellBorders
DrawCellBorders
DrawCellBorders method
DrawCellGrid
DrawCommentMarker
DrawFocusRect
DrawFrozenPaneBorders
DrawRow
DrawSelection
DrawTextInCell
EditingDone
EndUpdate
ExecuteHyperlink
FrozenCols
FrozenRows
GetCellHeight
GetCellHintText
GetCellText
GetDefaultHeaderColWidth
GetEditText
GetGridCol
GetGridRow
GetSheets
GetWorksheetCol
GetWorksheetRow
HasBorder
HeaderCount
HeaderSized
HeaderSizing
HorAlignment
HorAlignments
Hyperlink
InsertCol
InsertRow
InternalDrawTextInCell
KeyDown
ListenerNotification
Loaded
LoadFromSpreadsheetFile
LoadFromSpreadsheetFile
LoadFromSpreadsheetFile
LoadFromSpreadsheetFile method
LoadFromWorkbook
MergeCells
MergeCells
MergeCells
MergeCells method
MouseDown
MouseMove
MouseUp
MoveSelection
NewWorkbook
Notification
NumberFormat
NumberFormats
OnClickHyperlink
RangeSelectMode
ReadFormulas
RemoveWorkbookSource
RowHeights
SaveToSpreadsheetFile
SaveToSpreadsheetFile
SaveToSpreadsheetFile
SaveToSpreadsheetFile method
SelectEditor
SelectionPen
SelectSheetByIndex
SelPenChangeHandler
SetEditText
Setup
ShowCellBorders
ShowGridLines
ShowHeaders
Sort
TextOverflow
TextRotation
TextRotations
TopLeftChanged
TrimToCell
TsCustomWorksheetGrid events
TsCustomWorksheetGrid members
TsCustomWorksheetGrid methods
TsCustomWorksheetGrid properties
UnmergeCells
UnmergeCells
UnmergeCells method
UpdateColWidths
UpdateRowHeights
VertAlignment
VertAlignments
Wordwrap
Wordwraps
Workbook
WorkbookSource
Worksheet
TsCustomWorksheetGrid.AutoAdjustColumn
TsCustomWorksheetGrid.AutoAdjustRow
TsCustomWorksheetGrid.AutoCalc
TsCustomWorksheetGrid.AutoExpand
TsCustomWorksheetGrid.AutoExpandToCol
TsCustomWorksheetGrid.AutoExpandToRow
TsCustomWorksheetGrid.BackgroundColor
TsCustomWorksheetGrid.BackgroundColors
TsCustomWorksheetGrid.BeginUpdate
TsCustomWorksheetGrid.CalcWorksheetColWidth
TsCustomWorksheetGrid.CalcWorksheetRowHeight
TsCustomWorksheetGrid.CellBiDiMode
TsCustomWorksheetGrid.CellBorder
TsCustomWorksheetGrid.CellBorders
TsCustomWorksheetGrid.CellBorderStyle
TsCustomWorksheetGrid.CellBorderStyles
TsCustomWorksheetGrid.CellComment
TsCustomWorksheetGrid.CellFont
TsCustomWorksheetGrid.CellFontColor
TsCustomWorksheetGrid.CellFontColors
TsCustomWorksheetGrid.CellFontName
TsCustomWorksheetGrid.CellFontNames
TsCustomWorksheetGrid.CellFonts
TsCustomWorksheetGrid.CellFontSize
TsCustomWorksheetGrid.CellFontSizes
TsCustomWorksheetGrid.CellFontStyle
TsCustomWorksheetGrid.CellFontStyles
TsCustomWorksheetGrid.CellOverflow
TsCustomWorksheetGrid.CellRect
TsCustomWorksheetGrid.Cells
TsCustomWorksheetGrid.ColWidths
TsCustomWorksheetGrid.Convert_Font_to_sFont
TsCustomWorksheetGrid.Convert_sFont_to_Font
TsCustomWorksheetGrid.Create
TsCustomWorksheetGrid.CreateNewWorkbook
TsCustomWorksheetGrid.DblClick
TsCustomWorksheetGrid.DefaultColWidth
TsCustomWorksheetGrid.DefaultDrawCell
TsCustomWorksheetGrid.DefaultRowHeight
TsCustomWorksheetGrid.DefineProperties
TsCustomWorksheetGrid.DeleteCol
TsCustomWorksheetGrid.DeleteRow
TsCustomWorksheetGrid.Destroy
TsCustomWorksheetGrid.DisplayFixedColRow
TsCustomWorksheetGrid.DoCopyToClipboard
TsCustomWorksheetGrid.DoCutToClipboard
TsCustomWorksheetGrid.DoEditorShow
TsCustomWorksheetGrid.DoOnResize
TsCustomWorksheetGrid.DoPasteFromClipboard
TsCustomWorksheetGrid.DoPrepareCanvas
TsCustomWorksheetGrid.DrawAllRows
TsCustomWorksheetGrid.DrawCellBorders
TsCustomWorksheetGrid.DrawCellGrid
TsCustomWorksheetGrid.DrawCommentMarker
TsCustomWorksheetGrid.DrawFocusRect
TsCustomWorksheetGrid.DrawFrozenPaneBorders
TsCustomWorksheetGrid.DrawRow
TsCustomWorksheetGrid.DrawSelection
TsCustomWorksheetGrid.DrawTextInCell
TsCustomWorksheetGrid.EditingDone
TsCustomWorksheetGrid.EndUpdate
TsCustomWorksheetGrid.ExecuteHyperlink
TsCustomWorksheetGrid.FrozenCols
TsCustomWorksheetGrid.FrozenRows
TsCustomWorksheetGrid.GetCellHeight
TsCustomWorksheetGrid.GetCellHintText
TsCustomWorksheetGrid.GetCellText
TsCustomWorksheetGrid.GetDefaultHeaderColWidth
TsCustomWorksheetGrid.GetEditText
TsCustomWorksheetGrid.GetGridCol
TsCustomWorksheetGrid.GetGridRow
TsCustomWorksheetGrid.GetSheets
TsCustomWorksheetGrid.GetWorksheetCol
TsCustomWorksheetGrid.GetWorksheetRow
TsCustomWorksheetGrid.HasBorder
TsCustomWorksheetGrid.HeaderCount
TsCustomWorksheetGrid.HeaderSized
TsCustomWorksheetGrid.HeaderSizing
TsCustomWorksheetGrid.HorAlignment
TsCustomWorksheetGrid.HorAlignments
TsCustomWorksheetGrid.Hyperlink
TsCustomWorksheetGrid.InsertCol
TsCustomWorksheetGrid.InsertRow
TsCustomWorksheetGrid.InternalDrawTextInCell
TsCustomWorksheetGrid.KeyDown
TsCustomWorksheetGrid.ListenerNotification
TsCustomWorksheetGrid.Loaded
TsCustomWorksheetGrid.LoadFromSpreadsheetFile
TsCustomWorksheetGrid.LoadFromWorkbook
TsCustomWorksheetGrid.MergeCells
TsCustomWorksheetGrid.MouseDown
TsCustomWorksheetGrid.MouseMove
TsCustomWorksheetGrid.MouseUp
TsCustomWorksheetGrid.MoveSelection
TsCustomWorksheetGrid.NewWorkbook
TsCustomWorksheetGrid.Notification
TsCustomWorksheetGrid.NumberFormat
TsCustomWorksheetGrid.NumberFormats
TsCustomWorksheetGrid.OnClickHyperlink
TsCustomWorksheetGrid.RangeSelectMode
TsCustomWorksheetGrid.ReadFormulas
TsCustomWorksheetGrid.RemoveWorkbookSource
TsCustomWorksheetGrid.RowHeights
TsCustomWorksheetGrid.SaveToSpreadsheetFile
TsCustomWorksheetGrid.SelectEditor
TsCustomWorksheetGrid.SelectionPen
TsCustomWorksheetGrid.SelectSheetByIndex
TsCustomWorksheetGrid.SelPenChangeHandler
TsCustomWorksheetGrid.SetEditText
TsCustomWorksheetGrid.Setup
TsCustomWorksheetGrid.ShowCellBorders
TsCustomWorksheetGrid.ShowGridLines
TsCustomWorksheetGrid.ShowHeaders
TsCustomWorksheetGrid.Sort
TsCustomWorksheetGrid.TextOverflow
TsCustomWorksheetGrid.TextRotation
TsCustomWorksheetGrid.TextRotations
TsCustomWorksheetGrid.TopLeftChanged
TsCustomWorksheetGrid.TrimToCell
TsCustomWorksheetGrid.UnmergeCells
TsCustomWorksheetGrid.UpdateColWidths
TsCustomWorksheetGrid.UpdateRowHeights
TsCustomWorksheetGrid.VertAlignment
TsCustomWorksheetGrid.VertAlignments
TsCustomWorksheetGrid.Wordwrap
TsCustomWorksheetGrid.Wordwraps
TsCustomWorksheetGrid.Workbook
TsCustomWorksheetGrid.WorkbookSource
TsCustomWorksheetGrid.Worksheet
TsDecsChars
TsDecsChars type
TsHyperlinkClickEvent
TsHyperlinkClickEvent type
TsImageType
TsImageType type
TsInspectorExpandedNode
TsInspectorExpandedNode enumeration
TsInspectorExpandedNodes
TsInspectorExpandedNodes type
TsInspectorMode
TsInspectorMode enumeration
TsNotificationItem
TsNotificationItem enumeration
TsNotificationItems
TsNotificationItems type
TsNumFormatElement
TsNumFormatElement record
TsNumFormatElements
TsNumFormatElements type
TsNumFormatKind
TsNumFormatKind enumeration
TsNumFormatKinds
TsNumFormatKinds type
TsNumFormatList
TsNumFormatList class
about TsNumFormatList class
AddBuiltinFormats
AddFormat
AddFormat
AddFormat method
Clear
Create
Delete
Destroy
FClass
FFormatSettings
Find
Find
Find method
Items
TsNumFormatList fields
TsNumFormatList members
TsNumFormatList methods
TsNumFormatList properties
TsNumFormatList.AddBuiltinFormats
TsNumFormatList.AddFormat
TsNumFormatList.Clear
TsNumFormatList.Create
TsNumFormatList.Delete
TsNumFormatList.Destroy
TsNumFormatList.FClass
TsNumFormatList.FFormatSettings
TsNumFormatList.Find
TsNumFormatList.Items
TsNumFormatParams
TsNumFormatParams class
about TsNumFormatParams class
DeleteElement
GetNumFormat
GetNumFormatStr
InsertElement
NumFormat
NumFormatStr
Sections
SectionsEqualTo
SetCurrSymbol
SetDecimals
SetNegativeRed
SetThousandSep
TsNumFormatParams fields
TsNumFormatParams members
TsNumFormatParams methods
TsNumFormatParams properties
TsNumFormatParams.DeleteElement
TsNumFormatParams.GetNumFormat
TsNumFormatParams.GetNumFormatStr
TsNumFormatParams.InsertElement
TsNumFormatParams.NumFormat
TsNumFormatParams.NumFormatStr
TsNumFormatParams.Sections
TsNumFormatParams.SectionsEqualTo
TsNumFormatParams.SetCurrSymbol
TsNumFormatParams.SetDecimals
TsNumFormatParams.SetNegativeRed
TsNumFormatParams.SetThousandSep
TsNumFormatParamsClass
TsNumFormatParamsClass type
TsNumFormatSection
TsNumFormatSection record
TsNumFormatSections
TsNumFormatSections type
TsNumFormatToken
TsNumFormatToken enumeration
TsNumFormatTokenSet
TsNumFormatTokenSet type
TsRemoveWorksheetEvent
TsRemoveWorksheetEvent type
TsSelectionDirection
TsSelectionDirection enumeration
TsSelPen
TsSelPen class
about TsSelPen class
Create
JoinStyle
TsSelPen members
TsSelPen properties
Width
TsSelPen.Create
TsSelPen.JoinStyle
TsSelPen.Width
TsSheetOption
TsSheetOption enumeration
TsSheetOptions
TsSheetOptions type
TsSpreadsheetInspector
TsSpreadsheetInspector class
about TsSpreadsheetInspector class
Create
DblClick
Destroy
DisplayOptions
DoUpdate
TsSpreadsheetInspector class
ExpandedNodes
ExtendedColSizing
FixedCols
ListenerNotification
Mode
Notification
RemoveWorkbookSource
TsSpreadsheetInspector members
TsSpreadsheetInspector methods
TsSpreadsheetInspector properties
UpdateCellProperties
UpdateCellValue
UpdateWorkbook
UpdateWorksheet
Workbook
WorkbookSource
Worksheet
TsSpreadsheetInspector.Create
TsSpreadsheetInspector.DblClick
TsSpreadsheetInspector.Destroy
TsSpreadsheetInspector.DisplayOptions
TsSpreadsheetInspector.DoUpdate
TsSpreadsheetInspector.ExpandedNodes
TsSpreadsheetInspector.ExtendedColSizing
TsSpreadsheetInspector.FixedCols
TsSpreadsheetInspector.ListenerNotification
TsSpreadsheetInspector.Mode
TsSpreadsheetInspector.Notification
TsSpreadsheetInspector.RemoveWorkbookSource
TsSpreadsheetInspector.UpdateCellProperties
TsSpreadsheetInspector.UpdateCellValue
TsSpreadsheetInspector.UpdateWorkbook
TsSpreadsheetInspector.UpdateWorksheet
TsSpreadsheetInspector.Workbook
TsSpreadsheetInspector.WorkbookSource
TsSpreadsheetInspector.Worksheet
TStringArray
TStringArray type
TsWorkbook
TsWorkbook class
about TsWorkbook class
ActiveWorksheet
AddCellFormat
AddEmbeddedStream
AddErrorMsg
AddErrorMsg
AddErrorMsg method
AddFont
AddFont
AddFont method
AddNumberFormat
AddWorksheet
ClearErrorList
CopyToClipboardStream
CopyWorksheetFrom
Create
DeleteFont
Destroy
DisableNotifications
EnableNotifications
ErrorMsg
FCellFormatList
FEmbeddedStreamList
FFontList
FileFormatID
FileName
FindEmbeddedStream
FindFont
FNumFormatList
FormatSettings
GetBuiltinFontCount
GetCellFormat
GetCellFormatAsString
GetDefaultFont
GetDefaultFontSize
GetEmbeddedStream
GetEmbeddedStreamCount
GetFirstWorksheet
GetFont
GetFontAsString
GetFontCount
GetFormatFromFileHeader
GetFormatFromFileHeader
GetFormatFromFileHeader method
GetHyperlinkFont
GetLastRowColIndex
GetNumberFormat
GetNumberFormatCount
GetNumCellFormats
GetPointerToCellFormat
GetWorksheetByIndex
GetWorksheetByName
GetWorksheetCount
GetWorksheetIndex
HasEmbeddedSheetImages
InitFonts
NotificationsEnabled
OnAddWorksheet
OnChangeWorksheet
OnOpenWorkbook
OnReadCellData
OnRemoveWorksheet
OnRemovingWorksheet
OnRenameWorksheet
OnSelectWorksheet
OnWriteCellData
Options
PasteFromClipboardStream
PrepareBeforeReading
PrepareBeforeSaving
ReadFromFile
ReadFromFile
ReadFromFile
ReadFromFile method
ReadFromFileIgnoringExtension
ReadFromStream
ReadFromStream
ReadFromStream method
ReCalc
RemoveAllEmbeddedStreams
RemoveAllFonts
RemoveAllWorksheets
RemoveWorksheet
ReplaceFont
SelectWorksheet
SetDefaultFont
TryStrToCell
TryStrToCellRange
TryStrToCellRanges
TsWorkbook events
TsWorkbook fields
TsWorkbook members
TsWorkbook methods
TsWorkbook properties
UpdateCaches
ValidWorksheetName
VirtualColCount
VirtualRowCount
WriteToFile
WriteToFile
WriteToFile
WriteToFile method
WriteToStream
WriteToStream
WriteToStream method
TsWorkbook.ActiveWorksheet
TsWorkbook.AddCellFormat
TsWorkbook.AddEmbeddedStream
TsWorkbook.AddErrorMsg
TsWorkbook.AddFont
TsWorkbook.AddNumberFormat
TsWorkbook.AddWorksheet
TsWorkbook.ClearErrorList
TsWorkbook.CopyToClipboardStream
TsWorkbook.CopyWorksheetFrom
TsWorkbook.Create
TsWorkbook.DeleteFont
TsWorkbook.Destroy
TsWorkbook.DisableNotifications
TsWorkbook.EnableNotifications
TsWorkbook.ErrorMsg
TsWorkbook.FCellFormatList
TsWorkbook.FEmbeddedStreamList
TsWorkbook.FFontList
TsWorkbook.FileFormatID
TsWorkbook.FileName
TsWorkbook.FindEmbeddedStream
TsWorkbook.FindFont
TsWorkbook.FNumFormatList
TsWorkbook.FormatSettings
TsWorkbook.GetBuiltinFontCount
TsWorkbook.GetCellFormat
TsWorkbook.GetCellFormatAsString
TsWorkbook.GetDefaultFont
TsWorkbook.GetDefaultFontSize
TsWorkbook.GetEmbeddedStream
TsWorkbook.GetEmbeddedStreamCount
TsWorkbook.GetFirstWorksheet
TsWorkbook.GetFont
TsWorkbook.GetFontAsString
TsWorkbook.GetFontCount
TsWorkbook.GetFormatFromFileHeader
TsWorkbook.GetHyperlinkFont
TsWorkbook.GetLastRowColIndex
TsWorkbook.GetNumberFormat
TsWorkbook.GetNumberFormatCount
TsWorkbook.GetNumCellFormats
TsWorkbook.GetPointerToCellFormat
TsWorkbook.GetWorksheetByIndex
TsWorkbook.GetWorksheetByName
TsWorkbook.GetWorksheetCount
TsWorkbook.GetWorksheetIndex
TsWorkbook.HasEmbeddedSheetImages
TsWorkbook.InitFonts
TsWorkbook.NotificationsEnabled
TsWorkbook.OnAddWorksheet
TsWorkbook.OnChangeWorksheet
TsWorkbook.OnOpenWorkbook
TsWorkbook.OnReadCellData
TsWorkbook.OnRemoveWorksheet
TsWorkbook.OnRemovingWorksheet
TsWorkbook.OnRenameWorksheet
TsWorkbook.OnSelectWorksheet
TsWorkbook.OnWriteCellData
TsWorkbook.Options
TsWorkbook.PasteFromClipboardStream
TsWorkbook.PrepareBeforeReading
TsWorkbook.PrepareBeforeSaving
TsWorkbook.ReadFromFile
TsWorkbook.ReadFromFileIgnoringExtension
TsWorkbook.ReadFromStream
TsWorkbook.ReCalc
TsWorkbook.RemoveAllEmbeddedStreams
TsWorkbook.RemoveAllFonts
TsWorkbook.RemoveAllWorksheets
TsWorkbook.RemoveWorksheet
TsWorkbook.ReplaceFont
TsWorkbook.SelectWorksheet
TsWorkbook.SetDefaultFont
TsWorkbook.TryStrToCell
TsWorkbook.TryStrToCellRange
TsWorkbook.TryStrToCellRanges
TsWorkbook.UpdateCaches
TsWorkbook.ValidWorksheetName
TsWorkbook.VirtualColCount
TsWorkbook.VirtualRowCount
TsWorkbook.WriteToFile
TsWorkbook.WriteToStream
TsWorkbookOption
TsWorkbookOption enumeration
TsWorkbookOptions
TsWorkbookOptions type
TsWorkbookReadCellDataEvent
TsWorkbookReadCellDataEvent type
TsWorkbookSource
TsWorkbookSource class
AbortSelection
about TsWorkbookSource class
AddListener
AutoDetectFormat
CopyCellsToClipboard
Create
CreateNewWorkbook
CutCellsToClipboard
Destroy
DisableControls
DoShowError
EnableControls
ExecutePendingOperation
FileFormat
FileFormatID
FileName
InternalCreateNewWorkbook
InternalLoadFromFile
InternalLoadFromWorkbook
Loaded
LoadFromSpreadsheetFile
LoadFromSpreadsheetFile
LoadFromSpreadsheetFile method
LoadFromWorkbook
NotifyListeners
OnError
Options
PasteCellsFromClipboard
PendingOperation
RemoveListener
SaveToSpreadsheetFile
SaveToSpreadsheetFile
SaveToSpreadsheetFile
SaveToSpreadsheetFile method
SelectCell
SelectWorksheet
SetPendingOperation
TsWorkbookSource events
TsWorkbookSource members
TsWorkbookSource methods
TsWorkbookSource properties
Workbook
Worksheet
TsWorkbookSource.AbortSelection
TsWorkbookSource.AddListener
TsWorkbookSource.AutoDetectFormat
TsWorkbookSource.CopyCellsToClipboard
TsWorkbookSource.Create
TsWorkbookSource.CreateNewWorkbook
TsWorkbookSource.CutCellsToClipboard
TsWorkbookSource.Destroy
TsWorkbookSource.DisableControls
TsWorkbookSource.DoShowError
TsWorkbookSource.EnableControls
TsWorkbookSource.ExecutePendingOperation
TsWorkbookSource.FileFormat
TsWorkbookSource.FileFormatID
TsWorkbookSource.FileName
TsWorkbookSource.InternalCreateNewWorkbook
TsWorkbookSource.InternalLoadFromFile
TsWorkbookSource.InternalLoadFromWorkbook
TsWorkbookSource.Loaded
TsWorkbookSource.LoadFromSpreadsheetFile
TsWorkbookSource.LoadFromWorkbook
TsWorkbookSource.NotifyListeners
TsWorkbookSource.OnError
TsWorkbookSource.Options
TsWorkbookSource.PasteCellsFromClipboard
TsWorkbookSource.PendingOperation
TsWorkbookSource.RemoveListener
TsWorkbookSource.SaveToSpreadsheetFile
TsWorkbookSource.SelectCell
TsWorkbookSource.SelectWorksheet
TsWorkbookSource.SetPendingOperation
TsWorkbookSource.Workbook
TsWorkbookSource.Worksheet
TsWorkbookSourceErrorEvent
TsWorkbookSourceErrorEvent type
TsWorkbookTabControl
TsWorkbookTabControl class
about TsWorkbookTabControl class
Change
Destroy
GetSheetList
GetWorkbook
GetWorksheet
ListenerNotification
Notification
RemoveWorkbookSource
TsWorkbookTabControl members
TsWorkbookTabControl methods
TsWorkbookTabControl properties
Workbook
WorkbookSource
Worksheet
TsWorkbookTabControl.Change
TsWorkbookTabControl.Destroy
TsWorkbookTabControl.GetSheetList
TsWorkbookTabControl.GetWorkbook
TsWorkbookTabControl.GetWorksheet
TsWorkbookTabControl.ListenerNotification
TsWorkbookTabControl.Notification
TsWorkbookTabControl.RemoveWorkbookSource
TsWorkbookTabControl.Workbook
TsWorkbookTabControl.WorkbookSource
TsWorkbookTabControl.Worksheet
TsWorkbookWriteCellDataEvent
TsWorkbookWriteCellDataEvent type
TsWorksheet
TsWorksheet class
about TsWorksheet class
ActiveCellCol
ActiveCellRow
AddCell
BiDiMode
BuildRPNFormula
CalcAutoRowHeight
CalcFormula
CalcFormulas
CalcImageExtent
CellInRange
CellPosToText
Cells
CellUsedInFormula
ChangedCell
ChangedFont
ClearSelection
Cols
Comments
ConvertFormulaDialect
ConvertRPNFormulaToStringFormula
CopyCell
CopyCell
CopyCell method
CopyFormat
CopyFormat
CopyFormat method
CopyFormula
CopyFormula
CopyFormula method
CopyValue
CopyValue
CopyValue method
Create
DefaultColWidth
DefaultRowHeight
DeleteCell
DeleteCol
DeleteRichTextParams
DeleteRow
DeleteSelection
Destroy
DoCompareCells
DoExchangeColRow
DoInternalCompareCells
EraseCell
ExchangeCells
FindCell
FindCell
FindCell method
FindCol
FindComment
FindHyperlink
FindMergeBase
FindMergedRange
FindNextCellInCol
FindNextCellInRow
FindPrevCellInCol
FindPrevCellInRow
FindRow
FormatSettings
GetCalcState
GetCell
GetCell
GetCell method
GetCellCount
GetCellCountInCol
GetCellCountInRow
GetCol
GetColWidth
GetDisplayedDecimals
GetFirstColIndex
GetFirstRowIndex
GetImage
GetImageCount
GetLastColIndex
GetLastColNumber
GetLastOccupiedColIndex
GetLastOccupiedRowIndex
GetLastRowIndex
GetLastRowNumber
GetNumberFormatAttributes
GetRow
GetRowHeight
GetSelection
GetSelectionAsString
GetSelectionCount
GetSelectionRangeIndexOfActiveCell
HasComment
HasHyperlink
Hyperlinks
InSameMergedRange
InsertCol
InsertRow
IsMergeBase
IsMerged
LeftPaneWidth
MergeCells
MergeCells
MergeCells method
MergedCells
Name
OnChangeCell
OnChangeFont
OnCompareCells
OnSelectCell
Options
PageLayout
ReadAsDateTime
ReadAsDateTime
ReadAsDateTime method
ReadAsNumber
ReadAsNumber
ReadAsNumber method
ReadAsText
ReadAsText
ReadAsText
ReadAsText method
ReadAsUTF8Text
ReadAsUTF8Text
ReadAsUTF8Text
ReadAsUTF8Text method
ReadBackground
ReadBackgroundColor
ReadBiDiMode
ReadCellBorders
ReadCellBorderStyle
ReadCellBorderStyles
ReadCellFont
ReadCellFontIndex
ReadCellFormat
ReadComment
ReadComment
ReadComment method
ReadFormulaAsString
ReadHorAlignment
ReadHyperlink
ReadNumericValue
ReadNumFormat
ReadTextRotation
ReadUsedFormatting
ReadVertAlignment
ReadWordwrap
RemoveAllCols
RemoveAllImages
RemoveAllRows
RemoveAndFreeCell
RemoveCell
RemoveCol
RemoveComment
RemoveHyperlink
RemoveImage
RemoveRow
Rows
SelectCell
SetCalcState
SetSelection
Sort
Sort
Sort method
TopPaneHeight
TsWorksheet events
TsWorksheet members
TsWorksheet methods
TsWorksheet properties
UnmergeCells
UnmergeCells
UnmergeCells method
UpdateCaches
ValidHyperlink
Workbook
WriteBackground
WriteBackground
WriteBackground method
WriteBackgroundColor
WriteBackgroundColor
WriteBackgroundColor method
WriteBiDiMode
WriteBiDiMode
WriteBiDiMode method
WriteBlank
WriteBlank
WriteBlank method
WriteBoolValue
WriteBoolValue
WriteBoolValue method
WriteBorderColor
WriteBorderColor
WriteBorderColor method
WriteBorderLineStyle
WriteBorderLineStyle
WriteBorderLineStyle method
WriteBorders
WriteBorders
WriteBorders method
WriteBorderStyle
WriteBorderStyle
WriteBorderStyle
WriteBorderStyle
WriteBorderStyle method
WriteBorderStyles
WriteBorderStyles
WriteBorderStyles method
WriteCellFormat
WriteCellValueAsString
WriteCellValueAsString
WriteCellValueAsString method
WriteColInfo
WriteColWidth
WriteComment
WriteComment
WriteComment method
WriteCurrency
WriteCurrency
WriteCurrency
WriteCurrency
WriteCurrency method
WriteDateTime
WriteDateTime
WriteDateTime
WriteDateTime
WriteDateTime
WriteDateTime
WriteDateTime method
WriteDateTimeFormat
WriteDateTimeFormat
WriteDateTimeFormat method
WriteDecimals
WriteDecimals
WriteDecimals method
WriteErrorValue
WriteErrorValue
WriteErrorValue method
WriteFont
WriteFont
WriteFont
WriteFont
WriteFont method
WriteFontColor
WriteFontColor
WriteFontColor method
WriteFontName
WriteFontName
WriteFontName method
WriteFontSize
WriteFontSize
WriteFontSize method
WriteFontStyle
WriteFontStyle
WriteFontStyle method
WriteFormula
WriteFormula
WriteFormula method
WriteFractionFormat
WriteFractionFormat
WriteFractionFormat method
WriteHorAlignment
WriteHorAlignment
WriteHorAlignment method
WriteHyperlink
WriteHyperlink
WriteHyperlink method
WriteImage
WriteNumber
WriteNumber
WriteNumber
WriteNumber
WriteNumber
WriteNumber
WriteNumber method
WriteNumberFormat
WriteNumberFormat
WriteNumberFormat
WriteNumberFormat
WriteNumberFormat method
WriteRowHeight
WriteRowInfo
WriteRPNFormula
WriteRPNFormula
WriteRPNFormula method
WriteText
WriteText
WriteText method
WriteTextAsHTML
WriteTextAsHTML
WriteTextAsHTML method
WriteTextRotation
WriteTextRotation
WriteTextRotation method
WriteUsedFormatting
WriteUsedFormatting
WriteUsedFormatting method
WriteUTF8Text
WriteUTF8Text
WriteUTF8Text method
WriteVertAlignment
WriteVertAlignment
WriteVertAlignment method
WriteWordwrap
WriteWordwrap
WriteWordwrap method
TsWorksheet.ActiveCellCol
TsWorksheet.ActiveCellRow
TsWorksheet.AddCell
TsWorksheet.BiDiMode
TsWorksheet.BuildRPNFormula
TsWorksheet.CalcAutoRowHeight
TsWorksheet.CalcFormula
TsWorksheet.CalcFormulas
TsWorksheet.CalcImageExtent
TsWorksheet.CellInRange
TsWorksheet.CellPosToText
TsWorksheet.Cells
TsWorksheet.CellUsedInFormula
TsWorksheet.ChangedCell
TsWorksheet.ChangedFont
TsWorksheet.ClearSelection
TsWorksheet.Cols
TsWorksheet.Comments
TsWorksheet.ConvertFormulaDialect
TsWorksheet.ConvertRPNFormulaToStringFormula
TsWorksheet.CopyCell
TsWorksheet.CopyFormat
TsWorksheet.CopyFormula
TsWorksheet.CopyValue
TsWorksheet.Create
TsWorksheet.DefaultColWidth
TsWorksheet.DefaultRowHeight
TsWorksheet.DeleteCell
TsWorksheet.DeleteCol
TsWorksheet.DeleteRichTextParams
TsWorksheet.DeleteRow
TsWorksheet.DeleteSelection
TsWorksheet.Destroy
TsWorksheet.DoCompareCells
TsWorksheet.DoExchangeColRow
TsWorksheet.DoInternalCompareCells
TsWorksheet.EraseCell
TsWorksheet.ExchangeCells
TsWorksheet.FindCell
TsWorksheet.FindCol
TsWorksheet.FindComment
TsWorksheet.FindHyperlink
TsWorksheet.FindMergeBase
TsWorksheet.FindMergedRange
TsWorksheet.FindNextCellInCol
TsWorksheet.FindNextCellInRow
TsWorksheet.FindPrevCellInCol
TsWorksheet.FindPrevCellInRow
TsWorksheet.FindRow
TsWorksheet.FormatSettings
TsWorksheet.GetCalcState
TsWorksheet.GetCell
TsWorksheet.GetCellCount
TsWorksheet.GetCellCountInCol
TsWorksheet.GetCellCountInRow
TsWorksheet.GetCol
TsWorksheet.GetColWidth
TsWorksheet.GetDisplayedDecimals
TsWorksheet.GetFirstColIndex
TsWorksheet.GetFirstRowIndex
TsWorksheet.GetImage
TsWorksheet.GetImageCount
TsWorksheet.GetLastColIndex
TsWorksheet.GetLastColNumber
TsWorksheet.GetLastOccupiedColIndex
TsWorksheet.GetLastOccupiedRowIndex
TsWorksheet.GetLastRowIndex
TsWorksheet.GetLastRowNumber
TsWorksheet.GetNumberFormatAttributes
TsWorksheet.GetRow
TsWorksheet.GetRowHeight
TsWorksheet.GetSelection
TsWorksheet.GetSelectionAsString
TsWorksheet.GetSelectionCount
TsWorksheet.GetSelectionRangeIndexOfActiveCell
TsWorksheet.HasComment
TsWorksheet.HasHyperlink
TsWorksheet.Hyperlinks
TsWorksheet.InSameMergedRange
TsWorksheet.InsertCol
TsWorksheet.InsertRow
TsWorksheet.IsMergeBase
TsWorksheet.IsMerged
TsWorksheet.LeftPaneWidth
TsWorksheet.MergeCells
TsWorksheet.MergedCells
TsWorksheet.Name
TsWorksheet.OnChangeCell
TsWorksheet.OnChangeFont
TsWorksheet.OnCompareCells
TsWorksheet.OnSelectCell
TsWorksheet.Options
TsWorksheet.PageLayout
TsWorksheet.ReadAsDateTime
TsWorksheet.ReadAsNumber
TsWorksheet.ReadAsText
TsWorksheet.ReadAsUTF8Text
TsWorksheet.ReadBackground
TsWorksheet.ReadBackgroundColor
TsWorksheet.ReadBiDiMode
TsWorksheet.ReadCellBorders
TsWorksheet.ReadCellBorderStyle
TsWorksheet.ReadCellBorderStyles
TsWorksheet.ReadCellFont
TsWorksheet.ReadCellFontIndex
TsWorksheet.ReadCellFormat
TsWorksheet.ReadComment
TsWorksheet.ReadFormulaAsString
TsWorksheet.ReadHorAlignment
TsWorksheet.ReadHyperlink
TsWorksheet.ReadNumericValue
TsWorksheet.ReadNumFormat
TsWorksheet.ReadTextRotation
TsWorksheet.ReadUsedFormatting
TsWorksheet.ReadVertAlignment
TsWorksheet.ReadWordwrap
TsWorksheet.RemoveAllCols
TsWorksheet.RemoveAllImages
TsWorksheet.RemoveAllRows
TsWorksheet.RemoveAndFreeCell
TsWorksheet.RemoveCell
TsWorksheet.RemoveCol
TsWorksheet.RemoveComment
TsWorksheet.RemoveHyperlink
TsWorksheet.RemoveImage
TsWorksheet.RemoveRow
TsWorksheet.Rows
TsWorksheet.SelectCell
TsWorksheet.SetCalcState
TsWorksheet.SetSelection
TsWorksheet.Sort
TsWorksheet.TopPaneHeight
TsWorksheet.UnmergeCells
TsWorksheet.UpdateCaches
TsWorksheet.ValidHyperlink
TsWorksheet.Workbook
TsWorksheet.WriteBackground
TsWorksheet.WriteBackgroundColor
TsWorksheet.WriteBiDiMode
TsWorksheet.WriteBlank
TsWorksheet.WriteBoolValue
TsWorksheet.WriteBorderColor
TsWorksheet.WriteBorderLineStyle
TsWorksheet.WriteBorders
TsWorksheet.WriteBorderStyle
TsWorksheet.WriteBorderStyles
TsWorksheet.WriteCellFormat
TsWorksheet.WriteCellValueAsString
TsWorksheet.WriteColInfo
TsWorksheet.WriteColWidth
TsWorksheet.WriteComment
TsWorksheet.WriteCurrency
TsWorksheet.WriteDateTime
TsWorksheet.WriteDateTimeFormat
TsWorksheet.WriteDecimals
TsWorksheet.WriteErrorValue
TsWorksheet.WriteFont
TsWorksheet.WriteFontColor
TsWorksheet.WriteFontName
TsWorksheet.WriteFontSize
TsWorksheet.WriteFontStyle
TsWorksheet.WriteFormula
TsWorksheet.WriteFractionFormat
TsWorksheet.WriteHorAlignment
TsWorksheet.WriteHyperlink
TsWorksheet.WriteImage
TsWorksheet.WriteNumber
TsWorksheet.WriteNumberFormat
TsWorksheet.WriteRowHeight
TsWorksheet.WriteRowInfo
TsWorksheet.WriteRPNFormula
TsWorksheet.WriteText
TsWorksheet.WriteTextAsHTML
TsWorksheet.WriteTextRotation
TsWorksheet.WriteUsedFormatting
TsWorksheet.WriteUTF8Text
TsWorksheet.WriteVertAlignment
TsWorksheet.WriteWordwrap
TsWorksheetEvent
TsWorksheetEvent type
TsWorksheetGrid
TsWorksheetGrid class
about TsWorksheetGrid class
Align
AlternateColor
Anchors
AutoAdvance
AutoCalc
AutoEdit
AutoExpand
AutoFillColumns
BorderSpacing
BorderStyle
CellHintPriority
ColCount
Color
Constraints
DefaultColWidth
DefaultDrawing
DefaultRowHeight
DisplayFixedColRow
DragCursor
DragKind
DragMode
Enabled
ExtendedSelect
FixedColor
Flat
Font
FrozenCols
FrozenRows
GridLineWidth
HeaderHotZones
HeaderPushZones
MouseWheelOption
OnBeforeSelection
OnChangeBounds
OnClick
OnClickHyperlink
OnColRowDeleted
OnColRowExchanged
OnColRowInserted
OnColRowMoved
OnContextPopup
OnDblClick
OnDragDrop
OnDragOver
OnDrawCell
OnEditButtonClick
OnEditingDone
OnEndDock
OnEndDrag
OnEnter
OnExit
OnGetEditMask
OnGetEditText
OnHeaderClick
OnHeaderSized
OnHeaderSizing
OnKeyDown
OnKeyPress
OnKeyUp
OnMouseDown
OnMouseMove
OnMouseUp
OnMouseWheel
OnMouseWheelDown
OnMouseWheelUp
OnPickListSelect
OnPrepareCanvas
OnResize
OnSelectCell
OnSelectEditor
OnSelection
OnSetEditText
OnShowHint
OnStartDock
OnStartDrag
OnTopLeftChanged
OnUTF8KeyPress
OnValidateEntry
Options
ParentBiDiMode
ParentColor
ParentFont
ParentShowHint
PopupMenu
ReadFormulas
RowCount
ScrollBars
SelectionPen
ShowGridLines
ShowHeaders
ShowHint
TabOrder
TabStop
TextOverflow
TitleFont
TitleImageList
TitleStyle
TsWorksheetGrid events
TsWorksheetGrid members
TsWorksheetGrid properties
UseXORFeatures
Visible
VisibleColCount
VisibleRowCount
WorkbookSource
TsWorksheetGrid.Align
TsWorksheetGrid.AlternateColor
TsWorksheetGrid.Anchors
TsWorksheetGrid.AutoAdvance
TsWorksheetGrid.AutoCalc
TsWorksheetGrid.AutoEdit
TsWorksheetGrid.AutoExpand
TsWorksheetGrid.AutoFillColumns
TsWorksheetGrid.BorderSpacing
TsWorksheetGrid.BorderStyle
TsWorksheetGrid.CellHintPriority
TsWorksheetGrid.ColCount
TsWorksheetGrid.Color
TsWorksheetGrid.Constraints
TsWorksheetGrid.DefaultColWidth
TsWorksheetGrid.DefaultDrawing
TsWorksheetGrid.DefaultRowHeight
TsWorksheetGrid.DisplayFixedColRow
TsWorksheetGrid.DragCursor
TsWorksheetGrid.DragKind
TsWorksheetGrid.DragMode
TsWorksheetGrid.Enabled
TsWorksheetGrid.ExtendedSelect
TsWorksheetGrid.FixedColor
TsWorksheetGrid.Flat
TsWorksheetGrid.Font
TsWorksheetGrid.FrozenCols
TsWorksheetGrid.FrozenRows
TsWorksheetGrid.GridLineWidth
TsWorksheetGrid.HeaderHotZones
TsWorksheetGrid.HeaderPushZones
TsWorksheetGrid.MouseWheelOption
TsWorksheetGrid.OnBeforeSelection
TsWorksheetGrid.OnChangeBounds
TsWorksheetGrid.OnClick
TsWorksheetGrid.OnClickHyperlink
TsWorksheetGrid.OnColRowDeleted
TsWorksheetGrid.OnColRowExchanged
TsWorksheetGrid.OnColRowInserted
TsWorksheetGrid.OnColRowMoved
TsWorksheetGrid.OnContextPopup
TsWorksheetGrid.OnDblClick
TsWorksheetGrid.OnDragDrop
TsWorksheetGrid.OnDragOver
TsWorksheetGrid.OnDrawCell
TsWorksheetGrid.OnEditButtonClick
TsWorksheetGrid.OnEditingDone
TsWorksheetGrid.OnEndDock
TsWorksheetGrid.OnEndDrag
TsWorksheetGrid.OnEnter
TsWorksheetGrid.OnExit
TsWorksheetGrid.OnGetEditMask
TsWorksheetGrid.OnGetEditText
TsWorksheetGrid.OnHeaderClick
TsWorksheetGrid.OnHeaderSized
TsWorksheetGrid.OnHeaderSizing
TsWorksheetGrid.OnKeyDown
TsWorksheetGrid.OnKeyPress
TsWorksheetGrid.OnKeyUp
TsWorksheetGrid.OnMouseDown
TsWorksheetGrid.OnMouseMove
TsWorksheetGrid.OnMouseUp
TsWorksheetGrid.OnMouseWheel
TsWorksheetGrid.OnMouseWheelDown
TsWorksheetGrid.OnMouseWheelUp
TsWorksheetGrid.OnPickListSelect
TsWorksheetGrid.OnPrepareCanvas
TsWorksheetGrid.OnResize
TsWorksheetGrid.OnSelectCell
TsWorksheetGrid.OnSelectEditor
TsWorksheetGrid.OnSelection
TsWorksheetGrid.OnSetEditText
TsWorksheetGrid.OnShowHint
TsWorksheetGrid.OnStartDock
TsWorksheetGrid.OnStartDrag
TsWorksheetGrid.OnTopLeftChanged
TsWorksheetGrid.OnUTF8KeyPress
TsWorksheetGrid.OnValidateEntry
TsWorksheetGrid.Options
TsWorksheetGrid.ParentBiDiMode
TsWorksheetGrid.ParentColor
TsWorksheetGrid.ParentFont
TsWorksheetGrid.ParentShowHint
TsWorksheetGrid.PopupMenu
TsWorksheetGrid.ReadFormulas
TsWorksheetGrid.RowCount
TsWorksheetGrid.ScrollBars
TsWorksheetGrid.SelectionPen
TsWorksheetGrid.ShowGridLines
TsWorksheetGrid.ShowHeaders
TsWorksheetGrid.ShowHint
TsWorksheetGrid.TabOrder
TsWorksheetGrid.TabStop
TsWorksheetGrid.TextOverflow
TsWorksheetGrid.TitleFont
TsWorksheetGrid.TitleImageList
TsWorksheetGrid.TitleStyle
TsWorksheetGrid.UseXORFeatures
TsWorksheetGrid.Visible
TsWorksheetGrid.VisibleColCount
TsWorksheetGrid.VisibleRowCount
TsWorksheetGrid.WorkbookSource
TwipsToPts
TwipsToPts function
Types
U
UnquoteStr
UnquoteStr function
Unused
Unused function
UTF8FormatSettings
UTF8FormatSettings variable
V
Variables
W
WideStringLEToN
WideStringLEToN function
WideStringToLE
WideStringToLE function
WordLEtoN
WordLEtoN function
WordToLE
WordToLE function


Welcome