TZlibFilesList

[Properties (by Name)] [Methods (by Name)] [Events (by Name)]

Used to store the list of files to be compressed

Declaration

Source position: zlibar.pas line 42

type TZlibFilesList = class(TObject)
public
constructor Create;
destructor Destroy; override; |
function Add(); | Add a File to be compressed
function AddPath(); | Adds a FileName and a relative path
function Insert(); | Used to insert a file to be compressed into the list at a specific index
function InsertPath(); |
procedure Delete(); | Deletes the filename at index from the list
procedure Clear; | Removes all files from the list of files to be compressed
function Count; | Number of files in the list to be compressed
property FileName: ; [rw] | Used to retrieve the fully qualified filename that is to be compressed
property Path: ; [rw] | Used to retrieve the releative path the file should be extracted to
property FileInfo: TFileInfo; [rw] | Used internally to obtain the compressed size of the file
end;

Inheritance

TZlibFilesList

Used to store the list of files to be compressed
|

TObject


TZLibReadArchive

[Properties (by Name)] [Methods (by Name)] [Events (by Name)]

Object to read and extract files made with TZLibWriteArchive

Declaration

Source position: zlibar.pas line 138

type TZLibReadArchive = class(TObject)
procedure Create(); | Creates an instance of the object
public
destructor Destroy; override; |
public
procedure ExtractFileToStream(); | Extract the file at Index to a user provided stream
public
property Header: TZlibArchiveHeader; [r] | Retrieves the header of the file
property FilesInArchive: TTOCEntry; [r] | Contains information about the file in the archive
property Count: Integer; [r] | Number of files in the archive
property OnError: TZlibErrorProc; [rw] | Callback to intercept errors before they trigger an Exception
property OnExtract: TZlibExtractProgProc; [rw] | Callback used to monitor the progress of a file as it is being extracted
published
property InStream: TStream; [rw] | TStream that is currently loaded
end;

Inheritance

TZLibReadArchive

Object to read and extract files made with TZLibWriteArchive
|

TObject

Description

A TZlibReadArchive object is not capable of writing or changing an archive. You must use a TZLibWriteArchive object to do that.

See also

TZlibWriteArchive

Object used to create ZibArchive files.


TZlibWriteArchive

[Properties (by Name)] [Methods (by Name)] [Events (by Name)]

Object used to create ZibArchive files.

Declaration

Source position: zlibar.pas line 111

type TZlibWriteArchive = class(TObject)
public
constructor Create; | Creates an instance of the TZlibWriteArchive object
destructor Destroy; override; |
function CreateArchive; | Compresses and write all the files in the list to OutStream
property OnError: TZlibErrorProc; [rw] | Callback used to intercept errors before an exception is raised
property OnCompress: TZlibCompressProgProc; [rw] | Callback used to imform the user of the compression progress
published
property OutStream: TStream; [rw] | Stream the compressed archive it written to
property InputFiles: TZlibFilesList; [r] | List of files to be compressed
end;

Inheritance

TZlibWriteArchive

Object used to create ZibArchive files.
|

TObject


CompressStream

Compresses InStream into OutStream

Declaration

Source position: zlibar.pas line 184

function CompressStream(

  InStream: TStream;

  OutStream: TStream

):Integer;

Arguments

InStream | The TStream that you wish to be compressed
OutStream | The compressed stream

Function result

The size of the compressed stream in bytes

Description

Generic independant function to compress InStream into OutStream.

See also

ExtractStream

Decompresses InStream to OutStream


ExtractStream

Decompresses InStream to OutStream

Declaration

Source position: zlibar.pas line 185

function ExtractStream(

  InStream: TStream;

  OutStream: TStream

):Integer;

Arguments

InStream | The Stream that you wish to compress
OutStream | The stream that the decompressed data will be written into

Function result

The Size of OutStream in bytes

Description

Decompresses InStream to OutStream.


StreamMD5

Creates a TMD5Digest from a TMemoryStream

Declaration

Source position: zlibar.pas line 186

function StreamMD5(

  Stream: TStream

):TMD5Digest;

Arguments

Stream

The stream you wish to be scanned

Function result

Returns a TMd5Digest

Description

Use this to create a TMD5Digest from a Stream. This is used to ensure that a file matches in every way by comparing it to a previous TMD5Digest.


Reference for package 'zlibar'

Units

zlibar


Index of all identifiers in package 'zlibar'

C E P S T Z

C

CompressStream

E

ERR_CHECKSUM_FAILED | ERR_CORRUPT_TOC | ERR_UNKOWN_ERROR
ERR_CORRUPT_FILE | ERR_FILENAME_NOT_FOUND | ExtractStream

P

PFileInfo PTOCEntry

S

StreamMD5

T

TFileInfo | TZlibCompressProgProc | TZlibFilesList
TTOCEntry | TZlibErrorProc | TZLibReadArchive
TZlibArchiveHeader | TZlibExtractProgProc | TZlibWriteArchive

Z

ZAR_MAJOR_VERSION | ZAR_MINOR_VERSION | ZLibFileType
ZAR_MICRO_VERSION | zlibar |


ERR_CHECKSUM_FAILED

Error Code

Declaration

Source position: zlibar.pas line 180

const ERR_CHECKSUM_FAILED = 3;

Description

The file you are trying to compress does not match the checksum of the original file before it was compressed.


ERR_CORRUPT_FILE

Error Code

Declaration

Source position: zlibar.pas line 179

const ERR_CORRUPT_FILE = 2;

Description

The file you are trying to open does not have the correct header, or is not a recognized file format.


ERR_CORRUPT_TOC

Error Code

Declaration

Source position: zlibar.pas line 178

const ERR_CORRUPT_TOC = 1;

Description

The table of contents has been corrupted. A MD5 checksum is made before the TOC is compressed. If the checksum of the extracted TOC does not match this error occurs.


[Overview][Constants][Types][Classes][Procedures and functions][Index] Reference for unit 'zlibar' (#zlibar)

ERR_FILENAME_NOT_FOUND

Declaration

Source position: zlibar.pas line 181

const ERR_FILENAME_NOT_FOUND = 4;


[Overview][Constants][Types][Classes][Procedures and functions][Index] Reference for unit 'zlibar' (#zlibar)

ERR_UNKOWN_ERROR

Declaration

Source position: zlibar.pas line 182

const ERR_UNKOWN_ERROR = 6;


[Overview][Constants][Types][Classes][Procedures and functions][Index] Reference for unit 'zlibar' (#zlibar)

Reference for unit 'zlibar'

uses

  System,

  Classes,

  sysutils,

  paszlib,

  md5;


Reference for unit 'zlibar': Constants

ERR_CHECKSUM_FAILED | Error Code
ERR_CORRUPT_FILE | Error Code
ERR_CORRUPT_TOC | Error Code
ERR_FILENAME_NOT_FOUND
ERR_UNKOWN_ERROR |
ZAR_MAJOR_VERSION |
ZAR_MICRO_VERSION |
ZAR_MINOR_VERSION |
ZLibFileType |


Reference for unit 'zlibar': Types

PFileInfo |
PTOCEntry |
TFileInfo | Used internally
TTOCEntry | The structure of a table of contents entry
TZlibArchiveHeader | The information at the beggining of a TZlibArchive
TZlibCompressProgProc | Callback used to follow the progress of overall and current progress
TZlibErrorProc | Error Callback
TZlibExtractProgProc | Callback for progress during decompression


Reference for unit 'zlibar': Classes

TZlibFilesList | Used to store the list of files to be compressed
TZLibReadArchive | Object to read and extract files made with TZLibWriteArchive
TZlibWriteArchive | Object used to create ZibArchive files.


Reference for unit 'zlibar': Procedures and functions

CompressStream | Compresses InStream into OutStream
ExtractStream | Decompresses InStream to OutStream
StreamMD5 | Creates a TMD5Digest from a TMemoryStream


Index of all identifiers in unit 'zlibar'

C E P S T Z

C

CompressStream

E

ERR_CHECKSUM_FAILED | ERR_CORRUPT_TOC | ERR_UNKOWN_ERROR
ERR_CORRUPT_FILE | ERR_FILENAME_NOT_FOUND | ExtractStream

P

PFileInfo PTOCEntry

S

StreamMD5

T

TFileInfo | TZlibCompressProgProc | TZlibFilesList
TTOCEntry | TZlibErrorProc | TZLibReadArchive
TZlibArchiveHeader | TZlibExtractProgProc | TZlibWriteArchive

Z

ZAR_MAJOR_VERSION | ZAR_MINOR_VERSION
ZAR_MICRO_VERSION | ZLibFileType


[Overview][Constants][Types][Classes][Procedures and functions][Index] Reference for unit 'zlibar' (#zlibar)

PFileInfo

Declaration

Source position: zlibar.pas line 35

type PFileInfo = ^TFileInfo;


[Overview][Constants][Types][Classes][Procedures and functions][Index] Reference for unit 'zlibar' (#zlibar)

PTOCEntry

Declaration

Source position: zlibar.pas line 81

type PTOCEntry = ^TTOCEntry;


TFileInfo

Used internally

Declaration

Source position: zlibar.pas line 36

type TFileInfo = record
CompressedSize: Int64; | The compressed size of a stream
Md5Sum: TMD5Digest; | The TMD5Digest of the original uncompressed stream.
end;

Description

This holds temporarily the compressed size if a stream and it's MD5 checksum.


TTOCEntry

The structure of a table of contents entry

Declaration

Source position: zlibar.pas line 82

type TTOCEntry = packed record
FileName: ; | The file name only
FilePath: ; | The desired relative path for the file to be extracted to.
Position: Int64; | The position of the compressed stream in the TZLibArchive stream.
CompressedSize: Int64; | The size of a compressed file
Md5sum: TMD5Digest; | The checksum used to verify the file is the same as the original
end;

Description

Used to manage various information about the size and position of a file in the TZlibArchive


TZlibArchiveHeader

The information at the beggining of a TZlibArchive

Declaration

Source position: zlibar.pas line 72

type TZlibArchiveHeader = packed record
FileType: array [0..3] of Char; | The file identifier
MajorVersion: LongInt; |
MinorVersion: LongInt; |
MicroVersion: LongInt; |
TOCLength: Int64; | Length of the table of contents.
TOCMD5Sum: TMD5Digest; | Checksum of the uncompressed TOC
end;

Description

Contains vital information about the archive. Major Minor and Micro hold the version of the archive.


TZlibCompressProgProc

Callback used to follow the progress of overall and current progress

Declaration

Source position: zlibar.pas line 101

type TZlibCompressProgProc = procedure(

  Sender: TObject;

  FileIndex: Integer;

  FileSize: Int64;

  FilePos: Int64

) of object;

Arguments

Sender | TZlibWriteArchive Object
FileIndex | Index of the current file that is being compressed.
FileSize | Total size of the InStream to be compressed
FilePos | Amount of the InStream that has been compressed.

Description

Used to provide feedback to the user of the progress of compression.


TZlibErrorProc

Error Callback

Declaration

Source position: zlibar.pas line 105

type TZlibErrorProc = procedure(

  Sender: TObject;

  var ErrorCode: Integer;

  ErrorStr:

) of object;

Arguments

Sender | TZlibReadArchive or TZlibWriteArchive object
ErrorCode | Error code that has occured
ErrorStr | Description of the error.

Description

Used to catch error before an exception is raised.


TZlibExtractProgProc

Callback for progress during decompression

Declaration

Source position: zlibar.pas line 103

type TZlibExtractProgProc = procedure(

  Sender: TObject;

  FileSize: Int64;

  FilePos: Int64

) of object;

Arguments

Sender | TZlibReadArchive object
FileSize | Total size of the InStream
FilePos | Current position of the InStream


TZlibFilesList
 | FileName
 | Path
 | FileInfo
TObject


FileInfo (TZlibFilesList)

FileName (TZlibFilesList)

Path (TZlibFilesList)


TZlibFilesList
 | Create
 | Destroy
 | Add
 | AddPath
 | Insert
 | InsertPath
 | Delete
 | Clear
 | Count
TObject
 | Create
 | Destroy
 | newinstance
 | FreeInstance
 | SafeCallException
 | DefaultHandler
 | Free
 | InitInstance
 | CleanupInstance
 | ClassType
 | ClassInfo
 | ClassName
 | ClassNameIs
 | ClassParent
 | InstanceSize
 | InheritsFrom
 | StringMessageTable
 | Dispatch
 | DispatchStr
 | MethodAddress
 | MethodName
 | FieldAddress
 | AfterConstruction
 | BeforeDestruction
 | DefaultHandlerStr
 | GetInterface
 | GetInterfaceByStr
 | GetInterfaceEntry
 | GetInterfaceEntryByStr
 | GetInterfaceTable


Add (TZlibFilesList)

AddPath (TZlibFilesList)

AfterConstruction (TObject)

BeforeDestruction (TObject)

ClassInfo (TObject)

ClassName (TObject)

ClassNameIs (TObject)

ClassParent (TObject)

ClassType (TObject)

CleanupInstance (TObject)

Clear (TZlibFilesList)

Count (TZlibFilesList)

Create (TObject)

Create (TZlibFilesList)

DefaultHandler (TObject)

DefaultHandlerStr (TObject)

Delete (TZlibFilesList)

Destroy (TObject)

Destroy (TZlibFilesList)

Dispatch (TObject)

DispatchStr (TObject)

FieldAddress (TObject)

Free (TObject)

FreeInstance (TObject)

GetInterface (TObject)

GetInterfaceByStr (TObject)

GetInterfaceEntry (TObject)

GetInterfaceEntryByStr (TObject)

GetInterfaceTable (TObject)

InheritsFrom (TObject)

InitInstance (TObject)

Insert (TZlibFilesList)

InsertPath (TZlibFilesList)

InstanceSize (TObject)

MethodAddress (TObject)

MethodName (TObject)

newinstance (TObject)

SafeCallException (TObject)

StringMessageTable (TObject)


TZlibFilesList

TObject


TZlibFilesList.Add

Add a File to be compressed

Declaration

Source position: zlibar.pas line 57

public function TZlibFilesList.Add(

  AFileName:

):Integer;

Arguments

AFileName

Fully qualified FileName to be added

Function result

The index of the filename in the list

Description

Should be a fully qualified filename. Stored in the archive as just the filename without paths. To set a releative path for the file use AddPath.

See also

TZlibFilesList.AddPath | Adds a FileName and a relative path
TZlibFilesList.Insert | Used to insert a file to be compressed into the list at a specific index


TZlibFilesList.AddPath

Adds a FileName and a relative path

Declaration

Source position: zlibar.pas line 58

public function TZlibFilesList.AddPath(

  AFileName: ;

  APath:

):Integer;

Arguments

AFileName | Fully qualified filename to be compressed
APath | Relative path to be decompressed to

Function result

Index of added file name in the list

See also

TZlibFilesList.Add

Add a File to be compressed


TZlibFilesList.Clear

Removes all files from the list of files to be compressed

Declaration

Source position: zlibar.pas line 62

public procedure TZlibFilesList.Clear;


TZlibFilesList.Count

Number of files in the list to be compressed

Declaration

Source position: zlibar.pas line 63

public function TZlibFilesList.Count: Integer;

Function result

The number of files in the list

Description

Zero based so to do a loop using Count you must do Count-1


[Overview][Constants][Types][Classes][Procedures and functions][Index] Reference for unit 'zlibar' (#zlibar)

TZlibFilesList.Create

Declaration

Source position: zlibar.pas line 54

public constructor TZlibFilesList.Create;


TZlibFilesList.Delete

Deletes the filename at index from the list

Declaration

Source position: zlibar.pas line 61

public procedure TZlibFilesList.Delete(

  AIndex: Integer

);

Arguments

AIndex

Index of the filename to be removed


TZlibFilesList.Destroy

Declaration

Source position: zlibar.pas line 55

public destructor TZlibFilesList.Destroy; override;


TZlibFilesList.FileInfo

Used internally to obtain the compressed size of the file

Declaration

Source position: zlibar.pas line 70

public property TZlibFilesList.FileInfo: TFileInfo
  read GetFileInfo
  write SetFileInfo;

Description

Only usefull after the file has been compressed

See also

TFileInfo

Used internally


TZlibFilesList.FileName

Used to retrieve the fully qualified filename that is to be compressed

Declaration

Source position: zlibar.pas line 66

public property TZlibFilesList.FileName:
  read GetFileName
  write SetFileName;


TZlibFilesList.Insert

Used to insert a file to be compressed into the list at a specific index

Declaration

Source position: zlibar.pas line 59

public function TZlibFilesList.Insert(

  AIndex: Integer;

  AFileName:

):Integer;

See also

TZlibFilesList.Add

Add a File to be compressed


TZlibFilesList.InsertPath

Declaration

Source position: zlibar.pas line 60

public function TZlibFilesList.InsertPath(

  AIndex: Integer;

  AFileName: ;

  APath:

):Integer;


TZlibFilesList.Path

Used to retrieve the releative path the file should be extracted to

Declaration

Source position: zlibar.pas line 68

public property TZlibFilesList.Path:
  read GetPath
  write SetPath;


TZLibReadArchive
 | ro | Header
 | ro | FilesInArchive
 | ro | Count
pl |  | InStream
TObject


 | ro | Count (TZLibReadArchive)
 | ro | FilesInArchive (TZLibReadArchive)
 | ro | Header (TZLibReadArchive)
pl |  |


TZLibReadArchive
 | Create
 | Destroy
 | ExtractFileToStream
TObject
 | Create
 | Destroy
 | newinstance
 | FreeInstance
 | SafeCallException
 | DefaultHandler
 | Free
 | InitInstance
 | CleanupInstance
 | ClassType
 | ClassInfo
 | ClassName
 | ClassNameIs
 | ClassParent
 | InstanceSize
 | InheritsFrom
 | StringMessageTable
 | Dispatch
 | DispatchStr
 | MethodAddress
 | MethodName
 | FieldAddress
 | AfterConstruction
 | BeforeDestruction
 | DefaultHandlerStr
 | GetInterface
 | GetInterfaceByStr
 | GetInterfaceEntry
 | GetInterfaceEntryByStr
 | GetInterfaceTable


AfterConstruction (TObject)

BeforeDestruction (TObject)

ClassInfo (TObject)

ClassName (TObject)

ClassNameIs (TObject)

ClassParent (TObject)

ClassType (TObject)

CleanupInstance (TObject)

Create (TObject)

Create (TZLibReadArchive)

DefaultHandler (TObject)

DefaultHandlerStr (TObject)

Destroy (TObject)

Destroy (TZLibReadArchive)

Dispatch (TObject)

DispatchStr (TObject)

ExtractFileToStream (TZLibReadArchive)

FieldAddress (TObject)

Free (TObject)

FreeInstance (TObject)

GetInterface (TObject)

GetInterfaceByStr (TObject)

GetInterfaceEntry (TObject)

GetInterfaceEntryByStr (TObject)

GetInterfaceTable (TObject)

InheritsFrom (TObject)

InitInstance (TObject)

InstanceSize (TObject)

MethodAddress (TObject)

MethodName (TObject)

newinstance (TObject)

SafeCallException (TObject)

StringMessageTable (TObject)


TZLibReadArchive
 | OnError
 | OnExtract
TObject


OnError (TZLibReadArchive)

OnExtract (TZLibReadArchive)


TZLibReadArchive.Count

Number of files in the archive

Declaration

Source position: zlibar.pas line 165

public property TZLibReadArchive.Count: Integer
  read GetCount;


TZLibReadArchive.Create

Creates an instance of the object

Declaration

Source position: line 0

constructor TZLibReadArchive.Create;

constructor TZLibReadArchive.Create(

  InStream: TStream

);

Arguments

InStream

Stream that you wish to be opened


TZLibReadArchive.Destroy

Declaration

Source position: zlibar.pas line 158

public destructor TZLibReadArchive.Destroy; override;


TZLibReadArchive.ExtractFileToStream

Extract the file at Index to a user provided stream

Declaration

Source position: line 0

procedure TZLibReadArchive.ExtractFileToStream(

  AIndex: Integer;

  Stream: TStream

);

procedure TZLibReadArchive.ExtractFileToStream(

  const AFileName: ;

  Stream: TStream

);

procedure TZLibReadArchive.ExtractFileToStream(

  const AFileName: ;

  const APath: ;

  Stream: TStream

);

Arguments

AIndex | Index of the file to be extracted
Stream | User provided stream for the compressed file to be decompressed into

Arguments

Stream

User provided stream for the compressed file to be decompressed into

Arguments

Stream

User provided stream for the compressed file to be decompressed into


TZLibReadArchive.FilesInArchive

Contains information about the file in the archive

Declaration

Source position: zlibar.pas line 164

public property TZLibReadArchive.FilesInArchive: TTOCEntry
  read GetTOCEntry;

See also

TTOCEntry

The structure of a table of contents entry


TZLibReadArchive.Header

Retrieves the header of the file

Declaration

Source position: zlibar.pas line 163

public property TZLibReadArchive.Header: TZlibArchiveHeader
  read fHeader;


TZLibReadArchive.InStream

TStream that is currently loaded

Declaration

Source position: zlibar.pas line 169

published property TZLibReadArchive.InStream: TStream
  read fStream
  write SetStream;

Description

Set to nil to close the file


TZLibReadArchive.OnError

Callback to intercept errors before they trigger an Exception

Declaration

Source position: zlibar.pas line 166

public property TZLibReadArchive.OnError: TZlibErrorProc
  read fOnError
  write fOnError;

See also

TZlibErrorProc

Error Callback


TZLibReadArchive.OnExtract

Callback used to monitor the progress of a file as it is being extracted

Declaration

Source position: zlibar.pas line 167

public property TZLibReadArchive.OnExtract: TZlibExtractProgProc
  read fOnExtract
  write fOnExtract;

See also

TZlibExtractProgProc

Callback for progress during decompression


TZlibWriteArchive
pl |  | OutStream
pl | ro | InputFiles
TObject


pl | ro | InputFiles (TZlibWriteArchive)
pl |  |


TZlibWriteArchive
 | Create
 | Destroy
 | CreateArchive
TObject
 | Create
 | Destroy
 | newinstance
 | FreeInstance
 | SafeCallException
 | DefaultHandler
 | Free
 | InitInstance
 | CleanupInstance
 | ClassType
 | ClassInfo
 | ClassName
 | ClassNameIs
 | ClassParent
 | InstanceSize
 | InheritsFrom
 | StringMessageTable
 | Dispatch
 | DispatchStr
 | MethodAddress
 | MethodName
 | FieldAddress
 | AfterConstruction
 | BeforeDestruction
 | DefaultHandlerStr
 | GetInterface
 | GetInterfaceByStr
 | GetInterfaceEntry
 | GetInterfaceEntryByStr
 | GetInterfaceTable


AfterConstruction (TObject)

BeforeDestruction (TObject)

ClassInfo (TObject)

ClassName (TObject)

ClassNameIs (TObject)

ClassParent (TObject)

ClassType (TObject)

CleanupInstance (TObject)

Create (TObject)

Create (TZlibWriteArchive)

CreateArchive (TZlibWriteArchive)

DefaultHandler (TObject)

DefaultHandlerStr (TObject)

Destroy (TObject)

Destroy (TZlibWriteArchive)

Dispatch (TObject)

DispatchStr (TObject)

FieldAddress (TObject)

Free (TObject)

FreeInstance (TObject)

GetInterface (TObject)

GetInterfaceByStr (TObject)

GetInterfaceEntry (TObject)

GetInterfaceEntryByStr (TObject)

GetInterfaceTable (TObject)

InheritsFrom (TObject)

InitInstance (TObject)

InstanceSize (TObject)

MethodAddress (TObject)

MethodName (TObject)

newinstance (TObject)

SafeCallException (TObject)

StringMessageTable (TObject)


TZlibWriteArchive
 | OnError
 | OnCompress
TObject


OnCompress (TZlibWriteArchive)

OnError (TZlibWriteArchive)


TZlibWriteArchive.Create

Creates an instance of the TZlibWriteArchive object

Declaration

Source position: zlibar.pas line 125

public constructor TZlibWriteArchive.Create;


TZlibWriteArchive.CreateArchive

Compresses and write all the files in the list to OutStream

Declaration

Source position: zlibar.pas line 128

public function TZlibWriteArchive.CreateArchive: Boolean;

Function result

True if successful False otherwise

Description

The Stream is written to starting from the beginning. The Previos contents of the stream are lost.


TZlibWriteArchive.Destroy

Declaration

Source position: zlibar.pas line 126

public destructor TZlibWriteArchive.Destroy; override;


TZlibWriteArchive.InputFiles

List of files to be compressed

Declaration

Source position: zlibar.pas line 133

published property TZlibWriteArchive.InputFiles: TZlibFilesList
  read fInputFiles;

See also

TZlibFilesList

Used to store the list of files to be compressed


TZlibWriteArchive.OnCompress

Callback used to imform the user of the compression progress

Declaration

Source position: zlibar.pas line 130

public property TZlibWriteArchive.OnCompress: TZlibCompressProgProc
  read fOnCompress
  write fOnCompress;

See also

TZlibCompressProgProc

Callback used to follow the progress of overall and current progress


TZlibWriteArchive.OnError

Callback used to intercept errors before an exception is raised

Declaration

Source position: zlibar.pas line 129

public property TZlibWriteArchive.OnError: TZlibErrorProc
  read fOnError
  write fOnError;


TZlibWriteArchive.OutStream

Stream the compressed archive it written to

Declaration

Source position: zlibar.pas line 132

published property TZlibWriteArchive.OutStream: TStream
  read fStream
  write SetStream;

Description

If this is not assigned a TMemoryStream is automatically created and assigned to OutStream.


[Overview][Constants][Types][Classes][Procedures and functions][Index] Reference for unit 'zlibar' (#zlibar)

ZAR_MAJOR_VERSION

Declaration

Source position: zlibar.pas line 174

const ZAR_MAJOR_VERSION: LongInt = 1;


[Overview][Constants][Types][Classes][Procedures and functions][Index] Reference for unit 'zlibar' (#zlibar)

ZAR_MICRO_VERSION

Declaration

Source position: zlibar.pas line 176

const ZAR_MICRO_VERSION: LongInt = 0;


[Overview][Constants][Types][Classes][Procedures and functions][Index] Reference for unit 'zlibar' (#zlibar)

ZAR_MINOR_VERSION

Declaration

Source position: zlibar.pas line 175

const ZAR_MINOR_VERSION: LongInt = 0;


ZLibFileType

Declaration

Source position: zlibar.pas line 172

const ZLibFileType: array [0..3] of Char = ('Z', 'A', 'R', #0);